Wilcom DecoStudio e3.0V Update
Release Notes
16 October 2014
This file contains notes on the Wilcom DecoStudio e3.0V software update. This update is intended for
installation with any released version (already installed) of Wilcom DecoStudio e3.0. It contains all
improvements and fixes contained in other interim updates from e3.0H to e3.0R.
Note: Administrative privileges are required to install the software update. If you are installing to a corporate
network, an administrator password may be required during update installation.
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New & improved features in DS e3.0V
The main scope of the e3.0V software update was to provide language support for Arabic and Russian, and to
further improve the TrueType font conversion engine. The DS e3.0V update also sees improvements in the
Lettering Kiosk with the inclusion of customizable monograms.

Language support
Support for Arabic language
Responding to requests from the marketplace, DS e3 now provides Arabic language support.

Russian language support
This release now incorporates a Russian interface for DecoStudio which can be selected during installation.
Russian language support also includes:


ES Design Explorer GUI



ES Quick Start Guide - PDF version

TrueType font conversion
Composite character conversion
There are characters which can be regarded as ‘composites’. In European fonts, these are relatively rare – e.g.
‘i’ or ‘%’. However, Asian fonts have many characters which contain multiple elements. Some of these are
inadvertently eliminated during conversion. The current TTF conversion, including Korean improvements,
implements advanced processing for composite letters.

Automatically generated stitch angles with turning fill
There is a problem of consistency between automatically generated stitch angle lines. It can be observed
mostly in long sections. Currently, users can fix this problem by adding new stitch angles to the middle of such
sections. The improved automatic feature now provides the same or similar results.

Wilcom DecoStudio e3.0V Update
Release Notes

16/10/2014

3

Improved stitch angles in ring shapes in TTF conversion
Sometimes stitch angles produced near the edge of ring-shapes make the stitched shape look more like a
closed C rather than an O. This problem has been corrected.

Clarendon BT font conversion
There have been requests to improve turning strokes in the conversion of Clarendon BT font. Particularly E, Æ,
È, É, Ê, Ë, CE. The current TrueType font conversion provides high quality results for the reported letters.

Comic Sans font conversion
ES now correctly generates the ‘umlaut’ when creating the letter ‘a’ with Comic Sans TTF.
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Arial TrueType Arabic character conversion
Some Arabic characters in Arial TTF conversion produce poor stitch angles. These have been improved.

Batang TrueType font conversion
Batang TrueType still has issues with font conversion. Some object conversion ends up outside the object
shape. This has been improved.

Korean font conversion
Korean TrueType font conversion presents a number of problems:


Some Korean TTF characters are not correctly decomposed into patches according to Korean rules.



Some letters appear as question marks so it is impossible to create a word.

The improvements made in Korean TTF conversion involve minor improvements to stitch angles and related
improvements. There may, however, remain some inconsistencies with the results produced.
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Note: The improvements have general applicability and are available for all types of fonts, not only Korean.
They are also available for all ES features that use the TTF conversion method.

Other TrueType font conversions
A number of specific fonts have been tested which have been reported to produce poor letter quality.
Conversion quality for the following fonts has been improved:


Haettenschweiler TTF



Gungsuhche TTF



Garamond TTF



Bookman Old Style TTF



Century Gothic TTF



Palatino Linotype TTF



Georgia TTF lowercase



Impact TTF uppercase



Tahoma TTF regular lowercase and bold uppercase



Trebuchet MS TTF uppercase

Stitch quality improvements
Stitch generation for Complex Fill
With comparable objects, needle penetrations generally follow Input A outlines more closely than Complex Fill
outlines. Complex Fill stitch generation has been improved with this release.

Stitch length of tatami underlay for Fusion Fill objects
The stitch length of tatami underlay for Fusion Fill objects does not always follow the stitch length setting in the
Object Properties dialog. The stitch length can become too long and cause machine stitching problems. This
problem has been corrected.

Bling improvements
Exporting bling lettering to Yongnam GemMaster format
Currently bling lettering (rhinestone alphabets) is not being correctly output to Yongnam GemMaster (*.YNG)
format. This problem has been corrected.
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Bling palette color swatch
Currently the Bling Palette color swatch does not highlight the selected bling color. It now behaves the same
way as the Background Color swatch.

Input/output improvements
TAP files for Happy machines
Problems have been reported when loading TAP files into Happy machines. This problem has now been
corrected.

Opening JEF+ file format from MB-4 machine
At present the user is unable to open JEF+ files saved on the Janome MB-4 machine. Currently the Janome
MB-4 Machine is a supported by direct connection via Connection Manager. This limitation has now been
removed.

System improvements
Updated HASP dongle driver
This release installs the latest HASP V6.64 dongle driver.
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Monogram crashes
Selecting the Lettering tool with a monogram object selected can cause the system to crash. This problem has
been corrected.

Other improvements
Copy & paste for whole designs
A problem has been reported when trying to copy and paste whole designs or parts of designs to form repeating
elements. This has been corrected.

Sequence toolbar ‘back 1 color’
The Sequence toolbar Back 1 Color function fails to work when selecting a second object in the Color-Object
List. The button is now correctly enabled when selecting the second object.
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Thread chart sorting
Problems have been reported with the sorting of threads. The Edit Thread dialog picks up the wrong thread
after sorting operations. This problem has been corrected.

Stitch orientation of Input C objects
The stitch orientation of Input C objects can be lost after saving/opening a design or copy/paste operations. The
object is scaled correctly but the stitch direction may be reversed. This problem has been corrected.

Customer names on production sheets
Currently, customer names in the production worksheet are lost when updates are installed. This problem has
been corrected.
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New & improved features in DS e3.0R
The main scope of the DS e3.0R software update is to improve motif runs as well as resolve issues relating to
file output and system behaviour.

Motif run improvements
DS e3.0R includes the following improvements to motif run functionality.

Motif Run properties after resizing
When resizing a motif run on screen in Reshape mode, changes to object properties are now correctly
reflected in the Object Properties dialog.

Motif Run properties after mirror and reshape operations
In earlier versions, mirroring a motif run and then reshaping the baseline caused motifs to flip around the
baseline.

This issue has been resolved. Motif orientation is maintained.

Selection handles & mirrored pattern previews
When a motif run object is mirrored in ES:


Selection handles do not appear at the correct position.



The pattern preview when dragging the object is incorrect – it appears mirrored.

This issue has been resolved.
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Motif run color & orientation changes
Changes in motif run color and orientation have been reported in certain designs when digitizing new objects.
This issue has been resolved.

Mirroring motif runs with reshaped patterns
When mirroring motif runs, any manual reshaping to individual patterns may be lost. This issue has been
resolved.

Motif sizing following reshape operations
Unexpected changes in motif size are known to occur when reshaping certain motif runs. This issue has been
resolved.

Language-related improvements
DS e3.0R includes the following improvements in LOTE support.

Dutch language available
The DecoStudio e3.0R Update now provides a complete translation of the interface into Dutch language. It is
also supported with a Dutch Quick Start Guide.

Design area unit (mm²) in Japanese language
There was a problem with the display of the design area unit, mm², in the Japanese interface. This issue
affected the Information tab of Design Properties dialog, Print Preview and exported design properties CSV
file. The issue has been resolved.

Auto-update dialog
The Auto-Update dialog is now translated in languages other than English.

File output improvements
DS e3.0R includes the following file output improvements.

Design shifts when saving to PES
Problems have been reported with unexpected shifts when saving certain designs to PES. Lettering, in
particular, is shifted in relation to the rest of the design. This issue has been resolved.

Needle assignment in Barudan U?? files
The DS e3.0Q update inadvertently introduced a problem with needle assignments in Barudan U?? files, as well
as other Barudan formats such as DSB, T01. Needle bar addressing is offset unexpectedly. With the e3.0Q
update, this problem has been resolved.
However, for e3.0Q designs that already experience this issue, customers need to use the following workaround. In order to stop the shifting, you must set the boring Needle Number in the Machine Format Settings
dialog from 1 to 0 in already-affected design files.
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Note: If Barudan machine format settings have been saved as a default in DS e3.0Q, the Boring Needle
number should be set to ‘0’ and updated after installing DS e3.0R. If the default boring needle number for a
particular Barudan machine format is not 0, it will continue to cause problems.
To update the default boring needle number
1. Start DS e3.0R.
2. Select File > New to open a blank design.
3. Select Design > Select Machine Format.
4. Select the affected Barudan machine format – e.g. ‘Barudan Z Series’
5. Click Settings.
6. Set the Boring Needle number to ‘0’ and click Save.
7. Click Close.
8. Repeat for any other affected machine formats.

Miscellaneous improvements
DS e3.0R includes the following system improvements.

Travel by Trim shortcut
There is a conflict with the Ctrl + Left/Right arrow shortcut for the Travel by Trim function. The problem is that
the shortcut is already being used for Travel by Segment. The Travel by Trim shortcut has now changed to
Alt + Left/Right.

Resizing & reshaping objects with carving stamps
Resizing and reshaping objects with carving stamps has been found to crash the software. This issue has been
resolved.
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New & improved features in DS e3.0Q
The main purpose of the e3.0Q software update was to repair a number of system issues. This update also
provides better Korean language support as well as improved DecoStudio e3 Lettering & Editing functionality. A
number of other issues have been resolved for file output and object property handling.
Note: Some listed improvements may not be relevant to DecoStudio Lite users. Please contact your local
Wilcom dealer or distributor should you wish to upgrade.

System improvements
DS e3.0Q includes the following improvements to system performance.

Writing Defaults file
A number of cases have been reported where DecoStudio has encountered problems writing the defaults file. A
‘Can't write the Defaults file’ warning message appears and ES becomes disabled. This issue has been
resolved.

Extended use
Problems have been reported when leaving DecoStudio running overnight. Upon trying to open a design the
next day, the application becomes disabled. This issue has been resolved.

Machine Format Settings missing units
Some units of measurement are missing in the Machine Format Settings dialog. This issue has been
resolved.

Lettering improvements
DS e3.0Q includes the following improvements to embroidery lettering functionality.

TrueType Font conversion
TrueType Font conversion has undergone a general improvement in the way fonts are converted to embroidery
patches (decomposition). This applies to all character sets.
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Conversion of multi-line paragraph text
Several problems have been reported with the conversion of TTF text. CorelDRAW multi-line paragraph text is
not converting properly to embroidery. Also, problems have been reported when converting paragraph text with
center or right justification. These conversion issues have been resolved.

Note: Small Paragraph & Artistic Text – in particular, narrow fonts such as script fonts – may not convert to
embroidery. Try increasing font size or try converting directly from the DecoStudio Object Properties >
Lettering tab.

Digitizing improvements
DS e3.0Q includes the following improvements to embroidery digitizing functionality.

Conversion of vectors to embroidery
There have been reports of software crashes occurring when converting certain vector designs. This issue has
been resolved.

Vector conversion for letter-like objects
Vector conversion for letter-like objects has been improved with the use of Turning Satin. This works better for
narrow turning shapes like letters. Standard conversion still applies to general shapes.
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Curve edge smoothness
Problems have been reported with the relative smoothness of curved edges. The sample shows Input C and
Input A with very high stitch density so the edge line can be clearly seen. This issue has been resolved.

Output improvements
DS e3.0Q includes the following output improvements.

Rotate design 180º on output for cap applications
Connection Manager now provides the ability to optionally rotate design 180º on output for cap applications.

A Rotate design by 180° on output checkbox has been added to the Connection Settings dialog. If ticked,
all designs sent to that connection will be automatically rotated.
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Color selection for machine icons
Connection Manager also now provides the option to select a color for machine icons. There are 8 colors to
choose from. By default, the ‘next available’ color is pre-allocated as is currently done with the toolbar icon.

Save options added to Connection Manager
An Options button has been added in Connection Manager. This allows users to set up specific file format
options directly from within Connection Manager without having to go to the Save As dialog.

First needle number written to Barudan format
Previously, the first needle number was not written to Barudan file format. For a single color design, this meant
the machine always defaulted to the first needle rather than selected needle. With this release, all Barudan
machine formats have ‘First CC required’ enabled by default.

Capture Design Bitmap via Email
Problems have been reported when using the Capture Design Bitmap function for sending via email. It fails to
work as expected with Windows Outlook 2010 or Outlook 2007 on Vista. Nor does it work properly with
Windows Live Mail under Windows 7. This issue has been resolved.

Removal of PES Hoop type dialog when saving as PES format
Previously, when saving a design in PES format, the PES Hoop type dialog appeared requiring the user to
choose a size. The dialog has been removed when outputting a PES design via Save, Save As, or Connection
Manager functions. Instead, the PES file format Options button in enabled in the relevant dialog.

Stop function codes with U?? files
Problems have occurred with the placement of Stop function codes in U?? files. Trim and Stop codes are
placed in the wrong sequence, Stops being placed before Trims. This issue has been resolved.
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Object properties
DS e3.0Q includes the following improvements in the handling of object properties.

Use of Object Properties with dual monitors
In a situation of dual monitors with the Object Properties dialog in the second screen, the slider bar remains
outside the dialog to the edge the first monitor. In short, sliders are not always visible, being hidden off the edge
of the screen. This issue has been resolved.

Thread and bobbin lengths displayed in EMB file properties
Incorrect thread and bobbin length values have been reported in the EMB file properties display in Design
Explorer. This issue has been resolved.

Design preview in Windows Explorer
When a design is saved in EMB e2 (or earlier version) in DS e3, the version number is displayed in Windows
Explorer as 3.0. This issue has been resolved.

Thread length values in EMB file in DW/DE
There have also been reports of thread length values in EMB file changing to either 0 or negative values in
Design Workflow and Design Explorer. This issue has been resolved.

Korean language support
DS e3.0Q includes the following improvements in support of Korean language.

Korean language resources added to software
Korean language resources have been added to the latest software installation.
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Quality of Korean TTF conversion to embroidery
The quality of conversion of Korean TrueType Fonts to embroidery has been improved, with better detection of
shape cuts and embroidery patches that support Korean unicode characters. Conversion now better follows
Korean stroke rules. Also:


All characters are satin stitch.



Embroidery stitch direction is the reverse of character process direction.

These issues have been addressed with the current release.

Stitching Korean letters with turning fill style
Korean TTF conversion fails to stitch some letters with a turning fill style – i.e. conversion produces Tatami
Complex Fill objects. This issue has been resolved.
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New & improved features in DS e3.0K
The release of the DS e3.0K software incorporates the following new and improved features.

Interface & usability improvements
DS e3.0K includes the following interface & usability improvements.

Ruler display
Inch rulers are now displayed in 1/16, 1/8, ¼, ½, and 1" divisions not 1/10s. The grid size can be set in decimal
inches now. This is usable as is.

Transformation & measure tooltips
Unit of measure displayed in the Resize tooltip can now be chosen by the user. Similarly distance moved – e.g.
moving letters – is now displayed in appropriate units. Similarly, ‘Length’ and ‘Angle’ labels have been added to
the Measure tooltip, together with the appropriate length unit.

Travel tool keyboard shortcuts

All Travel tools now have keyboard shortcuts. New shortcuts include:


Travel by 1000 stitches: Shift + Num- / Shift + Num+



Travel by Function: Ctrl + Page Up / Ctrl + Page Down



Travel by Trim: Ctrl + Left Arrow / Ctrl + Right Arrow

Garbage characters in Japanese menus
Garbage characters are appearing in menus in e3 Japanese when using WinXP. This issue has been resolved.

Thread & fabric improvements
DS e3.0K includes the following thread and fabric improvements.

Access to Manage Thread Charts dialog
The Manage Thread Charts dialog is now directly accessed via the Setup menu along with other asset
management functions. Previously it could only be accessed indirectly via the Thread Charts dialog.

Wilcom DecoStudio e3.0V Update
Release Notes

16/10/2014

19

Madeira color palettes
Madeira color palettes have been updated and now include all the latest threads. The new PolyNeon palette is
also included.

Lettering improvements
DS e3.0K includes the following lettering improvements.

Offset outlines with Kanji lettering
DS now provides the ability to apply offset outlines to Kanji characters as part of a lettering object.
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Preview of fonts in lettering properties
Previewing fonts in lettering properties can cause ES to unexpectedly shut down. This generally happens if
there are a very large number of TrueType fonts installed in Windows. This issue has been resolved.

Stitching & color improvements
DS e3.0K includes the following stitching and color improvements.

Slant angle of zigzag underlay
The slant angle of zigzag underlay defaults to 30º when opening an V2006 or earlier EMB files in e3. This can
cause the underlay to extend outside the boundary. With e1.5 and e2.0, the slant angle correctly defaults to
90º. This issue has now been resolved for V2006 and earlier.

File handling improvements
DS e3.0K includes the following file handling improvements.

Design Explorer and DesignWorkflow file display
Currently, DE and DW do not display Barudan U?? files at all. This issue has been resolved.

Missing formats in ES
TrueSizer can open and save some formats that are not available in ES. This has now been corrected so that
all products open and save the same formats. Also, three additional formats have been added to both TrueSizer
and ES:


Elna (*.EMD)



Janome/Elna/Kenmore (*.JEF+)



Pfaff (*.PCM)
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New & improved features in DS e3.0H
The main theme of the e3.0H software update was to enhance support for third-party machine connection.
Specifically, Happy, ZSK and Brother machines. Other aims of this release include:


Resolve issues associated with multi-language release.



Improve machine connectivity by providing the ability to add named machines and define a network location
for design retrieval.



Fix other outstanding software issues unresolved at the time of last release.

Updated Connection Manager
DecoStudio Connection Manager has been updated to provide a more flexible method of connection to different
machines that appear as removable media or use a third-party application to connect to the machine and
require files to be placed in a specific network location. Each machine, once set up, will only require a single
click in order to send a design to the predefined folder on a network or PC.

Basic workflow
The basic workflow is as follows:
1. Set up a machine connection.


Each machine has a unique name and ‘Quick Access’ button.



Each machine can have a unique folder to which designs can be sent so they can be accessed from
the machine control panel or third-party machine connection software.

2. Create a design.
3. Click the Quick Access button for the specific machine.
4. The design is sent to the specified folder.
5. Using the machine controller or third-party connection software, access the design from the network or PC
folder.
6. Load or send the design.
7. Stitch the design on the machine.

Sending a design for the first time
1. Click the Connection Manager icon on the Standard toolbar.

Alternatively, select Setup > Connection Manager Setup.
If no connections currently exist, the message appears:
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2. Click Yes to start setting up your connections.
The Connection Settings dialog opens.

3. Select the connection type. Choose from:


Machine folder – e.g. Barudan DFS, HappyLink/LAN, Brother PR series and so on



Janome MB-4



CAMS (rhinestone placement machine)

4. Enter a unique machine name. This name identifies the Quick Access button.
5. Select the file type required by the machine.
6. Enter or browse to a file location on the network or the PC

7. Click OK when complete.
The new machine will appear as a Quick Access button on the Standard toolbar
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8. Click Send to send the currently open design to the specified machine folder.
A confirmation message is displayed.

Setting up additional connections
1. Click the Connection Manager icon on the Standard toolbar.

Alternatively, select Setup > Connection Manager Setup.
If a connection already exists, the Send to Connection Manager dialog opens.

2. Select Setup Connections.
The Connection Manager Setup dialog opens.

3. Click Create.
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The Connection Settings dialog opens.

4. Repeat steps outlined above to set up another machine connection.
As more machines are created, more quick access buttons are added with unique colors for each.

A single click on a machine quick access button will send the current design to the predefined location for
the selected machine.

Other improvements
The e3.0H also includes the following fixes and improvements.

Multi-language issues
Problem

Resolution

Multi-language GUI
problems

A number of problems were reported with regards to truncations and faulty message
strings in languages other than English. These have been resolved.

‘My Product’ for multilanguages

Previously, clicking an element on left hand pane of the ‘My Product’ dialog, when
switched to languages other than English, did not load the corresponding page. This
issue has been resolved.

‘Capture Design
Bitmap’ in French

If running ES in French language, the ‘Capture Design Bitmap’ dialog crashed the
system. This issue has been resolved.

German translation of
Application Fabric
dialog

The Application Fabric dialog title has now been correctly translated as
‘Applikations-Stoff’.

Fabric selection in nonEnglish languages

Fabrics displayed to the user in non-English language did not match the translated
fabric selected. This issue has been resolved.
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Lettering issues
Problem

Resolution

Complex Fill TTF
conversions

When converting letters with holes, such as the registered trademark character ®,
strokes inside the outer ring were not always properly generated. This issue has
been resolved.

Unwanted Wingdings
in text field

Characters entered into the text field sometimes appeared as Wingding symbols,
even when a Wilcom alphabet was selected. This happened after digitizing lettering
with Webding and Wingding alphabets. This issue has been resolved.

Team Names options
when sending via
Connection Manager

Problems were reported when selecting Team Names options when sending
designs via Connection Manager. This issue has been resolved.

Auto-digitizing issues
Problem

Resolution

Converting embroidery
to graphics

Previously, ‘Convert Embroidery to Graphics’ did not always convert selected
embroidery to vectors. When it did convert, a ‘ghost image’ of the embroidery could
still be seen after conversion to graphics. These issues have been resolved.

Appliqué covering
stitches when
converting vectors

When creating an appliqué object from a combined vector object, covering stitches
for the hole were positioned on the wrong side for appliqué and had to be manually
fixed by swapping ‘Inside’ and ‘Outside’ values. This issue has been resolved.

Thread-related issues
Problem

Resolution

Assigning threads to
colorways

The Color Palette Editor dialog was slow to respond during thread assignments
involving a large number of colorways – e.g. > 50. This issue has been resolved.

Only used colors
displayed in colorways

Colorways available from the Color Palette popup menu showed all colors in the
palette, whether used or not. Now only colors used in the design (underlined in blue)
are displayed. If no color is currently being used, no colors appear in the combo –
only the name and background.

Improved colorway
popup display

The number of colors visible in the colorways popup menu has been increased as
follows:
 Maximum number of (used) colors shown has been increased from 8 to 16.
 The number of colorways shown at any one time has increased from 4 to 6. The
list can be scrolled to reveal more colorways if available.

Miscellaneous
Problem

Resolution

Object scaling width
and height values

When resizing an object via selection handles, the Width and Height values
appearing in the resize tooltip were out of sync with those of the Property Bar. This
issue has been resolved.

Happy machine hoop
display

Happy machine hoops appear in the software to be smaller than actual size. This
issue has been resolved.
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Solving problems
If you encounter a problem with with the DecoStudio e3.0K software update, refer to the following sources for
help:


Wilcom DecoStudio e3.0 User Manual – select Help > User Manual.



Wilcom DecoStudio e3.0 Onscreen Help – select Help > Onscreen Help



Windows help – select Start > Help and Support



Windows manual – documentation supplied with your hardware.

If you are unable to solve a problem, you should contact your Wilcom dealer. Before seeking help, check that
your PC meets the system requirements, and check the Troubleshooting chapter of the Onscreen Manual.

Copyright
Copyright © 1990-2014 Wilcom Pty Ltd, Wilcom International Pty Ltd. All rights reserved.
No parts of this publication or the accompanying software may be copied or distributed, transmitted,
transcribed, stored in a retrieval system or translated into any human or computer language, in any form or by
any means, electronic, mechanical, magnetic, manual, or otherwise, or disclosed to any third party without the
express written permission of:
Wilcom Pty Ltd. (A.B.N. 62 062 621 943)
Level 3, 1-9 Glebe Point Rd, Glebe
Sydney, New South Wales, 2037, Australia
PO Box 1094 Broadway NSW 2007
Phone: +61 2 9578 5100
Fax: +61 2 9578 5108
Web: http://www.wilcom.com
TrueView™ and Point & Stitch™ are trademarks of Wilcom Pty Ltd. Portions of the imaging technology of this
Product are copyrighted by AccuSoft Corporation. The EPS File Import/Export Converter used in this Product is
copyrighted by Access Softek, Inc. All rights reserved.

Contact
If you have any questions, please contact your local Wilcom dealer or distributor in your country.
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