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Chapter 1

Introduction

Welcome to EmbroideryStudio e4, the leading design software 
application for the decorated goods industry. Combining both the 
embroidery capabilities of Wilcom software with the graphical capabilities 
of the CorelDRAW® Graphics Suite, no other product provides the 
flexibility of EmbroideryStudio in creating designs for both embroidery 
and multi-decoration. While supporting multi-decoration, the product is 
tailored to the requirements of the embroidery specialist who requires a 
powerful toolset to create and edit high-quality, production-ready 
embroidery.

Note: Screen illustrations in this publication are intended as 
representations only. Depending on your software model or product level, 
screen layouts generated by the software may differ slightly. Similarly, 
samples used to illustrate software features and capabilities may not be 
exactly duplicable in your product model.

Product models

EmbroideryStudio consists of five standard product models with over 20 
optional ‘Elements’. Standard products are powerful, well featured, 
professional embroidery applications. Additional Elements are available 
at extra-cost. Some Elements are provided as standard in higher product 
models.

EmbroideryStudio product models
The EmbroideryStudio e4 product suite consists of these product models:

Model Capabilities Applications

ES Designing ^ Professional digitizing and graphic design, lettering, 
and editing. It supports the full range of optional ES 
Elements. Some are included as standard.

Larger logo embroidery 
businesses with digitizing

ES Digitizing * Professional embroidery digitizing. Fashion and textile 
production digitizing

^ Includes CorelDRAW® Graphics Suite as standard. * Only available in certain countries.
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Note: To identify sources of information relevant to your model and any 
additional elements you may have activated, see Product differentiation 
table.

Integration with CorelDRAW®
CorelDRAW® Graphics Suite is bundled as standard with some product 
models. The built-in CorelDRAW Graphics window includes 
CorelDRAW® drawing tools which offer many techniques for drafting 
outlines and shapes on screen. Vector objects can be converted to 
embroidery designs. For a full description of the tools, refer to the online 
help available from the Graphics mode Help menu.
CorelDRAW® and its sister product, Corel PHOTO-PAINT® can also be 
run as standalone applications. CorelDRAW® Graphics Suite features 
‘best-of-breed’ bitmap-to-vector tracing, enhanced illustration 
capabilities, photo-editing together with a library of professional clipart 
images.
CorelDRAW® Standard Membership also provides access to content – 
clipart, fonts, stock photos, templates – via the built-in Corel CONNECT.

Modular elements

EmbroideryStudio offers optional ‘Elements’ for Creativity, Production, 
and Specialty processes. The EmbroideryStudio e4 product suite consists 
of these product models:

ES Decorating ^ Professional lettering, customization and editing. 
Auto-digitizing and simple manual digitizing. 
Includes some ES Elements.

Small embroidery shops – 
replaces DecoStudio

ES Editing Full lettering, customization, editing, with machine 
connections.

Logos, retail shops, 
production shops

ES Lettering Full lettering, customization, with machine 
connections.

Logos, retail shops

Model Capabilities Applications

^ Includes CorelDRAW® Graphics Suite as standard. * Only available in certain countries.

Product models Applications

1 ES Designing ^ Larger logo embroidery businesses with digitizing

2 ES Digitizing * Fashion and textile production digitizing

3 ES Decorating ^ Small embroidery shops – replaces DecoStudio

^ Includes CorelDRAW® Graphics Suite as standard. * Only available in certain countries.
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Optional ES Elements for each category – Creativity, Production, and 
Specialty – are shown below. Some are included as standard in certain 
product models.

4 ES Editing Logos, retail shops, production shops

5 ES Lettering Logos, retail shops

Product models Applications

^ Includes CorelDRAW® Graphics Suite as standard. * Only available in certain countries.

Element 1 2 3 4 5

Creativity

Shading & Open 
Fills

Add depth and dimension to your 
embroidery with powerful shadows, shades 
and open fills.

○ ○ – – –

Curved Fills
Create unique, flowing stitch patterns that 
add motion and dimension to any closed 
object.

○ ○ – – –

Maze Fills
Automatically fill large areas with 
double-spiral stitching that never crosses 
itself.

○ ○ – – –

Spiral Fills
Create open stitching that follows the 
contours of a shape for some interesting 
visual effects.

○ ○ – – –

String Stitch

Create outline or filled shapes with 
overlapping ‘string art’ stitching to hold 
mirror pieces or for decorative effects. 
Known as ‘Paghadi’ in India.

○ – – – –

Freehand Create embroidery the most natural way – 
as if you were drawing with pen and paper. ● ○ – – –

Hand Stitch

Create hand-stitch effects which combine 
randomized spacing and stitch angles for a 
more organic look. Apply to satin, tatami, 
run, backstitch, and other stitch types.

● ○ ○ – –

Motifs
Create motif runs and both single and 
double motif fills. Apply 3D Warp distortion. 
Create and reuse motif patterns.

○ ○ – – –

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering
● Included as standard  ○ Modular ‘element’
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Motif Runs 
Advanced

Create advanced motif runs with variable or 
gradient motif size and spacing effects. 
Motifs can also conform to varying size 
column shapes.

○ – – – –

Custom Splits Add carving, embossing and other 
dimensional effects to your embroidery. ○ ○ – – –

Photo Flash Convert black and white, grayscale and 
color images into embroidery. ○ ○ ○ – –

Reef PhotoStitch
Convert photos into embroidered designs in 
seconds. Automatically fill large areas with 
open stitching reminiscent of a coral reef.

○ ○ ○ – –

Productivity

Team Names 
Advanced

Save lettering layouts for reuse. With 
different logos and lettering, reuse makes 
teamname design simpler and faster.

○ ○ ○ ○ ○

Offsets Advanced Embolden logos, badges and other designs 
with distinctive, colorful borders. ○ ○ ○ – –

Auto Shaping
Use auto-shaping tools to weld, flatten, 
intersect, and other shaping operations to 
give you accuracy and speed.

● ○ – – –

Auto 
Arrangements

Automatically create reflecting borders, and 
wrap reflections around a center point to 
create wreath or kaleidoscope effects.

○ ○ – – –

Kiosk Mode
Use at retail outlets where fast and simple 
personalization of standard design layouts is 
required in consultation with customers.

● ● ● ○ ○

Specialty

Embroidery- 
Connect

Quickly and easily send, scan, and queue 
your embroidery designs for production. 
EmbroideryHub networking software is 
included as standard. EmbroideryConnect 
WiFi devices are available for purchase.

● ● ● ● ●

Single Sequin

Create artistic sequin designs with sequin 
runs and sequin fills for single sequin 
machines using automated predefined fixing 
stitches.

○ ○ ○ – –

Element 1 2 3 4 5

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering
● Included as standard  ○ Modular ‘element’



EmbroideryStudio e4 Reference Manual 5

Included features

For details of the features included with each Element, click the links in 
the table below.

Creativity

Sequins 
Advanced

Create embroidery files for single and 
twin-sequin dispensing machines. ○ ○ – – –

Beading
Provides support for beading devices. 
Classic fixing methods available: upright, 
flat, and sideways.

○ ○ – – –

Bling
Use any combination of stones, sizes and 
colors to light up your design. Includes bling 
lettering.

● ○ ● – –

Virtual Decoration
Bring the look of embroidery to your printed 
designs. Includes high resolution TrueView 
images. Print in CorelDRAW Graphics.

● ○ ● – –

Font Creator Match logo type exactly or create unique 
ones all your own. ○ ○ – – –

Chenille Add chenille embroidery capabilities to a 
lockstitch embroidery digitizing system. ○ ○ – – –

Schiffli Create and prepare lacework and emblems 
precisely and efficiently. ○ ○ – – –

Element 1 2 3 4 5

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering
● Included as standard  ○ Modular ‘element’

Element Features Reference

Shading & 
Open Fills

Cross Stitch Fill Cross stitch fills

Stipple Fill Stippling effects

Accordion Spacing Accordion spacing

Color Blending Color blends

Curved Fills

Liquid Effect Create curved fills with Liquid 
Effect

Florentine Effect Create curved fills with Florentine 
Effect

Contour Stitch Contoured fills
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Production

Maze Fills Maze Fill Maze fills

Spiral Fills Spiral Fill Spiral fills

String Stitch String String stitching

Freehand Freehand Freehand embroidery

Hand Stitch Hand Stitch Hand stitch effect

Motifs

Full Motif Fill Motif fills

Motif Run Motif runs

Create Motif Custom motifs

3D Warp Enveloped motif fills

Motif Runs 
Advanced

Motif Run Create graded motif runs

Motif Column Create graded motif columns

Custom Splits

Flexi Split Flexi-splits

Carving Stamp Creating patterns with custom 
splits

User Defined Split

Photo Flash
Photo Flash Auto-digitize with Photo Flash

Color PhotoStitch Auto-digitize with 
Color PhotoStitch

Reef 
PhotoStitch Reef PhotoStitch Auto-digitize with Reef PhotoStitch

Element Features Reference

Team Names 
Advanced

Save As Teamname 
Template Teamname templates

Element Features Reference
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Offsets 
Advanced Outlines & Offsets Generating outlines & offsets

Auto Shaping Shaping Tools Shaping objects

Auto 
Arrangements Mirror Merge Mirroring & reflecting selections

Kiosk Mode Lettering Kiosk Lettering Kiosk

Element Features Reference
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Specialty

System requirements

Before you install, or if you experience operating problems, make sure 
that your computer meets the system requirements.

Element Features Reference

Embroidery- 
Connect

EmbroideryHub
EmbroideryConnect Machine Networking

Single Sequin
Sequin Run Digitizing sequin runs

Sequin Fill Creating sequin fills

Sequins 
Advanced

Advanced Sequin Advanced Sequins

Sequin Fill Creating sequin fills

Twin Sequin
Creating multi-sequin runs

Multi Sequin

Beading Bead Run Bead Embroidery

Bling
Create Bling Bling Digitizing

Bling Lettering Creating bling lettering

Virtual 
Decoration

Capture Virtual 
Decoration Bitmap Virtual embroidery

Font Creator
Create Letter Creating custom fonts

Convert TrueType 
Font

Converting TrueType fonts to 
embroidery

Chenille Chenille Chenille Supplement

Schiffli Schiffli Schiffli Supplement
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PC specifications
Check CPU/RAM as well as hard disk space. The table below provides 
minimum system requirements.

Supported operating systems ‡
Since EmbroideryStudio no longer supports Windows® 32-bit operating 
systems, we recommend updating to Windows® 10 (64-bit edition) with 
latest updates installed. You will, however, need to uninstall any earlier 
versions of CorelDRAW® Graphics Suite. For latest operating system 
information, visit the Wilcom Support Center at help.wilcom.com.

Free hard disk space † 
EmbroideryStudio occupies up to 5GB of hard disk space, depending on 
options installed. CorelDRAW® Graphics Suite also takes up an additional 
3GB. However, you need additional free space for your applications to run 
smoothly.

Component Minimum Recommended

CPU Intel® Core i3 (3rd Gen or later) or AMD 
Athlon™ FX-6350 or later

Latest Generation Intel Core i7 
processor (4.0 GHz +)

Operating 
system

‡ Microsoft Windows 10 64-bit Edition Microsoft Windows 10 64-bit Edition 
with the latest updates

Browser IE 11.0 or later Microsoft Edge or later

Memory 8 GB 32 GB or more

Hard disk size 80 GB 256 GB or more (Solid State Drive)

Free disk space † 40 GB 60 GB or more

Graphics card Support for Highest Color (32bit) and 
resolution (1600 x 900)

• Support for Highest Color (32bit) and 
resolution (1920 x 1080 or higher) 

• 2 GB or more of graphics memory 
(non-integrated)

Monitor ¥ 1600 x 900 screen resolution Dual monitors capable of displaying 
1920 x 1080 screen resolution

Mouse USB mouse USB mouse

USB port Required for software installation and security device.

Sound card Required for online video help.

Internet 
connection

Required for:
• Product activation and registration
• Periodic software updates
• Access to news, community, product blog, tutorials, and product documentation
• During installation, to download Windows features.

http://help.wilcom.com
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Screen resolution ¥

Some controls may be hidden on the user interface if you run your 
monitor at low resolutions. The physical size of your monitor will have a 
bearing on the optimum screen resolution. Larger fonts will exacerbate 
the problem. If you experience visibility issues, try adjusting both screen 
resolution and font size. For example, a resolution of 1600 x 900 with a 
font size of 100% or 125% should be acceptable.

Power plan
For best performance make sure your PC is set to high performance 
power plan.

Product installation & registration

EmbroideryStudio products are supplied both as packaged and 
downloadable products. Packaged software installation is supplied on 
USB memory stick, not DVD.

To install and register the product
1 Close all open programs but leave Windows running. 
2 Insert the EmbroideryStudio installation USB memory stick into the 

USB port.
The installation will automatically run. If not, manually open the 
setup.exe found in the installation folder.

3 Follow the on-screen instructions and attach the dongle when 
prompted.

4 Upon successful installation of the software and any additional 
Windows files, the Installation Complete screen appears.

5 Click Finish. The computer will reboot. The software can then be used 
with the security dongle attached.
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Note: CorelDRAW® Graphics Suite may be installed together with 
Windows .NET Framework. To ensure that CorelDRAW® Graphics Suite is 
correctly installed with your embroidery software with the correct version 
of .NET, make sure you install it when prompted to do so. It can take up 
to 20 minutes or more to install the .NET Framework on some computers.

Security & registration
Don’t forget to register your copy of EmbroideryStudio Product 
registration is required to validate the warranty. Also, by registering you 
will have access to:
 Wilcom support
 Live and recorded online training (as it becomes available)
 Information about product updates, events and special offers.

Note: CorelDRAW® needs to be registered before it can be used by 
EmbroideryStudio. Registration provides CorelDRAW® Standard 
Membership which gives you access to content – clipart, fonts, stock 
photos, templates – via Corel CONNECT. It also gives you access to the 
latest CorelDRAW® updates.

Software updates

Use the My Wilcom page of the Home screen to check your current 
system status. This page provides details of your Wilcom license, 
including product level, version, as well as any compatible or enabled 

Click Mode > Home to return to the Home screen to get started with a new 
design, or access tutorials and other product information.
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Elements. Whenever you access this page, the software will check for 
latest software updates. 

Tip: You can deactivate automatic updates via the Options dialog. When 
deactivated, you will need to run the Help > Check for Updates 
command. See Other general options for details.

Security device
EmbroideryStudio e4 is supplied with a 
hardware dongle.
 Software is activated online and 

requires an occasional Internet 
refresh.

 End-user registration and details are 
required.

 Continuous Internet connection is not 
required for use of the software.

Caution: NVIDIA nForce motherboards are not fully compatible with the 
security dongle.

Multi-user network dongle
EmbroideryStudio e4 continues to provide network dongle support. This 
means:
 Licensed for set number of simultaneous users
 Ideal for educational institutions and corporate users
 Any ES e4 product model, including DesignWorkflow can be run
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 All systems on the network are same product and options
 Three models of network dongle to support up to 10, 50, 250 users
 Can also use individual dongles for other products – if a local dongle 

is plugged into the machine, it will be favored over the network 
dongle.

Uninstalling the software
If for any reason you need to uninstall EmbroideryStudio, make sure you 
do so via the MS Windows® Control Panel > Programs and Features. 
Select a Wilcom program from the list – either EmbroideryStudio (main 
application), Nova PDF Printer, Nova PDF SDK COM, Wilcom PDF Printer, 
and/or the Wilcom Shell Extension.

Note, however, the side effects of removing ancillary programs but not 
the main application:
 Nova PDF: No PDF printing from EmbroideryStudio.
 Wilcom Shell Extension: No thumbnails/design info displayed in File 

Explorer or Design Library.

Choose Wilcom 
application to 
uninstall
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Resources & support

EmbroideryStudio provides various ways to access information about the 
software and how to use it.

Product documentation

Product documentation is provided in two formats – HTML Help and 
Adobe Acrobat (PDF). Components include release notes, reference 
manual, online help, as well as various supplements.

Release notes
Release notes provide details of new features and major and minor 
improvements in the software, as well as known limitations and 
‘workarounds’.

Online help
Online help provides quick access to general information on 
EmbroideryStudio features and step-by-step instructions. There are two 
types available – Wilcom Workspace Help and CorelDRAW Graphics 
Help. The latter can be accessed from the CorelDRAW Graphics Help 
menu.

Tip: Context-Sensitive Help is available for tools and dialogs by pressing 
the 1 key.

Reference manual
The reference manual can be accessed from the EmbroideryStudio Help 
menu or MS Windows® Programs folder. You can read it with Adobe 
Acrobat™ Reader which can be downloaded from the Adobe website. It 
can also be downloaded from the online help home page.

Access onscreen 
documentation

Access Wilcom online support 

Access information about your product 
configuration plus available updates

Access Wilcom online registration 

Access the Home screen

http://www.adobe.com
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User guide
A printed user guide is available on demand at a small cost. It is intended 
as a convenience for beginner and intermediate users. It is not a 
complete description of software capabilities.

Note: Screen illustrations in the documentation are representations, not 
exact duplicates of screen layouts generated by the software. Procedural 
descriptions may vary slightly from your installation, depending on 
current settings.

Manual supplements

The EmbroideryStudio installation also installs a number of online 
supplements depending on your product options. These are generally 
used in conjunction with the User Manual.

Chenille
This supplement is supplied with the Chenille Option. It documents:
 Chenille features within EmbroideryStudio
 Chenille machines, including chain, moss, needle height
 Chenille stitch types and effects.

Sequin
This supplement is supplied with the ES Sequin Option. It documents:
 Setting up sequin mode
 Creating sequin runs and fills
 Converting objects to sequins
 Setting up twin-sequin designs
 Modifying sequin designs
 Digitizing individual sequins

Access supplemental 
documentation
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Schiffli
The manual is supplied with the Schiffli Option. It documents:
 Schiffli features within EmbroideryStudio
 Read/output to Schiffli files
 Schiffli disk utilities, Fixpat, Defced.

Cross Stitch
This supplement is supplied with the ES Cross Stitch Option. It 
documents:
 Manual and automatic cross stitch digitizing
 Cross stitch editing
 Cross stitch lettering
 Handling cross stitch design files.

Machine Manager
This supplement documents the following product capabilities:
 Machine Manager Direct Connect
 Feedback from machines
 Machine activity reporting 
 Technical details of machine network setup.

EmbroideryConnect
An EmbroideryConnect machine network allows for wireless design 
transfer to embroidery machines that have a USB port. When activated 
in EmbroideryStudio, you can send machine files via a standard WiFi 
network to a compatible WiFi USB Stick plugged into the machine. This 
supplement describes setup and usage.

Online support

You can access online sales and support information easily from the Help 
menu. You will need a correctly configured web browser together with 
web access.

To access online support
 The Wilcom.com link provides commercial information about Wilcom 

products and services.
 The Help & Support link provides access to various online support 

services. You need to be a registered user of the product.
 The Training & How-to Videos link provides access to online video 

demonstrations.

https://www.wilcom.com/
http://help.wilcom.com
https://www.wilcom.com/en-us/gethelp/support/trainingvideos.aspx
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 The Wilcom Community provides official Wilcom news and 
announcements, community ideas and feedback, as well as 
community self-help.

CorelDRAW® Graphics Suite support

CorelDRAW® Graphics Suite is bundled as standard with some product 
models. CorelDRAW® needs to be registered before it can be used by 
EmbroideryStudio. Registration gives you access to the latest 
CorelDRAW® updates. Registered users of this site can participate in 
forums as well as comment and rate blogs and galleries. Some forums 
are in local languages. Access the CorelDRAW Community site via the 
CorelDRAW Graphics > Help menu.

Note: For a detailed description of the CorelDRAW® Graphics Suite 
interface, refer to the electronic User Guide available via the 
MS Windows® Start > Programs group. Alternatively, use the online 
help available from the CorelDRAW Graphics Help menu.

Access CorelDRAW 
Community to participate in 
forums and access blogs 
and galleries

http://community.wilcom.com
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Chapter 2

Designing with EmbroideryStudio

Embroidery design with EmbroideryStudio consists of turning basic 
artwork shapes into embroidery designs. EmbroideryStudio gives you the 
flexibility of creating embroidery objects using artwork as backdrops, or 
of directly converting digital artwork. You can take a mixed-mode 
approach as well, doing the bulk of the design by means of automatic 
conversion, followed by touch-ups and edits using the suite of 
EmbroideryStudio embroidery digitizing tools.

Artwork & designs

High quality embroidery starts with good design and forward planning.

Artwork

Electronic artwork in both bitmap and vector formats can be inserted, 
pasted or scanned into EmbroideryStudio for use as digitizing templates 
or ‘backdrops’. Likely sources include:
 Internet and CD clipart libraries
 Business cards, post cards and wrapping paper
 Samples in the Design Library
 Books of embroidery patterns
 Children’s story books
 Printed table cloths or tea towels
 Original artwork – e.g. children’s drawings.
Unless you are an experienced digitizer, do not use complicated artwork. 
Also, be sure to check the copyright of any images you have not created 
yourself. If unsure, contact the relevant supplier to seek their permission.
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Good design

Keep the following points in mind when digitizing your design and 
assessing the final output:

The stitched-out design should also have the following characteristics:
 Design looks good – shapes, colors, balance
 Shapes are filled with correct fill and outline stitches
 Details are clearly defined
 Stitches are neat, smooth and even
 Stitches angles follow design shapes
 Lettering is clear and easy to read
 The design stitches out efficiently on the machine
 Shapes are stitched correctly – no unwanted gaps
 The fabric has not puckered around the stitched areas
 The design is free of loose ends.

Tip: Good design is enhanced by the use of correct backing, tension and 
a good quality embroidery machine. 

Sample designs & artwork

EmbroideryStudio contains hundreds of ready-to-stitch designs, 
including attractive ornaments, samples and digitizing backdrops. Design 

Details are clearly
defined

Shapes are filled with 
appropriate fill and 
outline stitches

Stitches are angled 
to match shapes

Design looks good—
shapes, colors, balance
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files (EMB files) and images (BMP, JPG, and WMF files) can be found in 
your Embroidery and Picture libraries.

The most valuable thing you can do when starting out is to spend some 
time exploring these designs and getting to know what’s available. 
EmbroideryStudio includes its own Design Library design management 
application to view and manage your embroidery designs. Alternatively, 
explore design folders using File Explorer. See also Design 
Management.

Navigate folder
structure via

navigation tree or
address bar
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Caution: Included artwork (clipart) and embroidery designs can only be 
used for personal use – i.e. they cannot be commercially sold in any form. 
Changing the medium – i.e. clipart to embroidery or embroidery to clipart 
– does not remove copyright protection.

CorelDRAW resources

CorelDRAW® Graphics Suite is bundled as standard with some product 
models. CorelDRAW® Standard Membership provides access to content 
– clipart, fonts, stock photos, templates – via Corel CONNECT. Clipart 
and other content can be accessed via the program group. It can also be 
accessed via the built-in CONNECT Content docker in CorelDRAW 
Graphics.

Go to Window > Dockers > CONNECT Content to open the docker.

Get familiar with the many clipart samples available to you. Many can be 
adapted for use with embroidery design, either as digitizing backdrops or 
direct conversion.

Access CorelDRAW 
CONNECT to browse 
extensive collection of 
clipart and other assets

Access online content 
via the CONNECT 
Content docker
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Caution: Included artwork (clipart) and embroidery designs are only 
available for personal use – i.e. they cannot be commercially sold in any 
form.

Embroidery creation techniques

Depending on your level of product, there are two fundamental design 
modes in EmbroideryStudio:
 CorelDRAW Graphics: This mode allows you to create or edit graphic 

designs using the CorelDRAW® Graphics Suite toolset.
Wilcom Workspace: This mode allows you to create and edit 

embroidery designs using an embroidery digitizing toolset.

Note: For a full description of the CorelDRAW® Graphics Suite tools, 
refer to the electronic User Guide available via the MS Windows® Start 
> Programs group. Alternatively, use the online help available from the 
Help menu.

Using electronic artwork
There are two broad categories of artwork file, both of which can be 
imported into EmbroideryStudio for use as digitizing backdrops – vector 
and bitmap. CorelDRAW Graphics supports the automatic and 
semi-automatic digitizing of both bitmap images and vector graphics. The 
quality of the resulting embroidery greatly depends on the type and 
quality of the original artwork.

Preparing images for digitizing
Generally speaking, vector graphics preserve the picture quality when 
resized, whereas bitmap images cause problems of pixelation and image 
degradation when enlarged or scaled down. In order to make bitmap 
images more suitable for automatic digitizing, EmbroideryStudio 
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provides image processing capabilities. See Digitizing with Bitmaps for 
details.

Digitizing shapes manually
You trace shapes and lines over electronic artwork using various digitizing 
on ‘input’ methods. Using a bitmap image in this way is like using an 
enlargement drawing on a digitizing tablet, except that everything is 
done on screen. See Embroidery digitizing for details.

Converting artwork to embroidery
EmbroideryStudio lets you convert vector objects directly to embroidery 
objects. In fact, entire vector designs can be converted to embroidery. 
You can modify these designs as you wish. You can also convert 
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embroidery to vector graphics. See Convert objects with CorelDRAW 
Graphics for details.

Tip: CorelDRAW® Graphics Suite lets you trace bitmaps to convert them 
to fully editable and scalable vector graphics. You can trace scanned 
sketches, artwork, digital photos, and logos and easily integrate them 
into your designs.

Object-based embroidery

In EmbroideryStudio, you build designs from basic shapes or ‘embroidery 
objects’. They are called ‘objects’ because they are discrete entities which 
can be manipulated independently of each other. These are like ordinary 
vector objects in that they have certain defining characteristics or 
properties’ such as color, size, position, and so on. They also have 
properties unique to embroidery such as stitch type and density.

Note: In EmbroideryStudio, vector and embroidery objects are in fact 
inter-convertible since they share many of the same characteristics. See 
also Convert objects with CorelDRAW Graphics.

Design shapes and stitching sequence
The embroidery objects comprising a design form a stitching sequence. 
Before creating an embroidery design, it is good practice to analyze and 
plan shapes and stitching sequence in advance. Shapes need to be clearly 
defined to make them easy to embroider. The best ones have relatively 
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constant width, with smooth edges, no sharp turns and no small, 
protruding details. Outlines and details should always be stitched last.

If you are digitizing manually, objects are stitched out in the order they 
were created. In other words, the digitizing sequence defines the 
stitching sequence. If you have converted an electronic design, 
EmbroideryStudio uses automatic sequencing to create the optimum 
stitching sequence. Auto-sequencing attempts to generate embroidery 
designs which are economical to produce, with minimal down time, and 
accurate registration of textures and colors.

Mixed-mode approach
If you take a mixed-mode approach, you may do the bulk of the design 
by means of automatic conversion, and touch-ups and edits using the 
suite of EmbroideryStudio embroidery digitizing tools. In addition, you 
can always manually adjust the stitching sequence to improve the 
stitchout, for example, to minimize color changes. See also Automatic 
digitizing.

Object viewing and selection

EmbroideryStudio provides many viewing modes to make it easier to 
work with your designs. View a design at actual size or zoom in for more 
detail. Pan a design instead of scrolling, or quickly change between one 
view and the last. Show or hide outlines, stitches themselves, or view 
designs in TrueView™.

1

2

3

4

5
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Understanding stitching sequence
When working with embroidery designs, you can check the stitching 
sequence by ‘traveling’ through it by means of color blocks, embroidery 
objects, or even stitch-by-stitch. Alternatively, simulate the actual 
embroidery design stitchout on screen. You can also preview designs in 
different colors on different backgrounds by selecting from predefined 
colorways. See Viewing stitching sequence for details.

Selecting embroidery objects
EmbroideryStudio provides various ways to 
select embroidery objects. Modify the 
design as a whole or select individual 
objects for more precise modification. The 
Color-Object List provides an easy way to 
select objects and colors in a design and 
access their properties. Use it also to group 
and ungroup, lock and unlock, and show 
and hide objects. See Selecting objects for 
details.

Digitizing embroidery shapes

In addition to the automated and semi-automated techniques 
EmbroideryStudio provides for creating embroidery designs, it also 
contains a suite of manual digitizing tools. These are similar to graphics 
tools except that the end result are embroidery rather than vector 
objects. It is important to be familiar with manual digitizing methods in 
order to fully understand the process, the types of objects created, and 
the problems associated with embroidery digitizing.

Digitizing simple & complex shapes
There are tools for digitizing filled shapes with turning stitches and fixed 
stitch angles, with or without holes. There are also tools for creating 
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columns and borders of fixed or varying width. See Embroidery digitizing 
for details.

Digitizing outlines & details
EmbroideryStudio provides tools for creating outline stitching of varying 
thicknesses and styles. They are typically used to add outlines and details 
to designs. There are tools for creating simple run stitching as well as 
decorative outlines using predefined motifs. Backstitch is an older-style, 
adaptable stitch which can be used for delicate outlines. Stemstitch is 
thicker and can be used to mimic hand-sewn embroidery. Occasionally 
you may even need to digitize individual stitches. See Digitizing outlines 
& details for details.

Stitch types
The most important property of all embroidery objects is their stitch type. 
The software uses object outlines and the associated stitch type to 
generate stitches. Whenever you reshape, transform or scale an object, 
stitches are automatically regenerated. See Stitch Types for details.

Threads & colorways
When digitizing, you select thread colors for objects from the color 
palette. This contains a selection of colors tailored to each design or color 
scheme. The particular ‘colorway’ represents the actual thread colors in 
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which a design will be stitched. You can define multiple color schemes and 
switch between them. See Colorways for details. 

For each colorway you define, you can select colors from commercial 
thread charts or define your own. Search for particular threads by specific 
code. Automatic thread color matching helps you locate thread colors 
based on closest match across one or several thread charts. You can also 
match thread colors from imported graphics – vector or bitmap.

Design backgrounds
EmbroideryStudio also lets you set the background color, fabric, or 
product of the current colorway for more realistic previews and 
presentations. The background is saved with the colorway. See Fabric & 
product backgrounds for details.
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Properties, fabrics, styles & templates
Object properties are stored with each object whenever you save a 
design. These properties determine how stitches will be regenerated 
whenever you reshape, transform or scale an object or entire design.

Default properties are stored with the design template and form the basis 
of all new designs. These may be overridden by fabric settings which are 
automatically adjusted to suit different fabric types. These in turn may 
be overridden by individual property settings determined by the digitizer. 
See Object Properties for details.

Underlays & pull compensation
Embroidery stitches pull fabric inward where needles penetrate. This can 
cause fabric to pucker, stitch bunching, and/or unsightly gaps to appear 
in the embroidery. EmbroideryStudio includes many techniques for 
achieving smooth, even placement of stitches, and the elimination of 
gaps in designs.

For an object to sew out correctly, it must have correct stitch spacing, 
sufficient pull compensation, together with a suitable underlay for the 
particular combination of cover stitch type, object type, object shape, 
and fabric. See Underlay & Pull Compensation for details.
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Embroidery connectors
Connectors link objects in a design. 
They can be run stitches or jumps. 
Travel runs are typically used to 
connect segments within filled 
objects. You can use automatic 
settings to generate connectors, trims 
and tie-offs, or add them manually. 
You can change connector settings for 
a whole design or selected objects. If 
you prefer to add tie-offs and trims as 
you digitize, you can turn off 
automatic connectors altogether.
EmbroideryStudio also allows you to 
automatically connect first and last 
stitches of a design. This makes it easy to position the needle before 
stitching, and reduces the chance of it hitting the frame. See Embroidery 
Connectors for details.

Automatic digitizing

Depending on your product level, EmbroideryStudio offers a variety of 
complementary tools and techniques for automatically digitizing suitably 
prepared artwork.

Auto-tracing bitmap artwork
Use Auto Trace To Vectors to create vector outlines from bitmap 
images. You can then convert these to embroidery objects using a variety 
of input methods. Auto Trace To Vectors can find holes in shapes – 
both inside and outside boundaries are detected. See Auto-tracing 
bitmap artwork for details.
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Auto-digitizing image shapes
Auto-Digitizing tools provide everything necessary to digitize shapes in 
bitmap images and vector graphics automatically without using manual 
digitizing methods. See Auto-digitize individual shapes for details.

Auto-digitizing entire images
Smart Design automatically converts whole bitmap images to fully 
digitized embroidery. See Auto-digitize entire designs for details.

Auto-digitizing photographs
Use Color PhotoStitch or Photo Flash to create embroidery from 
photographs and other images. While Photo Flash designs consist of 
rows of single-color satin stitching, Color PhotoStitch produces 
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Tatami fill



Chapter 2   Designing with EmbroideryStudio 32

variegated stitching using multiple thread colors. The overall effect is like 
multi-colored stippling. See Auto-digitizing photographs for details.

Modifying designs

After digitizing a design, you can modify it as a whole, edit individual 
objects or even individual stitches.

Combining & resequencing objects
EmbroideryStudio provides various techniques for combining and 
sequencing objects. You can add to designs by duplicating and copying 
objects. Combine designs. Resequence objects in designs to minimize 
color changes and optimize production.
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The stitching sequence naturally occurs in the order in which an 
embroidery design is digitized or assembled. When converting a graphic 
design to an embroidery design, EmbroideryStudio decides the stitching 
sequence according to its own internal logic. Either way, you may, for 
reasons of aesthetics or production efficiency, want to adjust it. The 
Color-Object List displays a sequential list of objects grouped by object 
and color. It provides an easy way to group, cut, copy and paste, and 
resequence selected objects and color blocks. EmbroideryStudio also 
allows you to create ‘branched objects’. Like-objects are thereby 
resequenced, connectors minimized, components grouped, and stitches 
regenerated. Underlay can be applied to all. See Combining Objects for 
details.

Arranging, scaling & transforming objects
You can change the position, size and orientation of objects in a design 
by moving, scaling and transforming them. Group objects together to 
apply universal changes, or lock them to avoid unintentional 
modification. Modify objects directly on screen or via their object 
properties. Access commonly used functions via the Color-Object List. 
See Transforming Objects for details.

Reshaping and converting objects
EmbroideryStudio offers a number of techniques for reshaping 
embroidery objects, all with the one tool. Sometimes you may need to 
cut, split or break up complex or compound objects in order to fine-tune 
them. Various tools are available for this purpose. As well as reshaping 
object outlines, you can add and adjust stitch angles, a property unique 
to embroidery objects. You can also change the entry and exit points of 
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individual objects which is important if you are digitizing manually or 
resequencing embroidery objects. See Reshaping Objects for details.

Optimizing stitch quality
When it comes to embroidery production, the current stitch density may 
not be perfect for certain fabrics or threads. Or you may want to make 
production cheaper by reducing overall stitch count. After scaling 
operations, for example, designs may contain small stitches which can 
damage fabric and cause thread or needle breakage. Sharp corners may 
cause stitch bunching which can create hard spots in the embroidery and 
damage fabric or needle. Embroidery machines have a maximum 
possible stitch length which is determined by the physical frame 
movement. If long Satin stitches exceed this, they are broken into 
smaller stitches. EmbroideryStudio helps you resolve these issues with a 
number of specialized techniques for optimizing stitching quality for 
different design types and production requirements. See Optimizing 
Stitch Quality for details.

Editing stitches & machine functions
EmbroideryStudio automatically generates stitches from design outlines 
and properties. This means you can scale, transform, and reshape native 
designs without compromising stitch density or quality.
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However, EmbroideryStudio also lets you edit 
individual stitches. You may need to do this, 
for example, when working with ‘stitch’ files 
which do not contain outline data. Like 
stitches, machine functions are inserted 
automatically whenever you digitize objects 
and specify object properties. They are stored 
with the embroidery object and updated 
whenever it is modified. However, 
EmbroideryStudio also lets you manually 
insert machine functions and modify them. 
This flexibility allows you to adapt designs to almost any machine 
requirement. See Stitches & Machine Functions for details.

Advanced digitizing

EmbroideryStudio provides specialized productivity features as well as 
special effects and digitizing techniques.

Productivity techniques
Specialized digitizing features help to save digitizing time. 
EmbroideryStudio provides special input tools for circles, stars, and rings, 
as well as methods for creating repeated or ‘backtracked’ outlines. 
Remove underlying layers of stitching in overlapping objects to reduce 
stitch counts and prevent a build-up of stitches.

EmbroideryStudio also provides tools for quickly creating outlines based 
on existing filled shapes, and vice versa. Add decorative borders such as 
rectangles, ovals, and shields to designs or selected objects using the 
Borders library. See Productivity Techniques for details.
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Decorative stitch effects
EmbroideryStudio provides many 
artistic effects and stitch types to 
create textured and contoured fill 
stitching. Create designs with a 
hand-drawn appearance, something 
which is difficult to achieve through 
conventional digitizing methods. 
Create rough edges, shading effects, 
or imitate fur and other fluffy 
textures. Stippling provides a method 
for creating textured fills of run 
stitching which meanders more or less randomly within a border.
Vary stitch spacing between dense and open fill, producing shading and 
color effects which are difficult to achieve manually. Create interesting 
perspective, shading and color effects by blending two colored layers. 
Add cross stitching to fill large areas with low stitch counts. See Specialty 
Stitching for details.

Textured & patterned fills
EmbroideryStudio provides special tools for creating textured effects 
from needle penetrations. Apply offset fractions and partition lines to 
tatami fills to create split-line patterns. Alternatively, use Program Split 
or Flexi Split to create decorative fills from predefined patterns of needle 
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penetrations. Select from the library or create your own. See Patterned 
Stitching for details.

The Carving Stamp feature allows you to define a pattern of needle 
penetrations using a ‘carving stamp’ as a template. With User-Defined 
Split, create your own split lines when you want to add detail to filled 
objects. See Creating patterns with carving stamps for details.

Curved fills
Create interesting curved effects by shaping needle penetrations to 
follow the contour of digitized lines. EmbroideryStudio provides a variety 
of techniques to create curved fills. 

Contour is a curved fill stitch type – stitches follow the contours of a 
shape, creating a contoured, light and shade effect. Flexi Split is a 
decorative effect where one or more lines of a program split pattern are 
used in the object fill. Radial Fill generates radial turning stitching in 
several stitch types such as Satin and Tatami stitch. Use Florentine 
Effect or Liquid Effect to create interesting curved effects by shaping 
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needle penetrations to follow the contour of digitized lines. See Curved 
Stitching for details.

Motif runs & fills
Motifs are predefined design elements, such as hearts, leaves or border 
patterns. They generally consist of one or more simple objects, and are 
stored in a special motif set. The EmbroideryStudio Motif tools allow you 
to use motifs to create ornamental runs and textured fills. Use the ones 
provided with the software or create your own. Motifs can be scaled, 
rotated and mirrored in the same way as other objects. You can even use 
them to create interesting three dimensional effects. See Motif Stitching 
for details.

Embroidery lettering

Create top-quality lettering quickly and simply. EmbroideryStudio 
provides a large range of scalable closest-join font styles and multi-color 
and fancy fonts to choose from.

Creating embroidery lettering
Create high-quality embroidery lettering quickly and simply. 
EmbroideryStudio provides a large range of scalable fonts to choose 
from. Add embroidery lettering directly to designs or convert from 
CorelDRAW Graphics. Apply formatting just like a word processor, 
including italics, bolding, and right/left justification. Change values for 
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the whole text or individual letters. See Creating Embroidery Lettering for 
details.

Editing embroidery lettering
EmbroideryStudio gives you interactive and precise numeric control over 
many settings affecting lettering objects. Adjust both individual letters 
and lettering objects as a whole. Apply horizontal, vertical, and curved 
baselines. Modify baseline type, length, radius and angle, as well as 
position. You can even define the rotation angle of letters relative to the 
baseline or the design itself. See Editing Embroidery Lettering for details.

Advanced lettering techniques
Add special characters and symbols to 
your lettering. By default, lettering 
objects are filled with Satin stitch. Apply 
other basic fill stitch types as with all 
embroidery objects.
Specify the sequence in which letters are 
stitched to minimize registration 
problems. The automatic kerning feature 
improves lettering appearance and 
legibility by fine-tuning spacings between 
character pairs.
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Alternatively, fine-tune letter spacing according to the number of 
characters per object. This is particularly useful with Asian fonts. 
Lettering appearance and quality can be improved with the correct 
underlay. See Advanced Embroidery Lettering for details.
Apply Lettering Art effects to make letters bulge or arch, stretch or 
compress. Many styles are available from the Lettering Art gallery. You 
can fine-tune preset shapes as preferred. Edit lettering text in envelopes 
the same way as normal lettering. See Creating special effects with 
lettering art for details.

Team lettering
The Team Names feature lets you create designs with multiple names. 
For example, you can use the same logo with different names for sports 
teams or corporate uniforms, without having to create multiple copies of 
the same design. Names are stored in lists that can be accessed from any 
design. You can add to these lists, or remove names at any time.

Depending on how you want to stitch out, you can choose to save and 
stitch names and designs separately, or together. See Team Names for 
details.

Monograms
A monogram is a design composed of one 
or more letters, typically the initials of a 
name, used as an identifying mark. The 
Monogramming feature offers a simple 
way to create personalized monograms 
using a selection of predefined monogram 
styles, border shapes and ornaments, 
together with a set of tools to help you 
place these elements in creative and 
decorative ways. See Monogramming for 
details.
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Custom fonts
Turn any TrueType font installed on your system into an embroidery font. 
The automatic kerning feature improves lettering appearance and 
legibility by fine-tuning spacings between character pairs. Sometimes 
you find that you want to reshape a letter to improve its appearance, 
perhaps to suit a particular lettering height. EmbroideryStudio lets you 
save the letter as an alternative version. In fact you can save multiple 
versions of the same letter within the same font. You can even create 
your own custom fonts or modify an existing font for special applications. 
Even merge letters from two or more fonts. See Custom Lettering for 
details.

Mixed decoration

EmbroideryStudio provides support for various multi-decoration 
techniques, including print.

Appliqué digitizing
Automatically create all the stitching you need 
for appliqué using the Appliqué tool. Up to four 
layers of stitching – guide runs, cutting lines, 
tack stitches and cover stitches – can be 
generated for any appliqué object, depending on 
current settings. You can also extract appliqué 
shapes from a design to output to a cutter or 
separate file. See Appliqué Embroidery for 
details.
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Sequin digitizing
Some embroidery machines are equipped with a 
sequin dispenser that drops sequins onto the garment 
as it stitches. EmbroideryStudio allows you to digitize 
sequined designs for compatible machines. A 
dedicated set of sequin tools lets you digitize sequin 
fills, outlines, or individual sequin drops.
EmbroideryStudio also supports the creation of 
twin-sequin designs for twin-sequin-capable 
machines. EmbroideryStudio also provides a 
dedicated tool for automatically converting sequin 
artwork in the form of a vector file to sequin runs. See 
Sequin Embroidery for details.

Bling digitizing
Bling refers to decorative objects placed on garments 
or templates, either on their own or in combination 
with other design elements. Bling is supplied in varying sizes, shapes, 
colors and materials. It goes under various names such as diamante, 
rhinestones, eyelets, ribbons, charms, crystals, glitz, nailheads, studs, 
etc.

EmbroideryStudio lets you create bling and embroidery multi-decoration 
designs with the Bling toolset. This tool lets you create and visualize 
bling embellishments in combination with other decorative elements. See 
Bling Digitizing for details.

Chenille digitizing
EmbroideryStudio provides an option to add special chenille embroidery 
capabilities to a lockstitch embroidery digitizing system. These Chenille 
features include chenille embroidery machine formats, stitch types and 
effects, as well as chenille-specific object properties. Chenille can be 
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added to all levels of product. See separate Chenille Supplement for 
details.

Multi-decoration export
The Multi-Decoration File Export (MDFE) capability allows you to 
export the different file formats involved in a multi-decoration design 
production with a single command option. The system recognizes 
whether a design element is embroidery, graphics, appliqué, or bling. It 
displays each element in an export dialog with a list of corresponding file 
types to choose from. See Exporting multiple decoration files for details.

Files, machines, & design processing

Design processing and encoding involve all the important, back-end 
operations of embroidery design and manufacture. This is where you 
actually output your designs to machine, disk, printer, cutter, and so on. 
For this, you will need an understanding of embroidery file types as well 
as different machine formats. Depending on your setup, you will also 
need an understanding of traditional storage media such as embroidery 
disks.
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Printing designs
From the same design file, you can output a production worksheet for the 
embroidery machine operator. Designers frequently want to distribute 
their designs for viewing in real colors, in TrueView™ or otherwise, with 
or without fabric or product backgrounds. EmbroideryStudio allows you 
to customize information in the format you require for production 
worksheets and/or approval sheets. You can specify the data to print, 
graphics to include, zoom factor, and general options such as company 
name. You can use a color printer or plotter to produce your worksheets. 
See Design Reports for details.

Outputting designs
You can output embroidery designs for actual stitchout in a variety of 
ways – sending directly to machine for stitching, or saving to specific 
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machine formats and/or to embroidery disk. See Embroidery Output for 
details.

Reading files of different formats
By default EmbroideryStudio saves to its native file format, EMB. This 
format contains all information necessary both for stitching a design and 
for later modification. When opening designs created or saved in other 
formats, EmbroideryStudio converts them internally to EMB format. They 
can then be modified using the full range of EmbroideryStudio features. 
Depending on the file type, you may need to provide additional 
information to assist EmbroideryStudio in the conversion process. See 
Machine Files for details.
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Hooping designs
Devices made from wood, 
plastic, or steel, hoops are used 
to tightly grip fabric and 
stabilizer between an inner and 
outer ring. Designed to hold 
fabric taut against the machine 
bed for embroidering, they 
attach to the machine’s frame. 
Fabrics must be hooped before 
stitching out on the machine. 
EmbroideryStudio allows you to 
select from a wide range of 
standard factory-supplied hoops. 
If you are using a hoop which 
does not appear in the hoop library, you can define your own from scratch 
or based on a standard hoop. See Design Hooping for details.

Machine formats
Different embroidery machines speak different languages. They have 
their own control commands for the various machine functions. Before 
you can stitch a design, it must be in a format which can be understood 
by the embroidery machine. When you select a machine format, 
EmbroideryStudio uses it to translate digitized designs into a specific 
machine-readable form. If required, you can customize machine formats 
to meet specific machine requirements. See Machine Formats for details.
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Hardware & software setup

In order to work with your particular equipment, EmbroideryStudio needs 
to be properly configured. You may also want to configure the software 
to your particular design requirements.

Setting up hardware
You will need to connect peripheral devices for use with 
EmbroideryStudio. These may include digitizing tablets, plotters, 
printers, appliqué cutters, scanners and embroidery machines. Different 
devices are set up in different ways – some in MS Windows®, via the 
Control Panel, others within EmbroideryStudio itself. See Hardware 
Settings for details.

Changing system settings
EmbroideryStudio lets you adjust various system settings controlling the 
appearance of designs on screen, display of design information, the 
behavior of the Design Window, and other settings. See System Settings 
for details.

Managing designs with Design Library

EmbroideryStudio comes equipped with its own built-in Design Library 
for managing your embroidery designs across your entire local network. 
Use it to browse design and artwork files stored on your local PC or 
company network. Design Library capabilities make it fast and practical 
for daily commercial use, avoiding the need to switch to and from File 
Explorer. It recognizes all file formats used by EmbroideryStudio. It also 
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makes it easy to search, sort and browse all embroidery designs on your 
network.

In a nutshell, Design Library lets you:
 Search for designs – including artwork files – anywhere on your local 

hard drive, network drives, or external devices such as USB or ZIP 
drive.

 Preview design information in the preview pane.
 Search for designs by various means, including known design 

information.
 Create an organizing structure for easy categorization.
 Batch-convert selected design files to all commercial embroidery 

formats such as DST, EXP, SEW, and others.
 Print selected designs or send them to embroidery machine for 

stitchout.
 Use Design Library to handle job orders.
Find embroidery designs anywhere on your hard drive or external storage 
device and, optionally, add them to your embroidery library. This section 
describes how to open and view designs in Design Library as well as 
adjusting viewing settings. It also covers browsing for and accessing 
designs in folders. See Design Management for details.
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Note: Design Library helps you manage designs in folders. It is not a 
multi-user database for company-wide design management. For this type 
of requirement, refer to the DesignWorkflow User Manual.
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PART I
OBJECT-BASED EMBROIDERY

Embroidery design with EmbroideryStudio consists of turning basic 
artwork shapes into embroidery designs. EmbroideryStudio gives you the 
flexibility of creating embroidery objects using artwork as backdrops, or 
of directly converting digital artwork. You can take a mixed mode 
approach as well, doing the bulk of the design by means of automatic 
conversion, followed by touch-ups and edits using the suite of 
EmbroideryStudio embroidery digitizing tools.

Basic procedures
This section describes how to open EmbroideryStudio and start using the 
commands and tools. It also explains how to open designs as well as 
create new ones. It describes how to display the grid and rulers, and 
measure distances on screen. And it also covers how to select machine 
formats for different output. See Basic Procedures for details.

Viewing designs
This section explains design viewing modes as well as the various design 
viewing settings, including design colorways. Techniques for viewing the 
stitching sequence are described as well as how to selectively view design 
color blocks. Viewing design information, including production 
worksheets, is also covered. See Viewing Designs for details.

Threads & charts
This section describes how to select colors from the Color toolbar as well 
as how to assign threads to the colors in your design. How to modify 
thread charts is also covered, as well as creating custom thread charts. 
See Threads & Charts for details.
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Chapter 3

Basic Procedures

EmbroideryStudio software is an MS Windows®-based product 
incorporating many of the conventions with which most PC users are 
already familiar. EmbroideryStudio integrates with CorelDRAW® 
Graphics Suite into a single application, allowing users to create, not just 
embroidery, but true, multi-decoration designs. 

Operating modes

Open EmbroideryStudio using the desktop icon or the MS Windows® 
Start menu. The application has one workspace or ‘design window’ but 

Double-click to start EmbroideryStudio.
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you interact with it in different operating modes. These can be accessed 
via the Modes toolbar.

The main modes you’ll be accessing are:

Caution: You need to calibrate your monitor so that designs at 1:1 scale 
appear at real size. Do this when you first install EmbroideryStudio or 
whenever you change your monitor. See Calibrating the monitor for 
details.

Home screen

The Home screen loads when EmbroideryStudio starts, offering you 
quick access to recently opened designs, as well as value-add content, 
including tutorial videos and the latest Community Forum and Product 
Blog posts. You can also browse ‘My Wilcom’ which provides details of 

Mode Function

Home With this mode you can return to the Home screen to access new 
designs, or access tutorials and other product information.

Wilcom 
Workspace

This mode allows you to create and edit embroidery objects 
using an embroidery digitizing toolset.

CorelDRAW 
Graphics

This mode allows you to create and edit vector objects using the 
CorelDRAW® Graphics Suite toolset.

Design Library This mode allows you to manage designs and job orders.

Switch between 
operating modes

Click Mode > Home to return to the Home screen to get started with a new 
design, or access tutorials and other product information.
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your Wilcom license, including product level, version, as well as any 
compatible or enabled Elements.

Tip: You can deactivate the Home screen from running on startup via the 
Options dialog. See Other general options for details.

Related topics...
 Open designs
 Create designs from templates

Wilcom Workspace window

When you open EmbroideryStudio, it appears by default in Wilcom 
Workspace window with a new, blank design displayed. This mode 
allows you to create and edit embroidery objects using the embroidery 
digitizing toolset. The screen image below shows the more prominent 

Use Mode > Wilcom Workspace to digitize and edit embroidery designs. 
Display embroidery as well as artwork. View designs realistically in 3D 
simulation.
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toolbars in EmbroideryStudio. Depending on your product level, you will 
have access to some or all of these options.

Use this mode when you want to create embroidery from digitizing 
‘backdrops’. Various types of image file can be loaded in 
EmbroideryStudio. Wilcom Workspace also offers a graphical 
representation of what the final embroidery will look like. Use 
TrueView™ together with a background fabric to see how your design 
will look when stitched out. Some of the more prominent Wilcom 
Workspace interface elements include:

Menu bar

Status / Prompt bars

Mode tools

Standard tools

Object properties
docker

Color tools

Docker tabs

Design window

View tools

Toolbox

‘Floating’ toolbar

Stitch Effects tools

Stitch Types tools

Graphic style and
traditional input

methods

Design tabs

Element Description

Menu bar This contains the application menus such as File, Edit, View, etc.

Mode toolbar This contains tools and icons which are visible in both Wilcom 
Workspace and CorelDRAW Graphics.

Standard 
toolbar

This contains commonly used tools and commands which are 
specific to and only visible in Wilcom Workspace.

View toolbar This contains commands for viewing embroidery designs – e.g. 
as design outlines, by stitches, by machine functions, as they will 
stitch out on the fabric – either separately or in combination. 
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 Customize the design window by showing or hiding the grid, changing 
the grid dimensions, as well as showing and hiding toolbars. 

 Dock or ‘float’ toolbars and dockers in any configuration that suits. 
Toolbars are dockable left, right, top and bottom, and can be ‘floated’ 
anywhere in the design window.

  EmbroideryStudio allows you the choice of large or small button icons 
with or without text names.

Related topics...
 Change backgrounds
 Toolbar display options
 Access object properties
 Display grids, rulers & guides
 Quick reference

Stitch Types 
toolbars

This contains tools which determine the stitch types which can 
be applied to embroidery objects, including Satin, Tatami, Motif 
Fill, etc. 

Stitch Effects 
toolbar

This contains tools for modifying or improving stitch quality, 
including applying automatic underlay to selected objects. 

Toolboxes Depending on the product model, there are up to three 
‘toolboxes’ – Toolbox, Graphics Digitizing, and Traditional 
Digitizing. Between them, toolboxes contain all the embroidery 
digitizing/editing tools specific to and visible only in Wilcom 
Workspace. 

Color toolbar This contains the embroidery color palette which is specific to 
and visible only in Wilcom Workspace. 

Status / Prompt 
bars

These contain current status information and prompts which are 
visible only in Wilcom Workspace. See below.

Docker Wilcom Workspace includes ‘dockers’ – Object Properties, 
Color-Object List, Color Palette Editor, and others. These stay 
open as long as you need them. 

Design Window This contains the main work area where you create and edit 
embroidery objects as well as graphics objects when you switch 
to CorelDRAW Graphics.

Element Description
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Design tabs
EmbroideryStudio allows you to switch between open designs by means 
of design tabs. This also makes it easy to copy/paste between designs, 
including drag and drop operations. 

Related topics...
 Set up multiple views
 Quick reference

Status & Prompt bars
The Status and Prompt bars at the bottom of the Wilcom Workspace 
design window provides continuous display of current cursor position 
status as well as instructions for use of selected tools.

Information includes:

Design tabs

Stitch type and 
current settingsStitch count

Coordinates of current
needle position

Status Bar

Prompt Bar

Length and angle of 
current stitch

Current object
Selected auto

fabric

Current machine function Current hoop

Item Details

Prompt Guides you through use of selected functions.

Stitch count Total number of stitches in design.

Design size Width and height.

Coordinates Coordinates of current needle position (X/Y), and length (L) and 
angle (A) of current stitch. 
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Related topics...
 Pointer position display
 Change fabrics

CorelDRAW Graphics window

CorelDRAW Graphics window includes the entire suite of CorelDRAW® 
Graphics Suite drawing tools. This mode allows you to create and edit 
vector graphics using the CorelDRAW Graphics toolset which offers 
many sophisticated techniques for drafting outlines and shapes onscreen.

Current fabric Fabric settings take into account the type of fabric you are stitching 
on.

Item Details

Use Mode > CorelDRAW Graphics to import, edit or create vector artwork 
as a backdrop for embroidery digitizing, manual or automatic.

In Graphics mode, click Mode > Show Embroidery to show or hide 
embroidery components.

Menu bar

Status bar

Toolbox

Mode toolbar

Standard toolbar

Properties bar

Design window

Docker



Chapter 3   Basic Procedures 58

In addition to the CorelDRAW® Graphics Suite toolset, CorelDRAW 
Graphics provides capabilities to convert vectors and vector text directly 
to embroidery objects. Imported vector graphics or created text can be 
converted directly to embroidery designs. You can use CorelDRAW 
Graphics to insert or paste third-party vector graphics such as clipart for 
use in embroidery designs. Alternatively, insert, paste or scan bitmap 
artwork for use as digitizing templates or ‘backdrops’. Here are some of 
the prominent CorelDRAW Graphics interface elements.

For a detailed description of the CorelDRAW® Graphics Suite interface, 
refer to the electronic User Guide available via the MS Windows® Start 
> Programs group. Alternatively, use the online help available from the 
Help menu.

Note: CorelDRAW® needs to be registered before it can be used by 
EmbroideryStudio. Registration provides CorelDRAW® Standard 
Membership which gives you access to content – clipart, fonts, stock 
photos, templates – via Corel CONNECT. It also gives you access to the 
latest CorelDRAW® updates.

Related topics...
 Loading bitmap artwork

Element Description

Menu bar This contains application menus such as File, Edit, View, etc.

Mode toolbar This contains the universal tools and icons which are visible in 
both Wilcom Workspace and CorelDRAW Graphics windows.

Standard toolbar This contains commonly used tools and commands which are 
specific to and only visible in CorelDRAW Graphics.

Properties bar This contains the commands and controls that relate to the 
active tool in the Toolbox or active object in the design window 
in CorelDRAW Graphics.

Toolbox This contains the drawing/editing tools specific to and visible 
only in CorelDRAW Graphics.

Design window This contains the main work area where you create and edit 
graphics objects as well as embroidery objects when you switch 
to Wilcom Workspace.

Color palette This contains the graphics color palette which is specific to and 
only visible in CorelDRAW Graphics.

Docker In CorelDRAW Graphics, this contains graphics-specific 
dockers.

Status bar This contains current status information visible only in the 
CorelDRAW Graphics.
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 Convert objects with CorelDRAW Graphics

Design library

Design Library is a design or job order management tool. Use it to 
browse design and artwork files stored on your local PC or company 
network. Design Library capabilities make it fast and practical for daily 
commercial use, avoiding the need to switch to and from File Explorer. 
It recognizes all file formats used by EmbroideryStudio.

Design Library is installed with sample designs in EMB format. These 
show various stitching techniques and effects, including 
‘multi-decoration’ and multiple colorways. When starting out as a new 
user, make sure to spend time exploring these designs.

Related topics...
 Design Management
 Loading bitmap artwork

Click Mode > Design Library to open a window from which to search and 
manage designs and job orders.
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Toolbars & dockers

The EmbroideryStudio design window provides ‘dockers’ for key 
functions. Wilcom Workspace has docking panes for Color-Object 
List, Object Properties, Overview Window, and so on. All panes are 
dockable on either side of the design window.

Access toolbars

Toolbars provide quick and easy access to most EmbroideryStudio 
commands. Show or hide them at your convenience. As you get more 
familiar with the system, you may prefer menu and keyboard commands. 

To access toolbars
 Select Window > Toolbars or right-click the docking area at the top 

or left of the design window. The Toolbars menu opens.

 Click to activate one or many.

Related topics...
 EmbroideryStudio toolbars

Work with dockers

Select toolbars 
to display

Use Docker > Color-Object List to view and sequence design objects.

Use Docker > Object Properties to preset properties or adjust properties of 
selected objects.
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In Wilcom Workspace mode, there are three important dockers:

Access dockers via the Docker toolbar or Window menu. They can be 
docked on either side of the screen.

All dockers can be fixed or minimized. Dockers may also be ‘floated’ by 
dragging the caption bar to the design window or double-clicking it when 

Use Docker > Colorway Editor to assign thread colors to color palette and 
define colorways.

Docker Description

Object 
Properties

The most important is the Object Properties docker. Use it 
together with the Property Bar to access properties of selected 
embroidery objects. 

Color-Object 
List

The Color-Object List offers an easy way to selectively view and 
resequence color blocks and objects. 

Colorway 
Editor

When you create a new design, it includes a single default 
colorway called ‘Colorway 1’. The Colorway Editor allows you to 
edit default colors, add extra color slots as required, and set up 
additional colorways.

Access dockers via 
menu or toolbar



Chapter 3   Basic Procedures 62

‘pinned’ in place. Dockers can be ‘nested’ to increase available 
workspace. When nested, tabs for each docker appear down the side. 

Toggle Auto Hide next to the X close button. Docking panes 
automatically retract when not in use. By hovering the mouse over the 
tab, a minimized docker will ‘fly out’, allowing you to access its functions. 

Related topics...
 Access object properties
 View selected color blocks
 Colorways

Access object properties

Hover docker over 
title bar of another

Click tab to 
view docker

Click and drag tab 
to float docker

Enable/disable
auto-hide

Close 
docker

Double-click title bar to
return to docked state

Use Docker > Object Properties to set properties of selected objects.
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The most important docker is Object Properties. Use it together with 
the Property Bar to access the properties of selected embroidery 
objects.

To access object properties
1 Open the Object Properties docker by any of the following means:
 Click the Object Properties tool.
 Double-click an object in the design window.
 Right-click an object and select from the popup menu.
 Right-click an object in the Color-Object List and select from the 

popup menu.

2 Select a tab to access the properties to adjust. 
3 Adjust general properties – width, height, position – by means of the 

Property Bar. Press Enter to apply. Press Esc to discard changes.

Tip: You can specify units of measurement when entering values into 
a measurement control.

Related topics...
 Working with object properties
 Set measurement units

Object Properties tabs

Adjust settings as 
required

Click to close

Droplist

Adjust position and 
size settings. Press 
Enter to apply.
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Embroidery machine formats

Different embroidery machines speak different languages. They have 
their own control commands for the various machine functions. When 
you create a design, you need to select a format corresponding to the 
embroidery machine you intend to use. EmbroideryStudio uses the 
format to translate digitized designs into a specific machine-readable 
form. You don’t, however, need to change a design’s ‘native machine 
format’ in order to output to a different machine. If a selected machine 
format does not support a particular function in the design, it is simply 
ignored on output.

To select a machine format
 Select Design > Select Machine Format.

 Select the required machine format from the list.

Note: You can change the machine format itself if machine values do 
not correspond precisely to your particular machine. Or you can create 
a new format based on a selected one.

Related topics...
 Supported machine types
 Embroidery Output
 Machine Formats
 Selecting sequin mode
 Custom machine formats

Embroidery file formats

Embroidery designs are saved in one of two formats – ‘design’ (outline) 
or ‘machine’ (stitch) file format.

Select machine
format

Click to adjust 
settings

Click to create 
new format
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Note: For details of the formats supported by EmbroideryStudio, see 
Embroidery file formats.

Design files

Design files, also known as ‘all-in-one’ files, are high-level formats which 
contain object outlines, object properties and stitch data. When you open 
a design file in the software, corresponding stitch types, digitizing 
methods and effects are applied.

Design files can be scaled, transformed and reshaped without affecting 
stitch density or quality. After modification, you can choose to save your 
design to EMB format, or to a different format altogether.

Note: Some design files, such as Wilcom INP and Gunold PCH, contain 
incomplete information. Old format ESD designs are somewhere between 
an design file and a machine file. They contain stitch data, information 
about selected stitch types, densities, and machine functions. They do 
not, however, contain information about shapes and lines. ESD files 
require object/outline recognition if you want to perform object editing in 
EmbroideryStudio.

Related topics...
 Embroidery file formats
 Wilcom INP format
 Gunold PCH format

Embroidery objects with
outlines and stitch

properties
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Machine files

Different embroidery machines understand different languages. Each has 
its own control commands for the various machine functions. Before you 
can stitch a design, it must be in a format which can be interpreted by 
the machine. Machine or ‘stitch’ files are low-level formats for direct use 
by embroidery machines. They contain only stitch coordinates and 
machine functions. They are generally created on-the-fly when sending 
designs to machine. Or they are converted when saving to disk or 
memory stick.

Manual objects
When they are read into EmbroideryStudio, machine files do not contain 
object information such as outlines or stitch types, but present the design 
as a collection of stitch blocks called ‘manual objects’. Manual objects are 
created wherever machine functions – e.g. color changes or trims – are 
detected in the design. They have only general and connector properties. 
Manual objects, in turn, consist of individual stitches, called ‘manual 
stitches’.

Related topics...
 Opening machine files
 Using embroidery disks 
 Embroidery file formats
 Exporting designs for machine

File sources

While embroidery files are broadly classified as ‘design’ (outline) or 
‘machine’ (stitch), EmbroideryStudio internally tags files as belonging to 

Manual objects with no
outlines and manual

stitches only
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one of four types – native design (A), imported outlines (B), processed 
stitches (C), or imported stitches (D).

Native EMB designs as well as ART and JAN files are all ‘Grade A’ 
embroidery formats read and written by EmbroideryStudio. They are 
called ‘Grade A’ because they contain a complete set of design 
information in a single file – object outlines, properties, stitches, thread 
colors, thumbnail image, and comments. There are three other grades of 
embroidery file. It goes without saying that only Grade A files provide 
100% perfect scaling and transformation. 

Note: For information about the source of a design file, refer to the 
Design Information docker.

Related topics...
 View design details in EmbroideryStudio

Working with design files

EmbroideryStudio handles all commercial and home stitch file formats. 
In fact native EMB files are read and written by leading home embroidery 
systems. 

Grade Description

A Pure embroidery file created in EmbroideryStudio or similar software. 
These files contain objects, outlines and stitches.

B Designs read from an outline format such as GNC and saved in ART / 
EMB / JAN format. Such designs cannot be read directly by 
EmbroideryStudio but once converted, they are treated as Grade B 
designs.

C Designs read from machine files – EXP, DST, PES, etc – where stitches 
have been converted to objects.

D Designs read from machine files where stitches have NOT been 
converted to objects.
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Whenever you start EmbroideryStudio, a new file – Design1 – is 
automatically created. By default, Design1 is based on the NORMAL 
template. Templates contain preset styles, default settings or objects, to 
make digitizing quicker and easier. EmbroideryStudio also provides a set 
of optimized fabric settings so that the software will take into account the 
type of fabric you are stitching on.

Open designs

EmbroideryStudio opens a comprehensive range of both ‘outline’ and 
‘machine’ files.

To open a design
 Click the Open Design icon.

 Navigate to the design folder. The dialog filter defaults to ‘Wilcom 
All-in-One’ designs which displays all native EMB design files. Adjust 
the filter as required...

Use Standard > Open Design to open an existing design.

Use Standard > Open Recent Designs to open a design from a list of 
recently opened designs.

Filter Files

All-in-one design 
files

All design files supported by EmbroideryStudio including 
JAN and ART.

Supported design
and machine files
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 Select a design or designs.
 To select a range, hold down Shift then select first and last.
 To select multiple items, hold down Ctrl and click.

Tip: For more information about a selected file, right-click and select 
Properties from the popup menu. 

 For file types other than EMB or ESD, click Options and adjust 
recognition options as preferred.

 Click Open.
 Optionally, select Design > Auto Fabric to apply preferred fabric 

settings.

 Whenever you want to work on a recently opened design, use the 
Open Recent Designs for quick access.

 If the Backup Copy option is active, a backup copy of the current 
design file is automatically created in its previously saved form. 
Access the backup folder via the File > Open Backup Design 
command.

All machine files Filter by machine file format only. No design files.

All embroidery files All supported ‘design’ and ‘machine’ files.

Filter Files

Choose a fabric 
type

Tick to
activate

Quickly access any 
recently opened 
designs
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Tip: You can also open designs from proprietary embroidery disks, or 
read them from paper tape.

Related topics...
 Automatic save & backup options
 Viewing design information
 Working with fabrics
 Using embroidery disks
 Embroidery file formats
 Embroidery file formats

Create designs from templates

Templates are special files used to store styles, default properties, as well 
as fabric settings. Although the NORMAL template settings are suitable 
for a range of fabrics, selecting an auto fabric further adjusts settings.

To create a design based on a template
1 Select File > New from Template or, holding down the Shift key, 

click New Design. The New from Template dialog opens.

Use Standard > New Design to start a blank design based on the currently 
selected template. Hold down Shift and click to open New from Template 
dialog.

Choose a 
template

Activate auto fabrics 
and choose a target 
fabric

Set background 
color and swatch

Choose a target 
machine format

Save as
default
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2 Select a template from the droplist. When you create a file based on 
a template, its settings are copied to the new design.

3 If you want, additionally, to use fabric settings, tick the checkbox. 
From the droplist, choose a fabric type nearest the one you intend to 
work with.

4 Optionally, choose a background to match the selected auto fabric.
5 Choose a target machine from the droplist. You normally decide which 

machine format to use before you start. However, formats can be 
changed at any time.

Tip: You can customize or add formats to suit the target machine.
6 Click OK to accept. A blank design opens in the design window based 

on the selected template. Settings will apply to all newly created 
embroidery objects. Any selected fabric is displayed in the Status Bar. 

Tip: The New from Template option is activated by default. Turn it 
off if you prefer work without predefined fabric settings.

Related topics...
 Working with templates
 Working with fabrics
 Other general options
 Machine Formats

Save & close designs

The Save Design option allows you to save a design to the latest native 
EMB ‘all-in-one’ format. To save designs to previous formats, choose File 
> Save As.

Use Standard > Save Design to save the current design. Right-click to open 
the Save As dialog.

Choose an output 
file format
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Native EMB files contain a complete set of design information in a single 
‘all-in-one’ file – object outlines and properties, actual stitches and 
machine functions, thread colors, a picture icon, summary information, 
and more. Even the original design bitmap image can be included in EMB 
format. Only native EMB files provide 100% perfect scaling and 
transformation. EmbroideryStudio lets you save designs in various native 
EMB formats. This can be important if your suppliers or clients use 
previous versions of Wilcom software.

Caution: If a design feature is not available in the selected file type, it 
will be converted. For example, Flexi Split stitching may be changed to 
plain tatami. If the design contains a bitmap using a color depth 
unsupported by the selected file type, it will be removed from the 
resulting file.

Closing designs
To close designs, use the commands in the File menu to close open 
designs individually or all together. Alternatively, use the design tabs to 
close open designs.

Design thumbnail display
Design thumbnails reflect display settings at the time of saving. When a 
design is saved, the design thumbnail is generated using all visible 

Design tabs – 
click X to close

Close current or 
all open designs
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objects as well as the current design background. If you have bitmap or 
vector display turned on, these too appear in the thumbnail. 

Related topics...
 Exporting designs for machine
 View embroidery components
 Using embroidery disks
 Machine Formats
 Embroidery file formats

Send designs as email attachments

You can attach designs to emails from the design window or via the Open 
Design dialog.

To send designs as email attachments
 With the design open in the design window, select File > Send via 

Email.
 Alternatively, click the Open Design icon. Select the file to send, then 

right-click it. The popup menu appears. Select Send To > Mail 
Recipient.

Use Standard > Open Design to send a design as an email attachment.
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Your default email system is launched and a new email created with 
the design file attached.

 Enter mailing details and send.
 Optionally, to output a design as a bitmap, select File > Capture 

Design Bitmap.

Related topics...
 Outputting designs as images

Select Send To > 
Mail Recipient

Select output 
option



EmbroideryStudio e4 Reference Manual 75

Selecting objects

EmbroideryStudio provides various ways to 
select embroidery objects. It supports point 
& click, selection marquee and multiple 
object selection. The Color-Object List 
provides an easy way to select objects and 
colors and access their properties.

Tip: Depending on your background, you 
can change display colors for unsewn 
stitches, selected objects, object outline, 
grid and guides. See also Change display 
colors.

Related topics...
 Select objects with selection tools
 Select objects with Color-Object List

Select objects with selection tools

Use selection tools to select individual objects as well as groups or ranges 
of objects.

Use Select > Select Object to select individual objects as well as groups or 
ranges of objects.

Use Select > Freehand Select to select object at current by drawing a 
freehand line. 

Click Select > Polygon Select to select objects with a selection marquee.

Click Select > Polyline Select to draw a line through the object to select.
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To select objects
 The simplest way to select an object is to point and click with the 

Select Object tool activated. Selection handles appear around 
selected objects.

 To select multiple items, hold down Ctrl as you click. To select a range, 
hold down Shift as you click. 

 Alternatively, drag a selection marquee around the objects you want 
to select.

 Where you have a mixture of objects – outline, closed-fill, open-fill – 
click through holes or gaps to select objects beneath.

 Alternatively, use the Freehand Select tool to draw a freeline around 
the object/s you want to select. Press Enter to close.

Click first object Hold down Ctrl and 
click another object

Ctrl + Hold down Shift and 
click last object

Shift +

OR

Drag a selection marquee 
around objects to select

Draw a freeline 
around object/s to 
select
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 Alternatively, use the Polygon Select tool to mark reference points 
around the object/s you want to select. Press Enter to close.

 Or use Polyline Select to mark two or more reference points to 
create a line touching all objects you want to select.

 To select an object which is sitting behind another filled object, hold 
down the 2 key and click until the underlying object is selected.

 To select all objects, select Edit > Select All or press Ctrl+A. 
Selection handles appear around the entire design.

 Deselect objects by any of the following means:
 To remove an object from a selection, hold down Ctrl and click.
 To deselect all, click an empty area of the background or a different 

object.
 Alternatively, press Esc or X to deselect all or select Edit > 

Deselect All.

Tip: EmbroideryStudio also provides a method for you to select 
individual objects within grouped objects. See Select objects within 
groups for details.

Select objects with Color-Object List

The Color-Object List offers an easy way to select objects and 
selectively view them. It is synchronized with the design window, 
dynamically updating whenever you edit.

Mark reference 
points around 
object/s to select

Mark two 
reference points

Use Docker > Color-Object List to toggle the Color-Object List on/off. Use 
it to view and sequence objects in a design.
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To select objects by Color-Object List
 Click the Color-Object List icon to open the docker. A separate icon 

for each color block and each object in the design appears in order of 
stitching.

 Click a ‘node’ to open or close a color block and see its components.

 Click an icon to select a color block and/or individual objects.
 To select a range of items, hold down Shift as you click.

Total objects in 
design

Total color block 
count

Object icon

Click to
open/close all

color block nodes

Click to open/close
individual color

block node

Blue border
appears around
selected objects

Right-click any 
object or color block, 
and Select All
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 To select multiple items, hold down Ctrl as you click.
 To select all items, right-click and choose Select All from the popup 

menu.
 To deselect, click away from the design.

Note: You can also use the Color-Object List to group and lock 
objects as well as cut, copy and paste, resequence, and branch 
objects. See Combining Objects for details.

Measurements

EmbroideryStudio provides a set of grid lines to help accurately align or 
size embroidery objects.

Display grids, rulers & guides

Use grid lines to help accurately align or size embroidery objects. Default 
grid spacing is 10mm x 10mm. Invoke rulers to accurately position and 
scale objects. The unit of measurement – mm or inches – defaults to the 
regional settings in the MS Windows® Control Panel.

To display grids, rulers and guides
 Click the Show Grid icon or press Shift+G. Right-click for settings. 

You can change grid spacing, select a reference point and turn Snap 
to Grid on or off in the Options dialog.

Click View > Show Grid to show or hide the grid. Right-click for settings.

Click View > Show Rulers and Guides to show or hide rulers and guides. 
Right-click for settings.

Drag the ruler zero point to reset a new ruler zero point.

Show Grid
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 Click the Show Rulers & Guides icon or press Ctrl+R.

 Reset the ruler zero point by clicking and dragging the button in the 
top left-hand corner of the ruler.

 To create a guide, click either ruler – horizontal or vertical – and 
click-and-drag it into position. Multiple guides can be created and just 
as easily removed.

 For more accurate positioning of guides, double-click the yellow 
handle. In the Guide Position dialog, enter a precise distance from 
zero point and click OK.

 To remove a guide, drag the yellow guide handle off the design 
window.

Click-and-drag to
reset ruler zero

point

Click-and-drag to
reposition guides

Click ruler to
create new guide

Drag guide off
ruler to remove

Enter precise offset 
from zero point
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 Optionally, turn on the Snap to... feature via the Options dialog.

 You can also change the color of grid and guidelines via the 
Background & Display Colors dialog.

Related topics...
 Grid display options
 Change display colors
 Selecting hoops manually

Set measurement units

The first time you run EmbroideryStudio, the measurement system will 
default to whatever the operating system is using. However, you can 
change measurement units from within EmbroideryStudio. 

Note: Technically, when you select ‘U.S.’, you will get the imperial 
measurement system – inches, feet, and yards. Inch rulers are displayed 
in 1/16, 1/8, ¼, ½, and 1" divisions. The grid size can be set in decimal 
inches.

Select to
display grid

Select to snap
design points

to grid

Show rulers
and guides

Select desired 
measurement unit
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Ripple-on effects
Changing the measurement system will change the units used by most 
controls.

Relevant fields also appear in the selected unit of measurement – e.g. 
Design Information docker as well as Production Worksheet.

There are, however, exceptions to this rule: 
 Stitch List: this used to be displayed in inches for U.S. systems. But 

these are stitch lengths, so must always be in mm.
 Stitch length and density controls remain in mm regardless of 

measurement system. These controls reflect the machine functions as 
industrial machines are always in millimeters.

Measurement 
units display

Selected 
measurement unit 
displayed

Stitch length and 
density controls remain 
in mm
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Specify measurement units on-the-fly
Alternatively, you can specify units of measurement when typing values 
into a measurement control. EmbroideryStudio automatically converts 
the value. 

For example, if a US customer orders lettering in inches – say ¾" – and 
the digitizing is to be done in metric, you can enter ‘3/4in’ or ‘3/4 in’ into 
the Lettering Height field and it is automatically converted to 
19.05mm.

Note: EmbroideryStudio supports both proper and improper fractions – 
e.g. ‘1 1/3’ as well as ‘4/3’. It does not, however, support mixed units – 
e.g. 1’3". Nor does it display values as fractions after they are entered, 
only during.

Supported units
Supported units include:
 millimeters, mm 
 inches, in
 feet, ft
 yards, yd 
 centimeters, cm 
 meters, m 

Tip: EmbroideryStudio also allows entering units in text form, both 
English and the language the software is currently running in.

Related topics...
 Grid display options
 View design details in EmbroideryStudio
 Create lettering with object properties
 Select stitches with the Stitch List
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Measure distances on screen

Measure the distance between two points on screen using the Measure 
command. View measurements in the Status bar or tooltip.

Tip: For more accurate results, zoom in before you measure. The 
measurement is always the actual size, and is not affected by the zoom 
factor.

To measure a distance on screen
1 Select View > Measure or press M and click the start point.
2 Move the pointer to the end point and hold the mouse still. If 

activated, length and angle measurements appear in a tooltip.

The following information displays in the Status Bar:
 Position coordinates of the end point (X=, Y=)
 Length of the measured line (L=)
 Angle of the line relative to the horizontal (A=).

Measurements are shown in millimeters or inches according to 
selection.

3 Press Esc again to exit the command.

Related topics...
 Other general options

Measurements 
appear as tooltip
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Chapter 4

Viewing Designs

EmbroideryStudio provides many viewing features to make it easier to 
work with your design. Use zoom and pan functions to study design 
details. Toggle between ‘artistic’ and ‘technical’ views. You can also 
preview designs in different colors on different fabrics by means of 
‘colorways’.

EmbroideryStudio provides design information in various forms. Approval 
and production sheets provide essential information such as design 
previews, size, color sequence information and any special instructions.

Viewing design components

EmbroideryStudio provides many viewing modes to make it easier to 
work with your design. View a design at actual size or zoom in for more 
details. Pan across instead of scrolling, or quickly change between 
current and previous views.

Note: You need to calibrate your monitor so that designs at 1:1 scale 
appear at real size. Do this when you first install EmbroideryStudio or 
whenever you change your monitor. Go to Setup > Calibrate Screen.

View embroidery components

When you open an embroidery design in EmbroideryStudio, toggles on 
the View toolbar allow you to alternate between ‘artistic’ and ‘technical’ 
views. Use TrueView for presentation purposes. You can include it on 
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approval sheets, or capture it as a bitmap to send via email or publish to 
a website.

Use these toggles, singly or in combination, to focus on design details. 
For example, view design outlines, stitches, needle points, or even 
machine functions such as trims and tie-offs. You can also turn on 
connectors in stitch view. How you use the view options will depend 
largely on whether you are editing a design or checking for production 
readiness. 

Note: Design thumbnails reflect display settings at the time of saving. 
When a design is saved, the design thumbnail is generated using all 
visible objects as well as the current design background. If you have 
bitmap or vector display turned on, these too appear in the thumbnail. 
See also Save & close designs.

Shortcut keys
Available shortcut keys include:

TrueView Toggle between stitch view and TrueView™. T

Show Stitches Toggle embroidery stitching display. S

Show Outlines Toggle object outlines. L

Show Needle 
Points

Toggle needle points to select stitches for 
editing. . (period)

Design viewing toggles

Hover cursor for 
tooltips
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Tip: Depending on the design background, you can change display colors 
for selected objects, unsewn stitches, etc.

Related topics...
 View options
 Change display colors

View graphical components

Apart from embroidery, EMB designs may include other components such 
as bitmap images, vector graphics, appliqué fabrics, product backdrops, 
and rhinestones or ‘bling’. These can also be turned on or off as desired.

Show 
Connectors

Toggle connecting stitches to help position entry 
and exit points. V+C

Show Functions Toggle display of machine functions such as 
trims and tie-offs. V+F

View graphic elements,
including product images
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 Toggle the Show Bitmaps and/or Show Vectors icons to selectively 
view both vector and bitmap images.

 Click Dim Artwork to dim the onscreen image to view stitches more 
clearly when digitizing. The command applies both to bitmap and 
vector graphics.

 To lock an image in place, select and press K.
 Click the Show Appliqué Fabric icon to toggle display of appliqué 

fabric on/off.

Vector graphic together 
with bitmap image

Appliqué 
fabric On

Appliqué 
fabric Off
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 Use Show Bling to visualize any bling components present in a 
design.

 Use Show Functions to visualize any sequin components present in 
the design.

 Similarly, beading can be viewed while Show Functions is toggled on.

Tip: Depending on view options set in the Options dialog, images 
display in full color, or dimmed. 

Bling components 
in TrueView

Sequins in 
TrueView

Sequins 
turned off

Beading in 
TrueView

Beading 
turned off
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Related topics...
 Image viewing options
 Lock & unlock objects
 View options
 Bling Digitizing
 Sequin Embroidery
 Bead Embroidery
 Customizing design reports

Zoom & pan designs

Zoom tools allow you to magnify your view of the design by zooming in 
on individual stitches or details. The easiest way to zoom is via the mouse 
wheel. This defaults to 1.25x increments. The zoom factor can be 
adjusted in the Options > Scroll tab. Zoom tools are also available from 

Click Zoom > Zoom to invoke zoom mode. Zoom in or out via left and right 
mouse clicks, or drag a selection marquee to view design detail.

Click Zoom > Zoom 1:1 to display a design at actual size.

Click Zoom > Zoom to Fit to display the whole design in the design window.

Click Zoom > Zoom to Selected to magnify only selected objects.

Select Zoom > Zoom Factor from the droplist or key in a zoom factor 
and press Enter.
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the View menu and Zoom toolbar. Experiment with the available 
options.

Use shortcuts keys as indicated in the menus. For instance, to zoom in 
on a section of design, select View > Zoom or press B, and drag a 
marquee around the zoom area. To display the whole design, select View 
> Zoom to Fit or press 0.

Zoom tools available 
from menu and from 
toolbar

Drag selection marquee 
around area to zoom
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 To display stitches at a particular scale, select a zoom scale from the 
droplist or key in a zoom factor and press Enter. Alternatively, select 
View > Zoom Factor (or press F). In the Zoom Factor dialog, enter 
a scale as a fraction of the actual size, where ‘1’ = ‘100%’, ‘1.5’ = 
‘150%’, etc.

 To pan across a design, select View > Pan or press P and use the 
‘grabbing hand’ tool.

Related topics...
 Scroll options

Set up multiple views

EmbroideryStudio gives you multiple views of the same design. It also 
allows you to switch between open designs by means of design tabs. This 
also makes it easy to copy/paste between designs, including drag and 
drop operations.

Enter scale as
fraction of actual

size

Click and drag to pan 
across design
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To set up multiple views
 Use the Window menu commands to set up groups of tabs as 

preferred.

 Set up vertical or horizontal tabbed groups.

Use commands 
to set up tab 
groups
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 To create multiple views of a single window, use the Window > Split 
Window command. Adjust view settings for each pane.

 Use the Remove Tiling command to return the design window to 
normal display mode.

Tip: After certain operations you may need to refresh the screen for a 
clearer display. Select View > Refresh Screen or press R.

Work with the Overview Window

Double-click to 
remove split bars

Use Docker > Overview Window to toggle window display on/off. Use it to 
view a thumbnail of the design.
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Use the Overview Window to view a thumbnail of the design. Use it to 
pan and zoom the design when working at high zoom factors. Set view 
settings independently to the design window.

 To zoom in or out, click the Zoom button at the bottom of the window 
and drag a selection marquee around the area to zoom.

 To pan across the design, click and drag the zoom box.

Click for
zoom box

Drag selection 
marquee around 
area to zoom

Drag zoom box
to pan across

design



Chapter 4   Viewing Designs 96

 To change the view settings for the Overview Window, click it to 
make it the active window.

Related topics...
 View embroidery components

Viewing objects & color blocks

EmbroideryStudio provides many techniques for selectively hiding or 
viewing embroidery objects or color blocks. 

The Color-Object List offers an easy way to selectively view color blocks 
and embroidery objects. This is useful when re-sequencing. 

View selected objects

EmbroideryStudio provides many techniques for hiding or showing 
selected embroidery objects in the design window.

Click inside window 
to change view 
settings

Use Select > Select Object to select individual objects as well as groups or 
ranges of objects.

Use Docker > Color-Object List to toggle the Color-Object List display on 
and off. Use to view and sequence objects in a design.
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To view selected objects
 Select the objects you want to view.

 Press Shift+S. All other objects are hidden. They can be revealed 
again via the Color-Object List popup menu.

Select objects 
to view

Select to
unhide objects

All other
objects hidden
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 Alternatively, to temporarily hide other objects, select the object you 
want to view and click and hold the Locate button.

 To display the selected object full-screen, press Shift+0 (zero).
 To return to the previous view, select View > Previous View or 

press V.
 To re-display the entire design, press Esc followed by Shift+S.
 To redraw the screen, select View > Refresh Screen or press R.
 Optionally, select the Options icon in the Standard toolbar, or select 

Setup > Options > View Design tab, to toggle options for selective 
display of embroidery objects:

Options include:

Option Function

No change The display remains the same as before.

Show whole 
design

All embroidery objects in the design are visible.

Show selected 
objects

Only objects that are currently selected are visible.

Select object/s
to view

Click and hold to isolate
selected blocks

Select viewing 
options
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Related topics...
 Selecting objects
 Selecting objects by color or stitch type
 Sequencing embroidery objects

View selected color blocks

A color block corresponds to a color stop in the design. It may contain a 
single object or group of like-objects – e.g. ‘ropes’. Or it may be 
comprised of different objects of like-color – e.g. ‘ropes and birds’. The 
Color-Object List offers an easy way to selectively view color blocks and 
embroidery objects. The View by Color function also lets you view 
objects by color. The Colorway Editor provides another method for 
selective viewing of color blocks.

To view selected color blocks
 Click the Color-Object List icon. The Color-Object List can be 

docked to the either side of the design window, or floated in any 
position.

Show unselected 
objects

The reverse of the above option. Only objects that are 
currently ‘unselected’ are visible.

Hide whole design All embroidery objects in the design are hidden.

Option Function

Use Docker > Color-Object List to toggle the Color-Object List display on 
and off. Use to view and sequence objects in a design.

Use Color > Colorway Editor to assign thread colors to color blocks in the 
design.
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 Click the switch to view the list by color block.

 Select a color block or blocks and click Locate and hold.

Total color blocks, 
objects and 
stitches in design

Click to toggle
color blocks

Select color 
block/s to view

Click and hold to isolate
selected blocks



EmbroideryStudio e4 Reference Manual 101

 Selectively hide or ‘unhide’ selected color blocks and embroidery 
objects using popup menu commands.

 Alternatively, to isolate a color block in the design window, click and 
hold it in the Color toolbar. First press Esc to deselect all objects.

Use commands to 
selectively hide or 
show color blocks 
and objects

Click and hold with 
no objects selected
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 Alternatively, select View > View by Color. Select the colors you 
want to view. This function will not work with grouped objects.

 Alternatively, click the Colorway Editor. Select a color block and click 
Locate and hold.

 To reveal all hidden objects press Esc followed by press Shift+S or 
select View > View all Colors.

Related topics...
 Selecting objects

Select color 
blocks to view

Select color
block

Click and hold to 
locate selected 
color block
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 Combining Objects
 Sequence by color
 View selected color blocks
 Name design elements

Viewing stitching sequence

When checking embroidery designs, you will want to understand the 
stitching sequence in order to ensure efficient stitchout on the machine. 
‘Travel’ through designs by color block, embroidery object, or even 
stitch-by-stitch. Alternatively, simulate the stitchout on screen.

Tip: Depending on your design background, you can change display 
colors for unsewn stitches. See Change display colors for details.

Simulate design stitchouts

Stitch Player is an important tool in EmbroideryStudio. It lets you 
simulate the actual embroidery design stitchout on screen. Because 
Stitch Player emulates the movements of the embroidery machine, you 
are able to make decisions about how to optimize your design in order to 
lessen the load on the machine. This is important if you intend to make 
multiple stitchouts.

To simulate the design stitchout
 Choose a design view to visualize your design. Stitch Player can be 

run with or without TrueView™.

Use View > Stitch Player to simulate embroidery design stitchout on 
screen.
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 Click Stitch Player or press Shift+R. 

 Optionally, use the slider bar to move the starting point.
 Use the controls to stitch forwards or backwards through the design. 

Typical ‘media player’ buttons are available for play, pause, rewind 
operations.

 Use the Auto Pause control to set stop points – by color change, stop, 
or trim.

 To redraw a section of design, specify a start and end stitch using the 
tabs.

 Use Auto Scroll when running Stitch Player at high zoom factors.

Tip: Depending on your background, you can change display colors for 
unsewn stitches, selected objects, object outline, grid and guides.

Adjust redraw 
speed

Set starting point

Use video controls to
run stitch player

Set design to pause 
at color changes, 
stops or trims

Toggle Auto Scroll to view 
at high zoom factors

Set stitch range to redraw section of design
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Related topics...
 Change display colors

Travel through designs

It is useful to be able to view the stitching sequence color-by-color, 
object-by-object, or even stitch-by-stitch. The Travel toolbar provides all 
tools required to do so. Travel forwards or backwards with any button by 
right or left mouse-clicks. Traveling can be initiated from any stitch in the 
design. The current needle position is marked by a white cross or ‘needle 
position marker’. The current stitch number is displayed in the Status 
Bar.

To travel through a design
 Turn off TrueView™ and press the Esc to ensure no object is 

selected. 

 Travel to the start of the design by clicking the Start/End Design icon 
or pressing the Home key.

 Use the Travel by Stitch functions to travel forwards or backwards 
through the stitching sequence. Use left or right mouse-clicks or arrow 
keys – l or r, t or b. Alternatively, to travel by 1000 stitches, press 
Shift + Num+ or Shift + Num-.

Use ‘travel’ tools to move 
through every component 
of a design

Travel to previous stitch Travel to next stitch
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 To travel by color, click/right-click Travel by Color. This is useful if you 
need to locate a specific color change in order to insert an object or 
delete it from the stitching sequence.

 To travel by object, click/right-click Travel by Object. Alternatively, 
press Tab or Shift+Tab. 

 To travel by machine function, click/right-click the Travel by 
Function tool. Alternatively, press Ctrl+Page Up or Ctrl+Page 
Down. The needle point will stop at every jump, trim, and color 
change in the design.

 It is sometimes easier to use Travel by Trim to travel by trim 
functions alone – e.g. when checking for unnecessary trims. 
Alternatively, press Ctrl + Left Arrow or Ctrl + Right Arrow. Turn 
on Show Connectors and Show Functions to view while traveling.

Tip: While traveling through a design or editing stitches, click the 
Select Current icon or press Shift+0 to select the object associated 
with the current cursor position. 

Related topics...
 View selected color blocks
 Nest objects

Select objects while traveling

Travel by trims with 
connectors and 
functions showing

Click Select > Select Object together with the Ctrl key to select objects as 
you travel through a design.
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Traveling is usually associated with checking the stitching sequence. You 
can select objects as you ‘travel’ through a design using the Ctrl key. 

To select objects while traveling
 Click the Select Object icon.
 Use the Travel by Object tool or Tab and Shift+Tab buttons to 

travel forwards or backwards by object. See Travel through designs for 
details.

 Click the Select Current icon or press Shift+0 to select the object 
associated with the current cursor position.

 Hold down the Ctrl key to select an object as you travel through it.

Viewing colorways

A ‘colorway’ is a color scheme or palette of thread colors. It may also 
include a background color, fabric sample, or a product image. In 
EmbroideryStudio, you can define multiple colorways for the one design. 
This means you can stitch out the same design in different colors on 

Left/right-click Travel > Travel by Object to travel to previous or next object.

Click Select > Select Current to select the object associated with the 
current cursor position.

Press Shift 
+Tab keys

Press Tab key
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different fabrics. You can also print multiple colorways, icons of color 
blocks, and design backgrounds with the production worksheet.

Switch colorways

In EmbroideryStudio, you can preview the same design in different colors 
on different fabrics.

To switch colorways
 Open a design with multiple colorways.

Use Color > Current Colorway dropdown to select a new color 
scheme for design.

Use Color > Colorway Editor to assign thread colors to slots in the color 
palette.
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 Select a colorway from the droplist.

 Alternatively, use the Colorway Editor to toggle between colorways.

Related topics...
 Colorways
 Change backgrounds

Change backgrounds

Select 
colorway

Select colorway

Double-click to edit 
background or 
product image

Click Color > Background & Display Colors split arrow to change the 
background color of the current colorway.

Use Color > Product Visualizer to choose a garment or product backdrop 
on which to position your decoration.

Click View > Show Product to toggle product image on/off. Right-click to 
open the Product Visualizer docker.
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EmbroideryStudio lets you set the background color, fabric, or product of 
each colorway for more realistic previews and presentations.

To change backgrounds
 Open the design and select a colorway. 

 Use View > Show Product to toggle on or off any product image that 
may be included in the colorway.

 Click the droplist next to the Background & Display Colors icon.
 Change color via the Background Color popout menu.

Select a 
colorway

Click arrow to invoke popup menu

Select background 
color
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 If your colorway includes a background fabric, change color via the 
Fabric Color popout menu.

 If your colorway includes an article or product, open the Product 
Visualizer droplist and change color via the Product Color popout 
menu.

Tip: Click Background & Display Colors or Product Visualizer 
icons to preset any of these options.

Related topics...
 Add colorways
 Fabric & product backgrounds

Change display colors

In addition to background color or fabric, display colors for borer holes, 
unsewn and selected stitches, object outlines and grid are part of the 
colorway definition. Change them if the default display color is not visible 

Change fabric 
colors

Change product
color

Use Color > Background & Display Colors (or Colorway Editor docker) to 
change design background presets for the current colorway.
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against the current colorway. The Background & Display Colors dialog 
includes a Display Colors panel.

Adjust colors as required for:

Display item Description

Selected Selected objects or stitches.

Unsewn Unsewn stitches as they appear when traveling through the design.

Object 
outline

Object outlines as they appear when Show Outlines is activated. 
See View embroidery components for details.

Needle 
points

Change needle point display color according to current 
background. See also View embroidery components.

Grid Depending on the colorway, you may need to adjust grid display 
colors in order to view them against the background color. See also 
Measurements.

Guides Depending on the colorway, you may need to adjust guide display 
colors in order to view them against the background color. See also 
Measurements.

Borer Borer points. These are machine functions which only appear when 
Show Functions is activated. See View embroidery components for 
details.

Select display 
colors to 
change
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Display colors are saved with the colorway. You can save the colorway as 
an EMT template file for use in future designs.

Related topics...
 Add colorways
 Fabric & product backgrounds
 Working with templates

Viewing design repeats

Many customers make traditional garments such as sarees which employ 
continuous and sometimes overlapping designs. It is important to be able 
to see these designs together with their repeats. The Show Repeats 
function displays repeating designs, including sequins, in both TrueView 

Black needle points
against white

background

Use View > Show Repeats to toggle design repeats display. Right-click for 
settings.
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and stitch view. You can view a design, even while digitizing, with any 
number of repeats. The number can be a whole number or fractional.

Note: It is important that the artwork you use is properly sized and in 
the correct horizontal position. Always check the position of your artwork 
before starting to digitize. 

To view design repeats
 Set your units of measurement as required. 

Note: Stitch length and density controls remain in mm regardless of 
measurement system. These controls reflect the machine functions as 
industrial machines are always in millimeters.

 The first time you use the feature, right-click the Show Repeats tool 
or press shortcut W to access the Repeats dialog.

Vertical distance,
user-defined

Horizontal distance, user-defined 
or automatically calculated

Enter required number 
of vertical repeats

Enter distance 
between vertical 
repeats

Enter required number
of horizontal repeats

Enter distance
between horizontal

repeats

Select Show Repeats
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 Select the Show Repeats checkbox to activate the feature.
 Set the distance between horizontal repeats. This will always be 

expressed in millimeters. Depending on the template, different 
options are available:

 Enter the number of horizontal repeats. Repeats are balanced around 
the source design. This means that whole designs are displayed only 
for odd integer (1, 3, 5) numbers of repeats.

 Vertical distance is not constrained by needle or head distance. 
Vertical distance will be a function of design height. Set vertical 
distance and number of repeats as preferred.

 To help distinguish the source design from repeat patterns, Use the 
Colors option to display repeats in different colors. Enter a color offset 
to indicate where you want to start the first repeat color. Let’s say you 
have a 4-color design using palette colors 1, 2, 3, 4. If you set color 
offset to 5, repeat colors will display as 5, 6, 7, 8.

Option Function

Design 
repeat

This option is only available with the Schiffli template. Repeat 
distance is fixed. This is typically a factor – x1, x2, x3, etc – of 
needle distance. See Schiffli Supplement for details.

Other When selected, you need to manually enter a repeat distance in 
mm. This is typically used when doing continuous design work on 
multihead machines. The figure will generally correspond to the 
distance between machine heads – e.g. 135 mm – or factors 
thereof.

Repeat Effect

1.0 The original design only is displayed.

1.2 • The original design is displayed, plus
• 0.1 of the design on either side of the original.

2.0 • The original design is displayed, plus
• 0.5 of the design to either side of the original.
The repeat pattern looks like this: ][][.

2.9 • The original design is displayed, plus
• 0.95 of the design to either side of the original.

3.0 • the original design is displayed, plus
• a complete copy of the design to either side of the original.
The repeat pattern looks like this: [][][].
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 Use the Show Repeats icon to toggle design repeats on or off.

Related topics...
 Preparing artwork for continuous embroidery
 Set measurement units

Viewing design information

You can obtain design information in a variety of ways and formats – 
before opening the EMB file via File Explorer and from the Design 
Information docker. See also Preview design reports.

View design details in EmbroideryStudio

You can check design details via the Design Information docker. This 
is always advisable prior to design approval or stitchout. The opening tab 
contains information about design height, width, stitch count, colors, and 
so on. On other tabs, summary and order information may be provided 
by the digitizer or sales team. The information is printed with approval 

Source design

Use Docker > Design Information to view and modify design details prior to 
design approval or stitchout.
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sheets and production worksheets. Choose a file and select Design > 
Design Information.

Related topics...
 Viewing & managing design information
 Managing quotes & orders

View design details in File Explorer

Even without opening EMB files, you can check software version number 
and other design details via File Explorer. This same dialog can be 
accessed from within the Open dialog in EmbroideryStudio as well as the 
Design Library.

To view design details in File Explorer
 In File Explorer, right-click an EMB file and select Properties from 

the popup menu. 

Use tabs to view other design 
information, including orders 
and machine runtime 
estimates

Provide descriptive 
name as preferred
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The Properties dialog displays with an EMB tab. View general file 
information, such as file size and modification dates, together with 
design information such as stitch count, number of stops and color 
changes, as well as machine format. 

 The Custom tab shares information with the Design Information > 
Summary docker in EmbroideryStudio. 

Related topics...
 Viewing & managing design information

Preview design reports

Approval sheets and production worksheets contain all or some of the 
design details contained in the Design Information docker. Approval 
sheets are intended for customers, not production staff. Customers can 

Dedicated EMB
properties tab

Use Custom tab to 
provide additional 
file information

Click Standard > Print Preview to preview the production worksheet on 
screen.
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see what they are ordering and approve accordingly. Production 
worksheets are intended for production staff. All production-related 
information, such as bobbin length, design size, garment fabric, etc, is 
provided.

To preview a design report
 Click the Print Preview icon.

 To change paper orientation, click Landscape or Portrait. Large 
designs may be displayed over a number of pages.

 To change included information and set printing/plotting preferences, 
click Options. Here you can choose the report type – e.g. Approval 
sheet.

 To print the design, choose an option:

 To close the preview, click Close.

Click Close to return to 
design window

Choose a
print option

Order 
details

Modify report 
options

Option Function

Print Now Send the design report to your local printer.

Save as PDF Save the report as a PDF document. You are prompted to 
save to the hard drive or network location.

Send PDF via 
Email

Send the report – usually an approval sheet – as a PDF 
attachment to your local email client.
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Related topics...
 Viewing & managing design information
 Printing design reports
 Customizing design reports
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Chapter 5

Threads & Charts

When you digitize, you select thread colors for each object from the 
Color toolbar. The palette contains a selection of thread colors tailored to 
each design. This color scheme represents the actual threads in which the 
design will be stitched. 

You can select colors from commercial thread charts containing a range 
of colors from different manufacturers. To save time when setting up new 
color schemes, you can create your own thread chart using your favorite 
or most frequently used colors. In EmbroideryStudio you can search for 
particular threads by criteria. Even match threads automatically from 
selected charts to colors in your design.
This section describes how to select colors from the Color toolbar as well 
as how to assign threads to the colors in your design. How to modify 
thread charts is also covered, as well as creating custom thread charts.
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Choosing threads

The color palette contains a selection of colors tailored to each design or 
colorway. New objects are created using the currently selected color. You 
can change colors at any stage. Machine functions are automatically 
inserted in the stitching sequence whenever you assign a color. Typically 
you will want to assign actual thread colors to the Color toolbar in these 
circumstances...
 When you create a design, it includes a single default colorway. Using 

the NORMAL template, ‘Colorway 1’ contains default colors, 
unassigned to any thread chart. 

 When you convert vector graphics in CorelDRAW Graphics, colors 
are appended to the color palette as unassigned RGB values (if Match 
to Embroidery Palette is off).

 When you use the Color Wheel to create new color combinations, 
RGB values are added to the color palette.

 When you auto-digitize a bitmap, RGB values can be automatically 
matched to actual threads or simply added to the color palette.

 If you read a machine file, unassigned colors will be appended to the 
color palette.

 If you receive a design which uses colors from a thread chart you don’t 
have, you may want to match them to a preferred thread chart.

In EmbroideryStudio you can search for threads in one or several charts 
and assign them manually or automatically.

Note: Due to the differences in computer monitors and computer video 
cards, the approximate colors displayed should be used only as guides. 
Threads should always be matched to the appropriate physical color card.

Select thread colors

Use Color > Pick Color to pick up a color from an existing object and make 
it current.

Use Color > Current Color to view current color.

Use Color > Apply Current Color to apply the currently selected palette 
color to embroidery objects.

Use Color > Add Color to add a color to the end of the color palette.

Use Color > Remove Color to remove an unused color from the end of the 
color palette.
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New objects are digitized using the current color on the Color toolbar. 
You can change colors at any time.

To select thread colors
 Press Esc to deselect all objects. 
 Click a color in the Color toolbar to make it current. Alternatively, pick 

a color from the design with the Pick Color tool. The current color is 
shown on the toolbar and highlighted in the palette with a black 
square.

 Hover the mouse pointer over a color to view the thread code, thread 
name, and thread chart in a tooltip.

Use Color > Hide Unused Colors to show or hide all unused colors in the 
color palette.

Use Color > Remove Unused Colors to remove all unused colors from the 
color palette.

Current color

Thread
description
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 To isolate a color block in the design window, click and hold it in the 
Color toolbar. First press Esc to deselect all objects.

 Select object/s you want to recolor. Alternatively, select a color block 
in the Color-Object List.

Click and hold to
isolate the color block

Select objects or color
block to recolor
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 Select a color from the palette. Alternatively, transfer a used color to 
other objects with the Apply Current Color tool.

 Use the +/- buttons to add or remove color slots as needed.
 Use the Hide or Remove Unused Colors controls as preferred to 

compact the palette.

Related topics...
 Change color schemes

Assign thread colors

Click to select
a new color

Use Color > Threads to search for and match threads from different charts, 
and assign for use.

Use Color > Add Color to add a new color slot to the color palette.

Use Color > Colorway Editor to assign thread colors to slots in the color 
palette.

Use Threads > Select Thread Charts to select the thread chart/s you 
currently have available for use.

Use Threads > Assign Thread to assign selected thread to the highlighted 
color in the current colorway.

Use Threads > Match All to match threads from the current chart/s to all 
color slots in the current colorway.
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The supplied charts represent the brands of threads that 
EmbroideryStudio supports. Each chart includes a range of thread colors 
together with code, brand and description. You can search for a thread 
by code or description and assign it to a selected design color slot. 
Alternatively, let the software match design colors to threads in the 
current thread chart/s.

To assign thread colors
 Press Esc to deselect all objects. The currently selected (default) color 

is shown in the toolbar.

 Select a colorway and click the Threads icon. Alternatively, right-click 
a color in the palette. The docker opens.

Current color

Select colorway

Click to open
thread charts

Assign preferred 
thread chart/s
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 Click the Select Thread Charts button to access the thread chart 
listing.

 Choose the chart/s you prefer or currently have available and click OK.
 Click a color in the Color toolbar to make it current. The Threads list 

updates automatically.
 Alternatively, click Add Color to add a new color slot to the color 

palette and make it current.

 Use the scrollbar to refine your search. Or, in the Search field, enter 
the first few characters of the required code or name. The code is the 
identification number of a thread color in a brand. The system 
searches for the closest match and displays it in the thread color list.

 Double-click or click Assign Thread to assign a thread to the current 
color slot in the current colorway.

 Alternatively, use Match All to assign threads from the current chart/s 
to all color slots in the current colorway.

 Check the thread assignments in the Color toolbar by hovering the 
pointer over the slots.

 Optionally, click Remove Unused Colors to remove unused colors. 

Note: The Remove Unused Colors tool is disabled for machine 
formats that use needle addressing – i.e. that have Color Change set 
as Needle No in the Machine Format Settings dialog.

Click to assign
thread to current

color slot
Selected thread

assigned

Use scrollbar to
search
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Thread usage estimates

In order to obtain more precise thread usage estimates, you can adjust 
fabric thickness to suit the target fabric. This may be necessary if you are 
planning a large production run. Settings are generally fine-tuned on a 
case-by-case basis. However, adjusted settings can also be saved to the 
current template.

To estimate total thread usage
1 Select Design > Design Information > Stitching tab.

2 Click Length Calculation.

3 Enter the thickness of the target fabric.
4 Adjust the bobbin thread length according to the mixture of thread 

types in the design.
This factor provides a simple mechanism for a more accurate bobbin 
thread length estimate. The default value (100%) is suitable for a 
design with a mixture of stitch types. If the design is all Run stitches 
or all Tatami, more bobbin thread will be used and the factor can be 
increased say to 125%. If the design is all Satin stitch, the factor can 
be reduced to say 65%.

5 Click OK. The Total Thread and Total Bobbin values are adjusted to 
take into account fabric thickness on total thread requirement.

6 Optionally, click Save to save revised settings to the current template.

Click to calculate thread 
and bobbin length

Enter target fabric 
thickness

Enter bobbin thread 
length as a %
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Related topics...
 Working with templates

Recoloring consecutive objects

You can change the color of consecutive objects of the same color at the 
same time. 

To recolor consecutive objects
 Select the first object in the sequence to recolor.

 Select Object > Set Color. The Set Color dialog opens.

 Select the All consecutive objects of the same color option.
 Select a color from the list and click OK.

Related topics...
 Select objects with Color-Object List

Blue Blue

Green

Change color of
consecutive objects

Select color

Red

Red

Green
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Managing thread charts

Thread charts in EmbroideryStudio represent the many different brands 
and colors of thread available. They may not always be accurate because 
thread manufacturers often change, delete, and add new colors to their 
lines. For this reason, you can update charts as necessary.

Edit thread colors

You can always change code, name, chart, thickness or thread colors. For 
example, in Schiffli work, you may want to change text labels to Parts A, 
B and C to reflect the pattern arrangements when printing. These labels 
appear on the production worksheet both in the stop sequence and in 
Color Film printout. Alternatively, you may want to edit colors in a 
colorway before you assign actual threads.

To edit thread colors
 Open the Colorway Editor and select your colorway. If already open, 

the Threads docker closes automatically.

Use Color > Colorway Editor to modify threads in selected colorways.

Use Colorway Editor > Edit Color to modify thread information for the 
currently selected palette color.

Select thread 
to edit

Click to view 
thread details
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 Select the thread to edit and double-click or click Edit Color. 
Alternatively, double-click a palette slot in the Color toolbar. 

 Edit thread details as required. 

Note: When a color is changed, all objects using that color update 
immediately, whether selected or not. All other objects in the design 
are unchanged.

Related topics...
 Creating colorways
 Assign thread colors
 Modify thread details
 Printing design reports

Create & modify thread charts

EmbroideryStudio lets you define your own charts. When you create a 
thread chart, you are creating a store of colors for future use. Select 
names that will help you remember the charts or help you sort 
frequently-used charts to the top of the list. Rename or remove charts at 
any time.

Click to select 
or mix color

Edit thread
details

Use Color > Colorway Editor to create new thread charts.
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To create a new thread chart
 Select Manage Thread Charts via the Setup menu. Alternatively, 

click the Select Thread Charts button in the Colorway Editor.

 Click Manage. The Manage Thread Charts dialog opens displaying 
the current thread chart.

 Click Create. The Create Thread Chart dialog opens.

Click to open
thread charts

Click to modify
thread charts

Click to create new chart

Enter new 
name

My Thread Chart
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 Enter a name for the chart and click OK. The new chart is created, 
ready for you to add colors.

 Click Delete to remove the entire chart.

 Click Rename to change names.

Caution: Be careful when deleting thread charts. If you delete the 
wrong chart you will need to reinstall EmbroideryStudio to restore it.

Related topics...
 Modify thread details
 Copy colors between charts
 Definine custom thread chart files

Copy colors between charts

Copy colors between charts to create your own charts from existing 
threads.

Click to add 
your own 
threads

Click to copy 
threads from 
other chart

Click to rename Click to delete

Enter new thread 
chart name

My Thread Chart

My New Thread Chart

Use Color > Colorway Editor to modify existing charts.
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To copy colors between charts
1 Select Setup > Manage Thread Charts. Alternatively, click the 

Select Thread Charts button in the Colorway Editor and click 
Manage.

2 Create a new chart or open an existing one from the Name list.
3 Click Copy. The Copy Thread Chart dialog opens.

4 Select the source chart from the Name list.
5 Select the color/s you want to copy. Use Ctrl or Shift keys to copy a 

group or range of colors.
6 Click OK. All colors are copied to the new chart.

Modify thread details

You can copy colors from other charts or mix them yourself. You can also 
set the code, description, brand, and thickness of existing threads. 
Remove obsolete thread colors for good housekeeping.

Select
thread chart

Click to create 
new chart

Click to copy 
threads from 
other charts

Select 
thread chart

Select color 
to copy

Use Color > Colorway Editor to modify existing charts.
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To modify thread details
 Select Setup > Manage Thread Charts. Alternatively, click the 

Select Thread Charts button in the Colorway Editor and click 
Manage.

 Create a new chart or open an existing one from the Name list.
 Click Add to add your own colors or Edit to change selected thread 

details. 

 Enter code, name, and chart for the thread color.
Code is the identification number of a thread color in a brand.

 Select the appropriate thread thickness. These values are added to or 
subtracted from values used in the Auto Spacing table for specific 
stitch lengths.

Thickness Description Default

A Normal embroidery thread (approx. denier 40) 0.01

B Thicker than normal (approx. denier 30) 0.03

C Finer than normal (approx. denier 80) -0.03

Select
thread chart

Enter thread
details

Select thread
thickness

Click to select 
or mix color

1234

My Brand

Deep Purple
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Tip: Lighter weight threads do not run so well in a production 
environment as the machines need to be slowed down in order to 
avoid thread breaks. However, lighter weight threads are good for very 
small lettering and fine-detail designs.

 Click More Colors in the droplist to see more colors or to mix your 
own. 

 Remove threads as required:
 Click Remove to remove individual threads.
 Click Clear All to remove all threads.

Related topics...
 Satin auto-spacing

Definine custom thread chart files

While you can define custom thread charts within EmbroideryStudio, you 
can also share custom charts in CSV format directly. Files need to be 
configured as shown...

The data that needs to be included is:
 Thread number
 Brand name
 Thread name
 Thread thickness – A, B, C, or D
 Thread RGB value.
A CSV file formatted in this way can be read directly by the software. 
However, you need to change the file extension to ‘TCH’ and save it to the 
correct custom asset location on your hard drive.

D Very fine (approx. denier 100) -0.06

Thickness Description Default

Standard TCH 
file format
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Related topics...
 Custom asset locations

Save default thread charts to template

You can save your default thread chart by selecting it in the Colorway 
Editor and saving to the NORMAL template. Alternatively you can save 
a dedicated template for the particular thread chart and stitch settings 
you are using.

Related topics...
 Working with templates

Overwrite existing
template or create

new one
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PART II
HARDWARE & SOFTWARE SETUP

In order to work with your particular equipment, EmbroideryStudio needs 
to be properly configured. You may also want to configure the software 
to your particular design requirements.

System settings
This section describes how to change the TrueView™ display, grid spacing 
and positioning, and Design Window scrolling options. It also describes 
how to save designs automatically as you work. There is also information 
about how to adjust the pointer position display, paste position options, 
and other general options. See System Settings for details.

Hardware settings
This section describes how to set up digitizing tablets and embroidery 
machines. It also describes how to calibrate the monitor. See Hardware 
Settings for details.

Machine formats
This section describes how to select a machine format for a design and 
output it using other formats. It also explains how to customize machine 
formats to meet your machine’s specific requirements. See Machine 
Formats for details.
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Chapter 6

System Settings

EmbroideryStudio lets you adjust various system settings controlling the 
appearance of designs on screen, display of design information, the 
behavior of the design window, and other settings.

General options

The General tab of the Options dialog provides a miscellaneous group 
of system settings including automatic save and backup, pointer position 
display, color handling for inserted files, paste position options, toolbar 
display, and others.

Set auto-save
options

Set pointer position
display

Set Object Property
‘apply’ options

Set color handling 
for inserted files

Set continuous 
input for Column A 
digitizing

Set toolbar 
display options

Set font list 
display options
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Automatic save & backup options

Save your work automatically at regular intervals using Auto Save. This 
protects you in the event of hardware or software failure.

Auto save
The Auto Save function creates a temporary file with the extension EMA 
in the RECOVER folder. This is automatically restored when 
EmbroideryStudio is restarted after a computer crash. You can access 
these files manually by browsing to the RECOVER folder and renaming 
files from EMA to EMB.

Backup copy
If the Backup Copy checkbox is ticked, a backup copy of the current 
design file is automatically created in its previously saved form. This 
protects you from overwriting the design with unintended changes – e.g. 
using the Save option instead of Save As to save a modified design. The 
backup copy is saved in the BACKUP folder with the original file name and 
native file format. Access backup files manually by browsing to the 
BACKUP folder.

Caution: Backup files remain in the BACKUP folder until you delete them. 
To prevent the folder from using too much hard disk space, delete 
unwanted files regularly. Backup files should be kept in a separate 
physical location, preferably off-site. Access the backup folder via the 
File > Open Backup Design command.

Related topics...
 Custom asset locations

Pointer position display

When you move the mouse or digitizer puck, the pointer position is 
displayed in the Status bar at the bottom of the screen. Use the Options 

Use Standard > Options to access application options for design view, grid 
& guides, and other settings.

Select to
auto-save designs

Select to
auto-backup designs

Use Standard > Options to access application options for design view, grid 
& guides, and other settings.
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> General tab to display the pointer position as a relative or absolute 
value. 

Select a Relative or Absolute pointer setting:

The X and Y values show the horizontal and vertical distance of the 
pointer from the relative or absolute point. The L value is the length of 
the line connecting two points, while A is the angle of that line, relative 
to the horizontal. You can measure onscreen distances using the values 
in the Status Bar. You can also use the Measure function (M).

A negative X value indicates that the second point was placed to the left 
of the first. A negative Y value displays when the second point is below 
the first. Negative angles indicate angles of more than 180º – e.g. an 
angle of -60º is equal to 300º.

Option Function

Relative Shows pointer position relative to the last digitized point or stitch 
point. Useful while digitizing or editing stitches.

Absolute Shows pointer position as an absolute value from the first needle 
point of the design. Useful for checking that the design fits a given 
area.

 Select relative or
absolute pointer

position

X: horizontal Y: vertical L: length A: angle

X = 28.61 mm

Length = 33.47 mm

Status bar

Y = 17.38 mm

X = -28.61 mm

Length = 33.47 mm

Y = -17.38 mm

12

1 2

2

1

90º

-90º

-45º

45º135º

-135º

180º 0º

A=30º
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Related topics...
 Measure distances on screen

Thread color handling for inserted files

Whenever you copy and paste or insert an embroidery design or element 
from one file to another, the respective color palettes are merged. You 
have the option of adding the source palette to the target palette or of 
matching the source palette to the nearest colors in the target palette. 

Click the Options icon or select Setup > Options and select the 
General tab.

Select an inserted embroidery file option:

Paste & duplicate options

Use Standard > Options to access application options for design view, grid 
& guides, and other settings.

Option Function

Add to palette Unique colors in the design are added to the current color 
palette.

Match to palette When you insert a design, colors are matched to the current 
color palette. The system finds the nearest match based first on 
RGB values, and then on Brand and Code.

Colors added 
to palette

Colors matched 
to palette

Select inserted 
embroidery file 
option

Use Standard > Options to access application options for design view, grid 
& guides, and other settings.
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You can control where an object is positioned when pasted. If you are 
pasting within the same design, the default is the same position from 
which the object was copied or cut. Other options are available.

Click the Options icon or select Setup > Options and select the Edit 
tab. Set Paste and Duplicate with offset settings independently of 
each other as preferred. 

Paste settings include:

Duplicate position settings apply only to normal Ctrl+Shift+D 
operations. Cloning by right-click and drag will override these settings 
temporarily. Ctrl+D operations will assume the ‘quick clone’ value.

Note: Paste and duplicate options control the physical position of the 
object in the design, not its position in the stitching sequence.

Option Function

Object property 
position

Objects are pasted according to the coordinates in the Object 
Properties docker.

Shift pasted 
objects

Objects are pasted slightly offset from their original position. 
Adjust offset distance as preferred.

Center at current 
stitch

Objects are centered at the current needle position marker.

Start at current 
stitch

Objects are positioned after the current needle position 
marker.

Pasted / duplicated 
objects offset from original

Select duplicate 
position setting

Select paste 
position setting
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Related topics...
 Copy & paste objects
 Duplicate & clone objects

Digitizing presets

The Continuous Input setting provides a simple and efficient way of 
digitizing a single Column A object comprised of separately stitched 
sections. 

Five preset styles are included for use with the ‘Use preset styles for 
traditional tools’ option. These apply to the Column A, Column B, Column 
C, Complex Fill, and Complex Turning tools. When the option is checked, 
default stitch type and underlay conform to the associated style. If you 
change stitch type or underlay, this applies throughout the current 
session. When the checkbox is unticked, current settings are used.

Related topics...
 Embroidery digitizing
 Create smooth joins
 Working with styles

Toolbar display options

Use Standard > Options to access application options for digitizing tools.

Traditional tool Cover Underlay 1 Underlay 2

Column A/B/C Satin Edge run Zigzag

Complex/Turning fill Tatami Edge run Tatami

Set continuous 
input for Column A 
digitizing

Use Standard > Options to access application options for design view, grid 
& guides, and other settings.
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You can adjust toolbar appearance via the Options > General tab. 
Choose between large or small button icons, with or without short names.

Font list display options

You can set the size of your font preview via the Options > General tab. 
You can also adjust the number of recently used fonts.

Related topics...
 Select embroidery fonts

Object property apply options

The most important dialog in EmbroideryStudio is the Object 
Properties docker. By default, modified object properties to take effect 
immediately. Alternatively, set the default to apply changes by means of 
an Apply button at the bottom of the docker. Click the Options icon or 
select Setup > Options and select the General tab.

Choose large or small
button icons with or

without names

Use Standard > Options to access application options for design view, grid 
& guides, and other settings.

Set font preview 
size

Set number of recent 
fonts shown in font list

Use Standard > Options to access application options for design view, grid 
& guides, and other settings.

Select object
properties default
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Related topics...
 Access object properties

Other general options

Miscellaneous other system settings available via the Options > 
General tab:

These options include:

Use Standard > Options to access application options for design view, grid 
& guides, and other settings.

Option Function

Closest join The Closest Join method (the default) automatically calculates 
closest join between objects while digitizing. When 
deactivated, entry/exit points of all newly digitized objects are 
set manually. See Embroidery digitizing for details.

Play button 
sounds

Enables beeping sounds made by the software in response to 
mouse clicks and pressing Enter or Spacebar keys while 
digitizing.

Cumulative stitch 
count

Displays stitch count as a cumulative total in the Stop 
Sequence tab of the Information docker. See also View design 
details in EmbroideryStudio.

Crosshair cursor Changes the default cursor pointer to crosshairs for more 
precise positioning. It is best used together with the grid.

Show measure 
tooltip

Shows length and angle in a tooltip when measuring distances 
on screen. See Measure distances on screen for details.

Show Home 
Screen on startup

When activated, the Home Screen always displays when the 
software starts up. See Home screen for details.

Select other
general options
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Tip: Use the measure tooltip in combination with the crosshair cursor on 
for more accurate measurements.

View options

You can preset viewing options for embroidery design elements as well 
as graphics.

Design viewing options

EmbroideryStudio lets you preset options to show or hide design 
elements such as stitches, outlines, and background fabric. You can also 
change TrueView™ settings for different viewing effects.

To set design viewing options
 Click the Options icon or select Setup > Options and select the 

View Design tab.

Check for 
updates

When activated, the software will check at every startup 
whether updates are available. It will also check whenever you 
access the My Wilcom page from the Home Screen. When 
deactivated, you will need to run the Help > Check for Updates 
command.

Option Function

Use Standard > Options to access application options for design view, grid 
& guides, and other settings.

Select design 
elements to display
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 Select viewing options to display. These control the same toggles as 
the View toolbar. The difference is that the selections you make here 
affect default system settings.

 Click TrueView Options to adjust TrueView™ settings.

 Adjust thread thickness and light source for preferred TrueView™ 
appearance. These settings also affect the appearance of printed 
TrueView™ ‘virtual decoration’.

Note: This Thread Thickness setting only affects the TrueView™ 
display, not actual thread thickness values. 

Related topics...
 View embroidery components
 Viewing design components
 Outputting designs as images

Image viewing options

Select thread thickness

Select light source

TrueView™ – thick thread, light above TrueView™ – thin thread, corner light

Use View > Show Bitmaps to show and hide bitmap images. Right-click to 
set image display options.

Use View > Show Vectors to show and hide vector graphics. Right-click to 
set image display options.

Use View > Dim Artwork to dim graphic backdrops to show stitches more 
clearly for digitizing.
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You can dim bitmap image backdrops to make it easier to view stitches. 
You can also show colored vector graphics as outlines only.

To set image viewing options
 Right-click either the Show Bitmap or Show Vectors icon. The 

Options > View Graphics dialog opens.

 To dim a bitmap image backdrop, select the Dim Graphics checkbox.

 To view a colored vector graphic as outlines, select the Show 
Wireframe checkbox.

Show vector outlines

Dim graphics

Dimmed bitmap 
image

Original bitmap 
image

Vector outlines 
only

Original vector 
graphic
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Show auto-start & end points

The stitch cursor always appears at the end of the last digitized object. 
On the View Design tab, auto-start & end symbols – a green circle and 
a red cross – can also be activated. 

Related topics...
 Setting auto start & end

Grid display options

EmbroideryStudio provides a set of grid lines to help accurately align or 
size embroidery objects. The Show Rulers and Guides feature lets you 
accurately place and align objects. When a design is saved, the ruler zero 
point and guide positions are saved with it.

Grid display options

Adjust grid spacing depending on the size of design you are working with. 
Use the Snap to Grid feature to align objects with the nearest grid lines. 
Checkboxes control the same toggles as the View toolbar. The difference 
is that the selections you make here affect default system settings next 
time you run EmbroideryStudio.

Auto start and end
symbols on

Current cursor 
position

Click View > Show Grid to show or hide the grid. Right-click for settings.

Click View > Show Rulers and Guides to show or hide rulers and guides. 
Right-click for settings.

Drag the Ruler Zero Point to reset a new ruler zero point.
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To adjust grid display
 Right-click Show Grid. The Options > Grid & Guides dialog opens.

 Enter Grid Spacing values for horizontal and vertical grid lines. To 
save grid spacing to the current template, click Save.

Set zero point
of your design

Enter grid
spacings Click to save 

for current 
template
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 Select the Snap to Grid checkbox as required. Reference points, 
control points or leading edges of objects snap to grid during 
digitizing, sizing, reshaping, or positioning operations.

 Choose a snap method. You can choose whether to activate in X or Y 
axes or both.

 Select the Set Reference Point checkbox to set the zero point of the 
rule. For example, you can set the grid reference point to the design 
center. This is easier and faster than moving the whole design. When 
you close the dialog, you are prompted to mark the zero point of your 
design.

Tip: To temporarily disable Snap to Grid as you digitize, hold down 
Alt.

Related topics...
 Display grids, rulers & guides

Ruler & guide display options

Rulers and guides are activated by the Show Rulers & Guides toggle. 
The unit of measurement – mm or inches – defaults to the regional 
settings in the MS Windows® Control Panel. The ruler scale adjusts with 

Snap to Grid
in X only

Snap to Grid
in X and Y

Right-click View > Show Rulers & Guides to set the Snap to Grid and Snap 
to Guides options.
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the current zoom setting. Guides can be used separately or in addition to 
grid lines for detailed work.

Snap to Guides can be set for guides independently of grid lines. 
Reference points, control points or leading edges of objects snap to 
guides during digitizing, sizing, reshaping, or positioning operations. To 
temporarily disable Snap to Guides as you digitize, hold down Alt.
The Show Column C Width Guide option activates a special cursor with 
the Column C tool. A circle appears at the cursor position corresponding 
to the width setting in the Object Properties docker. This is useful when 
digitizing a border based on a background image. When the offset is 
biased, two circles are shown, one for each side. 

Note: To gain the benefit of the width guide, you must accept the current 
width setting by pressing Enter, rather than digitizing reference points 
after finishing the centerline.

Related topics...
 Display grids, rulers & guides
 Set measurement units
 Digitizing regular columns

Scroll options

Guides can be set 
separately or in 
addition to grid 
lines

Column C width
guide activated

Use Standard > Options to access application options for design view, grid 
& guides, and other settings.
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The Options > Scroll tab lets you to control mouse pointer and mouse 
wheel behavior. Use Auto Scroll to scroll automatically while digitizing. 
This can be more convenient than using panning or scroll bars, especially 
when working on large designs. The dialog also lets you set four different 
mouse wheel behaviors.

To set scroll options
 Click the Options icon or select Setup > Options and select the 

Scroll tab.

 Adjust Auto Scroll options as needed. The effect only becomes 
apparent when you start to digitize. The design window automatically 
follows the current cursor position. 

Tip: Hold down the Shift key to temporarily deactivate Auto Scroll. 
Use the Ctrl+Shift+A key combination to toggle Auto Scroll on/off.

 Tick Center pointer when zooming to ensure that the pointer stays 
centered on screen at all times.

Option Function

Auto scroll Tick to enable automatic scrolling while digitizing.

Move pointer 
after scroll

Set pointer position after each scrolling action:

Center: Use this setting for large movements.

Midway: Use this setting for smaller movements – e.g. when 
zooming into a small area of the design.

Corner: Use this setting for slow scrolling.

Response time Adjust scrolling speed.

Adjust auto-scroll 
speed and pointer 
position

Select desired 
action for your 
mouse wheel
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Reshape options

Stitch generation during reshaping operations can slow down your 
system. Reshape options let you choose whether stitches are generated 
immediately or only after Enter is pressed. This tab also controls node 
dragging behavior in Reshape operations as well as re-sequencing 
behavior in cutting operations with the Knife tool.

To set automatic stitch generation options
 Right-click the Reshape Object icon. The Options > Reshape dialog 

opens.

 Select options for generating stitches immediately after reshaping 
operations – i.e. for lettering objects, motif runs, and/or other objects. 
If left unchecked, any reshaping changes made are not updated until 
Enter is pressed.

 Select your preferred left mouse drag node behavior – Traditional or 
Bézier.

Generally, ‘bézier’ node dragging preserves the shape of the curve 
more closely.

Right-click Reshape > Reshape Object to set reshaping options.

Select object types for
immediate stitch

generation

Select preferred drag
node behavior

Original curve Bézier curve Traditional curve
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 Select your preferred object-cutting reordering behavior.

EmbroideryStudio orders object fragments resulting from cutting 
operations with the Knife tool into a closest-join sequence that 
preserves the source object’s entry and exit points. There are three 
possible ways of reordering fragment objects:
 Reorder and create travel runs between objects separated by gap.
 Reorder, trimming between separated objects where necessary, but 

creating no travel runs.
 Combine fragments into a single branched object corresponding to 

the source object.
The option you choose will affect all Knife tool cutting operations.

Tip: The Break Apart tool allows you to split branched objects, 
including objects resulting from cutting operations, into their 
component parts.

Related topics...
 Reshape objects with Bézier controls
 Cut shapes manually
 Break apart composite objects

Warning options

Some warning messages may become distracting. You may want to 
switch such warnings off but still be able to re-activate them at a later 

Select preferred
object cutting

reordering behavior

Use Standard > Options to access application options for design view, grid 
& guides, and other settings.
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time. The Options dialog includes a Warnings tab which allows you to 
re- or de-activate specific warning messages as desired.

Warning messages include:
 Changed Stitches: This appears when sending designs to Stitch 

Manager, depending on whether stitches need to be regenerated to 
comply with a changed machine format.

 Non-Native Design: This appears when opening ‘machine files’ of 
unknown origin. Machine files cannot be scaled by more than 
approximately ±5% since their stitch count does not change. By 
contrast, design or ‘outline’ files such as native EMB, can be scaled by 
any factor as stitches are dynamically regenerated.

 Fabric Settings Unchanged: This appears if you have chosen to 
work with an auto-fabric and wish to save changes made to object 
properties. Any changes are saved to the template, not to the fabric 
itself. Such changes are overridden by current fabric settings.

Select warning 
options to include / 
exclude
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 ZSK File Name: This appears if you try to save a design to ZSK TC 
format with an alphanumeric file name. ZSK machines require 8-digit 
filenames.

 Design Integrity Alert: This appears if the software detects a 
problem with the design file. If you see an alert, you should use Undo 
to return the design to an error-free state. Save the design. Then save 
a separate instance of the design up to the point the alert is generated. 
Send both designs to Wilcom Support for analysis.

Note: Turning off this message also turns off design integrity checking.

Related topics...
 Send designs to Stitch Manager
 Working with fabrics
 Embroidery file formats
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Chapter 7

Hardware Settings

You will need to connect peripheral devices for use with 
EmbroideryStudio. These may include digitizing tablets, plotters, 
printers, appliqué cutters, scanners and embroidery machines. Different 
devices are set up in different ways – some in MS Windows®, via the 
Control Panel, others within EmbroideryStudio itself.

EmbroideryStudio provides alternate means for sending designs directly 
to machine. Depending on your hardware, you can send designs directly 
using Stitch Manager, Machine Manager, or Connection Manager. 
Machine Manager is described in a separate Supplement.

Tip: The number of available ports limits the number of devices you can 
connect. If additional ports are required, you can add them. Multi-port 
serial cards can also be used. See a PC technician about your 
requirements.
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Calibrating the monitor

You need to calibrate your monitor so that designs at 1:1 scale appear at 
real size. Do this when you first install EmbroideryStudio or whenever 
you change your monitor.

To calibrate the monitor
1 Select Setup > Calibrate Screen.

2 Measure the height and width of the dialog box.
3 Enter the measurement in the Width and Height fields.
4 Click OK.

Related topics...
 Viewing Designs

Peripheral device connections

Peripheral devices can be connected to your computer via USB port, 
serial port, parallel port, specialized network card, or Ethernet network. 
Local area networks (LANs) commonly use Ethernet networks for 
machine connection.

Note: For instructions on connecting devices to your computer and 
setting up in MS Windows®, see the documentation for the device as well 
as your MS Windows® documentation.

USB ports
Most machines now use USB port connection. They appear just like a disk 
drive on your PC so there is no need to configure communication 
parameters as for serial or parallel port connections. Some machines 
such as Janome MB-4 and Barudan are supplied with propriety 
connection software. EmbroideryStudio supports connection to these 

Measure width

Measure 
height
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machines via the Connection Manager option. See Setting up machines 
for Connection Manager for details.

Serial ports
PC serial COM ports are male connectors, and can be either 9-pin or 
25-pin. They are named COM1, COM2, COM3, etc. You must be able to 
identify the ports on your computer. (If in doubt, consult a PC technician.) 
When you set up a device that is connected via a serial port, you need to 
enter the serial port settings in EmbroideryStudio as part of the setup 
procedure. See also Enter serial port settings.
The following table provides standard settings for various devices. They 
are a guide only. Settings for the same device may vary according to 
manufacturer. Check the documentation supplied with the device before 
setting up.

Tip: The number of available ports limits the number of devices you can 
connect. If additional ports are required, you can add them. Multi-port 
serial cards can also be used. See a PC technician about your 
requirements.

Setting up machines for Connection Manager

Newer machines use USB port connection. They appear as a disk drive 
on the PC. As such there is no need to set up communication parameters 
as for serial or parallel port connections. Some machines such as Janome 
MB-4 and Barudan LEM, are supplied with propriety connection software. 
To integrate with EmbroideryStudio, the relevant software needs to be 
installed on the same machine. Discuss with your machine supplier for 
details.

Set up machines

Device Port Baud Hand-shaking Data bits Stop bits Parity

Digitizer COM1 9600 None 8 1 None

Plotter COM2 9600 XOn/XOff 8 1 None

Tape Punch COM2 4800 XOn/XOff 8 1 None

Tape Reader COM2 4800 XOn/XOff 8 1 None

Embroidery 
Machine

COM2 9600 Hardware 8 1 None

Use Standard > Send to Connection Manager to connect to supported 
machines via proprietary machine software.
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EmbroideryStudio supports various machine models. Some can be 
connected by cable directly to your PC via USB port. Others require files 
to be placed in a specific network location or ‘watching folder’. Older-style 
machines do not support direct connection but they do read ATA PC cards 
and/or USB memory sticks. Connection Manager provides a method of 
connection to machines that appear as removable media or make use of 
third-party connection software. Once set up in EmbroideryStudio, a 
single click is sufficient to send the design to machine.

To set up a machine
1 Select Setup > Connection Manager Setup. Alternatively, click the 

Send to Connection Manager icon on the Standard toolbar. If no 
connections currently exist, a message appears.

2 Click Yes or Create to start setting up your connections. The 
Connection Settings dialog opens.

3 Select the connection type. Choose from:
 Machine folder – e.g. Barudan DFS, HappyLink/LAN, Brother PR 

series, etc
 Janome MB-4
 CAMS (rhinestone placement machine). 

Enter unique 
connection 
name

Select connection
type

Set ‘watching
folder’

Select file type
required by machine
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4 Enter a unique name for the connection. This identifies the 
quick-access button on Standard toolbar and appears in the tooltip.

5 Choose an icon to identify the specific connection.

6 Select the file type required by the machine. Depending on the chosen 
file type, the Options button may become available. This allows you 
to set up specific file format options from within Connection 
Manager without having to go to the Save As dialog. 

7 Enter or browse to a folder location on the network or PC which has 
been set up for the specific machine.
For example, if you choose to connect to a Barudan LEM design server, 
this allows you to set up a ‘watching folder’ which the server monitors 
for design files (U?? format). It then systematically converts to PRJ for 
machine communication. When you output a design, Connection 
Manager saves it to this folder in the specified format.

Select an icon 
to identify 
connection

Tick to automatically
rotate designs on

output

Specify file format
options

Locate or create 
machine-specific 
folder 



Chapter 7   Hardware Settings 164

8 Optionally, tick the checkbox to rotate designs by 180º on output for 
cap applications. If ticked, all designs sent to that connection will be 
automatically rotated.

9 Click OK when complete. The new connection appears on the 
Standard toolbar.

10 Repeat steps to set up more machine connections. As more machines 
are created, more quick-access buttons are added to the Standard 
toolbar. Each can be assigned its own identifying color.

All machines connections you define are listed in the Connection 
Manager Setup dialog. From here they can be updated or removed 
from the system.

Tick for cap
applications

Quick-access button for
machine connection

Each connection is 
assigned a unique 
color

Update or remove 
as required



EmbroideryStudio e4 Reference Manual 165

Related topics...
 Save & close designs
 Send designs to Connection Manager
 Send bling to CAMS machine

Automatic machine file naming

Connection Manager provides an option for automatic machine file 
naming. When enabled, the specified filename format is used for all 
machine connections established in Connection Manager.

Where...

Note: When enabled, Kiosk also uses this auto-name specification for all 
machine files. If not enabled, it uses the kiosk machine file definition.

Related topics...
 Lettering Kiosk

Setting up machines for Stitch Manager

Before sending designs via Stitch Manager, you must first configure the 
machine in EmbroideryStudio. Add machines, change existing machine 
settings, or delete machines no longer in use. Newer machines use USB 

Setting Details

Filename format Filenames take the format <prefix><number>.<extension>

Prefix ASCII only, no Unicode characters. No Windows reserved 
characters. Length limit 8 characters.

Number Numeric only. This sets the starting number. Range 1–
99,999,999.

Interval Interval is numeric only and sets the number to increment 
each time a file is generated – e.g. ‘5’, ‘10’, etc. Range is 1–99.



Chapter 7   Hardware Settings 166

connection. EmbroideryStudio supports connection to these machines via 
the Connection Manager option.

Set up machines

To set up a machine you need to define a name, the port it is attached 
to, and the protocol it uses. For every machine, you need to select the 
machine format it supports.

To set up machines
1 Connect the embroidery machine using the instructions that came 

with the machine. Carefully note the port settings.
2 Run EmbroideryStudio. The port settings must now be entered in 

EmbroideryStudio Hardware Setup.
3 Select Legacy Features > Hardware Setup.

4 From the Type list, select Direct Machine Connection.
 To add a new machine, click Create.
 To change the settings of an existing machine, select it, then click 

Settings.
The Embroidery Machine Connection dialog opens.

Use Legacy Features > Hardware Setup to set up a machine connection 
with name, port, and protocol.

Select Direct
Machine

Connection

Click to add 
machine

Click to 
access 
machine 
settings

Select machine
connection to

delete

Enter machine
name

Select COM port
and protocol

Click to access 
serial port 
settings
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5 Use the Name and Comment fields to uniquely identify the machine 
connection.

6 From the Port list, select the serial (COM) or parallel (LPT) port to 
which the machine is connected. 

7 From the Protocol list, select the protocol for the connection between 
the computer and embroidery machine.
See the documentation supplied with the embroidery machine to 
determine the appropriate connection.

8 Click Setup to access the serial port settings.
These settings must be the same as those set on the embroidery 
machine, or EmbroideryStudio will not be able to communicate with it. 

9 Select Auto Download to directly download designs to the assigned 
machine. Deselect it to confirm before sending.

10 In the Machine Type panel, select the compatible machine formats.
To do this, select compatible machine types in the Available list, and 
click > to move them to the For this machine list.

Note: Machine format values can be added or changed if required. 
11 Click OK to return to the Hardware Setup dialog.
12 Click Close. All machine connections you define are listed in the 

Hardware Setup dialog. From here they can be updated or removed 
from the system.

Note: Once machine setup is complete, you can stitch out a design via 
Stitch Manager without changing the original design format.

Machine types 
supported by 
your machine

Click arrow buttons to swap 
machine types between fields

Select
machine type

Select Direct
Machine

Connection

Select
machine to

update

Update or 
remove as 
required
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Related topics...
 Peripheral device connections
 Serial ports
 Send designs to Stitch Manager
 Custom machine formats

Enter serial port settings

PC serial COM ports are male connectors, and can be either 9-pin or 
25-pin. They are named COM1, COM2, COM3, etc. When you set up a 
digitizer or machine that is connected via a serial port, you need to enter 
the serial port settings in EmbroideryStudio.

Note: You must be able to identify the ports on your computer. If in 
doubt, consult a PC technician.

To enter serial port settings
1 Select Legacy Features > Hardware Setup.

2 Select a device from the Type list and select an item in the Name 
column, then click Settings. The <Device> Setup dialog opens.

3 In the Connected To panel, select a serial port from the Port list. 

Use Legacy Features > Hardware Setup to set up a machine connection 
with name, port, and protocol.

Select device

Click to access 
device settings

Click Setup

Select serial port
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4 Click Setup. The Serial Port Setup dialog opens.

5 Enter the Baud rate, Data Bits, Stop Bits and Parity and 
Handshaking settings for the device. 

6 Click OK.

Note: The port settings must match those of the embroidery machine 
or selected device. The type of handshaking must match the type of 
cable you are using. Check the communications setup section of the 
documentation that came with the device.

Related topics...
 Connecting digitizing tablets
 Serial ports

Doing runtime estimates

EmbroideryStudio provides a Runtime Analyst feature for calculating 
estimated running times for embroidery files using specified RPM values 
and other runtime parameters. These are used on a design-by-design 
basis to determine scheduling, running costs, and payments for 
production staff. Output can be used by any third-party software such as 
ERP or accounting systems.

Typical usage
Information can be made available to various stakeholders for payroll, 
estimations, and scheduling. For instance:
 The designer creates a new design and saves as EMB and/or machine 

file such as U11.
 EmbroideryStudio automatically calculates running time.
 Calculated results are saved to CSV file in a designated file location.
 The payroll department accesses the CSV file and calculates pay rates 

for the design. For example:
 A payroll clerk may need to find out what the runtime will be for a 

given job in order to pay the machine operator.

Enter port settings 
for embroidery 
machine or selected 
device
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 A manager may need to provide an accurate runtime estimate for 
any given design so the payroll department is able to process 
machine operator payments.

 The ERP system accesses the CSV file for estimation and scheduling 
purposes.

 Runtime information may be communicated to a machine operator 
who needs to know the runtime estimate for a specific job.

Configure machine runtime settings

You can set up multiple named machines for the purposes of runtime 
analysis with specific parameters such as ‘fast speed’, ‘slow speed’, ‘trim 
time’, ‘color change time’, etc.

To configure machine runtime settings
1 Select Setup > Machine Runtime Setup. Or run the command from 

the Design Information > Runtime tab. The Machine Runtime 
Setup dialog opens. The dialog lists all machines currently defined for 
the purposes of runtime analysis.

Create a new 
runtime definition
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2 Click Create to set up a new runtime definition. The Machine 
Runtime Settings dialog opens.

3 Use the Name and Comment fields to uniquely identify the machine 
or machine class.
The class may be based on machine model. However different 
machines of the same model may be set up for different purposes – 
e.g. to run at different speeds. If so, you’ll need to set up different 
classes to suit.

Note: Machine types set up here are independent of machines defined 
in Connection Manager Setup or Embroidery Machine 
Connection dialogs.

4 Create a runtime definition for the machine. Parameters are based on 
machine specs, controller feedback, and/or empirical observation:

Option Function

Normal (high) 
speed

The speed at which the machine normally sews. Normally 
available from machine specs.

Slow speed The slowest speed at which the machine runs. Normally 
available from machine specs.

Slow above The length of stitch above which the machine slows down. 
This value is automatically adjusted according to speed 
settings, in particular slow speed. Should be available from 
the machine specs.

Trim time The time the machine takes to perform a trim. May be 
available from machine specs or empirical observation.

Color change 
time

Same as for trim time.

Name the
machine

Specify runtime
parameters
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5 Click OK. All machines or machine classes you define are listed in the 
Machine Runtime Setup dialog. From here they can be updated or 
removed from the system.

Output design information to CSV

Design information, including runtime estimates and relevant 
parameters, can be output to CSV file for later use by third-party 
applications. New data is appended to the file. 

Estimated running times
Once your machines or machine classes have been defined, estimated 
running time for a specific embroidery file is displayed in the Design 

Stop time Time spent stopping in order to place fabric, foam, etc. This 
is normally determined through empirical observation. The 
number of heads on the machine will be a determining factor 
– e.g. 16 heads x 6 secs each.

Design start time Time the machine takes to go from stop to normal speed – 
e.g. it may stitch a number of slow stitches to start off. May 
be available from machine specs or empirical observation.

Design end time Stopping time – the machine may slow down and then travel 
to the center of the hoop before actually stopping.

Option Function

Update or remove 
as required

Use Docker > Design Information to view and modify design details prior to 
design approval or stitchout.
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Information > Runtime tab. This tab lists available machines together 
with estimated runtimes for the current design. 

Related topics...
 Runtime tab

Cost of fabric parameters
An Design Area field on the Stitching tab shows the total design area. 
It is calculated by multiplying design width and height, not actual stitched 
area. This figure is used to estimate the cost of fabric or 3D foam that 
can be used in the design.

Estimated runtime per 
machine for current 
design

Total area used to 
estimate cost of fabric 
or 3D foam
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Export options
Design information can be written whenever the design is saved or 
recorded to DesignWorkflow database. An Options > Export tab allows 
you to preset these options.

Manual export
The File > Export Design Information command allows you to output 
current design information and machine runtime settings to CSV file.

The CSV output file includes the following fields. The first group derives 
from the Design Information > Design and Stitching tabs. The 
second group derives from Machine Runtime Settings.

Field Description

Date Date and time of exporting properties.

Design data Derived from design tab

File name Name design saved under.

Machine format Machine format of design.

Stitches Total number of stitches in design.

Colors Total number of thread colors in design.

Color changes Total color changes – may or may not coincide with number 
of colors.

Stops Number of machine stops in design.

Trims Number of trims in design.

Sequins Number of sequins in design.

Bling Number of individual rhinestones in design.

Height (mm) Height of sewing area - derived from design extents.

Width (mm) Width of sewing area - derived from design extents.

Automatically
record runtime

data to CSV file

Manually output
design information,

including runtime
data
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Related topics...
 Viewing design information

Stitching data Derived from stitching tab

Total thread (m) Total length of thread used in design.

Design area (mm²) Area covered by design - calculated according to design 
extents.

Runtime data Derived from runtime settings tab

Below / Above Number of stitches stitched at slow and high speed 
according to ’slow above’ parameter. Combined numbers 
should equate to ’Stitches’ value.

Machine Machine as shown on Machine Runtime Setup dialog. If 
there are multiple machines defined, a separate line entry 
appears for each.

Normal (high) speed 
(RPM)

Runtime setting as shown on Machine Runtime Settings 
dialog.

Slow speed (RPM) Ditto

Slow above (mm) Ditto

Trim time (sec) Ditto

Color change time 
(sec)

Ditto

Stop time (sec) Ditto

Design start time 
(sec)

Ditto

Design end time 
(sec)

Ditto

Runtime (min:sec) Calculated runtime of this design according to particular 
machine as shown on Design Information > Runtime tab. If 
there are multiple machines defined, a separate line entry 
appears for each.

Field Description
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Print runtime estimates

The Production Worksheet prints runtime information. Three fields 
pertaining to the information appear under the Blocks tab – ‘Area’, ‘Total 
thread’ and ‘Machine runtime’.

The Machine runtime checkbox is only available if the feature is 
available in the software. If there are no machines set up, checking 
‘Machine runtime’ has no effect as there is nothing to print. Total thread 
prints the information of the same name in the Design Information 
docker. This information is included in both Production Worksheet and 
Production Summary.

Related topics...
 Viewing design information
 Customizing design reports
 Printing design reports

Setting up scanners

EmbroideryStudio supports WIA-compatible scanners. Some scanners 
will not work with EmbroideryStudio because they require their own 
scanner software. If this is the case with your scanner, use your scanner 
software for scanning, save the image to your hard drive, then load the 
image into EmbroideryStudio.

To set up scanners
1 Connect the scanner using the accompanying instructions.
2 Set it up in MS Windows® using the accompanying instructions and/or 

the Microsoft MS Windows® documentation.
3 Start EmbroideryStudio.

Runtime
estimate settings
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4 Select Setup > Scanner Setup. The Select Source dialog opens 
displaying a list of scanner drivers loaded on your computer.

5 Select the scanning driver to use, then click Select.

Note: If you have trouble with scanning after re-starting 
EmbroideryStudio, there may be a conflict with previously installed 
scanner drivers. Re-install EmbroideryStudio and test the scanner. If 
the selected scanner driver does not work in EmbroideryStudio, select 
another scanner driver from the list. There are usually two installed for 
each scanner.

Connecting digitizing tablets

You can use a digitizing tablet and puck with EmbroideryStudio as an 
alternative to digitizing directly on-screen. To use a tablet, you place an 
enlargement drawing on the active area, and use the puck to mark 
reference points.

Caution: EmbroideryStudio cannot use the MS Windows®-compatible 
drivers of some tablets – e.g. GTCO and Calcomp tablets. Earlier versions 
of WinTab do not free up the COM port, even when it is not in use. This 

Select scanning
driver

WACOM Intuos3 digitizing table 
featuring 1024 levels of pressure 
sensitivity and pen tilt sensitivity. 
Can be used with a normal mouse 
or lens cursor
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means EmbroideryStudio is unable to communicate with the digitizing 
tablet. Check with the tablet manufacturer to obtain a version of tablet 
software which will free the port when not in use. Alternatively, the 
software may disable or uninstall WinTab, or use another COM port when 
working with EmbroideryStudio.

Set up digitizing tablets

EmbroideryStudio can only support one tablet at a time. The format and 
the preferred pointer display mode must be specified. 

To set up a digitizing tablet
1 Connect the digitizing tablet and puck using the accompanying 

instructions, and run EmbroideryStudio.
2 Select Legacy Features > Hardware Setup.

3 From the Type list, select Digitizer.

Use Legacy Features > Hardware Setup to set up a machine connection 
with name, port, and protocol.

Select Digitizer

Click to access 
digitizer settings
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4 Click Settings. The Digitizer Setup dialog opens.

5 Use the Name and Comment fields to uniquely identify the digitizing 
tablet.

6 In the Format panel, select a digitizer format.
Select from standard digitizer formats or select Auto Detect to 
automatically match the format to the connected digitizer. Not all 
digitizers can be automatically detected by EmbroideryStudio. For 
these tablets, you can define a new format or modify existing format 
settings.

7 From the Input Mode list, select Point or Stream.
This setting must be the same as the one you specified on the 
digitizing tablet:

8 From the Port list, select the COM port to which the digitizer is 
connected.
Digitizing tablets generally connect to COM1 but can connect to any 
available serial COM port. 

9 Click Setup to access the serial port settings. These settings must be 
the same as those set on the digitizing tablet, or EmbroideryStudio will 
not be able to communicate with it. 

Mode Function

Point In this mode, the pointer position on screen is only updated 
when you click a button on the puck.

Stream In this mode, the pointer position is continuously updated. When 
you move the digitizer puck on the tablet, the pointer moves on 
screen.

Enter name

Select digitizer
format

Select input
mode

Select COM
port

Click to access 
serial port settings
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Note: If you use Stream mode, you need to set the digitizer to 
transmit at 20 data packets per second or less. The baud rate for the 
digitizing tablet and serial port must both be set to 9600 baud. 

Caution: To avoid loss of data at high speed, it is important to set up 
the tablet correctly. If it can only transmit at greater than 20 data 
packets per second, reduce the baud rate of the tablet from 9600 baud 
to 2400 baud.

10 Click OK then Close.

Related topics...
 Customize digitizing tablet formats
 Serial ports

Customize digitizing tablet formats

If the digitizing tablet format you require is not preset in 
EmbroideryStudio, you can create a new format, or modify an existing 
format to match the output of your tablet. Before starting, review the 
digitizing tablet documentation.

Caution: This functionality is provided for advanced users with 
knowledge of the data protocols supported by their digitizing tablet. Only 
use it if your digitizing tablet does not work with any existing formats.

To customize a digitizing tablet format
1 Access the Digitizer Setup dialog. 

2 In the Format panel:
 To modify an existing format, select the format and click Modify.

Select
digitizer

format

Modify existing 
format

Create new format
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 To define a new format, click Create. The Custom Digitizer Setup 
dialog opens.

3 In the Format Name field, enter a name for the new or modified 
format.

4 In the Format String field, enter the format string your digitizing 
tablet outputs.
Obtain this information from the digitizing tablet documentation.

5 In the Scale field, enter the scale at which you are digitizing. For 
example, a scale of 3.0 means your on-screen design will be one third 
the size you digitize on the tablet.

6 Click OK.

Related topics...
 Set up digitizing tablets

Prepare enlargement drawings

When you digitize with a tablet, you use an enlargement drawing to trace 
the shapes and outlines of the design in the same way you use backdrops 
on-screen. Before you start, you need to prepare the enlargement 
drawing.

To prepare an enlargement drawing
1 Convert the artwork to a technical drawing.

Generally the drawing will be three times larger than the final 
embroidery.

Tip: If the drawing is in hard copy, scale it using a transparency 
projector or photocopier. If you used a graphics application to create 
the artwork, scale it before you print it out.

Enter format
name

Enter format
string for tablet

Enter digitizing
scale
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2 Modify the drawing to make it suitable for embroidery:
 Define shapes that can be easily filled with stitches.
 Overlap and distort shapes to compensate for push-pull.
 Draw digitizing guidelines – e.g. stitch angle lines.

3 Draw origin and rotation reference points.
These points set the position and orientation of the enlargement 
drawing on the digitizing tablet. 

Tip: If the drawing is bigger than the digitizing tablet, enter additional 
points to help you shift the drawing as you digitize.

4 Write the name and scale of the enlargement drawing for future 
reference.

Related topics...
 Shift enlargement drawings

Register enlargement drawings

When you place an enlargement drawing on the digitizing tablet, you 
need to register it so EmbroideryStudio can interpret the design. To 
register an enlargement drawing, enter the scale, and digitize the origin 
and rotation points on the tablet. The origin and rotation points should 
be marked on the enlargement drawing. If they are not, you need to draw 
them in.

Origin

Rotation reference 
point

Scale

Name flower

3:1
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To register an enlargement drawing
1 Select Setup > Tablet Setup.

2 In the Drawing Scale panel, enter the scale of the enlargement 
drawing. To calculate the scale, divide the height the enlargement 
drawing by the required height of the final embroidery. Enlargement 
drawings are generally prepared at a scale of 3.00.

3 Tick the Save as defaults checkbox. This saves the registration 
information for this drawing so you do not have to re-register each 
time you resume digitizing. 

4 Click OK and place the enlargement drawing on the digitizing tablet.
5 Click the origin and rotation points of the drawing with Button 1 of the 

digitizing puck. This completes the registration.

Enter drawing
scale

Select Save as
defaults

Origin

Rotation reference 
point

flower

3:1
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Change drawing scales

You can change drawing scale during digitizing. When you change scale, 
EmbroideryStudio automatically resizes object outlines and regenerates 
the stitches.

To change the drawing scale
1 Select Setup > Tablet Setup.

2 Enter the new drawing scale. To calculate the scale, divide the height 
the enlargement drawing by the required height of the final 
embroidery. Enlargement drawings are generally prepared at a scale 
of 3.00.

3 Tick the Resize Design to Match Drawing checkbox.
4 Tick the Register Drawing checkbox.
5 Click OK.
6 Digitize the origin and the rotation reference points to re-register at 

the new size. The design is resized to the new scale.

Shift enlargement drawings

If the drawing is bigger than the digitizing tablet, you can move it across 
the tablet and continue digitizing. To move a drawing you need to draw, 
and digitize, two additional reference points.

To shift an enlargement drawing
1 Draw additional reference points on the enlargement drawing. 

Position the points so that they will be on the active part of the 
digitizing tablet both before and after the move.

Tip: If you are shifting the drawing up or down, draw the additional 
reference points horizontally. If you are shifting left or right, draw 
them vertically.

Enter new
drawing scale

Tick to resize design to
drawing size
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2 Select Setup > Tablet Setup.

3 Tick the Shift Drawing checkbox.
4 Untick the Register Drawing checkbox and click OK.
5 Click the additional reference points with Button 1 on the digitizing 

puck.

6 Move the drawing so that the part you want to digitize next is over the 
active area of the digitizing tablet, and click the additional reference 
points again. The drawing is re-registered in the new position.

Use digitizing pucks

With a digitizing tablet, you generally use a puck instead of a mouse to 
mark reference points.

To use a digitizing puck
 Position the cross-hairs of the puck over a point on the enlargement 

drawing then press one of the four buttons.

Deselect

Select

Function Button
Mouse or keyb’d 

equivalent
Description

Digitize corner 
point

1 [ Digitize corner reference point when digitizing 
outlines.

Digitize curve 
point

2 ] Digitize curve reference point when digitizing outlines.
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Terminate 
omitting last 
stitch

3 M • Terminate input omitting last stitch – i.e. the fill is 
terminated on the opposite side as the last input 
point.

• Toggle between selected fill stitch type and input 
method, and the Run input tool.

Terminate 
including last 
stitch

4 R • Terminate input including last stitch – i.e. the fill is 
terminated on the same side as the last input point.

• Toggle between selected fill stitch type and input 
method, and the Manual input tool.

Function Button
Mouse or keyb’d 

equivalent
Description
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Chapter 8

Machine Formats

Different embroidery machines speak different languages. They have 
their own control commands for machine functions. Before you can stitch 
a design, it must be in a format which can be understood by the machine. 
When you select a machine format, EmbroideryStudio uses it to translate 
digitized designs into a specific machine-readable form. If required, you 
can customize machine formats to meet specific machine requirements.

Standard machine formats

Different machines require different settings. When you select a machine 
format, EmbroideryStudio uses it to translate digitized designs into a 
specific machine-readable form. Common formats include Barudan, 
Brother, Happy, Marco, Meistergram, Melco, Pfaff, Stellar, Tajima, Toyota, 
Ultramatic and ZSK. Typical modifiable values include stitch and jump 
length, trim functions and color change functions.

0101010101

01
01

01
01

01

10
10

10
10

10

1010101010
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Note: Not all values described here are available for all machine formats. 
See your embroidery machine manual for details.

Stitch & jump length settings

With most machines you can set maximum frame movement, minimum 
stitch length to recognize, and automatic jump length.

To set stitch and jump length
1 Open a design.
2 Access the Machine Format Settings > Standard dialog. Only fields 

relevant to the selected machine format will appear.

3 In the Maximum Stitch field, enter the maximum stitch length to 
allow.
The value you enter depends on the tape code used by your machine:
 Binary coding system: 12.7 mm – e.g. Barudan machines
 Ternary coding system: 12.1 mm – e.g. Tajima machines.

4 In the Minimum Stitch field, enter the minimum stitch length to 
allow.
This sets the default Small Stitches value. Generally the minimum 
stitch length is increased for dense materials and thick threads to 
prevent thread breakage.

5 In the Maximum Jump field, enter the maximum jump length to 
allow.
This sets the default Auto Jump value. Shorter jump values generally 
improve stitch quality and reduce wear on the machine but may 
increase stitch-out time.

6 Click Save then Close.

Related topics...
 Embroidery machine formats
 Eliminating small stitches

Trim functions

With some machine formats you can specify how to format and interpret 
trim functions. Some machines understand specific trim codes. Others 

Adjust stitch and 
jump settings
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interpret multiple jumps as a trim function. Machines without an 
automatic trimmer may not know how to interpret trim functions, and 
may even shift the design when a trim code is encountered. For these 
machines you need to deselect the Output Trims checkbox so that trim 
functions are ignored when the design is stitched.

To set trim functions
1 Open a design.
2 Access the Machine Format Settings > Standard dialog. Only fields 

relevant to the selected machine format will appear.

3 In the Trim panel, select the Output Trims checkbox to include trim 
functions when outputting to the selected machine.
If you deselect the checkbox, trim functions are not removed from the 
design but simply ignored during output.

4 Specify the trim format to use:

5 Click Save then Close.

Related topics...
 Embroidery machine formats

Color-change functions

Machines interpret Color Change functions differently – either as a Needle 
Number or Stop function. Basically, the following rules apply:
 Single-needle machines simply stop when a Color Change or Stop 

function is encountered.
 Some multi-needle machines default to the next color without 

stopping.
 Some multi-needle machines support direct needle addressing.

Option Function

Jumps Use for machines that interpret multiple jumps as trims. Enter 
the required number of jumps.

Trim code For machines that interpret explicit trim commands.

Select to output 
trim functions

Select trim 
function format
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Stop functions
Stop functions allow the operator to manually change threads. They are 
generally used with machines that only have one needle. Stop functions 
are sometimes combined with Jump functions to indicate color changes.

Color-change functions
For those machines that support them, Color Change functions tell the 
machine to move to the next needle whenever a CC function is 
encountered. The machine must have the correct thread colors loaded 
according to the production worksheet.

Needle-number functions
For needle addressing machines, each color ‘slot’ on the color palette 
corresponds to a needle number. Needle Number functions are 
sometimes combined with Jump functions to indicate color changes.

For needle addressing machines, you need to specify how many needles 
are on the machine. This tells the machine how often it needs to stop for 
the operator to change threads. For example, for a design with 15 colors 
to be stitched out on a machine with five needles, it must stop after every 
three color changes in order for the operator to change threads.

To set color change functions
1 Open a design.

Thread chart

Thread list

Color/needle 
sequence
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2 Access the Machine Format Settings > Standard dialog. Only fields 
relevant to the selected machine format will appear.

3 In the Color Change panel, select a method for interpreting 
color-change functions:

4 For needle-addressing machines, enter the number of needles on the 
machine in the No of Needles field. 

5 Optionally, select the Use Group Addressing checkbox.
Some machines can group two heads together so you can stitch a 
design using needles from both heads. For example, if a machine has 
two heads and nine needles per head, the machine moves the hoop 
from the first head under the second head, which allows you to stitch 
18 colors without a manual change. 

Note: If this is the case, enter the combined number of needles on 
the machine in the No of Needles field.

6 Optionally, select the First CC required checkbox.
Some machines require a First CC code to initialize the machine and 
bring the head back to the first color change needle position.

7 Optionally, select the Return to Start checkbox.
This returns the needle to the start of design, preparing the machine 
for the repeat run.

8 Click Save then Close.

Related topics...
 Embroidery machine formats

Method Converts color-change functions to...

Needle no Needle Number functions

Stops Stop functions

Stop & jump Stop and Jump functions

Needle no & 
jumps

Needle Number and Jump functions

Select method to interpret 
color change functions

Select optional 
functions as required

Enter number of 
needles
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Borer functions

Some embroidery machines are equipped with a borer. The borer often 
replaces one of the needles. You need to specify the needle position of 
the borer and its offset value. Borers are often ‘knife’ attachments where 
the cutting position is offset ±12 mm from the main needle. Before the 
machine starts, the frame moves so that the borer is in the correct 
position. This extra frame movement compensates for the borer offset. 
Some machines automatically adjust for this offset when a Borer In 
function is encountered. These machines should have an offset value of 
0. Similarly, if you are using a boring needle (instead of a knife), you do 
not need an offset value. See your machine manual for details.

To set borer functions
1 Open a design.
2 Access the Machine Format Settings > Standard dialog. Only fields 

relevant to the selected machine format will appear.

3 In the Boring panel, enter the required borer offset.
 If your machine automatically inserts an offset when a Borer In 

function is encountered, enter an offset of 0 mm.
 If your machine requires an offset value, enter an offset of 

±12.0 mm.
4 Enter the needle number to which the borer is attached.
5 Click Save then Close.

Related topics...
 Embroidery machine formats
 Boring

End-of-design functions

Some machines require an explicit End of Design function code in order 
to recognize when the end of the design has been reached. Some 
machines do not understand the End of Design function code, requiring 
a Stop code instead. For example, Tajima machines recognize the explicit 
End of Design function code while Happy machines require a simple 
Stop. 

Enter borer offset

Enter needle 
number of borer



EmbroideryStudio e4 Reference Manual 193

To set end-of-design functions
1 Open a design.
2 Access the Machine Format Settings > Standard dialog. Only fields 

relevant to the selected machine format will appear.

3 In the End of Design panel, select the appropriate option for your 
machine:

4 Click Save then Close.

Related topics...
 Embroidery machine formats
 Start/end-of-design sequence

Advanced machine formats

The Advanced tab provides access to additional machine format options. 
Again, the available settings depend on the selected machine format. You 
can set the color change sequence, insert special codes for start or end 
of a design, and enter speed settings. There are also miscellaneous 
settings, including whether to change fabric tension during boring, and 
whether to rewind tape when stitching is complete. Use the Machine 
Format Settings dialog to define values to allow when outputting to a 
specific machine format.

Note: Not all values described here are available for all machine formats. 
Use these instructions to enter values that apply to your selected format. 
Only change Advanced values if you are familiar with the codes used by 
your embroidery machine. See your embroidery machine manual for 
more information. 

Option Function

End of design Some machines require an explicit End of Design function 
code – e.g. some Tajima machines.

Stop Some machines require a Stop code instead – e.g. Happy 
machines.

Select end-of-design 
option
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Color-change sequence

Some machines cannot interpret color-change functions unless they form 
part of a ‘color change sequence’ made up of empty stitches and empty 
jumps before and after each color change. Check your machine 
requirements to determine whether you need to enter color-change 
sequence values. 

In the Advanced tab, the Color Change Sequence panel reads from 
top to bottom, in the order the codes appear in the sequence. The first 
two fields show the number of empty stitches and empty jumps to insert 
before the color change. The other fields show the empty jumps and 
empty stitches to insert after the function.

Related topics...
 Embroidery machine formats

Start/end-of-design sequence

In addition to an End of Design function, some machines require extra 
empty stitches and empty jumps in order to stitch the start and end of a 
design. Other machines require a Stop function. Depending on the 
machine type, you may also require functions to initialize the machine or 
trigger a frame-out after stitching.

Color Change Sequence in Stitch List 
matches sequence defined in Machine 
Format Settings Advanced tab

Enter number of Empty 
Stitches and Jumps to insert 
at end of design

Enter number of Empty 
Jumps and Stitches to insert 
at start of design



EmbroideryStudio e4 Reference Manual 195

Where available, the Set Needle Number option initializes the machine 
and brings the head back to the first color change needle position.

Where available, the Frame Out option triggers the frame to exit after 
stitching the design.

Note: Remember that these fields show the number of extra codes you 
want to insert in addition to default settings.

Related topics...
 Embroidery machine formats

Speed options

Some machines can stitch at different speeds. Depending on your 
machine, you may then be able to select different speeds to use when 
you start stitching or for when the borer is engaged.

Where available, the Boring Auto Speed Changes option in the 
Advanced tab slows the machine automatically whenever the borer is 
engaged. From the Start list, select the preferred starting speed – Fast 
or Slow. From the Fast list, select the faster setting on your machine – 
Speed 1 or Speed 2. Check your machine manual for details.

Related topics...
 Embroidery machine formats

Select to initialize machine
and bring head back to first

needle position

Select to trigger
frame to exit after

stitch out

Select and adjust 
speed options
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Miscellaneous advanced options

Depending on the machine format, you may also be able to select 
whether to reduce the tension on the fabric while boring, and indicate 
whether to rewind the tape when stitching is complete.

Where available, set the following as needed:

Related topics...
 Embroidery machine formats

Custom machine formats

EmbroideryStudio provides standard formats for most machines. 
However, if your machine is different, you may need to customize the 
machine format settings. For example, if you have different models of the 
same type of embroidery machine, different functions may require 
different values.

Option Function

Tension control 
for boring

This option reduces the fabric tension when the borer is 
engaged.

Stop before 
rewind at end

This option stops the machine at the end of the design and 
rewinds the tape. 

Rewind with 
Jump at end

This option inserts a jump at the end of the design and rewinds 
the tape.

Click to create 
custom format

Click to create 
design format
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Creating custom formats
You can create a new machine format based on a standard machine 
format, and make it available to all designs.

 In the Format Name field, enter a name for the new format – e.g. 
Melco-1.

 In the Comment field, enter any information that will help you 
identify the machine format – e.g. No Trim.

 Adjust Standard and Advanced machine format settings as needed. 

Creating design-specific formats
You can create a custom machine format for use with the current design. 
You cannot change the Name or Comment fields. The custom machine 
format is automatically named using the original machine format and 
design name – e.g. Melco-Design1.

Note: If necessary, you can update the standard machine format itself. 
However, you should only do this if the original values are no longer used.

Related topics...
 Embroidery machine formats
 Standard machine formats
 Advanced machine formats

Enter new 
format name
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PART III
EMBROIDERY DIGITIZING

In EmbroideryStudio, you build designs from basic shapes or ‘embroidery 
objects’. These are like ordinary vector objects in that they have certain 
defining characteristics or ‘properties’ such as color, size, position, and so 
on. They also have properties unique to embroidery such as stitch type 
and density.

Stitch types
This section explains how to select stitch types for your various fills, 
including how to create Satin fills, Tatami, Motif, and Contour fills, and 
how to adjust stitch settings for best results. It also describes how to 
create Zigzag and E Stitch fills and borders. See Stitch Types for details.

Digitizing shapes
This section discusses the automatic conversion of vector to embroidery 
objects. It also deals with manual digitizing methods, including digitizing 
free shapes, simple borders, and complex column shapes. See Digitizing 
Shapes for details.

Object properties
This section explains how to change property settings in a design, as well 
as how to apply and adjust fabric settings. It also explains how to create 
and maintain styles and templates in EmbroideryStudio. See Object 
Properties for details.

Colorways
When digitizing, you select colors from the color palette. This contains a 
selection of colors which can be tailored to each design or color scheme. 
The particular ‘colorway’ represents the actual thread colors in which a 
design will be stitched. You can define multiple color schemes and switch 
between them. See Colorways for details.
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Chapter 9

Stitch Types

All embroidery objects in EmbroideryStudio contain defining settings or 
properties. Some, such as size and position, are common to all objects, 
while others are specific to object type. The most important property of 
all is stitch type. The software uses object outlines and the associated 
stitch type to generate stitches. Whenever you reshape, transform or 
scale an object, stitches are regenerated according to current settings.

Stitch types divide broadly into two categories – outlines and fills. 
Different stitch types suit different shapes. Some stitch types are suitable 
for both outlines or fills. Others are dedicated to one or other purpose. A 
stitch type can be selected together with a digitizing method or applied 
afterwards. Whenever you create an object from scratch, it takes the 
currently selected stitch type.

Simple outlines

EmbroideryStudio provides tools for creating 
outline stitching of varying thicknesses and 
styles. They are typically used to add borders 
and pickout runs. There are tools for creating 
simple run stitching as well as a wide variety 
of decorative outlines. Outline stitch types 
can be interchanged. 
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Simple run stitching

Use Run to digitize lines of simple run stitching. Use Triple Run for 
emphasis. This stitch type is typically used for thicker borders and 
outlines. Sculpture Run creates thick-thin alternating single and triple 
stitching for a hand-stitched look. Adjust stitch length, chord gap, stitch 
repetitions, and other settings via the Object Properties docker.

Tips for use...
 Both Traditional Digitizing and Graphics Digitizing toolbars 

contain tools for digitizing outlines. These tools place a row of stitching 
along a digitized line.

 EmbroideryStudio provides tools for automatically generating 
outlines. 

 Use Backtrack and Repeat to reinforce outlines while specifying the 
direction of the stitching. 

 Swap outline types at any time, including vector outlines. Vector 
objects of course have no stitch properties. Satin outline width can be 
controlled via object properties or using the Reshape tool. 

Use Outline Stitch Types > Run to place a row of single run stitches along 
a digitized line. Right-click for settings.

Use Outline Stitch Types > Triple Run to place a triple row of run stitches 
along a digitized line. Right-click for settings.

Use Outline Stitch Types > Sculpture Run to create a thick-thin outline 
alternating single and triple stitches for a hand-stitched look.
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Related topics...
 Digitizing outlines & details
 Creating vector shapes in EmbroideryStudio
 Reinforce outlines
 Generating outlines & offsets
 Reshape Column C objects

Stitch length settings

For run stitch and other outline stitches, stitch length can be adjusted to 
suit the shape.

To adjust stitch length
 Right-click the icon to access object properties.

 To set a fixed stitch length, adjust the Length field. For sharp curves, 
reduce length – e.g. 1.8 mm – so that the stitches follow the line more 
closely. Mimic hand-made embroidery by increasing length to, say, 
4.0 mm.

 Alternatively, automatically shorten stitches to follow tight curves with 
the Variable Run Length option.

Use Outline Stitch Types > Run to place a row of single run stitches along 
a digitized line. Right-click for settings.

Adjust nominal 
stitch length

Adjust variable run 
length values

Change stitch 
type

Turn on/off
variable run

length

Too few stitches to follow 
tight curve

Stitches follow the curve 
more closely

Run length Run length
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 In the Chord Gap field, enter the maximum distance to allow between 
the digitized outline and the stitches.

 In the Min Len field, enter the minimum stitch length to allow. Stitch 
length will not reduce to less than this value, even if the chord gap is 
exceeded.

Run count setting

By default, Triple Run repeats each stitch three times. You can change 
the number of repetitions by adjusting the Run Count value.

Tip: Use Backtrack and Repeat to reinforce outlines while specifying 
the direction of the stitching. See Reinforce outlines for details.

Run
length

Chord 
gap

Fixed run length Variable run length:
0.07 mm (default)

Variable run length:
2 mm

Use Outline Stitch Types > Triple Run to place a triple row of run stitches 
along a digitized line. Right-click for settings.

Single Run

Stitch length

Triple Run

1 2 3 4 5 6

1

2

3

5

6

4

Select run count
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Sculpture run settings

Sculpture Run provides independent stitch length parameters for 
alternating stitches. This is handy for creating a hand-stitched look. 
Apply to open or closed shapes. Default alternating values are equal but 
can be independently set – e.g. A=2.5 mm and B=1.5 mm. Also, the 
number of A/B repeats can be independently set. The default setting is 
#A=3, #B=1.

Satin stitching

Satin is one of those stitch types which can be used for thicker borders 
or for fills. It is well-suited to narrow shapes where each stitch spans the 
width of the column. Because there are generally no needle penetrations 
breaking up the fill, satin stitch gives a glossy, high-quality appearance.

Tip: The Auto Split and Auto Jump features help you to control long satin 
stitches. See Optimizing long satin stitches for details.

Use Outline Stitch Types > Sculpture Run to create a thick-thin outline 
alternating single and triple stitches for a hand-stitched look.

B B

AA

Run count and length 
A can be different to B
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Applying satin stitch

In EmbroideryStudio, the Auto Spacing option is turned on by default. 
For most purposes, this option avoids thread breaks and creates visually 
appealing columns of satin stitches.

If a column is too wide, stitches may be loose and not cover the fabric 
properly. Conversely, in very narrow columns, stitch density may be too 
high and needle penetrations damage the fabric. Adjust stitch density by 
setting a fixed spacing, or let Auto Spacing calculate spacings wherever 
column width changes.

To apply satin stitch with auto-spacing
1 Select the digitizing method you want to use – e.g. Column C. 
2 Select Satin and create an embroidery object. Alternatively, select an 

existing embroidery object and click Satin.

Use Fill Stitch Types > Satin to apply satin stitch to new or selected narrow 
columns and shapes. Right-click for settings.

Use Outline Stitch Types > Satin to create thicker borders or columns of 
even thickness. Right-click for settings.

Use Fill Stitch Types > Satin Raised to create raised surfaces – can be 
applied to lettering or used with trapunto for quilting effects. Right-click for 
settings.

Use Outline Stitch Types > Satin Raised to create raised satin borders – 
can be used with outlines for quilting effects. Right-click for settings.
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3 Right-click the Satin icon to access object properties.

4 Tick Auto Spacing if not already checked.
5 Adjust Stitch Density for more or less open fills.

Density is given as a percentage of preset values:
 To decrease, increase the percentage – e.g. to 110-115%.
 To increase, decrease the percentage – e.g. to 90-85%.
75% generally produces high quality embroidery. An increased stitch 
count means the design will take longer and be more expensive to 
stitch.

6 Press Enter or click Apply. 

Note: For even more precise results, you can adjust Auto Spacing 
settings. 

Related topics...
 Embroidery digitizing
 Satin auto-spacing

Satin auto-spacing

Adjust density
percentage

Select Auto
Spacing

100% – no adjustment <100% – more stitches>100% – fewer stitches

Use Fill Stitch Types > Satin to apply satin stitch to new or selected narrow 
columns and shapes. Right-click for settings.
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Adjust Auto Spacing to specify how rapidly spacing changes and by how 
much. You can also specify spacing offsets to adjust for different thread 
types. These settings are intended for digitizing experts. You will usually 
want to save modified settings to a template. 

To adjust auto-spacing settings
1 Right-click the Satin icon to access object properties.

Use Outline Stitch Types > Satin to create thicker borders or columns of 
even thickness. Right-click for settings.

Use Fill Stitch Types > Satin Raised to create raised surfaces – can be 
applied to lettering or used with trapunto for quilting effects. Right-click for 
settings.

Use Outline Stitch Types > Satin Raised to create raised satin borders – 
can be used with outlines for quilting effects. Right-click for settings.

Length 1

Spacing 1

Spacing 2

Length 2

Auto spacingFixed spacing

Click to adjust
Auto Spacing

values

Select Auto
Spacing
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2 Click Settings. The Auto Spacing Settings dialog opens.

3 Adjust stitch settings in the Stitch panel:

4 Adjust spacing offsets for different thread types.
The offset determines the amount by which stitch settings will be 
adjusted for different thread thicknesses.

Setting Function

Length These values define the increments by which spacing is adjusted. 
The smaller the distance between each length, the more rapidly 
stitching changes from open to dense. Each length must be 
greater than the preceding.

Spacing These values define the spacing corresponding to each stitch 
length. See below.

Thickness Description Default

A Normal embroidery thread (approx. denier 40) 0.01

B Thicker than normal (approx. denier 30) 0.03

C Finer than normal (approx. denier 80) -0.03

D Very fine (approx. denier 100) -0.06

Adjust stitch
length values

Adjust spacing
values

Enter spacing 
offsets for each 
thread type

Default spacing values Custom spacing values



Chapter 9   St itch Types 208

Note: You assign the thread type in the Add Thread dialog. Stitch 
spacing of the assigned thread type is automatically adjusted 
according to the values set there. 

5 Click OK.

Related topics...
 Working with templates
 Modify thread details

Satin fixed spacing

In EmbroideryStudio, the Auto Spacing option is turned on by default. 
Sometimes, however, you may want to control the exact spacing of satin 
columns. Fixed spacing is sometimes used, for example, for decorative 
effects – e.g. very open spacing over, say, a tatami background. These 
effects cannot be achieved with Auto Spacing.

Tip: If you are using a digitizing tablet, you can quickly switch between 
preset styles with different spacing settings. Each button on the puck 
accesses the next preset style. For example, clicking button 1 accesses 
<PRESET_SATIN_1>.

To apply satin stitch with fixed spacing
1 Select the digitizing method you want to use – e.g. Column C. 

Use Fill Stitch Types > Satin to apply satin stitch to new or selected narrow 
columns and shapes. Right-click for settings.

Use Outline Stitch Types > Satin to create thicker borders or columns of 
even thickness. Right-click for settings.

Use Fill Stitch Types > Satin Raised to create raised surfaces – can be 
applied to lettering or used with trapunto for quilting effects. Right-click for 
settings.

Use Outline Stitch Types > Satin Raised to create raised satin borders – 
can be used with outlines for quilting effects. Right-click for settings.
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2 Select Satin and create an embroidery object. Alternatively, select an 
existing embroidery object and click Satin.

3 Right-click the Satin icon to access object properties.

4 Untick Auto Spacing.
5 In the Spacing field, enter a fixed spacing:
 To increase density, enter a smaller value.
 To reduce density, enter a larger value.

6 Press Enter or click Apply. 

Related topics...
 Embroidery digitizing

Satin stitch count

Adjust stitch 
spacing

Deselect Auto
spacing

Stitch spacing 0.5 mm Stitch spacing 0.7 mm Stitch spacing 0.9 mm

Use Fill Stitch Types > Satin to apply satin stitch to new or selected narrow 
columns and shapes. Right-click for settings.

Use Fill Stitch Types > Satin Raised to create raised surfaces – can be 
applied to lettering or used with trapunto for quilting effects. Right-click for 
settings.

Use Outline Stitch Types > Satin to create thicker borders or columns of 
even thickness. Right-click for settings.
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Satin Raised is often used for folk 
designs to mimic handmade 
embroidery that uses thicker thread. 
If you require thicker stitches, set the 
satin stitch to repeat itself multiple 
times. Use Satin Raised to create 
raised surfaces consisting of multiple 
layers of satin stitching. This can also 
be applied successfully to some styles 
of font for a raised embroidery 
surface.

To adjust satin stitch count
 Right-click the Satin icon to access object properties.

 Enter the number of repetitions in the Satin Count field.

Caution: Using a value higher than 10 may cause thread breaks, 
depending on the design, fabric, or thread tension.

Use Outline Stitch Types > Satin Raised to create raised satin borders – 
can be used with outlines for quilting effects. Right-click for settings.

Adjust satin
count

Adjust satin
layers
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 With Satin Raised you can also adjust the number of layers of 
stitching.

 Press Enter or click Apply.

Tip: When you increase satin stitch count, you should also increase 
the spacing to avoid bunching and thread breaks. 

Related topics...
 Satin fixed spacing
 Optimizing long satin stitches
 Applying stitch types & effects to lettering

Tatami stitching

Tatami stitch consists of rows of run stitches and is suitable for filling 
large shapes. Stitch offsets in each row are used to eliminate horizontal 
split lines.

Increase satin count 
for more layers
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Tatami density

Tatami stitch density is determined by the distance between each row of 
stitches. Sometimes row spacing is increased to create more open 
stitching for backgrounds and special effects.

Tip: When you increase stitch spacing, Auto Underlay should be turned 
off. If too open, you may also find that travel runs and overlapping 
segments spoil the effect. The Trapunto effect automatically moves 
underlying travel runs to the edges of an object so that they can’t be 
seen. 

To set tatami density
1 Select the digitizing method you want to use – e.g. Complex 

Turning. 
2 Select Tatami and create an embroidery object. Alternatively, select 

an existing embroidery object and click Tatami.

Use Fill Stitch Types > Tatami to create fills for larger irregular shapes. 
Right-click for settings.

Use Outline Stitch Types > Tatami to create borders or columns of even 
width for different needle penetration patterns.

Row spacing

Row direction

Stitch length

Offset 
fraction
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3 Right-click the Tatami icon to access object properties.

4 Adjust Spacing as required. For increased density, enter a smaller 
value. For more open stitching, enter a larger value.

5 Adjust Length as required.

6 In the Min length field, enter the length of the shortest stitch to be 
generated.

7 Adjust other settings as desired. 
8 Press Enter or click Apply.

Related topics...
 Embroidery digitizing

Adjust stitch spacing

Adjust stitch length

Spacing: 0.4 mm Spacing: 0.6 mm Spacing: 0.8 mm

Length: 4.5 mm Length: 2 mm Length: 1 mm

Length: 4 mm
Minimum stitch: 0.4 mm

Length: 4 mm
Minimum stitch: 0.8 mm

Length: 4 mm
Minimum stitch: 1.2 mm
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 Object property apply options
 Trapunto open stitching

Other tatami settings

Tatami settings also allow you to control needle offsets for more even 
distribution of needle points or for patterned effects. Choose a different 
backstitch type to control edge stitching.

Offsets
With tatami fills you can specify how each row is offset in order to create 
patterns formed by needle penetrations. You do this by adjusting either 
offset fractions or partition lines. 

Tip: Using a Random factor you can eliminate the split line patterns 
formed by regular needle penetrations and distribute stitches randomly 
inside a shape. 

Adjust offsets to
create patterned

effects

Adjust backstitch
to control

appearance of
borders
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Backstitch
Tatami backstitch is the term used for every second row of stitches in a 
tatami fill. There are three types available – Standard, Borderline, and 
Diagonal.

The table below describes the differences:

Related topics...
 Creating textures with tatami offsets
 Create random patterns
 Trapunto open stitching
 Jagged edges

Decorative embroidery

EmbroideryStudio provides many techniques for embellishing the basic 
stitch types covered in this section. Some are treated as stitch types in 
their own right – both outline and fill – and appear on the Stitch Types 

Type Notes

Standard 
backstitch

Because the rows are different lengths, there are fewer small 
stitches at the edge of the shape, reducing possible damage to the 
fabric. Standard backstitch is suitable for high density fills.

Borderline 
backstitch

With lower density fills, borderline backstitch creates a smooth, 
well-defined edge. Borderline backstitch is also called Trapunto 
style. 

Diagonal 
backstitch

The backward rows are diagonal, directly connecting the forward 
rows. Diagonal backstitch is suitable for turning shapes, and gives 
good results with Jagged Edge. 

Standard backstitch Borderline backstitch Diagonal backstitch
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toolbars. Others can be applied as stitch effects. In all cases, the 
digitizing techniques are similar. See also Digitizing Shapes.

Decorative outlines

While simple run stitching is typically used to add borders and pickout 
runs, there are stitch types for creating decorative outlines. Backstitch is 
an older-style, adaptable stitch which can be used for delicate outlines. 
Stemstitch is thicker and can be used to mimic hand-sewn embroidery. 
Digitize decorative outlines as you would a Run stitch outline. 

Graphical and 
traditional digitizing 
tools

Fill and outline
stitch types

Stitch effects applied in 
addition to stitch types

Thread colors applied in 
addition to stitch types

Use Outline Stitch Types > Backstitch to place a row of backstitches along 
a digitized line. Right-click for settings.

Use Outline Stitch Types > Stemstitch to place a row of stemstitches along 
a digitized line. Right-click for settings.
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To create decorative runs
 For more delicate outlines, use Backstitch. Backstitch is an 

older-style, adaptable stitch which follows intricate curves well.

 Backstitch settings allow you to specify exact stitch length, chord 
gap, thickness and overlap values as well as number of strokes. 
Length, Min Length, and Chord Gap values work like the Variable 
Run Length option.

 For thicker, decorative lines, use Stemstitch. Stemstitch can be used 
to mimic hand-sewn embroidery. It is used for stems and vines with 
other decorative stitches, or as an outline for satin or motif fills.

Run length: 1.5 mm

Stitch thickness: 
0.25 mm

Strokes: 5
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 Stemstitch settings allow you to specify exact stitch and line 
thickness, spacing and overlap values as well as thickness (number of 
strokes).

Note: For Triple stitching, you can also adjust Stitch Thickness.

Related topics...
 Embroidery digitizing
 Digitizing outlines & details
 Converting designs with CorelDRAW Graphics

Border stitching

The Stitch Types toolbars include Zigzag, E Stitch, and Square. All 
can be used to create borders around appliqués and other embroidery 
objects. They can also be used for decorative effects or open fills where 

Line thickness: 1.5 mm

Spacing: 1.2 mm

Angle: 90°

Click Outline Stitch Types > Zigzag to create open borders or columns of 
even width for an open ‘sawtooth’ effect. Right-click for settings.

Use Outline Stitch Types > E Stitch to create open borders or columns of 
even width for an open ‘comb’ effect. Right-click for settings.

Use Outline Stitch Types > Square to create open borders or columns of 
even width for an open ‘toothed’ effect. Right-click for settings.
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fewer stitches are required. Zigzag and double zigzag stitches are also 
frequently used as underlays. See also Decorative borders.

Patterned stitching

EmbroideryStudio provides tools for creating patterns with needle 
penetrations. Apply offset fractions or partition lines to tatami fills for a 
variety of split-line effects. Alternatively, use Program Split or Flexi 
Split to create decorative fills from predefined patterns. Select from the 
library or create your own. The Carving Stamp feature allows you to 
define patterns using a ‘carving stamp’ as a template. Use it also to 

Use Fill Stitch Types > Program Split to create decorative fill stitches where 
needle penetrations form a tiled pattern.

Use Outline Stitch Types > Program Split to create borders or columns of 
even width for decorative needle penetration patterns. Right-click for 
settings. 
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create your own split lines when you want to add detail to filled objects. 
See also Patterned Stitching.

Related topics...
 Creating textures with tatami offsets
 Creating textures with program splits
 Creating patterns with custom splits
 Creating patterns with carving stamps

Curved stitching

EmbroideryStudio provides a variety of stitch types and techniques for 
creating curved stitching effects. These follow the contours of a shape 

Choose from the 
pattern library
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and can be used to give a sense of depth and movement to your stitching. 
Some can be used with borders as well as fills. See also Curved Stitching.

Curved stitch effects covered in the related topics below include:

Related topics...
 Contoured fills
 Offset fills
 Spiral fills
 Radial fills
 Flexi-splits
 Curved fills

Feature Overview

Contour Stitches follow the contours of a shape, creating a contoured, 
light and shade effect. 

Offset Similar to Contour in following the contours of a shape. It can 
be used in combination with turning stitches. 

Spiral Fill Works best with simple shapes without holes or islands. Use 
it with either fixed or variable length run stitching.

Radial Fill Generates radial turning stitching in several stitch types such 
as Satin, Tatami and Program Split.

Flexi Split Decorative effect where one or more lines of a program split 
pattern are molded to the object shape.

Florentine / 
Liquid

Create interesting curved effects by getting needle 
penetrations to follow the contour of digitized lines.
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Specialty stitching

EmbroideryStudio provides many specialty effects and stitch types to 
create artistic fills. These can be used to create more organic, naturalistic 
stitching. They can be used to create textures like feathers or wool. Use 
them also to create open stitching with low stitch counts. See also 
Specialty Stitching.

Specialty stitch effects covered in the related topics below include:

Feature Overview

Freehand
Create designs with a hand-drawn appearance, something 
which is difficult to achieve through conventional digitizing 
methods. See Freehand embroidery for details.

Hand Stitch Create hand-stitch effects which combine randomized stitch 
length, angle and count. See Hand stitch effect for details.

Jagged 
Edge

Create rough edges, shading effects, or imitate fur and other 
fluffy textures. See Jagged edges for details.

Stipple Create textured fills of run stitching which meanders more or 
less randomly within a border. See Stippling effects for details.

Maze Fill Create maze-like stitching which follows object contours for 
open fills. See Maze fills for details.

String
Ideally suited to creating craftstitch fills as well as delicate 
borders. Can be used as a border for fixing ornamental mirrors 
and sequins. See String stitching for details.

Zigzag Create fills or open borders or columns of even width for an 
open ‘sawtooth’ effect. See Decorative borders for details.
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Motif stitching

Motifs are predefined design elements, such as hearts, leaves or border 
patterns. They generally consist of one or more simple objects, and are 
stored in a special motif set. Motifs can be used for ornamental outlines 
and patterned fills. Use the ones provided with the software or create 
your own. Motifs can be scaled, rotated and mirrored in the same way as 

E Stitch Create fills or open borders or columns of even width for an 
open ‘comb’ effect. See Decorative borders for details.

Trapunto
Move internal travel runs to the edges of an object so that they 
can’t be seen through open stitching. See Trapunto open 
stitching for details.

Accordion 
Spacing

Vary stitch spacing between dense and open fill, producing 
gradient and shading effects. See Accordion spacing for 
details.

Color 
Blending

Like Accordion Spacing but used to create color blends where 
two colors are merged from one to another using a mixture of 
dense and open fill. See Color blends for details.

Chenille
Incorporate stitch patterns traditionally associated with 
chenille work – Square, Double Square, Coil, and Island Coil. 
See Chenille patterns for details.

Cross 
Stitch

Fill large areas with cross stitching on an invisible grid that 
applies to all design objects. See Cross stitch fills for details.

Feature Overview

Use Outline Stitch Types > Motif Run to create a string of motifs along a 
digitized line.

Use Fill Stitch Types > Motif Fill to create decorative fills using embroidery 
motifs to form repeating patterns. Right-click for settings.

Use Traditional Digitizing > Use Motif to add motifs to design one-by-one. 
Rotate, scale, or mirror as you add.



Chapter 9   St itch Types 224

other objects. You can even use them to create interesting three 
dimensional effects. See also Motif Stitching.

Note: Auto Underlay is deactivated with this feature and stitch angle 
has no effect.

Related topics...
 Selecting & placing motifs
 Motif runs
 Motif fills



EmbroideryStudio e4 Reference Manual 225

Chapter 10

Digitizing Shapes

In EmbroideryStudio, you build designs from basic shapes or embroidery 
objects. These are like ordinary vector graphics in that they have defining 
characteristics or ‘properties’ such as color, size, position, and so on. 
They also have properties unique to embroidery such as stitch type and 
density. The most important property of an embroidery object is its stitch 
type. Different stitch types are suited to different shapes.

Tip: EmbroideryStudio also lets you convert vector objects directly to 
embroidery objects. In fact, entire vector designs can be converted to 
embroidery. See also Convert objects with CorelDRAW Graphics.

Embroidery digitizing

The process of creating embroidery objects on screen is called ‘digitizing’. 
Like design creation in CorelDRAW Graphics, this involves the use of 
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‘input’ or ‘digitizing’ methods. In fact, digitizing tools in EmbroideryStudio 
can be used to generate both embroidery objects and vector objects.

Tip: The CorelDRAW® Graphics Suite of curve-line digitizing tools such 
as B-Spline Curve, Freehand, Bézier, Pen, etc, are very useful. 
Objects created with these tools can be converted directly to embroidery. 
See also Convert objects with CorelDRAW Graphics.

Digitizing methods

EmbroideryStudio provides an outline/fill digitizing paradigm similar to 
CorelDRAW® Graphics Suite and other graphics applications. This 
makes embroidery digitizing easy for those coming from a graphic design 
background. It also makes it easy to convert between outlines and fills 
generally. For those coming from an embroidery background, the toolset 
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also provides traditional ‘power digitizing’ methods professional digitizers 
are familiar with.

Digitizing toolset
The toolset you will typically use for digitizing work includes some or all 
of the following:

Graphics digitizing
The graphics approach to digitizing is similar to CorelDRAW® 
Graphics Suite or other graphics applications. It provides one set of 

Toolbar Function

Graphics 
Digitizing Select a digitizing method – either graphical or traditional, 

open or closed.Traditional 
Digitizing

Outlines Select a stitch type – either outline or fill. Both open and closed 
shapes may be treated as outlines. Only closed shapes can be 
used in conjunction with fill stitching.

Fills

Stitch Effects Select a stitch effect to apply as you digitize – e.g. smart 
corners. These can be modified at any time.

Color Select a thread color to apply as you digitize. Colors in the 
palette may or may not be assigned to actual threads. It makes 
no difference when you digitize.

Graphical and 
traditional digitizing 
tools

Fill and outline
stitch types

Stitch effects applied in 
addition to stitch types

Thread colors applied in 
addition to stitch types
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tools to create shapes which can be stitched as outlines or fills. You assign 
a stitch type to a shape by selecting from the Stitch Types toolbars.

Traditional digitizing
Traditional digitizing methods divide into three main categories – ‘free 
shapes’, ‘column shapes’, and ‘outlines’.

EmbroideryStudio also provides special time-saving input tools for 
creating stars and rings. See Digitize stars & rings for details.

Tip: Traditional methods also include ‘manual’ digitizing tools. Use these 
to add individual stitches, either singly or three stitch layers at a time. 
See Digitizing manual stitches for details.

Digitizing methods
Different digitizing tools are suited to different shapes or design 
elements. Whichever approach you take – graphical or traditional – 
methods divide broadly into two categories – open or closed – and two 
types – outline or fill. No stitch type, effect, or thread color is set in stone. 
Object properties can be modified at any time.

Whenever you select a traditional digitizing tool, instructions in the 
Prompt Bar guide you through the process. Because these tools use an 

Outlines

Details

Columns

Free-form 
shapes
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embroidery digitizing paradigm, you may be prompted to add multiple 
boundaries for holes, stitch angles, and/or start and end points. Refer to 
the prompts until the tool becomes familiar to you.

Underlays
Embroidery appearance and quality depends a lot on underlay which 
serves as a foundation for cover stitching. Underlay settings are stored 
with each object in the same way as other object properties. They are 
regenerated whenever the object is scaled or transformed. When Auto 
Fabric is turned on, a default underlay is applied, based on fabric 
settings. When Auto Fabric is turned off, an underlay is still applied but 
it is based on the digitizing method.

Tips for use...
 Change settings of most tools by right-clicking and adjusting values in 

the Object Properties docker.
 Use the Prompt Bar to help you digitize.
 If you make a mistake, press Backspace to delete the last point.
 Press Esc to undo all new points. Press Esc again to exit digitizing 

mode.
 Use Auto Scroll to scroll automatically within the design window while 

digitizing.
 Hold down the Shift key to temporarily deactivate Auto Scroll. 
 Use the Ctrl+Shift+A key combination to quickly toggle Auto Scroll 

on/off.

Tip: The Show Repeats function displays repeating designs, including 
sequins, in both TrueView and stitch view. You can view an existing 
design, even while digitizing, with any number of repeats.

Stitch count

Status Bar

Prompt Bar



Chapter 10   Digit izing Shapes 230

Switching between fill & outline
You can switch between a fill stitch input method and Digitize Run or 
Manual by means of shortcut keys.
 Press Enter to switch between a fill stitch digitizing method and 

Manual.
 Press Spacebar to switch between a fill stitch digitizing method and 

Digitize Run.

Tip: After digitizing, most object types can be easily inter-converted. 

Related topics...
 Scroll options
 Viewing design repeats
 Creating free-form shapes
 Digitizing regular columns
 Simple outlines
 Stabilizing with automatic underlay
 Digitize stars & rings
 Freehand embroidery
 Digitizing manual stitches
 Keyboard shortcuts

Reference points & reshape nodes

Once you have selected a digitizing method, you create shapes by 
marking points along an outline.

Right-click for 
curve points

Click for 
corner points

1 3 5 7

8

9

10

11

12

13

14

2 4 6
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Use the left mouse button for corner points and right mouse button for 
curve points. Bézier control handles are available when you come to 
modify a shape.

A few general rules apply:
 To constrain the line to 15° increments, hold down Ctrl as you digitize.
 For a perfect circular arc, mark three points with a right-click, and 

press Enter.

The reference points you mark when digitizing a shape become its 
‘control points’. These vary slightly with the object type. Most points can 
be added, deleted, or moved. Corner and curve points can be 
interchanged. Some control points such as entry and exit points cannot 
be deleted. 

Related topics...
 Reshaping Objects
 Reshaping embroidery objects

Join methods

When you are digitizing closed objects, the Closest Join method 
automatically calculates connector points. When deactivated, all newly 

Curve 
point

Curve 
point

Curve 
point

Connect corners and 
curves with a corner point

Hold down Ctrl to 
constrain the line to 
15° increments

1

2

3 180° 0°

270°

30°

45°
60°90°

Corner reshape node

Exit point

Curve reshape node

Entry point

Stitch angle points

Control handle
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digitized objects are joined by the As Digitized method. This means that 
you manually specify entry and exit points while digitizing. 

Tip: The Apply Closest Join feature allows you to (re-)apply closest join 
to objects after editing.

Related topics...
 Other general options
 Apply closest join

Generate stitches

With Generate Stitches on (the default), stitches are calculated for new 
objects whenever you press Enter. They are also updated whenever you 
scale, transform or move the object. If speed is an issue, you can digitize 
objects with Generate Stitches off.

Closest Join onClosest Join off

Use Stitch > Generate Stitches to generate stitches for selected objects.
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To generate stitches...
 To generate stitches for new or selected objects, select Stitch > 

Generate Stitches or press G.

 To remove stitches, or digitize without generating stitches, deselect 
Stitch > Generate Stitches or press G again.

Tip: Make sure Show Outlines is selected, otherwise stitchless 
objects will not be visible.

Related topics...
 Reshape options
 Change backgrounds

Digitizing with graphical tools

The graphics approach to digitizing is similar to CorelDRAW® 
Graphics Suite or other graphics applications. Assign a stitch type to 
shapes from the Stitch Types toolbars. Graphics digitizing tools are set 
to default values. To adjust the resulting objects, use the stitch angle, 
reshape, and hole tools.

Note: The Graphics Digitizing toolbar also contains ‘freehand’ tools to 
create ‘drawing’ embroidery outlines and fills directly on screen. See 
Freehand embroidery for details.

Related topics...
 Digitize regular shapes
 Digitize open & closed shapes

Press G to 
generate stitches
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Digitize regular shapes

EmbroideryStudio provides digitizing tools for quickly creating regular 
shapes such as circles and squares, ovals and rectangles.

Squares & rectangles
Digitize squares and rectangles with a few clicks of the Rectangle tool. 
Use any fill or outline stitch type.

Click to mark a corner. Drag the pointer and click to define the opposite 
corner. To create a square, hold the Ctrl key down whilst dragging the 
pointer.

Circles & ovals
Digitize filled circles and ellipses with a few clicks with the Ellipse tool. 
You can use any stitch type, including outlines. Contour stitch looks most 
effective with long, narrow ovals.

To digitize circles or ellipses, click to mark the center and click again to 
set the radius, and press Enter. This point becomes the entry point. To 

Use Graphics Digitizing > Rectangle to digitize rectangle or square objects. 
Press <Ctrl> for a square.

Use Graphics Digitizing > Ellipse to digitize ellipse or circle objects.

SatinSingle SplitsMotif RunTatami

1

2
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create an oval, click a third time to mark the second radius point, and 
press Enter.

Related topics...
 Selecting & editing stitches

Digitize open & closed shapes

Use the Digitize Open Shape tool to digitize open shapes with any kind 
of outline stitch. Digitize Open Shape places a row of stitches along a 
digitized line. This tool is typically used to add borders or details to 
designs. Digitize free-form closed shapes with the Digitize Closed 
Shape tool. This tool can be used with either outline or fill stitch types. 

Tip: To create both an outline and a fill, create the fill first, then select 
and duplicate the object and convert the duplicate to an outline, which is 
stitched after the fill.

To digitize an open or closed shape...
 Select a tool – open or closed shape – together with a suitable stitch 

type – outline for open, outline or fill for closed.

Press 
Enter

Press Enter
Center

Center

1

2

1

2

3

Use Graphics Digitizing > Digitize Open Shape to digitize open shapes. 
Press <Ctrl> to constrain.

Use Graphics Digitizing > Digitize Closed Shape to digitize closed shapes. 
Press <Ctrl> to create a square.
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 Choose a color from the Color toolbar. The palette contains a selection 
of colors which can be tailored to each design or color scheme.

 Digitize the shape by marking reference points:
 Click to enter corner points.
 Right-click to enter curve points.

Tip: Follow the prompts in the Prompt Bar to help you digitize. If you 
make a mistake, press Backspace to delete the last reference point, 
then continue adding reference points or press Esc to delete all the 
points so you can start again.

 Press Enter to complete a shape. With the Digitize Closed Shape 
tool, the shape will be closed with the same type of reference point as 
the last you digitized – i.e. corner or curve. To close with a different 
type of reference point, mark the last on top of the first and press 
Enter.

 If you decide to close an open object, use Edit > Close Curve... 
commands to close using straight or curved points.

 Press Esc to deselect the tool.

Note: By default, objects are joined by the Closest Join method. If 
deactivated, all newly digitized objects are joined by the As Digitized 
method. This means you need to specify entry and exit points, 
following prompts in the Prompt Bar. 

Related topics...
 Choosing threads
 Other general options

1

2

3

4

5

6
7

1

2

3

4

5

6

Open object Close object - 
Curve Line

Close object - 
Straight Line
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 Selecting & editing stitches
 Minimizing connectors

Digitizing outlines & details

EmbroideryStudio provides tools for creating outline stitching of varying 
thickness and styles. These tools place a row of stitching along a digitized 
line. They are typically used for adding outlines and details. They can also 
be used for decorative effect.

To digitize outlines and details...
 Select a suitable input tool together with an outline stitch type.

Use Outline > Digitize Run to place a row of single or triple run stitches 
along a digitized line.

Choose input method 
and outline stitch type
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 Alternatively, choose a traditional outline input method from the 
Outline tools.

 In addition to Run and Triple Run, traditional methods include:

 Choose a color from the Color toolbar. You can change colors at any 
time.

 Digitize the shape by marking reference points:
 Left-click for corner points.
 Right-click for curve points.
 To constrain the line to 15° increments, hold down Ctrl as you 

digitize.
 For a perfect circular arc, mark three points with a right-click. 
 Where curves connect – either to a straight line or another curve – 

click to mark the connection point.

Tip: If you make a mistake, press Backspace to delete the last point. 
Press Esc to undo all new points. Press Esc again to exit digitizing 
mode. 

 Press Enter to finish.
 To view stitches better, use the View toolbar to turn on or off 

backdrops.
 Optionally, use Edit > Close Curve... commands to close an object 

using straight or curved points.

Use Motif Run to place a row of motifs along a digitized line. 

Use Backstitch to place a row of backstitches along a digitized line. 

Use Stemstitch to place a row of stemstitches along a digitized line. 

Choose outline 
input method
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 Optionally, double-click the object to access object properties.

 To set a fixed stitch length, adjust the Length field. For sharp curves, 
reduce length – e.g. 1.8 mm – so that the stitches follow the line more 
closely. Alternatively, automatically shorten stitches to follow tight 
curves with the Variable Run Length option.

Tip: Use Auto Scroll to scroll automatically within the design window 
while digitizing. Hold down the Shift key to temporarily deactivate 
Auto Scroll. Use the Ctrl+Shift+A key combination to quickly toggle 
Auto Scroll on/off.

Related topics...
 Simple outlines
 Choosing threads
 Other general options
 View graphical components
 Scroll options
 Minimizing connectors

Adjust nominal 
stitch length

Adjust variable run 
length values

Change stitch 
type

Turn on/off
variable run

length

Too few stitches to follow 
tight curve

Stitches follow the curve 
more closely

Run length Run length
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Digitizing regular columns

Use Column C to digitize columns and borders of fixed width. Column C 
is usually used with satin stitch but other outline stitch types are available 
for use. See also Satin stitching.

Tip: You can toggle between Column C and Digitize Run by pressing 
the Spacebar. See also Convert objects with CorelDRAW Graphics.

Create columns & borders

Digitize columns and borders of fixed width with the Column C tool.

To create columns and borders...
1 Insert some artwork to use as a digitizing backdrop.
2 Select a color and stitch type – e.g. Satin.
3 Select Column C and mark corner or curve points around the outline 

of the shape.
 Click to enter corner points.
 Right-click to enter curve points.

Tip: The Show Column C width guide setting in the Options dialog 
activates a special cursor. This is useful when digitizing a border based 
on a background image.

Use Traditional Digitizing > Column C to digitize columns or borders of 
fixed width. Right-click for settings.

1

2
4

5

6

7

3
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4 To close the shape, enter the last point on top of the first.
5 Press Enter.
6 Specify column width:
 To use the default width – as set in the Object Properties > 

Special > Column C docker – press Enter.
 To specify a width, mark two additional points. By default, stitches 

are positioned around the center of the digitized line.

 To specify an offset, right-click reference points instead of 
left-clicking. 

7 Press Enter to finish.

Related topics...
 Stitch Types
 Ruler & guide display options
 Reshape Column C objects

Adjust column width & offset

By default, stitches are positioned around the center of an Column C 
object. Set an exact offset via Object Properties. You can also set an 
exact width.

Digitize column 
width anywhere in 
design window

8

9

Left-click
reference points

Right-click
reference points

Use Traditional Digitizing > Column C to digitize columns or borders of 
fixed width. Right-click for settings.
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To adjust column width and offset...
 Double-click an Column C object or right-click the tool to access object 

properties.

 Enter a column Width.

 In the Input Side panel, select Offset.

 Set an offset in either Side 1 or Side 2 field.

Adjust column 
width

Set offsets 
either side

Select offset

Offset: 75% Offset: 25% 
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Tip: You can also change the width of Column C objects by adjusting 
control points with the Reshape tool.

Related topics...
 Ruler & guide display options
 Reshaping embroidery objects

Set corner fractions

With sharp curves, spacing which provides adequate coverage on the 
outside edge may cause bunching along the inside edge. This may cause 
thread breakage when stitching out. You can control the way stitches turn 
in Column C objects by adjusting the ‘corner fraction’.

To set corner fractions...
 Double-click a Column C object or right-click the tool to access object 

properties.

 Enter a new corner fraction in the Corner Fraction field. 
 Increasing the fraction spreads the turn over more stitches.
 Decreasing the fraction reduces the number of stitches that turn.

Tip: Round Sharp Corners is also available for Column C objects to 
give you the option of sharp or round points. 

Use Traditional Digitizing > Column C to digitize columns or borders of fixed 
width. Right-click for settings.

Adjust corner 
fraction

Corner
fraction 0.5

Corner
fraction 0.8

Corner
fraction

0.25
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Related topics...
 Round sharp corners

Set angles & orientation

The Column C tool provides control of stitching angle and orientation.

Angle and Orientation controls allow you to:
 Control the angle of stitches relative to baseline.

Use Traditional Digitizing > Column C to digitize columns or borders of 
fixed width. Right-click for settings.

Default Column C 
stitch angles

Column C parallel 
stitching

Column C stitch 
angle and 
orientation 
controls

Slanted Column C 
stitch angles
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 Create parallel stitching and control the angle relative to the 
horizontal. Use it to create calligraphy-like stitching in conjunction 
with Freehand.

 Control orientation to set which side to start stitching on. This is most 
useful for E Stitch.

Related topics...
 Freehand embroidery
 Reshape Column C objects

Digitizing irregular columns

In addition to Column C, both Traditional Digitizing and Graphics 
Digitizing toolbars provide tools for creating column shapes and borders 
of varying width.

Note: EmbroideryStudio lets you convert between Complex Fill and 
Column A or Column B objects. See Converting designs with CorelDRAW 
Graphics for details.

Digitize columns of varying width

Use Traditional Digitizing > Column A to create columns of varying width 
and stitch angle. Right-click for settings.

Use Graphics Digitizing > Digitize Column to create columns of varying 
width and stitch angle. Right-click for settings.



Chapter 10   Digit izing Shapes 246

Use the Column A or Digitize Column tools to 
digitize columns of varying width and stitch angle.

To digitize columns of varying width...
1 Click the Column A or Digitize Column icon.
2 Select a color and stitch type – e.g. Satin.
3 Digitize the column by marking points on 

alternate sides of the column.
 Click to enter corner points.
 Right-click to enter curve points.
The control points in a pair do not have to be the same type. For 
example, one can be a corner point, the other a curve.

Tip: If you make a mistake, press Backspace to delete the last point. 
Press Esc to undo all new points. Press Esc again to exit digitizing 
mode.

4 When you have finished digitizing, either:
 Press Enter to keep the last stitch and place the exit point at the 

last point you digitized, or
 Press Spacebar to omit the last stitch and place the exit point on 

the opposite side of the column.

Related topics...
 Stitch Types

Create smooth joins

Stitches change angle 
through the entire 
shape

Stitches remain parallel 
between parallel stitch 
angles

Press Enter Press Spacebar

Finish

OR

FinishStart Start

Use Traditional Digitizing > Column A together with ‘continuous input’ to 
create single objects comprising separately stitched sections.



EmbroideryStudio e4 Reference Manual 247

The ‘continuous input’ option provides a simple and efficient way of 
digitizing a single Column A object comprised of separately stitched 
sections. The objects so created can be deleted or edited using standard 
reshape tools.

To create smooth joins...
1 Click the Options icon or select Setup > Options and click the 

General tab.

2 Select a continuous input method:
 Normal: Use this for non-continuous input.
 Continuous replace: Use this to continue digitizing the same 

object after each Enter keypress. Any properties you change 
during digitizing will affect the entire object, not just the section 
you are working on.

 Continuous add: Use this to join objects of different size where 
different stitch types are used – e.g. a narrow section of satin stitch 
joining to a larger section of tatami.

3 Click OK.
4 Digitize the Column A object. When you press Enter, the digitized 

object fills with stitches. The input tool is still active.

Use Standard > Options to access application options for design view, grid 
& guides, and other settings.

Select continuous 
input method

Second section 
‘smooth joined’ to 
first as a single 
object

First section created

First section created

Second section 
‘smooth joined’ to 
first – two sections 
become separate 
objects
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5 If you are using Continuous Add mode, you can select another stitch 
type at this point.

Tip: To stop the screen scrolling while moving the mouse, hold down 
Shift and click the stitch type button you require.

6 Recommence digitizing where you left off and press Enter when you 
have finished.
If you are using Continuous Add mode, the new section is a new 
object. This means that, while the two sections are smoothly joined, 
they can have different properties, including stitch type.

Tip: To start a new object without joining to the previous object, click 
the Column A icon again.

Related topics...
 Digitize columns of varying width

Digitize columns of turning stitches

Use the Column B tool to digitize shapes where one side is different to 
the other, especially where one side requires more points than the other. 
Stitches turn evenly throughout the entire shape.

To digitize asymmetric columns...
1 Click the Column B icon.
2 Select a color and stitch type – e.g. Satin.
3 Digitize the first side of the shape – i.e. top or left – by marking points.
 Click to enter corner points.
 Right-click to enter curve points.

Use Traditional Digitizing > Column B to create asymmetrical columns of 
turning stitches, where opposite sides are different shapes. Right-click for 
settings.

1

2

3
5

6

7

4
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Tip: If you make a mistake, press Backspace to delete the last point. 
Press Esc to undo all new points. Press Esc again to exit digitizing 
mode.

4 Press Enter. 
An elastic line attaches to the pointer, ready for you to digitize the 
second side of the shape.

5 Digitize the second – i.e. bottom or right – side of the object.

Tip: Stitch angles vary from tightly turning fills to parallel fills, 
depending on the ends of the shape – the more ‘pointy’, the tighter the 
stitch angles.

6 When you have finished digitizing the shape, either:
 Press Enter to keep the last stitch and place the exit point at the 

last point you digitized, or
 Press Spacebar to omit the last stitch and place the exit point on 

the opposite side of the column.

Related topics...
 Stitch Types

Creating free-form shapes

In EmbroideryStudio, you digitize free shapes with turning stitches with 
the all-purpose Complex Turning tool. Use the Complex Fill tool for 

Press Enter or 
Spacebar

Stitches turn 
evenly

109

90°

Parallel fillSloping fillTurning fill
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free shapes with fixed stitch angles. By digitizing further internal 
boundaries, you can create shapes with holes in them.

Boundaries in complex shapes should not overlap or intersect. The 
shapes below, for example, cannot be successfully digitized.

Tip: You can create new objects from existing boundaries using the Fill 
Holes feature. Alternatively, you can use other objects to cut holes. See 
Removing underlying stitching and Fill holes for details.

Digitize free-form shapes

Digitize free-form shapes with Complex Fill or with Complex Turning. 
The method is essentially the same:
 Digitize the shape
 Define entry and exit points
 Define stitch angle/s. Complex Turning lets you create multiple 

stitch angles.

To digitize a free-form shape...
1 Insert artwork to use as a digitizing backdrop. Make sure Show 

Bitmaps or Show Vectors are toggled on or press 0 (zero) to see 
artwork on screen. 

Boundaries overlap Boundary overlaps itself Hole within hole

Use Traditional Digitizing > Complex Fill to digitize filled shapes with a 
single stitch angle. Right-click for settings.

Use Traditional Digitizing > Complex Turning to digitize filled shapes with 
turning stitch angles. Right-click for settings.
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2 Select a color and stitch type.
3 Select a tool and mark corner or curve points around the outline of the 

shape. 
 Click to enter corner points.
 Right-click to enter curve points.

Tip: If you make a mistake, press Backspace to delete the last point. 
Press Esc to undo all new points. Press Esc again to exit digitizing 
mode.

4 Close the shape:
 To close with the same type of point as the last entered – i.e. corner 

or curve – press Enter.
 To close using a different type of point, mark the last on top of the 

first and press Enter.

Last point marked on top of 
first with right button

cu
rv

e

Press Enter – the object is 
closed automatically
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5 Optionally, digitize additional (internal) boundaries in the same way 
and press Enter. 

6 Define entry and exit points by marking two points outside the object 
boundary and press Enter. The Closest Join method (the default) 
automatically calculates closest join between objects while digitizing. 
When deactivated, entry and exit points need to be set manually. 

Tip: If you choose to digitize entry/exit points manually, place them 
opposite each other on the boundary in order to minimize travel 
stitching. Then define the stitch angle to be perpendicular to the line 
between entry and exit points.

7 Mark stitch angles:
 If you are using Complex Fill, mark two points.

Stitch angle 
direction

Stitch angle 
direction1

12

14

13

14

131

15
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 If you are using Complex Turning, add more stitch angles as 
desired. Stitch angles may intersect over any holes you have 
digitized.

 Alternatively, press Enter to accept calculated stitch angles. Or 
press Spacebar to discard calculated stitch angles and accept a 
single default stitch angle.

Tip: You can adjust and/or add stitch angles using the Reshape 
Object tool. 

8 Press Enter. Free shapes generally stitch out in several segments, 
joined by travel runs. However, all segments and boundaries are part 
of the same object. 

Tip: To view stitches better, toggle off Show Bitmaps (press D).

Related topics...
 View graphical components
 Stitch Types
 Choosing threads
 Add holes to free-form shapes
 Other general options
 Adjusting stitch angles
 Stabilizing with automatic underlay

Stitch angle 1

Press Enter to accept 
stitch angles

Press Spacebar to accept 
single default angle

Stitch angle

Stitch 
angle 2
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Add holes to free-form shapes

While EmbroideryStudio provides dedicated tools for cutting and filling 
holes in existing objects, it also lets you add holes to closed shapes as 
you digitize. 

To add holes to free-form shapes...
 Use one of the free-form digitizing tools to create your shape. Simply 

follow the prompts to add holes as you digitize. Alternatively, select 
the final object and click the associated free-shape tool. Points display 
around the object outline.

 Digitize additional holes making sure they do not overlap. Press Enter 
each time.

 If you make a mistake, press Backspace to delete the last point. 
Press Esc to undo all new points.

 When you have digitized all additional holes, press Enter again.

Use Traditional Digitizing > Complex Fill to digitize filled shapes with a 
single stitch angle. Right-click for settings.

Use Traditional Digitizing > Complex Turning to digitize filled shapes with 
turning stitch angles. Right-click for settings.
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Tip: To remove unwanted holes, select the object and use the 
Reshape Object tool to delete control points around the hole.

Related topics...
 Adding & filling holes
 Reshaping embroidery objects
 Removing underlying stitching

Set nominal angles

You can change the stitch angle of Complex Fill objects using object 
properties. By definition, Complex Turning objects contain multiple stitch 
angles. However, they also have a property called the ‘nominal angle’.

To set the nominal angle...
 Double-click a free-shape object to access object properties.

Use Traditional Digitizing > Complex Fill to digitize filled shapes with a 
single stitch angle. Right-click for settings.

Use Traditional Digitizing > Complex Turning to digitize filled shapes with 
turning stitch angles. Right-click for settings.

Adjust nominal
angle
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 In the Angle or Nominal Angle field, enter a stitch angle.

Note: The ‘nominal angle’ in a Complex Turning object only takes 
effect if multiple stitch angles are irreconcilable – it then reverts to 
parallel stitching in the direction of the nominal angle. The nominal 
angle also affects certain underlay styles.

Tip: You can adjust stitch angles of free-form objects interactively 
using the Stitch Angles tool. 

Related topics...
 Stabilizing with automatic underlay
 Adjusting stitch angles

Adjust segment overlaps

Free shapes generally stitch out in several segments, joined by travel 
runs. Where segments within an object meet, the push-pull effect on the 
fabric during stitching may cause gaps to appear. These gaps can be 
prevented by adding overlapping rows. 

Angle: 90° Angle: 0°

Use Traditional Digitizing > Complex Fill to digitize filled shapes with a 
single stitch angle. Right-click for settings.

Use Traditional Digitizing > Complex Turning to digitize filled shapes with 
turning stitch angles. Right-click for settings.
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To adjust segment overlaps...
 Double-click a free-shape object to access object properties.

 Adjust the number of overlapping rows where segments join. An 
overlap of ‘1 row’ means no overlap between segments. An overlap of 
‘2 rows’ means that the segment is extended by one extra row of 
stitches.

 With Complex Turning objects, you can also adjust the taper angle. 
This value limits the width of overlaps. It defaults to 22.5° with a range 
of 15° to 90°. 

Adjust travel margins

When dealing with complex shapes with multiple segments, you may 
want to keep travel runs away from the boundary for various reasons. If, 
for instance, you are using Jagged Edge effect, the travel might become 

Enter required 
overlap

Overlap rows 5No overlap row

Taper angle: 
90°

Taper angle: 
22.5°

Use Traditional Digitizing > Complex Turning to digitize filled shapes with 
turning stitch angles. Right-click for settings.
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visible through shortened stitches. For this reason, you can specify a 
margin.

To adjust travel margins...
 Select an object.

 Right-click the Complex Turning icon to access object properties.

 Adjust the travel margin in the Distance field.

Travel run too 
close to edge

Adjust travel 
margin

Travel run closer to 
center of shape
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Chapter 11

Object Properties

Every object you create in EmbroideryStudio has a unique set of 
properties that are stored with it whenever you save the design. These 
properties define general characteristics such as size and position, as well 
as embroidery-specific characteristics such as stitch type and density. 
The stitch properties determine how stitches will be regenerated when 
you reshape, transform or scale the object.

This section explains how to change property settings in a design, as well 
as how to apply and adjust fabric settings. It also explains how to create 
and maintain styles and templates in EmbroideryStudio.

Basic concepts

Base properties or ‘defaults’ are stored with the design template and 
form the basis of all new designs. These may be overridden by fabric 
settings which are adjusted to suit different fabric types. These in turn 
may be overridden by individual property settings.

Actual settings
Each object has its own unique set of properties. Actual object properties 
are those settings stored with each object in the design. These may or 
may not be the same as the defaults.

Default settings
Default or starting property settings are the ones stored with the design 
template and/or selected fabric (if activated). These are automatically 
applied to any newly created objects in the design.
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Current settings
You can define ‘current’ settings to influence all the objects you create in 
the current design. Simply change property settings in the Object 
Properties docker with no objects selected. These settings then apply to 
all new objects. 
You generally change them to save time when digitizing. For example, 
you may preset Tatami stitch spacing to use a specific density for all new 
Tatami objects you create. Alternatively, you can make a selected object’s 
‘actual’ properties ‘current’ for all new objects. You can also apply current 
settings to existing objects.
When you close a design, current settings are not automatically saved to 
the template. You can save them as the new default settings of the 
current template or to another template altogether. Or you may be able 
to save them as a custom fabric.

Fabric settings
Matching object properties to the intended fabric is critical for good 
quality designs. Fabric settings are a subset of settings stored in the 
template which are fine-tuned to different fabric types. Although the 
NORMAL template settings are suitable for a range of fabrics, selecting a 
matching fabric automatically customizes object properties to the 
intended fabric. 

Styles
A style is a group of property settings stored under a unique name. You 
can save any combination of settings to a style. This makes it easy to 
apply these settings to selected embroidery and lettering objects. When 
you apply a style to an object, style settings replace current properties. 
Any properties not specified by the style, retain their current settings.

Templates
Templates are special files used to store styles, default properties, as well 
as default fabric settings. Use templates when digitizing frequently-used 
design types to save time re-adjusting current property settings. 

Working with object properties

When you start a new design, EmbroideryStudio uses the default settings 
associated with the chosen fabric (if activated). Other property settings 
are stored with the design template. You can override most settings on 
an object-by-object basis. For this reason, EmbroideryStudio 
distinguishes three sets of object properties – default, actual and 
current.
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Change current settings

Whenever you change current settings, these automatically apply to any 
new objects you create. If you know which settings you require before 
digitizing, you can preset them.

To change current settings
 With no objects selected, click the Object Properties icon.

 Select a tab to view current settings – e.g. Fills.
 Select an item from the droplist – e.g. Fills > Satin – to access those 

properties.

Use Docker > Object Properties to preset properties or adjust properties of 
selected objects.

Object Properties tabs

Select stitch type

Click to close

Click to save modified 
settings to the current 
template

Click to access
another set of tabs

Modify settings as 
required
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 Use droplists, radio buttons and checkboxes to choose options. Key in 
precise values or use the popup slider.

Tip: The slider has two operating modes – Normal and Accelerated. 
Holding down the Ctrl key puts it in Accelerated mode.

 Click the FX button to access a further set of tabs and modify settings 
as required.

 Press Enter to confirm changes. Modified settings are now current for 
all new objects. You can apply them to existing objects by means of 
the Apply Current Properties tool. 

 Optionally, click Save. The object properties are saved to the current 
template. These will apply to any new objects in any design based on 
this template.

Change object properties

You can change an object’s properties at any time without affecting those 
of any other object not currently selected. Some properties can be 
modified on screen – for example, you can change size by scaling an 
object with selection handles. Other properties, such as stitch spacing or 
length, are modified via the Object Properties docker. 

After clicking
‘swivel’ button, drag

popup slider to set

‘Radio’ buttons are
mutually exclusive

Click ‘swivel’ button 
to invoke slider 
control

Use Docker > Object Properties to preset properties or adjust properties of 
selected objects.
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To change object properties
 Select the object/s whose properties you want to change.

 Use any of the interactive techniques for scaling, transforming, or 
reshaping selected object/s. 

 Adjust general properties – width, height, position – by means of the 
Property Bar. Press Enter to confirm or Esc to discard.

 Double-click an object to access object properties.

 Select a tab and to access available properties. 

Adjust properties and 
press Enter

Object 
Properties tabs

Droplist

Click to close

Click to save modified 
settings to the current 
template

Click to access
another set of

tabs

Modify settings as 
preferred
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If you select more than one object, the Object Properties docker 
only displays settings relevant to all. If selected objects have different 
values for the same setting – e.g. stitch length – the field will be blank. 
If you enter a new value, it applies to all selected objects.

 Click the FX button to access a further set of tabs.
 Press Enter to apply changes to selected object/s.

 Some properties, such as Auto Underlay, are applied by means of 
toolbar buttons. When the button is selected, that tool’s settings are 
current.

 Optionally, click Save. The object properties are saved to the current 
template. These will apply to any new objects in any design based on 
this template.

Related topics...
 Access object properties
 Transforming Objects
 Working with templates
 Reshaping Objects

Copy properties

You can make a selected object’s ‘actual’ properties ‘current’ for all new 
objects or apply them to existing objects.

To copy properties
 Select the object whose properties you want to make current.

Click Styles > Make Properties Current to make the properties of a selected 
object current for the design.

Use Styles > Apply Current Properties to apply current settings to selected 
objects.
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 Click the Make Properties Current icon. Alternatively, right-click the 
selected object and choose the Make Properties Current command 
in the popup menu. 

 Select the object/s whose properties you want to change.
 Click the Apply Current Properties icon. Alternatively, right-click the 

selected object and choose the Apply Current Properties command 
in the popup menu. 

Working with fabrics

Embroidery stitches pull fabric inward where the needle penetrates. This 
can cause fabric to pucker and gaps to appear. For an object to sew out 
correctly, it must have correct stitch spacing, sufficient pull compensation 

Copy properties from 
one object to another 
using these 
commands



Chapter 11   Object Propert ies 266

together with a suitable underlay for the combination of cover stitch type, 
object type, object shape and fabric.

EmbroideryStudio provides a set of customized fabric settings so the 
software will take into account the type of fabric you are stitching on. 
Fabrics are a critical element of designs and are controlled separately 
from template values. Fabric settings are fewer in number than those 
contained in templates.

Change fabrics

Normally you choose a fabric when you start a design although you can 
change it at any stage. Fabric settings affect all object types other than 
motif fills, appliqué, and run stitches.

To change fabrics
1 Select Design > Auto Fabric.

Choose a
fabric type

Activate
auto-fabrics
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2 Tick the Apply Auto Fabric checkbox to activate the feature. 
Conversely, you can turn off auto fabrics at any stage. You are 
prompted to confirm the decision.

3 From the list, choose a fabric type matching or nearest to the fabric 
you intend to work with. 

4 Click OK.
The selected fabric is displayed in the Status bar. If you choose to 
apply an auto fabric to a design with no previous fabric, you are 
prompted to apply it to new objects only or to existing objects as well.

Note: Changing the current Auto Fabric will affect all colorways in 
the design. However, the converse is not the case. While colorways 
allow you to select different fabric swatches for different colorways, 
these have no bearing on Auto Fabric settings. However, the 
background Fabric option is ‘aware’ of Auto Fabric selection. 
Consequently, the Browse button takes you to an assortment of 
swatches relevant to your current fabric selection. 

Related topics...
 Create designs from templates

Choose how to
apply auto fabric

Click OK to 
activate

Tick to turn on
auto fabric
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 Compensating for fabric stretch

Manage fabrics

In addition to predefined fabric settings, you can create your own custom 
fabrics to suit particular needs. You can also modify, rename or delete 
custom fabrics.

To create a new fabric
1 Select Setup > Manage Auto Fabrics.

If you already have custom fabrics defined, you have the option of 
editing, renaming, or deleting.

2 To create a new fabric type, click Create.
3 Enter a new fabric name. If you want to base the new fabric on default 

settings, select blank.
4 Click OK.

The Auto Fabric Settings dialog opens. This dialog allows you to set 
the fabric values for four object groups – Tatami/Program Split, Wide 
Satin, Narrow Satin, and Lettering – as well as enter details of any 
recommended stabilizers.

Create new 
fabric type

My Fabric Enter fabric 
name
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To set tatami/program split values
 Click the tab to access Tatami/Program Split Fill settings. These 

will become the defaults for Tatami and Program Split objects.

 Adjust Length and Spacing settings for your Tatami / Program Split 
Fill objects as required:
 Tatami stitch consists of rows of run stitches and is suitable for 

filling large, irregular shapes. See Tatami stitching for details.
 Program Split is a decorative stitch type. Use it to fill wide and 

large areas with artistic effects while keeping the appearance of a 
solid field of stitching. See Creating textures with program splits for 
details.

 Set a suitable underlay type for Tatami/Program Split objects. See 
Stabilizing with automatic underlay for details.

 Set a pull compensation allowance for these objects. See 
Compensating for fabric stretch for details.

Adjust Tatami/Prog 
Split values for new 
fabric

Fabric: Denim
Pull Comp: Low

Fabric: Silk
Pull Comp: Medium

Fabric: Terry Toweling
Pull Comp: High
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To set satin object values
 Click the tab to access Wide Satin settings. These settings will 

become the defaults for larger Satin objects.

 Adjust the Wide Satin settings as you did for Tatami / Program Split 
objects. See Satin stitching for details.
Instead of Stitch Length and Stitch Spacing settings, you have a 
single density setting which is controlled by a slider bar.

 Click the tab to access the Narrow Satin settings and adjust as you 
did for Wide Satin objects. Generally, narrow objects will require a 
different underlay type. See Satin stitching for details.

Adjust Wide 
Satin values for 
new fabric

Adjust Narrow 
Satin values for 
new fabric
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To set lettering object values
 Click the tab to access Lettering settings.

 Adjust settings as you did for Satin objects. See Applying stitch types 
& effects to lettering for details.

To set stabilizer settings
 Click the tab to access Stabilizer settings.

 Key in one or more recommended stabilizer(s) together with a 
description or any other relevant information for the custom fabric. 
This information will be displayed in the Choose Fabric dialog. See 
Change fabrics for details.

Working with styles

A style is a group of property settings stored under a unique name. This 
makes it easy to apply them to selected embroidery and lettering objects. 
Use the Styles toolbar to apply styles to selected objects. The tools also 
allow you to set and apply current settings. Styles you tag as ‘favorites’ 
are each assigned an icon on the toolbar.

Styles are stored with the design template. The NORMAL template 
provides a selection of preset styles for you to use. Each template may 

Adjust Lettering 
values for new 
fabric

Adjust stabilizer 
values for new 
fabric
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contain specific styles for different types of embroidery. See also Working 
with templates.

Apply styles

When you apply a style, the settings overwrite current settings. Any 
properties not specified in the style, retain their current settings.

To apply styles
 If available, click the Favorite Style icon assigned to the style you 

want to use. 
 If an object is selected, the style settings are applied to it alone.
 If no object is selected, the style settings become current and 

apply to any new objects you create.

 Alternatively, click the Apply Style icon.

 Select a style from the droplist and click OK.

Tip: If you are using a digitizing tablet, you can quickly switch 
between preset styles. Each button on the puck accesses the next 
preset style with different spacing settings. For example, clicking 
Button 1 accesses <PRESET_SATIN_1>.

Use Styles > Apply Style to apply a style from the template to new or 
selected objects.

Use Styles > Favorite Styles to apply preferred styles to new or selected 
objects.

Style 1, E stitch spacing 
0.75 mm

Style 2, E stitch spacing 
1.25 mm

Style 3, E stitch spacing 
1.75 mm

Select 
style

My Style
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Related topics...
 Working with object properties
 Assign favorites

Define styles

Define new styles for a design template, either from scratch or based on 
an existing style or object. New styles are saved to the current template.

To define a style
1 To base the new style on an existing object, select it now. To base it 

on current settings, make sure no objects are selected.
2 Select Setup > Manage Styles.

3 Click Create.
4 Enter a new style name. Choose how you want to base your style:
 If you want to base the new style on default settings – current or 

selected object – select blank.
 If you want to base it on an existing style, select from the droplist.

5 If you want the new style to be added to the Style toolbar, tick the 
Favorites checkbox.

6 Click OK. The Object Properties docker opens.
7 Update properties as required.
 If you want to apply current settings, click Apply. 
 Otherwise, update those settings you want to change. You don’t 

have to enter values in all fields, only those you specifically wish to 
store.

8 Press Enter. The new style is saved to the current template.

Click to define 
new style

My Old Style

My New Style Enter name for 
new style

Select style to 
base it on
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Modify styles

The Setup > Manage Styles function allows you to modify styles, 
including the factory presets in the NORMAL template. You can merge 
settings from one style to another. You can rename a style without 
affecting its settings. You can also remove any unwanted styles from a 
template.

Select a style from the list and modify using the available buttons:

Tip: At some stage, you may want to revert to the original style settings 
in the NORMAL template. See Revert to the NORMAL template for details.

Assign favorites

You can assign up to ten favorite styles to tool icons on the Styles 
toolbar. To apply the style, you then simply select the tool.

Function Description

Edit Edit styles as you would a selected object. See Change current 
settings for details.

Rename Rename a style at any time. Select names that will help you 
remember the style or help you sort frequently-used styles to the 
top of the list. 

Remove / All Remove unwanted styles from the current template. The style is 
removed from the list of style names. To remove all styles from a 
template click Remove All.

Merge Copy settings from one style to another via the Merge With Style 
dialog. When you merge, settings from the second style overwrite 
the first. 

Favorites You can assign up to ten favorite styles to tool icons on the Styles 
toolbar. See Assign favorites for details.

Edit style 
properties

Select style to
modify
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To assign a favorite style
1 Select Setup > Manage Styles.

2 Click Favorites. The Manage Favorites dialog opens.

3 Click Add. The Add To Favorites dialog opens.

4 Select a style from the droplist and click OK.
5 Change the order in which the favorites will appear on the Styles 

toolbar using Move Up and Move Down.
6 Close out the dialogs. Styles are assigned in the order they appear in 

the Manage Favorites dialog. The tool tip for each button shows the 
style name.

Working with templates

Templates are special files used to store fabrics, styles and default 
settings. Use templates when digitizing frequently-used design types so 

Organize 
favorite styles

Click Add

My New Style

Select style
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that you do not have to set the current settings every time. For example, 
a template may include standard objects and sample lettering. It may 
simply have preferred stitch settings, lettering font and size, and colors 
set as current settings. Or it may have special density, pull compensation 
or underlay settings to suit different fabrics.

The NORMAL template
The NORMAL template is the default template supplied with the software. 
It contains current property settings as well as a selection of preset 
styles. These styles include variations on the current property settings. 
For example, <PRESET_SATIN_1> and <PRESET_SATIN_2> contains 
different stitch spacing settings for Satin stitches. You can view and 
modify the settings for these styles at any time. See Modify styles for 
details.

Note: If necessary, you can revert to the original NORMAL template after 
modifying it. See Revert to the NORMAL template for details.

Using design templates
When you start a new design from the File > New menu, a list of the 
available templates appears in the New dialog. If you select the New 
tool on the Standard toolbar, the NORMAL template is applied by default. 
See Create designs from templates for details.

Save current properties to a template

You can easily save current settings to the current template. 

To save current properties to a template
 To use the current property settings, deselect all objects, then click 

the Object Properties icon. 
 To use the settings of a favorite style, click the button with no objects 

selected.

Use Docker > Object Properties to preset properties or adjust properties of 
selected objects.
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 Open the Object Properties docker.

 Make any further adjustments as required.
 Click Save. Current settings are saved to the template as the new 

defaults.

Tip: To save more than one set of property settings to the template, 
save them as styles. 

Related topics...
 Working with object properties
 Define styles

Create design templates

You create templates from designs containing the required objects and 
property settings. Simply save the design, or elements of it, as a 
template. Templates look the same as design files, but use the file 
extension EMT.

To create a design template
1 Start a new design or open an existing one.
2 Adjust the property settings, styles, and effects as required.

Object Properties 
tabs

Droplist

Click to close

Click to save 
modified settings to 
the current template

Click to access
another set of

tabs

Modify settings as 
preferred
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3 Add the objects and lettering to be included in the template. For 
instance, you may want to include sample lettering using different 
baselines. Simply overtype the sample text when using the template. 

4 Select File > Save As. The Save as Template dialog opens onto the 
Template folder.

5 Select Design Templates (EMT) from Save as type list.
EmbroideryStudio automatically opens the C:\Program 
Files\Wilcom\EmbroideryStudio_e4.5\Template folder. Design 
templates must be saved here or they will not appear in the template 
list when you start a new design.

6 Enter a name and click Save. The template is ready for use.

Tip: The File menu provides separate commands for saving 
monogram and team name templates. See related topics below.

Related topics...
 Working with baselines
 Monogram designs

Modify design templates

You can modify templates in the same way as a normal design. Changes 
apply only to future uses of the template. Existing designs based on the 
template are not affected.

To modify design templates
1 Select File > Open. The Open dialog opens. 

Enter a name for 
your custom 
template

MY TEMPLATE
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2 Navigate to the C:\Program 
Files\Wilcom\EmbroideryStudio_e4.5\Template folder.

3 Select Templates (EMT) from the Files of type list. The available 
template files display.

4 Select the template you want to modify and click Open.
5 Modify property settings, styles and other settings as required.
6 Select File > Save As. The Save As dialog opens.
7 From the Save as type list, select Templates (EMT).
8 Enter a name and click Save. The modified template is ready for use.

Note: Delete templates in the same way as you would any other 
MS Windows® file, using File Explorer.

Revert to the NORMAL template

If you modify the NORMAL template supplied with EmbroideryStudio, you 
can revert to the original version. A factory copy is always maintained so 
that the NORMAL template can be restored.

To revert to the NORMAL template
1 Close EmbroideryStudio.
2 Click the MS Windows® Start button and navigate to the Wilcom 

EmbroideryStudio group.
3 Select Revert. The Revert to Factory Settings dialog opens.

4 Select the Templates checkbox and click OK. The original settings for 
the NORMAL template are restored.

Select 
Templates

Click OK
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Chapter 12

Colorways

When digitizing, you select colors from a color palette. These can be 
tailored to each design or color scheme. The particular ‘colorway’ 
represents the actual thread colors in which a design will be stitched. 
EmbroideryStudio lets you define multiple color schemes and switch 
between them. 

For each colorway you define, you can select colors from commercial 
thread charts or define your own. Search for particular threads by specific 
code. Locate thread colors based on closest match across one or several 
thread charts. 
EmbroideryStudio also lets you set the background color, fabric, or 
product of the current colorway for more realistic previews and 
presentations. The background and product are saved with the colorway.

Note: You can also print multiple colorways, design background and 
product, and icons of color blocks in the production worksheet. See also 
Printing design reports.



EmbroideryStudio e4 Reference Manual 281

Creating colorways

EmbroideryStudio provides various techniques for selecting and changing 
colorways manually or generating them automatically.

Caution: Due to differences in computer monitors and video cards, 
onscreen colors should only be used as guides. Always check thread 
colors against the actual thread chart you intend to use.

Add colorways

When you create a new design, it contains a single default colorway 
called ‘Colorway 1’. You can add a virtually unlimited number of 
colorways to the design using the same or different thread sets. Preview 
designs in different colors on different fabrics. Colorways are saved with 
the design in EMB format. They can also be saved to an EMT template file 
for use in future designs. They cannot, however, be saved with machine 
files. 

Tip: Other settings are included as part of the colorway definition – 
background color, fabric, or product, as well as display colors for borer 
symbols, unsewn stitches, selected objects, object outlines and the grid.

Use Color > Colorway Editor to add or edit colorways.

Use Colorway Editor > Create Colorway to add a new colorway to the 
design.
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To add a colorway
 Open the design and click the Colorway Editor icon.

 Click the Create Colorway icon.

 Enter a new colorway name – e.g. ‘Colorway 2’. The new colorway will 
use the current colorway as a starting point.

Click to create 
new colorway

Click to toggle 
single or multiple 
colorway display

Enter new 
colorway name

Colorway 2

New colorway added 
based on current 
colorway
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 Assign colors from available threads to selected color slots. 

Note: As dark-colored threads cover light-colored fabrics better than 
vice versa, different densities may be required when changing from 
one colorway to another. Colorways do not automatically compensate 
for different densities. These must be adjusted manually. 

 Use the internal toolbar to edit:

Tip: If you change the background in Colorway 1 and save it to your 
template, it will display like this at start up.

Tip: You can also match thread colors from imported graphics – vector 
or bitmap.

Related topics...
 Viewing colorways
 Assign thread colors
 Add & match image colors
 Set fabric backgrounds
 Printing design reports

Give the colorway a unique name for easy identification in the droplist 
and production worksheet – e.g. a name which reflects the background 
fabric.

Remove a colorway from the design.

Change the colorway background fabric and/or color. 

Assign threads to 
new colorway
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 Working with templates

Change color schemes

The color tools allow you to quickly re-color entire designs. Their main 
purpose is to create new ‘colorways’ quickly and easily in order to ‘spice 
up’ old designs or place them on a different fabric.

To change color schemes
 Optionally, add a new colorway for your new color scheme. See Add 

colorways for details.

Use Color > Cycle Used Colors to cycle through combinations of used 
colors. Right- or left-click.

Use Color > Color Wheel to access Color Wheel to test combinations of 
related colors.

New colorway



EmbroideryStudio e4 Reference Manual 285

 Use the Cycle Used Colors tool to try out different combinations 
using threads already in the design.

 Alternatively, select Color Wheel. This allows you to cycle through 
many color combinations using preset color schemes including 
Analogous, Complementary, Harmonious, etc.

Cycle through
used colors

Choose a 
color scheme

Double-click any slot to 
set base color

Click and drag base color 
node to adjust all
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 Click and drag the ‘base color’ node to test combinations against 
different background colors. You can make any color the base color by 
double-clicking in the palette at the top of the dialog.

 Each color node can be further individually adjusted.

 To adjust the brightness of the entire design, select the base color 
node and adjust the Brightness control.

Adjust individual
nodes as required

Adjust base node to
change all colors

proportionately
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 Click OK to apply changes. New colors are added to the palette as RGB 
values.

 Match and assign thread colors manually or use the Match All 
function.

Related topics...
 Assign thread colors

Color blocks & stop sequence

A color block corresponds to a color change in the design. It may be 
comprised of one or more same-color objects. These may form a single 
group – e.g. ‘ropes’ – or more – e.g. ‘ropes and birds’. Each color block, 
or ‘element’, can be given a descriptive name for easy identification. 
These can be included on the production worksheet. Together this 
information is known as the ‘stop sequence’. The operator generally uses 

Palette updated
with new colors
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it to ensure that correct colors are used in the correct sequence during 
production.

Note: The Color-Object List shows the same sequential list of objects, 
grouped by ‘color block’.

Design thread colors

The Thread Colors tab displays the color sequence and stitch counts for 
each design ‘element’. Elements equate to color changes. The tab also 

Stop sequence

Use Docker > Design Information to view and modify design details prior to 
design approval or stitchout.
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provides thread usage estimates which may be used for costings as well 
as production requirements.

Data is extracted from the design file and, apart from the Element 
column, cannot be modified. 

Field Function

Filename File name of the selected design. This will often be a number 
or alphanumeric format for easy cataloging.

Title Defaults to filename. Add a more descriptive name for easy 
searching. This name appears on the approval sheet or 
worksheet.

Stitches Indicates total stitch count for design.

Colors Indicates number of thread colors involved in the design.

Colorways Number of colorways in the design.

Edit element
names for each

color block as
necessary
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The table at the bottom lists all color changes in the design as they will 
appear on the production worksheet. It provides the following details:

Related topics...
 Name design elements
 Assign thread colors
 Thread usage estimates
 Modify thread details
 Other general options

Name design elements

Current colorway Use the droplist to change colorways, if available. When 
choosing a different colorway, the thumbnail and stop 
sequence list are updated.

Field Function

Stop # The machine stop corresponding to the color change. 

Color Indicates color slot number of the color in color palette.

Element User-defined name to identify each color block.

Stitches There is a stitch count for each element in the design. You can 
show this as a discrete stitch count or a cumulative stitch 
count.

Length Meterage of thread required per color.

Code Color code as registered in the thread chart. 

Name Color name appearing in thread chart.

Chart Brand name of thread chart used.

Thickness A: Normal embroidery thread (approx. denier 40)
B: Thicker than normal (approx. denier 30)
C: Finer than normal (approx. denier 80)
D: Very fine (approx. denier 100)

Field Function

Use Docker > Colorway Editor to add or edit colorways.

Use Docker > Design Information to view and modify design details prior to 
design approval or stitchout.
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You can view color blocks in the Colorway Editor. Named color blocks 
are known as design ‘elements’. This information is saved with the design 
and printed on production worksheets as an aid for machine operators.

To name design elements
 Click the Colorway Editor icon to access the Colorway Editor.

 Select a color and click and hold Locate to view in isolation. Elements 
corresponding to the color are listed below. If there is more than one, 
select and click Locate.

 Double-click the Element field and enter a descriptive name – e.g. 
‘Stems’. 

Select color
block

Click and hold to locate 
selected color block

Enter descriptive
name for selected

color block
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 To check design elements, select Design > Design Information > 
Thread Colors.

 In the Element fields, edit names for each color block as desired. This 
information can be included on the production worksheet. 

Related topics...
 Assign thread colors
 View selected color blocks
 Printing design reports
 Customizing design reports

Split color blocks

A color block corresponds to a color stop in the design. It may comprise 
a single object or group of like-color objects – e.g. ‘ropes and birds’. In 
one colorway you may want to assign the same thread to all items in the 
color block, while in another you may want to assign different colors. The 
Split Palette Color tool makes this possible.

To split a color block
1 Open the design and select a colorway.

Edit element
names for each

color block

Use Color > Colorway Editor to assign thread colors to slots in the color 
palette.

Use Color > Split Palette Color to create a new color slot with the same 
thread specification as the selected slot.
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2 Open the Colorway Editor.

3 Create a new colorway or select one to edit.
4 Select the object/s you want to split. The Split Palette Color button 

is activated.

5 Click the Split Palette Color icon. A new color slot of the same color 
is added to the color palette. Selected objects are assigned to the new 
palette position.

Select 
colorway to 
edit

Select object/s to 
be split to a 
separate color 
block

Assign a color 
to new color 
block
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6 Assign a new color to the slot. The colors of other colorways remain 
unaffected. By default, the new color slot is placed at the end of the 
palette. This, however, does not affect the stitching sequence.

Related topics...
 Assign thread colors

Fabric & product backgrounds

EmbroideryStudio lets you set background color, fabric, or product 
backdrop for more realistic previews and presentations. The background 
is saved with the colorway.

Stitching sequence 
unchanged
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Tip: While you can change background colors, fabrics, and even 
products, this does not automatically affect current fabric settings. See 
Working with fabrics for details.

Set fabric backgrounds

EmbroideryStudio lets you set the colorway background for more realistic 
previews and presentations. These can be included on approval or 
production sheets. Choose from an assortment of swatches, or if you 
have your own, import them into your design. Almost any artwork can be 
used – photos, magazine pictures, clipart images, and even fabric 
samples. The background is saved with the colorway.

To set the background
 Open the design and select a colorway.

 Click Background & Display Colors icon.

 To set a background color, select from the palette in the droplist.

Use Color > Background & Display Colors (or Colorway Editor docker) to 
change design background presets for the current colorway.

Preset
background

color
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 You can, if you prefer, color only the background inside the hoop, 
leaving the rest of the design window a neutral color.

 To set a background fabric, select Factory Fabric.

Choose fabric
color

Choose a 
background 
fabric
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 Click the Fabric droplist for more options.

 Alternatively, to choose a custom swatch, select Custom Fabric and 
click Browse.

Select background fabric 
and color as desired

Tick Custom to
choose your own

fabric swatch

Click Browse to locate 
custom fabric swatch
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 Click OK.

Note: If you change the background in Colorway 1 and save your 
template, it will always display like this at start up.

Related topics...
 Add colorways
 Working with fabrics
 Visualize products
 Preparing artwork for scanning

Visualize products

EmbroideryStudio allows you to choose a garment or product backdrop 
on which to position decorations. This feature is mainly used to display 
location, size and overall appearance for visualization and customer 

Use Color > Product Visualizer to choose a garment or product backdrop 
on which to position your decoration.

Click View > Show Product to toggle current product display. Right-click for 
Product Visualizer settings.

Use Zoom > Zoom to Product to view the entire product in the design 
window.
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approval purposes. Production worksheets provide an option to print 
approval sheets with or without garment backdrops.

Choose colors for each product type. The software provides a library of 
garments of common brands and styles. Up to three layers of color are 
supported for multi-color garments.

To visualize a product
 Open the design and select a colorway.
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 Click the Product Visualizer icon. The docker appears.

 Select a category and click a garment or product to select. The product 
image is centered in the design window at the default scale.

 Optionally, a Custom option allows you to import custom product 
images. These need to be prepared as grayscale images. They need to 
be correctly sized.

 Switch to the Settings tab. This lets you color, size, and position the 
product in the design window.

 Scale the product image as necessary. Scale should be adjusted 
according to actual garment size – XS, S, M, L, XL, or XXL. 

Select a
product folder

Select
product

Optionally toggle
product image on/off

If a multi-layer
product image is

selected, customize
colors for each layer

Click to apply
color
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 Optionally, use the Smart Tape function to measure, say, shoulder 
size against the ruler. Adjust the Length field and press Apply to 
resize the product image accordingly. Use the Keep proportions 
setting as appropriate.

 Finally, position the design on the product image. Press Ctrl+A to 
select and drag or use arrow keys to nudge.

 Alternatively, position the product image in relation to the design. By 
default, the center is placed at the design origin. The ‘X’ and ‘Y’ fields 
display 0,0.
 Enter values directly into the ‘X’ and ‘Y’ fields to move the image 

center to the new location.
 Use the nudge control buttons to move the image incrementally.

 To toggle the product background on/off, click the Show Product 
icon.

Measure garment to
determine real-world size

Scale product image
as necessary

Alternatively, enter known
dimension and click Apply to

resize product image

Position product
image in relation to

design

Alternatively, position
design on product

image
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 To change colors ‘on-the-fly’, use the Product Visualizer droplist and 
change fabric colors via the Product Color popout menu.

Related topics...
 Printing design reports
 Product Visualizer Templates

Change product
color
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PART IV
MODIFYING DESIGNS

After digitizing a design, you can modify it as a whole, edit individual 
objects or even individual stitches.

Combining objects
This section describes how to combine objects and designs by copying 
and pasting, duplicating, and inserting techniques. It also describes how 
to resequence objects by cut-and-paste, by color, and with the 
Color-Object List. Automatic branching of grouped objects is also 
covered. See Combining Objects for details.

Transforming objects
This section describes how to position objects, how to lock and group, 
align and space objects, as well as how to scale, rotate, skew, and mirror 
objects in a design. See Transforming Objects for details.

Productivity techniques
EmbroideryStudio provides input tools for stars and rings and other 
preset shapes. There are special tools for cutting holes in objects as well 
as filling them. There are also tools for generating outlines based on 
existing shapes. In addition, EmbroideryStudio provides powerful tools 
for mirroring and reflecting selections or entire designs. See Productivity 
Techniques for details.

Reshaping objects
This section describes how to reshape objects with control points, how to 
break up objects, how to adjust and add stitch angles, as well as how to 
change entry and exit points of objects in a stitching sequence. It also 
covers conversion of one embroidery object to another. See Reshaping 
Objects for details.

Stitches & machine functions
This section deals with selecting and editing stitches, and converting 
selected stitches to objects. It also includes instructions for inserting, 
checking, editing and clearing manually-inserted functions. How to edit 
stitches and functions using the Stitch List is also covered. It also 
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explains manual digitizing techniques. See Stitches & Machine Functions 
for details.
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Chapter 13

Combining Objects

EmbroideryStudio provides various techniques for combining and 
sequencing objects. You can add to designs by duplicating and copying 
objects. Resequence objects in designs to minimize color changes and 
optimize production.

The stitching sequence naturally occurs in the order in which an 
embroidery design is digitized or assembled. When converting a graphic 
design to an embroidery design, EmbroideryStudio decides the stitching 
sequence according to its own internal logic. Either way, you may, for 
reasons of aesthetics or production efficiency, want to adjust it. 
The Color-Object List displays a sequential list of objects grouped by 
object and color. It provides an easy way to group, cut, copy and paste, 
and resequence selected objects and color blocks.
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Combining objects & designs

Objects can be combined to create composite designs. They can be 
inserted from disk, copied and pasted via the MS Windows® clipboard 
for, or duplicated within the same design.

Insert designs

EmbroideryStudio lets you insert one design into another. The two (or 
more) designs can then be saved as a combined design. When you insert 
a design into another, the two color palettes are combined. Colors with 
the same RGB values are automatically identified as having the same 
thread color. If you want to preserve them as separate colors, you need 
to change one or other before importing.

Tip: If you don’t know the origin of a design you are editing, you can 
insert it into a blank design file so that it acquires known fabric settings.

To insert designs
1 Open the source design.

Click Standard > Import Embroidery to import embroidery design file into 
current design.
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2 Optionally, travel to the position in the stitching sequence where you 
want to insert the design. Otherwise, the inserted design will be placed 
at the end of the stitching sequence.

3 Select Standard > Import Embroidery. File type defaults to the 
native ‘all-in-one’ EMB format but any supported embroidery file can 
be used.
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4 Select the design file to insert, and click Open. The design is inserted 
at the current needle position. By default, colors are added to the 
palette. 

5 Scale and position the inserted design as required. To ensure that all 
the objects in the inserted design stay together, group it first.

6 Sequence colors for efficient stitchout.

Note: The Options > General tab provides another setting – ‘Match 
to palette’ – which matches inserted design colors to the current 
palette.

Related topics...
 Inserting designs with Embroidery Clipart
 Thread color handling for inserted files
 Sequencing embroidery objects
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 Transforming Objects

Copy & paste objects

You can copy objects to create multiple, identical objects, or to insert 
objects from other designs. Cut-and-paste action changes the stitching 
sequence in the design.

To copy and paste objects
 Select the object (or objects) and click Copy or press Ctrl+C. The 

selected object is copied to the clipboard.
 Optionally, change Insert Embroidery File options via the Options 

> General dialog. By default, when you insert a design, colors are 
added to the color palette.

 Optionally, change Paste options via the Options > Edit dialog.
 Optionally, travel to the position in the stitching sequence where you 

want to insert the object/s. Otherwise, it will be placed at the end of 
the stitching sequence.

 Click the Paste icon. The object is pasted according to current 
settings.

Click Standard > Cut to remove selected objects to the clipboard.

Click Standard > Copy to copy selected objects to the clipboard.

Click Standard > Paste to paste copied objects to a design.

Colors added 
to palette

Colors matched 
to palette
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 Alternatively, use the Paste After Selected command to override 
current defaults and paste directly after the selected object in the 
stitching sequence.

 Alternatively, use the Paste Special flyout to override current paste 
position settings. Shortcut keys are available. Make sure there is only 
one copy of an object at any one position. If an object is pasted twice 
in the same position, it will be stitched twice.

Related topics...
 Paste & duplicate options
 Thread color handling for inserted files
 Sequencing embroidery objects
 Transforming Objects

Duplicate & clone objects

Objects can be duplicated rather than copied. When duplicated, the 
object is not copied to the clipboard. This preserves the current contents 
of the clipboard. They can also be ‘cloned’.

To duplicate or clone objects
 Select an object or objects.
 Optionally, travel to the point in the stitching sequence where you 

want to place the duplicate. Otherwise, the duplicate object will be 
included at the end of the stitching sequence.

Override current
default settings

Override current 
settings

Use Select > Select Object to select and clone objects.
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 It is handy to be able to ‘quick clone’ objects. Select the object and, 
holding down the right mouse button, drag to a new position. Hold 
down Ctrl to constrain movements horizontally or vertically.

 Optionally, select Edit > Duplicate or press Ctrl+D to keeping 
duplicating the last cloned object. This means you can step-repeat 
duplicate objects.

 Optionally, press Ctrl+Shift+D to duplicate with a preset offset. 
Adjust this setting via the Options > Edit dialog.

Tip: Clone objects to another window by the same method. To 
temporarily deactivate automatic scrolling, hold down the Shift key 
while dragging. Use the Window > New Tab Group commands to 
view multiple design tabs at the same time.

Related topics...
 Paste & duplicate options
 Travel through designs
 Set up multiple views

Nest objects

EmbroideryStudio lets you ‘nest’ one object inside another at an exact 
point of the stitching sequence. This feature is useful with motifs and 

Right-click object

Drag-and-drop

Object duplicated

Set duplicate
offsets
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other designs where long connectors may be generated. It also helps 
reduce overall numbers of objects, minimizing trims and tie-offs.

To nest objects
1 Travel through the object until the needle position marker is positioned 

where you want to insert the new object.

2 Either digitize the new object or copy and paste. The object is ‘nested’ 
inside the stitching sequence. All required functions are automatically 
added.

3 Use arrow keys to fine-tune placement of the new object.

Related topics...
 Paste & duplicate options

Grouping & locking objects

EmbroideryStudio lets you group objects together for group 
modifications. Ungroup whenever you need to work with the component 
objects. You can also lock objects to prevent them from being moved or 
modified by accident.

Group & ungroup objects

Travel to insertion 
point and paste object

Use Arrange > Group to group selected objects.
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Group objects, or an entire design, to keep them together for moving, 
scaling and transforming actions. With grouped objects you can also 
apply global changes, saving time and ensuring consistency. When you 
have finished making changes to a group, you can ungroup and work with 
the component objects.

To group or ungroup objects
 Select objects and click the Group icon or press Ctrl+G.

Selected objects are combined. This group can be selected, moved, 
resized and transformed as a single object.

 To ungroup, select and click Ungroup or press Ctrl+U.

Use Arrange > Ungroup to ungroup selected objects.

Select, move, resize, or 
transform grouped objects 
as single object

Objects ungrouped
and deselected
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Tip: The Color-Object List provides an easy way to select objects in 
designs and access their properties. Use it to group, lock, and hide 
objects.

Related topics...
 Select objects with selection tools
 Sequence with the Color-Object List

Lock & unlock objects

Lock objects to prevent them from being moved or modified by accident. 
For example, locking backdrop images holds them in place as you 
digitize, transform or reshape the embroidery objects near them.

To lock or unlock objects
 Select objects and click the Lock icon or press K.

Selection handles disappear, indicating that the object can no longer 
be selected or modified.

 To unlock objects, click the Unlock All icon or press Shift+K.

Click to open
or close node

Group/ungroup 
objects

Use Arrange > Lock to lock selected objects.

Use Arrange > Unlock All to unlock all locked objects in a design.
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Tip: The Color-Object List provides an easy way to select objects in 
designs and access their properties. Use it to group, lock, and hide 
objects.

Related topics...
 Select objects with selection tools
 Sequence with the Color-Object List

Select objects within groups

EmbroideryStudio provides a method for selecting individual objects 
within object groupings. This is handy if you want to make changes 
‘on-the-fly’ without first having to ungroup and then regroup objects. 

Click to open
or close node

Lock/unlock 
objects

Use Select > Select Object to select individual objects as well as groups or 
ranges of objects.
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To select objects within groups
 Click the Select Object icon or press 0.

 Use Alt+Click to select a single object within a group.
 Use Ctrl or Shift keys in combination with Alt to select multiple 

objects or a range of objects within a group.

 Use Alt+Drag to select by ‘selection marquee’.
 Use Alt+Polygon/Polyline to isolate objects as you select.
 Within the Color-Object List, use the same techniques to:
 Select a single object/color within a group (Alt+Click).
 Add/remove a single object/color within a group (Alt+Ctrl+Click).
 Select a range of objects/colors within a group (Alt+Shift+Click).

Entire design 
grouped

Individual objects 
selected within a 
group
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Note: Once an object (or more) is selected, all properties, stitching 
and otherwise, can be changed ‘inside’ the group without the need to 
ungroup/regroup.

Related topics...
 Select objects with selection tools

Selecting objects by color or stitch type

You can select embroidery objects of the same color or stitch type with a 
single command.

Select objects by color

You can select embroidery objects of the same color with a single 
command.

To select objects by color
 Select Edit > Select by Color.

 Select color blocks from the list and click OK. All objects using the 
selected colors are selected in the design.

Related topics...
 View selected color blocks

Choose color 
blocks
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 Sequence with the Color-Object List

Select objects by stitch type

You can select embroidery objects of the same stitch type with a single 
command.

To select objects by stitch type
1 Select Edit > Select by Stitch Type. The Select by Stitch Type 

dialog opens.

2 Select a stitch type from the list.
 To select a range of stitch types, hold down Shift as you click.
 To select multiple stitch types, hold down Ctrl as you click.

3 Click OK. Objects using the selected stitch types are selected in the 
design.

Related topics...
 Select objects by color

Sequencing embroidery objects

The embroidery objects comprising a design form a ‘stitching sequence’. 
It is good practice to analyze and plan design shapes and stitching 
sequence in advance. Shapes need to be clearly defined to make them 
easy to embroider. The best shapes have relatively constant width, with 

Select stitch 
type
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smooth edges, no sharp turns and no small, protruding details. Details 
should always be stitched last.

If you are digitizing manually in Wilcom Workspace, objects are 
stitched in the order in which they were created. If you have converted a 
design directly from CorelDRAW Graphics to Wilcom Workspace, 
EmbroideryStudio uses automatic sequencing to determine the stitching 
sequence. You can always manually adjust the sequence to improve the 
stitchout – e.g. to minimize color changes.

Tip: Entry and exit points should also be checked when resequencing 
objects in a design. See also Adjust entry/exit points. See also Minimizing 
connectors.

Sequence by cut-and-paste

You can resequence objects by cutting an object from the design and 
pasting it back at a different point in the sequence. This does not change 
its physical location.

To sequence objects by cut-and-paste
1 Select the object (or objects) to resequence.

1

2

3

4

5

Click Standard > Cut to cut a selected object or objects and place them on 
the clipboard.

Click Standard > Paste to paste copied objects in the design.
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2 Click the Cut icon. The selected object is removed to the clipboard.

3 Travel to the point in the stitching sequence where you want to paste 
the object. You can place it between other objects or ‘nest’ it within 
another object.

4 Click the Paste icon. The object is pasted according to current 
settings.

 Alternatively, use the Paste After Selected command to override 
current defaults and paste directly after the selected object in the 
stitching sequence.

Note: Make sure there is only one copy of an object at any one 
position.
If an object is pasted twice in the same position, it will be stitched 
twice.

Related topics...
 Viewing stitching sequence
 Nest objects

Completed design – 
center stitched first

Object cut to 
clipboard

Object pastedCursor inserted at 
end of design

Override current
default settings

Override current 
settings
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 Paste & duplicate options

Sequence with the Color-Object List

The Color-Object List provides an easy way to select objects in designs 
and access their properties.

To sequence with the Color-Object List
1 Click the Color-Object List icon.

2 Select the color block or object to resequence.
 To select a range of items, hold down Shift as you click.
 To select multiple items, hold down Ctrl as you click.

Use Docker > Color-Object List to resequence objects.

Click-and-drag object to
new position
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3 Click-and-drag selected objects to reposition them.

Tip: You can also use the Color-Object List to group, lock, and hide 
objects.

Related topics...
 Grouping & locking objects
 Copy & paste objects
 Adjust entry/exit points
 Minimizing connectors

Sequence selected objects

The Sequence toolbar provides a convenient means for sequencing 
selected objects. Use it in conjunction with the Color-Object List. 

Drop object into
new position

Use Sequence > Back 1 Object to move a selection back one object in the 
stitching sequence.

Use Sequence > Forward 1 Object to move a selection forward one object 
in the stitching sequence.

Use Sequence > Back 1 Color to move a selection back one color in the 
stitching sequence.

Use Sequence > Forward 1 Color to move a selection forward one color in 
the stitching sequence.

Use Sequence > Move to Start to move a selection to start of stitching 
sequence.

Use Sequence > Move to End to move a selection to end of stitching 
sequence.
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Alternatively, use the popup menu Sequence option to resequence 
objects ‘on-the-fly’. The same options can be accessed from the 
Color-Object List popup menu.

Tip: Entry and exit points should also be checked when you are 
resequencing objects in a design.

Related topics...
 Adjust entry/exit points
 Minimizing connectors

Auto-sequence entire designs

The Optimize Color Changes feature improves the quality and 
efficiency of the stitchout by minimizing the number of color changes and 
trims. All existing overlaps are preserved by the operation. Grouped 
objects are not ungrouped but different colored objects are optimally 
sequenced regardless of grouping.

Sequence selected
objects via the toolbar

or popup menu
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To auto-sequence an entire design
 Open or create a design and select objects to resequence.

 Select Arrange > Sequence > Optimize Color Changes or use the 
popup menu in the Color-Object List. 

 Click OK to confirm. The system analyzes all selected objects and 
calculates optimal color changes and trims.

Tip: The Undo command will reverse the effect of any sequencing 
changes.
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Related topics...
 Adjust entry/exit points
 Minimizing connectors

Sequence by color

The Sequence by Color feature lets you resequence all objects in a 
design by color. This technique resequences all color blocks of the same 
color.

To sequence by color
 Select the objects to resequence or press Ctrl+A to select the entire 

design.
 Click the Sequence by Color icon or select Arrange > Sequence > 

By Color. The Sequence by Color dialog opens listing colors in the 
selected objects.

 Select a color and click Move Up or Move Down to change its position 
in the sequence.

Note: If you need to sequence separate color blocks, use the 
Color-Object List.

Sequence by selection order

Use Sequence > Sequence by Color to resequence all blocks of like color.

Select color 
block

Use buttons to 
resequence

Use Sequence > Sequence by Selects to resequence objects in the order 
selected. 
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You can resequence objects by selecting them in the required stitching 
order.

To sequence objects by selection order
 Select the first object you want to resequence.

 Holding down Ctrl, select subsequent objects. Select each object in 
the order you want it to stitch out. Do this directly on-screen or via the 
Color-Object List.

 With objects still selected, select Arrange > Sequence > By Selects 
or click the Sequence by Selects icon. The objects are resequenced 
in the selection order. 

Select objects 
in order to be 
stitched

Objects 
resequenced in 
order selected



EmbroideryStudio e4 Reference Manual 327

Tip: Entry and exit points should also be checked when you are 
resequencing objects in a design.

Related topics...
 Adjust entry/exit points
 Minimizing connectors

Sequence by number

You can resequence objects numerically in the Color-Object List. Use it 
to move an object to a position between consecutive members of a color 
block. This technique is used primarily with designs containing many 
objects where precise object sequencing is important. 

To sequence objects by number
1 Click the Color-Object List icon.
2 Right-click an object in the list.
3 Select Sequence > By Number from the popup menu. The 

Sequence by Number dialog opens.

Use Docker > Color-Object List to resequence objects.

Enter number of 
target object

Sequence
selected object

by number
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4 Enter the number of the object before which you want to position your 
selected object.

Note: If you prefer to position the selected object after a selected 
number – e.g. to make it the last object in the list – select After 
Position.

5 Click OK. The selected object will be placed in the new position and all 
other objects resequenced accordingly.
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Chapter 14

Transforming Objects

Change position, size and orientation of objects by moving, scaling and 
transforming them. Modify objects directly on screen or via their object 
properties. Mirror objects or entire designs. Create design ‘wreathes’ or 
borders. Create design arrays for efficient stitchout.

Note: The scalability and stitching quality of a design ultimately depend 
on its original source – Native Design, Imported Outlines, 
Processed Stitches, or Imported Stitches. Only EMB designs contain 
the complete set of design information required for 100% perfect scaling 
and transformation. See also Embroidery file formats.

Arranging objects

Position objects using the mouse to drag and drop, or ‘nudge’ them with 
arrow keys. Alternatively, specify X:Y coordinates in the Property bar. 
EmbroideryStudio also provides tools to align objects relative to each 
other, or distribute them evenly within the design.
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Position objects

The simplest way to move an object is to drag-and-drop to a new 
position.

To position objects
 Select the objects to move and click-and-drag to a new position.

 For more accurate positioning, use the arrow keys to ‘nudge’ selected 
objects.

Tip: With no objects selected, using arrow keys will travel through the 
design.

 For even more accurate positioning, enter X:Y coordinates in the 
Property Bar. The selection is centered over the coordinates you set.

Tip: Zoom in to make small adjustments. The distance the object 
moves depends on the current zoom factor.

Related topics...
 Select objects with selection tools

Align objects

Use cross-hair cursor 
to center object

Enter exact
coordinates

Use Arrange > Align Left to left-align selected objects.

Use Arrange > Align Centers Vertically to align the centers of selected 
objects vertically.

Use Arrange > Align Right to right-align selected objects.
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You can align selected objects to the left, right, top, bottom or center of 
a specified object.

To align objects
 Select the objects you want to align. 
 Select the object you want to align with.
 Click an alignment tool or select Arrange > Align > ...

Note: Objects are aligned with the last selected object. When all 
objects are selected using Ctrl+A or a selection marquee, they are 
aligned with the last object in the sequence.

Related topics...
 Select objects with selection tools

Distribute objects evenly

Use Arrange > Align Top to top-align selected objects.

Use Arrange > Align Centers Horizontally to align the centers of selected 
objects horizontally.

Use Arrange > Align Bottom to bottom-align selected objects.

Use Arrange > Align Centers to align selected objects through their 
centers.

Align center

Align left

Align bottom

2 1

3

Use Arrange > Space Evenly Across to distribute selected objects evenly 
across the screen.
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You can automatically distribute selected objects with even spacing 
between them, both vertically or horizontally.

To distribute objects evenly
 Select the objects you want to distribute.
 Click a spacing tool or select Arrange > Space Evenly > ...

Note: The tools all become enabled when three or more objects are 
selected.

Related topics...
 Select objects with selection tools

Scaling objects

You can scale objects by dragging selection handles, specifying exact 
dimensions in the Property bar, or by setting a distance between 
reference points on the design. As an object is scaled, the stitch count 
changes to preserve the current spacing.

Note: Only EMB designs contain the complete set of design information 
for 100% perfect scaling and transformation. 

Use Arrange > Space Evenly Down to distribute selected objects evenly 
down the screen.
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Scale objects interactively

You can change height and width of an object, or scale it proportionally 
using selection handles. Scale objects individually, or select multiple 
objects and scale them together. Use the tooltips as a guide.

To scale objects interactively
 Select the objects to scale.

 To scale height and width proportionally, use a corner handle.

Tip: By default, objects scale proportionally. To scale freely in vertical 
and horizontal planes, hold down Ctrl as you drag.

 To change the height or width, use the center handles.

 To scale proportionally around an anchor point, hold down Shift as you 
drag.

Scale proportionally Scale freely in both 
directions

Ctrl + drag
Drag

Scale 
vertically

Drag

Scale 
horizontally

Drag

Scale proportionally 
about center

Shift + dragScale horizontally in 
both directions

Shift + drag
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Scale objects numerically

You can scale artwork, selected objects or a whole design by means of 
object properties. With design files (EMB), this allows stitches to be 
regenerated while preserving the original stitch density. An exact size 
may not be achieved due to pull compensation being added to stitches 
after scaling operations.

Caution: If you scale a machine file by more than ±10%, however, 
changes to stitch density will affect the design quality.

To scale objects numerically
1 Select the objects or design to scale.
2 In the Property Bar, either:
 Enter an exact height and width, or
 Enter the new height and width as a percentage of current 

dimensions.

Tip: Toggle Lock Aspect Ratio to preserve aspect ratio.
3 Press Enter to apply.

Note: After scaling, the new object size is reset to 100%.

Related topics...
 Embroidery file formats

Enter dimensions as exact 
values or as a percentage

Lock aspect 
ratio toggle

Vase scaled
Width: 120% Height: 140%

Shadow scaled
Width: 140% Height: 120%
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Scale objects by reference line

You can scale an object or design by marking reference points and 
specifying a line length.

To scale an object by reference line
1 Select the objects or design to scale.
2 Select Edit > Transform > Transform by Reference Line 

Numerically. 
You are prompted to enter start and end points. You will have already 
decided which two points in the object or design will form the 
reference line.

3 Click to mark the reference points. Press Ctrl to constrain the angle of 
the axis to 15° increments. 

4 Alternatively, press Enter twice to use the default reference line. The 
Transform by Reference Line dialog opens.

5 Select the Resize to checkbox, and enter the required distance 
between reference points.

6 Click OK.

Make objects the same size

Use Transform > Transform by Reference Line Numerically to transform 
selected objects using a combination of reference points and numeric 
values.

Click to mark the 
reference points

Select Resize
to checkbox

Specify 
size

Click Arrange > Make Same Width to scale an object or design to the same 
width as a reference object.

Click Arrange > Make Same Height to scale an object or design to the same 
height as a reference object.
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You can scale objects to the same size as a reference object. Resize 
height or width or both.

To make objects the same size
1 Select the objects to resize.
2 Select the object that is the size you require.
3 Click a sizing tool or select Arrange > Make Same Size > ...

Note: Objects are resized with reference to the last object selected. If 
all objects are selected by using Ctrl+A or a selection marquee, they 
are resized with reference to the last object in the sequence.

Click Arrange > Make Same Width and Height to scale an object or design 
to the same size as a reference object.

Make same 
width

Make same 
height

Make same width 
and height

13

2
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Rotating objects

You can rotate objects directly on screen or by setting an exact rotation 
angle.

Rotate objects interactively

When you select an object, selection handles display at its extremities. 
When you click the object again, the handles change to rotation handles. 
Use the tooltips as a guide.

To rotate objects interactively
1 Select the objects to rotate.
2 Click a second time. Rotation handles appear at the corners and an 

anchor point at the center.

Click second 
time

Anchor point

Skew handle

Rotation handle
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3 Optionally, drag the anchor point to any position.

4 Click-and-drag a rotation handle in either direction.

Rotate objects numerically

You can rotate selected objects in 15° increments or by entering an exact 
value using the Transform toolbar.

To rotate an object numerically
 Select objects to rotate.
 To rotate in 15° increments, click one of the Rotate 15° icons.

 To rotate by an exact amount, enter an exact angle in the Rotate field 
and press Enter.

Drag corner point to rotate 
about the anchor point

Anchor point
repositioned

Drag corner point to rotate 
about the anchor point

Click Transform > Rotate Right 15° to rotate selected objects by 15° in a 
clockwise direction.

Click Transform > Rotate Left 15° to rotate selected objects by 15° in a 
counter-clockwise direction.

Use Transform > Rotate to rotate selected objects by an exact amount 
(in degrees).
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Rotate objects by reference line

The Transform by Reference Line Freely tool lets you rotate selected 
objects with the aid of reference points alone. This technique is useful if 
you want to duplicate and rotate objects around an anchor point – e.g. 
the petals of a flower.

To rotate an object by reference line
1 Select objects to rotate.
2 Select Edit > Transform > Transform by Reference Line Freely.
3 Follow the prompt line:
 Click the first reference point. This becomes the anchor point for the 

rotation.
 Click a second reference point. An outline attaches to the pointer.

 Optionally, press Ctrl to constrain the angle of the axis to 15° 
increments.

 Click the anchor point. The pointer then aligns itself with the second 
reference point.

 Click a guide point for the required rotation position. Use 
coordinates on the Status bar for exact alignment.

Rotate objects by reference line and angle

The Transform tool provides another method for transforming selected 
objects using a combination of reference points and numeric values. This 
provides a very accurate technique for rotating selected objects.

Use Transform > Transform by Reference Line Freely to rotate selected 
objects with the aid of reference points alone.

Move the pointer

Use Transform > Transform by Reference Line Numerically to transform 
selected objects using a combination of reference points and numeric 
values.
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To rotate objects by reference line and angle
1 Select the objects to rotate.
2 Decide which two points in the object or design will form the reference 

line. This should be a significant line – e.g. one which must be 
perfectly horizontal or vertical in the final design.

3 Select Edit > Transform > Transform by Reference Line 
Numerically.

4 Select the Rotate to checkbox, and enter the rotation angle of the 
reference line. For example, to rotate the image so it aligns with the 
horizontal axis, enter a value of 0°. The Angle field accepts angles 
from 0 to ±180 degrees.

5 Click OK.
6 Click to mark the start and end points of the reference line.

Press Ctrl to constrain the angle of the axis to 15° increments. 
Alternatively, press Enter twice to use a horizontal reference line by 
default.

Skewing objects

Select
Rotate to

Enter absolute rotation 
angle in degrees

Select rotation angle – 
e.g. 0°

Reference line set to angle 
specified in dialog

Digitize reference line – align 
with base of object

Use Transform > Skew to skew selected objects by an exact amount 
(in degrees).
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You can skew objects directly on screen or by setting an exact skew 
angle.

To skew objects
1 Select the objects to skew.
2 Click the object a second time. Skew handles are diamond-shaped and 

appear at the center-top and bottom of the object.

3 Drag handles left or right.

Tip: Alternatively, to skew by an exact amount, enter an exact angle 
in the Skew field on the Transform toolbar and press Enter. 

Mirroring objects

Fashion and textile designs often use copied and mirrored design 
elements. In EmbroideryStudio you can mirror objects horizontally or 
vertically by means of the Transform toolbar. You can also mirror around 
a defined axis using a reference line.

Tip: The Mirror Merge tools allow you to duplicate and transform 
selected embroidery objects, as well as merge them into a single object. 
This feature is often used in making fashion or textile designs. See 
Mirroring & reflecting selections for details.

Click second 
time

Anchor point

Skew handle

Rotation handle

Drag skew handle 
left or right
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Flip objects horizontally & vertically

You can mirror selected objects horizontally or vertically using the Mirror 
tools. Select objects to mirror and click a Mirror icon. For productivity, 
shortcut keys are available for mirror operations.

Related topics...
 Create multiple reflections

Mirror objects around an axis

Use Mirror by Reference Line to mirror objects around a reference line.

To mirror objects around an axis
 Select the objects to mirror.

Click Transform > Mirror Horizontal to flip selected objects in the horizontal 
plane.

Click Transform > Mirror Vertical to flip selected objects in the vertical 
plane.

Mirrored 
vertically

Mirrored in both
axes

Starting 
object

Mirrored
horizontally

Use Transform > Mirror by Reference Line to mirror objects around a 
defined axis using a reference line.
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 Select the Mirror by Reference Line icon or select Edit > 
Transform > Mirror by Reference Line.

 Click to mark two reference points of the mirror axis.
 Press Ctrl to constrain the angle of the axis to 15° increments.

Mirrored

Starting 
object
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Chapter 15

Productivity Techniques

Specialized features help to save digitizing time. EmbroideryStudio 
provides input tools for stars and rings and other preset shapes. Add 
decorative borders from a Borders library. EmbroideryStudio provides 
special tools for cutting holes in objects as well as filling them. There are 
also tools for generating outlines based on existing shapes.

In addition, EmbroideryStudio provides powerful tools for mirroring and 
reflecting selections or entire designs for the creation of decorative 
wreaths or borders. The same toolset can be used to create perfectly 
symmetrical objects or designs. Alternatively, create arrays of designs, 
such as badges, automatically resequenced for faster stitchout.

Adding preset shapes

EmbroideryStudio provides a number of productivity tools for quickly 
creating predefined shapes for use as borders and design objects, both 
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embroidered and vector. These tools can be particularly useful for logo 
design and embroidered badge work. 

Add design borders

Add decorative borders such as rectangles, ovals, and shields to designs 
or selected objects using the Borders library.

Use Toolbox > Add Borders to add borders to designs (or selected objects) 
with or without lettering.
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To add decorative borders to designs
1 Open a design and click the Add Borders icon.

Tip: By selecting individual objects, you can add borders to these 
rather than the entire design.

2 Select a border and adjust Border Width as required. The default is 
3.00 mm.

3 Click OK.
4 Edit borders in the normal way – change thread color, adjust border 

size, etc.

Tip: By default, borders scale proportionally. To resize proportionally 
around a central anchor point, hold down Shift as you drag. To scale 
freely in vertical and horizontal planes, hold down Ctrl as you drag.

Digitize stars & rings

Select border

Adjust border
width

Use Traditional Digitizing > Star to digitize star shapes filled with Zigzag 
stitching.

Use Traditional Digitizing > Ring to digitize circle and oval-shaped rings.
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The Traditional Digitizing toolbar provides special time-saving tools for 
creating embroidered rings and stars or ‘French dots’. 

Stars
Digitize circles and ovals which use turning zigzag stitches to create a 
‘Star’ or ‘French dot’ using the Star tool.

To digitize stars, click to mark the center and click again to set the radius. 
This point becomes the entry point. To create an oval star, mark a second 
radius point, then press Enter.

Rings
Create rings by digitizing circles and ovals within each other using the 
Ring tool. Use different combinations of inner and outer boundary 
shapes to create different effects.

Center

Reference point

1

2
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To digitize rings, digitize the inner boundary of the ring first either as a 
circle or an oval. Digitize the outer boundary of the ring in the same way 
and press Enter.

You can digitize rings with a variety of fill stitch types. Contour stitch is 
well suited to rings, as it runs stitches around the ring in a spiral pattern.

Related topics...
 Reshaping stars & rings

Digitize basic shapes

The Graphics Digitizing toolbar provides a dedicated Basic Shapes 
tool which allows you to quickly create design objects from a library of 
preset shapes. These can be created as vector objects, or you can apply 
the full range of outline and fill stitch types. These can be useful when 
creating logo designs or embroidered badges. Available shapes are 

Center

Reference point

Reference 
point

Reference point

1

2

3

4

Use Graphics Digitizing > Basic Shapes to digitize basic shapes. Press 
<Ctrl> to maintain aspect ratio. Press <Shift> to center at the first point.
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exactly the same as for preset borders. Use Ctrl and Shift keys, alone or 
in combination, to maintain aspect ratio and center point.

Related topics...
 Reshaping embroidery objects

Adding & filling holes

EmbroideryStudio provides special tools for cutting holes in objects as 
well as filling them.

Add & remove holes

Click to insert

Use Graphics Digitizing > Hole > Add Holes to cut holes in filled objects.

Use Graphics Digitizing > Hole > Remove Holes to remove holes from 
selected objects.
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With EmbroideryStudio you can cut holes in selected closed objects with 
a single stitch angle using the Add Holes tool. The complementary 
Remove Holes tool allows you to remove unwanted holes in closed 
objects.

To add or remove holes
 Select the object to modify.
 Click the Add Holes icon. Reference points display around the object 

outline.
 Digitize additional boundaries for the object. Press Enter after each 

boundary.

 Press Enter.
 Optionally, add turning stitch angles to the object.

Note: To remove all internal boundaries from a closed object, select it 
and click Remove Holes.

Related topics...
 Add holes to free-form shapes
 Removing underlying stitching
 Adjusting stitch angles
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Fill holes

Create new objects with the Fill Holes feature. This lets you fill holes 
formed by existing boundaries, without having to re-digitize the shape.

To fill holes
1 Select a source object and click the Fill Holes icon.

2 Enter an underlap value.

 To cover holes exactly, accept the default value of 0.00.
 To leave a gap between the filled holes and the original object, enter 

a negative underlap – e.g. -1.00.
 To overlap the filled holes and the original object, enter a positive 

underlap – e.g. 1.00.
3 Click OK. All newly created objects are filled with the current fill stitch 

settings, stitch angle and thread color. Each new object is an 

Use Graphics Digitizing > Hole > Fill Holes to fill holes formed by existing 
boundaries, without having to re-digitize the shape – choose to fill the hole 
exactly or offset it.

Enter required 
underlap

Underlap: 0.00 Underlap: 1.00Underlap: -1.00Source object
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independent object and is placed immediately after the source object 
in the stitch sequence.

Generating outlines & offsets

EmbroideryStudio provides tools for quickly generating outlines and filled 
areas based on existing boundaries. The Outlines & Offsets feature 
creates outlines and offset objects from closed objects with both fixed 
and variable spacings.

Simple offsets

When available, the Simple Offsets feature allows you to quickly create 
outline stitching around selected objects or entire designs with a variety 
of outline styles.

To create outlines and borders
1 Select a source object/s and click the Simple Offsets icon.

Use Toolbox > Simple Offsets to create simple outlines for any filled 
embroidery or closed vector object.

Choose offset 
object type
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2 Adjust the settings as required:

3 Click OK to apply settings. The design outline is stitched in the current 
palette color using current properties. Change settings as required.

Tip: You can use Simple Offsets to 
create outlines around entire designs, 
including lettering.

Create outlines & offsets

Use the Outlines & Offsets tool to add outline stitching to selected 
objects or entire designs with a complete range of outline styles. Any 
closed shape can be used, including vector objects, runs, or any filled 
shapes.

Outlines
The Outlines & Offsets dialog divides into two panels for outlines and 
offsets. Use the outlines panel to generate outlines around single or 
multiple selected objects. The droplist includes the full range of outline 

Option Function

Spacing Set an outline offset in mm. This may be zero or even a 
negative value.

Number of 
offsets

Specify multiple outlines – up to 99.

Object type Choice of outline object types: Run, Triple Run or Column C.

Offsets for 
holes

Option to exclude or include outlines for any holes in the 
selected object.

Use Toolbox > Outlines & Offsets to create outlines and offsets of any type 
for any filled embroidery or closed vector object.
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stitch types. For each selected object, the software generates outlines 
and inserts them immediately after in the stitching sequence.

The Overlapping Method determines how outlines will overlap:

Offsets
The offsets panel allows you to generate single or multiple offsets in any 
combination of styles, colors, and spacings. Any closed shapes can be 
used, including vector objects, runs, or any filled shapes. You have the 
option of preserving source objects.

Overlap method Details

Individual All generated outlines are full outlines.

Common Intersecting outlines are combined into a single outline.

Trimmed Overlapped portions are trimmed by overlapping objects.

Generate outline
objects around single

or multiple selects

Define offset
pattern

Specify number
of patterns

Use icons to lock 
settings in place



EmbroideryStudio e4 Reference Manual 355

 Tick Create offsets and define an offset pattern in the Offset 
Pattern panel. Each row defines a single offset. For each, specify an 
object type – e.g. Run – a spacing in millimeters – e.g. 1mm – and a 
color. Remember that each spacing is calculated from the previous 
object.

 Use the + buttons to add offsets to a pattern. Use the Lock icons to 
lock settings in place. 

 Specify pattern repeats in the Number of patterns field. Adjust 
spacing between pattern repeats in the Pattern spacing field.

 Tick the Create offsets for holes checkbox as appropriate.
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 Use the Overlapping method options to determine offsets for 
multiple selections.

 Tick the Join offsets into spiral checkbox to create a continuous 
spiral around the source object.

 Select rounded or squared corners as preferred. The squared option 
allows you to adjust the angle limit – first select Cut Sharp Corners 
and set required angle value.

 Adjust the Approximation setting as required. This controls the 
smoothness of the generated object outline – the larger the value, the 

Squared
Angle limit: 30°

RoundedSquared
Angle limit: 20°

Squared
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more approximate the curve. If the value is set to zero, the generated 
outline is unsmoothed. This is suitable for use with cutting machines.

Note: By default, source objects are preserved. If you choose not to, the 
offset object replaces the original in the same position in the stitching 
order. Start and end points of the resultant object will be as close as 
possible to those of the source object.

Create negative offsets

The Outlines & Offsets tool allows you to specify both negative and 
positive offsets.

Approximation: 0.3 mmApproximation: 0 mm Approximation: 0.6 mm

Use Toolbox > Outlines & Offsets to create outlines and offsets of any type 
for any filled embroidery or closed vector object.
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To create negative offsets
1 Select a source object/s and click the Outlines & Offsets icon.

 Tick Create offsets and define a simple offset object in the Offset 
Pattern panel.

 Set the required offset in millimeters:
 To center the offset object over the original, enter a value of 0.00.
 To position the offset object outside the original, enter a positive 

offset – e.g. 1.00.
 To position the offset object inside the original, enter a negative 

offset – e.g. -1.00.

 If you want multiple offsets, enter a value in the Number of patterns 
field.

 Select Pattern spacing and enter the required offset in millimeters. 
Offsets are always offset in a positive direction, even if you have 

Set negative
spacing

Specify number
of patterns

Zero Offset Negative Offset Positive Offset 
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entered a negative number. Spacing is calculated from the previous 
object, not the source object.

Note: As an alternative to the above technique, you can define your 
negative offsets entirely as a single offset pattern. Note how you set 
up the spacings.

Create offsets with open objects

Offset spacing: -1.5mm
Number of patterns: 3
Pattern spacing: 3mm

Offset spacing: 0mm
Number of patterns: 3
Pattern spacing: 1.5mm

Offset spacing: 1.5mm
Number of patterns: 3
Pattern spacing: 0mm

Define offset
pattern

Set number
patterns to 1

Use Toolbox > Open Offsets to create precise offsets for any open 
embroidery or vector object.

Use Toolbox > Outlines & Offsets to create closed offsets for open 
embroidery or vector objects.
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The Open Offsets tool allows you to generate parallel offsets from any 
open shape. Offset lines are calculated at a specified distance for a 
specified number, one side or other side, or both sides.

You can use the Outlines & Offsets tool with open objects to create 
closed offsets as shown. Select rounded or squared corners as preferred. 
The squared option allows you to adjust the angle limit – first select Cut 
Sharp Corners and set required angle value.

Mirroring & reflecting selections

The Mirror Merge tools allow you to duplicate and transform selected 
objects, as well as merge them into a single object. Use them to create 
wreaths or decorative borders. Or use them to create perfectly 

Define offset
pattern



EmbroideryStudio e4 Reference Manual 361

symmetrical objects. Color blocks are automatically resequenced to 
minimize unnecessary color changes.

Mirror selections horizontally & vertically

Use the Mirror Copy Horizontal and Vertical tools to duplicate and 
mirror selections simultaneously. Simply select objects and click a tool to 

Use Mirror Merge > Mirror Copy Horizontal to duplicate and mirror objects 
or designs in the horizontal plane.

Use Mirror Merge > Mirror Copy Vertical to duplicate and mirror objects or 
designs in the vertical plane.

Use Mirror Merge > Mirror Copy Horizontal & Vertical to duplicate and 
mirror objects or designs simultaneously in both planes.
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duplicate and mirror in any plane. Click to mark the reflection point and 
press Enter to confirm.

The Mirror Merge tools can also be used, as the name suggests, to 
merge mirrored objects into a single object. If duplicates overlap the 
original, you are prompted to merge objects. Use this feature to merge 
duplicates into a perfectly symmetrical object such as a face or heart.

Create multiple reflections

Use the Reflect tool to duplicate and mirror designs simultaneously. Set 
any number of rows or columns. The feature is often used in making 
fashion or textile designs. The limit for allowable wreath points is 100.

Reflected objects mergedObject reflected Source object 

Use Mirror Merge > Reflect to duplicate and mirror objects or designs.
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To create reflected objects
1 Select the object or design.
2 Click the Reflect icon. The associated settings are activated.
3 Move the pointer to position duplicates.

Tip: Press Shift to disable Auto-Scroll while using Mirror Merge.
4 Adjust the number of columns and rows required in the settings 

toolbar. Tab from field to field to enter values. 
5 For more precise positioning, adjust spacing settings. Press Enter to 

confirm.

Set no. of columns Set no. of rows

Set precise column and row spacings
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6 Click to mark the reflection point and press Enter to confirm.

Note: Color blocks are automatically resequenced to minimize 
unnecessary color changes.

Related topics...
 Duplicate & clone objects

Create wreaths

Use Mirror Merge > Wreath to duplicate objects around a center point.

Use Mirror Merge > Kaleidoscope to mirror paired objects in a wreath.
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Use the Wreath tool to duplicate objects around a center point. The 
Kaleidoscope toggle mirrors the selection as well. Color blocks are 
automatically resequenced to minimize unnecessary color changes.

To create wreaths
1 Select the object or design.
2 Click the Wreath icon. The associated settings are activated.
3 Move the pointer. Optionally, click the Kaleidoscope toggle to mirror 

duplicates.
4 Enter the number of wreath points. Because objects are mirrored, 

Kaleidoscope works best with an even number.

Enter no. of wreath points

Click toggle to
mirror duplicates

Set precise angleSet precise distance
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5 Move the pointer to position duplicates. Hold down Ctrl to constrain 
the reference line to 45° increments.

6 For more precise positioning, adjust Distance and Angle settings. 
Tab from field to field to enter values. Press Enter to confirm.

Note: Distance and angle are measured from the center of the source 
to the center of the wreath or kaleidoscope. 

7 Click to mark the reflection point and press Enter to confirm. The 
selection is duplicated and distributed around the center point.

Note: If the duplicates overlap the original, you are prompted to 
merge objects.

Creating design arrays

Use the Array tool to create multiple copies of designs, such as badges, 
spaced in rows and columns for faster stitchouts. Color blocks are 
automatically resequenced to minimize unnecessary color changes.

To create design arrays
 Select the object or design.
 Click the Array icon. The associated settings are activated. 
 As you move the pointer, duplicate outlines move accordingly. Press 

Shift to disable Auto-Scroll while using Mirror Merge.

Five-point wreath 

Six-point kaleidoscope

Use Mirror Merge > Array to duplicate designs, such as badges, 
re-sequencing color blocks for efficient multiple design stitchouts.
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 Set the number of columns and rows. Tab from field to field to enter 
values.

 Move the pointer to position duplicates.

Set no. of columns Set no. of rows

Set precise column and row spacings



Chapter 15   Productivity Techniques 368

 Click to mark the anchor point or press Enter to confirm.

 Optionally, for more precise positioning, adjust spacing settings. Press 
Enter to confirm.

Color blocks resequenced
to eliminate unnecessary

color changes
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Chapter 16

Reshaping Objects

EmbroideryStudio offers a number of techniques for reshaping 
embroidery objects, all with the one tool. Sometimes you may need to 
cut, split or break up complex or compound objects in order to fine-tune 
them. Various tools are available for this purpose. As well as reshaping 
object outlines, you can add and adjust stitch angles, a property unique 
to embroidery objects. You can also change the entry and exit points of 
individual objects which is important if you are digitizing manually or 
resequencing embroidery objects.

Reshaping embroidery objects

The reference points you mark when digitizing a shape become its 
‘control points’. Most control points can be added, deleted, or moved. 
Corner and curve points can be swapped. Some, such as entry and exit 
points, cannot be deleted.

Corner reshape-node

Exit point

Curve reshape-node

Entry point

Stitch angle points

Control handle
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View control points

The Reshape Object tool is important in EmbroideryStudio. Use it 
whenever you want to change object shapes. Use it also to edit stitch 
angles as well as entry and exit points.

To view control points
 Select an object and click Reshape Object. Control points appear 

together with Reshape Views toolbar.

Tip: Most control points can be added, deleted, or moved. Corner and 
curve points can be swapped. Entry/exit points, however, cannot be 
deleted.

Use Reshape > Reshape Object to reshape selected objects, edit stitch 
angles, and adjust entry/exit points.

Use Reshape Views > Show Reshape Nodes to toggle on/off reshape 
nodes for selected objects.

Use Reshape Views > Show Bézier Handles to toggle on/off Bézier 
handles for selected objects.

Use Reshape Views > Show Stitch Angles to toggle on/off stitch angles for 
selected objects.

Use Reshape Views > Show Entry/Exit Points to toggle on/off entry/exit 
points for selected objects – respectively, green diamond and red cross 
markers.

Bézier control handle

Curve reshape-node

Entry point

Stitch angle point

Stitch angle line

Corner reshape-node

Exit point
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 Use the Reshape Views toolbar to selectively display control points.

 Show Reshape Nodes: Use hotkey combination Alt+N to toggle. 
See Reshape objects with reshape-nodes for details.

 Show Bézier Handles: See Reshape objects with Bézier controls 
for details. See also Reshape options.

 Show Stitch Angles: Use hotkey combination Alt+A to toggle. 
See Adjusting stitch angles for details.

 Show Entry/Exit: See Adjust entry/exit points for details.
 To view next or previous objects, press Tab or Shift+Tab keys. Any 

changes to objects are confirmed.

Related topics...
 Reshape objects with reshape-nodes
 Reshape objects with Bézier controls
 Reshape options
 Adjusting stitch angles
 Smoothing curves

Show Reshape Nodes Show Stitch Angles Show Entry/ExitShow Bézier Handles

Shift + Tab Tab
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Reshape objects with reshape-nodes

Change object shapes with the Reshape Object tool. 

To reshape objects with reshape-nodes
 Select an object and click Reshape Object. Control points appear 

together with Reshape Views toolbar.
 Toggle on Show Reshape Nodes and toggle off other icons.
 Optionally, press S to turn off stitch display and turn back on when you 

are ready to regenerate stitches. 
 Add nodes as required:
 Left-click to add a corner node.
 Right-click to add a curve node.

 Select reshape-nodes as follows:
 Click a single node.
 Click-and-drag a selection marquee around a group of nodes.

Use Reshape > Reshape Object to reshape selected objects by means of 
control points.

Use Reshape Views > Show Reshape Nodes to toggle reshape-node 
display when using the Reshape Object tool.

Use View > Show Stitches to toggle embroidery stitching display on or off.

Right-click

Left-click
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 Use Ctrl or Shift keys to select multiple nodes. Left-clicking or 
right-clicking in closed shapes reverses the direction of the 
selection.

 Adjust reshape-node position by dragging along the outline. 

Tip: Use the arrow keys to ‘nudge’ selected nodes.
 Press Delete to remove unwanted nodes.

 Press Spacebar to toggle between corner and curve nodes.

Click to select – hold 
down Ctrl to select 

multiple nodes

Drag selection marquee 
around reshape-nodes 

to select

OR

Hold down Shift and right 
or left-click to select range 

of nodes

Drag 
reshape-nodes

Delete reshape-nodes 
and toggle between 
corners and curves
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 Press Esc to cancel changes. Press Esc again to exit Reshape mode.

Note: You can also adjust stitch angles as well as change entry and 
exit points. 

Related topics...
 Reshape objects with Bézier controls
 Reshape options
 Adjusting stitch angles

Reshape objects with Bézier controls

When EmbroideryStudio converts a vector graphic, it preserves nodes 
and control points. CorelDRAW® Graphics Suite uses Bézier curves. In 
Wilcom Workspace you can work with reshape-nodes or Bézier control 
points.

To reshape objects with Bézier controls
1 Select an object and click Reshape Object. Control points appear 

together with Reshape Views toolbar.
2 Toggle on Show Reshape Nodes together with Show Bézier 

Handles.
3 Reshape objects in one of two ways:
 Drag the control handle to reshape the curve around 

reshape-nodes.

Use Reshape > Reshape Object to reshape selected objects by means of 
control points.

Use Reshape Views > Show Reshape Nodes to toggle reshape-node 
display when using the Reshape Object tool.

Use Reshape Views > Show Bézier Handles to toggle Bézier control 
handle display when using the Reshape Object tool.

Bézier control 
handle

Drag control handle 
to reshape curve

Curve point



EmbroideryStudio e4 Reference Manual 375

 Adjust reshape-node position by dragging along the outline. 

Note: Generally, bézier node dragging preserves the shape of the 
curve more accurately. 

4 Release the mouse and/or press Enter to finish. Again depending on 
system settings, stitches are generated as soon as the reshape-nodes 
are moved or after Enter is pressed. 

Tip: Press Spacebar to toggle between corner and curve 
reshape-nodes.

Related topics...
 Reshape options

Reshape Column C objects

Reshaping operations for Column C objects are handled a little differently 
to other embroidery objects.

Original curve Bézier curve Traditional curve

Use Reshape > Reshape Object to add stitch angles to selected objects.

Hold down Shift and Alt
keypress combinations to

control Column C reshaping
operations
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 With the Reshape tool activated, drag reshape handles to control 
object width.

 Hold down Alt and drag to adjust offsets.
 Hold down Shift and drag to adjust angles.

Related topics...
 Digitizing regular columns
 Set angles & orientation
 Ruler & guide display options

Reshaping stars & rings

For objects created with the Star or Ring tools, reshape using default 
control points only.

Reshape star objects

Change circle/star objects from circles to ovals using the Reshape 
Object tool.

Use Reshape > Reshape Object to reshape circle and star objects.
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To reshape star objects
 Select an object and click Reshape Object. Circle/star objects have 

two reshape-nodes (for radius and orientation), a center point (to 
reposition), and an entry point.

 Use reshape nodes to change object radius, orientation, and position.

Tip: Change the stitch angle of circle objects by moving the entry 
point.

 Press Enter.

Tip: To scale a circle without changing it to an oval, select it with the 
Select Object tool, and use selection handles.

Related topics...
 Digitize stars & rings

Reshape ring objects

Entry point

Reshape-nodeCenter point

Stitch angle

90°

Click-and-drag 
reshape-node

Press Enter

Use Reshape > Reshape Object to reshape ring objects.
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You can reshape the inner and outer boundaries of ring objects with the 
Reshape Object tool.

To reshape ring objects
 Select an object and click Reshape Object.

 Use reshape nodes to change object radius, orientation, and position.

 Use reshape nodes to offset boundaries. Center points are generally 
on top of each other to begin with, and may not be visible.

Entry point

Reshape-nodeCenter point may
not be visible

Press EnterClick-and-drag 
reshape-node

Press Enter
Click-and-drag 

center point



EmbroideryStudio e4 Reference Manual 379

Related topics...
 Digitize stars & rings

Applying envelopes

Four types of Envelope effect are available – Bridge, Pennant, 
Perspective and Diamond. Envelopes are typically applied to lettering 
objects, but they can also be applied to other types of embroidery object.

To apply an envelope
1 Select the lettering object you want to distort. To apply an envelope to 

several objects, group them first, then apply the envelope.
2 Select Edit > Envelope.

Apply Envelope > Bridge Envelope to make objects bulge or arch.

Apply Envelope > Pennant Envelope to make objects compress.

Apply Envelope > Perspective Envelope to make objects stretch.

Apply Envelope > Diamond Envelope to make objects bulge or compress.

Choose an envelope
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3 Select an envelope type from among the following alternatives:

Shaping handles display around the envelope outline.

4 Drag handles up or down to shape the object.
 To move two handles in opposite directions, hold the Shift key 

down while dragging.

Bridge Pennant Perspective Diamond

Bridge reshape 
handles

Shift + drag
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 To move handles in the same direction, hold down the Ctrl key 
while dragging.

5 Press Esc to finish.

Related topics...
 Creating special effects with lettering art

Splitting objects

EmbroideryStudio lets you split branched objects – monograms, 
appliqués, lettering, etc – into their components. You can even split 
manual objects with Process Stitches in order to convert sections to 
outline objects.

Break apart composite objects

Ctrl + drag

Use Edit > Break Apart to split composite objects – monograms, appliqués, 
lettering, etc – into component objects.
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The Break Apart tool allows you to break up composite objects – 
monograms, appliqués, lettering, etc. The effect on these objects is 
similar to ungrouping.

Note: When saved into earlier versions of the software, monograms, 
appliqués, lettering, and blackwork runs may be subjected to the Break 
Apart procedure by default.

To break apart a composite object
1 Select the object you want to break apart – e.g. branched object, 

appliqué, monogram, lettering, etc.

2 Click the Break Apart icon or select Arrange > Break Apart. The 
branched object is split into component objects.

Tip: To modify individual objects – e.g. to change the stitching 
sequence of monogram borders – use the Color-Object List to 
ungroup and resequence.

Tip: Applying the Break Apart function to a lettering object breaks it 
into a logical stitching sequence while maintaining lettering object 
characteristics.

Related topics...
 Splitting objects
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 Breaking apart lettering

Cut shapes manually

The Knife tool is used to manually cut filled shapes into smaller 
fragments. It has the advantage over Split Object and Divide tools of 
allowing you to digitize temporary cut lines. Cut objects are generated 
with stitching – parallel or turning – appropriate to their shape. The tool 
cuts both filled and ‘fillable’ vector objects as well as embroidery objects. 
Run objects can also be cut with the Knife tool.

The Knife tool has two modes of operation:
 With nothing selected, it will cut all objects under the knife.
 With selected objects, it will only cut those within the selection.

To cut shapes manually
1 Select one or more suitable objects for cutting.

2 Click the Knife tool. The cursor changes to a knife icon.

Use Edit > Knife to cut objects along a digitized line, preserving stitch 
settings and colors in resulting objects.

Object needs cutting at 
this point to avoid 
awkward stitch angles
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3 Digitize a cutting line – left-click for corner points, right-click for curve 
points – and press Enter.

4 Manually adjust object overlaps using the Reshape Object tool.

Note: By default EmbroideryStudio orders fragments into a 
closest-join sequence that preserves the source object’s entry and exit 
points. The Options > Reshape dialog offers other ways of managing 
cut fragments.

Note: When you select a lettering object to cut, the object is 
highlighted with a thick magenta outline. See Converting TrueType 
fonts to embroidery for details.

Related topics...
 Split vector & embroidery objects 
 Shaping objects
 Reshape options
 Reshape objects with reshape-nodes

Source object 
separated into two 
adjoining objects

Adjust Knife tool 
behavior

Lettering object 
highlighted for 
cutting
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Cut shapes automatically

The Automatic Knife tool assists semi-automated digitizing of vector 
artwork. When objects have clean boundaries, EmbroideryStudio 
fragments them automatically and generates good quality stitching in 
most cases. It also operates on Complex Fill and Complex Turning 
embroidery objects.

To cut shapes automatically
1 Select one or more suitable objects for cutting.

2 Click the Automatic Knife icon.

Use Edit > Automatic Knife to automatically slice Complex Fill and 
Complex Turning embroidery objects into smaller turning stitch and single 
angle objects with automatic overlaps.

Object needs cutting 
at this point to avoid 
awkward stitch 
angles
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EmbroideryStudio cuts the selected object automatically, discarding 
any unwanted fragments.

For each source object, EmbroideryStudio:
 Creates turning-stitch objects as well as single-angle objects where 

appropriate.
 Creates overlaps at junctions between objects.
 Branches adjoining objects. 

Related topics...
 Automatic branching
 Break apart composite objects

Shaping objects

When working with overlapping vector or embroidery objects, you can 
merge, trim or split them using the Shaping tools. All ‘shaped’ 
embroidery objects convert to Complex Fill or Complex Turning. Vector 
objects remain as vector objects unless combined with embroidery 
objects. You have the option of preserving source objects. You also have 
the option of adding overlaps to objects resulting from Flatten or Divide 
operations.

Related topics...
 Merge vector & embroidery objects
 Trim vector & embroidery objects

Overlaps created 
between fragment 
objects at junctions
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 Split vector & embroidery objects
 Preserve original objects

Shaping tools summary table

Source Tool Result Description

Weld

Selected objects are combined into a 
single object. The resulting object takes the 
properties – stitch color and type, etc – of 
the topmost object.

Flatten
Only areas unique to each selected object 
are retained. All overlapping areas are 
removed.

Intersect
Only areas common to all selected objects 
are retained. All non-overlapping areas are 
removed.

Exclude
Areas where pairs of selected objects 
overlap are removed, starting from the 
topmost object.
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Merge vector & embroidery objects

Merge selected objects using the Weld or Combine tools.

To merge vector and embroidery objects
 Select vector or embroidery objects to shape.

Front-Back
The topmost object is retained, but all of the 
areas overlapping with other selected 
objects are removed.

Back-Front
The bottommost object is retained, but all 
of the areas overlapping with other 
selected objects are removed.

Divide The objects are split wherever overlaps 
occur and all hidden areas are removed.

Combine

Areas where pairs of selected objects 
overlap are removed, starting from the 
topmost object. All resulting objects share 
the properties – stitch color and type, etc – 
of the topmost object.

Source Tool Result Description

Use Shaping > Weld to merge overlapping objects into a single ‘flattened’ 
object.

Use Shaping > Combine to merge the properties of overlapping objects 
and trim overlapping areas.
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 Use Weld to merge overlapping objects into a single ‘flattened’ object.

 Make symmetrical shapes by digitizing one half, duplicating and 
reflecting, then welding the duplicate shapes.

 Use Combine to convert embroidery objects into multiple objects 
sharing the properties – stitch color and type, etc – of the topmost 
object.

If drawing tools are used as the input method, Combine converts 
vector objects to a single complex shape.

 Weld applied to 
petals

Weld 
applied

Combine applied 
to petals

Combine applied 
to petals
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Tip: Cut objects in half by drawing a line through them and applying 
Divide. Apply Combine to create closed objects or Weld to fuse two 
objects.

Trim vector & embroidery objects

Trim selected objects using the Intersect, Exclude, Front-Back or 
Back-Front tools.

To trim vector and embroidery objects
 Select vector or embroidery objects to shape.

Weld + Run + 
Combine applied to 
resulting objects

Weld + Run 
applied to 
resulting objects

Divide 
applied

Use Shaping > Intersect to trim overlapping areas so that only those 
intersected by all selected objects remain.

Use Shaping > Exclude to trim overlapping objects and preserve their 
individual properties.

Use Shaping > Front-Back to trim overlapping objects so that only 
non-overlapped areas of the topmost object remain.

Use Shaping > Back-Front to trim overlapping objects so that only 
non-overlapped areas of the bottommost object remain.
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 Use Intersect to trim overlapping areas so that only those intersected 
by all selected objects remain.

 Use Exclude to trim overlapping objects and preserve their individual 
properties. The result is similar to Combine except that object 
properties are not merged.

Tip: Use Exclude to cut holes in Complex Fill objects.
 Use Front-Back to trim overlapping objects so that only 

non-overlapped areas of the topmost object remain.

 Use Back-Front to trim overlapping objects so that only 
non-overlapped areas of the bottommost object remain.

Intersect 
applied

Exclude applied to 
petals

Front-Back 
applied

Back-Front 
applied



Chapter 16   Reshaping Objects 392

Tip: Use the Remove Overlaps feature to maintain shapes but 
remove the underlying layer of stitching.

Related topics...
 Removing underlying stitching

Split vector & embroidery objects

Split selected objects using the Flatten or Divide tools. These tools 
preserve the outlines of the original shapes. The Overlap setting allows 
you to add overlaps to objects resulting from Flatten or Divide shaping 
operations.

To split vector and embroidery objects
 Select the vector or embroidery objects to shape.
 Click Flatten to trim all overlaps while retaining the original objects.

Use Shaping > Overlap to adjust the overlaps of objects resulting from 
Flatten or Divide shaping operations.

Use Shaping > Flatten to trim all overlaps while retaining the original 
objects.

Use Shaping > Divide to split selected objects into separate adjoining 
objects wherever they intersect with other selected objects.

Flatten 
applied
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 Click Divide to split selected objects into separate adjoining objects. 
All overlapped areas become discrete objects.

 Use the Overlap feature to add overlaps to the objects resulting from 
Flatten or Divide shaping operations.

The Overlap range is from 0.00 to 5.00 mm with increments of 
0.01 mm. The default overlap is 0.50 mm.

The border of a third object in the stitching order is extended where it 
touches the other two layers of objects. And so on.

Divide applied 
(petals only)

Flatten: 0.00 mm Flatten: 2.00 mmSource objects

Flatten: 2.00 mmFlatten: 0.00 mmSource objects
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Preserve original objects

The Keep Original Objects is a toggle which affects the behavior of all 
the other shaping tools. While it is active, all selected source objects of 
all shaping operations are preserved. The resultant objects are inserted 
after the last source object in the stitching sequence.

Use Shaping > Keep Original Objects to keep the source objects after 
shaping.
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Chapter 17

Stitches & Machine Functions

EmbroideryStudio automatically generates 
stitches from design outlines and properties. 
This means you can scale, transform, and 
reshape native designs without compromising 
stitch density or quality. However, 
EmbroideryStudio also lets you edit individual 
stitches. You may need to do this, for 
example, when working with ‘stitch’ files 
which do not contain outline data.
Like stitches, machine functions are inserted 
automatically whenever you digitize objects 
and specify object properties. They are stored with the embroidery object 
and updated whenever it is modified. However, EmbroideryStudio also 
lets you manually insert machine functions. This flexibility allows you to 
adapt designs to almost any machine requirement. See Machine Files for 
details.
Occasionally you may need to digitize individual stitches. Use these 
sparingly. 
You can also use manual stitching together with machine functions to 
create boring holes. Holes are cut in the fabric, producing an effect 
similar to lace.

Selecting & editing stitches

The Stitch Edit tool lets you select individual stitches or groups of 
stitches directly or via the Stitch List.

Caution: When you insert stitches manually, you must maintain them 
manually. For this reason, only insert stitches if they cannot be added 
automatically.

Select stitches by needle point

Use Stitch > Stitch Edit to select individual stitches for editing.
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Select individual stitches in Stitch Edit mode.

To select stitches by needle point
 Click the Stitch Edit icon and zoom into the area you want to edit.
 Click Show Needle Points for easier selection. 
 Click a needle point.

 Use keyboard shortcuts to aid selection:
 To select a range, hold down Shift as you select.
 To select multiple stitches, hold down Ctrl as you select.

 Alternatively, drag a selection marquee around stitches.

 Deselect by either means:
 Press Esc.
 Select Edit > Deselect All.

Tip: While editing stitches, use the Selects On/Off command to 
select stitches while traveling. 

Related topics...
 Select stitches while traveling

Click View > Show Needle Points to show or hide the needle points in a 
design.

Selected
stitch

Hold down Shift
to select a range

of stitches

Selection 
marquee

Stitches 
selected
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Select stitches with the Stitch List

You can view and select individual stitches by means of the Stitch List.

To select stitches with the Stitch List
 Click the Stitch List icon.

The Stitch List opens. It shows stitch position coordinates and 
function information – e.g. whether the stitch is a jump. It also shows 
the length of every stitch in the design.

 Right-click to access popup menu options. For example, display text in 
black by selecting Black Text or in the associated stitch color by 
selecting Colored Text.

Use Docker > Stitch List to toggle Stitch List display on and off. Use it to 
select individual stitches.

Stitch List shows position 
coordinates, function information, 
and individual stitch lengths

Change Stitch List text and 
background colors
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 Click a stitch to select it. Stitches selected in the Stitch List are also 
selected in the design, and vice versa.

 Use keyboard shortcuts to aid selection:
 To select a range, hold down Shift as you select.
 To select multiple stitches, hold down Ctrl as you select.

Related topics...
 Filtering stitches & functions

Select stitches while traveling

Select a range of stitches by traveling by stitch with Selects On/Off 
activated. This command adds stitches to the selection as you travel 
through the stitching sequence.

To select stitches while traveling
 Click the Stitch Edit icon.
 Zoom into the area you want to edit and click a needle point.

 Select Stitch > Selects On/Off or press Q.

Selected
stitches

Use Stitch > Stitch Edit to select individual stitches for editing.

Select Stitch > Selects On/Off to select a range of stitches as you travel 
through the design.

Travel to the 
first stitch
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 Travel through the design using arrow keys or Travel tools. As you 
travel, stitches are added to the selection.

 Press Q again to toggle off stitch selection.

Related topics...
 Travel through designs

Insert stitches

You can insert stitches in an object to fill gaps. Inserted stitches are 
considered part of the object. They will, however, be lost if the object’s 
stitches are regenerated. Where possible, edit object properties rather 
than individual stitches. For example, to increase stitch density, reduce 
spacing rather than insert stitches.

To insert stitches
1 Click the Stitch Edit icon and zoom into the area you want to edit.
2 Select a needlepoint.

3 Move the mouse pointer where you want to insert the new stitch, and 
right-click.

Note: Inserting stitches is different from creating stitches using the 
Manual input method. With this tool you create a separate object, 
with its own properties and connectors. 

Related topics...
 Digitizing manual stitches

Travel 10 Stitches 
tool used

Use Stitch > Stitch Edit to insert stitches in an object.

Right-click
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Edit stitches

You can move or delete individual or groups of selected stitches.

To edit stitches
 Click the Stitch Edit icon and zoom into the area you want to edit.
 Select stitches and drag them to a new position.

 Select a stitch or stitches and press Delete.

Use Stitch > Stitch Edit to select individual stitches for moving.

Use Docker > Stitch List to toggle Stitch List display on/off. Use it to edit 
coordinates of individual stitches.

Drag selected stitch
to new position

Shadow
outline

 Select
stitches

Press 
Delete
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 Open the Stitch List and double-click the stitch coordinate you want 
to edit.

 Enter new coordinates in the X and Y fields and press Enter. The new 
coordinates will change the location of the stitch end point.

Caution: If an object’s stitches are regenerated for any reason, all 
stitch editing functions are lost. Where possible, reshape the object 
rather than move individual stitches.

Related topics...
 Reshaping Objects
 Select stitches with the Stitch List

Splitting objects

Enter new stitch 
coordinates as 
required

Use Travel > Travel by Segment to move stitch cursor to the next/previous 
segment. Left/right click.

Use Travel > Travel 1 Stitch to move stitch cursor forwards/backwards 1 
stitch at a time. Left/right click.

Use Stitch > Split Object to split object in two at current needle position. Use 
with Travel by Stitch functions.
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Use the Split Object command to split most embroidery objects. Run 
objects may also be split but Complex Fill and Complex Turning objects 
may not.

To split objects
 Use the Travel by Segment or Travel by Stitch functions to move to the 

stitch where you want to split the object. See also Travel through 
designs.

 Select Stitch > Split Object.

Tip: You can convert any split manual objects to outline objects with 
Process Stitches. 

Related topics...
 Adjusting stitch densities
 Travel through designs
 Converting stitches to objects

Editing machine functions

Most machine functions are inserted automatically whenever you select 
commands or specify object properties. They are stored with the 
embroidery object and updated whenever it is modified. However, 
EmbroideryStudio lets you insert machine functions manually. Depending 
on the current machine format, different functions are available. The 
most common types are described below. See your machine manual for 
further details. See also Embroidery machine formats.

Caution: Machine functions which are manually inserted into 
non-manual objects – e.g. Column A, Complex Fill, etc – need to be 

Split object 

Split object
deleted
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maintained manually. If an object’s stitches are regenerated for any 
reason, manually inserted machine functions may be moved to another 
point in the stitch sequence. For this reason, only insert functions 
manually if they cannot be added automatically.

Machine function types

EmbroideryStudio lets you manually insert color changes, thread trims, 
jumps, machine stops, needles in and out, and boring functions, 
depending on the selected machine format.

Color Change functions
Color Change functions tell the machine to use the next thread color in 
the design. They are automatically inserted when you select a new color 
from the color palette. See Assign thread colors for details.

Note: You only need to insert manual color change functions if you 
cannot recolor using standard methods – for example, when using 
multiple colors within a single object.

Trim functions
Trim functions instruct machines with trimmers to cut connecting threads 
before moving to the next object. You insert trims automatically by 
setting connector values or using the Trim tool. See Automatic trim 
settings and Add trims for details.
If you need additional trims, you can insert the functions manually.

Note: If a machine does not have a trimmer, the Trim function is ignored. 
Depending on the machine format, the Trim function may be a code or a 
sequence of jumps. See Trim functions for details.

Stop functions
If you want the embroidery machine to stop for any reason during 
stitching, you need to manually insert a Stop function in the stitching 
sequence.

Tip: Because a Stop function may be inserted for various reasons, you 
should record the purpose of the stop on the production worksheet to 
assist the machine operator.

Jump functions
Jump functions cause frame movements without needle penetrations and 
are used to move smoothly from one part of a design to another. There 
are various methods for automatically entering Jump functions.
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 Apply Auto Jump to preserve long stitches. See Preserve long stitches 
for details.

 Digitize individual jumps by right-clicking the Manual icon. See 
Digitizing manual stitches for details.

 Select jumps as connectors. See Use jumps as connectors for details.
 Create jump connectors manually by digitizing with Penetrations 

deselected. See Add jumps with penetrations off for details.
If you need additional jumps, you can insert the functions manually.

Begin/End Jump functions
The Begin/End Jump functions (formerly known as Needle Out/In) 
instruct the machine whether or not to use needle penetrations. You 
insert these functions automatically using the Penetrations tool 
(formerly known as Needles In). See Add jumps with penetrations off for 
details.
If you need additional Begin/End Jump functions, you can insert them 
manually.

Note: Remember to insert a End Jump function to instruct the machine 
to resume normal stitching.

Borer In/Out functions
Borer In/Out functions are available for embroidery machines equipped 
with a borer. They instruct the machine when to use the boring knife or 
tool instead of a needle. You insert these functions automatically using 
the Borers tool (formerly known as Borers In). See also Boring.
If you need additional Borer In or Out functions, you can insert them 
manually.

Sequin On/Off functions
Sequin On and Sequin Off functions are available for embroidery 
machines that are equipped with a sequin dispenser. The Sequin On 
function generally instructs the machine to physically lower the sequin 
dispenser into position for sequins to be placed (fed and cut). These 
functions are automatically inserted when using the Sequin tools. See 
Sequin Embroidery for details.
If you need additional Sequin On or Sequin Off functions, you can insert 
them manually. See Insert sequin drops for details.
Some machines, notably Schiffli, use only explicit Drop Sequin functions. 
These instruct the machine to drop a sequin on the fabric for stitching. 
Schiffli machines, for example, do not require Sequin On/Off functions. 
See the ES Schiffli User Manual Supplement for details.
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Insert machine functions manually

You can insert machine functions manually by means of the Insert 
Function dialog. Depending on your machine’s requirements, you will 
either add the function to the current stitch, or insert it on an empty 
stitch or empty jump. For some machines you will also need to add empty 
stitches or empty jumps on either side of some functions. See your 
machine manual for details.

Caution: When you insert machine functions manually, you must 
maintain them manually. For this reason, only insert manual functions if 
they cannot be added automatically.

To insert machine functions manually
 Open the Stitch List and locate the position in the stitching sequence 

where you want to insert the machine function. Alternatively, use the 
travel functions to locate the insertion point. The function name 
appears in the Prompt Bar.

 Right-click the stitch and select Insert Function from the popup 
menu.

Use Docker > Stitch List to toggle Stitch List display on/off. Use it to insert 
machine functions directly into the stitching sequence.

Click Function > Insert Function to insert machine function at current stitch 
cursor position. 

Select Insert 
Function
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Alternatively, click the Insert Function icon or select Function > 
Insert Function.

 From the Available Functions list, select the function you want to 
insert. Available functions and their options depend on the current 
machine format. 

Tip: It is faster to digitize individual jumps – Jump(M) – by 
right-clicking with the Manual input method selected. If you want the 
whole object to consist of jumps, deselect the Penetrations icon. 

 If available, choose an insertion method. With some functions you can 
choose whether to insert on the current stitch or on an empty stitch.

 To insert additional empty stitches or empty jumps, select one or other 
in the Component field.
Depending on your machine, you may need to insert additional empty 
stitches or empty jumps before or after the selected function. For 
example, before a particular Stop function, you may need to insert a 
number of empty jumps. See your machine manual for details.

 Use the buttons to insert additional components before or after the 
selected function.
Click Insert Before if you need the empty stitch/jump to precede the 
selected function.

Select from functions
available for selected

machine format
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 To insert multiple empty stitches or jumps, click Add. The selected 
function, together with any additional empty stitches or jumps, 
appears in the Sequence panel.

 Click OK to insert. The selected function, together with any additional 
empty stitches or jumps, is added at the current needle position. The 
name of the inserted function appears in the Prompt Bar.

Related topics...
 Create designs from templates
 Travel through designs
 Select stitches with the Stitch List
 Add jumps with penetrations off

Edit machine functions manually

Additional empty 
stitches inserted 
before and after 
selected function

Additional empty 
jumps inserted before 
and after selected 
function

Use Docker > Stitch List to toggle Stitch List display on/off. Use it to edit 
machine function encoding and to clear machine functions.

Click Function > Clear Function to remove machine functions at current 
stitch cursor position. 
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You can edit the encoding of machine functions by changing the number 
or sequence of empty stitches or empty jumps that appear around them. 
Some machines require a specific number of empty stitches or empty 
jumps in combination with a function in order to interpret it correctly. You 
may need to edit functions if they were inserted incorrectly or the 
machine format has changed.

Note: Both automatic and manually-inserted functions can be removed. 
Functions added by EmbroideryStudio are automatically updated if an 
object is modified or the machine format changes. Manually inserted 
machine functions are not automatically removed or updated. You 
generally only need to edit manually inserted machine functions. If a 
function is no longer required, it must be manually cleared from the 
design. 

To edit machine functions manually
 Open the Stitch List and locate the position in the stitching sequence 

where you want to insert the machine function. Alternatively, use the 
travel functions to locate the insertion point. The function name 
appears in the Prompt Bar.

 To remove the function altogether, select Clear <function> from the 
popup menu. 

Click Function > Edit Function to edit machine function at current stitch 
cursor position. 

Edit selected 
machine function
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 If a stitch includes more than one machine function – e.g. Trim and 
Tie-off – the Clear <function> command will invoke the Clear 
Function dialog. Use this to selectively clear functions as desired.

 Right-click the function and select Edit Function from the popup 
menu. Alternatively, click the Edit Function icon or select Function 
> Edit Function. The Sequence panel shows the current format of 
the selected function.

 To insert additional empty stitches or empty jumps, select one or other 
in the Component field.

 Use the buttons to insert additional components before or after the 
selected function. Click Insert Before if you need the empty 
stitch/jump to precede the selected function.

 To insert multiple empty stitches or jumps, click Add.
 To delete an empty stitch or empty jump from the sequence, select 

and click Remove.

Related topics...
 Travel through designs

Filtering stitches & functions

You can use the Stitch List to help locate stitches and machine functions 
for editing. The Stitch List displays stitch number, stitch coordinates, 
stitch length, stitch function, stitch color. When you select a stitch in the 
list, it is simultaneously selected in your design.

Select functions 
to clear

Select empty stitch 
or empty jump

Insert empty stitch/jump 
before or after the 
machine function
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Filter stitches by function

You can apply a filter to the Stitch List so that only stitches associated 
with specific functions appear in the list.

To filter stitches by function
1 Open the Stitch List. 

2 Right-click a stitch and select Show Functions from the popup menu.

3 Select the functions you want to show.

Tip: To select multiple functions, use Ctrl or Shift keys as you click. 
Click Select All to show all function types.

Use Docker > Stitch List to toggle Stitch List display on/off. Use it to display 
stitches associated with specific functions.

Show 
functions

Select functions 
to show 
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4 Click OK. Selected functions are displayed in the list.

Tip: To display the text in the associated stitch color, select Colored 
Text from the popup menu.

5 To show all stitches again, right-click in the Stitch List and select 
Show All from the popup menu.

Related topics...
 Select stitches with the Stitch List

Filter stitches by stitch length

You can apply a filter to the Stitch List so that only stitches of a certain 
length appear in the list. The main use of this feature is to find stitches 
which cause production problems, such as short stitches (e.g. < 
1.0 mm).

To filter stitches by stitch length
1 Open the Stitch List.

Only selected 
functions are 
displayed

Use Docker > Stitch List to toggle Stitch List display on/off. Use it to display 
only stitches of a certain length.

Show 
stitches
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2 Right-click a stitch and select Show Stitches from the popup menu. 
The Show Stitches dialog opens.

3 Select the range of stitch lengths you want to show:

4 Click OK. Only the selected stitches are displayed in the list.

Tip: To display the text in the associated stitch color, select Colored 
Text from the popup menu.

5 To show all stitches again, right-click in the Stitch List and select 
Show All from the popup menu.

Related topics...
 Select stitches with the Stitch List
 Eliminating small stitches
 Preserve long stitches

Digitizing manual stitches

Option Function

Radial Corresponds to the actual stitch length.

Axial X,Y Corresponds to the horizontal and vertical frame movements. 

Select stitch 
range to show 

Only selected 
stitches are 
displayed

Use Traditional Digitizing > Manual to digitize individual ‘manual’ stitches.
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Occasionally you may need to digitize individual stitches. Use these 
sparingly, for example, to add a few details to a finished design. Digitize 
individual stitches with the Manual method. You can enter single manual 
stitches, or enter three stitch layers at a time with the Triple Manual 
tool. Manual stitches digitized together form a single embroidery object. 
The only properties of manual objects are general and connector 
properties. They are not well suited to scaling and transforming actions. 
Use them sparingly, for example to add a few stitches to a finished 
design.

Caution: Manual stitches are not well suited to scaling and transforming 
actions as the stitches have no associated properties. Use them 
sparingly.

To digitize individual stitches
1 Click the Manual or Triple Manual icon.
2 Click to mark the start of the stitch and again to mark its end.

The end-point becomes the beginning of the next stitch.
3 Continue marking stitch points until the manual stitch object is 

complete.

Tip: Stitches that are too long will automatically become jump 
stitches, but you can also create jumps manually by right-clicking as 
you digitize.

Tip: You can also use manual stitching together with machine 
functions to create boring holes. If your embroidery machine is 

Use Traditional Digitizing > Triple Manual to digitize triple ‘manual’ stitches.

Use the left 
mouse button

1

2

3

4

5

6

7

8

9
11

10

Click for manual 
stitches

Right-click for 
jumps
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equipped with a boring knife or needle, you can use the Borers tool 
to turn needle penetrations into boring holes, regardless of selected 
stitch type. Holes are cut in the fabric, producing an effect similar to 
lace.

Related topics...
 Use jumps as connectors
 Boring

Converting stitches to objects

By default, machine files are converted to outlines and objects upon 
opening. If you only want to convert selected parts of a design, you can 
open the file without object/outline recognition and process only the 
required stitch blocks. If you want to scale a design, edit an outline or 
change a stitch type, then the design or selected elements must be first 
converted into ‘objects’. 

Tip: To ensure object outlines, stitch types, stitch density and colors are 
correct, it is always a good idea to check and edit designs after 
conversion. To improve the quality of a machine file, it is often better to 
edit stitches before conversion. See also Opening machine files.

Recognize object outlines

New or revised object outlines can be recognized after stitch edits have 
been made. This is useful with machine files which have been opened 
without Object/Outline recognition. You may do this to preserve the 
original stitching in most of the design, while modifying a single section 
of it. You may also want to turn edited stitches into an embroidery object 
in order to preserve the edits.

Use Stitch > Stitch Edit together with Recognize Objects/Outlines to turn 
selected stitches into an embroidery object.
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To recognize object outlines
1 Click the Stitch Edit icon and select the individual stitches you want 

to process.

2 Select Stitch > Recognize Objects/Outlines. The selected stitches 
are converted to objects.

Related topics...
 Opening machine files
 Selecting & editing stitches

Process manual stitches

You can process manual stitches to recognize outlines or adjust size and 
stitch density. You can also use the Process Stitches feature to change 
stitch count and density for the whole design, or for objects of a particular 
stitch type only. 

Tip: You can also split larger manual objects into smaller objects, and 
process them individually.

To process manual stitches
1 Open a machine file without object/outline recognition.
2 Edit parts of the design as required.

Stitches selected

Objects and
outlines created

Use Stitch > Process Stitches to adjust stitch density of and/or scale whole 
or selected parts.
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3 Select the part of the design you want to process. You can select the 
whole design or individual manual objects.

4 Select Stitch > Process Stitches. The Process Stitches dialog 
opens.

5 In the Stitch Values panel, enter the number of Target Stitches as 
either a percentage or absolute value (in millimeters).

6 Adjust the density for each stitch type as required. You can change the 
density for selected objects and/or for specific stitch types only. 

7 Click Recognition to set advanced recognition options as required.
8 Click OK. Selected objects are processed and converted to Column A 

or Run objects with fill or outline stitch properties as well as general 
and connector properties. If an object is not recognized, it remains a 

Manual object

Adjust stitch
densities

Enter target
stitch count

Adjust Pull
Compensation

Click to access 
advanced 
recognition 
options
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manual object with general and connector properties only. In this 
case, the target stitch count may not be reached.

Note: Process Stitches adds the missing information to the file, but 
does not change the stitches.

Related topics...
 Adjusting stitch densities
 Splitting objects
 Advanced recognition settings

Manual object converted to
Column A and Run

objects, or left as Manual
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PART V
STITCH QUALITY

EmbroideryStudio provides many settings to ensure high quality 
stitchout on any fabric. For instance, to sew out correctly, an object must 
have correct stitch spacing, sufficient pull compensation together with a 
suitable underlay for the combination of cover stitch type, object type, 
object shape and fabric. Auto Fabric provides a set of customized fabric 
settings so the software will take into account the type of fabric you are 
stitching on. However, you can override these on an object-by-object 
basis as necessary. See also Working with fabrics.

Underlays & pull compensation
This section describes how to set and adjust automatic underlays. It also 
deals compensating for fabric stretch with automatic pull compensation. 
See Underlay & Pull Compensation for details.

Optimizing stitch quality
This section describes how to adjust stitch density as well as eliminate 
small stitches. It also explains controlling corner stitching and reducing 
stitch bunching. Optimizing long satin stitches is also covered. See 
Optimizing Stitch Quality for details.

Embroidery connectors
This section describes how to add connectors, tie-offs and trims to your 
designs. It also describes adjusting settings for automatic connectors, 
including the stitch length for travel runs. It also deals with setting 
automatic start and end points. See Embroidery Connectors for details.
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Chapter 18

Underlay & Pull Compensation

Embroidery stitches pull fabric inward where needles penetrate. This can 
cause fabric to pucker, stitch bunching, and/or unsightly gaps to appear 
in the embroidery. EmbroideryStudio includes many techniques for 
achieving smooth, even placement of stitches, and the elimination of 
gaps in designs.

For an object to sew out correctly, it must have correct stitch spacing, 
sufficient pull compensation, together with a suitable underlay for the 
particular combination of cover stitch type, object type, object shape, 
and fabric. 

Note: EmbroideryStudio provides a set of optimized fabric settings that 
take into account the type of fabric you are stitching on. These settings 
are all object properties, some of which are entirely automated and some 
which you have control over. See Object Properties for details.

Stabilizing with automatic underlay

Embroidery appearance and quality depends a lot on underlay which 
serves as a foundation for the cover stitching. Without an underlay, 
embroidery lies flat on the underlying fabric which can often show 
through. New digitizers might be tempted to increase stitch density but 
it is much more effective to apply an automatic underlay. Although it 
increases the stitch count, underlay helps to stabilize fabrics and reduce 
puckering and pulling especially on larger designs. It also provides ‘loft’, 
raising cover stitches and preventing them from sinking into soft fabrics. 
It can also prepare a napped fabric by flattening it.
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Underlay types

Different underlays suit different shapes and different fabrics. Larger 
areas and stretchy fabrics such as knits and pique generally need more 
underlay than smaller areas and firm fabrics such as drill or leather. 
Smaller objects may use a single layer of underlay. Larger objects may 
combine two layers.

Underlay settings are stored with each object the same way as other 
object properties. They are regenerated whenever the object is scaled or 
transformed. They are stored separately from, and do not affect, cover 
stitch settings.

Default underlay values
Default underlay values are derived from three possible sources:
 When Auto Fabric is turned on, a default underlay is applied, based 

on current fabric settings.
 When Auto Fabric is turned off and the ‘use preset styles’ option is 

turned on, style definitions are used. See Digitizing presets for details.
 When Auto Fabric is turned off and the ‘use preset styles’ option is 

turned off, template values are used. See Working with templates for 
details.

Related topics...
 Digitizing presets
 Working with fabrics
 Working with object properties
 Setting lettering underlay

Apply automatic underlay

Use Stitch Effects > Auto Underlay to strengthen and stabilize embroidery 
designs with automatic underlays. Right-click for settings.
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EmbroideryStudio provides a wide selection of underlay types to choose 
from. Use a single layer of underlay, or for more support, combine two 
underlay types. The underlay you choose is determined by the shape and 
size of object, fabric type, and purpose it is to serve. EmbroideryStudio 
lets you set values to suit different fabrics, lettering appearance and size.

To apply automatic underlay
 Toggle underlays on/off with the Auto Underlay button.
 Without objects selected, right-click the Auto Underlay icon to 

change current settings.
 With objects selected, right-click the Auto Underlay icon to change 

settings for those objects.

 For a single underlay, tick the First Underlay checkbox and choose 
an underlay type from the droplist.

Select 1st
underlay

Select 1st
underlay type

Adjust 1st
underlay settings

Select 2nd
underlay type

Adjust 2nd
underlay settings

Adjust 2nd
underlay marginsAdjust 1st

underlay margins

Select 2nd
underlay

First underlay: Edge Run
(Column B object)

First underlay: Edge Run
(Complex Fill object)

First underlay: Edge Run
(Complex Turning object)
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 For a double-underlay, tick the Second Underlay checkbox and 
choose a second underlay type.

Related topics...
 Working with fabrics
 Working with object properties
 Setting lettering underlay

Underlay by segment or by shape

Free shapes generally stitch out in several segments, joined by travel 
runs. However, all segments and boundaries are part of the same object. 
With the exception of lettering objects, underlay is normally applied 
segment-by-segment before any cover stitches are sewn. 

‘By shape’ underlay is applied to lettering objects by default. However, it 
can also be applied to objects such as Complex Turning as well as 
branched objects. This has the effect of calculating an underlay for the 
whole shape rather than each segment. This in turn reduces bunching, 

2nd underlay: Zigzag 2nd underlay: Tatami 2nd underlay: Double Zigzag

Branched Complex
Turning with Edge +

Center Run underlay
‘by shape’

Branched Complex 
Turning with Edge + 
Center Run underlay ‘by 
segment’

Stitch count: 1060

Stitch count: 957
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travel runs, and overall stitch count. Depending on the size of object, 
however, registration issues may come into play.

Underlay margins

The underlay margin is the distance between an object outline and the 
edge of the underlay. Increase this margin to prevent underlay stitches 
from extending outside the cover stitches.

 For Column A, Column B, Column C and Lettering objects, enter 
margins in the 1:, 2: and 3: fields, using the diagram as a guide.

 For Complex Fill objects, enter a margin in the 1: field only. Values in 
the other fields will be ignored.

 If you are joining two columns, use a negative value at the joining end. 
The underlay will extend outside the cover stitching, allowing for 
smooth joining of the columns.

Right-click Stitch Effects > Auto Underlay to adjust underlay margins.

Adjust margins to prevent 
underlay stitches from 
extending to far

Mgn 1: 0.8 mm, Mgn 2: 0.2 mm,
Mgn 3: 0.4 mm

All margins: 0.1 mm

Two columns joined
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Run stitch underlay settings

Center Run places a row of stitches along the center of a column. It is 
used to stabilize narrow columns – e.g. 2-3 mm wide. Edge Run places 
stitches around the edge of an object. Use Edge Run together with the 
zigzag or tatami underlays when digitizing large shapes.

 Enter a stitch length for each underlay type. The samples below show 
the difference between fixed and variable run lengths.

 Adjust stitch length to ensure underlay stitches follow curves and are 
not visible in the final embroidery.

Related topics...
 Adjust column width

Right-click Stitch Effects > Auto Underlay to adjust Center Run and Edge 
Run underlay settings.

Option Function

Length Sets the maximum length of each stitch.

Vary run length If enabled, specify minimum stitch length and chord gap 
values. The chord gap is the distance between digitized curve 
and underlay stitch. This determines how closely stitches 
follow digitized lines.

Center Run and Edge Run
underlays used together

Edge Run and Center Run underlay 
with 2.5 mm stitch length

Edge Run and Center Run underlay 
with variable run length
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Tatami underlay settings

Tatami underlay is used to stabilize large, filled shapes. It resembles an 
extremely open tatami fill stitch, where rows of stitches are placed across 
the object to create the underlay. Tatami underlay is often used together 
with Edge Run, especially for Complex Fill objects under tatami cover 
stitching.

 Adjust stitch spacing and length settings for tatami underlay in the 
same way as for tatami fill stitches.

 Select the backstitch type you require and, for Complex Fill objects, 
set the stitch angle of the underlay stitches. Underlay stitch angle 
should run counter to cover stitching.

 For extra support with very soft or elastic fabrics, try using Double 
Tatami in combination with Edge Run. Adjust stitch angle so that 

Right-click Stitch Effects > Auto Underlay to adjust tatami underlay settings.

Tatami stitch with Edge
Run & Tatami underlay

Direction of cover 
stitching

Direction of 
underlay

Spacing: 2mm

Spacing: 3mm

Angle: 135º 

Angle: 45º
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Double Tatami provides symmetrical slanting in forward and 
backward directions. This should result in a ‘cross-hatch’ effect. In 
addition, it can give a raised surface similar to ‘puff embroidery’.

Tip: Increase the margin as necessary to prevent underlay stitches from 
extending outside the cover stitches. 

Related topics...
 Tatami density
 Other tatami settings
 Object property apply options
 Underlay margins

Zigzag underlay settings

Use Zigzag and Double Zigzag underlay stitching to support wide 
columns. You can combine Zigzag or Double Zigzag with Center Run or 
Edge Run underlays. These underlays are best used under Satin cover 
stitching.

Tatami stitch with
Edge Run & Double

Tatami underlay

Adjust angle for 
slanted double 
tatami underlay

Right-click Stitch Effects > Auto Underlay to adjust Zigzag and Double 
Zigzag underlay settings. 
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Adjust the required spacing and length for each underlay type.

EmbroideryStudio allows you to slant Zigzag underlay to create what is 
sometimes called ‘stemstitch underlay’. This can be applied to Column A, 
B, C, and lettering objects.

Normal zigzag underlay runs in a similar direction to satin cover stitching 
causing it to ‘sink’. Double Zigzag provides symmetrical slanting in 
forward and backward directions resulting in a ‘cross-hatch’ effect. This 
may provide more support than single zigzag. In addition, it can give a 
raised effect similar to ‘puff embroidery’.

Double Zigzag too can be slanted to create even more loft.

Spacing: 3.0 mm Spacing: 4.0 mm

Zigzag underlay

Slanted zigzag 
underlay

Adjust angle for 
slanted zigzag 
underlay

Zigzag underlay
Angle: 45°

Spacing: 3mm

Zigzag underlay
Angle: 45°

Spacing: 1mm

Double-zigzag 
underlay

Slanted double-zigzag 
underlay
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Caution: When using very small angles for slanted underlays, they can 
extend outside object boundaries.

Related topics...
 Adjust column width
 Underlay margins
 Setting lettering underlay
 Open stitching

Compensating for fabric stretch

Embroidery stitches tend to pull fabric inwards where the needle 
penetrates. This can cause fabric to pucker and gaps to appear in the 
embroidery. Experienced digitizers can manually compensate for pull by 
overlapping objects as they digitize. Automatic pull compensation, 
however, counters the pull effect by ‘overstitching’ outlines of filled 
shapes on the sides where the needle penetrates.

Adjust overstitching by varying pull compensation in the Object 
Properties docker. This is handy if you want to stitch a design on fabrics 
with varying degrees of stretch. 

Tip: Applying underlay stitching, and using appropriate backing and 
topping when stitching out can also reduce the push-pull effect.

Apply automatic pull compensation

Apply automatic pull compensation to objects in your design and adjust 
as part of your quality checks prior to stitchout.

To apply automatic pull compensation
 Toggle automatic pull compensation on/off via the Pull 

Compensation button.

Pull
compensation

Digitized outline

Calculated outline

Use Stitch Effects > Pull Compensation to automatically compensate for 
fabric stretch. Right-click for settings.
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 Without objects selected, right-click the Pull Compensation icon to 
change current settings.

 With objects selected, right-click the Pull Compensation icon to 
change settings for those objects.

 Enter an overstitch allowance (in millimeters).

Appropriate pull compensation settings vary with the type of fabric – 
stretchy, pile, etc – hooping method – tight or loosely hooped – and size 
of embroidery object – wide or narrow columns. Use the following table 
as a guideline.

Related topics...
 Working with fabrics
 Working with object properties

Adjust column width

The Column Width setting adjusts the width of columnar shapes, 
allowing you to change the column width at every point by a constant 

Fabric Pull compensation (mm)

drills, cotton 0.20

T-shirt 0.35

fleece, jumper 0.40

lettering 0.2 - 0.3

Select Pull Compensation 
and enter an overstitch 
allowance

Pull Compensation: 0.6 mmPull Compensation: 0.0 mm

Right-click Stitch Effects > Pull Compensation to adjust column width 
setting.
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amount in the direction of stitching. The purpose is to ‘fatten’ or ‘thin’ a 
column, for example, in order to create ‘bold’ lettering. See also Format 
lettering.

Tip: Reduce column width if you need to allow the underlay to extend 
outside the object boundary.

To adjust column width
 Right-click the Pull Compensation icon to access object properties.

 Select the Column Width checkbox and adjust as necessary.

Related topics...
 Apply automatic pull compensation

Select Column Width and 
enter column width 
adjustment

Column width: -1 No adjustment Column width: +1
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Chapter 19

Optimizing Stitch Quality

When it comes to embroidery production, the current stitch density may 
not be perfect for certain fabrics or threads. Or you may want to make 
production cheaper by reducing overall stitch count. After scaling 
operations, for example, designs may contain small stitches which can 
damage fabric and cause thread or needle breakage. Sharp corners may 
cause stitch bunching which can create hard spots in the embroidery and 
damage fabric or needle.

Embroidery machines have a maximum possible stitch length which is 
determined by the physical frame movement. If long satin stitches 
exceed this, they are broken into smaller stitches.
EmbroideryStudio helps you resolve all these issues with a number of 
specialized techniques for optimizing stitching quality for different design 
types and production requirements.

Controlling stitch direction

Sometimes you need to control stitching direction in order to minimize 
trims, push-pull effect, improve stitching efficiency, and/or reinforce 
outlines. Backtrack and Repeat allow you to reinforce outlines while 
specifying stitching direction. The Reverse Curves command allows you 
to reverse stitching direction without duplication.
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Reverse stitch direction

Stitching direction can affect embroidery quality because of the push-pull 
effect. The Reverse Curves command lets you control the push-pull 
effect by reversing stitch direction. It can be applied to open as well as 
closed outline objects. To reverse stitch direction, select an object and 
apply Edit > Reverse Curves. The command is also available from the 
popup (right-click) menu.

Reverse Curves can be applied to Run, E Stitch, Column C, Motif Run, 
and Sequin Run. It can also affect the stitching direction of Jagged Edge, 
Contour Stitch, Tatami offsets, and Flexi Split patterns.

Tip: Vector objects too can be reversed. The effect on vector objects is 
only visible when they are converted to embroidery.

Reinforce outlines

Use Backtrack and Repeat to reinforce outlines. Backtrack stitches in 
reverse direction to the original. It is typically used to make run stitch 
outlines thicker without creating unwanted connecting stitches. Repeat 
duplicates the original stitching direction and is typically used with closed 
shapes.

To reinforce outlines
1 Select the outline (or outlines) to reinforce.
2 Click the Backtrack or Repeat icon as required:

Use Edit > Reverse > Reverse Curves to reverse stitch direction in vector or 
closed embroidery objects.

Reverse Curve
applied

Column C object with 
Jagged Edge

Use Traditional Digitizing > Backtrack to reinforce an outline, stitching it in 
the reverse direction to the original.

Use Traditional Digitizing > Repeat to duplicate an outline in the same 
direction – typically used with closed shapes.
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 Backtrack for open shapes
 Repeat for closed shapes.
The object is duplicated and placed over the original. It is positioned 
after the original in the stitching sequence.

3 Check that the object has been duplicated by using one of the 
following methods:
 Check the stitch count in the Status Bar.
 Use Stitch Player. 
 Travel through the stitches. 

Note: If you use Repeat for open shapes, a connecting stitch is 
inserted from the end to the start of the next object which will require 
trimming.

Related topics...
 Simulate design stitchouts
 Viewing stitching sequence

Removing underlying stitching

Backtrack for 
open shapes

Repeat for 
closed shapes

Use Appliqué > Remove Overlaps to remove underlying layer of stitching 
in overlapping objects using the selected object as a ‘cutter’. Right-click for 
settings.
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Use the Remove Overlaps command to remove underlying stitching in 
overlapping objects. This helps to reduce stitch count and prevent a 
build-up of stitches.

To remove underlying stitching
 Select one or more ‘cutters’.

 Click the Remove Overlaps icon. Underlying stitching is removed 
using default settings. Alternatively, select Arrange > Remove 
Overlaps to access settings or right-click the tool.

Select cutters

Set ‘cutter’ 
values

Enter amount of overlap

Enter size of smallest 
permissible object
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 In the Cutters panel, adjust minimum object width and maximum 
stitch spacing as desired.
These settings are useful if, for example, you choose an entire design 
as a cutter and wish to exclude objects, such as borders or details, less 
than a certain width. The Maximum Stitch Spacing setting allows 
you to exclude background stitches of a certain density.

 Select Accordion Allowed to include Accordion Spacing objects. By 
default, the software treats these objects as backgrounds and 
excludes them from the cutting operation.

 Enter the amount of overlap required in the Cutting Overlaps field.

 In the Minimum Fragments field, enter the size of the smallest 
object that will be produced after cutting. This eliminates the 
generation of small objects and unnecessary color changes.

 Click OK. Underlaying stitching is removed.

Tip: You can use an entire design as a cutter excluding objects, such 
as borders or details, less than a certain width.

Related topics...
 Create partial cover appliqué

Specify cutting 
overlap – e.g. 
2.0mm
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Adjusting stitch angles

Stitch angle adjustments depend on object type. With Complex Fill 
objects you can set a single stitch angle for the entire object. You can add 
multiple stitch angles with the Stitch Angles tool. You can also adjust 
stitch angles with the Reshape Object tool.

Add angles in stitch angles mode

Add stitch angles to most embroidery objects interactively using the 
Stitch Angles tool. Create embroidery objects by adding stitch angles 
directly to vector objects.

Use Graphics Digitizing > Stitch Angles to add stitch angles to selected 
objects.

Use Graphics Digitizing > Remove Stitch Angles to remove stitch angles 
from closed objects with turning stitches.

Complex Fill object – one 
stitch angle

Complex Fill converted
to Complex Turning
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To add stitch angles in stitch angles mode
1 Select an object and click Stitch Angles.

2 Digitize stitch angles so that they intersect two sides of the object. 
3 Press Enter. The object is displayed in Reshape mode. 
4 Holding down the Ctrl key, click the outline wherever you want to 

place an additional stitch angle.

Note: To remove all except the default stitch angle, select the object 
and click Remove Stitch Angles.

Add stitch angles in Reshape mode

Adjust or add stitch angles to embroidery objects interactively using the 
Reshape Object tool.

To add stitch angles in Reshape mode
1 Select the object.

Complex Fill object Stitch angles added

Column A object Column B object

Use Reshape > Reshape Object to add stitch angles to selected objects.

Use Reshape Views > Show Stitch Angles to toggle stitch angle display 
when using the Reshape Object tool.
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2 Click the Reshape Object icon and click Show Stitch Angles to view 
only these control points.

3 Click-and-drag stitch angle points to adjust.

Tip: Column A objects automatically convert to Column B as soon as 
you add or adjust a stitch angle. You cannot add stitch angles to 
Complex Fill objects in Reshape mode.

4 Holding down the Ctrl key, click the outline wherever you want to 
place an additional stitch angle.

5 Press Enter.

Related topics...
 Converting designs with CorelDRAW Graphics

Adjusting stitch densities

You may need to change stitch density in order to stitch on a different 
fabric or with a different thread. Or you may want to make production 
cheaper by reducing the overall stitch count. The Process Stitches 
feature lets you change the density of all stitch types (except manual 

Column A object Column B object

Column A object Column B object

Use Stitch > Process Stitches to adjust stitch density of and/or scale the 
whole or selected parts of a design.
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stitch) across the whole or selected parts of a design. It also lets you 
adjust the density of selected stitch types. You can even use the feature 
to scale a design.

To adjust overall stitch density
 Select the design or objects you want to process.
 Click Process Stitches icon.

 In the Stitch Values panel:
 Enter Target Stitches either as a percentage or absolute value. 

This automatically adjusts density of each stitch type required to 
achieve the target stitch count.

 Optionally, adjust density for each stitch type. You can select 
spacing or length as a percentage of the original – from 10% to 
1000% – or as an absolute value – e.g. in millimeters. If you do not 
want to change the density of a certain stitch type, leave it as 
100%.

 Select the checkbox if you want to use Auto Spacing for satin 
stitching. If the checkbox is cleared, Auto Spacing will be removed 
from all selected satin objects and will change to fixed spacing. If 
the checkbox is dimmed, original Auto Spacing values are retained. 

 In the Pull Compensation field, enter an amount by which to 
overstitch (or understitch) in order to compensate for fabric pull.

 In the Dimensions panel, adjust Width and Height values to scale 
selected objects.

Adjust pull
compensation

Adjust stitch
densities

Select auto
spacing

Enter target
stitch count

Adjust width and
height settings to

scale
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 Click OK to apply. Stitches for Tatami, Satin, Run, Zigzag, and 
Program Split objects are regenerated.

Note: If a design was originally created in EmbroideryStudio, or was 
converted into objects, changes you make through the Process 
Stitches dialog will change properties of selected objects. You can 
check changes via the Object Properties docker.

Related topics...
 Satin stitching
 Working with fabrics
 Compensating for fabric stretch
 Scale objects numerically

Eliminating small stitches

Small stitches can damage fabric and cause thread or needle breakage. 
Before you stitch out, unwanted small stitches can be automatically 
removed. The filter can be applied continuously, on output only, or never.

To eliminate small stitches
 Select Design > Remove Small Stitches.

 Choose your preferred option:
 When set to ‘Always’, the filter will be automatically applied in the 

background whenever objects are edited or digitized. 

100%: 5195 stitches 20%: 987 stitches

Program Split
Tatami stitches

Tatami stitch spacing reduced 
(density increased)

Enter minimum 
stitch length to 
keep
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 When set to ‘On Output’, the filter is only applied when printing or 
outputting files.

 Enter the minimum stitch length you want to preserve.
 Click OK to confirm.
 Check the Status Bar for the new stitch count.

Related topics...
 Other general options

Controlling corner stitching

The quality and style of corners is important in borders and appliqué, and 
satin column sewing in general. Sharp corners may cause stitch bunching 
which can create hard spots in the embroidery and may damage fabric or 
needle. The Smart Corners feature helps you control sharp corners in 
Column A and Column C objects.

Corner handling methods

The following approaches can apply to both appliqué and standard satin 
(Column C) columns.

Method Sample Outline Description

No corner Stitches curve around 
corners – standard Column C 
corner handling.

Mitre 
corner

Corners are formed by two 
segments that join in a sharp 
point.
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Corner rounding
A Round Sharp Corners option is available for Column C objects which 
can also be applied to sharp corners. The option is only available in 
conjunction with the Smart Corners effect. It is typically used with the 
Cap Corner option.

Cap 
corner

Corner is capped by an extra 
segment – cap stitching 
remains parallel to the 
column.

Lap corner Corner broken into two 
segments.

Method Sample Outline Description

Rounded 
corner

Corner is sewn in one 
segment, with turning 
stitching, forming a round 
corner on the outer boundary.

Rounded 
cap corner

The corner is sewn in three 
segments forming a round 
corner on the outside 
boundary.

Method Sample Outline Description
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Apply Smart Corners

Use the Smart Corners feature to reduce the number of stitches and 
risk of bunched, distorted embroidery in sharp corners. Mitre Corners 
creates a sharp line at the intersection of two columns. Use it primarily 
for corner angles of 20° to 45°. Cap Corners is suitable for very sharp 
corners as it generates fewer stitches. Lap Corners is suitable for ‘Tidori’ 
style stitching. It can be applied to Column C and appliqué objects. 

To apply Smart Corners
 Click a Smart Corners icon with or without objects selected. With no 

objects selected, smart corners are automatically generated for all 
new objects. Corners are based on current properties. 

 Click again to turn off the effect.

Note: You can also combine Smart Corners in Column C objects with 
sharp corner rounding. 

Related topics...
 Adjust smart corner settings
 Round sharp corners
 Appliqué Embroidery

Use Stitch Effects > Mitre Corners to create sharp lines at intersections of 
two columns. Right-click to adjust settings.

Use Stitch Effects > Cap Corners with very sharp corners to generate fewer 
stitches. Right-click to adjust settings.

Use Stitch Effects > Lap Corners for ‘Tidori’ style stitching. Right-click to 
adjust settings.

Mitre corners Cap cornersLap corners
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Adjust smart corner settings

You can set different angles at which Smart Corners will be applied, and 
specify overlap and stitch length allowances. Right-click a Smart 
Corners icon to access object properties.

Cap corners
Cap provides the following settings:
 Cap below: angle below which to apply capped corners – any corners 

greater than this are not capped. The default is cap below 20°.

Use Stitch Effects > Mitre Corners to create sharp lines at intersections of 
two columns. Right-click to adjust settings.

Use Stitch Effects > Cap Corners with very sharp corners to generate fewer 
stitches. Right-click to adjust settings.

Use Stitch Effects > Lap Corners for ‘Tidori’ style stitching. Right-click to 
adjust settings.

Apply mitre
corner and adjust

settings

Apply cap corner
and adjust

settings

Apply lap corner
and adjust

settings

Angle > 30° Angle < 30° 

Cap below 
30° 
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Tip: If Mitre Corners is also selected, the cap angle is usually smaller 
than the mitre angle.

 Overlap: number of overlapping rows to allow where the sections of 
the cap join.

 Max length: maximum length of cap stitches. Cap Corners with 
stitches exceeding this length will become Mitre Corners. This 
prevents long and short stitches appearing next to each other.

Mitre corners
Mitre provides the following settings:
 Mitre below: angle below which to apply Mitre Corner – any corners 

greater than this are not mitred. The default is lap below 45°.

 Overlap: distance by which stitches are allowed to overlap in the 
center of the corner.

Capping 
overlap: 1

Capping 
overlap: 8

Capping overlap

Mitre below 
angle: 40° 

Angle > 40° Angle < 40° 

Mitre overlap: 
0.5 mm 

Mitre overlap: 
1.5 mm
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Tip: You can use Mitre Corner and Cap Corner options together. For 
example, you may want a corner less than 75° to be mitred but less 
than 45° to be capped.

Lap corners
The Lap Corners feature provides good technical stitching in tight 
corners, as well as creative stitching effects. You have a choice of full 
overlap or split overlap methods, object-by-object. The split overlap 
method provides a variable amount of overlap at the corner. The Lap 
Below setting applies to either method and defines the angle below 
which Lap Corner will take effect. Any corners greater than this are not 
lapped. The default is lap below 110°.

With scalloped shapes, lap corners will always be applied since the corner 
angle approaches zero. 

Full overlap,
Angle < 45° 

Angle > 45° Split overlap,
Angle < 45° 

Lap below: 45° Not lapped

Lap corners
always applied
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Full overlap
Full Overlap provides a Max Extension setting. Technically, this is the 
extension of the corner point from the curve as a percentage of width. 
When set to zero, this setting achieves a blunting effect.

Split overlap
When enabled, Split Overlap provides the following settings:
 Overlap: This setting provides a selectable amount of overlap 

between the two parts of a lapped corner. The effect is similar to a 
mitre corner but with different stitching.

 Max curve extension: extension of corner point from curve as a 
percentage of width. Curve shapes can have flat full or selectable 

Extension = 0

Extension > 0

Overlap: 0.5mm

Lap below: 45° 

Overlap: 2mm Overlap: 3mm
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pointed split overlaps. This parameter achieves a blunting effect, with 
similar practical application as round sharp corners.

Note: The Lap Corners effect is incompatible with mitre or cap 
corners. Turning it on will switch off the other two.

Related topics...
 Set corner fractions

Round sharp corners

A Round Sharp Corners option is available for Column C objects and 
can be applied to sharp corners. The option is only available in 
conjunction with the Smart Corners effect. It is typically used with the 
Cap Corner option. 

To round sharp corners
1 Double-click a Column C object or right-click the tool to access object 

properties.

2 Select the Round Sharp Corners checkbox.

Extension = 0

Extension > 0

Right-click Traditional Digitizing > Column C to set sharp corner rounding.

Select Round 
Sharp Corners
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3 Press Enter or click Apply.

Reducing stitch bunching

Standard stitch spacing is calculated at the outside edge of a shape. With 
sharp curves, spacing which provides adequate coverage on the outside 
edge may cause bunching along the inside edge. This may cause thread 
breakage when stitching out. The longer the stitches, the worse the 
problem. 
With Fractional Spacing, EmbroideryStudio calculates spacing settings 
from a specified point called the ‘offset fraction’. Changing it adjusts 
stitch spacing at inside and outside edges.

Stitch Shortening reduces the length of some stitches in sharp turns so 
that needle penetrations are distributed evenly, creating smoother 
stitching.

Sharp corner Rounded corners

0.00

0.66

0.33

1.00

Offset
fraction:

Outside 
edge

Stitch bunching 
reduced on curves
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Apply fractional spacing

Apply fractional spacing to curved shapes to even out stitch density along 
outside and inside edges. Fractional spacing is particularly useful for 
columns of satin stitches with sharp turns. For best results, combine 
stitch shortening and fractional spacing effects. 

To apply fractional spacing
 Right-click the Fractional Spacing icon with or without objects 

selected to access object properties.

 Select the Fractional Spacing checkbox.
 In the Offset Fraction field, enter an offset as a fraction of column 

width, where the outside edge is 0.00 and inside edge 1.00.

Tip: An offset fraction of 0.33 generates fewer stitches than standard 
spacing, reducing bunching along the inside edge. An offset fraction of 
0.66 eliminates bunching on the inside edge, but may produce 
insufficient stitches to cover the fabric.

Use Stitch Effects > Fractional Spacing to even out stitch density along 
outside and inside edges. Right-click to adjust fractional spacing settings.

Select fractional 
spacing and enter an 
offset fraction

Offset 
fraction 0.00

Offset 
fraction 0.33

Offset 
fraction 0.66

49 stitches59 stitches 43 stitches
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Apply stitch shortening

Apply stitch shortening to sharp corners to decrease density on the inside 
edge. Default settings suit most designs. Advanced users can override 
with custom settings.

To apply stitch shortening
 Right-click the Shortening icon with or without objects selected to 

access object properties.

 In the If spacing < field, enter the minimum spacing permitted 
between stitches (as % of nominal spacing) before automatic 
shortening takes effect.

 Enter the maximum number of consecutive short stitches to allow, up 
to a limit of five.

Use Stitch Effects > Shortening to reduce stitch bunching in tight curves by 
shortening some stitches on the inside edge. Right-click to adjust stitch 
shortening settings.

Select shortening

Access further settings

Adjust shortening settings

 If spacing < 90%  If spacing < 40%
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A higher number allows smoother distribution of needle penetrations 
in tight curves and reduces stitch bunching.

 Click the Settings button. The Stitch Shortening Settings dialog 
opens. Here you can define individual lengths of consecutive short 
stitches as a percentage of the original.

 A value of 80% means that stitches are shortened to 80% of the 
original length, not by 80%. The smaller the percentage, the 
shorter the stitch.

 If you allow three short stitches, you need only fill in the first three 
rows. If you allow five short stitches, fill in all five rows. If only one 
short stitch is generated between normal stitches, the value in Row 
1 will apply. If two consecutive short stitches are generated, the 

Max no. of short 
stitches: 1

Max no. of short 
stitches: 5

Define length of short
stitches relative to

original stitch length

Randomize
shortening pattern

Max no. of short stitches: 1
Shorten stitch length to: 80%

Max no. of short stitches: 1
Shorten stitch length to: 50%
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values in Row 2 will apply to 1st and 2nd stitch respectively. And so 
on up the scale.

Tip: For best results use a jagged pattern between consecutive 
stitches.
 Select the Randomize checkbox to randomize the shortening 

pattern values. This will eliminate unwanted lines appearing in 
regular curves.

Optimizing long satin stitches

Embroidery machines have a maximum possible stitch length which is 
determined by the physical frame movement. If a stitch exceeds this, it 
is generally broken into smaller stitches of equal length. The line formed 
by needle penetrations can affect the appearance of the embroidery, 
especially satin fills. Auto Split breaks long satin stitches into shorter 

Max no. of short stitches: 5
Shorten stitch length to: 50%
Row 1: 80
Row 2: 85 70
Row 3: 70 90 70
Row 4: 70 90 80 70 
Row 5: 70 85 65 85 70

Max no. of short stitches: 5
Shorten stitch length to: 50%
Row 1: 90
Row 2: 70 60
Row 3: 55 85 55
Row 4: 55 85 75 55 
Row 5: 55 70 45 70 55

Randomize ON Randomize OFF
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ones. It also distributes needle penetrations in a random pattern so that 
they do not form a line down the middle of the shape.

If you want to preserve the satin effect – for example, if only a few 
stitches are too long – you can use Auto Jump instead. This preserves 
long stitches in an object by turning them into a series of jumps. Auto 
Split must be turned off for Auto Jump to take effect. Auto Jump is 
applied by default to connectors. 

Note: The maximum frame movement is defined in the software by 
format values. See Standard machine formats for details.

Split satin stitches

While Auto Split is used primarily to prevent long stitches in wide 
columns, it can also be used as an alternative to tatami fill. Auto Split 
looks more satin-like and works well with turning stitches, creating soft 
lines and a little more depth. By contrast, tatami is flat and can show 
unwanted patterns with tight curves. 

Right-click Fill Stitch Types > Satin to apply Auto Split to new or selected 
satin objects.
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To split satin stitches
1 Click the Satin icon with or without objects selected to access object 

properties.

2 Select the Auto Split checkbox.
3 Enter a maximum satin stitch length to allow before Auto Split is 

applied.
Stitches that exceed this value will be split into smaller stitches. This 
value can be smaller than the maximum stitch generally used in the 
design.

Tip: Use a length of 7.00 mm to preserve the satin effect.
4 In the Min length field, enter the shortest stitch that can be 

generated when using Auto Split.

5 Press Enter or click Apply.

Select Auto Split

Adjust max and min 
stitch lengths

Length: 5 mm
Min length: 0.4 mm

Length: 4 mm
Min length: 0.4 mm

Length: 3 mm
Min length: 0.4 mm

Length: 4 mm
Min length: 5 mm

Length: 4 mm
Min length: 3 mm

Length: 4 mm
Min length: 1 mm
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Tip: As an alternative to Auto Split, try a textured tatami fill or 
Program Split. Or, use User Defined Split to manage split lines in 
satin fills.

Related topics...
 Use jumps as connectors
 Patterned Stitching

Preserve long stitches

Apply Auto Jump to satin objects with stitches that exceed the 
maximum stitch length. If the cover stitches are short, extending them 
with a jump makes them looser and thus more effectively raised off the 
fabric. Auto Jump can be used, for example, with manually digitized 
underlays. It can also be used to create quilted effects, for example, by 
applying it to satin areas that are over-stitched with Run stitch or Motif 
Fill.

With User Defined Split With Tatami With Program Split

Use Stitch Effects > Auto Jump to preserve long stitches in new and 
selected objects. Right-click to adjust settings.
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To preserve long stitches
1 Right-click the Auto Jump icon with or without objects selected to 

access object properties.

2 Select the Auto Jump checkbox.
3 In the Max length field, enter the maximum stitch length to allow. 

Stitches exceeding this value will have Auto Jump applied. 

Note: This value must be smaller than or equal to the maximum stitch 
length possible for the selected format. 

4 Adjust Jump length as required. 
Smaller jumps increase the time required to stitch out, but move the 
frame more smoothly across the design.

5 Choose a Length calculation method:

The option you select depends on the way your machine measures 
stitch length. See your machine documentation for details.

Option Function

Along radius Measures the distance between two consecutive needle 
penetrations.

Along axis Measures either the horizontal or vertical movement required 
for the stitch.

Select Auto Jump

Select calculation 
method

Enter maximum stitch 
and jump length settings

Measured 
along radius

Measured 
along axis

Y

X

Maximum
stitch

Maximum stitch

Maximum 
stitch
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6 Press Enter or click Apply.

Caution: Many machines trim by jumps. Thus, to prevent the 
trimmers being activated, usually only one or two jumps between 
needle penetrations may be used. 

Related topics...
 Stabilizing with automatic underlay
 Trim functions
 Standard machine formats

Jump stitches –
not trimmed

NO jump stitches –
additional needle

penetrations
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Chapter 20

Embroidery Connectors

Connectors link objects in a 
design. They can be run stitches 
or jumps. Travel runs are also 
used to connect segments within 
filled objects. 
You can use automatic settings to 
generate connectors, trims and 
tie-offs, or add them manually. 
You can change connector 
settings for a whole design or 
selected objects. If you prefer to 
add tie-offs and trims as you 
digitize, you can turn off 
automatic connectors altogether. 
For Schiffli work, for example, you 
are advised to add connectors manually rather than rely on automatic 
settings.
EmbroideryStudio also allows you to create ‘branched objects’. 
Like-objects are thereby resequenced, connectors minimized, 
components grouped, and stitches regenerated. Underlay can be applied 
to all.
You can also set first and last stitches of a design. This makes it easy to 
position the needle before stitching, and reduces the chance of it hitting 
the frame.
This section describes how to add connectors, tie-offs and trims to your 
designs. It also describes adjusting settings for automatic connectors, 
including the stitch length for travel runs. It also deals with setting 
automatic start and end points.

Types of connectors

The type of connector you use depends on whether you want it to be 
visible in the final design. The default connector setting in 
EmbroideryStudio is for jumps.
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Jumps
Jumps move the frame from one part of the design to another without 
needle penetrations. You can use automatic jumps as connectors 
between embroidery objects. The connecting thread generally needs to 
be tied-off and trimmed. The default connector jump length is the same 
as that set for Auto Jump.

Tip: You can also digitize jumps manually using the Penetrations 
function or with Manual stitch. 

Runs
Travel runs are typically used to connect segments of complex shapes. 
They can also connect adjacent objects. Because runs are not trimmed, 
they may be visible in the final embroidery. If objects are adjacent and 
connectors will be hidden, they can be used. You can change the stitch 
length of travel runs to ensure they do not protrude from the cover 
stitching. You may also adjust the travel run length to reduce the stitch 
count. 

Note: While you can control the properties of run connectors between 
objects, you generally cannot control connectors within objects. 
Lettering and motif run objects are the exception.

Tie-ins
Tie-in stitches are inserted at the start of objects to prevent stitches from 
unraveling. They are inserted inside the shape on the second stitch. You 
generally use them when the previous connector is trimmed.

Tie-offs
Tie-offs are generally placed before trims to prevent stitches from 
unraveling. You can adjust connector settings to automatically add 
tie-offs under certain conditions, or add them manually. You can also 
include trim functions so machines with trimmers cut the thread 
automatically.

Trims
If you are using a machine with an automatic trimmer, the trim function 
causes the thread to be cut after a tie-off. In the software, trims are 
represented by a triangle with a small circle at the point where stitching 
starts again. The trimmed connector appears as a dotted line. You can 
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adjust connector settings to automatically add trims, or add them 
yourself.

Related topics...
 Add jumps with penetrations off
 Digitizing manual stitches
 Adjusting travel run stitch length

Using automatic connectors

EmbroideryStudio lets you generate automatic connectors based on 
settings in the Object Properties > Connectors docker. You can 
change connector settings for a whole design or selected objects. If you 
prefer to add tie-offs and trims as you digitize, you can turn off automatic 
connectors altogether. For Schiffli work, you are advised to add 
connectors manually rather than rely on the automatic settings. 
Automatic connectors are turned off in the Schiffli template. See Adding 
connectors manually for details.

Tip: The Branching feature lets you digitize like-objects – e.g. the 
fingers of a hand – without having to think about the most efficient 
stitching sequence and joins. See Automatic branching for details.

Use jumps as connectors

You can use automatic jumps as connectors between embroidery objects. 
Jumps move the frame from one part of the design to another without 
needle penetrations. You generally need to tie-off and trim the 
connecting thread.

 Trim
Stitching starts

Connector

Use Docker > Object Properties to toggle the Object Properties docker 
on/off. Use it to set jumps as connectors.



Chapter 20   Embroidery Connectors 462

To use jumps as connectors
1 Click the Object Properties icon and select the Connectors tab.

2 Select a connector method:

3 Select Jump and enter a distance for each frame movement. Shorter 
jump values generally improve stitch quality and reduce wear on the 
machine but may increase stitch-out time.

4 Adjust trims and ties as required:

Option Function

After object Adjust connectors immediately following the current object.

Inside object Adjust connectors joining components of lettering objects or 
motif runs. This setting also applies to disconnected parts of 
branched objects. It does not apply to segments within an 
object.

Option Function

Trim after You can choose to turn off automatic trimming, to always trim 
connecting stitches, or to trim only when the connecting stitch 
is longer than a specified value. 

Tie in Tie-in stitches are inserted at the start of objects to prevent 
stitches from unraveling. You generally use them when the 
previous connector is trimmed. 

Select ‘Jump’ and 
enter distance

Select connector 
method

Adjust ‘trim 
after’ settings

Adjust ‘tie-in’ and 
‘tie-off’ settings
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Tip: You can also digitize jumps manually using the Penetrations 
function.

Related topics...
 Adjusting travel run stitch length
 Stitch & jump length settings
 Add jumps with penetrations off

Use runs as connectors

You can use runs of single stitches to connect objects in a design. 
Because runs cannot be trimmed, they are visible on the final 
embroidery, unless another object is digitized to cover them.

Tie off With trims, stitches need to be tied off so the thread can be 
trimmed without unraveling. Select between automatic tie-off 
methods to set preferred default. 

Option Function

Use Docker > Object Properties to toggle the Object Properties docker 
on/off. Use it to set runs as connectors.
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To use runs as connectors
1 Click the Object Properties icon and select the Connectors tab.

2 Select a connector method:

3 Select Run and enter a length for the connecting run stitches.
4 Adjust Tie In settings as required. The Tie Off and Trim After 

options are disabled as they do not apply to travel runs.

Related topics...
 Adjusting travel run stitch length

Automatic tie-in settings

Option Function

After object Allows you to adjust settings of connectors immediately 
following the current object.

Inside object Allows you to adjust settings of connectors joining letters 
within a lettering object, and motifs within motif runs. This 
setting also applies to disconnected parts of branched 
objects. It does not apply to segments within an object. 

Select Run and 
adjust stitch length

Adjust tie-in 
settings

Select connector 
method

Use Docker > Object Properties to toggle the Object Properties docker 
on/off.
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Tie-in stitches are inserted at the start 
of objects to prevent stitches from 
unraveling. They are inserted inside the 
shape on the second stitch. You 
generally use them when the previous 
connector is trimmed.

To adjust tie-in settings
1 Click the Object Properties icon.
2 Select the Connectors tab.

3 Select Tie In from the list and select a tie-in option:

4 Set tie-in values:

Automatic tie-off settings

Option Function

Off No tie-ins are inserted.

Always tie in Tie-ins are inserted before the object.

After Trim/CC Tie-ins are inserted after trims and color changes.

Previous 
connector

Tie-ins are inserted when the previous connector exceeds 
the length you specify.

Option Function

Length Determines length of tie-in stitches.

Number Determines number of tie-in stitches to generate.

Tie-in with 
four stitches

Adjust tie-in 
settings

Use Docker > Object Properties to toggle the Object Properties docker 
on/off.
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With trims, stitches need to be tied off so the thread can be trimmed 
without unraveling. Select between automatic tie-off methods to set 
preferred default.

Method 2 is generally more visually pleasing on smaller objects and satin 
columns. With this method, however, stitches sew on top of each other 
with the consequent risk of thread breakage. On larger areas, the safer 
alternative is Method 1. Method 3 provides an alternative method for 
hiding tie-offs along existing stitch lines.

Tip: For narrow shapes or columns – e.g. small lettering – use only one 
tie-off stitch. You may also decrease the stitch length.

To adjust tie-off settings
1 Click the Object Properties icon and select the Connectors tab.

Method 2 with four 
stitchesMethod 1 with 

two stitches

Method 1 with four
stitches

Method 3 with 2
stitches

Adjust tie-off 
settings

Select a tie-off 
method
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2 In the Tie Off panel, select a tie-off option:

3 Select a default tie-off method. The system will apply this method 
where it can but switch where necessary, depending on stitch spacing 
and type.

4 Set the tie-off values:

Automatic trim settings

You can choose to turn off automatic trimming, to always trim connecting 
stitches, or to trim only when the connecting stitch is longer than a 
specified value.

Option Function

Off No tie-off is inserted. By selecting this option, you need to 
add tie-off functions manually. See Add tie-offs for details.

Always tie off A tie-off is inserted after the object.

Before trim / color 
change

A tie-off is inserted before a trim or color change.

Always tie off last A tie-off is inserted if the object is the last one in the design.

Next connector 
longer than

A tie-off is inserted if the next connector exceeds the 
specified length.

Method Function

1 Adds a specified number of small stitches between the last two 
stitching lines. Generally used with dense fills.

2 Adds a specified number of small stitches up and back down the last 
stitching line. Generally used with open fills where it is less visible.

3 Splits the second-last stitching line into three equal stitches. Also 
adds a specified number of small stitches back up the last stitching 
line.

Option Function

Length Determines length of tie-off stitches.

Number Determines number of tie-off stitches to generate.

Use Docker > Object Properties to toggle the Object Properties docker 
on/off.
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To adjust automatic trim settings
1 Click the Object Properties icon and select the Connectors tab.

2 In the Trim After panel, select a trim option:

Tip: Usually, connectors shorter than 3 mm are not visible on the final 
embroidery. You may sometimes require a smaller value – e.g. if the 
thread color contrasts with the background color.

Adding connectors manually

You can add tie-offs and trims to a design manually using the Tie Off, 
Trim and Empty Stitch tools. While generally not recommended and 
less efficient than using automatic connectors, this method does give you 
more control over the final design. For example, some machine formats 
are unable to read functions that appear on a normal stitch. For these 
machines, you need to add trim, tie-off and other machine functions to 
an Empty Stitch or Empty Jump. You may also need to add one or 
more empty stitches or empty jumps to either side of a function for the 
machine to read it correctly.

Note: For Schiffli work, you are advised to add connectors manually 
rather than rely on the automatic settings. Automatic connectors are 
turned off by default in the Schiffli template.

Option Function

Off No trims are inserted. This feature is useful if trimming 
causes your machine to slow down, or the needle to 
lose the thread. You can either add trim functions 
yourself, or trim the final embroidery by hand.

Always trim Trims are inserted after the object.

Trim if next connector 
is longer than

Trims are inserted if the next connector exceeds the 
length you specify.

Adjust ‘trim after’ 
settings
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Add tie-offs

You can add tie-offs in your design using the Tie-Off tool. This provides 
a semi-automated technique for adding tie-offs as an alternative to 
digitizing them with manual stitches. Tie-offs are usually added before a 
trim at the end of an object. Generally you will follow a tie-off with a trim. 

To add a tie-off
1 Travel to the object you want to tie-off.
2 Click the Insert Tie-off icon. A Tie-off function is inserted.

The default number of tie-off stitches is two. This means the needle 
backtracks twice and returns to the insertion point. Adjust this value 
in the Object Properties > Connectors docker. 

Tip: You can also insert machine functions manually using the Insert 
Machine Function dialog. 

Related topics...
 Viewing stitching sequence
 Add trims
 Insert machine functions manually
 Automatic tie-off settings

Add trims

Click Function > Insert Tie-Off to insert a tie-off.

Tie-off
function start

Tie-off
function end

Click Function > Insert Trim to insert a trim.
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You can add trims in your design using the Trim tool. When you add a 
trim in this way, the trim function is added to the current stitch. Some 
machines require empty stitches or empty jumps on either side of the 
trim. If this is the case for the machine you want to stitch to, you will need 
to insert them. 

Tip: Make sure that all stitches you trim have been tied in and off, 
otherwise stitches will not be secured.

To add a trim
1 Travel to the needle position where you want to trim the thread.
2 Click the Insert Trim icon. A trim function is inserted at the current 

needle position. 

Tip: You can also insert machine functions manually using the Insert 
Machine Function dialog. 

Related topics...
 Travel through designs
 Insert machine functions manually

Add empty stitches & jumps

Empty stitch is a tight (zero length) lockstitch used together with, or as 
an alternative to, tie-in and tie-off stitches. Use empty stitches instead of 
tie-ins or tie-offs for objects filled with light density stitching where 
standard tie-ins and tie-offs may be visible. Also, use empty stitches or 
empty jumps when required by the selected machine format. 

Trim symbol

Tie-in symbol

Click Function > Insert Empty Stitch to insert an empty stitch.

Click Function > Insert Empty Jump to insert an empty jump.
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To add empty stitches and jumps
1 Travel to the needle position where you want to trim the thread.
2 Click the Insert Empty Stitch icon to insert an empty stitch.
3 Click the Insert Empty Jump icon to insert an empty jump.

Tip: You can also insert machine functions manually using the Insert 
Machine Function dialog. 

Related topics...
 Travel through designs
 Insert machine functions manually

Add jumps with penetrations off

You can create jump connectors manually in a design by digitizing with 
penetrations off. The Penetrations tool prevents the needle from 
penetrating the fabric, forcing the machine to move across the design in 
a series of jumps. You can use Penetrations with any input method.

To add a jump with penetrations off
1 Select an input method – e.g. Run.
2 Deselect Penetrations. 
3 Digitize the connector in the usual way for the selected input method.

Empty functions
added to stitching

sequence

Deselect Function > Penetrations to create jumps with needles or borers 
out.
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The jumps are saved together as an embroidery object.

Adjusting travel run stitch length

Travel runs are usually used to connect segments within filled objects. 
They are usually covered by fill stitches when the object is stitched out. 
You can adjust the travel run length to reduce the stitch count.

To adjust travel run stitch length
1 Click the Object Properties icon.
2 Select the Special tab and Travel Run from the list.

3 Enter a value in the Length field as required.

Penetrations off – jump stitches Satin Jumps Tatami

Use Docker > Object Properties to toggle the Object Properties docker 
on/off. Use it to set the travel run stitch length.

Adjust travel 
run length

Travel Run 
length: 1 mm

Travel Run 
length: 3 mm
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Tip: Increase stitch length to reduce the stitch count. Travel Run 
automatically varies the stitch length on tight curves.

Keeping or omitting last stitches

If you are digitizing adjoining columns, you can keep or omit the last 
stitch in the first column to achieve a smoother join or shorter connecting 
stitches.

Note: This feature only applies when the exit point is at the end of the 
column – i.e. the default exit point. Moving the exit point using the 
Reshape Object tool overrides the Keep Last Stitch/Omit Last 
Stitch command.

To keep or omit the last stitch
 To keep the last stitch, select the object and click the Keep Last 

Stitch icon.
 To omit the last stitch, select the object and right-click the Omit Last 

Stitch icon.

Click Reshape > Keep Last Stitch to keep the last stitch in a column.

Click Reshape > Omit Last Stitch to omit the last stitch in a column.

Columns 
smoothly joined

Columns with 
unwanted space

Press Enter – last stitch kept Press Spacebar – last stitch omitted
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Tip: Alternatively press Spacebar to omit the last stitch or Enter 
keep it.

Related topics...
 Apply closest join

Minimizing connectors

Designs stitch out more efficiently when the connectors between objects 
are short. This also reduces the number of trims in a design. 
EmbroideryStudio has a Closest Join method which is set via the Setup 
(or Standard toolbar) > Options > General tab. When activated (the 
default), entry and exit points of objects are automatically placed when 
the user digitizes new objects.

However, closest joins are not automatically maintained when objects 
are moved, re-sequenced, or edited. The Apply Closest Join feature 
allows you to (re-)apply closest joins to objects after editing. 
EmbroideryStudio also allows you to manually change entry and exit 
points of individual objects. 

Adjust entry/exit points

Use Reshape Object to adjust the entry and exit points of selected objects.

Use Reshape Views > Show Entry/Exit Points to toggle entry/exit point 
display when using the Reshape Object tool.
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EmbroideryStudio allows you to manually change entry and exit points of 
individual objects. Entry and exit points should always be checked if you 
are re-sequencing objects in a design. 

Tip: Closest joins are not automatically maintained when objects are 
moved, re-sequenced, or edited. The Apply Closest Join feature allows 
you to automatically re-apply closest joins to objects after editing. 

To adjust entry/exit points
 Select an object and click Reshape Object.
 Click Show Entry/Exit to view only entry and exit points.
 To view next or previous objects, press Tab or Shift+Tab keys. Any 

changes to objects are confirmed.
 Select entry or exit points of adjoining objects and drag into close 

proximity.

 Press Enter.

Tip: If you are digitizing adjoining columns, optionally keep or omit 
the last stitch in the first column to achieve a smoother join or shorter 
connecting stitches.

Related topics...
 Sequencing embroidery objects
 Keeping or omitting last stitches
 Other general options

Exit point

Entry point Exit point

Entry point Exit point

Entry point
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Apply closest join

When you are digitizing closed objects, the Closest Join method 
automatically calculates the closest join between them, saving you 
having to think about entry and exit points. The Apply Closest Join 
feature allows you to (re-)apply closest join to objects after editing. The 
command may be accessed via:
 Toolbar button on the Arrange toolbar
 Arrange menu
 Design Window popup menu
 Color-Object List popup menu
 Shortcut key (J)

Note: The Apply Closest Join command is only enabled when two or 
more embroidery objects are selected.

To apply closest join
 Digitize embroidery objects as required.

If the Closest Join method has been activated via the Setup (or 
Standard toolbar) > Options > General docker, entry and exit 
points of objects are automatically joined at the closest point.

 Move, reshape, and/or resequence objects in the design as required.

Use Arrange > Apply Closest Join to (re-)apply closest join to objects after 
editing.

Objects joined at 
closest point
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Closest join is not recalculated automatically – long connectors may 
result.

 Select all objects in the sequence and reapply closest join – click 
Apply Closest Join or choose the command from the popup menu.
Selected embroidery objects are regenerated and Closest Join 
applied.

Long connectors 
may result after 
resequencing

Closest joins 
recalculated
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Caution: Any non-sequential embroidery objects in the selection will 
cause a message to be displayed:

Tip: Apply Closest Join also to generated offset objects.

Related topics...
 Other general options
 Generating outlines & offsets

Closest join limitations

The Apply Closest Join feature is not applicable to all objects in all 
circumstances. Note the following limitations.

Stitch regeneration
Closest Join requires the complete stitch regeneration of the objects – 
the whole object, not just connectors. Stitch regeneration has its 
limitations:

Closest joins 
recalculated
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 Recognized objects – i.e. opened from machine files – may generate 
poor or incorrect embroidery.

 Manual (unrecognized) objects cannot be changed by stitch 
regeneration. Thus Closest Join will not work properly for them.

 Manual stitch edits to objects will be lost.
 Inserted and recognized machine functions may be mistakenly 

regenerated on the underlay.
 Nested objects are not supported. They will become un-nested and 

placed after the object in which they were originally nested. This may 
not produce ideal sequence.

Run objects
The Closest Join technique is not as powerful as Branching for run 
objects. Closest Join will not produce a nicely-merged double-run, so 
connectors are only possible at the ends of the run, not in the middle. 
The best it can do is swap the ends of the runs.

Automatic branching

The Branching feature lets you digitize like objects – e.g. the fingers of 
a hand, sections of a custom letter – without having to think about the 

Branched run 
objects

Closest-join run 
objects
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most efficient stitching sequence and joins. Apply Branching to join 
touching or overlapping objects to form a single ‘branched object’.

Characteristics of branched objects
 Objects are resequenced, connectors minimized, component objects 

grouped, and stitches regenerated.
 When dissimilar objects are selected, any which cannot be branched 

are omitted.
 All component objects are grouped and selectable as one.
 Branched objects can be reshaped.
 There is a single entry and one exit point but all component objects 

have individual reshape points.
 Branched objects preserve their component object properties while 

sharing the color of the first object in the sequence.

 Branching works with any combination of the following object types – 
Run, Column A, Column B, Column C, Complex Fill and Complex 
Turning. Objects with Motif Run and Motif Fill cannot be used.

 Stitch types can be re-assigned via the toolbar.
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Apply automatic branching

Apply Branching to selected objects. These become a single branched 
object.

To apply automatic branching
1 Select the objects.

Note: The function is only available if more than one object of any 
suitable type is selected.

2 Click the Branching icon. EmbroideryStudio will prompt you to 
digitize entry and exit points.

3 Digitize entry and exit points, or press Enter twice to accept the 
defaults.

Click Arrange > Branching to automatically sequence and group like 
embroidery objects.

Long connectors 
between separate 
objects
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Component objects are grouped and share the color of the first 
branched object. Objects are resequenced, connectors minimized, and 
stitches regenerated. 

4 Travel through the branched object to check stitching.

Related topics...
 Travel through designs

Branch objects with the Color-Object List

The Color-Object List provides an easy way to select objects in designs 
and access their properties. You can use it to branch like objects in a 
design.

To apply branching with the Color-Object List
1 Click the Color-Object List icon.
2 Select objects in the Color-Object List.

Objects resequenced, 
connectors minimized

Use Docker > Color-Object List to branch selected objects in a design.
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3 Right-click and select Branching from the popup menu.

Note: The function is only available if more than one object of any 
suitable type is selected.

4 Digitize entry and exit points, or press Enter twice to accept the 
defaults.
Component objects are grouped and share the color of the first 
branched object. Objects are resequenced, connectors minimized, and 
stitches regenerated. 

Tip: Use the Color-Object List also to cut, copy and paste, group and 
ungroup, lock and unlock, and show and hide objects, as well as 
resequence objects.

Related topics...
 Combining Objects

Branch selected 
objects

Long connectors 
join objects

Selected objects 
grouped into single 
branched objectLong connectors 

eliminated
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Apply automatic underlay to branched objects

Because Branching combines objects to form a 
single branched object, you may be able to apply 
a single underlay to the entire object. The 
technique works well with Column A or Column B 
objects.

To apply automatic underlay to branched 
objects
1 Select the branched object and right-click 

Auto Underlay.

2 Select the First Underlay checkbox and select an underlay type.
3 Optionally, add a second underlay.
4 Press Enter or click Apply. Underlay stitches are automatically 

generated for the branched object. 

Note: If component objects are touching or overlapping, the underlay 
is first stitched out for the whole branched object followed by the cover 
stitch.

Related topics...
 Viewing stitching sequence

Right-click Stitch Effects > Auto Underlay to select an underlay type to 
apply to branched objects.

Select underlay type

Select First Underlay

Entire underlay 
stitched first

Cover stitched 
second
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PART VI
DECORATIVE EMBROIDERY

EmbroideryStudio provides many features for the creation of motif runs 
and fills, textured and patterned fills, open stitching, and curved fills.

Patterned stitching
This section explains how to create textures with tatami offsets and 
program splits. Create your own and add them to a custom library. 
Creating stitch patterns with carving stamps is covered as well as adding 
details with user-defined splits. See Patterned Stitching for details.

Curved stitching
This section covers contoured fills and flexi-splits. It also covers the 
creation of radial fill effects and curved fills. See Curved Stitching for 
details.

Specialty stitching
This section describes how to create jagged or fluffy edges as well as 
open stitching with trapunto effect. It also describes how to create 
stippling and cross stitching, as well as accordion spacing, and color 
blending effects. Creating curved fills with ‘Florentine’ and ‘liquid’ effects 
is also covered. See Specialty Stitching for details.

Motif stitching
This section describes how to insert motifs into your design, and how to 
rotate, mirror and scale them. It explains how to manage motifs, 
including how to create your own motifs and motif sets. It also describes 
how to create both motif runs and motif fills, as well as how to apply 3D 
effects to motif fills. See Motif Stitching for details.
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Chapter 21

Patterned Stitching

EmbroideryStudio provides tools for 
creating patterns with needle 
penetrations. Apply offset fractions 
or partition lines to tatami fills for a 
variety of split-line effects. 
Alternatively, use Program Split or 
Flexi Split to create decorative fills 
from predefined patterns. Select 
from the library or create your own.
The Carving Stamp feature allows 
you to define patterns using a 
‘carving stamp’ as a template. Use 
it also to create your own split lines 
when you want to add detail to filled 
objects.
This section explains how to create 
textures with tatami offsets and program splits. Create your own and add 
them to a custom library. Creating stitch patterns with carving stamps is 
covered as well as adding details with user-defined splits.

Creating textures with tatami offsets

With tatami fills you can create patterns of needle penetrations. With only 
two offsets available, the number of patterns is limited, but even with 
small offsets, visible lines are produced. Partition lines, with up to eight 
offsets, can create more patterns. Using a random factor you can 
distribute needle penetrations randomly.
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Tip: Auto Split can be used to create special textures in satin stitches as 
an alternative to tatami fill. See Split satin stitches for details.

Create offset patterns

The tatami offset default settings are designed to create a uniformly flat 
and smooth surface. The texture is like a woven tatami mat without 
obvious split lines. By manipulating offset fractions, you can create stitch 
penetrations which are more clearly visible.

Tip: By adjusting offsets, you can also improve the quality of turning 
tatami where the pattern may be disturbed by non-parallel stitches. 
Changing the offsets can reduce this interference.

To create offset patterns...
1 Right-click the Tatami icon to access object properties.

2 Select the Offset Fraction option. To control needle penetrations you 
set offset fractions for both forward and backward rows. 

Use Fill Stitch Types > Tatami to create fills for larger irregular shapes. 
Right-click for settings.

Specify offset 
fractions for alternate 
rows
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3 In A and B fields, experiment with offset fraction values. Offsets are 
defined as fractions of stitch length – e.g. 0.3 = 30%.

 Even stitching: set both fields to 0.25.
 Strong horizontal lines: set both fields to 0.00 or 1.00. The 

distance between each line of needle penetrations is the stitch 
length.

 Light horizontal lines: set both fields to 0.5. Lines are produced 
at half stitch-length intervals.

 Diagonal lines: set both fields to any value other than 0.00, 
0.50 and 1.00. Diagonal lines are less noticeable than horizontal 
or vertical lines. Vary both values to change the angle of the lines 
and the distance between them.

 Other: set one field to 0.00, and experiment with the other values 
to place the needle penetrations on the forward and backward rows 
close to each other, but with different effects.

A=0.00, B=0.00 A=0.50, B=0.50 A=0.25, B=0.25

A=0.50, B=0.25 A=0.30, B=0.60 A=0.40, B=0.00

Offset: A=0.3, B=0.6
Stitch length: 4 mm

Offset: A=0.3, B=0.6
Stitch length: 3 mm

Offset: A=0.3, B=0.6
Stitch length: 2 mm
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Note: If A-B offsets add up to 1.0, lines will be horizontal. If the sum 
is less than 1.0, lines will slope down, more and they slope up. The 
mirror image of ‘A=0.3 and B=0.6’ is ‘A=0.7 and B=0.4’.

Tip: Tatami patterns can be combined with curved fills for interesting 
effects.

Related topics...
 Curved fills

Create partition line patterns

The Partition Line feature provides an alternative method for offsetting 
needle penetrations in tatami fills. The Object Properties > Fills > 
Tatami docker allows you to set partition lines. Two parameters can be 
set – Sequence and Angle.

A=0.30, B=0.60 A=0.50, B=0.50 A=0.70, B=0.40

Use Fill Stitch Types > Tatami to create fills for larger irregular shapes. 
Right-click for settings.

Select Partition Line

Enter partition sequence 
and grid angle
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Sequence
Partition Line allows you to specify up to eight tatami offsets. In any 
pattern, number of rows is determined by number of digits in the 
sequence. 

Each stitch length is split into ‘knots’ numbered anywhere from 0 to 7. A 
partition sequence number of ‘20163’ would translate to the following 
pattern:

Angle
You can skew the grid formed by the partition knots to further vary the 
needle penetrations. In the Angle field, specify a grid angle.

Tip: Tatami patterns can be combined with curved fills for interesting 
effects.

Related topics...
 Curved fills

Sequence: 11 Sequence: 012 Sequence: 01

Stitch length

Row 1

Row 2

Row 3

Row 4

Row 5

Knot 2

Knot 0

Knot 1

Knot 6

Knot 3

Sequence: 11
Angle: 0

Sequence: 11
Angle: 45

Sequence: 11
Angle: 90
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Create random patterns

Using a random factor you can eliminate the split line patterns formed by 
regular needle penetrations and distribute the stitches randomly inside 
the shape. This can create interesting mottled effects.

To create random patterns...
 Right-click the Tatami icon to access object properties.

 In the Random field, specify a random factor between 0% and 100%. 

Tip: A value of around 50% generally gives good results.

Use Fill Stitch Types > Tatami to create fills for larger irregular shapes. 
Right-click for settings.

Enter a 
random factor

Random factor: 10%
Offset fraction A: 0.25, B: 0.25

Random factor: 50%
Offset fraction A: 0.25, B: 0.25

Random factor: 100%
Offset fraction A: 0.25, B: 0.25
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Creating textures with program splits

Program Split is a decorative fill stitch where needle penetrations form 
a tiled pattern. Select a predefined pattern or create your own.

Apply program splits

You can apply Program Split to a wide variety of objects. You can adjust 
these either before or after applying the effect. Choose from a library of 
split patterns. 

Use Fill Stitch Types > Program Split to create decorative fill stitches where 
needle penetrations form a tiled pattern. Right-click for settings. 

Use Outline Stitch Types > Program Split to create borders or columns of 
even width for decorative needle penetration patterns. Right-click for 
settings. 
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Note: Digitize the stitch angle carefully when creating objects with 
program splits. If rows are parallel with pattern lines, they will rarely 
intersect and the pattern may not be visible. A 45° stitch angle is suitable 
for most patterns.

To apply program splits...
 Click the Program Split icon. Program Split stitching is applied to 

new or selected objects, based on current settings.
 Right-click the Program Split icon to access object properties.
 Select a pattern from the droplist. Alternatively, click the arrow button 

to access the pattern library.

 Adjust pattern size via Size X/Y fields. The scaling lock maintains 
aspect ratio. Use the Angle setting to orientate the pattern within the 
shape.

Tip: Tatami patterns can be combined with curved fills for interesting 
effects.

Pattern preview

Choose from
the pattern

library

Select a pattern

Enter pattern width 
and height

Default values Size X and Size Y 
increased

Angle adjusted
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Related topics...
 Curved fills

Apply combination splits

Standard program split consists of a satin foreground and background – 
i.e. Satin-in-Satin. If patterns do not overlap you may get jump stitches 
or gaps occurring in the background. In this case, you can select from 
different combinations of satin and tatami stitches.

To apply combination splits...
1 Right-click the Program Split icon to access object properties.

2 In the Combination Split panel, click the desired option:

Use Fill Stitch Types > Program Split to create decorative fill stitches where 
needle penetrations form a tiled pattern.

Use Outline Stitch Types > Program Split to create borders or columns of 
even width for decorative needle penetration patterns. Right-click for 
settings. 

Satin-in-Tatami

Tatami-in-TatamiSatin-in-Satin

Satin-in-Satin Satin-in-Tatami Tatami-in-Tatami
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Options include:

Program split settings

You can adjust program splits both interactively on screen and via object 
properties.

Column & row spacing
Column and row spacing settings determine distance between grid lines. 
Patterns are placed at intersection points – the center of each pattern 
coincides with an intersection.

Option Function

Satin-in-Satin This is the standard program split stitch type, which 
produces the smallest number of stitches.

Satin-in-Tatami Use this option to avoid long stitches when the patterns 
are small but column and row spacings are wide.

Tatami-in-Tatami Both foreground and background use tatami. Select this 
option for large objects and patterns to avoid long 
stitches.

Use Fill Stitch Types > Program Split to create decorative fill stitches where 
needle penetrations form a tiled pattern.

Use Outline Stitch Types > Program Split to create borders or columns of 
even width for decorative needle penetration patterns. Right-click for 
settings. 

Column spacing increased Row spacing decreasedDefault spacing values
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The initial settings define a simple grid, where the spacing equals the 
dimensions of the pattern. The row offset is set to 0.00 mm so columns 
and rows are perpendicular.

Column & row offsets
With all three program split combinations – Satin-in-Satin, 
Satin-in-Tatami and Tatami-in-Tatami – you can vary the pattern by 
applying offset settings to rows and/or columns. You can also provide 
background texture with tatami stitch offsets. 

If both offsets are set to ‘0’, grid lines are perfectly vertical and 
horizontal. As a rule, it only makes sense to use values between 0 and 
half the pattern size. For example, if the pattern is 8 mm, select row and 
column offsets between 0 mm and 4 mm.

Stitch settings
Specify stitch length, minimum stitch length and spacing settings for 
program split objects, in the same way as for other fill stitch types. You 

Set column spacing 
and offset values

Set row spacing 
and offset values

Column offset: 0.00  Column offset: 1.00  Column offset: 2.50

Row offset: 0.00  Row offset: 1.00  Row offset: 2.50
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can eliminate unwanted patterns and distribute stitches evenly within a 
shape using a random factor.

In the Stitch Spacing field, enter the required spacing. For tatami this 
is the distance between two forward rows of stitches, for satin, the 
distance between each forward stitch.

Enter a value in the Random field – specify a factor between 0% and 
100%. The random factor does not affect the deliberate needle 
penetrations that form the pattern. Values of around 50% generally give 
good results.

Tatami stitch offsets
When using Satin-in-Tatami or Tatami-in-Tatami, you can also control 
tatami stitch offsets.

Adjust stitch spacing, 
length and minimum 
length

Enter random 
factor

Stitch spacing increased Stitch spacing decreasedDefault spacing values

Random factor: 25%  Random factor: 90%Random factor: 0%
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Tatami is mainly used to avoid long stitches, so it should not have a 
distinct appearance which may obscure the program split pattern. 
Therefore, typical offsets are in the range 0.2 mm to 0.4 mm.

Enter a stitch offset in the Stitch > Offset A field. This offset controls 
where the needle penetrations line up for each row of stitching. 

Related topics...
 Creating textures with tatami offsets

Lay out program splits on-screen

You lay out program splits on-screen in a similar way to Motif Fills by 
using ‘guide patterns’ to scale, space, transform and offset the entire 
pattern fill.

Enter stitch 
offset

Offset A: 0.00 Offset A: 0.25 Offset A: 0.50

Use Fill Stitch Types > Program Split to create decorative fill stitches where 
needle penetrations form a tiled pattern.

Use Outline Stitch Types > Program Split to create borders or columns of 
even width for decorative needle penetration patterns. Right-click for 
settings. 
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To lay out program splits on-screen...
1 Right-click the Program Split icon to access object properties.

2 Select a pattern from the droplist. Alternatively, click the arrow button 
to access the pattern library.

3 Click Layout. Three blue guide patterns allow you to change the 
layout.

4 Adjust the guide patterns to achieve the desired effect:
 Move patterns by selecting the middle guide pattern and dragging.
 Scale patterns by selecting a guide pattern and dragging selection 

handles.

 Rotate patterns by clicking the middle guide twice to display the 
rotation handles. Click a corner handle and drag to rotate. 

Select 
pattern

Click to change
pattern layout

Use top guide pattern to change row 
spacing, row offset, and to scale patterns

Use side guide pattern to change 
column spacing, and to scale 
patterns

Use middle guide pattern to
move, rotate, skew, and

scale patterns

Drag the 
pattern

Scale
proportionally

Scale 
horizontally

Scale 
vertically



Chapter 21   Patterned St itching 500

 Skew patterns by clicking the middle guide twice, then dragging the 
skew handles. 

 Change column spacing by selecting the side guide and dragging it 
left or right.

 Change column offset by selecting the side guide and dragging it up 
or down.

 Change row spacing and offsets in the same way as columns.

5 Press Enter to apply.

Rotate

Skew

Anchor

Change column 
spacing

Change 
offset

Change row 
spacing

Change offset
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Related topics...
 Lay out motif fills on-screen

Creating patterns with custom splits

Make your own patterns to use in Program Split fills. The same patterns 
can also be used with Flexi Split effects.

Make split patterns

Make your own patterns to use in program split fills. Create patterns from 
the outlines of embroidery objects or from drawing objects. Patterns you 
create can also be used for Flexi Split effects. 

To make a split pattern...
1 Select the object (or objects) you want to use for the pattern.

2 Select Object > Create Program Split.

3 Enter a name in the Create Program Split dialog.
4 Click OK. The new pattern is automatically selected in the Pattern 

list.

Enter pattern
name

A-My Program Split
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Related topics...
 Creating textures with program splits
 Flexi-splits

Edit split patterns

Editing a pattern changes the actual pattern, not just the object layout.

To edit a split pattern...
1 Right-click the Program Split icon to access object properties.

2 Select a pattern and click Edit.

3 Press Shift+0 to zoom in on the pattern.
4 Scale, transform or reshape the pattern as required.
5 Select Object > Create Program Split with the pattern selected.

6 Enter a name for the pattern in the Create Program Split dialog.
 To create a pattern based on the old one, enter a new name.
 To overwrite the original pattern, enter the name of the original.

7 Click OK. The pattern is automatically selected in the Pattern list.

Related topics...
 Creating textures with program splits

Select pattern

Click to edit pattern 

Edit pattern

Enter pattern
name

A-My New Program Split
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 Flexi-splits

User-defined splits

The User-Defined Split function lets you add detail to filled objects by 
digitizing lines of needle penetrations called ‘split lines’. Split lines are 
stored as object properties. They are preserved when stitches are 
regenerated even if you apply a different stitch type.

To create new objects with user-defined splits...
1 Select a fill input method such as Complex Fill and suitable stitch 

type.
2 Click the User-Defined Split icon.

Use Traditional Digitizing > Complex Fill to digitize filled shapes with a 
single stitch angle. Right-click for settings.

Use Stitch Effects > User-Defined Split to create your own split line effects. 
Right-click to adjust settings.

Use Reshape > Reshape Object to reshape selected objects, edit stitch 
angles, and adjust entry/exit points.
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3 Digitize the object boundaries, entry and exit points and stitch angle 
as you normally would, following the prompts in the Prompt Line.

When you have completed the object, you will be prompted to digitize 
the split line.

4 Digitize the split line or press Enter to accept the default. Repeat this 
step for any additional split lines.

5 If you have accepted the default, click Reshape Object. Click the 
diamond control point in the center of the split line to invoke resizing 
control points. Use these to resize, rotate, or reposition the split line.

6 Alternatively, click the split line at any point. Control points appear 
together with Reshape Views toolbar. Use these to reshape the split 

Digitize object 
outline

Digitize split 
line

Click diamond control 
point to invoke resizing 
control points
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line like any outline object. Note that the split line can extend beyond 
the object itself.

7 Press Esc to complete.

Tips for use...
 User-defined split can be applied to various stitch types – most 

commonly tatami, satin, or possibly zigzag.
 If using it with satin, it’s best to turn off auto-split. 
 For best results, split lines should be approximately perpendicular to 

the stitch angle.

Related topics...
 Reshaping embroidery objects
 Digitize custom splits

Reshape split line 
like any outline 
object
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Creating patterns with carving stamps

The Carving Stamp feature allows you to define a pattern of needle 
penetrations using a ‘carving stamp’ as a template. A carving stamp can 
be any vector or embroidery shape.

Carving Stamp docker
The Carving Stamp docker contains four tabs as shown...

These tabs provide the following functionality:

Tab Lets you...

Use Pattern Select and apply predefined stamp patterns to selected objects.

Use Object Use selected outlines as a temporary stamp. These can include 
vector graphics. 

Digitize Digitize custom splits ‘on the fly’. 

Appearance Soften or intensify the effect.

Select a tab
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Apply predefined patterns

The Use Pattern tab lets you select and apply predefined stamp 
patterns. You can start with or without embroidery objects selected. If 
one or more objects is selected, stamps are only applied to selected 
objects. If no object is pre-selected, stamps can be applied to any 
objects.

To apply predefined patterns...
1 Select an embroidery object or not as required.
2 Click the Carving Stamp icon. The Use Pattern tab is open by 

default.

3 Select a pattern set from the Set list. The droplist contains predefined 
pattern sets as well as custom sets. Many are shared with other 
features such as Monogramming.

4 Select a predefined stamp pattern. A thumbnail appears in the preview 
panel and the Use Stamp button is enabled.

5 Click the Use Stamp button and move the mouse pointer to the 
design window. 

6 Move the mouse pointer to the desired position over the target 
object/s.
 Right-click to mirror the stamp.
 Press Shift to prevent Auto Scroll.

Use Docker > Carving Stamp to define a pattern of needle penetrations 
using a ‘carving stamp’ as a template.

Select a pattern 
set

Select a stamp 
to use
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7 Click the mouse button to fix the anchor point.

8 Swivel the pattern about the anchor point to the desired guide point 
position.

9 Optionally, with the Shift key pressed, resize the stamp while moving 
the mouse pointer. 

10 Click the mouse button.
 If you have pre-selected an object or objects, the stamp pattern is 

applied only to those objects.
 If no objects are pre-selected, the stamp pattern is applied to any 

underlying objects.
11 Press Esc to exit the feature.

Note: The Rename and Delete buttons are enabled whenever a 
custom stamp is selected. When the Rename button is clicked, the 
Rename Split Pattern dialog opens. 

Tip: Use the Softened Stamp and Raised Stamp options on the 
Appearance tab to soften or accentuate the effect. 

Related topics...
 Add stamps to a library
 Carving stamp appearance

Use objects as carving stamps

Enter name for
new library set

My new pattern

Use Docker > Carving Stamp to define a pattern of needle penetrations 
using a ‘carving stamp’ as a template.
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The Use Object tab allows you to select object outlines from the design 
window and apply them directly as stamps or save them to a library for 
future reference. You can use vector or embroidery objects as a basis for 
stamps.

To use an object as a carving stamp...
1 Choose an embroidery object or vector object to serve as your stamp.

2 Click the Carving Stamp icon and select the Use Object tab.

3 Click the Start Selecting button. Any pre-selected objects remain 
selected.

4 Hover the mouse over any object in the design window.
5 Click the Use Stamp button to apply the selection as a carving stamp.

Select ‘Use 
Object’ tab
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6 Optionally, click the Add to Library button to add the selection to the 
library for future reference.

Tip: You can also use lettering, embroidery or TrueType, as an input 
to stamp creation. 

Tip: If you want to use a bitmap image, you can convert to vector 
format in CorelDRAW Graphics using the Bitmaps > Outline Trace 
command set.

Related topics...
 Add stamps to a library

Digitize custom splits

Select character to 
use as stamp

Use Docker > Carving Stamp to define a pattern of needle penetrations 
using a ‘carving stamp’ as a template.
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The Digitize tab allows you to digitize split lines and directly apply in situ 
or to any applicable objects in the design window.

To digitize custom splits...
1 Select an embroidery object or not as required. If embroidery objects 

are pre-selected, digitized stamps will apply only to these objects.

2 Click the Carving Stamp icon and select the Digitize tab of the 
dialog.

Click to start 
digitizing
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3 Click the Start Digitizing button. You are prompted to enter a 
starting point for the stamp outline.

4 Digitize split lines:
 Press Enter once to complete a boundary.
 Press Enter again to finish stamp digitizing.

5 Click the enabled Stamp button.
 Click the Stamp button to apply the stamp to selected applicable 

objects only.

 Alternatively, use Stamp to apply the stamp to applicable objects 
with no object/s selected. Every object beneath the stamp is 
affected.

Stamp applied 
with object/s 
selected

Stamp applied 
with no object/s 
selected
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 Click the Use Stamp button to position the stamp. You are 
prompted to enter an anchor point as with predefined patterns. 

6 Optionally, click the Add to Library button to add the selection to the 
library for future reference. 

Related topics...
 Apply predefined patterns
 Add stamps to a library

Add stamps to a library

This procedure starts when you click the enabled Add to Library button 
either on the Use Object tab or Digitize tab in the Carving Stamp 
docker.

Tip: The Carving Stamp feature can only use vector or embroidery 
objects as a basis for stamps. If you want to use a bitmap image, you can 
convert to vector format in CorelDRAW Graphics using the Bitmaps > 
Outline Trace command set.

To add a stamp to a library...
1 Select an object which you want to add to the library as a custom 

stamp.
 Digitize carving stamps on the spot using the Carving Stamp > 

Digitize tab.

Use Docker > Carving Stamp to define a pattern of needle penetrations 
using a ‘carving stamp’ as a template.
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 Define carving stamps using the Carving Stamp > Use Object 
tab. 

2 On either of these tabs, click the enabled Add to Library button. The 
Create Split Pattern dialog opens.

3 Select a set from the droplist or click the Create button to create a 
new library.
If you chose to create a new library set, use the New Pattern Set 
dialog to create a new stamp set. The newly created stamp set is 
displayed in the Set list when the Use Pattern tab is selected. 

4 Enter a new stamp name and click OK. You are prompted to digitize 
the first reference point in the design window.

5 Enter the first reference point:
 Press Enter to have the reference point created automatically.

Click to add
to library

Bitmap converted 
using Graphic mode 
Bitmaps > Outline 
Trace command

Select library set
from droplist

Enter name for
new stamp

Pattern 1

Enter name for
new library set

My Patterns
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 Move the mouse pointer to the position you want to use as the 
anchor point during manual stamp placement, and left-click.

6 Enter the second reference point:
 Press Enter to have the reference point created automatically.
 Move the mouse pointer to the position you want to use as the 

guide point during manual stamp placement and left-click.

7 Click OK. The newly created stamp is displayed in the stamp list when 
the Use Pattern tab is selected.

Note: The Rename and Delete buttons are enabled in the Use 
Patterns tab whenever a custom stamp is selected. 

Related topics...
 Digitize custom splits
 Use objects as carving stamps
 Apply predefined patterns

Carving stamp appearance

Enter first 
reference point

Enter second 
reference point

Use Docker > Carving Stamp to define a pattern of needle penetrations 
using a ‘carving stamp’ as a template.
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The Appearance tab of the Carving Stamp docker provides settings 
which can help to soften or intensify the effect. 

 Checking the Softened Stamp checkbox causes any existing stamp/s 
to be softened.

 Checking the Raised Stamp checkbox cause any splits within the 
combined closed boundaries of a carving stamp to be removed.

Note: Clicking the Clear All Stamps button will cause all existing 
stamps to be removed from selected objects.

Reshape carving stamps

Carving stamps can be moved, rotated, scaled, reshaped, and deleted 
individually in Reshape mode. As you transform carving stamps, needle 
penetrations in the underlying object are automatically updated. 

Appearance 
options

Unadjusted appearance Softened appearance Raised appearance

Use Reshape > Reshape Object to reshape selected objects by means of 
control points.

Use Reshape Views > Show Reshape Nodes to toggle reshape-node 
display when using the Reshape Object tool.
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To reshape a carving stamp...
 Select an embroidery object in Reshape mode with carving stamps 

applied. A diamond selection handle is displayed at the center of each 
stamp.

 Select the diamond selection handle. Another set of sizing, stretching 
and rotation handles appears.

 Drag the diamond to move the stamp. Holding down the Ctrl key will 
constrain the movement to the horizontal or vertical axis.

Click a diamond 
selection handle

Drag diamond



Chapter 21   Patterned St itching 518

 Drag a corner sizing handle to scale the stamp.

 Hold down the Shift key to scale stamp from the center.
 Hold down the Ctrl key to scale stamp proportionally. 
 Hold down both Ctrl and Shift keys while dragging a corner sizing 

handle to scale stamp proportionally about the center.
 Drag a stretching handle to stretch the stamp. Hold down the Shift 

key to stretch from the center.

 Drag the rotation handle to rotate the stamp.
 Click the stamp outline to display control points. Use these to reshape 

the stamp.

Drag corner 
sizing handle

Drag stretching 
handle

Drag rotation 
handle
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Chapter 22

Curved Stitching

EmbroideryStudio provides a variety of stitch types and techniques for 
creating curved stitching effects. These follow the contours of a shape 
and can be used to give a sense of depth and movement to your stitching. 
Some can be used with borders as well as fills.

Curved stitch effects covered in this section include:

Feature Overview

Contour Stitches follow the contours of a shape, creating a contoured, 
light and shade effect. 

Offset Similar to Contour in following the contours of a shape. It can 
be used in combination with turning stitches. 

Spiral Fill Works best with simple shapes without holes or islands. Use 
it with either fixed or variable length run stitching.

Radial Fill Generates radial turning stitching with various stitch types 
including satin, tatami and program splits.

Flexi Split Decorative effect where one or more lines of a program split 
pattern are molded to the object shape.

Florentine / 
Liquid

Create interesting curved effects by shaping needle 
penetrations to follow the contour of digitized lines.
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Contoured fills

Contour is a curved fill stitch type which can be applied to Column A/B 
or Circle/Ring objects. It can also be used for outline stitching. Stitches 
follow the contours of a shape, creating a contoured, light and shade 
effect. Use it to create a sense of movement in contrast to flatter fills 
created by tatami stitching.

Digitize contour fills

The Object Properties > Fills > Contour tab offers the following 
contour stitch options. There are three types of contour stitching which 

Use Outline Stitch Types > Contour to create outlines which follow object 
contours, creating a curved, light-and-shade effect. Right-click for settings.

Use Fill Stitch Types > Contour to create fills which follow object contours, 
creating a curved, light-and-shade effect. Right-click for settings.

Use Traditional Digitizing > Column A to create columns of varying width 
and stitch angle. Right-click for settings.

Use Traditional Digitizing > Column B to create asymmetrical columns of 
turning stitches, where opposite sides are different shapes. Right-click for 
settings.

Use Graphics Digitizing > Ellipse to digitize ellipse or circle embroidery 
objects.
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can be applied to most closed objects – Standard, Spiral and Even 
Density.

Standard contour

The number of stitch lines is constant, so stitching is denser where the 
shape narrows, and more open where the shape widens.

Spiral contour

Spiral is typically used for rings and borders, it is also suitable for other 
closed shapes.

Standard Lays rows of stitches back and forth along a shape, 
perpendicular to the digitized stitch angle. 

Spiral Creates a single, continuous line of stitching that spirals 
around to fill the shape.

Select contour 
type

Select backstitch 
type
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Spiral Contour can only be used with closed shapes with two outlines 
such as rings. If a shape is not properly closed, it will be filled with 
Standard Contour instead.

Tip: To fill a solid shape with Spiral Contour, create a closed object with 
a very small hole at the center. For example, to create a circle filled with 
Spiral Contour, digitize a thick ring with a very small inner boundary.

Even density contour

Even Density is ideally suited to shapes of variable width. Contour 
stitching follows the shape with uniform stitch density.

Caution: EmbroideryStudio may not generate even-density contour 
stitching in certain shapes. Stitching will revert to standard contour 
stitching.

Backstitch
The Backstitch panel offers a choice of two backstitch styles – Standard 
and Borderline.

Even 
Density Maintains even density across shapes which vary in width. 

Standard Even density

Standard

Borderline
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The term ‘backstitch’ refers to every second row of stitches in the fill. The 
choice depends on style – dense or less dense.

If spacing is small, Borderline backstitch will not be applied. This 
prevents damage to the fabric from too many small stitches.

Tip: When you digitize shapes with pointed ends – e.g. leaves, diamonds, 
stars – cut the ends to prevent the stitches from bunching.

Contour stitch settings

Adjust stitch length, spacing and offset fraction for Contour fills.

Backstitch Function

Standard
Creates backstitch rows that are slightly shorter than the 
forward rows, reducing small stitches. Suitable for high 
density fills.

Borderline Creates parallel backstitch rows to give a smooth, 
well-defined edge. Suitable for lower density fills.

Stitch bunching 
at sharp ends

Column B

Column B
1

2
3

4

8

7
6

5

1

2
3

4
5

10

98
7

6

Use Stitch Types > Outlines > Contour to create outlines which follow object 
contours, creating a curved, light-and-shade effect. Right-click for settings.

Use Stitch Types > Fills > Contour to create fills which follow object 
contours, creating a curved, light-and-shade effect. Right-click for settings.
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To adjust contour stitch settings
 Right-click the Contour icon to access object properties.

 The Spacing setting has the most conspicuous effect on contour fills. 
Use it to adjust between dense and more open fills. The spacing value 
sets the widest part of the shape. As the shape narrows, spacing 
decreases.

Adjust stitch 
values

Adjust offset 
fraction

Adjust variable 
stitch settings



EmbroideryStudio e4 Reference Manual 525

 While it has no conspicuous effect on fill appearance, the Length 
setting helps to distribute stitches evenly throughout the shape.

 The Offset Fraction controls the pattern of needle penetrations to 
achieve even distribution of stitches and prevent needle penetrations 
from forming unwanted lines. Try different settings to find the optimal 
distribution of needle points.

 Activate Vary Stitch Length as preferred. Stitch length is 
automatically adjusted on corners for more even curves. Settings are 
the same as simple run stitching.

Related topics...
 Digitizing methods
 Simple run stitching
 Tatami density

Optimal distribution

Variable ON Variable OFF
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 Stitch length settings

Offset fills

Offset Fill is similar to Contour in that it produces a curved fill stitch 
type which follows the contours of the shape. However, it can be applied 
to complex fill objects as well as turning stitch objects. It is fully editable 
in that it dynamically recalculates offsets as you reshape. Like Contour, 
it is best used for open fills with low stitch counts. Stitch angles have no 
effect on the fill pattern. 

When applied to shapes of varying width, Offset fill is similar to Contour 
> Even Density in producing an even distribution of needle 
penetrations, avoiding stitch bunching in narrower sections.

Use Fill Stitch Types > Offset Fill to create offset fill stitching in any closed 
shape.

Offset fill Contour even 
density fill
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Offset fill settings are similar to Contour fill. The Spacing setting has 
the most conspicuous effect for creating less or more open fills.

Related topics...
 Digitizing methods
 Maze fills
 Simple run stitching
 Tatami density
 Stitch length settings

Spiral fills

Use Spiral Fill to create open stitching that follows the contours of a 
shape. It is useful when trying to emphasize movement in your digitizing. 
It works best with simple shapes that can be stitched in a single segment 
without holes or islands. Use it with either fixed or variable length run 
stitching. With longer shapes, it may generate stitches that go outside 
the perimeter of the object, but this can provide for some interesting 
visual effects. Different stitch types can be used – sculpture, backstitch, 

Adjust stitch
values

Adjust variable
stitch settings

Use Fill Stitch Types > Spiral Fill to create spiral stitching from the center of 
any closed object.
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stemstitch, or run stitch. Similarly, basic spiral fills can be converted to 
outlines such as motif run, satin outline, sequin run, and bling run.

To create a spiral fill
 Create or select a closed shape and click Spiral Fill.

 To change settings, double-click or right-click the object to access 
object properties.

Note: Stitch angle has no effect on the pattern layout.
 Adjust spiral Stitch settings as desired:

Select stitch
type

Adjust spacing
and length

values
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 Adjust Stitch length for smoother or sharper curves.

 Adjust Stitch spacing for denser or more open stitching.

Note: If the object already has a hole, this is ignored when spiral is 
applied. It returns when other stitch types are applied.

Stitch length: 2.0 mm Stitch Length: 1.0 mm
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Tip: The center of the spiral can be reshaped or moved with the 
Reshape Object tool. Some interesting visual effects can be achieved. You 
can even move it outside the object outline.

Related topics...
 Digitizing methods 

Radial fills

Radial Fill creates radial turning stitching in either Satin, Tatami or 
Program Split objects. Stitches are generated from the outside edge to 
the geometric center. The center can be shifted. The effect may be on or 
off while digitizing. Operations such as Mirror Merge or Remove 
Overlaps preserve the effect.

Use Stitch Effects > Radial Fill to create radial turning stitching with various 
stitch types including satin, tatami and program splits. Can be applied to 
ring shapes. 

Click Reshape > Reshape Object to view the reshape nodes of a selected 
object.
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To create a radial fill
 Select a closed-object and click the Radial Fill icon.

 To modify, select and click Reshape Object. In Reshape mode, you 
can:
 Move the center point of the radial stitching.
 Set the size of the center hole.
 Edit the hole shape for circle/ellipse.

 Alternatively, hole properties can be changed via Object 
Properties.

Tip: Like Spiral Fill stitch, the center of Radial Fill effect can be 
moved outside the shape or into an included hole to achieve a different 
effect, without losing the original shape.

Adjust hole 
dimensions
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 Optionally, apply Satin, Program Split and/or Jagged Edge 
together with Radial Fill.

 Press Enter to apply, Esc to finish.

Note: You are not able to directly edit stitch angles generated by 
Radial Fill. But you can apply Break Apart and edit the resulting 
turning angle closed object. See also Break apart composite objects.

Tips for use...
Not all patterns and stitch settings or objects (size specific) are suitable 
for Radial Fill. In particular, if you are using it with larger objects, use 
one or a combination of the following to avoid bunching at the center:
 Increase the size of the hole, move the center into an existing hole in 

the object, or move it outside the object altogether.
 Add Jagged Edge to the inside.
 Use larger stitch spacing – increase by about 20%.
 Avoid patterns which add needle penetrations close to the center of 

the object.
 Use Edge Run underlay with smaller objects, to help reduce the 

number of stitches at the object center.
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 Radial Fill can be applied to ring shapes. The center of the radial 
effect will lie within the hole of the ring. Use Reshape to adjust as 
necessary.

Flexi-splits

Flexi Split is a decorative effect where one or more lines of a program 
split pattern are used in the object fill. It is both a patterned and curved 
fill. The pattern follows the stitch angle and may be scaled to fit the width 
of the object. It is intended for use with objects with turning stitches or 
varying column width. You can apply Flexi Split to a wide variety of 
object and stitch types. Use existing patterns or create your own.

To apply the Flexi Split
 Select an object and click the Flexi Split icon. 

Use Stitch Effects > Flexi Split to create decorative split patterns following 
stitch angles and scaled according to object width. Right-click for settings.
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 Right-click to access properties.

 Select a pattern from the droplist. Alternatively, click the arrow button 
to access the pattern library.

 Select one of four options.

Pattern preview

Click to expand
pattern list

Select Flexi Split

Click to select 
pattern

Select pattern

Select Flexi Split 
option
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 Adjust Flexi Split settings to vary size, shape indent, spacing and 
pattern offsets.

 In the Size X and Size Y fields, enter dimensions of the largest 
pattern in the effect. The scaling lock maintains aspect ratio.

 In the Indent field, enter the distance between the first pattern and 
the first stitch line.

 In the Column panel, enter spacing and offset settings as required:

 If you selected an option that uses more than one row of patterns, the 
fields in the Row panel are available.

Related topics...
 Make split patterns

Enter distance between 
first pattern and first 
stitch line

Enter dimensions of
largest pattern

Enter spacing
and offsets

Indent: 2 mmDefault indent values Indent: 4 mm

Default column values  Column spacing decreased Column offset value changed

Default column and 
row values

Column and row 
spacing decreased

Row offset value 
changed
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Curved fills

To create a flowing stitch effect, apply Florentine Effect. Stitches follow 
a digitized line but maintain uniform density and needle penetrations. 
Liquid Effect is similar to Florentine Effect except that you enter twin 
guidelines for stitches to follow.

Create curved fills with Florentine Effect

While you can apply Florentine Effect to any closed shape, it is 
generally used in conjunction with Complex Fill or Close Shape input 
methods. This is because Florentine Effect overrides any stitch angles 
already applying. You can apply the effect while digitizing or to existing 
objects.

Use Traditional Digitizing > Complex Fill to digitize filled shapes with a 
single stitch angle. Right-click for settings.

Use Graphics Digitizing > Digitize Closed Shape to digitize closed shapes. 
Press <Ctrl> to create a square.

Use Stitch Effects > Florentine Effect to create custom curved stitching.

Use Reshape > Reshape Object to adjust control points of the guideline.
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To create a curved fill with Florentine Effect
 Choose an input method and a suitable stitch type. Florentine Effect 

works well with satin, tatami, or even program splits. 
 Click the Florentine Effect icon.
 Digitize boundaries and entry and exit points of the object following 

the prompts.
 Digitize the guideline you want stitches to follow and press Enter. The 

guideline must intersect both sides of the object, have at least three 
points, and must not overlap itself. Curves generally give better 
results than sharp corners.

 Use the Reshape Object tool to modify the guideline.

Tips for use...
 For best results, use smaller stitch lengths – e.g. 4.00 mm or less.
 With satin stitch, turn off auto-splits.
 Curved fill effects work better with open stitching.
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 They can also work well with Accordion Spacing.

Related topics...
 Digitizing Shapes
 Stitch Types
 Contoured fills
 Accordion spacing
 Apply curved fills to existing objects
 Reshaping embroidery objects

Create curved fills with Liquid Effect

Liquid Effect works the same ways Florentine Effect except that you 
enter twin guidelines. Turning stitches are distributed evenly between 
guidelines to produce smooth curves. Liquid Effect guidelines are 

Use Traditional Digitizing > Complex Fill to digitize filled shapes with a 
single stitch angle. Right-click for settings.

Use Graphics Digitizing > Digitize Closed Shape to digitize closed shapes. 
Press <Ctrl> to create a square.

Use Stitch Effects > Liquid Effect to create curved stitch effects with two 
guidelines.

Use Reshape > Reshape Object to adjust control points of the guideline.
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digitized outside the object, rather than over. While you can apply the 
effect to any closed shape, it overrides any existing stitch angles.

To create a curved fill with Liquid Effect
1 Choose a suitable input method and stitch type, and click Liquid 

Effect.
2 Digitize outline, entry and exit points following the prompts. You are 

not prompted to digitize a stitch angle.
3 Digitize the first guideline around the outside of the object. You must 

enter at least three reference points.

4 Press Enter. You are prompted to enter a second guideline. Elastic 
lines appear joining the two guidelines.

5 Digitize the second in the same direction as the first, marking at least 
three reference points.

Note: The two guidelines must not overlap or intersect the object 
outline.

Guideline 1
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6 Press Enter to apply.

Tip: Use the Reshape Object tool to modify guidelines.

Related topics...
 Digitizing Shapes
 Stitch Types
 Reshaping embroidery objects

Adjust curved fill settings

Guideline 1

Guideline 2

Right-click Stitch Effects > Florentine Effect to adjust settings.

Right-click Stitch Effects > Liquid Effect to adjust settings.
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In a curved fill, stitch lengths vary to map the needle point pattern to the 
curve. You choose between Nominal and Maximum stitch length 
calculation.

To adjust curved fill settings
 Right-click a Florentine Effect or Liquid Effect icon to access object 

properties.

 Select a preferred stitch length calculation:

Apply curved fills to existing objects

Option Function

Nominal Average length of fill stitches matches the current Stitch Length 
setting. This generates roughly the same number of fill stitches as 
with normal stitching. 

Max Longest stitch matches the Stitch Length setting. This generally 
produces smoother curves than Nominal, but the stitch count is 
higher. Use Max when the curve is tight with respect to the stitch 
length.

Nominal

Maximum

Select Florentine 
Effect

Use Stitch Effects > Florentine Effect to apply curve stitching to existing 
objects.

Use Stitch Effects > Liquid Effect to apply curve stitching to existing objects.
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Apply Florentine Effect to existing complex fill objects. The effect can 
also be applied to Column A/B objects. You can also apply Liquid Effect 
to existing objects.

To apply a curved fill to an existing object
1 Select an object and select a curve fill method.
2 With the object still selected, click the Reshape Object icon. A default 

guideline with three corner control points appears.

3 Reshape guidelines in the normal way by moving, adding, changing or 
deleting reference points.

4 Press Enter. EmbroideryStudio regenerates stitches along the new 
curve. 

5 Turn on TrueView™ or click the Show Needle Points icon to view the 
results.

Related topics...
 Reshaping embroidery objects

Apply curved lines to multiple objects

You can apply Florentine Effect or Liquid Effect to multiple objects in 
a design. All objects share the same curved line.

Use Reshape > Reshape Object to adjust control points of the guideline.

Use Outline > Digitize Run to place a row of single or triple run stitches 
along a digitized line.

Use Stitch Effects > Florentine Effect to apply curve stitching to existing 
objects.

Use Stitch Effects > Liquid Effect to apply curve stitching to existing objects.
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To apply a curved line to multiple objects
1 Using the Digitize Run tool, digitize a guideline for the curve to 

follow. Digitize a second line if you want to apply Liquid Effect.

2 With the guideline selected, select Object > Use for Florentine 
Effect. This tags the digitized run as the default curve line.

Tip: With two guidelines selected, the Object > Use for Liquid 
Effect command becomes available.

3 Select an object and click the Florentine Effect icon. Notice that the 
turning stitches follow the guideline.

4 Apply to the other objects in the same way. Notice that the turning 
stitches again follow the original guideline.

5 Press Esc to complete. Optionally, delete the original run object if not 
required as part of the design.
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Tip: Turn on TrueView™ or use the Show Needle Points tool to view 
the results.

Related topics...
 Digitizing outlines & details
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Chapter 23

Motif Stitching

Motifs are predefined design 
elements, such as hearts, leaves or 
border patterns. They generally 
consist of one or more simple 
objects, and are stored in special 
motif sets. 
Motifs can be used for ornamental 
outlines and patterned fills or even on 
their own. Motifs can be scaled, 
rotated and mirrored in the same way 
as other objects. You can even use 
them to create interesting three 
dimensional effects.
Whether using them in runs, fills, or 
individually, motifs can be selected 
from predefined motif sets. Other ornament types can be used as motifs. 
You can even define your own, including motifs derived from cross 
stitching.

Selecting & placing motifs

Use Outline Stitch Types > Motif Run to create a string of motifs along a 
digitized line.

Use Fill Stitch Types > Motif Fill to create decorative fills using embroidery 
motifs to form repeating patterns. Right-click for settings.

Use Traditional Digitizing > Use Motif to add motifs to design one-by-one. 
Rotate, scale, or mirror as you add.
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You select motifs for use in runs, fills, or individually, via the Object 
Properties docker.

Motifs are commonly used in decorative outlines or open fills. However, 
you can add them to your design one-by-one. Rotate, scale, or mirror 
them as you add or edit them like any other object.

To select a motif
 Right-click the Motif Run icon to access object properties.

 Select a motif set from the droplist. There are two sets specific to 
motifs – single or two-part. However, you can use any other available 
set.

Select motif 
set

Single or 
two-part sets
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 Select a pattern from the droplist. Alternatively, click the arrow button 
to access the motif library.

 Select Use Motif. A motif outline appears attached to the mouse 
pointer.

 Click to mark an anchor point.

 Drag the mouse to rotate, scale, or mirror:
 To rotate, move the pointer then click again.

 To mirror the motif, right-click.

Select motif
from library

Motif preview

Select motif from 
droplist or click 
arrow to open library

Click to mark
anchor point

Click to mark 
guide point

Motif rotated

Motif rotated 
and mirrored

Right-click to mark 
guide point and 
mirror motif
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 To scale the motif, press Shift, move the pointer, then click again.

 Repeat as required. Stitches are generated automatically.

 Alternatively, press Enter to accept default position and settings.
 Press Esc to finish.

Tip: You can create motifs from patterns made in ES Cross Stitch 
and use them to create a cross stitch sampler. See Cross Stitch 
Supplement for details.

Related topics...
 Motif runs
 Motif fills

Hold down Ctrl to constrain 
rotation angles

Motif rotated 
and scaled

Hold down Shift to 
resize the motif

Insert anchor 
point

Insert guide 
point

Repeat as 
required

Motifs created 
from cross 
stitching
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Motif runs

Motif Run is a stitch type that forms repeated motifs along a digitized 
line. It is typically used for decorative borders or special effects.

Digitize motif runs

Motif runs can be digitized as open or closed objects with graphical or 
traditional digitizing tools. Pretty much any digitizing tool can be used, 
including Freehand. Motif runs have some different properties to other 
decorative outline stitches. You can modify rotation angle, orientation 
and scale, and vary motif spacing.

To digitize motif runs
 Double-click or right-click the Motif Run icon to access object 

properties and select the motif you require.

Use Outline Stitch Types > Motif Run to create a string of motifs along a 
digitized line.

Use Graphics Digitizing > Digitize Open Shape to digitize open shapes.

Use Graphics Digitizing > Digitize Closed Shape to digitize closed shapes.

Use Outlines > Motif Run to place a row of motifs along a digitized line.
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 Select a motif set and the motif you want to use.

Tip: Select a motif with no object selected and click Apply to make 
the selection current. Use it with the Use Motif tool.

 Select a digitizing tool such as Digitize Open Shape or Digitize 
Closed Shape to create a string of motifs along a digitized line:

 To use default size and orientation, press Enter.
 Use the Size fields to adjust motif dimensions. The scaling lock 

maintains aspect ratio.

Select motif

Motif run
preview

Enter motif 
dimensions

Enter spacing 
between repeats

Choose whether to 
keep or omit first and 
last motifs

Original outline Scaled in X Scaled in Y
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 Use the Spacing field to control repeat distance.

 Optionally, use the Reverse Curves command in the popup menu to 
change motif orientation.

 Choose whether to keep or omit first and last motifs to avoid overlaps.

 Press Enter or click Apply.

SpacingInitial spacing

First and last 
motifs kept

First motif kept, 
last motif 
omitted
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Create graded motif runs

In some products, size and spacing settings allow you to automatically 
grade motif size and spacing in motif runs from a specified starting size 
to finishing size.

Options include:
 Grade motif size proportionally or maintain constant size.
 Grade motif spacing proportionally or maintain constant spacing.
 Vary motif size and spacing on tight curves. This option automatically 

reduces motif size and spacing in proportion to the sharpness of the 

Select grading
option

Set starting
size
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curve, similar to variable run stitch length. Also similar, the ‘chord 
length’ setting controls how closely motifs follow the curve.

Reshape motif runs

Motif runs can be reshaped like other embroidery object, but special 
control points are provided.

To reshape a motif run
 Select a motif run object and click the Reshape Object icon. Control 

points appear around the motifs.

Vary motif size and
spacing on tight

curves

Use Reshape > Reshape Object to reshape selected motif run objects.
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 Adjust object size like any other object using sizing handles.

 Click the diamond control point of a motif to activate reshape nodes. 
Use these to fine-tune individual motifs. Each one can be rotated, 
skewed, or resized respectively.

Note: A ‘Regenerate motif run’ checkbox forces the system to 
regenerate motif runs based on current settings whenever an object 
is scaled or skewed. When left unchecked, the system will not 

Click and drag handles
to resize and reshape

whole object

Click and drag 
sizing handle

Click to activate 
reshape nodes

Click and drag control 
handles to reshape 
individual motifs
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re-generate and the number of motifs will remain unchanged after the 
transformation.

 Press Esc to finish.

Related topics...
 Reshaping Objects

Motif fills

Motif Fill is a decorative stitch used for 
filling closed objects. This feature 
repeats motifs in parallel rows to fill the 
shape. It is generally used for open 
stitching and special effects. 
Alternatively, it can be layered over top 
of solid stitching backgrounds. You can 
select different motifs for forward and 
backward rows. You can create motif 
layouts onscreen or via object 
properties. Auto Underlay is 
deactivated with motif fills and stitch 
angle has no effect.

Digitize motif fills

Regenerate after
transformation

Motif run regenerated 
– motif size and 
spacing maintained

Use Fill Stitch Types > Motif Fill to create decorative fills using embroidery 
motifs to form repeating patterns. Right-click for settings.

Use Traditional Digitizing > Complex Fill to digitize filled shapes with a 
single stitch angle. Right-click for settings.
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Digitize closed objects with Motif Fill or apply it to existing objects. 
Pretty much any closed digitizing tool can be used, including Freehand 
Closed Shape. Stitch angles are ignored. Select from a wide range of 
motifs. Mix and match different motifs for forward and backward rows, or 
use the same motif for each. There is a special Two-Part Motifs set 
which contains complementary paired motifs.

To digitize a motif fill
 Click Motif Fill and select a closed digitizing tool.
 Double-click the object or right-click the Motif Fill icon to access 

object properties.

 In the Motif 1 panel, select a motif set and pattern from the library. 
For single rows, use the Single Motifs set. You can also use 
monogram ornaments or even define your own sets. 

 If you want different motifs for forward and backward rows, select the 
Motif 2 checkbox. For best results, use the Two-Part Motifs set for 
both.

Select motif set to 
select from for forward 
row

Select motif set to 
select from for 
backward row

Select motif for
forward row

Select motif for
backward row



EmbroideryStudio e4 Reference Manual 557

 In the Motif 2 panel, select a complementary motif. The predefined 
two-part motif set is specially designed to provide complementary 
motifs for forward and backward rows – e.g. ‘Duet01a’ and ‘Duet01b’.

Tip: As an alternative, you can generate layers of colored motifs by 
duplicating an object and selecting a different color and/or motif.

Related topics...
 Motif scaling

Motif fill settings

You can adjust motif fills both interactively on screen and via object 
properties.

Spacing & offsets
You can adjust the exact row, column and spacing settings for motif fills. 
The default settings define a simple grid where the spacing equals the 

Use Fill Stitch Types > Motif Fill to create decorative fills using embroidery 
motifs to form repeating patterns. Right-click for settings.
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motif dimensions. The row offset is set to 0.00 mm so columns and rows 
are perpendicular.

 To adjust spacing and offset settings, open the Object Properties > 
Fills > Motif Fill dialog.

 Adjust column and row spacing as well as row offsets.

 Select the Scale to fit grid checkbox to scale motifs to exactly fit the 
grid squares.

 Select the Clip to fit shape checkbox to clip motifs that do not fit the 
shape.

Scale and clip motifs 
to fit shape

Enter column 
spacing

Enter row spacing 
and offset 
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Motif scaling
You can set the exact size of motifs in a fill. You can also scale Motif 1 
and Motif 2 motifs independently. Adjust Size controls in the Object 
Properties > Fills > Motif Fill dialog.

Motif rotation
The rotation angle defines the orientation of the entire motif fill pattern. 
It overrides the stitch angle you set when digitizing the shape with 
Complex Fill. Enter a rotation angle in the Object Properties docker.

Lay out motif fills on-screen

Lay out motif fills on-screen in a similar way to program splits by using 
‘guide motifs’ to scale, space, transform and offset the entire fill. There 

Use Fill Stitch Types > Motif Fill to create decorative fills using embroidery 
motifs to form repeating patterns. Right-click for settings.
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are three blue guide motifs. Each guide motif lets you change a different 
element of the layout. Stitch angle has no effect on motif layouts.

Generally you define a layout before digitizing. If it is important to align 
motifs with the object boundary, digitize the object using current 
settings, and change the layout afterwards.

To lay out motif fills on-screen
1 Right-click the Motif Fill icon to access object properties.

2 Select a motif set and motif and click Layout. Sample and guide 
motifs appear in the design window. Zoom in to select the correct 
guide motif.

3 Adjust the guide motifs to achieve the effect you require:
 Move motifs by selecting the middle guide motif and dragging it to 

a new position.

Click to lay out 
selected motif

Use top guide motif to change row 
spacing, row offset, and to scale motifs

Use side guide motif to change 
column spacing, and to scale motifs

Use middle guide motif to
move, rotate, skew, and

scale motifs
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 Scale motifs by selecting a guide motif and resizing it using the 
selection handles.

 Rotate motifs by clicking the middle guide twice to display the 
rotation handles. Click a corner handle and drag to rotate. 

 Skew motifs by clicking the middle guide twice, then dragging the 
skew handles. 

 Change column spacing by selecting the side guide and dragging it 
left or right.

 Change row spacing by selecting the top guide and dragging it up 
or down.

Scale
proportionally

Scale 
horizontally

Scale 
vertically

Rotate

Skew

Anchor

Change column 
spacing
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 Change row offset by selecting the top guide and dragging it left or 
right.

Note: Motif Fill does not have a column offset since motifs are 
connected along each row. Instead you can rotate the layout to 
achieve a similar effect. 

4 Press Esc to finish. The size and layout settings you select become 
current settings.

Tip: To revert to the original factory settings, run the Revert utility. 
Alternatively, enter the values manually in the Object Properties > 
Fills > Motif Fill and click Save.

Related topics...
 Lay out program splits on-screen

Enveloped motif fills

EmbroideryStudio provides techniques for ‘sculpting’ motif fills to create 
three dimensional effects. Create graded columns of motif stitching. Or 
make motif fills appear concave or convex. You can also create 
perspective effects.

Change row 
spacing

Change 
offset
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Tip: Small stitches may be generated along the edge of objects 
employing these effects. You can remove these automatically. See 
Eliminating small stitches for details.

Create graded motif columns

The Motif Column feature allows you to create graded columns of motif 
stitching. Motifs dynamically resize to fit varying widths. Similar in 
concept to flexi-split with turning satin, you digitize a tapering shape 
using, for example, Column A. Apply Motif Column and select a motif. 
Motifs are automatically ‘enveloped’ to fit to the shape.

Right-clicking the Motif Column tool opens the Object Properties 
docker with its dedicated Motif Column fill stitch settings. Choose motifs 

Use Fill Stitch Types > Motif Column to place motifs along the center line of 
a column shape and resize to fit the shape. Right-clicking for settings.
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from any one of the available libraries. Mirror motifs around their own 
axis internal to the shape.

Choose between proportional or fixed spacings. Fixed spacing maintains 
constant motif width throughout the shape.

Caution: Stitches are ungenerated when branching two Column A 
objects together with Motif Column.

Create convex & concave effects

Motif Column settings 
for proportional or fixed 
spacings

Mirror motifs 
internal to the 
shape

Fixed spacing locks width
(size x) throughout

Proportional spacing scales
entire motif throughout

Click Stitch Effects > 3D Warp to apply 3D effects to selected motif fills. 
Right-click to change settings.
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Using Globe In with 3D Warp gives a concave effect by increasing motif 
size and spacing around a center point. Globe Out gives a convex effect 
by decreasing motif size and spacing. You can apply the effect to an 
entire object, or to a specified part of the fill.

To create convex and concave effects
 Select a motif fill object and right-click the 3D Warp icon. The Object 

Properties > Curve docker opens.

 Select the 3D Warp checkbox, and select Globe In or Globe Out 
from the list.

 Press Enter or click Apply. The Globe In or Out effect is applied to 
the selected object.

Use Reshape > Reshape Object to reshape selected 3D Warp objects.

Select 3D Warp

Select Globe In or 
Globe Out

Globe In appliedComplex FIll object 
with Motif Fill

Globe Out applied

OR
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 To make further adjustments, click Reshape Object with the object 
selected. A guide frame appears with three control points.

 Adjust the control points to:
 Change frame height 
 Change frame width
 Reposition frame.

Tip: You can generate layers of colored motifs by duplicating an object 
and selecting a different color. For example, after filling a shape with 
circles, you can create a second layer, offset it, and apply a different 
color. You can then apply effects such as Globe Out to the whole motif 
fill.

Create perspective effects

Click-and-drag to 
reposition frame

Click-and-drag 
control point

Click Stitch Effects > 3D Warp to apply 3D effects to selected motif fills. 
Right-click to change settings.

Use Reshape > Reshape Object to reshape selected 3D Warp objects.
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Use Perspective with 3D Warp to create a perspective effect by 
exaggerating relative sizes.

To create perspective effects
 Select a motif fill object and right-click the 3D Warp icon. The Object 

Properties > Curve docker opens.

 Select the 3D Warp checkbox, and select Perspective from the list.
 Press Enter or click Apply.
 Click the Reshape icon. A guide frame appears around the object.

 Adjust the frame to move the guidelines closer together or further 
apart.

 Press Enter or click Apply.

Note: The guide frame must not cross the outer boundary of the 
shape, and cannot be inside the shape.

Select 3D Warp

Select Perspective

Select object and 
click Reshape

Adjust frame and 
press Enter
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Custom motifs

EmbroideryStudio provides a function for creating custom motifs for use 
in motif runs and fills, or as individual motif placements.

Tip: A motif may include color changes, trims, and even different stitch 
types. However, remember that whenever used in a motif run or fill, each 
motif must be stitched individually in sequence. Optionally, they may be 
broken apart and manually resequenced.

Create & save motifs

The Create Motif function lets you save your own motifs for future use. 
Custom motifs are saved in custom ‘motif sets’. 

To create and save a motif
1 Create or choose the object you want to save as a motif. This may be 

an outline or a filled object.

2 Adjust stitch angles as required, and turn off any underlays.
3 Scale to a suitable nominal size for practical use – e.g. 5-10 mm. Bear 

in mind that motif size can be adjusted within the run or fill.
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4 Duplicate and align the motif as you want it to appear in a motif run. 
Use Alignment tools for precise arrangement.

5 Once you have determined the layout, select objects and apply 
Closest Join. Use the middle motif to determine reference points.

6 Select the motif and choose Object > Create Motif.

7 Select a custom motif set from the droplist and enter a name in the 
Motif Name field.
 Optionally, click Create. The Create Motif Set dialog opens.

 Enter a name for the new motif set and click OK. The Motif Set is 
ready for use. Motif sets are stored in the program folder 
...\Userletw.

Determine nominal 
layout

Entry and exit points should 
align with reference points

Select motif set

Enter motif name

Remove or include
machine functions

My First Motif

My Motifs

Enter name for 
custom motif setMy Motifs
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8 Choose how to handle any included machine functions:
 If you have created a multi-color motif, untick the Remove color 

changes option. This ensures that color changes are preserved.
 If you have created a motif with explicit trims, untick the Remove 

other functions option. This ensures that trims are preserved.
9 Click OK.
10 Click two reference points for the motif. These should coincide with 

entry and exit points.
 Reference points determine default motif orientation. They also 

determine default spacing between motifs.

 With individual motifs, reference point 1 becomes the anchor point. 
Reference point 2 becomes the rotation point.

Reference point 1

Reference point 2Reference point 1

Reference point 2

Rotation direction
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11 Click OK. The motif is ready for use. Check to make sure connectors 
align with the direction of travel.

Manage custom motifs

Manage your custom motif sets via the Manage Motifs command.

To manage custom motifs
 Select the Setup > Manage Motifs command. The dialog opens.

 Select the motif set you want to modify from the droplist.
 Select a motif from the Motif group.
 Use the Rename and Delete buttons to modify as required.

Connectors aligned with
direction of travel

Connectors not aligned with 
direction of travel

Modify motif set

Modify selected 
motif

My Motifs

Motif 1
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Chapter 24

Specialty Stitching

EmbroideryStudio provides many specialty effects and stitch types to 
create artistic fills. These can be used to create more organic, naturalistic 
stitching. They can be used to create textures like feathers or wool. Use 
them to create open stitching with low stitch counts.

Specialty stitch effects covered in this section include:

Feature Overview

Freehand
Create designs with a hand-drawn appearance, something 
which is difficult to achieve through conventional digitizing 
methods.

Hand Stitch Create hand-stitch effects which combine randomized stitch 
length, angle and count.

Jagged 
Edge

Create rough edges, shading effects, or imitate fur and other 
fluffy textures. 

Stipple Create textured fills of run stitching which meanders more or 
less randomly within a border.
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Freehand embroidery

The Freehand feature provides 
functionality similar to 
CorelDRAW® Graphics Suite 
Freehand and Polyline tools. 
Freehand has many benefits. It 
lets you create designs with a 
hand-drawn appearance, 
something which is difficult to 
achieve through conventional 
digitizing methods. The aim is to 
mimic the fluid and free-flowing 
effects formed by means of 
freehand stitching techniques.

Freehand stitching techniques

Maze Fill Create maze-like stitching which follows object contours for 
open fills.

String Create craftstitch fills as well as delicate borders. Can be used 
as a border for fixing ornamental mirrors and sequins.

Zigzag Create fills or open borders or columns of even width for an 
open ‘sawtooth’ effect.

E Stitch Create fills or open borders or columns of even width for an 
open ‘comb’ effect. 

Trapunto Move internal travel runs to the edges of an object so that they 
can’t be seen through open stitching.

Accordion 
Spacing

Vary stitch spacing between dense and open fill, producing 
gradient and shading effects. 

Color 
Blending

Create color blends where two colors are merged from one to 
another using a mixture of dense and open fill.

Chenille Utilize stitch patterns traditionally associated with chenille 
work – Square, Double Square, Coil, and Island Coil.

Cross 
Stitch

Fill large areas with cross stitching on an invisible grid that 
applies to all design objects.

Feature Overview

Use Graphics Digitizing > Freehand Open Shape to draw ‘freehand’ 
outlines on screen.
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Any of the outline stitch types can be used with Freehand open and 
closed curves. When Open Shape is selected, the Stitch Types toolbars 
offer a choice of Run, Triple Run, and other outline stitch types. When the 
Closed Shape tool is selected, the toolbar offers the full range of stitch 
types, both outline and fill. In addition, an ancillary Freehand 
Smoothing toolbar gives you control over freehand lines.

The possibilities offered by these options for creative, artistic expression 
are limitless. Especially when used with stylus pen tablets. Techniques 
include stitching on top of photographic images or detailed line drawings.

Alternatively, designs resembling pencil or charcoal sketches can be 
digitized. Use the tools to create ‘doodle’ type drawing effects without 
following detailed artwork – for example, adding to a basic clipart design 
or decorative text and so on.

Related topics...
 Set angles & orientation

Use Graphics Digitizing > Freehand Closed Shape to draw ‘freehand’ 
closed objects on screen.



EmbroideryStudio e4 Reference Manual 575

Create freehand lines

Accessed from the Graphics Digitizing 
toolbar, the freehand feature is deployed in 
two forms: ‘Open Shape’ and ‘Closed Shape’. 
As with other digitizing tools, freehand tools 
can be used in conjunction with all stitch 
types. With these tools, however, you draw 
objects directly onscreen. It is thus possible 
to produce artistic effects similar to 
free-motion machine embroidery or ‘thread 
painting’.

Tip: The Embroidery tools can be operated 
with a mouse or WACOM pen.

To create freehand lines
 When digitizing with the Freehand tools, the Auto Scroll option 

needs to be turned off. Use the Ctrl+Shift+A key combination to 
toggle on/off.

 Create open outlines with the Freehand Open Shape tool. Select any 
outline stitch and click and drag to draw. Release to finish.

 Try creating embroidered calligraphy by combining the Freehand 
Open Shape tool with Column C angle and orientation controls.

Use Graphics Digitizing > Freehand Open Shape to draw ‘freehand’ 
outlines on screen.

Use Graphics Digitizing > Freehand Closed Shape to draw ‘freehand’ 
closed objects on screen.
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 To create closed outlines, use the Freehand Closed Shape tool in 
conjunction with an outline stitch.

 To create closed fills, use the Freehand Closed Shape tool in 
conjunction with a fill stitch.

 If you want to close an open object, use the Edit > Close Curve 
with... command with the option of using straight or curved points.

Related topics...
 Scroll options
 Set angles & orientation

Adjust freehand line smoothness

Open object
Close Curve 
with Curve Line

Close Curve with 
Straight Line

Use Graphics Digitizing > Freehand Open Shape to draw ‘freehand’ 
outlines on screen.

Use Graphics Digitizing > Freehand Closed Shape to draw ‘freehand’ 
closed objects on screen.
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The Freehand tools have a special cursor. Adjust settings via the 
Freehand Smoothing toolbar. Also adjust curve ‘smoothing’ as you 
digitize.

To adjust freehand line smoothness
 Create a freehand design using outline and/or filled objects. The 

Freehand Smoothing toolbar opens.

 Adjust the freehand cursor as required:

 Adjust freehand line ‘smoothness’ by means of the slider bar. This 
controls the number of control points generated. Alternatively, adjust 
smoothing by means of the percentage value.

 View and edit Freehand control points in Reshape mode.

Tool Function

Use to toggle on/off freehand guide cursor.

Use to set the size of the inner circle in millimeters.

Use to set the number of circles in the cursor. If the inner circle 
radius is 2mm, each additional guide circle is offset by 2mm.

No smoothing With smoothing

No smoothing With smoothing
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 If you want to erase a portion of a line, press and hold the Shift key 
while dragging backward over the line before releasing the mouse.

 Alternatively, press the Backspace key. The last point digitized is 
removed.

 Release the mouse to finish the outline at the last point digitized. Or 
press Esc to cancel input of the object.

Note: Objects created using the Freehand tools can be reshaped in 
the same way as objects created via conventional methods.

Related topics...
 Create freehand lines
 Reshaping embroidery objects

Organic stitching

EmbroideryStudio provides tools for creating more natural, ‘organic’ 
stitching styles with the Hand Stitch and Jagged Edge effects. These 
can be applied to satin, tatami, run, backstitch, and other stitch types, to 
imitate hand stitching as well as imitate fur and other fluffy textures. 
String stitch type is ideally suited to creating craftstitch fills as well as 
delicate borders.

Hold the Shift key 
and drag back
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Hand stitch effect

Fashion trends sometimes favor a more organic look which is very hard 
to achieve with normal design tools. With Hand Stitch, you can create 
effects which combine randomized stitch length, angle and count.

To apply hand stitch effect
1 Choose the object you want to apply the effect to or toggle on Hand 

Stitch effect before you start digitizing. It can be applied to satin, 
tatami, run, backstitch, and other stitch types.

2 Click the Hand Stitch icon. The effect is applied based on current 
settings.

Use Stitch Effects > Hand Stitch to create hand-stitch effects which 
combine randomized stitch length, angle and count. Can be applied to 
satin, tatami, run, backstitch, and other stitch types.
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3 Right-click the Hand Stitch icon to access object properties.

4 Adjust stitch roughness settings to diminish or exaggerate the effect:
 In the Length field, enter a value between 0 and 5 to set 

stitch-length variation. ‘0’ indicates that no change is applied to 
current stitch settings.

 In the Angle field, enter a value between 0 and 5 to set stitch-angle 
variation.

5 Adjust stitch mass settings to diminish or exaggerate stitch mass:

Adjust 
roughness

Select Hand 
stitch effect

Adjust stitch 
density or ‘mass’

Length: 0 Length: 3 Length: 5

Angle: 0 Angle: 3 Angle: 5
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 In the Count field, select a multiplication factor to increase 
hand-stitch density.

 In the Random field, select a value between 1 and 5 to set a 
random factor for the stitch count. The system randomly adds or 
sometimes removes stitches when Count > 1x, usually resulting in 
increased stitch mass. (When count is 1x, no stitches are removed 
but some are added.)

6 Optionally, in the Variant field, enter a value between 1 and 10 to 
experiment with variants of the same roughness and mass settings.

Tip: Make any further adjustments necessary to the underlying stitch 
type. For instance, when using Satin stitch, you may want to increase 
stitch spacing as well as use a lighter underlay.

Count: 1x Count: 3x Count: 5x

Random: 0 Random: 3 Random: 5

Variant: 1 Variant: 6 Variant: 10
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Tips for use...
 For hand-stitching, embroiderers tend to use ‘long & short’ satin 

stitching or contoured runs to fill a large area. This is the effect we are 
aiming for.

 When used with satin stitching, Hand Stitch effect works best with 
Auto Split turned off. However, when used with higher stitch 
roughness ‘length’ settings, jump stitches are sometimes generated 
as this setting affects stitch length.

 For smaller objects, turn off underlay.
 More stitch spacing is needed for higher stitch counts to avoid stitch 

bunching.
 Tatami fill is not so well suited for use with Hand Stitch effect. If you 

want to use it, try using a random factor to eliminate split-line 
patterns.

Related topics...
 Stitch Types
 Digitizing Shapes
 Satin stitching
 Stabilizing with automatic underlay
 Create random patterns

Jagged edges

Use Stitch Effects > Jagged Edge to create rough edges, shading effects, 
or imitate fur and other fluffy textures along one or more sides of selected 
objects.
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Use Jagged Edge to create rough edges, shading effects, or imitate fur 
and other fluffy textures.

To apply Jagged Edge
 Choose the object you want to apply the effect to or toggle on before 

you start digitizing. It can be applied to satin or tatami fills with or 
without program splits. It doesn’t work with Contour stitch.

 Click the Jagged Edge icon. The effect is applied based on current 
Jagged Edge and stitch settings.

Tip: For objects filled with tatami, use diagonal backstitch for best 
results. 

Side 2 jaggedSide 1 jagged Both sides jagged
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 Right-click the Jagged Edge icon to access object properties.

 Select a side – Side 1, Side 2, or Both Sides.

 In the Roughness field, enter a value between 1 and 10 to set the 
degree of jaggedness.

 In the Range field, enter the margin within which you want stitches 
to fall.

Related topics...
 Other tatami settings

Adjust 
roughness

Select Jagged 
Edge

Side 2 Side 1Both Sides

Roughness: 1
Range: 5

Roughness: 5
Range: 5

Roughness: 10
Range: 5

Range: 1.5
Range: 4
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String stitching

String Stitch has its origins in India where it is known as ‘Paghadi’. This 
is commonly used to hold down small mirrors in intricate fabric designs. 
String Stitch mimics the overlapping ‘string art’ of Paghadi stitching. It 
too can be used to secure mirrors or sequins. Or it can be used for 
decorative effects such filling leaf-like shapes with elongated stitching. It 
comes in two forms – outlines and fills – and can be applied to open or 
closed shapes.

Most String stitch effects can be achieved by quite simple means. Since 
stitch angles have no effect, you can digitize most shapes with simple 
tools such as Run or Complex Fill. String outline provides spacing and 
chord length settings for control of outline density and thickness. 

Use Fill Stitch Types > String to create string craftstitch fills. Apply to closed 
shapes.

Use Outline Stitch Types > String to create string craftstitch outlines for 
delicate borders. Apply to open or closed shapes.

Use Traditional Digitizing > Digitize Run to create row of single stitches 
along a digitized line.

Use Traditional Digitizing > Complex Fill to digitize filled shapes with a 
single stitch angle. Right-click for settings.

Use Traditional Digitizing > Ring to digitize circle and oval-shaped rings.
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Reversing entry and exit points will also affect the direction of stitch 
overlaps.

String fill provides a spacing setting for control of stitch density. 
Thickness is determined by the shape. Try using it with both closed 
objects and objects with holes such as Ring objects. Direction of stitch 
overlaps is controlled by the Direction setting.

The Coverage setting can be used create partial covers such as the ones 
below. Control orientation either via the Direction setting or by changing 
entry/exit points.

Related topics...
 Digitizing outlines & details
 Creating free-form shapes
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 Digitize stars & rings

Open stitching

EmbroideryStudio provides various stitch types and effects to create 
open stitching. These can be used to provide interesting textures and low 
stitch counts for larger embroidered areas.

Decorative borders

The Stitch Types toolbars 
include Zigzag, E Stitch, and 
Square. All can be used to create 
borders around appliqués and 
other embroidery objects. They 
can also be used for decorative 
effects or open fills where fewer 
stitches are required. Zigzag and 
double zigzag stitches are also 
frequently used as underlays.

To create decorative borders
 Select the digitizing method you want to use – open or closed. 

Click Outline Stitch Types > Zigzag to create open borders or columns of 
even width for an open ‘sawtooth’ effect. Right-click for settings.

Use Outline Stitch Types > E Stitch to create open borders or columns of 
even width for an open ‘comb’ effect. Right-click for settings.

Use Outline Stitch Types > Square to create open borders or columns of 
even width for an open ‘toothed’ effect. Right-click for settings.
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 Select an outline or fill stitch type and create the embroidery object. 
Alternatively, select an existing object and apply a stitch type.

 Double-click the object or right-click the icon to access object 
properties. These give you control over stitch spacing, length, and run 
count values.

 Adjust Spacing for more or less dense outlines.

Adjust stitch 
spacing

Zigzag E Stitch Square
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 Create parallel stitching and control the angle relative to the 
horizontal. Use it to create calligraphy-like stitching.

 E Stitch also lets you set the number of runs:

Related topics...
 Chenille patterns
 Zigzag underlay settings
 Embroidery digitizing
 Digitizing regular columns
 Trapunto open stitching
 Appliqué Embroidery

Stippling effects

E Stitch spacing1 run E Stitch spacing

3 runs

Use Fill Stitch Types > Stipple Fill to create stippled fills of run stitching 
which meanders more or less randomly within a border. Right-click for 
settings.

Use Fill Stitch Types > Stipple Backstitch to create a backstitch fill which 
meanders randomly within a border. Right-click for settings.

Use Fill Stitch Types > Stipple Stemstitch to create a stemstitch fill which 
meanders randomly within a border. Right-click for settings.
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Stippling is a method for creating textured fills of run stitching which 
meanders more or less randomly within a border. It can be applied to any 
closed objects. Stitch angle has no effect.

To create a stippling fill
 Choose the object you want to apply the stitch type to or toggle on 

before you start digitizing. It can be applied to any closed object.

 Click the Stipple Fill icon. Stipple fill is applied and the Object 
Properties docker opens.

Adjust stipple 
settings
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 Adjust Run Length as required.

 Adjust Min Length (minimum stitch length) and Chord Gap as 
required.

 Adjust Run Count setting for a thicker line.
 Adjust Loop Spacing as required.

Stitch length: 0.25 mm Stitch Length: 0.75 mm Stitch Length: 1.5 mm

Min length: 0.1 mm
Chord Gap: 0.01 mm

Min length: 0.4 mm
Chord Gap: 0.03 mm

Min length: 0.7 mm
Chord Gap: 0.05 mm

Loop Spacing: 1.0 mm Loop Spacing: 2.0 mm Loop Spacing: 3.0 mm
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 Set a margin from the object outline by adjusting the Inset value.

 Use Stipple Stemstitch and Stipple Backstitch as preferred.

Related topics...
 Break apart composite objects

Maze fills

Inset: 1.0 mm Inset: 3.0 mm Inset: 5.0 mm

Stipple Stemstitch Stipple with SatinStipple Backstitch

Use Fill Stitch Types > Maze Fill to create maze-like stitching which follows 
object contours for open fills. Right-click for settings.
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Automatically fill large areas with double-spiral stitching that never 
crosses itself with Maze Fill.

To create a maze fill
 Choose the object you want to apply the stitch to or toggle on before 

you start digitizing. Stitch angles have no effect on this stitch type.
 Click the Maze Fill icon. The result is based on current settings.
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 Right-click the Maze Fill icon to access object properties.

 To set a nominal stitch length, adjust the Length field. To 
automatically shorten stitches to follow tight curves, activate the 
Variable Run Length option. Because this fill type creates 
double-spiral stitching, these settings are essentially the same as Run 
stitch.

 Adjust Spacing to create more or less open stitching.

Set maze 
spacing

Set maze 
smoothing

Set maze stitching 
direction

Spacing: 2.0 mm Spacing: 1.5 mm Spacing: 1.0 mm
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 Adjust Smoothing for more or less even curves.

 Adjust Direction to reverse stitch direction.

Tip: Maze Fill uses single run stitch for the fill. If you want a thicker 
stitch type, use Break Apart to turn the object into an outline and 
then apply a different stitch type.

Related topics...
 Digitizing outlines & details
 Offset fills

Smoothing: Low Smoothing: Medium Smoothing: High

Direction: Counterclockwise Direction: Clockwise
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Trapunto open stitching

The Trapunto effect automatically moves underlying travel runs to the 
edges of an object so they can’t be seen. It is available with complex fill 
objects using tatami stitching. In EmbroideryStudio, the effect is typically 
used in combination with open stitching to fill backgrounds or for shading 
effects. Without it, travel runs, spacing variations and overlapping rows 
between segments are visible and can spoil the effect.

Accordion Spacing extends the usefulness of Trapunto by providing a 
simple way to produce variation in a filled pattern and the illusion of 
depth. Trapunto and Accordion Spacing can also be combined with Liquid 
and Florentine effects to produce curved color blending.

To create open stitching with trapunto
1 With or without a complex fill object selected, right-click the Tatami 

icon to access object properties.

Use Stitch Effects > Trapunto to force underlying travel runs to the edges 
of a selected object. Right-click to adjust Trapunto settings.

Adjust stitch 
spacing
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2 In the Spacing field, enter the required stitch spacing. The larger the 
value, the more open the spacing.

3 Press Enter.
4 With the complex fill object selected, click the Trapunto icon.

Travel runs and overlapping rows are removed and consistent row 
spacing applied.

Note: Trapunto effect overrides whatever tatami backstitch settings 
currently apply.

Related topics...
 Other tatami settings
 Color blends
 Curved fills

Gradient stitching

EmbroideryStudio provides tools for varying stitch spacing between 
dense and open fill, producing gradient and shading effects which are 
difficult to achieve manually. Create color blends combining two gradients 

Spacing: 3 mmSpacing: 5 mm
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which merge smoothly from one to another using a mixture of dense and 
open fill. 

Accordion spacing

The Accordion Spacing feature varies stitch spacing between dense 
and open fill, producing gradient and shading effects which are difficult 
to achieve manually. It provides a simple way to produce variation in a 
filled pattern and the illusion of depth. It is best used with tatami fill. 
When applied, current settings – including Auto Spacing and Fractional 
Spacing – are ignored. However, other settings still apply, including stitch 
angle.

To apply accordion spacing
 Click the Accordion Spacing icon. The effect is applied to new or 

selected objects, based on the current Accordion Spacing settings.

Tip: Because of the open stitch, Accordion Spacing is best used 
without Auto Underlay.

Click Stitch Effects > Accordion Spacing to create perspective and shading 
effects. Right-click to adjust settings.
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 Right-click the Accordion Spacing icon to access object properties.

 In the Profile panel, select a spacing effect.

 In the Spacing panel, adjust spacing values:

Select spacing 
effect

Adjust spacing 
settings

Maximum 
spacing

Minimum
spacing



Chapter 24   Specialty St itching 600

 Use the Reshape tool to adjust the angle of the gradient fill. See also 
Adjusting stitch angles.

Tip: Apply Trapunto effect to force underlying travel runs to the 
edges of an object so that they can’t be seen through open stitching. 
It’s also a good idea to turn off Auto Underlay.

Related topics...
 Apply automatic underlay
 Trapunto open stitching 

Color blends

From sunsets to wood grains, Color Blending creates interesting color 
blends. Use it with standard tatami to create depth and shading. Two 
colors are merged smoothly from one to another using a mixture of dense 
and open fill. 

The effect is generally applied to Complex Fill objects. Curved blends 
can be created with Column A, B or C objects. Objects can be resized, 
rotated and skewed without losing the color blending effect. However, 

Use Toolbox > Color Blending to generate color blends, perspective effects 
and shading in selected objects.
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editing a color-blended object is limited. The two components must first 
be ungrouped and separate objects edited according to Accordion 
Spacing settings such as color, profile, and spacing.

To create a color blend
 Select your tatami object and click the Color Blending icon. The 

Color Blending dialog opens.

 Select complementary profiles for top and bottom layers. Generally 
you will want to use opposites but you can also mix and match 
completely different profiles.

 Choose complementary colors for each layer and adjust spacing 
settings. Generally, you will want to use the same values so that rows 
blend into one another.

 Click OK to generate.

Note: To prevent underlay stitching from showing through, Auto 
Underlay is deselected by default and Trapunto effect applied.

To adjust settings
 Select the blended object and press Ctrl+U to ungroup. 

Select first
Spacing effect

Select first color

Select second color

Select second
Spacing effect

Select first
spacing

Select second
spacing

Maximum 
spacing

Minimum
spacing
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 Select a component object and change color as required.
 Double-click the object to open Object Properties.
 Click the FX button and select the Accordion tab.

 Select a profile and adjust spacing as preferred.

 Repeat the process for the second object and re-group both.

Related topics...
 Stabilizing with automatic underlay
 Trapunto open stitching
 Accordion spacing

Chenille patterns

EmbroideryStudio provides a number of stitch patterns traditionally 
associated with chenille work – Square, Double Square, Coil, and 

Select spacing 
effect

Adjust spacing 
settings

Linear Profile Exponential Profile Convex Profile Wave Profile
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Island Coil. The pattern you use depends on the input tool used as well 
as object shape, size and the effect you want to achieve.

While these patterns are normally used with chenille designs, they can 
also be used as decorative lockstitch pattern types. Of course lockstitch 
machines can’t produce actual chenille chain or moss stitching, except 
with the aid of a ‘Simple Chenille’ device. However, the patterns 
themselves can create forms of decorative, open stitching.

Coil stitching

Coil stitching is more similar to Satin and is suitable for use with most 
closed-object input methods. Stitches are generated in spirals. 

Coil stitch

Coil fill is suited to narrow shapes or columns where each stitch traverses 
the width of the column. It provides a convenient way to fill an area with 
open stitching. Stitches are generated along curved lines and coils 
generate consistent stitch length even over different widths. This 

Coil stitching for 
perspective and depth

Island Coil for
texture

Use Outline Stitch Types > Coil to create borders or columns of even width 
for an open ‘coil’ effect. Right-click to adjust settings.

Use Fill Stitch Types > Coil to stitch narrow shapes or columns where each 
stitch traverses the column width. Right-click to adjust settings.
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produces a smooth finish which does not unravel easily. Coil is generally 
applied to objects created with Column A, Column B and Column C. 

You can adjust Coil settings for stitch length, coil spacing and width.

Column C + Coil

Column B + 
Coil

Column A + Coil

Coil spacing

Stitch
length

Coil width
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Column A/B objects can be used with variable width Coil stitching, while 
complex fill objects will default to Island Coil.

Similarly, Column C objects can be used with variable width stitching.

Island Coil fill stitch

Island Coil is used to fill larger closed areas. This technique allows 
complex shapes to be filled with concentric rows of coil stitching, 
simulating the circular motion of hand-chenille embroidery. With chenille, 

Use Fill Stitch Types > Island Coil to fill large objects with concentric rows 
of coil stitching, simulating the circular motion of hand-chenille embroidery. 
Right-click to adjust settings.

Column A/B 
with Coil

Complex fill with 
Island Coil

Column C with Coil
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this is commonly used with looped Moss stitching. Stitch angles have no 
effect on this stitch type. 

You can adjust a variety of Island Coil settings, including – stitch length, 
coil width, coil spacing, coil height and coil overlap.

 Juggle spacing and width values for a more or less dense chenille look. 
Width is set as a percentage of coil spacing value. The smaller the 
value, the tighter the coils.

 Adjust coil height as preferred. In chenille work, this value affects loop 
size.

 Adjust coil overlap as preferred. This controls loop spacing and thus fill 
density.

Square stitching

Square stitching is closer to Tatami and is suitable for use with most 
closed-object input methods. It can be used for borders like Zigzag and 
E Stitch, or it can be used as a substitute for Tatami in more open fills. 
Double Square is commonly used in chenille work with Moss stitching. 
It is suitable for larger areas.

Square stitch

Coil height

Stitch length Coil spacing

Coil overlap

Coil width

Use Outline Stitch Types > Square to create open borders or columns of 
even width for an open ‘toothed’ effect. Right-click for settings.
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Square is suitable for narrow objects digitized with most closed-object 
input methods. You can fill areas diagonally, or on the horizontal and 
vertical. All stitches generated along a row are of same length. However, 
some shorter stitches are generated where the shape is narrow and 
between rows of stitching. You could obtain a similar effect using open 
tatami with borderline backstitch, but Square stitch makes it simpler to 
achieve. Use it to create a ‘chenille look’ using cord and adjusting the 
presser foot height to create loops.

You can set the Square stitch values for stitch length and spacing.

Tip: Limit travel runs showing through the stitching by changing entry 
and exit points to reduce segmentation within the shape.

Use Fill Stitch Types > Square to create open straight parallel fills. 
Right-click for settings.

Column C + Square

Column B + 
Square

Column A + Square

Stitch spacing

Stitch
length

Stitch angle
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Double Square stitch

As an alternative to Island Coil, larger areas can be filled using Double 
Square. It is made up of two layers of Square stitching. With chenille 
work, this too is suitable for use with looped Moss stitching.

You can adjust stitch length, spacing, and the angle of the second 
Double Square layer. Spacing determines the space between stitch 
lines. Stitch length is the gap between needle points.

The angle of the first layer is defined by Complex Fill object properties. 
The Double Square properties give you the angle of the second layer in 
relation to the first – default, 90°. Thus, if the first is 30°, the second will 
be 120°.

Tip: Like Square stitch, you can use Double Square to create a ‘chenille 
look’ using cord and adjusting the presser foot height to create loops. 
Double square creates a denser fill.

Use Fill Stitch Types > Double Square to create grid fills. Apply closed 
shapes. Right-click for settings.

Stitch
length

Stitch 
spacing
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Cross stitch fills

Cross stitching is a popular technique for filling large areas with low stitch 
counts. Cross stitch is also sometimes combined with appliqué. Cross 
Stitch fill is something like Motif Fill but is generated differently. 

Crosses in different objects align when using the same fabric count. This 
is because cross stitch fills are generated on an invisible grid, not 
referenced to the individual object. Fractional crosses are generated at 
object boundaries in order to avoid gaps forming. Cross Stitch fill uses 
travel runs under and along the cross stitching.

Note: Cross Stitch fill is a stitch type in its own right but does not 
replace the ES Cross Stitch application available via the File menu. See 
also EmbroideryStudio Cross Stitch Supplement.

To create a cross stitch fill
 Create or select a closed-object and click the Cross Stitch icon.

Current Cross Stitch settings are applied. Auto Underlay and Pull 
Compensation are automatically deactivated. Stitch angle has no 
effect on the pattern layout.

Use Fill Stitch Types > Cross Stitch to fill large areas with cross stitching on 
an invisible grid that applies to all design objects.
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 To change settings, double-click or right-click the object/s to access 
object properties.

 Adjust Fabric Count settings to match the fabric size you are working 
with.

 Choose a stitch style.

Cross Stitch 
settings

Fabric count: 
10.0 stitches/inch

Fabric count: 
14.0 stitches/inch

Fabric count: 
6.0 stitches/inch

Stitch style: Upright Cross Stitch style: Full Cross
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 Adjust other cross stitch settings as desired:

Tip: The cross stitch grid is not displayed but you can set the 
background grid to the cross size to get a better idea. Use Snap to 
Grid to ensure that your object outlines line up with the cross stitch 
grid.

Related topics...
 Motif fills
 Embroidery digitizing
 Grid display options

Option Function

Fabric count Controls the size of cross specified as a counted fabric rather 
than an actual cross size.

Threads Sets thread count – e.g. 2, 4 or 6 – which determined number 
of times thread passes over the same cross in order to make 
it bulkier.

Stitch style Full cross (X), diagonal (\), or upright (+).

Floss direction Controls direction of top leg of the cross – forward or 
backward for diagonal full crosses, horizontal or vertical for 
upright full crosses.
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PART VII
EMBROIDERY LETTERING

Create top-quality lettering quickly and simply. EmbroideryStudio 
provides a large range of scalable closest-join font styles and multi-color 
and fancy embroidery fonts to choose from.

Creating embroidery lettering
This section describes how to add lettering, apply lettering baselines, 
change letter formatting, and adjust letter size and spacing. See Creating 
Embroidery Lettering for details.

Editing embroidery lettering
This section describes how to edit lettering text. It also explains how to 
scale and transform lettering objects. It also covers adjusting individual 
letters as well as reshaping baselines on screen. See Editing Embroidery 
Lettering for details.

Advanced embroidery lettering
This section shows you how to add special characters and symbols. It 
describes changing lettering stitch types in lettering objects, and 
adjusting lettering stitch angles. It also explains how to adjust the 
lettering stitching sequence as well as lettering join method. Automatic 
letter kerning and letter spacing are discussed. Lettering underlay is also 
discussed. It also describes how to create special effects with envelopes. 
See Advanced Embroidery Lettering for details.

Team names
This section shows you how to set up name groups and create team name 
designs. It also describes how to modify team name designs and output 
them in a variety of ways. See Team Names for details.

Monogramming
This section details the creation of monogram lettering with initials or 
with a name, how to add ornaments to monograms, and how to create 
ornament layouts. See Monogramming for details.

Custom lettering
This section describes how to create embroidery fonts from TrueType 
fonts. Automatic letter kerning and user-refined fonts are explained. The 
section also describes how to create and modify your own custom fonts 
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and letters. Font merging is also explained. See Custom Lettering for 
details.

Lettering kiosk
The lettering kiosk provides a set of predefined design layouts and the 
ability to easily personalize them by modifying text and color. You can 
create your own layouts as well. Designs can be sent to machine from the 
kiosk via a single button press. See Lettering Kiosk for details.
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Chapter 25

Creating Embroidery Lettering

Create high-quality embroidery 
lettering quickly and simply. 
EmbroideryStudio provides a large 
range of scalable fonts to choose from. 
Add embroidery lettering directly to 
designs or convert from CorelDRAW 
Graphics. Apply formatting just like a 
word processor, including italics, 
bolding, and right/left justification. 
Change values for the whole text or 
individual letters.
This section describes how to add 
lettering, apply lettering baselines, 
change letter formatting, and adjust 
letter size and spacing.

Creating lettering with CorelDRAW Graphics

Some EmbroideryStudio product levels include CorelDRAW® 
Graphics Suite as standard. This allows you to add and format TrueType 
lettering in CorelDRAW Graphics. This can then be converted to either 
embroidery lettering or embroidery objects.

Note: For a detailed description of the CorelDRAW® Graphics Suite 
interface, access the Help menu in CorelDRAW Graphics mode.

To create lettering with CorelDRAW Graphics
1 Switch to CorelDRAW Graphics.

Use Mode > Tag Fill as Turning Satin to tag narrow shapes for conversion 
to turning stitching.

Use Mode > Convert Graphics to Embroidery to convert selected graphics 
to embroidery and switch to Wilcom Workspace.
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2 Create a CorelDRAW® Graphics Suite text object and select it.

3 Click Convert Graphics to Embroidery. Wilcom Workspace opens 
in a few moments and the converted embroidery lettering displays. 
Change to a native embroidery font and adjust settings as desired.

 You can create lettering along any shape of baseline in CorelDRAW 
Graphics and convert to embroidery lettering.

 You can also convert multi-line paragraph text with left, center, or 
right justification.

Tip: If you are not satisfied with the results of lettering conversion and 
want to preserve the precise appearance of the original text, try 
converting to curves first and then to plain embroidery. Right-click and 
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select Convert to Curve. Optionally, use Tag Fill as Turning Satin 
to tag letters for conversion to turning stitching. 

Related topics...
 Operating modes
 Editing text
 Adjusting baselines

Creating embroidery lettering

You can add lettering to a design by typing it directly on-screen or 
entering it via the Object Properties docker.

Convert to 
curves first
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Select embroidery fonts

EmbroideryStudio offers a range of purpose-built embroidery fonts 
optimized for embroidery design work. Tick the Preview checkbox for a 
preview of fonts prior to selection. 

Use the droplists to filter the font list by type and by TrueType style:
 Choose a font type: Embroidery, TrueType, or All.
 Choose a TrueType font style: Block, Serif, Script, Decorative, or All. 

These only apply to TrueType fonts.

Font selection
The font list remembers the previously selected font, allowing you to 
continue searching from this point.

 First up, the font list provides a preview of recently used fonts. This 
can be adjusted.

 With no lettering object selected, the preview displays the name of the 
font. Otherwise, it will show the selected text.

Activate to
preview fonts in

droplist Filter font list by 
type and 
TrueType style

Type to filter list 
dynamically

Recently used 
fonts listed below

Drag corner to 
enlarge preview pane

Scroll to preview 
available fonts



Chapter 25   Creating Embroidery Lettering 618

 If you know what you are looking for, simply start typing the font name 
and the list will update dynamically.

 The preview pane can be enlarged as necessary.

Font list settings
You can set the size of your font preview via the Options > General tab. 
You can also adjust the number of recently used fonts.

Conversion of TrueType and OpenType fonts
In addition to dedicated embroidery fonts, EmbroideryStudio also 
converts any TrueType or OpenType font on your system on-the-fly into 
an embroidery font. This is an important feature for Asian fonts which 
may contain several thousand characters.

The process is automatic. The result is similar to manually digitized fonts 
although the quality may not be quite as good. It depends on the original 
shapes. Narrower serif type fonts produce better results than blocked 
fonts. See also Converting TrueType fonts to embroidery.

Set font preview 
size

Set number of recent 
fonts shown in font list

Scroll to preview 
available TrueType 
fonts
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Support for complex text layouts
EmbroideryStudio provides support for ‘complex text layout’ 
(right-to-left) and non-European scripts including Arabic, Hebrew, and 
Thai. With ‘RTL languages’ like Arabic and Hebrew, the order of 
characters is correctly rendered in the generated lettering objects. 
Complex text rendering is also supported in other languages which 
include combined characters. See also Converting TrueType fonts to 
embroidery.

Tip: It is also possible to select TrueType fonts in CorelDRAW® 
Graphics Suite and convert them on-the-fly via Convert tool. 

Recommended sizes
For best results when stitching, do not exceed the recommended 
maximum or minimum sizes. Note, however, that recommended heights 
refer to UPPER CASE letters. Most embroidery fonts are digitized from an 
original TrueType Font (TTF), some of which have lower-case letters – e.g. 
‘a’ and ‘c’ – which are about 70% the height of a capital letter. As a result, 
these letters may be too small to embroider neatly. You may need to 
increase the size of lower-case characters to suit the embroidery.

Special characters
You can create special characters in each font by holding down the Alt 
key on your keyboard and typing 0 (zero), its code, using the numbers 
on the keypad. For example, to type ê with the code 234, type 
Alt+0234. The accented letter will appear when you release the Alt key. 
Not all characters are available in all fonts.



Chapter 25   Creating Embroidery Lettering 620

Bling lettering
EmbroideryStudio also provides dedicated Bling Lettering.

Related topics...
 Adjust dimensions
 General options
 Creating lettering with CorelDRAW Graphics
 Adding special characters
 Creating bling lettering
 Standard Fonts

Add embroidery lettering on-screen

If it is not essential to fit letters precisely to a certain area, you can type 
them directly on-screen as with a word processor. Current settings are 
used. You can also modify lettering objects directly on-screen to achieve 
various artistic effects.

To add embroidery lettering on-screen
 Click the Lettering icon.
 Select a color from the Color toolbar.
 Click an insertion point and start typing. To start a new line, press 

Shift+Enter.

 Press Enter to complete.

Bling-specific 
fonts

Use Toolbox > Lettering to create embroidery lettering directly on-screen. 
Right-click to access settings.
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Note: Baselines determine the shape of lettering objects in a design. 
You can place lettering on a straight horizontal or vertical line, curve 
lettering around a circle or arc, or digitize your own baseline.

Related topics...
 Working with baselines

Create lettering with object properties

Using the Object Properties docker, you can specify letter formatting 
before adding it to the design. This is the more traditional method and is 
useful with more complex designs. EmbroideryStudio provides a font 
range suitable for many applications. Select from the supplied 
embroidery fonts or convert TrueType or OpenType fonts installed on your 
system.

Right-click Toolbox > Lettering to enter text in the docker and adjust 
settings for embroidery lettering.
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To create lettering with object properties
1 Right-click the Lettering icon to access object properties.

2 Enter the text you want to embroider in the text entry panel. To start 
a new line, press Enter.

3 Select a font from the Font droplist. To filter the list:
 Choose a font type: Embroidery, TrueType, or All.
 Choose a TrueType font style: Block, Serif, Script, Decorative, or All. 

These only apply to TrueType fonts.

Adjust formatting

Select font

Enter text

Click to create text

Choose baseline

Filter font list
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 Type two (or more) characters of the font name to further filter the 
list.

Tip: Check min/max recommendations for each font and stay within 
them for best results. See Standard Fonts for details.

4 Select a baseline from the droplist. Baselines determine the shape of 
lettering objects in a design.

5 Click Create Text in the docker.
6 Click on screen to place the lettering, or mark reference points for the 

selected baseline.
7 Press Enter to generate. Letters are filled with stitches according to 

current settings in the Object Properties docker. Change these at 
any time.

Scroll to preview 
available fonts

Scroll down to 
access recently 
used fonts

Select 
baseline style



Chapter 25   Creating Embroidery Lettering 624

Tip: Lettering appearance and quality depends a lot on underlay which 
serves as a foundation for cover stitching.

Related topics...
 Select embroidery fonts
 Standard Fonts
 Working with baselines 
 Format lettering
 Setting lettering underlay
 Converting TrueType fonts to embroidery

Adjusting lettering properties

Letter height, width, italic and justification can all be controlled via object 
properties. Letter, word and line spacings can also be controlled via 
properties. Letter spacing is calculated automatically according to 
justification – left, right, center, or fully justified.

Format lettering

Change current formatting settings before or after adding lettering. You 
can slant letters to left or right for an italic effect. Use the justification 
setting – left, right, center, or fully justified – to align lettering along the 
baseline.
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To format lettering
1 Create a new lettering object and select it.

2 If not already open, double-click to open the Object Properties > 
Special > Lettering dialog.

3 Adjust lettering height and width using the slider controls.

Tip: Say, for example, you are using the metric measurement system 
so your lettering heights are in mm. And say you get an order for ¾" 
lettering. Simply enter ‘3/4in’ or ‘3/4 in’ into the Lettering Height 
field and it is automatically converted to 19.05mm.

4 Enter an angle, ±45°, in the Italic field to create slanted lettering – 
0° is equivalent to no italics.

Adjust lettering width 
as percentage

Adjust lettering height

Adjust letter slant angle

Italic angle 25° Italic angle 0° Italic angle -10°
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5 Select a justification setting as required – Left, Right, Center, or 
Full.

Tip: When the justification setting is Full, letters are evenly 
distributed along the baseline. To change spacing for fully justified 
lettering, simply change baseline length.

6 To make bold lettering, select the Pull Comp tab.

7 Select column width or pull comp options as required.

Related topics...
 Create lettering with object properties
 Creating special effects with lettering art
 Set measurement units
 Compensating for fabric stretch

Adjust spacing settings

You can adjust letter, word and line spacings via object properties.

RightCenterLeft

Select Pull 
Comp tab

Increase pull comp 
or column width
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To adjust spacing settings
 Double-click a selected lettering object or right-click the Lettering 

icon to access object properties.

 Enter Spacing values as absolute values (mm) or percentages of the 
height.
 Letter Spacing: the space between letters.

Word Spacing: the space between words.

 Line Spacing: the space between lines.

Tip: If you want to remove spacing between words, set Word 
Spacing to 0%.

Adjust letter spacings on-screen

Enter values as 
absolutes (mm) or 
percentages

Use Reshape > Reshape Object to change letter spacing.
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Spacing between letters is calculated automatically as a percentage of 
letter height. In most cases the default spacing is adequate. Sometimes 
you may want to control the overall letter spread to fit a particular 
location. Similarly, you can change the space between lines in a 
multiple-line lettering object using the Reshape Object tool. Sometimes 
spacing between certain letters may appear too large or too small, 
depending on the shape of neighboring letters. To compensate for this 
visual effect, you can move one or several selected letters closer or 
further apart along the baseline to improve spacing. 

To adjust letter spacings on-screen
 Select the lettering object and click the Reshape Object icon.

 Drag the letter spacing control point left or right to adjust the spacing 
of all letters along the baseline.

 Release the mouse button to complete and press Esc.

Tip: When the justification setting is Full, letters are evenly 
distributed along the baseline. To change the spacing for fully justified 
lettering, simply change the length of the baseline.

 Drag the line spacing control point up or down to change line spacing.

 Release the mouse button to complete and press Esc.

Drag letter spacing
control point

Drag line spacing 
control point
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 Click the diamond control point in the center of the letter. To select 
multiple letters or a range of letters, hold down Ctrl or Shift as you 
select.

 Drag selected letter/s along the baseline or use arrow keys to adjust 
the spacing.

Tip: Alternatively, to move multiple letters, right-click the diamond 
control point of the first letter and drag. All letters to the end of the 
line move as one.

 Release the mouse button to complete and press Esc.

Related topics...
 Setting automatic letter kerning
 Setting automatic letter spacing
 Adjusting individual letters

Working with baselines

Baselines determine the shape of lettering objects. You can place 
lettering on a straight horizontal or vertical line, curve lettering around a 
circle or arc, or digitize your own baseline. You can digitize baselines 

Hold down Ctrl and click diamond 
points to select multiples

Drag or use arrow keys to 
fine-tune kerning
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on-screen or, if you are working from an enlargement drawing, on a 
digitizing tablet.

Apply baselines

With the exception of Free Line and Free Line Vertical, baselines allow 
you to set the final length of the finished lettering. Once you have placed 
a baseline, EmbroideryStudio attempts to fit all the letters without 
altering baseline length. EmbroideryStudio gives you interactive and 
numeric control over many baseline settings.

To apply a baseline
 Double-click a selected lettering object or right-click the Lettering 

icon to access object properties.

 Select a baseline from the list. Options include:
 Horizontal – Free Line and Fixed Line
 Vertical – Free Line Vertical and Fixed Line Vertical

Right-click Toolbox > Lettering to select baselines and adjust baseline 
settings.

Select 
baseline style
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Fixed Line baselines allow you to set the final length of the finished 
lettering. Free Line baselines expand to fit the letters you enter.

With vertical baselines, line spacing is calculated horizontally while 
letter spacing is calculated vertically. Letters, by default, are centered 
along vertical lines. New lines are placed by default from right to left 
to suit Asian languages. For Western languages, vertical lettering is 
best suited to uppercase because descenders in lowercase letters are 
not accommodated in the letter spacing.

 Arc – Arc CW and Arc CCW: By default, letters are positioned above 
the Arc CW and below the Arc CCW baseline. They are also centered 
by default. Hold down the Ctrl key to constrain the line to 15° 
increments.

Depending on the order in which you mark the reference points, the 
text will be placed left to right, or right to left.

 Circle – Circle CW and Circle CCW: Place letters around a full circle 
or oval. Mark a point on the circumference to define the radius. Mark 

Arc clockwise

Arc anti-clockwise

1

1

2

2

3

3
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a third point to define an ellipse or press Enter directly for a perfect 
circle. Hold down the Ctrl key to constrain the line to 15° increments.

Tip: Adjust circle and arc baseline settings for more precise numeric 
control over radius (X and Y), as well as tilt, justification, and arc 
angles.

 Custom: Digitize Any Shape baselines by marking reference points to 
form the required line. The number of reference points and length of 
baseline are practically unlimited.

Tip: If the baseline has tight curves, or sharp corners, letters may 
overlap. For best results, only mark curve points and digitize lines 
which have shallow, gentle curves.

4

3

21
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 Predefined: This technique is typically used for creating logos.

 Adjust baseline settings in the Baseline Settings dialog.

Related topics...
 Adjust fixed-width baseline settings
 Adjust curved baseline settings
 Use predefined baselines
 Adjusting baselines

Use predefined baselines

Use Predefined baselines to quickly create three rows of lettering, or 
two rows surrounding a design object. This technique is typically used for 
creating logos.
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To use a predefined baseline
1 With no objects selected, right-click the Lettering icon to access 

object properties.

2 Enter two or three lines of text in the text entry panel. To start a new 
line of lettering, press Enter.

Tip: If you want to insert a logo or design between the top and bottom 
lines, leave the middle line of text blank.

3 Select the font and adjust other settings you require.

Select options and
adjust settings

Enter two or three
lines of text
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4 Select Predefined from the baseline list and click OK.

5 Click where you want to place the lettering and drag the cursor 
downward.

Tip: Hold down the Ctrl key to constrain the line to 15° increments.
6 Click to enter a point on the circumference of the circle.
7 Mark another point if you want to create an oval, or press Enter for a 

circular baseline. The lines of text are generated and dispersed around 
the baseline you have defined. Each line of text becomes a separate 
lettering object.

Related topics...
 Select embroidery fonts
 Format lettering

Select ‘Predefined’
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Chapter 26

Editing Embroidery Lettering

EmbroideryStudio gives you interactive and precise numeric control over 
many settings affecting lettering objects. Adjust both individual letters 
and lettering objects as a whole. Apply horizontal, vertical, and curved 
baselines. Modify baseline type, length, radius and angle, as well as 
position. You can even define the rotation angle of letters relative to the 
baseline or the design itself.

This section describes how to edit lettering text. It also explains how to 
scale and transform lettering objects. It also covers adjusting individual 
letters as well as reshaping baselines on screen.

Editing text

When you have created a lettering object, you can select it and make 
changes to it interactively or by adjusting object properties.

Use Toolbox > Lettering to edit lettering on screen.
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To edit text
 Click Lettering and then click inside the lettering object. An I-beam 

appears.

 Edit the text as required. The lettering shows its wireframe.
 Press Shift+Enter to start a new line. Press Enter to complete.
 Alternatively, double-click the lettering object. The Object 

Properties > Special > Lettering docker opens.

 Edit the text in the text entry panel and make any other adjustments 
you require.

Adjust formatting

Change font

Edit text

Click to update
text

Change baseline
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 Click the Update Text button.

Related topics...
 Format lettering
 Applying stitch types & effects to lettering

Modifying lettering

When you first create lettering, it may be too big or too small. Size can 
be adjusted interactively or by adjusting object properties. Lettering 
objects can also be skewed and rotated.

Tip: The size of lettering will determine the type of underlay you need to 
apply. Lettering with heights under 5 mm should not have underlay. 
Letters 6 mm to 10 mm can have a center-run underlay applied. Lettering 
larger than 10 mm is large enough for edge-run underlay. See Setting 
lettering underlay for details.

Adjust dimensions

You can scale lettering objects vertically, horizontally and proportionally 
using the general properties or via the Special tab of the Object 
Properties docker.

Use Toolbox > Lettering to adjust letter height and width.
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To adjust dimensions
 Select the lettering object. The current dimensions appear in the 

Property Bar.

 Adjust width and height settings either as absolute values (mm) or as 
a percentage of current settings.

 Press Enter.

 Alternatively, double-click the lettering object to access object 
properties.

 In the Height field enter the height of your lettering object in 
millimeters.

 Enter the width of your lettering object in the Width field as a 
percentage of the height.
 For wide letters, increase the percentage – e.g. 140%.
 For narrow letters, decrease the percentage – e.g. 70%.

Note: Letter height can vary between roughly 5mm and 200mm. For 
recommended sizes, see Standard Fonts.

Related topics...
 Transforming Objects
 Reshaping Objects

Adjust width and
height settings

Lock to resize 
proportionately

Original

Width and
height 125%

Adjust lettering width 
as percentage

Adjust lettering height 
in millimeters

Width 100% Width 70% Width 140%
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Scale lettering

You can scale your lettering objects vertically, horizontally and 
proportionally with the Select Object tool. You can scale your lettering 
objects vertically, horizontally and proportionally with the Reshape 
Object tool. 

To scale lettering
 Click Select Object and select the lettering object.

 Click-and-drag one of the selection handles to resize the object 
horizontally, vertically or proportionally.

 Alternatively, click Reshape Object.

Use Select > Select Object to scale lettering objects on screen.

Use Reshape > Reshape Object to scale lettering objects on screen.

Drag to resize 
horizontally

Drag to resize 
proportionally

Drag to resize vertically

Drag

Drag to resize 
horizontally

Drag to resize 
proportionally

Drag to resize vertically
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 Click-and-drag one of the dark triangular control points to resize the 
object horizontally, vertically or proportionally.

 Release the mouse to complete and press Esc.

Related topics...
 Transforming Objects
 Reshaping Objects

Transform lettering

Apart from scaling, you can use the Select Object and Reshape Object 
tools to skew and rotate lettering objects.

To transform lettering
 Click Select Object and select the lettering object.
 Click the lettering object again. Another set of control points appears. 

These let you rotate and skew the lettering object.

Drag

Use Select > Select Object to transform lettering objects on screen.

Use Reshape > Reshape Object to rotate lettering objects on screen.

Drag to rotate

Drag to skewRotation point
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 Click-and-drag diamond-shaped control points to skew the lettering 
object.

 Click-and-drag hollow square control points to rotate the lettering 
object.

 Click-and-drag the rotation point itself to a new position before 
rotating.

 Alternatively, click Reshape Object.

 Click-and-drag up or down one of the solid square control points on 
the baseline to slant the lettering object.

Drag

Drag
Rotation

point

Drag
Rotation 
point

Click and drag up or down
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 Release the mouse to complete and press Esc.

Related topics...
 Transforming Objects
 Reshaping Objects

Adjusting individual letters

As well as scaling and rotating lettering objects, the Reshape Object 
tool is used to manipulate individual letters. You can reposition letters in 
relation to each other, scale, rotate and skew them, as well as reshape 
them. You can also recolor letters individually.

Reposition letters

You can reposition individual letters in a lettering object using the 
Reshape Object tool.

To reposition letters
1 Select the lettering object and click Reshape Object.
2 Click the diamond control point.

Use Reshape > Reshape Object to reposition individual letters on screen.
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To select multiple letters, hold down Ctrl or Shift as you select.

3 Click-and-drag the letter/s to the new position:
 To move horizontally, drag along the baseline.
 To move vertically, hold down Shift as you drag.
 To move the letter freely, hold down Ctrl as you drag.

4 Release the mouse to complete and press Esc.

Related topics...
 Adjust letter spacings on-screen

Transform letters

You can transform individual letters by manipulating control points on 
screen with the Reshape Object tool.

Click diamond control points

Use Reshape > Reshape Object to transform individual letters on screen.
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To transform letters
1 Select the lettering object and click Reshape Object.

2 Click the diamond control point. Another set of reshape nodes appear 
around the letter.

3 Click-and-drag a reshape node around the letter to transform it.

4 Press Esc to finish.

Reshape letters

Create special lettering effects by reshaping letter outlines with the 
Reshape Object tool.

Drag to scale 
letter width

Drag to scale letter 
proportionally

Drag to scale
letter height

Drag to rotate 

Drag to skew

Drag to
skew

Use Reshape > Reshape Object to reshape individual letters on screen.
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To reshape letters
1 Select the lettering object and click Reshape Object.
2 Click the letter outline. Control points appear around the outline. 

Selectively turn off control points as required.

3 Select reshape nodes by any of the following means:
 Drag a selection marquee around the reshape nodes you require.
 To select multiple nodes, hold down Ctrl or Shift as you select.

4 Reshape the letter like any other object and press Enter.

Tip: Press Spacebar to toggle between selected corner and curve 
reshape-nodes.

Click letter outline

Hold down Shift and left- or 
right-click to select range

Hold down Ctrl and click to 
select individual nodes

Draw selection marquee 
to select group of nodes

Reshape by adding, 
deleting and dragging 
reshape nodes
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5 Adjust stitch angles as required and press Enter.

Tip: Holding down the Ctrl key, click the outline wherever you want to 
place an additional stitch angle.

6 Adjust entry/exit points as required and press Enter.

7 Press Esc to finish.

Note: Custom fonts are saved in ESA format to in the USERLETW 
folder within the local EmbroideryStudio installation. If you want to 
adjust converted characters or add special characters to a custom 
font, you can do so via the Create Letter function.

Related topics...
 Adjusting stitch angles
 Smoothing curves
 Reshaping embroidery objects
 Create custom letters
 Save custom letters

Adjust entry/exit
points
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Recolor letters

EmbroideryStudio lets you change the color of individual letters.

To recolor individual letters
1 Click Lettering then click the lettering object.
2 Select a letter (or letters) by dragging the cursor over the letter.

3 Click a color on the Color toolbar.
4 Press Enter.

Tip: You can also insert a color change between two letters by keying 
a caret (^) symbol. Subsequent letters default to the next color in the 
palette.

Related topics...
 Create lettering with object properties

Adjusting baselines

Baselines can be modified after placement either directly on-screen or via 
the Object Properties > Special > Lettering docker. With the 
exception of Free Line and Free Line Vertical, baselines allow you to 
set the final length of the finished lettering. Once you have placed a 
baseline, EmbroideryStudio attempts to fit all the letters without altering 
the baseline length.

Use Toolbox > Lettering to recolor letters on screen.

Drag cursor over 
letter to select
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Tip: As a baseline is filled with letters, letter spacing decreases. 
Eventually, letters may overlap. If so, you can adjust the baseline length 
to accommodate them, or change the lettering width in the Object 
Properties > Special > Lettering docker.

Reshape baselines interactively

Baselines can be adjusted with the Reshape Object tool. Depending on 
baseline type, you can adjust angles, lengths, and sizes. You can change 
curve radii and justification points. You can completely reshape Any 
Shape baselines.

To reshape a baseline interactively
1 Select the lettering object and click Reshape Object.

Tip: The large diamond and cross represent start and end points. 
Toggle them off to access baseline controls.

Use Reshape > Reshape Object to reshape lettering baselines.
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 Change angles of straight baselines by dragging square control points 
at either end.

 Create an arc baseline from a circular one by dragging the hollow 
square control point.

 Change lettering orientation of arc baselines by dragging the solid 
square control points at either end.

Tip: Letter positions depend on justification – left, center, right or 
justified. If the baseline becomes too short, letters may overlap.

Drag up/down to change
baseline angle

Drag left or right to change 
circle baseline to arc

Drag along circumference to 
change baseline length
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 Change the radius by dragging the solid square control point in the 
center of the circle.

 Alternatively, change the radius by dragging the control point in the 
center of the baseline.

Drag up or down 
to change radius 
of curve

Drag up or down to 
change radius of curve
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 Adjust Any Shape baselines by adding, deleting, changing or moving 
reference points like any embroidery object.

 To reshape, left-click to bend the line at an angle, right-click to 
bend into a curve.

 To re-position, drag any one of the baseline control points up or 
down.

 To delete, select a control point and press Delete.
 To change straight to curve, or curve to straight, select the control 

point and press Spacebar.
 Press Esc to finish.

Related topics...
 Adjust fixed-width baseline settings
 Adjust curved baseline settings
 Reshape letters
 Reshaping embroidery objects

Adjust fixed-width baseline settings

A free-line baseline does not have a fixed or pre-determined length – the 
baseline extends as long as you keep adding letters. A fixed-line baseline 

Left or right-click on the
baseline to add

Drag to change curvature

Use Toolbox > Lettering to adjust baseline settings.



EmbroideryStudio e4 Reference Manual 653

has a fixed length which you can digitize or specify numerically. Various 
options are available to handle text that extends beyond the baseline. 

Tip: Precise control over baseline width is important when combined with 
Team Names when you want to ensure all names fit within the same 
area such as a pocket.

To adjust fixed-width baseline settings
1 Double-click a selected lettering object/s to access object properties.

2 Click Settings. The Baseline Settings dialog opens. Options depend 
on baseline type.

3 Select a horizontal, vertical, or arc baseline from the list.
4 Adjust the Length value as required.

Click to lay out
baseline

Adjust length and
angle values

Select auto
frame style

Select baseline
position
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Fixed-line baselines allow control over line length as well as options for 
handling text which does not fit the baseline. This is particularly useful 
for multiple ‘team’ names. Free-line baselines only allow you to adjust 
the Line Angle value. 

5 For fixed-line baselines, select an ‘auto-frame’ style:
 Spacing: Letter size and width stays the same and letters are 

spaced evenly along the baseline. Letters may overlap if the text is 
too wide.

Width: The width of each letter is reduced and the original spacing 
kept.

 Size (Keep Proportions): Letter width and height is reduced 
proportionally but the original spacing remains.

 Spacing and Width: Letter width and spacing is reduced.

 Spacing and Size (Keep Proportions): Letter width, height and 
spacing is reduced proportionally.

6 Adjust the Line Angle as required. Enter the exact angle of baseline 
to the horizontal axis.

7 Select a baseline position.

Baseline 
below

Baseline 
centered

Baseline 
above
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When creating lettering for a badge, for example:
 For lettering above the badge, select a baseline below.
 For lettering below the badge, select a baseline above.
 For horizontal lettering through the middle of the badge, select a 

centered baseline.
8 Specify the letter, word and line spacing as required.
9 Select a letter orientation.
10 Click OK to return to Object Properties > Special.

Related topics...
 Apply baselines
 Adjust spacing settings
 Adjusting baselines
 Creating simple teamname designs

Adjust curved baseline settings

Adjust baseline settings for more precise numeric control over radius (X 
and Y), as well as tilt, justification, and arc angles.

To adjust curved baseline settings
1 Double-click a selected lettering object/s to access object properties.

Use Toolbox > Lettering to adjust baseline settings.

Click to lay out
baseline
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2 Click Settings. The Baseline Settings dialog opens. Options depend 
on baseline type.

3 Select a circle or arc baseline type from the list. The Tilt, Radius X, 
Radius Y, Justification Angle and Arc Angle fields are activated.

4 Adjust these values as required:
 Radius X: default radius of the baseline arc (X-axis).
 Radius Y: default radius of the baseline arc (Y-axis).

 Tilt: angle of the baseline relative to the horizontal axis.

Note: The Tilt field is activated when Radius X and Radius Y values 
are different.

Adjust Tilt, Radius X, 
Radius Y, Justification 
and Arc Angle values

Radius X: 50
Radius Y: 50

Radius X: 50
Radius Y: 100

Radius X: 100
Radius Y: 50

Tilt angle 45°

Tilt angle 0°
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 Justification Angle: angle of the vertical axis through the 
lettering object relative to the horizontal axis.

 Arc Angle: angle between radii connecting ends of baseline to 
center of arc. This constrains the baseline so the text falls within the 
arc specified.

Tip: Precise control over baseline width is important when combined 
with Team Names when you want to ensure all names fit within the 
same area such as a pocket. A fixed width on arch baselines can be 
set by adjusting Arch Angle value in the Baseline panel.

5 Select a baseline position.

When digitizing lettering for a badge, for example:
 For lettering above, select a clockwise circle or arc with baseline 

below.
 For lettering below, select a counterclockwise circle or arc with 

baseline above.
 For horizontal lettering through the middle of the badge, select a 

fixed line with baseline centered.
6 For fixed-line baselines, select an ‘auto-frame’ style.
7 Specify the letter, word and line spacing as required.
8 Select a letter orientation. 

Justification 
angle 90°

Justification
angle 45°

Arc angle 70°Arc angle 100°

Baseline 
below

Baseline 
centered

Baseline 
above
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9 Click OK to return to Object Properties > Special > Lettering 
docker.

Related topics...
 Adjust fixed-width baseline settings
 Adjust letter spacings on-screen
 Adjusting baselines
 Creating simple teamname designs

Change letter orientation

You can define the rotation angle of letters relative to the baseline or the 
design itself. The latter lets you keep letters vertical regardless of 
baseline angle in order to achieve a ‘staircase effect’.

To change letter orientation
1 Right-click the Lettering icon or double-click selected lettering 

object/s to access object properties.

2 Click Settings to open the Baseline Settings dialog.
3 Select an Orientation setting.

 Baseline: orients letters relative to the lettering baseline.
 Design: orients letters relative to the horizontal.

Click to lay out
baseline

Set orientation 
angle

Select orientation
relative to baseline

or design
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4 Enter an orientation angle.

5 Click OK to return to Object Properties > Special > Lettering 
docker.

Breaking apart lettering

Applying the Break Apart function to a lettering object breaks it into a 
logical stitching sequence while maintaining lettering object 
characteristics. Object properties can be edited separately for single 
lines, single words, or even single characters. Stitching sequence is 
maintained.

Sequence logic is as follows:
 Multi-line lettering can be broken into separate objects per line
 Individual lines can be broken into separate objects per word
 Words can be broken into separate objects per letter

Baseline angle: 0º 
Orientation: 60º to design

Baseline angle: 0º 
Orientation: 10º to baseline

Use Edit > Break Apart to split composite objects – monograms, appliqués, 
lettering, etc – into component objects.

Lettering broken apart into
logical stitching sequence
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 Letters can be broken into their individual embroidery patches. 
Lettering properties are lost. Only general embroidery object 
properties remain.

Tip: An exception for single-line (multi-word) objects is the case of the 
center-out stitching sequence. Such objects are broken apart directly into 
single-letter objects. The stitching sequence is thereby preserved.

Related topics...
 Break apart composite objects

Individual letter with 
full lettering object 
properties

Individual letter broken 
into separate 
embroidery patches

Properties of each 
patch can be 
separately edited
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Chapter 27

Advanced Embroidery Lettering

EmbroideryStudio provides a 
variety of advanced editing 
techniques for fine-tuning 
lettering designs. Add special 
characters and symbols as 
desired. By default, lettering 
objects are filled with Satin. 
Apply other basic fill stitch 
types as with all embroidery 
objects.
Specify the sequence in which 
letters are stitched to minimize 
registration problems. The 
automatic kerning feature 
improves lettering appearance 
and legibility by fine-tuning 
spacings between character pairs. Alternatively, fine-tune letter spacing 
according to the number of characters per lettering object. This is 
particularly useful with Asian fonts. Lettering appearance and quality can 
be improved by the correct selection of underlay. Apply Envelope effects 
to lettering objects to make them bulge or arch, stretch or compress.
This section shows you how to add special characters and symbols. It 
describes changing lettering stitch types in lettering objects, and 
adjusting lettering stitch angles. It also explains how to adjust the 
lettering stitching sequence as well as lettering join method. Automatic 
letter kerning and letter spacing are discussed. Lettering underlay is also 
discussed. It also describes how to create special effects with envelopes. 

Adding special characters

Embroidery and TrueType fonts generally contain many more characters 
than are available via keyboard. In EmbroideryStudio, you can add 
special characters and symbols directly through the Select Symbols 
dialog or by means of the MS Windows® Character Map.
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Insert symbols

Add special characters and symbols to your lettering designs.

To insert symbols
1 Right-click the Lettering icon to access object properties.

Tip: If you already know the keyboard shortcut for a symbol, you can 
add it by entering the combination on screen or in the docker.

2 Click Insert Symbol.

Use Toolbox > Lettering to add special characters and symbols. Right-click 
to select lettering options.

Click to insert
symbols

Toggle display 
settings

Select font or
symbol set

Select
symbols

Selected symbols

Click to add
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3 Select a font or symbol set from the Symbol set list.
4 Select the symbols you want to use. Selected symbols are displayed 

in the Selection field.
5 Click OK. The selected symbols are displayed in the text entry panel 

of the Object Properties > Special > Lettering docker.

Create flair script designs

Flair script is a special font which allows you to add decorative flairs to 
the end of text objects, mimicking flamboyant handwriting flourishes.

To create a flair script design
1 Right-click the Lettering icon to access object properties.

2 Select Flair Script from the Font list.
3 Enter the text you want to embroider in the text entry panel.

Use Toolbox > Lettering to add special characters and symbols. Right-click 
to select lettering options.

Select Flair Script
font

Enter text

Click to select special
characters
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4 Click Insert Symbol.

5 Select the flourish you want to use. Scroll down for more options.
6 Click OK to close the dialog. The selected characters are displayed in 

the text entry panel.

7 Adjust lettering settings as required and click OK.
8 Click an insertion point or mark reference points for the selected 

baseline.
9 Press Enter.

Tip: Experiment with different flourishes to obtain the look you want.

Select flourish

Corresponding
keystrokes

$

Flourish added
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Add monogram lettering

In addition to the dedicated Monogramming feature, EmbroideryStudio 
allows you to create monogramming designs using special monogram 
fonts. See also Monogramming.

To add monogram lettering
1 Right-click the Lettering icon to access object properties.

2 Select a suitable monogram font such as Octagon Monogram. See also 
Standard Fonts.

Click to select
fancy lettering

characters

Select monogram
font
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3 Click Insert Symbol. The Insert Symbol dialog opens.

Tip: When you select a character, a keystroke appears in the 
Selection field. This indicates the key combination required to type 
the character directly on-screen.

4 Select a left-facing letter. Octagon Monogram, for example, has three 
sets of each letter, one for the left side, one for the middle and one for 
the right side. When selecting letters, you need to ensure letter 
orientation is correct. 

5 Select a middle letter and then a right-facing letter.

6 Select a border if required.

Select
character

Corresponding
keystrokes

Select viewing 
mode

Select
border
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7 Click OK. The selected characters are displayed in the text entry 
panel.

8 Click Create Text.

Tip: If you want the letters in your monogram to be different colors, 
select and recolor one-by-one.

Use the Character Map

Use the MS Windows® Character Map to provide quick access to 
common symbols and letters. The Character Map is usually installed as 
part of the MS Windows® setup. See your MS Windows® documentation 
for more details.
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To use the Character Map
1 Open the MS Windows® Character Map. By default, you will find it 

under Start > Programs > Accessories > System Tools > 
Character Map.

2 Select a font from droplist.
3 Double-click a character, or select it and press Select. The character/s 

appear in the Characters to copy field.
4 Click Copy to copy the character to the clipboard.
5 Paste it into the text entry panel of the Object Properties > Special 

> Lettering docker. To do this, click inside the text entry panel and 
press Ctrl+V or right-click to open the popup menu. 

Tip: You can also paste characters and symbols into an external 
graphics program to use as the basis for creating your own custom 
characters.

Select font

Select symbols
or double-click

Selected symbols
displayed Click to select

Click to copy
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Applying stitch types & effects to lettering

By default, lettering objects are filled with 
Satin stitch. You can apply other fill stitch 
types such as Tatami or Program Split 
as well as stitch effects such as Jagged 
Edge. See Stitch Types for details.

Note: Lettering values are stored in the 
<PRESET_LETTERING> style in the 
Normal template. Changing these does 
not affect the values of other objects. Do 
not delete or rename this style. See 
Working with styles for details. 

Satin lettering

By default, lettering objects are filled with Satin stitch. Because there are 
generally no needle penetrations breaking up the fill, satin stitch creates 
a glossy, high-quality effect suitable for most lettering.

Satin Raised can be applied successfully to some styles of font for a 
raised embroidery surface. Outlines can be added with the 
Outlines & Offsets tool for use with quilted designs. Traditionally, 
trapunto utilizes two or more layers, the underside of which is slit and 

Use Fill Stitch Types > Satin to apply satin stitch to new or selected narrow 
columns and shapes. Right-click for settings.

Use Fill Stitch Types > Satin Raised to create raised surfaces – can be 
applied to lettering or used with trapunto for quilting effects. Right-click for 
settings.

Auto Spacing OFF
Stitch Spacing 0.6 mm

Auto Spacing ON
Stitch Density 60 %

Auto Spacing ON
Stitch Density 100 %
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padded, producing a raised surface on the quilt. Lay the second layer 
over Satin Raised lettering and stitch down with trapunto outlines.

Note: EmbroideryStudio also includes as standard a number of dedicated 
3D fonts.

Related topics...
 Satin stitching
 Standard Fonts
 Generating outlines & offsets

Tatami lettering

You can fill lettering shapes with Tatami stitching. This may be suitable 
for filling larger lettering shapes.

Zigzag lettering

Use Fill Stitch Types > Tatami to create fills for larger irregular shapes. 
Right-click for settings.

Use Fill Stitch Types > Zigzag to create fills with an open ‘sawtooth’ effect. 
Right-click for settings.

Stitch Spacing 0.4 mm
Stitch Length 2 mm

Stitch Spacing 0.6 mm
Stitch Length 3 mm

Stitch Spacing 0.4 mm
Stitch Length 5 mm
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Zigzag stitch can be applied to lettering for any open stitching effect.

Related topics...
 Open stitching
 Standard Fonts

Patterned lettering

Try applying Program Split to lettering. This too may be suitable for 
filling larger lettering shapes or for special effects. Density is determined 
by stitch spacing.

Related topics...
 Creating textures with program splits

Jagged edge lettering

Use Fill Stitch Types > Program Split to create decorative fill stitches where 
needle penetrations form a tiled pattern.

Use Stitch Effects > Jagged Edge to create rough edges, shading effects, 
or imitate fur and other fluffy textures along one or more sides of selected 
objects.
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Jagged Edge can be used with lettering objects for special ‘spooky’ 
effects or fluffy textures.

Related topics...
 Jagged edges

Creating special effects with lettering art

Apply Lettering Art effects to make letters bulge or arch, stretch or 
compress. Many styles are available from the Lettering Art gallery. You 
can fine-tune preset shapes as preferred. Edit lettering text in envelopes 
the same way as normal lettering. Return lettering to its original shape 
by removing the envelope altogether.

To create lettering art effects
 Create a lettering object.

 Double-click the object to access its properties.

Use Toolbox > Lettering to edit letters on-screen.

Use Reshape > Reshape Object to reshape selected objects by means of 
control points.
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 Scroll through the Lettering Art list or click More to access the 
gallery. You can tear it off for easy access.

 Select a shape from the gallery.

 Click again to access rotation control handles.

Click to apply a 
predefined 
shape

Scroll or click More 
button to access 
gallery
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 Use Reshape Object to fine-tune the envelope shape.

 Drag control handles to adjust:
 To move two handles in opposite directions, hold Shift while 

dragging.
 To move handles in the same direction, hold Ctrl while dragging.

 Press Esc to finish.
 To edit, click the Lettering icon with the object selected. Duplicate 

letters appear below.

 Click inside the duplicate and edit text as desired. Press Enter to 
confirm.

Drag nodes to 
reshape

Edit duplicate 
letters and press 
Enter
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 To return an object to its original shape, click Remove Art.

Related topics...
 Applying envelopes

Setting stitching sequence & join method

You can specify the sequence in which letters are stitched to minimize 
registration problems such as on caps or difficult fabrics. While the 
Closest Join method is recommended in most cases to minimize trims, 
you may sometimes want to use the As Digitized setting with fonts 
which include multiple colors, multiple stitch types, or special effects.

Adjust letter sequencing

You can specify the sequence in which letters are stitched to minimize 
registration problems such as on caps or difficult fabrics. For example, 
the Center Out option is especially useful when stitching on caps. There 
are also options for multiple lines of lettering which are useful for 
machines without trimmers.

To adjust letter sequencing
1 Right-click the Lettering icon or double-click selected lettering 

object/s to access object properties.

Click to remove 
effect

Click Toolbox > Lettering to adjust the lettering stitching sequence.

Click
Sequence
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2 Click Sequence. The Letter Sequence dialog opens.

3 Select a stitching sequence. Options include:
 In-line: Select whether you want the lettering to be stitched 

left-to-right or right-to-left in each line.

 Center-out: Select this checkbox if you want the lettering stitched 
from center out.

 Line-by-line: Choose whether you want multiple lines to stitch 
top-to-bottom or bottom-to-top.

Note: You can combine both In-line and Line-by-line sequencing 
options.

4 Click OK to return to the Special tab.

Adjust single
line stitching

sequence

Adjust multiple
line stitching

sequence

 Stitched left-to-right Stitched right-to-left

 Left side stitched first Right side stitched first

Stitched 
bottom-to-top 

Stitched
top-to-bottom
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Tip: Travel through your design to check the stitching sequence. See 
Travel through designs for details.

Change lettering join method

The lettering stitch method is preset to give the best results for each font. 
In most cases, Closest Join is recommended in order to minimize trims.

Lettering objects normally consist of one stitch type and one color only. 
However, the As Digitized join method together with Original Stitch 
Values setting can be used with special fonts which combine several 
stitch types – e.g. Satin with Run, or Tatami, or Motifs. The As 
Digitized setting can also be used with fonts which include multiple 
colors or special effects. Such fonts may include machine functions, as 
for two-color fonts, or run stitches as part of the cover stitching.

To change the lettering join method
1 Right-click the Lettering icon or double-click selected lettering 

object/s to access object properties.
2 Click Sequence. The Letter Sequence dialog opens.

Use Toolbox > Lettering to change the lettering join stitch method.

Select join method

Select original stitch 
values
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3 Select a stitch method from the droplist:

Options include:

4 Select the Original stitch values checkbox as required.
This setting is only available if the As Digitized join type is selected. 
Use it with special fonts which combine several stitch types. If not 
selected, these letters will be stitched with a single stitch type.

5 Click OK to return to the Special tab.

Note: For recommended stitch and join methods, see Standard Fonts.

Setting automatic letter kerning

The automatic kerning feature improves lettering appearance and 
legibility by fine-tuning spacings between character pairs. Typically, 
spacing between certain pairs looks uneven due to the optical illusion 
formed by mixing straight lines with curves. Automatic kerning optimizes 
spacing between lettering pairs according to preset values. While it works 

Option Function

Bottom join Letters are joined along the baseline. Use it when stitching on 
towelling – joins are hidden in the pile.

Closest join Letters are joined at the closest point. Use it to minimize trims.

As digitized Letters are joined the same way they were originally digitized. 
Use it with fonts combining different fill stitch types or special 
effects.

Closest join As digitizedBottom join

As digitized – original 
stitch values selected

As digitized – original 
stitch values not selected

Closest join
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very well without customization, advanced users can customize these 
values as they wish. Kerning tables can even be copied from similar 
MS Windows® fonts.

Tip: For more information about kerning, see the Windows Dev Center 
topic on Justification, Kerning, and Spacing.

Apply automatic kerning

The automatic kerning option is accessed by means of the Object 
Properties docker.

To apply automatic kerning
1 Double-click a lettering object to access object properties.

2 Scroll down to the Spacing panel. If a kerning table exists for the 
selected embroidery font or TrueType font, the Auto Kerning 
checkbox is enabled and selected by default.

3 Select Auto Kerning as required and click Apply.

Related topics...
 Setting automatic letter spacing

Right-click Toolbox > Lettering to adjust automatic kerning for selected 
lettering objects.

Click auto
kerning

https://msdn.microsoft.com/en-us/library/windows/desktop/hh994452%28v=vs.85%29.aspx
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Manage kerning tables

A kerning table is an array of kerning values for every possible pair of 
letters in the font. The Kerning Table command accesses a dialog used 
to manage kerning tables. You can copy tables from one font – 
embroidery or TrueType – to another or remove its kerning table 
altogether.

Note: TrueType kerning tables cannot be replaced, added to, or modified 
in any way. You can, however, convert a TrueType font to an embroidery 
font and add or modify a kerning table as required.

To manage kerning tables
1 Open the Object Properties > Special > Lettering docker.
2 Select a font from the droplist.

3 Scroll down and click the Kerning Table button. The Kerning Table 
dialog opens with the current (target) embroidery font displayed. The 
droplist displays all fonts that contain kerning tables.

4 Choose a suitable font or TrueType font from the list and click Copy 
Source to Table to load its kerning table to the current embroidery 
font.

Use Docker > Object Properties to access kerning tables.

Click to
access

kerning table

Choose 
similar font

Current (target)
font

Copy kerning table
to current font
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The Zero Table command is enabled if the current (target) font 
already has a kerning table.

Related topics...
 Apply automatic kerning
 Edit kerning values

Edit kerning values

You have created a lettering object which has Auto Kerning toggled on. 
Use this procedure to update kerning settings for contiguous pairs of 
letters.

To edit kerning values
1 Select a lettering object with automatic kerning and click the Reshape 

icon.

2 Click the diamond control point in the center of the letter.
3 Drag selected letter/s along the baseline or use arrow keys to adjust 

the spacing. Alternatively, to move multiple letters, right-click the 
diamond control point of the first letter and drag. All letters to the end 
of the line move as one.

4 Repeat as many times as necessary to fine-tune all letter spacings in 
the object.

5 Select one or more blocks of contiguous letters by Ctrl-clicking their 
diamond control points or dragging a selection box around them.

6 Select Object > Update Kerning Settings. The operation will affect 
letter spacing of all new lettering objects.

7 Click OK.

Use Reshape > Reshape Object to reshape selected objects, edit stitch 
angles, and adjust start/end points.
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A new kerning value is generated for each contiguous pair of letters, 
and written to the associated kerning table.

Related topics...
 Adjust letter spacings on-screen

Setting automatic letter spacing

The Auto Letter Spacing feature allows you to fine-tune letter spacing 
according to the number of characters per lettering object. When 
activated, EmbroideryStudio automatically spaces letters according to a 
predefined spacing table. For example, in a five-character lettering 
object, spacing may be set to 2mm, while in a three-character lettering 
object, it may be increased to, say, 3mm.

To apply automatic letter spacing
1 Create or select a lettering object and double-click to access object 

properties.

2 Select a baseline for use with Auto Letter Spacing. Automatic letter 
spacing is available for all baselines. However, with fixed-line and arc 
baselines, automatic spacing only works with Width and Size options 
selected.

3 Tick the Auto Letter Spacing checkbox.

Without auto 
letter spacing

With auto letter 
spacing

Auto letter
spacing unticked

by default
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4 Click the Letter Spacing Table button. The Letter Spacing Table 
dialog contains a matrix of settings for lettering objects of two to six 
or more characters.

5 Adjust spacings for each character grouping. The topmost field for two 
characters has a range of 0.10mm to 100.00mm.

6 Click OK. With the Auto Letter Spacing checkbox checked:
 For a lettering object with more than one line of text, the system 

will use the longest line of text for the letter spacing. 

 The letter spacing table will not change even if individual letters are 
resized in Reshape mode.

Single line of text – uses predefined 
character length for letter spacing

Multiple lines of text – uses 
character length of longest line for 
letter spacing – in this case, 3 

Letter resized - spacing 
stays the same
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Tip: The Auto Letter Spacing feature also works with the Team 
Names feature. Any ‘name frame’ can have a specified letter spacing 
just as it can assume any other lettering property.

Related topics...
 Setting automatic letter kerning
 Adjusting baselines
 Creating simple teamname designs

Setting lettering underlay

Lettering appearance and quality depends a lot on underlay which serves 
as a foundation for cover stitching. As well as stabilizing, underlay also 
provides ‘loft’, raising cover stitches and preventing them from sinking 
into soft fabrics. It can also prepare a napped fabric by flattening it. 

Most lettering used in designs is 15 mm high or less. The columns at such 
sizes are less than 3 mm wide for normal – not heavy or block – fonts. 
Such objects are best served with a single Center Run or Edge Run 
underlay. Here are a few rules of thumb:
 Lettering with heights under 5 mm should not have underlay. 
 Letters 6 mm to 10 mm can have a center-run underlay applied. 
 Lettering larger than 10 mm is large enough for edge-run underlay. 
 Large letters for jacket backs and so on can use a second layer of 

underlay. Double-zigzag is sometimes used to give added loft.

To set lettering underlay
1 Select a lettering object.

Right-click Stitch Effects > Auto Underlay to adjust lettering underlay 
settings.
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2 Right-click the Auto Underlay icon to access object properties.

3 Select the First Underlay checkbox and select Center Run or Edge 
Run as the first underlay type. If you select Edge Run, a further By 
Shape option becomes available. When activated, underlay is applied 
to the lettering object as a whole.

4 Select the By Segment or By Shape option as required.

Note: With most embroidery objects, underlay is stitched 
segment-by-segment before cover stitches are sewn. Lettering 
underlay, however, defaults to a single By Shape > Edge Run 
underlay, except ‘As Digitized’ lettering. This has the effect of 
calculating an underlay for the entire shape rather than each segment 
comprising it. This in turn reduces bunching, travel runs, and overall 
stitch count.

5 Enter the required length values for each underlay type. 

Adjust fixed or 
variable run length

Select Edge Run 
(or Center Run)

Select 1st underlay and 
optionally select ‘by shape’

Segments comprising letter Underlay ‘by segment’ Underlay ‘by shape’
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6 If you are using zigzag underlay, adjust stitch angles to create a 
‘cross-hatch’ effect. This may provide more support than single 
zigzag.

7 Press Enter or click Apply.

Tip: Run Stitch Player to see how the underlay will stitch out.

Related topics...
 Run stitch underlay settings
 Zigzag underlay settings
 Simulate design stitchouts

Default Zigzag Slanted Zigzag Slanted Double Zigzag
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Chapter 28

Team Names

The Team Names feature lets you create designs with multiple names. 
For example, you can use the same logo with different names for sports 
teams or corporate uniforms, without having to create multiple copies of 
the same design. Depending on how you want to stitch out, you can 
choose to save and stitch names and designs separately, or together.

This section shows you how to set up teams and create teamname 
designs. It also describes how to modify teamname designs and output 
them in a variety of ways.

Creating simple teamname designs

Create simple teamname designs by keying names directly into the 
Team Names docker. Alternatively, import names from a tab-delimited 
text file. By default, teamname objects consist of a single baseline with 
three names. Add or remove name columns as desired.

Create teamname objects

To associate team members with a design, you create a variable 
‘teamname object’. Either key in the names of the team members 
directly, or import from a list provided by the customer.

Use Toolbox or Docker > Team Names to associate multiple names with a 
design.
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To create a teamname object
 Open the design you want to use.

 Click the Team Names icon to access the docker. By default, the 
teamname object will consist of a single baseline with three names.

 If you are happy with the default layout, simply click a cell and start 
typing. Press Tab or Shift+Tab to move back and forth through name 
fields.

 Alternatively, use the Teamname List tools to add names, delete 
names, etc:

Tool Function

Manage 
Teams

Manage teams and team members for future use. See 
below.

Import Team 
Members Import or export a list of team members in either TXT or 

CSV format. Names must be comma delimited.Export Team 
Members

Click a cell and 
start typing
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 Optionally, click the Import Team Members button to import team 
members from a list possibly provided by the customer. The list must 
be comma delimited.

Tip: When you import a teamname list you can import it from 
anywhere. However, you cannot use the Manage Teams dialog 
effectively with it unless it is saved in the ‘Teamname Teams’ system 
folder. See Managing teams for details.

Name Order Change default naming order or include/exclude names 
as required.

Remove 
Selected Delete selected rows or the entire member list.

Select All Select all list members for modification or positioning.

Sort 
Ascending Sort a selected column in ascending or descending 

order.Sort 
Descending

Tool Function

Import names 
as TXT or 
CSV
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 Click the Name Order button if you want to change the default 
naming order. Use it, for example, to put surnames first or limit which 
names are included – e.g first and third.

 Click OK and enter reference points as prompted.

 Select all names and select Stitch > Generate Stitches or press G.
 Select names one-by-one to view them in the design.

Related topics...
 Managing teams 
 Teamname templates
 Apply baselines

Import teamname lists with additional fields

Change name
order as desired

Choose a name to 
view on-screen

Use Team Names > Import Team Members to import a list of team 
members in either TXT or CSV format. Names must be comma delimited.
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A ‘size’ field is often added to teamname lists even though it does not 
form part of the design. While the size field doesn’t appear in the design, 
it is added to each design name when generated. This allows machinists 
to ensure they are using the right size garment for the specified name.

Use Team Names > Manage Teams to manage teams and team members 
for future use.
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To view size fields in the Manage Teams dialog, first save the teamname 
file in CSV or TXT format to the Teamname Teams folder as shown. 
Don’t use sub-folders.

Open the Manage Teams dialog and select the file name from the 
Teams droplist. All fields will be imported...

Navigate to 
teamnames 
folder

Save to 
Teamname 
Teams folder
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Teamname templates

The Team Names feature allows you to use predefined layouts or create 
your own. These layouts may consist of single or multiple baselines, each 
with one or more names.

Use templates with teamname designs

When creating teamname designs, you can use a preset layout or a 
custom layout based on artwork you may have received.

To use a template with a teamname design
 Open the design you want to use.

 Click the Team Names icon to access the docker and choose the 
Designs tab. This tab includes template samples as well as any 

Use Toolbox or Docker > Team Names to select a layout for your 
teamname design.
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custom designs saved as teamname templates. These may contain 
more than one baseline.

 Choose a template on which to base your intended layout. 

Select a design 
category and choose 
a template
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 If you haven’t already entered the names, switch to the Teamname 
List and key in or import the names to use. The sample below uses 
two sets of names on separate baselines.

 Press G to generate stitching and use arrow keys to ‘nudge’ the 
lettering into position.

 Use the Teamname List to select and view individual team members.
 To reposition or modify a lettering object within a teamname object, 

first hold down the Alt key and click to select it.

Choose a name to 
view on-screen

Hold down Alt key 
to select and 
reposition
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 Edit lettering object properties as desired. 

Related topics...
 Select objects within groups
 Modifying teamname designs

Create custom templates

Typically, you will receive a brief and possibly artwork from a customer. 
Before you even import the names, you may prefer to mock up the design 
for approval purposes. This same design can then be saved as a 
teamname template.

To create a custom template
1 Import any artwork needed for your template.

Edit properties and 
apply to all as 
desired
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2 Add any lettering elements you want to use. Include any ‘static’ 
elements which won’t change in the eventual teamname design.

3 Optionally, give generic names to any text which will form part of the 
eventual teamname design – ‘TEAM NAME’.

4 Select any lettering that is to remain static – e.g. ‘Zetland Highshool’ 
– and lock by pressing the K shortcut. When the template is opened, 
the locked text will be excluded from the teamname object.

5 Select File > Save As Teamname Template, enter a name for the 
layout – e.g. ‘Zetland High’ – and click OK. The dialog opens onto the 

Key in generic 
names for eventual 
teamname objects

Select static text 
and press K to 
lock
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Custom teamname templates folder. When you save here, the design 
will appear in the Designs tab under the Custom folder.

6 To test your template, open a new design tab and click the Team 
Names icon to access the docker. Go to Designs > Custom to locate 
your template. Once opened, the unlocked text will be interpreted as 
a teamname object.

7 Edit the text as you would any other teamname template.

Related topics...
 Creating simple teamname designs
 Use templates with teamname designs

Save to custom 
templates folder

Enter template 
name

Navigate to 
teamname 
templates folder

Choose a name to 
view on-screen
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Modifying teamname designs

You can preview individual team names as they will be stitched out. Add 
or delete names, sort teamname lists, and change properties of team 
members. Set properties such as font, size or color for each name. You 
can also set properties for an entire column of names.

To modify a teamname design
 Open a teamname design and click the Team Names icon. By default 

all names are selected.

Use Toolbox > Team Names to add/remove team members and edit 
individual names.

Right-click Toolbox > Lettering to edit lettering on-screen.

Select all 
team 
members
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 Adjust positioning of the teamname group as desired.

 View team names in any of the following ways:
 Select a name.
 Use arrows keys to scroll up and down the list to view each name 

in turn.

Select name
to view

on-screen
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 Click list header to select a column of names – use Sort buttons to 
sort lists in ascending or descending alphabetical order.

 Click a cell to select an individual name in the Teamname List.

 Edit selected names on-screen as you would any other lettering object 
– e.g. adjust letter kerning.

 Adjust lettering baselines as you would any other lettering object. For 
example, select an ‘auto-frame’ style for fixed line baselines.

Click to select
column

Click again to sort 
column 
alphabetically

Select and edit 
individual 
name
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 Use the Teamname List tools to add names, delete names, change 
properties, as required:

 To view and/or edit member properties, click Object Properties.

Tool Function

Manage Teams Manage teams and team members for future use.

Remove Delete selected rows or the entire member list.

Select All Select all list members for modification or positioning.

Sort Ascending
Sort a selected column in ascending or descending 
order.Sort 

Descending

Object 
Properties

Edit properties of selected rows, columns or all list 
members.

Apply to All Copy one team member’s properties to all members.

Create Designs Create individual designs for each member.

Teamname 
Matrix

Create a matrix of all teamname designs, sequenced 
for efficient stitchout. See below.

Ben Warburton

Adjust name
settings

Edit text for
individual name

Change font
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Tip: By default a space is inserted between names. To remove this 
space, set the Word Spacing value in the Layout dialog to 0%. 

Related topics...
 Creating simple teamname designs
 Adjust spacing settings
 Editing Embroidery Lettering
 Adjust fixed-width baseline settings

Managing teams

A teamname object may contain all names in a given team, or a subset 
of those names. You can even combine members from different teams.

To manage teams
 Open a teamname design and click the Team Names icon. By default 

all names are selected.
 To save a team for future use, click the Export Team Members icon 

in the Teamname List. The dialog will open onto a public folder 

Use Toolbox or Docker > Team Names to associate multiple names with a 
design.

Use Team Names > Export Team Members to export a list of team 
members in either TXT or CSV format.

Use Team Names > Manage Teams to manage teams and team members 
for future use.
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containing all your teams – a single file, either TXT or CSV, for each 
team.

 Click the Manage Teams icon to access the dialog. The Team 
Members panel will default to the last opened team.

Enter team 
name

Dialog opens to 
Public 
Embroidery

Save to 
Teamname 
Teams folder

Manage
teams Manage 

current 
teamname list
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 To view the team you have just exported, select from the Teams 
droplist.

 Use the +Column or -Column buttons to establish the number of 
names for each team member – the default is three (3).

 Select names to associate with the design. To select multiple names, 
hold down Ctrl or Shift as you select.

 Edit the list as necessary by means of Delete and Edit buttons.
 Add team members one-by-one or as a group:
 To add a single name, click Add in the Team Members panel.

Select team

Edit names
as required

Use controls to
add, delete or

edit team
members

Add nameBen

John

Warburton
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 To add a group of names, click Quick Names. Enter names in the 
format Name 1, Name 2, Name 3.

Tip: You can type in the names, or paste them in from a text file. Each 
name must be separated by a comma. There is no need for a space.

 Click OK. The new names are added to the Team Members list. 
 Transfer names, selectively or all together, to the Teamname list 

using the arrow buttons. You can even transfer names from different 
teams to the same list.

 Edit the list as desired:
 Sort names alphabetically by column.
 Sequence names – this will determine their stitching order.
 Remove names from the list.

Prasanna,E,Nanaya

Ben,John,Warburton

Petar,Michael,Pavlovic

Ichiro,Roy,Suzuki

Khieng,,King

Sam,,Kong

Enter 
names

Adjust name
order for current

design

Use controls to
transfer names

between lists

List of names 
used in current 
design

Use buttons to 
move selected 
names
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 Click the Name Order button if you want to change the default 
naming order. Use it, for example, to put surnames first or limit which 
names are included – e.g first and third.

Outputting teamname designs

You can create individual designs from each name in a teamname design. 
Alternatively, you can create a matrix of names optimized for batch 
stitching. 

For output, you can generate machine files consisting of:
 Both design and names
 Design in one file and names in another, or 
 Design and names in individual files.

Change name
order as desired
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Create separate designs

You can create individual designs from each name in a teamname design.

To create separate designs
1 Open a design and click the Team Names icon. By default all member 

names are selected.

2 Select names to output – click Select All or use Ctrl and Shift keys 
to selectively choose.

3 To create individual embroidery designs for each team member, click 
Create Designs. Designs are generated for each name. The name is 
now a normal lettering object.

4 Save each design out individually.

Create a matrix of designs

The Teamname Matrix function allows you to create a matrix of names 
optimized for batch stitching. Minimize the number of color changes 
created by the matrix operation.

Use Toolbox or Docker > Team Names to add/remove team members and 
edit individual names.

Select
names to

output

Click to create 
individual 
designs 

Use Team Names docker > Teamname Matrix to automatically create a 
matrix of all names in a teamname object together with their corresponding 
design.
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To create a matrix of designs
1 Open a teamname design.

2 Select everything you want to include and click the Teamname 
Matrix icon in the Teamname List tools.
The number of rows and columns in the matrix are automatically 
calculated according to number of team names, row and column 
height settings, and the physical area of the hoop. More than one 
hooping may be calculated.

3 Adjust height and width settings to match the intended hoop.
4 Adjust row height and column width to set the gap for most efficient 

stitchout.
Increase settings if you want to enlarge the gap between designs. 
Calculated fields are updated, including number of rows/columns and 
output files.

Adjust row and 
column settings

Adjust hoop
width and

height

Select
stitching

sequence

Select to minimize 
color changes

Calculated rows 
and columns
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5 Select a Sequence option. Each option indicates a possible stitching 
sequence for the entire matrix.

6 Optionally, select the Minimize Color Changes checkbox. When 
selected, the entire matrix is resequenced by color.

7 Click OK. A new file is created containing the number of team names 
that will fit into the specified hoop – i.e. number of rows multiplied by 
number of columns. If needed, another file is created to accommodate 
additional names. The Output Files field indicates the total number 
of files.

Output teamname designs 

When you output a teamname design, you need to define how it is to be 
generated as a machine file. You can generate files that include:
 Both design and names in a single file
 Design in one file and names in another, or
 Individual files for each name plus design.
You set these options whenever you save the file in machine format or 
output directly to machine.

Access output options
You access the Save Options > Team Names dialog in any of these 
ways:
 Select File > Export Machine File, choose a machine file format – 

e.g. DST – from the Save as type droplist, and click Options.
 Select File > Record in Database, choose a machine file format – 

e.g. DST – from the Save as type droplist, and click Options.
 Select Legacy Features > Disk > Save As > Options.
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 Select Legacy Features > Send to Machine Manager > Options.
 Select Legacy Features > Send to Stitch Manager > Options.
 Select File > Send to Connection Manager > Options.

Output options
The following output options are available to you:

Available centering methods
The Auto Start and End feature is available to specify first and last 
stitches in a design. This makes it easy to position the needle before 

Option Function

Design and team 
names, with 
Stops

Creates a single machine file including one copy of the design 
and all names. Stops are inserted after the design, and 
between the names – i.e. Design Stop TeamMember1 Stop 
TeamMember2 Stop, etc.

Repeated design 
and team names, 
with Stops

Creates a single machine file with multiple copies of the design, 
and all names. Stops are inserted after each static 
design/name combination – e.g. Design + TeamMember1 Stop 
Design + TeamMember2 Stop.

Create multiple 
output files

Creates separate files for each name, each of which includes 
a copy of the static part of the design. When stitching to ES 
Machine Manager, each file is queued separately.

Design part only Creates a file containing only the static part of the design.

Team names only, 
with Stops

Creates a single file containing only the names, separated by 
stops. This means that after each machine stop, you can 
change frames.

Auto start/end method 
options enabled for all 
output options
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stitching, and reduces the chance of the needle hitting the side of the 
frame.

The trouble comes when you try to set a common start and end point for 
team names. 

Teamname designs, however, can be stitched in a consistent location on 
the garment irrespective of name length. Select either output option:
 ‘Repeated design and team names, with Stops’, or
 ‘Team names only, with Stops’.
And select one of the nine Auto Start and End preset end points. 
The purpose of auto-alignment is to allow ‘name frame’ layouts and 
optional repeated designs to be stitched in a consistent location on the 
garment where names are of varying lengths.

Method Description

Auto Start and 
End

Auto Start and End is automatically turned on during Team 
Names output, defaulting to Center-Center. Select one of the 
nine preset end points. 

Return to Start 
Point

Creates a connecting stitch from the end point to the start point.

Use Digitized 
Auto Start/End 
Point

This option is primarily used with multi-decoration designs 
where you want to strictly define the start/end point of the 
embroidery component. It is only available if there are already 
digitized start and end points in the design.

Auto alignment off Auto alignment on
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Related topics...
 Send designs to Stitch Manager
 Setting auto start & end
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Chapter 29

Monogramming

A monogram is a design composed 
of one or more letters, typically the 
initials of a name, used as an 
identifying mark. The 
Monogramming feature offers a 
simple way to create personalized 
monograms using a selection of 
predefined monogramming styles, 
border shapes and ornaments, 
together with a set of tools to help 
you place these elements in creative 
and decorative ways.
This section details the creation of 
monogram lettering with initials or 
with a name, how to add ornaments 
to monograms, and how to create ornament layouts.

Monogram designs

You build monograms using the Monogramming docker. The simplest 
way to get started is to select a monogram template from the Designs 
tab. This tab gives you a selection of design templates ranging from 
lettering only, with borders or with ornaments. The Custom folder 

Use Toolbox > Monogramming to create personalized monograms using a 
selection of predefined monogramming styles, border shapes and 
ornaments.
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contains your custom templates. Select a design template from the 
display panel and modify as required via the other tabs.

Note that the monogramming design is grouped in the Color-Object 
List docker. It is treated as a single, composite object. It can only be 

Select monogram type and
choose a design template Use Custom 

folder for custom 
designs
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edited via the Monogramming docker. It cannot be ungrouped but it can 
be broken apart into its components. See also Breaking apart lettering.

However, if all you want to do is recolor monogram elements, you can 
select them individually without breaking apart the monogram. Simply 
hold down Alt and click the object.

If you want to save a design as a template for future use, use the File > 
Save as Monogram Template command. The dialog opens onto the 

Monogram grouped as
composite object

Break apart 
composite 
objects

Use Alt key to
select and

recolor
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Custom monogram designs folder. When you save here, the design will 
appear in the Designs tab under the Custom folder.

Monogram lettering

The Letters tab of the Monogramming docker allows you to create 
personalized monograms with initials, including special characters and 
symbols, or unlimited lines of characters.

The Letters tab provides similar options to the Lettering tab of the 
Object Properties docker. If you are using one of the template designs, 
the easiest way to adapt it is to apply a different style. Change initials as 
required and choose from any number of native embroidery fonts or any 

Enter a name for your
custom template

Use Toolbox > Monogramming to create personalized monograms using a 
selection of predefined monogramming styles, border shapes and 
ornaments.
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TrueType font installed on your system. In addition, this tab provides a 
selection of styles to choose from.

In place of single letters, the same tab allows you to enter multiple lines.

If a selected style doesn’t quite give you what you are looking for, open 
the Advanced panel to access more settings. Use these to adjust letter 

Choose 
lettering style

Choose 
lettering font

Enter multiple 
lines of text
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width, spacing, etc. Adjust letter rotation and baseline angle. These allow 
you rotate individual letters or the entire baseline.

Click Properties to make any further adjustments – e.g. stitch type. The 
default values for monogram lettering are different from those for 
conventional lettering. All settings can, however, be controlled via the 
Object Properties docker. See also Create lettering with object 
properties.

Monogram ornaments

Ornaments can be added to a monogram either from motif patterns or 
from any design file. You have a choice of:
 Adding ornament motif patterns or designs
 Creating single ornament layouts
 Creating multi-ornament layouts.

Modify ornaments

If you are using a template design or adapting another monogram, it is 
a simple matter to change the ornament to a different type or 

Access advanced 
settings

Access full set of 
object properties

Use Digitize > Monogramming to create personalized monograms using a 
selection of predefined monogramming styles, border shapes and 
ornaments.
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configuration. Use the buttons at the top of the Ornaments tab to add, 
delete, or change ornaments.

Choose from a range of preset placement patterns, including Mirrors, 
Duplicates, and Cycle. Note that the pyramid icon indicates not only the 
placement but also the orientation of the pattern in both horizontal and 
vertical planes.

Add, delete, or change 
ornaments

Choose preset 
placement pattern
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If the preset pattern gallery doesn’t quite give you what you are looking 
for, open the Advanced panel. These settings give you precise control 
over ornament placement, size, rotation, orientation, and margin.

Add ornaments

You can add up to ten ornament sets to a monogram design and change 
them at any time. Any available motif set can be used. 

Access advanced 
settings

Fine-tune ornament 
placement, size, 
rotation, orientation, 
and margin

Choose ornaments
from any available

motif set
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A set of ornamental designs is also available. These are stored in their 
own Ornaments folder.

Use the checkboxes to add up to eight instances of a selected ornament. 
These are arranged according to ornament placements relative to the 
lettering.

The first selected serves as the ‘anchor’ position (highlighted in red). All 
other ornaments are sized, rotated and mirrored in relation to it. Use the 
Width and Height fields to change ornament dimensions. The Lock 
Aspect Ratio toggle forces width and height to maintain their 
proportions. Use the Margin setting to offset ornaments from the 
lettering.

Create single ornament layouts

Use Position #5 to insert an ornament as a standalone component 
within a set. All other checkboxes are unchecked automatically. Width, 

Access advanced 
settings

Anchor position 
highlighted in 
red
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Height, and Rotate By fields and Mirror checkboxes remain available, 
and Offset controls replace the Margin control.

Use the X and Y fields in the Offset panel to position the ornament 
horizontally or vertically relative to the lettering object. These settings 
specify the position of the ornament center relative to the center of the 
lettering object.

Multi-ornament layouts

You can add up to eight instances of a selected ornament to your 
monogram. Any combination of ornaments and ornament positions can 
be used. Add the ornament sets you want and assign placements to each 
one.

Remember, if you want to recolor monogram components, you can select 
them individually without breaking apart the monogram. Simply hold 
down Alt and click the object.

Position ornament relative
to lettering object
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Monogram borders

You can add up to four borders of the same shape to a monogram design.

Use Toolbox > Monogramming to create personalized monograms using a 
selection of predefined monogramming styles, border shapes and 
ornaments.
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Change borders

If you are using one of the template designs, it is a simple matter to 
change borders. Use the Change button on the Borders tab to select 
from one of the many available.
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Adjust border shape & offset

Use the Aspect Ratio settings to adjust height and width proportions.

Use the Offset field to fine-tune margins between lettering and border, 
and between border and border.

Adjust aspect ratio to
change border

proportions
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Use the Rotate field to re-orientate the border as desired.

Add multiple borders

Add up to four borders to the selected monogram. Use the Offset field 
to adjust margins between multiple borders. The software lets you enter 
a negative offset. This allows you to create multiple overlapping borders.

Use the Stitch Type buttons to change to line or fill stitch type for 
selected borders. Satin Line is the default stitch type. All line and fill stitch 



Chapter 29   Monogramming 728

types available in the software can be used as borders. Click the 
Properties button to make further adjustments.

Remember, if you want to recolor monogram elements, you can select 
them individually without breaking apart the monogram. Simply hold 
down Alt and click the object.
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Chapter 30

Custom Lettering

Turn any TrueType font installed on your system into an embroidery font. 
Sometimes you find that you want to reshape a letter to improve its 
appearance, perhaps to suit a particular lettering height. 
EmbroideryStudio lets you save the letter as an alternative version. You 
can even create custom fonts or modify an existing font for special 
applications. Even merge letters from two or more fonts.

This section describes how to create new embroidery fonts from TrueType 
fonts. Automatic letter kerning and user-refined fonts are explained. It 
also describes how to create, modify, and merge your custom fonts and 
letters.

Converting TrueType fonts to embroidery

The Convert TrueType Font feature lets you convert any TrueType font 
installed on your system to an embroidery font. You can do this 
‘on-the-fly’ or convert entire fonts for later use. This is an important 
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feature for Asian fonts which may contain several thousands of 
characters.

The process is fully automatic. Lettering shapes are ‘cut’ into Column A 
or Column B embroidery objects. Overlaps and stroke order are detected 
and stitch angles defined. The result is similar to manually digitized fonts 
although the quality may not be quite as good. The quality greatly 
depends on the original shapes, narrower serif type fonts producing 
better results than blocked fonts.

Tip: The simplest option for creating custom embroidery fonts is to use 
the built-in Convert TrueType Font feature. This lets you convert any 
TrueType font installed on your system to an embroidery font. See 
Custom Fonts for details.

Convert letters on-the-fly

You can convert individual TrueType letters ‘on-the-fly’ and add them 
directly to a design through the Object Properties docker.

Tip: If your product level allows it, you can add and format TrueType 
lettering in CorelDRAW Graphics. This can then be converted to either 
embroidery lettering or embroidery objects.

Use Toolbox > Lettering to add TrueType lettering directly on-screen. 
Right-click to set the formatting values for new or selected lettering objects.
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To convert TrueType letters on-the-fly
1 Right-click the Lettering icon to access object properties.

2 Select a TrueType font from the droplist.
3 Enter the text you want to embroider.
4 Optionally, click TTF Conversion to adjust conversion settings. 

Whenever you choose a TrueType font in the Object Properties 
docker, calculated settings are used by default. As always, conversion 
settings can be further refined by the user.

Select TT font

Set conversion
values

Enter text

Select lettering
style

Select Complex
Fill for fixed stitch

angle

Select Turning
Strokes for variable

stitch angle
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5 Click OK to return to the Object Properties > Special > Lettering 
docker.

6 Select a baseline, adjust letter height and spacings, and click Create 
Text.

7 Click an insertion point to create text on-screen.

Related topics...
 Converting & editing TrueType fonts
 Experiment with conversion settings
 Refine turning stroke options
 Creating lettering with CorelDRAW Graphics

Convert TrueType fonts

The Convert TrueType Font feature lets you convert any suitable 
TrueType font installed on your system into an embroidery font. 
Converted letters can be filled with parallel or turning stitches. 
Conversion happens fairly quickly, although Asian fonts may take longer.
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To convert a TrueType font
 Select Setup > Convert TrueType Font. The Convert TrueType 

Font dialog opens.

 Select the font to be converted and font style. The entire embroidery 
font will be created in the selected style.

 Enter a Font Name if you want to override the default.
 Choose whether to convert All Characters or Extended ASCII 

character sets. The standard character set contains alphanumeric 
characters only. It excludes punctuation marks and other special 
characters.

Select font
Select font 
style

Set values

Enter font
name

Choose 
character set
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 Optionally, click Conversion Settings to adjust conversion settings.

 Specify whether to convert as Turning Strokes or Complex Fill.
This will depend in part on font type – whether serif or non-serif, 
whether script or block. If you want stitching to follow letter contours, 
select Turning Strokes. The Complex Fill option provides a single 
fixed stitch angle.

 With the Turning Strokes option, there are many more settings. 
Presets are automatically adjusted according to selected font 
characteristics – e.g. whether serif or sans serif, whether block or 
script. Try the defaults to start with.

 Click OK.
 To check, right-click the Lettering icon to open the Object 

Properties > Special > Lettering docker. The newly converted font 
will be selected by default and available for use.

Note: Custom fonts are saved in ESA format to the ‘Fonts’ folder within 
the Windows ‘ProgramData’ folder. They can be copied and distributed for 
use by others. If you want to adjust converted characters or add special 
characters to a custom font, you can do so via the Create Letter 
function.

Related topics...
 Converting & editing TrueType fonts
 Refine turning stroke options
 Edit & repackage generated letters

Select lettering
style

Select Complex Fill
for fixed stitch angle

Select Turning
Strokes for variable

stitch angle
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 Custom asset locations

Creating user-refined letters

Sometimes you find that you want to reshape a letter to improve its 
appearance, perhaps to suit a particular lettering height. 
EmbroideryStudio lets you save the letter as an alternative version. In 
fact you can save multiple versions of the same letter within the same 
font. Each version can have a unique height range. When using the letter 
in a design, the height setting will automatically determine which version 
is used. The feature thereby allows you to permanently record fixes to 
particular lettering problems and thereafter automatically apply them.

Note: The software preserves all user-refined letters when a new version 
is installed. Only factory default letters are overwritten.

Save user-refined letters

User-refined letters are saved via the Create User-Refined Letter 
option. This is enabled only if a native letter or converted TrueType font 
letter is currently highlighted in the design window or selected in 
Reshape mode. One and only one letter may be saved at a time.

To save a user-refined letter
1 Create a lettering object with an embroidery font. 
2 Size the object and reshape the letter as required. The Stitch Angle 

and Reshape Object tools let you add, delete, or adjust stitch angles.
In the example below, the letter ‘a’ tends to close over at reduced 
sizes. You may want to open it up. By saving it as a user-refined letter, 

Use Reshape > Reshape Object to reshape selected objects, edit stitch 
angles, and adjust start/end points.
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any changes made will be automatically applied to new lettering 
objects using the font in the specified size range.

3 Still in Reshape mode, select the modified letter by clicking the 
diamond control point.

4 Select Object > Create User-Refined Letter.

5 Set a height range for the letter:

Option Function

All The letter will be used at all letter heights (effectively replacing 
the factory default).

Greater than The letter will only be at heights greater than that specified.

Less than The letter will only be at heights less than that specified.

Letter ‘a’ opened up at 
smaller size

Default ‘a’ too narrow at smaller size

Select modified letter

Name the new 
version

Specify the 
height range
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6 Give the new letter a unique name that you can easily identify – by 
default, the new version is given the name ‘User 1’.

7 Click OK.

8 To apply changes to all the same letters in the selected object, select 
the Use saved version checkbox in the Object Properties > 
Special > Lettering docker.

Related topics...
 Creating Embroidery Lettering
 Reshape letters
 Adjusting stitch angles
 Select embroidery fonts

Manage user-refined letters

User-refined letters are managed via the Manage User-Refined 
Letters option. This menu item is only enabled when a lettering object 
with a font containing user-refined letters is currently selected.

To manage user-refined letters
 While the letter is selected, select Setup > Manage User-Refined 

Letters.

Modified
letter ‘a’

Default letter ‘a’

Changes applied to 
both letters

Select to use 
user-refined letters
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The original factory default letter is identified by the name ‘Factory’. 
For converted TrueType font letters, the word ‘Convert’ appears 
instead of ‘Factory’.

 Use left/right arrow buttons or droplist to select a user-refined letter.
 Click and rename any version except ‘Factory’ or ‘Convert’.
 Delete any selected version name except ‘Factory’.
 Untick the Use checkbox if you want to temporarily exclude a letter.
 Swap height ranges with the Move Up/Down buttons and adjust 

them by means of slider bars.

Creating custom fonts

EmbroideryStudio provides methods for defining custom embroidery 
fonts. You can digitize letters from backdrop images, convert vector 
objects, or digitize freehand using any of the input method tools. You can 
use artwork from sources such as calligraphy books. You can also copy 
characters and symbols from the MS Windows® Character Map into an 
external graphics program. Here you can modify them as you like, save 
them to a graphics file, and use it as a design backdrop. See also Use the 
Character Map.

Note: You can also create new embroidery fonts by converting TrueType 
fonts. See also Converting TrueType fonts to embroidery.

Custom font considerations

You can use artwork to create letters in the same way you do other 
objects. Before digitizing, however, establish whether the letter shapes 

Swap height ranges 
by moving selected 
version up or down

Adjust height range for the 
selected letter version 

Select letter version to
include in font

Scroll to next or 
previous letter

Click and
rename version

as required
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are suitable for embroidery, and determine reference height and baseline 
for the font. Letters are generally 20 to 40 mm in height.

Caution: Because of copyright laws, you cannot simply select letters 
from an existing embroidery font and save them to another font.

Letter shapes
For best results, letter columns should be of similar width, without tight 
curves or sharp corners, or very fine, very wide, or curved serifs.

Reference height and baseline
Reference height is the maximum height of capital letters. Although there 
may be subtle differences between upper and lower case letters, it is a 
useful guide for digitizing. Place letters along a standard baseline to help 
digitize at a standard height. Draw in the baseline if you are digitizing 
from artwork, or use a grid line as your guide. Descenders in letters such 
as y or g generally fall below the baseline.

Tip: Use E or H as reference letters to determine the height and baseline 
for the font. These letters work well because they sit on the baseline and 
do not extend above the standard cap-height.

Corners too sharp

Differences in column
width too great

Serifs too long and fine

Letter
height

Baseline
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Letter spacing and width
Letter width varies with letter shape and spacing. When you digitize 
letters, you enter two reference points to mark the width, and a third to 
mark height.

Default spacing affects ‘kerning’ or spacing across all letters. Additional 
width can be added as spacing around individual letters.

Tip: For italic styles, you may need some overlap between letter extents.

Letter sequencing
Letter stitching sequence is based on the join type you select when 
saving the font. If you use the Closest Join or Bottom Join methods, 
EmbroideryStudio applies automatic branching to letters. In this case, 
you don’t need to worry about the direction individual letter strokes will 
stitch in. When branching is applied, EmbroideryStudio determines where 
each stroke starts and ends, adding travel runs as necessary. 
However, it is good practice to digitize strokes in the direction they are 
most likely to be stitched in. It is also important to specify the stroke 
order as this is maintained when sequencing is calculated.
If you want to specify the stitching sequence and connectors yourself, 
digitize the letter exactly as you want it stitched. You then need to select 
As Digitized as the join method.
The lettering stitch method should be preset to give the best results for 
each font. In most cases, Closest Join is recommended in order to 
minimize trims. Bear in mind though that the join method can be changed 
by the end user.

Related topics...
 Change lettering join method

Letter width

Letter width

Spacing 
increased
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Create custom letters

You create or modify letters for a custom font just like other embroidery 
objects. Custom letters can be made up of multiple objects, and may be 
letters, numbers, symbols or even pictures. To change the shape of an 
existing letter, you must first break it apart. The letter reverts to 
embroidery objects, and letter properties such as font type and baseline 
are lost. When you have finished modifying, you have to enter these 
details again.

To create a custom letter
1 Import the starting point for your custom letter. You can use various 

methods:
 Import and size suitable artwork. Letters are generally 20 to 40 mm 

in height. 
 Select a TrueType font in CorelDRAW Graphics, key in the letter or 

letters you want to use, and switch back to Wilcom Workspace.
 Pre-convert an entire TrueType font using the Convert TrueType 

Font feature.
 Select an existing embroidery font and key in the letter or letters 

you want to use. 
2 If you use an existing embroidery font as a starting point, you must 

first Break Apart to revert the letter to normal embroidery objects. 
Letter properties such as font type and baseline are lost.

3 Select an input method.
 If you are digitizing the sequence and connectors manually, use any 

input method.
 If you want the letter to be automatically resequenced with Closest 

Join or Bottom Join, use Column A, Column B, Column C and 
Complex Fill objects.

4 Select a stitch type. Most letters use satin or tatami.
5 Digitize each section of the letter.

Use Edit > Break Apart to split composite objects – monograms, appliqués, 
lettering, etc – into component objects.

Use Reshape > Reshape Object to reshape custom letters.
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 Create an ‘underlap’ to bind two strokes together. Underlaps should 
be about a third of the stroke width or less, but may be half for thin 
strokes.

 Try to avoid having more than two strokes on top of each other as 
this causes thread buildup and can lead to thread breaks. 
Sometimes modifying the shape can improve it.

 Sometimes it is helpful to angle the ends of underlaps so that a few 
stitches are ‘caught’ by the overlapping stroke.

 Where a stroke crosses another stroke, such as in the letter t, one 
stroke is commonly broken into two parts. For thin objects, you 
may digitize the above stroke in one piece, crossing over or under 
the other.

Underlaps

Overlap / 
underlap



EmbroideryStudio e4 Reference Manual 743

6 Adjust existing outlines using the Reshape Object tool if necessary.

7 When the letter is the correct shape, you can now save it as a custom 
letter.

Related topics...
 Insert bitmap images
 Convert TrueType fonts
 Reshape letters
 Break apart composite objects
 Save custom letters

Save custom letters

When you create a new letter, you need to select a font for it, give it a 
name, specify its height, and indicate whether to preserve any machine 
functions. You also need to indicate its spacing settings by digitizing 
reference points on-screen.

Caution: Do not use the tilde (~) symbol when naming letters. This is a 
special character for entering letters with multiple-character names.

To save custom letters
1 Select the objects that make up your newly digitized or modified letter.

Reshape objects

Select whole 
character
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2 Select Object > Create Letter.

3 Select a font from the droplist.
4 Enter a name for the letter in the Letter field.

For example, if you digitized the letter H, enter ‘H’ in the Letter field.

Tip: You can create names with multiple characters to identify special 
letters – e.g. ‘Star’ for a star symbol, or ‘e-acute’ for é.

5 In the Reference Height field, enter a height for the letter.
The letter is recorded at this height regardless of its original size. You 
can also set height on-screen by selecting the Digitize Reference 
Height checkbox. When you return to the design window, you are 
prompted to digitize the height. If you select Digitize Reference 
Height, the value in the Reference Height field is ignored. Letters 
are generally 20 to 40 mm in height.

6 Deselect Remove Functions only if you want to keep any machine 
functions in the object.
The letter may, for example, include deliberate color changes or other 
machine functions. Such letters require the As Digitized join type.

7 Click OK.
8 Click to mark two reference points for letter width and baseline.

The distance between reference points determines the letter width, 
including any spacing either side of the letter. This then determines 
‘standard spacing’ between letters. 

Note: The reference points you digitize also determine where the 
letter sits on the baseline.

Enter reference height

Enter letter name

Select font

Select to set height on-screen

Deselect to include functions

1 2

1 2 1 2



EmbroideryStudio e4 Reference Manual 745

9 If you selected Digitize Reference Height in the Create Letter 
dialog, you are prompted to digitize a third reference point to mark 
letter height. 
A message confirms that the letter has been saved to current font.

Related topics...
 Select custom fonts
 Create custom letters
 Save custom fonts
 Select custom fonts
 Change lettering join method
 Letter spacing and width
 Reference height and baseline

Save custom fonts

Use custom fonts to store any letters you create. To make a new font, 
you name it and set the default spacing and join type for adjacent letters. 
You also specify the file type.

To save custom fonts
1 Digitize the objects that make up the new letter, and select them.

2 Select Object > Create Letter.

Select whole 
letter

Click to create 
new font

My Font
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3 Click Create. The Create Alphabet dialog opens.

4 Enter a name for your new font.
5 Enter spacing in the Default Letter Spacing field. As a rule of 

thumb:
 Use 8-10% for standard fonts such as block and serif styles.
 Use 0% for script-style fonts.

6 Select a method of joining adjacent letters in the Default Join Type 
list. 

Note: The lettering stitch method should be preset to give the best 
results. In most cases, Closest Join is recommended in order to 
minimize trims. Bear in mind though that the join method can be 
changed by the end user. 

7 Click OK.
8 Enter additional values for the selected letter in the Create Letter 

dialog.

Related topics...
 Create custom letters
 Change lettering join method
 Save custom letters

Option Function

As digitized Preserves the original stitching sequence of each letter as it 
was digitized, as well as any stitch types and machine 
functions used in its creation.

Closest join Resequences entry and exit points in adjacent letters to join 
them at the closest point.

Bottom join Resequences entry and exit points in adjacent letters to create 
a connector along the lettering baseline.

Enter font name

Enter default spacing

Select join method
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Select custom fonts

To use a custom font, select it like any other font. If a letter has a 
multi-character name, you can only access it from the Lettering dialog 
using the special tilde (~) symbol.

To select custom fonts
1 Right-click the Lettering icon to access object properties.

2 Select a custom font from the droplist.
3 Enter the names of the letters you want to use in the text box.
 If the letter name is a single character – e.g. ‘A’ – enter that 

character.
 If the letter name consists of more than one character – e.g. ‘Star’ 

– enter a tilde (~) followed by the letter name.

Tip: Combine letters that use single or multiple characters in their 
name by prefacing the single character with two tildes – e.g. 
~Star~~A~Star. 

4 Set the formatting values as you would for other lettering objects. 

Right-click Toolbox > Lettering to select a custom font.

My FontSelect custom
font
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Manage fonts

Modify custom fonts by changing names, default letter spacings and join 
types. If a font is no longer required, delete it. To modify fonts, select 
Setup > Manage Alphabets. 

Use this dialog to:
 Rename a custom font.

 Delete a font.
 Change default letter spacing. 
 Change the default join type.
 Delete or rename selected letters. You can use names with more than 

one character.

Related topics...
 Adjust spacing settings
 Setting stitching sequence & join method

Select font Click to 
rename fontMy Font

Select letter

Enter new 
name

New Font Name

Enter new 
name

My New Letter
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Merging fonts 

You can merge letters from two or more fonts with the stand-alone font 
merging utility. Files to be merged must be placed in the 
EmbroideryStudio userletw folder of your installation.

To merge fonts
1 Select Start > Programs > MS-DOS Prompt.
2 When the command prompt appears, change to the BIN directory of 

your EmbroideryStudio installation. This is usually:
C:\Program Files\Wilcom\EmbroideryStudio_e4.5\BIN

3 Choose whether to automatically overwrite or receive prompt.
 To automatically overwrite the letters in the first file with letters of 

the same name from the other file(s), type: 
alphcat.exe file1.ESA file2.ESA file3.ESA.

 To receive a prompt message before a letter is overwritten, type:
alphcat.exe file1.ESA file2.ESA file3.ESA /Y. 
Press Y or N to confirm whether to overwrite.

4 Click Yes to merge.
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Chapter 31

Lettering Kiosk

EmbroideryStudio provides an easy-to-use Kiosk capability for cap and 
other embroidery. The lettering kiosk is primarily intended for use at 
retail outlets where fast and simple personalization of standard design 
layouts is required in consultation with customers.

The benefits to retail staff are:
 Minimal training time
 Minimal production errors
 Improved customer satisfaction
 Increased productivity
 Easy configuration for changing requirements
 Support for several brands of machine
 Simplicity of kiosk mode together with full embroidery lettering 

capabilities for supervisors.
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The lettering kiosk provides a set of predefined design layouts and the 
ability to easily personalize them by modifying text and color. You can 
create your own layouts as well. Designs can be sent to machine from the 
kiosk via a single button press.

Operations summary

Here are some steps to get you up-and-running quickly with the lettering 
kiosk.

Configure the kiosk settings
1 Run the EmbroideryStudio software:
 You need the Kiosk Element enabled.
 There is no special setting required for kiosk mode.

2 Configure the kiosk design layouts:
 Located under C:\Program 

Files\Wilcom\EmbroideryStudio_e4.0\Kiosk\Designs
 Set palette colors in the design layouts to match the thread colors 

and needle assignments used on your machines. See Set up thread 
colors for details.

 Check the fonts and stitch settings being used.
3 Configure the machine connections for the kiosk:
 Select Setup > Connection Manager Setup.

4 Configure the kiosk password:
 Select Setup > Options > Kiosk.
 Enable ‘Lock Kiosk’.
 Set a password.

5 Configure character count limits. See Configure kiosk character count 
limits for details.

Switch to and from kiosk mode
1 To switch to kiosk mode, select menu command Window > Kiosk…
2 Type the kiosk password to enter into kiosk mode.
3 To close the application while in kiosk mode, click on the red X button 

in upper right corner.
When you restart EmbroideryStudio, it will automatically re-start in 
kiosk mode directly.

4 To return to the EmbroideryStudio screen, click Exit Kiosk and key in 
the password if prompted.
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Operate the software in kiosk mode
1 Select a layout from the design chooser.
2 Key in a name. Lettering adjusts to fit the allowed space. By default, 

a maximum of 16 characters is allowed. See Configure kiosk character 
count limits for details.

3 Change fonts by selecting a different design layout.
4 Select a thread color.
5 When finished, click a button to send the design to the machine:
 Stitching starts and ends at the bottom center of the allowable 

embroidery area.
 The design is auto-rotated 180° for the machine, according to 

connection settings. See Set up machine connections for details.
 A machine file is created and sent to the folder set in the 

Connection Settings dialog.
 The file name uses the text to be embroidered.

6 Click Start Again for the next name.

Operating modes

The Lettering Kiosk has all the capabilities and functionality of a 
commercial kiosk system together with EmbroideryStudio embroidery 
functionality.

Screen modes

In Wilcom Workspace mode, supervisors can use the full range of 
software capabilities to fine-tune settings. All adjustments can be saved 
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to a template ready for use when the software is run in kiosk mode. 
Onscreen help is available via the Help menu.

Kiosk screen mode
A password configuration setting allows supervisors to bypass the 
EmbroideryStudio screen and run the software in kiosk mode by default. 
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Operators normally work in this screen and never need to leave it. In fact, 
they cannot exit without, optionally, a supervisor password.

Kiosk mode includes a 56-color default palette together with a number of 
packaged designs. However, in practice you will want to limit the palette 
to the colors available on your machines. The screen is divided into three 
functional areas apart from the banner at the top.

Choose design panel
The Choose Design panel is positioned on the left side. It contains a set 
of predefined design layouts to choose from. It is easily extensible with 
other supervisor-created designs.

Working design area
A working design area in the middle is optimized for 1366 x 768 
resolution. It includes a dotted line indicating the maximum stitching 
boundary.

Design chooser
panel

EmbroideryStudio
Kiosk title banner

Design work
area

Customization
panel

Selected design
shown within

allowable stitching
boundary
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Customization panel
The customization panel on the right allows the operator to easily 
customize designs by changing color and text of the selected layout. The 
supervisor can pre-configure the number and values of standard colors 
to match the thread color setup on the machines. Custom designs can be 
sent to one of several attached embroidery machines.

Send to machine
Machines are pre-configured by the supervisor – typically up to 6. 
Color-coded buttons easily identify machine by number and machine 
name. The supervisor can set color-coded icons for each machine brand. 
For example:
 Brother - Cyan
 Barudan - Navy Blue
 SWF - Red

Normal Kiosk operation

Once in kiosk mode, typical operation will flow as follows.

To operate the kiosk
 Choose a design layout from prepared templates in the left panel.

Choose a
design layout
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 Enter a new name in the text field and press Enter.

This text automatically replaces default text. By default, a maximum 
of 16 characters is allowed.

 Click in design window and zoom in / out by the following means:
 Press 1 for actual size.
 Press 0 to show all.
 Use the mouse scroll wheel to zoom.
 Click Start Again to return to default view.

 Choose a thread color from the list of available colors.
You can switch layouts and colors as desired and text will be 
preserved.

Default 9-color
design palette

Enter new
name

Send design to
a machine

Input text
replaces default

text

Template
switched
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 When you are satisfied with the design, press a Send to Machine 
button. A separate button is present for each machine configured on 
the system.

 Press Start Again to create another design. The current design is 
automatically saved to the watching folder with a filename equal to 
text name. 

Note: If the operator does not press Start Again but instead selects 
a new design layout, the new design overrides the current one, 
preserving any typed text.

 To exit kiosk mode altogether, press the lock icon. Normally you are 
prompted for a supervisor password. 

Related topics...
 Set up machine connections
 Configuration options for supervisors

Troubleshooting long descenders

Some characters may extend slightly beyond the allowable stitching 
area. This usually happens with script fonts or characters with long 
descenders or ascenders such as the ‘k’ in this example. This problem is 
easily fixed by adding a space after the final character.

Creating two-line lettering

Kiosk mode allows two-lines of text to be entered and edited. The text 
box in the control panel supports single- or multi-lines depending on the 
selected layout. Two-line layouts need to be predefined and saved to the 
designs folder. When using a multi-line layout, the first Enter keypress 

Add space after 
final character

Long descender 
extends beyond 
stitching area
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will create another line. The next will confirm text entry as for a 
single-line layout.

Note: If you switch design layouts, the system will attempt to preserve 
user-entered text between single- and multi- line designs. For example, 
switching from single to double, the original line of text will be copied to 
the first line. The second will be empty.

Personalizing monograms

The lettering kiosk also supports customization of monogram objects. 
Only text can be changed in Kiosk mode. Monogram templates can be 
created and added to the kiosk.

Edit two-line 
design layout

Personalize 
monogram text
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Configuration options for supervisors

When first running EmbroideryStudio e4, supervisors have access to 
EmbroideryStudio operations. In this mode, they can use the full range 
of software capabilities to fine-tune settings. Primarily, supervisors are 
concerned with:
 Creating a password for the kiosk
 Setting up machine connections
 Setting up thread colors
 Configure kiosk character count limits

Create kiosk passwords

Supervisors can lock the kiosk to protect against unauthorized use. They 
can later temporarily unlock the kiosk in order to edit designs or change 
other settings.

To create a password for the kiosk
1 Click the Options icon or select Setup > Options. Click the Kiosk 

tab.

2 Enter a secure password and click OK.
3 Select Window > Kiosk start the kiosk. You will be prompted to enter 

the password.

Use Standard > Options to access application options for kiosk and other 
settings.

Tick to lock kiosk
and activate

password
Enter 
password for 
kiosk access

Enter
password for
kiosk access
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Note: You can return to Options dialog at any time to change or 
remove password protection. If you forget the password, you will need 
to run the Revert program from the EmbroideryStudio program group 
to restore factory defaults.

Set up machine connections

Connection Manager allows you to connect to most later model 
machines. These machines often require files to be placed in a specific 
network location or ‘watching folder’. Once set up in EmbroideryStudio, a 
single click from the kiosk is sufficient to send the design to machine. 
Each configured machine:
 has a unique name and assigned button
 has a unique folder to which designs can be sent so they can be 

accessed from the machine control panel or third-party connection 
software.

To set up machine connections
1 Select Setup > Connection Manager Setup.

Run Revert to 
restore defaults

Click to create a 
new connection
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2 Click Create to set up a connection. The Connection Settings dialog 
opens.

3 Make sure the connection type is set to ‘Machine Folder’. Watching 
folders should already have been set up for each machine on the 
network.

4 Enter a unique machine name – e.g. ‘Brother PR600 Mach 1’.
5 Choose a colored icon from the droplist to identify the machine in kiosk 

mode.
6 Select the file type required by the machine. Each machine type uses 

a different file format:

7 If the file type requires it – e.g. PES – click the Options button to 
preset file options such as version type.

8 Enter or browse to a folder location on the network or PC which has 
been set up for the specific machine. When you output a design, 
Connection Manager saves it to this folder in the specified file 
format.

9 If the machine is intended for cap designs, tick the Rotate design by 
180° option.

10 Click OK when complete.

Enter unique 
machine name

Select
connection type

Select file type 
required by machine

Set ‘watching
folder’

Choose a color to 
identify the machine

Tick if the machine is 
to be used for cap 
production

Machine Format

Brother PES

SWF DST

Barudan U??
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11 Repeat as many times as you have machines to connect. Connections 
can be edited or removed at any time.

New machine connections appear as prominent buttons in the 
customization panel of the kiosk.

Set up thread colors

Thread colors are set up for each design layout. All three sample designs 
need to be edited according to the requirements of your machine setups.

Delete or edit 
connections as 
required

Color-coded
machine buttons

Use Standard > Open to open an existing design.

Use Standard > Save Design to save the current design. Right-click to open 
the Save As dialog.
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To set up thread colors
1 Click the Open icon. The Open dialog opens.

2 Navigate to the Designs folder of your EmbroideryStudio e4 
installation:
C:\Program Files\Wilcom\EmbroideryStudio_e4.0\Kiosk\Designs
Alternatively, specify your own folder.

3 Select a design to edit and click Open.
4 Use the Color Palette tools to add or remove colors according to the 

thread setup on your machine/s.

Navigate to
Design folder

Add or remove colors

Open Editor
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5 Open the Threads docker and select your thread chart.

6 Assign threads to the palette with the Match All button. Alternatively, 
select threads corresponding to the thread setup on your machine, 
and assign these. The design layout defaults to the first color in the 
palette. The tooltip tells you the corresponding thread of each color.

7 Click Save to save the file in the design folder. The modified palette 
for this design will appear in the kiosk when you next run it.

Related topics...
 Change design location

Click to open
thread charts

Assign preferred 
thread chart/s

Default color
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Configure kiosk character count limits

Different scenarios may lead to variations in the number of characters 
allowed. The commercial requirement is for 16 characters per line, but 
the software allows you to change that limit. For example, maximum 
characters when buying online may be limited to 10, while baby-size caps 
may be less than 16. Optionally, the supervisor can limit the number of 
characters allowed in kiosk mode.

Note: Spaces between words count as characters. However, extra spaces 
are allowed at the start and end of a line without compromising the 
character count.

To configure the kiosk character count limit
 Click the Options icon or select Setup > Options. Click the Kiosk 

tab.

 Tick the Restrict number of characters option and set the 
maximum number of characters – e.g. 16.

Use Standard > Options to access application options for kiosk and other 
settings.

Tick to restrict
text length

Set character 
limit
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When the number of characters is limited by this option, the kiosk 
shows the number used vs the number available – e.g. ‘5 / 16’. Where 
a two-line design is selected, the limit is shown for each line.

Related topics...
 Troubleshooting long descenders

Change design location

The default kiosk design folder is located within the EmbroideryStudio e4 
folder structure. This may not be convenient for you if you are dealing 
with numbers of custom designs. You can easily change the folder 
location to any on your kiosk hard drive or network. If you have more 
than one kiosk set up, they can all reference the same design folder.

To change the design location
 Click the Options icon or select Setup > Options. Click the Kiosk 

tab.

 Tick the Custom kiosk design folder option and browse for the 
folder on your local drive or network. This then becomes the default 

Kiosk shows number 
used vs number 
available per line

Use Standard > Options to access application options for kiosk and other 
settings.

C:\My Kiosk DesignsTick to activate
custom Design

folder

Browse for 
folder location
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kiosk design folder. Any EMB designs kept in this location will appear 
in the kiosk design chooser.

Customize kiosk banners

Like the kiosk Design folder, the default kiosk banner is located within 
the EmbroideryStudio folder structure. If you want to modify the banner 
in any way – e.g. with a specific location name – it is a simple matter to 
access the banner and update it. Alternatively, you can copy the modified 
banner to a separate location on your kiosk hard disk or network location 
and reference it there. If you have more than one kiosk set up, they can 
all reference the same banner.

To customize the kiosk banner
1 Navigate to the ‘Kiosk’ folder of your EmbroideryStudio e4 installation:

C:\Program Files\Wilcom\EmbroideryStudio_e4.0\Kiosk\
Here you will find the default kiosk banner – dimensions 1200 x 100 
pixels.

2 Customize the banner as required:
 Either replace the current image with one of the same dimensions.
 Edit the current banner in any graphics or paint program and save 

to the same location.
 Copy the banner to the same or another location and edit as 

desired.
If you move the banner to another location, you need to update the 
software settings as follows:

Use Standard > Options to access application options for kiosk and other 
settings.
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3 Click the Options icon or select Setup > Options. Click the Kiosk 
tab.

4 Tick the Custom kiosk banner option and browse to the folder on 
your local drive or network.

5 Select the custom banner file and click Open. This then becomes the 
default banner which the kiosk will reference.

Creating custom design layouts

Various techniques are available to add your own design layouts to 
EmbroideryStudio.

Create new layouts from old

Tick to activate
custom banner Browse for 

folder location

Navigate to
folder location

Select custom 
banner

Use Standard > Open to open an existing design.

Use Standard > Save Design to save the current design. Right-click to open 
the Save As dialog.
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To create custom design layouts is not very different to setting up thread 
colors. The simplest approach is to base a new design on an existing one 
in order to preserve stitch settings and design scale. You can change 
colors, fonts and stitch settings as required.

To create a new layout from an old one
1 Click the Open icon. The Open dialog opens.

2 Navigate to the Designs folder of your EmbroideryStudio e4 
installation:
C:\Program Files\Wilcom\EmbroideryStudio_e4.0\Kiosk\Designs
Alternatively, specify your own folder. 

3 Select a design to edit and click Open.
4 Before you do anything else, select File > Save As and save the 

design under a different name.

Navigate to
Design folder
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5 Double-click the design to open its properties.

6 Edit the default text and select an alternative font from the droplist as 
desired.

7 Click the Update Text button to view the result on screen.

8 Change default thread color as desired. The design will appear in the 
kiosk design chooser when you next run it.

Related topics...
 Change design location

Choose font from
droplist

Edit default text
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Create layouts based on templates

Alternatively, you have access to complete EmbroideryStudio capabilities 
to create designs from scratch. Onscreen help is provided via the Help 
menu.

To create a layout based on a template
 If you are creating a design from scratch, use the File > New from 

Template command.

 Select a kiosk template if you have set one up. For example, you may 
set up your template to include a stitching boundary defining the area 

Use Toolbox > Lettering to create embroidery lettering directly on-screen. 
Right-click to access settings.

Use View > Auto Start & End to toggle function on/off according to the 
current settings. Right-click to open the Auto Start & End dialog.

Select 
template
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to work within, say, for cap designs. This can be drawn in CorelDRAW 
Graphics. You might also want to include a product image.

 Select the Lettering tool and create the text you require. Adjust 
settings such as font, dimensions, etc.

Note: To ensure that text remains within the allowable boundary, it is 
safest to use the Fixed Line baseline.

Kiosk stitching 
boundary

Use ‘Fixed Line’
baseline
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 Change thread color as desired. 

 Set the lettering object position to zero (0,0) as shown. This will 
ensure that the lettering layout automatically centers itself in the 
allowable stitching area.

 When you are happy with the result, click Save.
The file must be saved to the EmbroideryStudio e4 Designs folder:
C:\Program Files\Wilcom\EmbroideryStudio_e4.0\Kiosk\Designs
Alternatively, set your own designs folder. 

 The design will appear in the kiosk design chooser when you next run 
it.

Related topics...
 Set up thread colors
 Change design location

Create layouts with included design motifs

For special occasions, you may want to create a kiosk layout which 
includes a special motif – for instance, St Patrick’s Day, with a Shamrock 
at the start of the lettering. These motifs need to be about the size of a 
capital letter. Together with the lettering, they need to fit within the 
allowable stitching boundary.

To create a layout with an included design motif
1 Create a layout from scratch or based on an existing layout. See 

above.

Set X/Y position of
selected lettering to zero

Use Toolbox > Lettering to create embroidery lettering directly on-screen. 
Right-click to access settings.

Click Standard > Import Embroidery to import embroidery design file into 
current design.
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2 Import a suitable design motif using the Import Embroidery 
command. See main help system for details.

3 Place the motif and key in the default lettering.

4 Double-click the lettering and set left justification in Object 
Properties. Alternatively, if you place the motif on the right, set 
justification to right.

5 When you are happy with the result, click Save.
The file must be saved to the EmbroideryStudio e4 Designs folder:
C:\Program Files\Wilcom\EmbroideryStudio_e4.0\Kiosk\Designs
Alternatively, set your own designs folder. 

6 The design will appear in the kiosk design chooser when you next run 
it. The whole design, including motif and lettering, is auto-centered 
immediately after text is updated in kiosk mode.

Related topics...
 Change design location

Include design backdrops

Select left
justification

Use Color > Product Visualizer to choose a garment or product backdrop 
on which to position your decoration.
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It’s a simple matter to include a design backdrop to your design layout – 
e.g. a cap.

To include a design backdrop
 Click the Product Visualizer icon. The docker appears.

 Select a product image – e.g. cap – and set color as desired.

Click View > Show Product to toggle current product display. Right-click for 
Product Visualizer settings.

Use Zoom > Zoom to Product to view the entire product in the design 
window.

Select a 
product folder

Select 
product
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 Set the lettering object position to zero (0,0) as shown. This will 
ensure that the lettering layout automatically centers itself in the 
allowable stitching area.

 As the lettering object and stitching boundary may not be in the 
correct position for the backdrop, click the Auto Start & End icon and 
digitize a start and end point as shown.

Note: The stitching boundary is locked in the template. It has to be 
unlocked to be moved.

 When you are happy with the result, click Save.
The file must be saved to the EmbroideryStudio e4 Designs folder:
C:\Program Files\Wilcom\EmbroideryStudio_e4.0\Kiosk\Designs
Alternatively, set your own designs folder.

Digitize start and end
point at base of design

Set X/Y position of
selected lettering to zero
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 The design will appear in the kiosk design chooser when you next run 
it.

Related topics...
 Change design location
 Visualize products

New design listed
in kiosk chooser
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PART VIII
DIGITIZING WITH ARTWORK

There are two broad categories of artwork file, both of which can be 
imported into EmbroideryStudio for use as digitizing backdrops – vector 
and bitmap. To create good quality embroidery, you need to choose or 
create suitable artwork of either format.

Digitizing with bitmaps
This section describes how to prepare images for automatic digitizing. It 
explains how to insert bitmap images as well as how to edit them, 
including cropping, editing in third-party applications, and smoothing. It 
also explains how to prepare both outlined and non-outlined images. See 
Digitizing with Bitmaps for details.

Digitizing with vectors
This section describes how to create drawing objects using the drawing 
tools as well as how to import them from third-party applications. It also 
explains how to merge, trim and split overlapping drawing or embroidery 
objects using the shaping tools. See Digitizing with Vectors for details.

Automatic digitizing
This section describes how to automatically convert bitmap images to 
embroidery objects and complete designs, as well as how to create 
embroidery from grayscale images. See Automatic Digitizing for details.
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Chapter 32

Digitizing with Bitmaps

EmbroideryStudio supports the automatic and semi-automatic digitizing 
of both bitmap images and vector graphics. The quality of the resulting 
designs greatly depends on the type and quality of the original artwork. 
Generally speaking, vector graphics preserve the picture quality when 
resized, whereas bitmap images cause problems of pixelation and image 
degradation when enlarged or scaled down. You can insert or paste 
third-party vector graphics such as clipart for use in embroidery designs. 
Alternatively, insert, paste or scan bitmap artwork for use as digitizing 
templates or ‘backdrops’. In order to make bitmap images more suitable 
for automatic digitizing, EmbroideryStudio provides image processing 
capabilities.

Note: CorelDRAW Graphics includes the latest CorelDRAW® 
Graphics Suite drawing tools. These offer many sophisticated techniques 
for drafting outlines and shapes on screen. Vector graphics so created can 
be directly converted to embroidery objects or even entire designs. For a 
full description of the CorelDRAW® tools, refer to the electronic User 
Guide available via the MS Windows® Start > Programs group. 
Alternatively, use the online help available from the Help menu.

Choosing suitable artwork

For both manual and automatic embroidery digitizing purposes, ‘clean’ 
images, sometimes referred to as ‘cartoons’, work best. Such images 
have a limited number of solid colors which in turn have well-defined 
outlines. Ideally, they are:
 Well defined, where each shape is made up of pixels of the same color.
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 Clearly ‘blocked’, where each shape is a stitchable size, at least 1 sq 
mm.

 Saved at a color depth of at least 256 colors (8 bit), or preferably 
millions of colors (16 bit).

Best results are produced with images of the type found in clipart libraries 
or created from scratch in CorelDRAW®. EmbroideryStudio can work 
with images from other sources but they require some preparation. This 
is because most commonly available images are not made up of solid 
colors. Scanners introduce noise, while graphics packages perform 
‘dithering’ and ‘anti-aliasing’ to improve image print quality.

Photographic images
Embroidery digitizing works least effectively with photographic images 
which may contain many dithered colors and complex forms. With 
photographs, however, you can pick out shapes that you want to 
embroider, leaving out unnecessary detail. For best results, use sharp 
images with well-defined subjects and contrasting shades.
You can also use Photo Flash to create embroidery from photographs or 
other images, color or grayscale. Photo Flash designs consist of rows of 
stitches of varying spacing settings. The effect resembles the output of a 
line printer. See also Auto-digitize with Photo Flash.
An extension of Photo Flash, you can also use Color PhotoStitch to 
create embroidery from photos. While Photo Flash designs consist of 
rows of single-color satin stitching, Color PhotoStitch produces 
variegated stitching using multiple thread colors. The overall effect is like 
multi-colored stippling. See also Auto-digitize with Color PhotoStitch.

Clean image with 
well-defined outlines

Clean image with 
well-defined color blocks

Complex image, needs editing 
to remove background and 

improve outlines
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Scanned images
Images scanned from hardcopy drawings or 
existing embroidery typically contain a lot of 
introduced ‘noise’. While they can be used as 
input to embroidery digitizing, once again, best 
results are achieved with relatively clean images 
consisting of solid color blocks. Typically, logos 
and simple drawings scanned from business 
cards, letterheads, books, magazines, cards all 
fall into this category.
Noisy images typically need to be prepared by 
reducing the color count and sharpening the 
outlines. See also Preparing artwork for 
scanning.

Dithered images
Dithering is a software technique which combines existing colors in a 
checkerboard arrangement of pixels. It is typically used to simulate 
colors that are missing from an image palette.

Like noisy images, dithered images need to be color-reduced before use. 
Be aware, however, that while EmbroideryStudio can process dithered 
colors within a defined outline, it does not work so well with non-outlined 
images.

Anti-aliased images
Anti-aliasing is a software technique similar to 
dithering which is used to soften hard outlines 
where color blocks intersect. It produces 
smoother outlines by ‘blurring’ the pixels 
where colors join.
Where anti-aliasing is deliberately used to blur 
outlines, these need to be ‘sharpened’ before 
use with automatic digitizing.

Image containing a lot of 
scanner ‘noise’

Dithered color blocks
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Color depth
When loaded into EmbroideryStudio, images are automatically reduced 
to 256 colors or less. The main reason is to provide acceptable 
performance for automatic digitizing. 
256 colors sounds a lot for embroidery needs and, in practice, a 256 color 
image may look quite similar to a 24-bit RGB image. The appearance and 
quality differences can only be observed by zooming in. The 256-image 
will be dithered to improve its appearance at a distance. However, this 
feature is also responsible for single color pixels and small areas, which 
effectively create image noise. This in turn can affect the quality of 
automatically generated embroidery.

Guidelines
Bear in mind the following key points when selecting artwork for 
auto-digitizing:
 Use 300 DPI high-resolution images, NOT low-res 96 DPI.
 Do not use anti-aliasing.
 Do use PNG format, not JPG.
 Do use transparent backgrounds.
 If the image does not conform to these settings, return to the original 

vector artwork and generate a bitmap that includes them.

Image preparation techniques

Before converting artwork to vector graphics, you frequently need to 
clean it up. To work effectively, the Convert function requires solid color 
images as input. You can improve artwork with the bitmap editing tools.

Note: For a full description of the editing tools in CorelDRAW Graphics, 
refer to the electronic User Guide available via the MS Windows® Start 
> Programs group. Alternatively, use the online help available from the 
Help menu.

Outlined vs non-outlined images
Before preparing your image you need to know what type you are using. 
For the purposes of automatic digitizing, there are two categories – 
outlined and non-outlined. Outlined images ideally have a solid black 
outline around each colored area. Non-outlined images ideally consist of 
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solid areas of color. Outlined and non-outlined images require different 
methods of preparation.

Image cleanup
In practice, cleaning up scanned images may involve any one or a 
combination of the following techniques:
 Reducing the number of colors
 Adding or emphasizing outlines
 Removing noise, dithering or anti-aliasing
 Eliminating unnecessary detail
 Cropping sections
 Eliminating backgrounds.

Color reduction
Sometimes an image looks clean but extra colors have been introduced 
during scanning or processing. Color reduction means reducing the actual 
number of image colors in order to eliminate unnecessary detail and 
reduce each block to a single color. Color reduction also cleans the image, 
removing any noise and anti-aliasing present. This in turn helps minimize 
the number of trims and color changes required in the resulting 
embroidery design. Color reduction should only be applied if the loss of 
detail does not affect the image shapes. Before reduction, the colored 
areas in the image below include many colors. After reduction, each area 
is reduced to a single color. The detail is preserved.

Image with 
outlines

Image without 
outlines

Before color reduction After color reduction
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If you are scanning images, make sure you scan them correctly for best 
results. See also Preparing artwork for scanning.

Be aware that some techniques are better for removing noise and 
anti-aliasing but not so good for processing dithering in non-outlined 
images. See also Choosing suitable artwork.

Outline sharpening
Outline sharpening means emphasizing outlines bordering distinct color 
blocks. These may have been indistinct in the original or made so by the 
scanning process. Outline sharpening is important for vectorizing 
because it makes it easier for EmbroideryStudio to identify areas for 
conversion to embroidery.

Image scanned in 
RGB color mode, then 
colors reduced to 6

Image scanned in 256
color mode, then

colors reduced to 6

Outlined image – 
dithered color blocks 
cleaned, edges sharp

Non-outlined image – dithered 
color blocks not completely 
cleaned, edges fuzzy

Before outline 
sharpening 

After outline 
sharpening
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Some images have solid outlines but they may be indistinct or 
incomplete. These need to be rectified with the CorelDRAW Graphics 
bitmap editing tools prior to vector tracing. Refer to the electronic User 
Guide available via the MS Windows® Start > Programs group. 
Alternatively, use the online help available from the Help menu.

Noise filtering
Noise filtering means restoring the solid color blocks of the original 
artwork in scanned images. This is achieved by merging different shades 
into one solid color. Noise filtering is important for vectorization because 
it makes it easier for EmbroideryStudio to identify solid color blocks to 
become embroidery objects in the resulting design. It also cleans up 
blurred or mottled areas of color.

Image preparation summary

Image before noise 
filtering, mottled color

Image after noise
filtering, single colors

Action Outlined image Non-outlined image Photograph

Scan artwork • Scan in RGB mode
• Use sharpening

• Scan in RGB mode
• No sharpening

Scan in RGB mode

Scan line 
drawing

Scan in two color mode - -

Touch up 
graphics

• Crop
• Add or edit outlines
• Edit colors
• Remove noise

• Crop
• Edit image shapes
• Edit colors
• Remove noise

• Crop
• Convert to grayscale
• Remove background
• Lighten or darken
• Adjust contrast

Adjust bitmap • Adjust lightness or 
darkness of outlines 
manually.

• Adjust lightness or 
darkness of outlines 
manually.

• Adjust lightness or 
darkness of outlines 
manually.
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Preparing artwork for scanning

If you have existing artwork, you can scan it in CorelDRAW Graphics 
with a WIA-compatible (Windows Image Acquisition) scanner using the 
scanning function. It is important to scan your artwork properly if you 
intend to use one of the automatic digitizing techniques – the scanned 
image quality will affect the quality of the final embroidered design.
With embroidery design, less is more. You don’t need every detail in an 
image to create a design. You use the ‘structure’ of the image rather than 
the fine details of texture and color. To simplify artwork, you can cover it 
with tracing paper and draw only the essential shapes and lines which will 
be filled with stitches. When scanning, take away the original artwork and 
put white paper behind the tracing paper. Shiny surfaces, such as glossy 
photographs, may not scan well. Cover them with tracing paper. If the 
artwork has very light colors, highlight outlines with a fine black felt-tip 
pen.

Note: For a full description of how to scan images into CorelDRAW® 
Graphics Suite, refer to the electronic User Guide available via the 
MS Windows® Start > Programs group. Alternatively, use the online 
help available from the Help menu.

Prepare 
bitmaps

Adjust lightness or 
darkness of outlines. 
Automatically:
• blend each outlined 

block into a single color
• remove anti-aliasing, 

noise and dithering
• sharpen outlines.

Reduce colors to a 
specified number. 
Automatically:
• reduce each block to a 

single color
• remove anti-aliasing, 

noise and dithering
• remove colors less than 

specified area.

-

Vectorize 
bitmaps

CorelDRAW Graphics provides the latest CorelDRAW® drawing tools. These offer 
many sophisticated techniques for drafting outlines and shapes on screen. Refer to 
the electronic User Guide available via the Windows Start > Programs group. 
Alternatively, use the online help available from the Help menu.

Convert vectors 
directly

EmbroideryStudio provides techniques for both converting vectors directly to 
embroidery as well as manual digitizing of prepared artwork. See Digitizing Shapes 
for details.

Digitize 
automatically

• Manual
• Auto-Digitizing
• Instant Smart Design 
• Smart Design

• Manual
• Auto-Digitizing
• Instant Smart Design
• Smart Design

• Photo Flash
• Color PhotoStitch

Action Outlined image Non-outlined image Photograph
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Scanning resolution
Most scanners require you to enter scanning resolution information. 
Resolution determines the number of dots per inch (DPI) used to create 
an image. Generally speaking, the smaller the source image and/or more 
detail it contains, the higher the resolution needs to be. Use the following 
table as a guide.

Color mode
Most scanners also require you to enter color mode information. First 
decide whether your image is line art (black and white drawing), sketch, 
color picture, or black and white or color photograph, then choose an 
appropriate mode. Black and white mode produces the smallest files. 
Color photograph and grayscale modes generate 256 color images and 
produce similar sized files. ‘RGB’, ‘True Color’ or ‘millions of colors’ modes 
generate 16.7 million colors and produce the biggest files. Use the table 
below to decide which mode is suitable for use with your image.

Type of artwork Scanning resolution

Business cards, letter heads 150 - 300 dpi

Hand sketches 150 - 300 dpi

Photos and images 150 - 300 dpi

Commercial art, line drawing 72 - 150 dpi

Source image Example Description
Recommended 
color mode *

No. of colors in 
scanned image

Line art Two colors – 
usually black and 
white

Black/white 
drawing
Line art

2
2

Drawing/sketch Sketch or 
drawing with 
shades of gray

Grayscale 
Line art

256
2

Black & white 
photograph

Shades of gray Black/white photo
Grayscale

256
256

* Different scanning software uses different terms for the equivalent mode.
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Scanning tips
 Do not scan line art images in grayscale mode – grayscale scanning 

produces fuzzy edges.
 Scan color images in RGB mode (millions of colors) rather than 256 

color mode. The color count can be reduced once the image is loaded 
into the software. EmbroideryStudio can use the extra information to 
produce a better image than one scanned at 256 colors.

 Do not scan color images in CMYK (Cyan, Magenta, Yellow, and Black) 
mode as this is only used for images that will be printed – colors may 
be different to RGB colors.

 If the image needs to be rotated, do so while scanning. Rotating 
afterwards may distort the image.

Sharpening
Some scanning software lets you apply what is called ‘sharpening’ as you 
scan. Sharpening compensates for the slight blurring in a scanned image 
by looking for any differences between colors. Sharpening accentuates 
these differences which makes the image edges more defined. It does not 

Color photograph Many colors Color RGB 
Color photo

16 million
256

Color picture Two colors or 
more

Color RGB
Millions of colors
Color drawing

16 million
16 million
2 - 256

Source image Example Description
Recommended 
color mode *

No. of colors in 
scanned image

* Different scanning software uses different terms for the equivalent mode.

Scanned in 256 
color mode

Scanned in RGB color
mode (millions of

colors)
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increase image details but makes them more obvious. In general, use 
sharpening with well-defined outlines. Don’t use it with non-outlined 
images.

Loading bitmap artwork

Bitmap images of different formats can be scanned or ‘loaded’ into 
EmbroideryStudio for use as digitizing backdrops. You can scale and 
transform them after importing but it is generally better to do so during 
scanning. Scaling afterwards may distort the image.

Sample designs & artwork

EmbroideryStudio contains hundreds of ready-to-stitch designs, 
including attractive ornaments, samples and digitizing backdrops. Design 

Scanned with 
sharpening

Scanned without
sharpening
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files (EMB files) and images (BMP, JPG, and WMF files) can be found in 
your Embroidery and Picture libraries.

The most valuable thing you can do when starting out is to spend some 
time exploring these designs and getting to know what’s available. 
EmbroideryStudio includes its own Design Library design management 
application to view and manage your embroidery designs. Alternatively, 
explore design folders using File Explorer. See also Design 
Management.

Navigate folder
structure via

navigation tree or
address bar
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Note: CorelDRAW® needs to be registered before it can be used by 
EmbroideryStudio. Registration gives you access to the latest 
CorelDRAW® updates. It also provides CorelDRAW® Standard 
Membership which gives you access to content – clipart, fonts, stock 
photos, templates – via Corel CONNECT.

Caution: Included artwork (clipart) and embroidery designs can only be 
used for personal use – i.e. they cannot be commercially sold in any form. 
Changing the medium – i.e. clipart to embroidery or embroidery to clipart 
– does not remove copyright protection.

Scan images

You can scan images directly into EmbroideryStudio for use as digitizing 
backdrops. The scanning feature in EmbroideryStudio allows you to use 
most WIA-compatible scanners. You can use any scanning software 
provided that it can save the image in one of the compatible formats.

Tip: You can also scan in your own textured backgrounds to see what a 
design will look like on real fabric. Fabrics can be scanned to provide full, 
centered, backgrounds to your design, or as small samples which can be 
tiled to fill the screen. 

To scan an image
1 Set up your scanner. 
2 Prepare the artwork for scanning. 
3 Select File > Scan Graphic.
4 Choose a scanning mode and resolution. If you are scanning a fabric 

background, set the scan to 256 colors, 100% and 72 dpi (dots per 
inch). These settings will give a small file which will display well on 
your screen without taking up too much disk space or memory.

5 Preview the image in the scanning program.
6 Select the area to be scanned and scan the image.
7 Save the scanned picture in a compatible format picture file to your 

My Designs folder.

Note: Scanned drawings are bitmaps and must be saved separately 
from the design file or they will be lost when you close the design. 

Related topics...
 Fabric & product backgrounds
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 Setting up scanners
 Save artwork
 Preparing artwork for scanning

Insert bitmap images

Bitmap images of various formats can be imported or pasted into 
EmbroideryStudio for use as digitizing backdrops.

Tip: If you are editing images in a third-party graphics application, you 
can copy and paste into EmbroideryStudio via the Windows clipboard.

To import a bitmap image
1 Click the Import Graphic icon or select File > Import Graphic.

2 Navigate to the graphics folder. The dialog defaults to ‘All graphic files’ 
which displays all supported file types, bitmap and vector.

3 Filter the Files of Type list as required – e.g. ‘BMP’.

Use Standard > Import Graphic to import artwork into current design as a 
backdrop for manual or automatic digitizing.

Use View > Show Bitmaps to toggle bitmap images on or off. Right-click for 
settings.

Filter list as
preferred
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Note: While ‘All graphic files’ includes both vector and bitmap formats, 
for native CDR and other vector file types, use the CorelDRAW® 
Graphics Suite import function.

4 Select a file and click Open.
5 Scale and transform the image on-screen or via the Property and 

Transform toolbars.

Tip: Use Auto Trace To Vectors to create vector outlines from 
bitmap images. You can then convert these to embroidery objects 
using a variety of input methods. Auto Trace To Vectors can find 
holes in shapes – both inside and outside boundaries are detected.

Related topics...
 Operating modes
 Auto-tracing bitmap artwork
 Supported machine types

Open graphic files directly

Scale and transform images 
like embroidery objects

Click Mode > Design Library to open the Design Library window from which 
to search and manage designs and job orders.

Use Manage Designs > New From Selected to create new designs based 
on designs selected in Design Library.
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Artwork can be opened in EmbroideryStudio in both vector and bitmap 
(raster) formats via Design Library. Samples of both file types are 
installed with EmbroideryStudio in the Pictures library as shown below.

The New from Selected command can also be used to open graphics 
files, including Corel CDR. With CDR, a new file is opened in 
EmbroideryStudio before switching to CorelDRAW Graphics.

Related topics...
 Combining objects & designs
 Opening designs from Design Library
 Working with templates

Add & match image colors

You can manually match colors from an inserted bitmap or vector graphic 
to thread colors in selected chart/s. Alternatively, simply add raw image 
colors to the palette for later matching.

Filter by 
graphic file
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To add and match image colors
 Insert a bitmap image for use as a digitizing backdrop.

 Select Graphics > Add Bitmap Colors. The Prepare Bitmap 
Colors dialog opens by default.

 Reduce design colors to the minimum necessary before adding to the 
color palette. Click OK to confirm.

Default palette 
colors
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 Selected colors are displayed in the Add Bitmap Colors dialog.

 To add the image colors directly to current colorway, simply click OK. 
The raw image (RGB) colors are transferred. These can be used as is 
and thread-matched at any time.

 Alternatively, to make thread selections straight away, select the 
thread chart/s to use from panel. 

 Select an image color and click Match. The system searches for the 
closest match in the selected chart/s and displays them in the thread 
color list.

 To assign the thread color, double-click or click Assign.

Click OK to add
image colors to

palette

Colors read from
bitmap

Default color
palette

Raw image colors 
added to palette
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 Repeat until all colors you intend to use in the design have been 
matched.

 Click OK. The selected threads are assigned to the current colorway.

Note: The maximum number of new thread colors which can be added 
to the color palette from a bitmap is 128.

Related topics...
 Preparing images for auto-digitizing
 Auto-digitize individual shapes
 Insert bitmap images

Preparing artwork for digitizing

EmbroideryStudio allows you to crop bitmap images prior to use. You can 
also open images directly in third-party bitmap editing packages or use 
in-built CorelDRAW® Graphics Suite. Within EmbroideryStudio you can 
set general properties such as size and position. You can also scale and 
transform bitmap images although it may be best to do this during 
scanning.

Select thread 
chart/s

Select color
to match

Matched
colors listed

Click to
assign

Click to
match

Selected threads 
assigned to palette
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Note: CorelDRAW Graphics provides the latest CorelDRAW® 
Graphics Suite drawing tools. These offer techniques for inserting and 
manipulating bitmap images, including vector tracing. Vector objects can 
then be converted to embroidery designs. See also Operating modes.

Image transparencies

Support is provided for transparent backgrounds in 24 bit and 32 bit 
images.

If an image contains a transparent background:
The background is automatically excluded from auto-digitizing.
The image is automatically cropped to its visible extents.

Caution: Avoid using images that contain semi-transparent or 
transparent pixels within image color areas as these cause poor results 
when reducing the color count. The resulting pixels may end up as holes 
inside the image or significantly reduce color areas to the point where 
they are unnecessarily removed from the embroidery results.

Crop bitmap images

Imported into
EmbroideryStudio

Source bitmap with 
transparent 
background

Use Auto-Digitizing > Crop Bitmap to crop bitmap artwork for use with 
auto-digitizing.

Click Auto-Digitizing > Remove Crop to remove any crop areas applying 
to selected artwork.
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Before using bitmap images for design purposes, crop them to remove 
unnecessary detail and save processing time. EmbroideryStudio allows 
you to ‘soft crop’ images which means that you can redefine or remove 
the cropping area at any stage.

To crop a bitmap image
 Scan or import the image to use.
 Select the image and choose a cropping tool from the Crop Bitmap 

droplist. The same options are available under the Graphic menu.

 Click and drag the selected shape around the area to be cropped. 
Alternatively, use the Any Shape method to digitize a cropping shape.

Click Auto-Digitizing > Finalize Crop to make the cropping permanent. 
Once finalized, the cropping cannot be removed.

Select cropping 
method
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 Reshape or transform the cropping shape with the Reshape tool.

 Click Select Object or press Esc to close. 
 To remove a cropping area, select all reshape nodes and press Delete.
 Use the Graphics > Finalize Crop command to crop an image to its 

new visible extents. When you create a cropped area, it is considered 
‘temporary’ and can be reshaped at will. By using the Finalize Crop 
command, you make the crop permanent. The only way to go back is 
via the Undo command or by reinserting the original bitmap.

Related topics...
 Insert bitmap images
 Reshaping embroidery objects

Touch up bitmaps

Sometimes you need to edit bitmap images directly in a third-party 
graphics package. You would normally do this in order to eliminate 
backgrounds, flood-fill solid areas with color, add or reinforce outlines, or 
close gaps. From within EmbroideryStudio you can open images directly 
in MS Paint, Corel PHOTO-PAINT®, or Paint Shop Pro™. Images updated 
in this way are automatically re-imported into EmbroideryStudio.
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To touch up a bitmap
1 Select the image.

2 Select Graphics > Edit Using >.... The image opens in the select 
graphics package.

3 Edit the image and save.

Note: If you return to EmbroideryStudio before closing the image in 
the graphics package, it is overlaid with stripes.

4 Return to the graphics package and select either File > Close or File 
> Exit & Return <Filename>. In EmbroideryStudio, the stripes will 
disappear.

Background may be 
cleaned and eyes 
added

Background cleaned 
and eyes added

File still open in the 
graphics package
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Related topics...
 Insert bitmap images

Smooth bitmap images

When you scale or transform backdrops, the quality is sometimes 
reduced – e.g. thin straight lines become jagged or distorted. 
EmbroideryStudio allows you to smooth an image before and after 
scaling or transforming, making it easy to digitize.

To smooth a bitmap image
 Select the image and double-click to access object properties.

 Select the desired smoothing option, depending on whether the 
majority of lines in the image are light or dark.

 Optionally, scale and transform the image on-screen or via the 
Property and Transform toolbars.

Select required 
smoothing option

Light lines smoothed Dark lines smoothedNo smoothing

Scale and transform images 
like embroidery objects
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Related topics...
 Insert bitmap images
 Transforming Objects

Save artwork

All images placed in the design window, whether by scanning, pasting or 
inserting from hard disk, are saved together with the embroidery design 
in the EMB file. After editing in EmbroideryStudio or third-party graphics 
application, you may want to save the image out as a separate file.

To save artwork
1 Scan or load the image you want to use.
2 Still in CorelDRAW Graphics mode, select the image.

3 Select File > Export. The Export dialog opens.

4 Choose a suitable file format from the droplist – e.g. BMP or PNG.
5 Select an export folder, then select a format from the Save as type 

droplist.
6 Enter a file name and click Export.

Note: This file is not referenced by the EMB file. Any further changes 
to it are not reflected in the embedded image.

Select file 
format
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Related topics...
 Loading bitmap artwork

Preparing images for auto-digitizing

The Auto-Digitizing tools provide everything necessary to 
automatically digitize electronic artwork and photographs. Results 
depend greatly on the resolution, color depth, and quality of source 
images. For best results, use crisp images with well-defined subjects and 
strong contrasts. In addition a degree of preparation is needed. This may 
involve preparation using third-party graphics applications such 
CorelDRAW Graphics. Tools are also available within Wilcom Workspace.

Prepare bitmaps for auto-digitizing

The Auto-Digitizing tools provide everything necessary to 
automatically digitize shapes in electronic artwork without using manual 
input methods. Even if your artwork looks ready to stitch when inserted 

Use Auto-Digitizing > Prepare Bitmap Colors to reduce the number of 
colors and remove image ‘noise’ in non-outlined images.
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into the software, however, it will need to be image-processed before 
conversion.

Use the Prepare Bitmap Colors tool to prepare images for automatic 
digitizing. This function automatically flattens colors, sharpens outlines, 
and reduces ‘noise’. Areas enclosed by a black outline are reduced to a 
single color. This makes it easier for the software to recognize distinct 
areas in the artwork. These areas then become the embroidery objects 
of the finished design.

To prepare bitmaps for auto-digitizing
 Scan or import the image to use. Depending on the quality of the 

scanned image, you may need to touch it up manually before 
processing in EmbroideryStudio. You would normally do this in order 
to eliminate backgrounds, flood-fill solid areas with color, add or 
reinforce outlines, or close gaps.

 Depending on the source, you may find dithering, anti-aliasing, or 
other sources of ‘noise’ in the image. If it contains outlines, these will 
generally be blurred by anti-aliasing.

Outlines blurred by 
anti-aliasing
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 Select the image and click the Prepare Bitmap Colors icon. The 
image appears in both ‘before’ and ‘after’ preview panels. Note the 
number of colors in the original. The software automatically detects 
the main color blocks and reduces colors accordingly.

 If there appear to be too few colors to provide the detail you want, use 
Processing options to increase the color count.

 Manually locate and merge like-colors as necessary:
 Holding the Ctrl key, click like-colors to select.
 Click and hold Locate to preview.
 Click Merge to merge like-colors into a single color.

Set desired 
color count

Set ‘granularity’ of 
source image for 
processing

Click to merge 
selected colors

Ctrl + click to 
select multiples
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 Use the scroll button on your mouse to zoom in and inspect details.

 Adjust the Details slider to control number of details and resultant 
objects. 
While this setting doesn’t affect the image, it affects the embroidery 
result by filtering out smaller areas of color. ‘More’ generally results in 
greater detail and number of objects. ‘Fewer’ generally results in fewer 
details and objects. It is useful for ‘noisy’ images with lots of small 
areas. It works well with JPG files which are inherently more noisy.

 Click OK to process the image. Image colors should be reduced as per 
the preview. The artwork can now be auto-digitized.

Related topics...
 Graphics and multi-decoration file formats
 Scan images
 Insert bitmap images
 Crop bitmap images
 Touch up bitmaps
 View graphical components
 Auto-digitizing photographs

Scroll to zoom in 
and inspect 
detail

Outlines sharpened and 
noise reduced



Chapter 32   Digit izing with Bitmaps 808

Prepare photos for auto-digitizing

A degree of preparation is needed for any of the photographic 
auto-digitizing techniques. For best results, use crisp images with 
well-defined subjects and strong contrasts.

To prepare photos for auto-digitizing
 Scan or insert the photo you want to use. For best stitching results, 

images are better imported via the CorelDRAW Graphics than 
Wilcom Workspace.

 If you cannot see the image, turn on Show Bitmaps.
 Optionally, crop the image.
 Size the photo for its intended purpose. Optimal size is 150mm x 

150mm or about 6" x 6". 210mm is about the limit for optimal results. 

Use Auto-Digitizing > Prepare Bitmap Colors to reduce the number of 
colors and remove image ‘noise’ in non-outlined images.

Use Auto-Digitizing > Adjust Bitmap to adjust image lightness and contrast 
in preparation for auto-digitizing.

Use Auto-Digitizing > Crop Bitmap to crop bitmap artwork for use with 
auto-digitizing.

Use Mode > CorelDRAW Graphics to import, edit or create vector artwork 
as a backdrop for embroidery digitizing, manual or automatic.
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You may be prompted to resize when you run one of the PhotoStitch 
features.

 If your graphics application supports it, try re-sampling the image 
while resizing.

 Optionally, use the Prepare Bitmap Colors tool to reduce the 
number of colors and remove image ‘noise’.

Set desired 
color count

Set ‘granularity’ of 
source image for 
processing
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 Optionally, use Adjust Bitmap to adjust basic lightness and contrast. 

 First, try clicking Auto Adjust to allow the software to optimize image 
settings. This works well most of the time. Use Brightness and 
Contrast settings to sharpen the image further.

 Optionally, click Reset to return the image to default settings.
 Choose between image variations:

Option Function

Sepia In photographic terms, ‘sepia’ refers to the dark-brown color of old-fashioned 
prints. Originally the process involved adding a pigment made from cuttlefish 
ink during development.

Gray Grayscale images are ones composed exclusively of shades of gray, varying 
from black at the weakest intensity to white at the strongest.

Adjust image 
lightness and 
contrast
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 Optionally, switch to Graphics Mode for alternative pre-processing. 

 For the full range of image adjustment techniques, use a dedicated 
graphics program like Corel PHOTO-PAINT®. If installed, the Edit 
Bitmap option is available.

Related topics...
 Scan images
 Insert bitmap images
 Crop bitmap images
 Touch up bitmaps
 View graphical components
 Auto-digitizing photographs

Preparing artwork for continuous embroidery

Many customers make traditional garments such as sarees which employ 
continuous and sometimes overlapping designs. It is important that 
artwork used for continuous embroidery is properly sized and orientated. 
When doing continuous designs on multihead systems, horizontal 

Edit bitmap for
auto digitizing
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distance will generally be a function of the gap between machine heads 
– e.g. 135 mm.

There are two main sources of artwork for continuous embroidery:
 Enlargement drawings. These are typically used with a digitizing 

tablet. See the Schiffli Supplement for details.
 Scanned images or graphics files from third-party software. These are 

used for on-screen digitizing.
The same considerations apply for both types of artwork. However, while 
with enlargement drawings you adjust drawing scale, with electronic 
artwork, you adjust on-screen image size and rotation. Generally 
electronic artwork will be prepared to exact dimensions. To check a 
design repeat, you need to measure the distance between two repeat 
points. You will need to choose clearly identifiable points on the design 
which are easy to identify.

To adjust an image to repeat
 Scan or insert your artwork as you would a normal digitizing backdrop. 

If you have prepared your artwork in CorelDRAW Graphics, switch 
to Wilcom Workspace.

Vertical
distance

Horizontal distance
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 Select View > Measure. Click the first (left) repeat reference point, 
then place the cursor over the second point.

 Check the X and Y values and the angle. If the angle is not zero the 
image may need to be rotated. You can decide the acceptable 
tolerance. Small errors are usually acceptable. Usually 0.3mm in real 
size is the smallest error the human eye can discern.

 If you need to rotate it, select the image and enter the exact rotation 
setting in the Transform toolbar.

Caution: Rotation of bitmap images can reduce definition. For better 
quality, go back to the source application and adjust artwork there. Or, 
in the case of scanned artwork, adjust it on the scanner and re-scan.

 Once rotation is fixed, measure the two points again and compare the 
X value with the Design Repeat value. Again you need to decide what 
tolerance is acceptable. First you need to calculate the necessary scale 
factor, which is:
Scale Factor = (Measured Repeat (X) ÷ Design Repeat) × 
100%
If the image needs to be enlarged by 10%, you will get 110% or a 
similar value. If it needs to be reduced by 5%, you will get 95% or 
similar.

 If necessary, adjust dimensions by a percentage in Property Bar.

Repeat
reference point

Repeat 
reference point

5°

Enter exact rotation 
value – e.g. -5°

Adjust overall design 
dimensions
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Tip: The Show Repeats function displays repeating designs, 
including sequins, in both TrueView and stitch view. You can view a 
design, even while digitizing, with any number of repeats.

Related topics...
 Viewing design repeats
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Chapter 33

Digitizing with Vectors

There are two fundamental design modes in EmbroideryStudio:
Wilcom Workspace: This mode allows you to create and edit 

embroidery objects using an embroidery digitizing toolset.
 CorelDRAW Graphics: This mode allows you to create and edit 

vector objects using the CorelDRAW® Graphics Suite toolset.

Wilcom Workspace also provides tools for drawing shapes and outlines 
directly on screen. In this mode, you can also import or paste third-party 
vector graphics such as clipart for use as digitizing backdrops. Scale and 
transform them in the same way as embroidery objects. You can also 
select colors for vector object outlines and fills.
The Auto Trace To Vectors feature lets you convert scanned artwork to 
vector objects. You can then convert these to embroidery objects using 
a variety of input methods.
When working with overlapping vector or embroidery objects, merge, 
trim or split them using Shaping tools.
CorelDRAW Graphics includes the entire suite of CorelDRAW® 
Graphics Suite drawing tools which offer many sophisticated techniques 
for drafting outlines and shapes on screen. Vector graphics so created can 
be directly converted to embroidery objects or even entire designs. 
Alternatively, you can insert or paste third-party vector graphics such as 
clipart for use in embroidery designs. Or, insert, paste or scan bitmap 
artwork for use as digitizing templates or ‘backdrops’.
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Tip: For a full description of the CorelDRAW® Graphics Suite tools, refer 
to the electronic User Guide available via the MS Windows® Start > 
Programs group. Alternatively, use the online help available from the 
Help menu.
This section describes how to create vector objects using the digitizing 
tools as well as how to import them from third-party applications. It also 
explains how to merge, trim and split overlapping vector or embroidery 
objects using the shaping tools.

Creating vector shapes in EmbroideryStudio

EmbroideryStudio lets you ‘draft’ shapes and outlines on screen. You can 
set colors for outlines as well as fills. Vector objects can be converted to 
embroidery objects with the application of manual input methods and 
stitch types. See also Convert objects with CorelDRAW Graphics.

Note: Depending on your product level, EmbroideryStudio includes the 
CorelDRAW® Graphics Suite drawing tools which offer many techniques 
for drafting outlines and shapes on screen. See also Operating modes.

Create vectors

Use Graphics Digitizing > Digitize Open Shape to digitize open shapes. 
Press <Ctrl> to constrain.

Use Graphics Digitizing > Digitize Closed Shape to digitize closed shapes. 
Press <Ctrl> to constrain.

Use Graphics Digitizing > Ellipse to digitize ellipse or circle embroidery 
objects.

Use Graphics Digitizing > Rectangle to digitize rectangle or square 
embroidery objects. Press <Ctrl> to constrain.

Use Graphics Digitizing > Basic Shapes to digitize basic shapes. Press 
<Ctrl> to maintain aspect ratio. Press <Shift> to center at the first point.

Use Outline Stitch Types > Vector Outline to create vector outlines with no 
stitch properties applying.

Use Fill Stitch Types > Vector Fill to create vector fills with no stitch 
properties applying.
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Use the Graphics Digitizing tools to create vector objects directly in 
EmbroideryStudio. Digitizing vector outlines and fills is like digitizing any 
other objects except that they have no stitch properties applying.

To create vectors
 Select Vector Outline or Vector Fill as your stitch type.
 Draw straight lines in your design using either Digitize Open Shape 

or Digitize Closed Shape digitizing tools. Enter start and end points. 
To constrain the line vertically, horizontally or in 15° angles, press Ctrl 
as you mark the end point.

 Draw lines of any shape using the same tools. Enter reference points 
to create the shape you want – left-click for corner points, right-click 
for curve points.

 When you create closed shapes with the Digitize Closed Shape 
drawing tool, press Enter to close the shape.

 Draw rectangles and squares using the Rectangle tool. To draw a 
square, hold down Ctrl as you move the pointer.

 Draw circles and ellipses using the Ellipse tool.
 To draw a perfect circle, press Enter.

Corner point

Curve point

Corner point

Curve point

Press Enter to 
close the shape

Click to enter
corner point

Drag pointer, 
click again
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 To draw an ellipse, move the pointer again, then mark a second 
radius point when the outline is the required size. Press Enter.

 Press Enter to close a shape.

Color vectors

EmbroideryStudio lets you set colors for vector outlines as well as fills. 
Coloring makes vector objects easier to interpret. For example, a solid fill 
color might suggest Satin or Tatami, while a fill pattern may be 
interpreted as Motif Fill or Program Split.

To color vectors
1 Create or insert a vector graphic.

2 Ungroup the vector objects as necessary.
3 Select a vector object, right-click and select Properties from the 

popup menu. The Object Properties docker opens. 
4 To change the outline color of the selected object, adjust the settings 

in the Line panel:
 Select an outline style from the Style list.
 Select an outline width from the Width field.

Click to enter
center point

Press Enter for circle or 
mark a point for ellipse

Drag pointer

Use Docker > Object Properties to toggle the Object Properties docker 
on/off. Use it to select colors for vector outlines and fills.

Vector graphic
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 Click Color and select an outline color from the Color dialog.

5 To fill the selected object with a solid color, select the Solid Fill icon 
and click the Color droplist to access the colors.

6 To fill the selected object with a pattern fill, select the Pattern Fill icon 
and adjust the settings:
 Select a pattern style from the droplist.
 Select a foreground color via the Front button.
 Make the background transparent as required or choose a color via 

the Back button.

Select outline style

Select outline width

Select outline color

No fill currently
selected

Select solid fill

Click to
choose color

Select pattern fill

Select pattern style

Select colors for pattern
foreground and

background
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7 To fill the selected object with a bitmap – e.g. a fabric texture – select 
the Bitmap Fill icon and click the Load button to insert an image file 
via the Open dialog.

Note: To view the changes in the production worksheet, select File > 
Print Preview. In the Options > Design tab select the Vectors 
checkbox.

Related topics...
 Insert vector graphics
 Customizing design reports
 Design options

Loading vector artwork

Vector graphics of different formats can be inserted or ‘loaded’ into 
EmbroideryStudio for use as digitizing backdrops or for conversion to 
embroidery. Vectors can be inserted directly into Wilcom Workspace or 
via CorelDRAW Graphics.

Tip: CorelDRAW® Graphics Suite is bundled as standard with some 
product models. CorelDRAW® and its sister product, Corel 
PHOTO-PAINT® can also be run as standalone applications. CorelDRAW® 
Graphics Suite features ‘best-of-breed’ bitmap-to-vector tracing, 

Select bitmap fill

Click to load
image file
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enhanced illustration capabilities, photo-editing together with a library of 
professional clipart images. CorelDRAW® needs to be registered before 
it can be used by EmbroideryStudio.

Insert vector graphics

Vector graphics from third-party applications can be inserted into 
EmbroideryStudio in a variety of native and interchange vector formats. 
You can also import some vector graphics as bitmaps. You can convert 
vector graphics to embroidery objects using a variety of input methods 
or with the Auto-Digitizing tools.

To insert a vector graphic
1 Create a new file in EmbroideryStudio or open the design file into 

which you want to insert the vector graphic.
2 Click the Import Graphic icon or select File > Import Graphic.

3 Navigate to the graphics folder. The dialog defaults to ‘All graphic files’ 
which displays all supported file types – BMP, PNG, EPS, etc. Change 

Use Standard > Import Graphic to import vector graphic or bitmap image 
into current design

Use View > Show Vectors to show or hide any vector artwork included in 
the design. Right-click for settings.

Select to remove 
overlapping objects

Untick to insert 
as vectors

Filter list as
preferred
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the Files of type setting if you want to filter on a specific file type – 
e.g. EPS.

Note: While ‘All Graphic Files’ includes both vector and bitmap 
formats, for native CDR and other vector file types, use the 
CorelDRAW® Graphics Suite import function.

4 If you are working with DXF files:
 Click Options. The DXF File Options dialog opens.

 Select Inches or Millimeters from the Units of Measurement 
list and click OK. If this information is not specified, the vector 
graphic may not display at the correct size.

5 Select the As Bitmap checkbox to insert the vector graphic as a 
bitmap image. 

Note: DXF files cannot be imported as bitmaps.

Select unit of 
measurement

 Imported as bitmap image – 
individual objects cannot be 

selected

Imported as vector graphic – 
individual objects can be selected
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6 Select the Flatten checkbox to remove any overlapping areas from 
the vector graphic.

7 Select the Preview checkbox to see a preview of the vector graphic.
8 Click Open to insert the vector graphic into the design window.

Tip: You can also paste vectors directly into EmbroideryStudio through 
the MS Windows® clipboard.

Related topics...
 Operating modes
 Converting designs with CorelDRAW Graphics 
 Auto-digitize individual shapes

Import vector graphics

You can load vector artwork of various formats via CorelDRAW 
Graphics for use as digitizing backdrops for manual or automatic 
digitizing. You can also use this technique to insert bitmaps.

Note: CorelDRAW® needs to be registered before it can be used by 
EmbroideryStudio. Registration provides CorelDRAW® Standard 
Membership which gives you access to content – clipart, fonts, stock 
photos, templates – via Corel CONNECT.

Vector objects not ‘flattened’Vector objects ‘flattened’

Hidden areas 
removed

Hidden areas 
preserved

Use Mode > CorelDRAW Graphics to import, edit or create vector artwork 
as a backdrop for embroidery digitizing, manual or automatic.

Use Standard > Import to import a file to the active document in 
CorelDRAW Graphics.

Use View > Show Vectors to show or hide any vector artwork included in 
the design such as CorelDRAW® clipart. Right-click for settings.
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To import a vector graphic
1 Switch to CorelDRAW Graphics and click Import on the Standard 

toolbar.

2 Select a folder and select a file type from the Files of Type list – e.g. 
EPS.

Select 
format

Select required
format
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3 Select a file and click Import. The Import EPS dialog opens. You are 
prompted to import text as pure text or as vector curves.

4 Position the cursor in the design window and press Enter.
5 Choose a digitizing technique:
 Convert vectors to embroidery: See Convert objects with 

CorelDRAW Graphics for details.
 Switch to Wilcom Workspace and use the artwork as a digitizing 

backdrop: See Digitizing methods for details.

Note: If you cannot see the image you loaded in Wilcom 
Workspace, make sure Show Vectors icon is toggled on. 

Tip: Locking backdrop images holds them in place as you digitize, 
transform or reshape the embroidery objects near them. Locked 
objects can be unlocked for modification at any time. 

Related topics...
 Operating modes
 Change backgrounds
 Grouping & locking objects
 Converting designs with CorelDRAW Graphics 
 Auto-digitize individual shapes

Auto-tracing bitmap artwork

Use Auto Trace To Vectors to create vector outlines from bitmap 
images. You can then convert these to embroidery objects using a variety 
of input methods. Auto Trace To Vectors can find holes in shapes – 
both inside and outside boundaries are detected.

Import text as
text or curves

Use Auto-Digitizing > Auto Trace To Vectors to convert artwork to vector 
objects for conversion to embroidery objects.
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Tip: Once digitized in EmbroideryStudio, embroidery designs can be 
output as vectors. These can be opened in CorelDRAW Graphics. See 
also Exporting embroidery as vectors.

To auto-trace bitmap artwork
1 Scan or insert a bitmap image. 
2 Select the image and process it using the Prepare Bitmap Colors 

tool.

3 Click the Auto Trace To Vectors icon. The design is automatically 
traced into vectors, both outlines and filled shapes.

Note: If the bitmap needs preliminary color reduction, clicking 
Auto Trace To Vectors takes you directly to the Prepare Bitmap 
Colors dialog.

Bitmap converted 
to vector outlines 
and filled shapes
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4 Select the shape/s you want to convert to embroidery and convert 
using any of the available techniques.

Related topics...
 Converting designs with CorelDRAW Graphics
 Insert bitmap images
 Preparing images for auto-digitizing

Smoothing curves

Both vector and embroidery objects contain reshape-nodes on their 
outlines. On shapes where the angle changes constantly, the software 
may insert hundreds of reshape-nodes, making reshaping difficult. The 
Smooth Curves command applies curve ‘smoothing’ to embroidery as 
well as vector objects.

To smooth curves
1 Select the object (or objects) to smooth.

Note: You can only smooth objects that have been ungrouped and 
selected. However, you can select multiple objects.

Convert vectors 
to embroidery

Use Reshape > Reshape Object in combination with Edit > Smooth Curves 
to remove unnecessary reshape-nodes from vector graphic objects.
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2 Optionally, click Reshape Object to view reshape-nodes around the 
outline.

3 Select Edit > Smooth Curves.

4 Adjust the Precision field. This value controls how closely the 
smoothed outline follows the original. The larger the precision value, 
the fewer the reshape-nodes.

5 Click OK.

Visualizing vector graphics

Vectors can be viewed in a variety of ways in Wilcom Workspace. 
Toggle vectors on or off with the Show Vectors icon. View vectors in the 

Reshape-nodes 
reduced to minimum 
necessary

Enter smoothing
precision value

Use View > Show Vectors to show or hide any vector artwork included in 
the design such as CorelDRAW® clipart. Right-click for settings.

Use View > Show Repeats to toggle design repeats display. Right-click for 
settings.
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Color-Object List. Click Locate to isolate selected vector objects 
on-screen.

Vector graphics can also be visualized using Show Repeats. This can be 
useful when digitizing continuous embroidery designs. 

Related topics...
 Viewing design repeats

Click to view selected 
vector object

Vector drawing 
objects

Show repeats for 
more accurate 
digitizing
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Chapter 34

Automatic Digitizing

EmbroideryStudio provides a variety of complementary tools and 
techniques to automatically and semi-automatically digitize suitably 
prepared artwork and photographs.

Auto-digitizing features covered in this section include:

Feature Overview

Convert
The Convert feature lets you convert vector objects 
directly to embroidery objects. And vice versa. Entire 
designs can be converted in either direction.

Auto-Digitizing
The Auto-Digitizing tools provide everything necessary to 
digitize shapes in graphics automatically without using 
manual digitizing methods.

Smart Design The Smart Design feature automatically converts bitmap 
images to embroidery.
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This section describes how to automatically convert graphics to 
embroidery objects and complete designs using a variety of techniques, 
as well as how to create embroidery from grayscale images and 
photographs.

Loading & presetting artwork

Artwork can be inserted, pasted or scanned into EmbroideryStudio for 
use as digitizing backdrops. For both manual and automatic digitizing 
purposes, ‘clean’ images, sometimes referred to as ‘cartoons’, work best. 
The auto-digitizing tools handle both bitmap and vector formats.

To load & preset artwork for auto-digitizing...
1 Import the artwork. Whether you’re working with bitmap or vector 

graphics, you need to prepare them first:
 Scan or insert a bitmap image. If you are using a bitmap image as 

input, it will need to be image-processed before conversion. 
 Insert or create a vector graphic. If you are using a vector graphic 

as input, you can remove overlapping objects by ‘merging’ them. 
This eliminates overlapping stitching when vector objects are 
converted.

2 Whether you’re working with bitmap or vector graphics as input, you 
may want to prepare them first:
 If you are using a bitmap image, it can be image-processed before 

conversion.

Photo Flash
The Photo Flash feature creates embroidery designs from 
photographs and other grayscale bitmap images. The 
effect resembles the output of a line printer.

Reef 
PhotoStitch

The Reef PhotoStitch feature also creates embroidery 
designs from photographs and other bitmap images. The 
features creates open stitching reminiscent of a coral reef.

Color 
PhotoStitch

The Color PhotoStitch feature creates embroidery from 
photographs and other images. It produces variegated 
stitching using multiple thread colors.

Feature Overview

Use Auto-Digitizing > Color Matching Method to preselect a thread 
matching method.

Use Auto-Digitizing > Crop Bitmap to crop bitmap artwork for use with 
auto-digitizing.
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 If you are using a vector graphic, you can remove overlapping 
objects by ‘merging’ them. This eliminates overlapping stitching 
when vector objects are converted.

3 Size the image to the preferred dimensions for your target article.

4 Optionally, select Design > Auto Fabric to apply preferred fabric 
settings.

5 Crop the image as desired using the Crop Bitmap tools. 
6 Optionally, click Color Matching Method and decide how you want to 

handle color matching.

You have three options:

Enter dimensions as exact 
values or as a percentage

Lock aspect ratio
toggle

Choose a 
fabric type

Tick to
activate

Choose a thread
matching method

Select one or more thread
charts to match to



EmbroideryStudio e4 Reference Manual 833

 Add bitmap colors directly to the design palette (default).
 Choose a chart and match bitmap colors to actual threads. Click the 

Select Thread Charts button to access thread charts.
 Or, match bitmap colors to the nearest colors in the design palette.

Tip: Various techniques are available for changing design colors from 
the Design Colors toolbar.

Related topics...
 Graphics and multi-decoration file formats
 Loading bitmap artwork
 Loading vector artwork
 Preparing artwork for digitizing
 Preparing images for auto-digitizing
 Add & match image colors
 Working with fabrics
 Choosing threads

Converting designs with CorelDRAW Graphics

EmbroideryStudio lets you convert vector graphics directly to embroidery 
objects using a variety of techniques. Similarly, you can convert 
embroidery designs or objects to vector graphics. You can also quickly 
convert between different embroidery objects.

Convert objects with CorelDRAW Graphics

Use Mode > Tag Fill as Turning Satin to tag narrow shapes for conversion 
to turning stitching. 

Use Mode > Match to Embroidery Palette to toggle on/off thread color 
matching for converted vector objects.

Use Mode > Tag as Photo Flash to convert photos to Photo Flash 
embroidery from CorelDRAW Graphics.

Use Mode > Convert Embroidery to Graphics to convert selected 
embroidery to graphics and switch to CorelDRAW Graphics.

Use Mode > Convert Graphics to Embroidery to convert selected graphics 
to embroidery and switch to Wilcom Workspace.

Use Mode > Keep Graphic Objects to retain original artwork during 
conversion.
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Some EmbroideryStudio product levels include CorelDRAW® 
Graphics Suite as standard. This lets you convert vector objects directly 
to embroidery objects via CorelDRAW Graphics. You can also convert 
embroidery to vector objects. Individual objects or whole designs can be 
converted. Bitmaps can also be used.

To convert graphic and embroidery objects...
 Open a vector or embroidery design, depending on which mode you 

are working in – CorelDRAW Graphics or Wilcom Workspace.

The Convert function is located on the Mode toolbar. Behavior 
depends on the operating mode:
 In CorelDRAW Graphics, selected vector objects are converted to 

embroidery and displayed in Wilcom Workspace.

 In Wilcom Workspace, selected embroidery objects are 
converted to vector objects and displayed in CorelDRAW 
Graphics.

 If you want to keep a copy of the original vector objects, click the 
Keep Graphic Objects toggle in CorelDRAW Graphics.

 Use the Match to Embroidery Palette tool to toggle on/off thread 
color matching.
 When turned on, converted vector objects are assigned the nearest 

matching thread color in the current color palette. 

Convert in both 
directions
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 When turned off, a new thread color is added to the palette based 
on the vector color.

 Optionally, activate Tag Fill as Turning Satin. This produces a 
branched object as shown below. 

Tip: Vectors can also be converted to appliqué as well as to lettering. 
See also Creating lettering with CorelDRAW Graphics.

Related topics...
 Working with design files
 Creating lettering with CorelDRAW Graphics
 Convert vector graphics to appliqué 

Convert objects with Wilcom Workspace

You can convert vector objects to embroidery objects by right-clicking a 
selected object and select Convert > ... from the popup menu.

Without turning satin With turning satin

Vectors converted to lettering

Choose a 
conversion target
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The resulting object takes the current stitch type, color and object 
properties set for that digitizing method. Vector objects can be converted 
to appliqué. You can also create objects with turning stitches by adding 
stitch angles directly to vector objects.

You can easily convert objects from Column A/B to Complex Fill or 
Complex Turning. This is useful for editing. For example, as curved fill 
effects can only be used with Complex Fill objects, you can add them to 
Column A/B shapes by first converting to Complex Fill. Also when scaling 
designs, an Column A/B shape may become too big for Turning Satin. By 
converting to Complex Fill or Complex Turning, you can apply fixed or 
turning Tatami or some other fill stitch type. 

You can change an Appliqué or vector object to a complex fill object in 
the same way. You can also convert Complex Fill to Complex Turning. 
If you convert to Complex Turning, you are prompted to enter more 
than one stitch angle line and press Enter.

Enter angle points

Press Enter
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Note: If a current stitch type is not applicable to the target object – e.g. 
Contour stitch – Satin will be substituted. If the underlay type is not 
applicable – e.g. Center Run – Zigzag will be used.

Related topics...
 Adjusting stitch angles
 Convert embroidery objects to appliqué

Auto-digitizing artwork

The quality of auto-digitized designs greatly depends on the type and 
quality of the original artwork. Generally speaking, vector graphics 
preserve image quality when resized, whereas bitmaps cause problems 
of pixelation and image degradation when enlarged or scaled down. In 
order to make bitmap images more suitable for automatic digitizing, 
EmbroideryStudio also provides image processing capabilities and links 
to graphics packages.

Auto-digitize ‘instant embroidery’

Use Auto-Digitizing > Color Matching Method to preselect a thread 
matching method.

Use Auto-Digitizing > Instant Smart Design to automatically create 
embroidery from imported artwork instantly.

Use Auto-Digitizing > Keep Graphic Objects to retain original artwork 
during conversion.
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In essence, creating an embroidery design with the Instant Smart 
Design tool is simply a matter of selecting the image you want to 
convert, and clicking the tool. EmbroideryStudio automatically 
determines colors to treat as fills or outlines, or omit altogether. And it 
chooses the most suitable stitch types to apply with default settings. This 
is very useful for stitch estimates. The tool handles both bitmap and 
vector formats.

To auto-digitize ‘instant embroidery’...
1 Load and preset the artwork as necessary.

2 Optionally, choose a color matching method.

Insert artwork to 
auto-digitize

Default color 
palette
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3 Click Instant Smart Design and study the result.

By default, artwork colors are added to the palette. If you have chosen 
to match artwork colors, you might obtain a result like this...

4 Edit the result as preferred – e.g. change colors, change stitch types, 
delete any unwanted background stitching, etc. 
 Use the Color-Object List and/or Sequence toolbar to optimize 

the stitch sequence of your auto-digitized objects.

Artwork colors 
added to palette

Artwork colors 
matched to palette
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 Use the Closest Join and/or the Reshape tool to minimize 
connectors.

 Toggle underlays on/off with the Auto Underlay button.

Related topics...
 Loading & presetting artwork
 Crop bitmap images
 Preparing images for auto-digitizing
 Sequencing embroidery objects
 Reshaping embroidery objects
 Merge vector & embroidery objects
 Minimizing connectors
 Stabilizing with automatic underlay

Auto-digitize entire designs

For more control over object conversion, use the Smart Design method. 
This can recognize shapes in artwork and allow you to preset suitable 
stitch types for conversion. Smart Design determines stitching 
sequence based on closest join. Artwork is effectively ‘batch processed’ 
to create the many embroidery objects that make up a design. The tool 
handles both bitmap and vector formats. 

Use Auto-Digitizing > Smart Design to create embroidery designs directly 
from imported artwork.

Use Auto-Digitizing > Keep Graphic Objects to retain original artwork 
during conversion.
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To auto-digitize entire designs...
1 Load and preset the artwork as necessary.

2 Select the image and click Smart Design.
If the image requires preprocessing, the software displays the 
Prepare Bitmap Colors dialog. See Preparing images for 
auto-digitizing for details.
Next, the Smart Design dialog opens. Image colors are automatically 
sequenced and backgrounds omitted altogether.

Enter dimensions as exact 
values or as a percentage

Lock aspect ratio
toggle

Click to view selected 
colors in the design

Tick to omit 
unwanted 
colors
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3 Use the Color Allocation panel to omit unwanted colors. Use the 
Locate button to isolate selected colors.

4 Select a conversion method for color processing. By default, bitmap 
colors are added to the current colorway. Optionally, select a specific 
thread chart to match to or match colors to the current palette.

5 Optionally, add outlines to all detected shapes. Tick Add outlines and 
select a palette color from the droplist. This has the effect of 
reinforcing all color blocks with continuous, branched running stitches.

White background 
color omitted

All colors omitted 
except black

Specify preferred 
color handling 

Image colors 
added to palette

Image colors matched 
to nearest thread colors

Include outlines as 
preferred and 
choose color
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6 Click OK to process the image.

7 Edit object properties as preferred, including colors, stitch types, and 
so on. Even convert run outlines to satin borders.
 Use the Color-Object List and/or Sequence toolbar to optimize 

the stitch sequence of your auto-digitized objects.
 Use the Closest Join and/or the Reshape tool to minimize 

connectors.
 Toggle underlays on/off with the Auto Underlay button.

Related topics...
 Loading & presetting artwork
 Crop bitmap images
 Preparing images for auto-digitizing
 Sequencing embroidery objects
 Reshaping embroidery objects
 Merge vector & embroidery objects
 Minimizing connectors
 Stabilizing with automatic underlay

Auto-digitize individual shapes

Outlines added to 
all color blocks

Colors omitted and 
outlines only generated

Use Auto-Digitizing > Color Matching Method to preselect a thread 
matching method.

Use Auto-Digitizing > Turning Satin Object to fill narrow column shapes 
with turning stitch angles.

Use Auto-Digitizing > Tatami Fill Object with Holes to fill large areas with 
tatami stitching, preserving any holes.
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The Auto-Digitizing tools provide everything necessary to automatically 
digitize shapes in electronic artwork – both bitmap and vector – without 
using manual digitizing methods. These tools are useful for turning 
scanned images into embroidery designs that do not require particular 
artistic effects or embroidery-specific knowledge. If you are using a 
vector graphic, it must include a fill color. Auto-Digitizing can be used 
to create tatami fills as well as objects with turning satin. Use it also to 
digitize outlines and details with run stitching. Current properties are 
applied.

To auto-digitize individual shapes...
1 Load and preset the artwork as necessary.

2 Select an auto-digitizing fill method:
 Use Tatami Fill Object with Holes for large areas, preserving any 

holes within them. 
 If you want holes ignored, use Tatami Fill Object.
 Use Turning Satin Object to digitize narrow turning shapes with 

satin stitch.

Use Auto-Digitizing > Tatami Fill Object to fill large areas with tatami 
stitching, ignoring any holes.

Use Auto-Digitizing > Centerline Run Object to create centerlines in narrow 
shapes with run stitching.

Use Auto-Digitizing > Outline Run Object to create outlines of run stitching.

Enter dimensions as exact 
values or as a percentage

Lock aspect ratio
toggle
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3 Click the shapes you want to digitize. Stitches are generated according 
to current settings.

4 Optionally, edit object properties, including colors, stitch angles, 
entry/exit points and so on.

To auto-digitize outlines and details...
1 Select an auto-digitizing outline method:
 Use Centerline Run Object to create centerlines in narrow shapes 

with run stitching.
 Use Outline Run Object to create outlines of run stitching.

Turning satin

Tatami fill

Edit object properties 
as preferred
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2 Again click the shapes you want to digitize. Stitches are generated 
according to current stitch settings.

To edit the result...
 Edit the result as preferred – e.g. change colors, change stitch types, 

delete any unwanted background stitching, etc. 
 Use the Color-Object List and/or Sequence toolbar to optimize 

the stitch sequence of your auto-digitized objects.
 Use the Closest Join and/or the Reshape tool to minimize 

connectors.
 Toggle underlays on/off with the Auto Underlay button.

Related topics...
 Loading & presetting artwork
 Crop bitmap images
 Preparing images for auto-digitizing
 Sequencing embroidery objects
 Reshaping embroidery objects
 Merge vector & embroidery objects
 Minimizing connectors
 Stabilizing with automatic underlay

Auto-digitize
center lines

Auto-digitize 
outlines
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Auto-digitizing photographs

EmbroideryStudio provides dedicated techniques for auto-digitizing 
photographs. Both colored and grayscale photos can be used as input.

Tip: Results depend greatly on the resolution, color depth, and quality of 
source images. For best results, use crisp images with well-defined 
subjects and strong contrasts. In addition a degree of preparation is 
needed. This may involve preparation using third-party graphics 
applications such CorelDRAW Graphics. Tools are also available within 
Wilcom Workspace. See also Prepare photos for auto-digitizing.

Auto-digitize with Photo Flash

Feature Overview

Photo Flash
The Photo Flash feature creates embroidery designs from 
photographs and other grayscale bitmap images. The 
effect resembles the output of a line printer.

Reef 
PhotoStitch

The Reef PhotoStitch feature also creates embroidery 
designs from photographs and other bitmap images. The 
features creates open stitching reminiscent of a coral reef.

Color 
PhotoStitch

The Color PhotoStitch feature creates embroidery from 
photographs and other images. It produces variegated 
stitching using multiple thread colors.

Use Auto-Digitizing > Photo Flash to create embroidery designs directly 
from photographs.
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Use Photo Flash to create embroidery from photographs or other 
images, color or grayscale. Color images are automatically converted to 
grayscale. Photo Flash designs consist of rows of stitches of varying 
spacing settings. The effect resembles the output of a line printer.

To create embroidery with Photo Flash...
1 Insert the bitmap image in your design and scale it to the required 

size. 
2 Crop the image as desired using the Crop Bitmap tools.

Use Mode > Tag as Photo Flash to convert photos to Photo Flash 
embroidery from CorelDRAW Graphics.

Use Auto-Digitizing > Crop Bitmap to crop bitmap artwork for use with 
auto-digitizing.
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3 With the bitmap still selected, click the Photo Flash icon to access 
object properties.

4 In the Resolution panel, select a resolution option – Coarse, Medium, 
or Fine.

Note: The coarser the resolution the more spacing between rows.

Select resolution 
(row spacing)

Select positive or 
negative image

Enter row angle

Medium resolution Coarse resolutionFine resolution
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5 In the Row panel, enter a new angle as required.

6 In the Background panel, select a background option:

Tip: The option you select usually depends on whether the fabric is 
light or dark. The Dark option produces a negative of the image.

Option Function

Light Applies the maximum row width value to the lightest part of the 
image.

Dark Applies the maximum row width to the darkest part of the 
image.

Row Angle: 90°Row Angle: 0°

Dark backgroundLight background
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7 Select the Fills tab and adjust the stitch spacing and skew angle as 
required.

The Skew Angle determines the angle of the stitches.

Tip: Use TrueView™ for a more accurate representation of the 
stitching.

8 Fine-tune Auto Spacing and Auto Split settings as required.
 The Auto Spacing option automatically adjusts stitch spacing 

according to column width. For columns of varying width, Auto 
Spacing automatically adjusts the stitch spacing wherever the 
column changes width.

 Auto Split breaks long Satin stitches into shorter ones. It also 
distributes needle penetrations in a random pattern so that they do 
not form a line down the middle of the shape. 

Adjust stitch 
values

Adjust skew 
angle

Skew 
angle: 0°

Skew 
angle: 45°
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9 Press Enter or click Apply. 
If you have defined a ‘soft crop’ for your bitmap, EmbroideryStudio 
generates stitches for that area. Otherwise stitches are generated for 
the entire bitmap.

Note: In CorelDRAW Graphics, the Mode toolbar also includes a 
Tag as Photo Flash icon which allows you to convert photos to Photo 
Flash embroidery.

Related topics...
 Insert bitmap images
 Crop bitmap images
 Prepare photos for auto-digitizing
 Satin fixed spacing
 Applying satin stitch
 Split satin stitches

Auto-digitize with Reef PhotoStitch

Reef PhotoStitch expands on the Photo Flash auto-digitizing method 
to convert photos into embroidered designs. Automatically fill large areas 
with open stitching reminiscent of a coral reef. Adjust to the stitch 
resolution of choice.

Use Auto-Digitizing > Reef PhotoStitch to turn photographs into a single 
embroidery field resembling a coral reef.

Use Auto-Digitizing > Crop Bitmap to crop bitmap artwork for use with 
auto-digitizing.
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To create embroidery with Reef PhotoStitch...
1 Insert the bitmap image in your design and scale it to the required 

size. 
2 Crop the image as desired using the Crop Bitmap tools.
3 With the image selected, click Reef PhotoStitch.

4 Adjust the grayscale image settings as preferred:
 Click Auto Adjust to allow the software to optimize image settings 

for automatic digitizing.
 Use Brightness and Contrast settings to further differentiate 

stitched and unstitched areas.
 Use the Grayscale threshold setting to further filter the number 

of gray tones in the image.
 Click Invert Colors to create an image negative.
 Click Reset to return the adjusted bitmap to the default grayscale 

image.

Adjust grayscale 
image

Adjust reef stitch 
density and color
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5 Use the zoom buttons to examine the image preview in detail. 
Alternatively, holding down the Ctrl key, zoom in and out with the 
mouse wheel.

6 Adjust reef stitch settings as preferred:
 Adjust Density to create more dense or more open stitching, 

similar to Loop Spacing in stipple stitching. The highest density 
value may result in thread breaks.

 Select the thread color you wish to apply to the end result.
7 Use Preview to generate temporary stitching without closing the 

dialog. Move the dialog as necessary in order to preview the result in 
the design window. Further adjust settings until you obtain the look 
you want and click OK to confirm. 

Tips for use...
 Use crisp images with well-defined subjects and strong contrasts.



EmbroideryStudio e4 Reference Manual 855

 For denser stitching, try combining different outputs and different 
colors.

 Posterizing effects may produce good results at lower thresholds. In 
Corel PHOTO-PAINT, this is available via Image > Transform 
Posterize.

 Try applying filters such as Stucki, Jarvis and Crosshatch effects. 
 In Corel PHOTO-PAINT Stucki and Jarvis are available via Image > 

Convert to Black and White (1-bit). Adjust intensity as 
necessary.

 Crosshatch is available via Effects > Art Strokes > Pen & Ink.
 An interesting technique is offered by applying a halftone filter. In the 

sample below, the image is split into separate CMYK channels and 
Reef PhotoStitch applied to each one. In Corel PHOTO-PAINT select 
Image > Convert to CMYK Color and Image > Split Channels To 
> CMYK.

Related topics...
 Insert bitmap images
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 Crop bitmap images
 Prepare photos for auto-digitizing

Auto-digitize with Color PhotoStitch

Use Color PhotoStitch to create embroidery from photographs and 
other images. While Photo Flash designs consist of rows of single-color 
satin stitching, Color PhotoStitch produces variegated stitching using 
multiple thread colors. The overall effect is like multi-colored stippling.

To process the image...
1 Insert the bitmap image in your design and scale it to the required 

size.

2 Crop the image as desired using the Crop Bitmap tools.

Use Standard > Import Graphic to import artwork into current design as a 
backdrop for manual or automatic digitizing.

Use View > Show Bitmaps to toggle bitmap images on or off. Right-click for 
settings.

Use Auto-Digitizing > Crop Bitmap to crop bitmap artwork for use with 
auto-digitizing.

Use Auto-Digitizing > Adjust Bitmap to adjust image lightness and contrast 
in preparation for auto-digitizing.

Use Auto-Digitizing > Color PhotoStitch to automatically turn photographs 
and other bitmap artwork into multi-colored embroidery. 
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3 With the image selected, click Color PhotoStitch.

Note: Support is provided for transparent backgrounds in 24 bit and 
32 bit images.

4 Set the number of thread colors. There will be a point a diminishing 
returns where more colors do not always result in greater design 
clarity or stitchability. Usually 7 to 10 colors produce the best results.

5 Use the zoom buttons to examine the previews in detail. You can also 
zoom in and out with the mouse wheel.

Set required number 
of thread colors

Choose a color 
matching method
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6 Optionally, adjust stitching resolution to high, medium, or low. High 
resolution allows greater detail but with a higher stitch count. 

7 Click Adjust Bitmap for further options:
 Click Auto Adjust to allow the software to optimize image settings 

for automatic digitizing.
 Use Brightness and Contrast settings to further differentiate 

darker and lighter areas of stitching.
 Click Reset to return adjusted settings to default image settings.

8 Choose between several image variations:

9 Use Color Matching to assign image colors to the color palette for 
manual thread matching. This ensures the best representation. 
Alternatively, automatically match them to the current color palette or 

Option Function

Sepia In photographic terms, ‘sepia’ refers to the dark-brown color of 
old-fashioned prints. Originally the process involved adding a pigment 
made from cuttlefish ink during development.

Gray Grayscale images are ones composed exclusively of shades of gray, 
varying from black at the weakest intensity to white at the strongest.
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current thread chart. Select one or more available thread charts to 
match to.

10 Use Apply to generate temporary stitching without closing the dialog. 
Further adjust settings until you obtain the result you want and click 
OK to confirm.

To edit the result...
 Check the results with TrueView™ on and off. Turn connector 

stitching on and off. For better visualization, set TrueView™ viewing 
options to thin thread.
If you are unsatisfied with the results, click Undo and try again. Try 
different settings and check the previews. You may need to touch up 
the image in PHOTO-PAINT if none of the results is good enough.

Choose a thread
matching method

Select one or more thread
charts to match to

Click Apply to
generate preview
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 Edit the results and manually merge thread colors as necessary using 
the Color-Object List.

 If you have added RGB colors to the color palette, open the 
Color-Object List and Threads dockers side-by-side, and select the 
thread charts you have available from the Select Thread Charts 
dialog.
Select each color block in turn, check the closest match in Threads 
docker, and manually choose a thread. Sometimes the closest match 
may not be the best or be unavailable. Choosing the correct thread is 
key to getting a good result.

Related topics...
 Insert bitmap images
 Crop bitmap images
 Prepare photos for auto-digitizing

Manually merge 
thread colors as 
necessary



EmbroideryStudio e4 Reference Manual 861

PART IX
EMBROIDERY PRODUCTION

Design processing and encoding involve all the important, back-end 
operations of embroidery design and manufacture. This is where you 
actually output your designs to machine, disk, printer, cutter, and so on. 
For this, you will need an understanding of embroidery file types as well 
as different machine formats. Depending on your setup, you will also 
need an understanding of traditional storage media such as embroidery 
disks.

Design hooping
This section deals with selecting and centering hoops, both manually and 
automatically. It also covers defining and editing custom hoops. See 
Design Hooping for details.

Design reports
From the same EMB design file, you can output production worksheets or 
approval sheets for machine operators or customers respectively. This 
section describes how to create production worksheets and approval 
sheets as well as how to send designs as email attachments. See Design 
Reports for details.

Machine files
This section describes the different conversion options for opening and 
saving stitch and outline design formats. It also provides details about 
the processing of Melco CND outline files, including color merging, as well 
as reassigning colors to both stitch and Melco CND files. See Machine 
Files for details.

Embroidery output
This section describes how to stitch designs out with the Stitch Manager 
and with Connection Manager utilities. It also explains how to save 
designs for machine, how to read and write to embroidery disk. It also 
deals with exporting multi-decoration files. See Embroidery Output for 
details.

Machine networking
A Wilcom EmbroideryConnect machine network provides for wireless 
design transfer to embroidery machines with a USB port. When activated 
in the EmbroideryStudio software, you can send machine files wirelessly 
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via a standard WiFi network to a compatible EmbroideryConnect device 
plugged into the machine. See Machine Networking for details.
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Chapter 35

Design Hooping

Devices made from wood, plastic, or steel, hoops are used to tightly grip 
fabric and stabilizer between an inner and outer ring. Designed to hold 
fabric taut against the machine bed for embroidering, they attach to the 
machine’s frame. Fabrics must be hooped before stitching out. 
EmbroideryStudio allows you to select from a wide range of standard 
factory-supplied hoops. You can also define your own from scratch or 
based on a standard hoop.

The Auto Hoop feature allows you to:
 Prompt EmbroideryStudio to select a hoop from a hoop library.
 Show/hide the selected hoop in the design window and design preview 

area of the production worksheet. See also Print reports.
 Create/edit/delete user-defined hoops with circle, oval, rectangle, 

round rectangle, or square shapes.
 Zoom-to-hoop in the design window and print preview.

Hoops & templates

When it comes to stitching out, it is important to align the fabric squarely 
in the hoop, with even pressure on all sides, and fabric patterns and 
weaves running perpendicular to the hoop. Otherwise, fabric bias allows 
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stretch. This can distort stitching and result in puckering. Each hoop 
contains vertical and horizontal centering marks on the frames. These 
help with aligning both the fabric and the design.

Many hoops also come with a clear plastic template overlay. These 
include alignment lines, with tiny holes which allow you to create 
positioning marks. Hoop template display can be toggled on or off 
independently of the hoop itself.

Uses in the software...
 Templates include alignment and registration guide markings. These 

can help production staff align the design in the hoop.
 Templates can also be printed with alignment and registration 

markings. This allows you to cut out the printed design and align it in 
the hoop with the physical template.
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Setting up hoop lists

A range of commercial brands is available for a wide variety of design 
types. Configure the My Hoops list to include only those hoops you 
currently have available for use. If you are using a hoop that is not in the 
hoops list, you can define your own and save it for later use.

Note: The Auto Hoop feature only selects hoops from the My Hoops 
list. Thus you need to set up this list before Auto Hoop is available for 
use. 

To set up a hoop list
 Right-click the Show Hoop icon. The first time you run it, the Options 

dialog will open with the My Hoops dialog already opened. Otherwise, 
click the My Hoops button.

Click View > Show Hoop to turn hoop display on or off. Right-click to 
change hoop settings.

Click to set up your 
own hoop list
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 Use the My Hoops dialog to set up your own list of available hoops. 
Select from the listed hoops and use the arrow buttons to assign.

 Click OK to confirm. Only selected hoops will be available for manual 
or automatic selection.

Tip: You may be working with hoops which don’t appear in the 
standard hoop list. Define your own hoops using circle, oval, rectangle, 
and other shapes. 

Related topics...
 Selecting hoops automatically
 Creating custom hoops

Setting auto start & end

Before stitchout, some embroidery machines require you to position the 
hoop precisely in relation to the needle. The Auto Start & End feature 
is available to connect first and last stitches in a design. This makes it 
easy to position the needle before stitching, and reduces the chance of 
the needle hitting the side of the frame.

Note: Machines which auto-center designs around design extents will 
ignore the Auto Start & End setting.

Add available 
hoops to your 
custom list

Use View > Auto Start & End to toggle the Auto Start & End function on/off 
according to the current settings. Right-click to adjust settings.
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To set automatic start & end points
 Right-click Auto Start & End.

 Select the Apply checkbox to connect first and last stitches in the 
design.

 Select Maintain automatically to maintain the design center after 
modifying the design.

 Select a centering method:

Method Function

Auto start and 
end

By default, connecting stitches are created from the start and 
end points to the center of the design. Select one of the nine 
preset end points.

Return to start 
point

Creates a connecting stitch from the end point to the start 
point.

Digitize 
start/end point

Primarily used with multi-decoration designs where you want 
to strictly define the start/end point of the embroidery 
component. If you select this, you are prompted to select the 
point after clicking OK. Tick the ‘Separately’ checkbox to 
create separate start and end points.

Select ‘Apply auto
start & end’

Select centering
method

Specify how to
match connecting

stitches

Select preset 
end point

Click to enter
separate start and

end points

Specify the
connector type
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 Select to match connecting stitches on the Horizontal plane, Vertical 
plane or both in the Match On panel.

 Select the type and length of the connecting stitches in the 
Connectors panel. 

 Click OK to confirm. Connectors – travel runs or jumps – are inserted 
as specified, before first and after last stitches of the design.

Tip: Auto-start & end symbols – a green circle and a red cross – can 
be activated via the Options > View Design tab. See Show 
auto-start & end points for details.

Caution: Problems may occur when you try to set a common start and 
end point for team names. 

Related topics...
 Design viewing options
 Types of connectors
 Outputting teamname designs

Selecting hoops automatically

The simplest way to hoop a design is to prompt the system to select a 
hoop for you. Auto Hoop finds the smallest hoop which can 
accommodate the entire design. Auto Hoop only selects hoops from the 
My Hoops list thus only ever suggesting a hoop you have pre-selected 
as available for use. 

Match on bothMatch on vertical Match on horizontal

Click View > Auto Hoop to prompt the system to select a suitable hoop 
automatically.
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To select a hoop automatically
 Open your design and click the Auto Hoop icon or access the 

command from Design > Auto Hoop menu. From amongst its library 
of predefined hoops, EmbroideryStudio looks for a suitable hoop.

 If the My Hoops list is empty, the system prompts you to create a 
custom list. 

 If the system cannot find a suitable hoop with a stitching area adapted 
to the current embroidery design, it displays a message with the 
option to create a new hoop, either automatically or manually.

 Click Auto Create if you want the system to generate a suitable hoop. 
EmbroideryStudio will create either a circular or rectangular hoop to 
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best suit design dimensions. It will also name it accordingly – e.g. 
‘Circle 100mm’.

 Click Manual Create/Select if you want to define your own hoop 
template to suit a specific hoop type you may have. 

 Optionally, select View > Zoom > Zoom to Hoop or press Alt+0 to 
view the entire hoop in the design window.

 Optionally, turn on the Hoop Template display via the View menu. 
Templates can be used instead of grids. The template, especially when 
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printed in the worksheet, provides a means for aligning the design in 
the hoop at the correct location and orientation.

Tip: The current hoop name is displayed in the Prompt Line.

Related topics...
 Setting up hoop lists
 Define custom hoops

Selecting hoops manually

From your My Hoops list, you can manually select your preferred hoop. 
Generally you will want to select the smallest hoop which will 
accommodate your design. This will hold the fabric tight while stitching. 
When you output your design, most machines will automatically center 
the design within the hoop according to its geometric extents. Some 
machines will center designs in the hoop at the start needle position. For 
these machines, you can set a starting point using Auto Start & End 
settings.
For display purposes, EmbroideryStudio will generally ensure that the 
design is centered in the hoop. However, you can use the manual option 
to lock the hoop position onscreen. This means it won’t automatically 
center while you are digitizing. It’s always a good idea, however, to turn 

Click View > Show Hoop to turn hoop display on or off. Right-click to 
change hoop settings.

Click Zoom > Zoom To Hoop to view entire hoop in the design window. 
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auto-centering back on to check that the design will fit within the selected 
hoop.

To change hoops
 Open your design and click the Show Hoop icon. The current hoop is 

displayed. It may be too big or too small for your design.

 Right-click the icon. The Options > Hoop dialog opens.

 Select a hoop from the My Hoops list. Configure the list to include 
only those hoops you currently have available for use via the My 
Hoops function.

 In the Position panel, choose how you want the hoop to be positioned 
on the machine:

Choose 
preferred hoop
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 Automatic centering: Ensure that design is always centered 
onscreen within the hoop.

Normally the hoop will center itself around the geometric center of 
the design. However, you have the option of centering around the 
start needle position. This option is usually used on conjunction 
with Auto Start & End settings.

 Manual: Use the manual option to make sure the hoop display 
does not move from its original position. This means it won’t 
automatically center while you’re digitizing. This may be important 
if you are combining embroidery with print or if you want to stitch 
out in certain locations like chest pockets.

 Manual > Set hoop center: Digitize a point on the design that the 
hoop will center around. 

 Click OK. If you selected Set Hoop Center, click a point where you 
want to center the hoop.

 Use the View toolbar to turn on/off hoop. 

Design automatically
centered after editing

Design remains in
same position
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 Optionally, click the Zoom to Hoop icon, select View > Zoom > 
Zoom to Hoop or press Alt+0 to view the entire hoop in the design 
window.

 Optionally, turn on the Hoop Template display via the Options 
dialog or View menu. The template may be used to help position your 
design within the hoop.

Tip: You can include the hoop template in the production worksheet, 
together with alignment and registration guide markings. This allows 
you to cut out the printed design and align it within the hoop. Use the 
template markings to align it to physical hoop template.

Related topics...
 Display grids, rulers & guides
 Scroll options

Show the hoop
template
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Creating custom hoops

You may be working with hoops which don’t appear in the standard hoop 
list. Define your own hoops using circle, oval, rectangle, and other 
shapes.

Define custom hoops

If you are using a hoop size that is not in the hoop list, you can define a 
custom hoop to conform to the dimensions of any physically existing 
hoops you may be using. Various formats are available to define anything 
from rectangular, oval, circle, to square hoops.

To define a custom hoop
1 Right-click the Show Hoop icon. The Options > Hoop dialog opens.

Click View > Show Hoop to turn hoop display on or off. Right-click to 
change hoop settings.

Create new 
hoop



Chapter 35   Design Hooping 876

2 Click Create. The Create Hoop dialog opens.

3 Select the required format for your hoop from the droplist – e.g. 
rectangle, circle, etc.

4 In the Stitching Area Dimensions panel, enter the dimensional 
characteristics of the stitching area:
 Circle: Circle stitching areas only require a Diameter to be 

specified.

Select required
format

Enter required
diameter
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 Square: Square stitching areas only require a Width to be 
specified.

 Rectangle: Rectangular stitching areas require Height and Width 
dimensions.

Enter required
width

Enter required
dimensions
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 Oval: Oval stitching areas require three dimensions – Total 
Height, Rectangle Height, and Width.

 Round Rectangle: Similar to oval stitching areas, round 
rectangles require three dimensions – Height, Width, and Corner 
Radius. The greater the radius, the rounder the corner.

5 Click Save Hoop or Save Hoop As. The Save Hoop As dialog opens.

6 Give your hoop a meaningful name – e.g. ‘Rectangle 180x120’.

Enter required
dimensions

Enter required
dimensions

Rectangle 180x120
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7 Click Save. Your user-defined hoop is now available for use along with 
the system-defined hoops.

Edit custom hoops

You can edit and delete custom hoops as required – both those you have 
defined yourself and those created by the system. Only custom hoops 
can be modified or removed, not those from the existing library.

To edit a hoop
 Right-click the Show Hoop icon. The Options > Hoop dialog opens.

 Select the hoop you want to edit or delete from the My Hoops list.
 Click Delete then OK to confirm. The hoop is permanently removed.

Click View > Show Hoop to turn hoop display on or off. Right-click to 
change hoop settings.

Edit or delete 
custom hoops
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 Click Edit. The Create Hoop dialog opens. The same dialog is used 
for editing as for defining hoops. 

 Enter new dimensions and click the Save Hoop button.

Related topics...
 Define custom hoops

Edit dimensions
as required

Click to save
hoop
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Chapter 36

Design Reports

From the same EMB design file, you can output production worksheets or 
approval sheets for machine operators or customers respectively. 

EmbroideryStudio allows you to customize information in the format you 
require. The printing capability also allows you to:
 Personalize worksheets with company name and logo
 Print approval sheets with or without design details
 Display the assigned hoop
 Visualize on selected fabric/garment
 Include selected colorways.
Optionally, email production worksheets in PDF format with the 
embroidery file as an attachment in a specified format – e.g. EMB or DST, 
etc. Screen images may also be captured in PNG format to distribute 
designs for viewing in real colors.
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Outputting designs as images

Designers frequently want to distribute their designs for viewing in real 
colors, in TrueView™ or otherwise, with or without fabric backgrounds. 
This might be for stock design sales purposes, for approval of digitized 
designs, or for presentation on the web or in catalogs. Screen images are 
captured in PNG format because it supports transparency.

To output a design as an image
1 Open the embroidery design.
2 Select File > Capture Design Bitmap.

Select Output 
option

Check bitmap 
resolution

Select image
selection option

Select to include
background color or

fabric
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3 Select a Selection option:

4 Select an Output option:

Option Function

Whole design 
(1:1)

Captures the screen image in a ratio of 1:1.

Current design 
window

Captures the screen image at the currently selected zoom 
factor.

Custom Lets you specify a capture area. You are prompted to define 
the area to capture.

Option Function

Save to disk Save screen capture to disk. The Save Capture Screen dialog 
allows you to select a location, name and format for the 
captured design image.

Send via email Lets you send the screen capture as an email. A new email 
message opens with the image attached. This option only 
works with the default MAPI compliant desktop email. It won’t 
work with email apps or other clients that don’t support the 
MAPI standard. Generally, this means MS Outlook email 
clients only.

Save & send Lets you both save to hard disk and send as an email 
attachment.

Draw marquee 
around selection 
area
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5 Select Include background/fabric to include the background color 
or fabric with the screen capture.

Note: Bitmap resolution defaults to current screen resolution. 
Properly calibrated, this figure should be approximately 96 DPI. 

Related topics...
 Virtual embroidery

Printing design reports

EmbroideryStudio allows you to print designs in various predefined 
formats. The most common are the approval sheet and the production 
worksheet. Approval sheets are usually sent to the client for confirmation 
prior to production. The production worksheet is the link between 
designer and embroidery machine operator. It contains a design preview 
as well as essential production information, including design size, color 
sequence and special instructions. Reports can be output as hard copy or 
in electronic (PDF) format.

Caution: If certain thread colors are not available on your printer, they 
may be mapped to a different color, including white. Print the design in 
TrueView™ color, or black and white, or turn off color mapping. See your 
printer manual for more information.

Print reports

Image captured as 
Whole Design (1:1) with 
background fabric

Use Docker > Design Information to view and modify design details prior to 
design approval or stitchout.

Use Standard > Print to print production worksheets for the current design 
using the current settings.
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Create a hard copy of your design report using a printer or plotter. 
Alternatively create soft copy in PDF format. Optionally, send it directly 
as an email attachment. Preview the report prior to printing. 

To print a report
1 Before printing, it’s a good idea to check design information to make 

sure all details are up-to-date.
2 Click the Print icon or select File > Print.

3 Select the printer or plotter you want to use and required number of 
copies.

4 To select a report type, click the Options button. The Print Options 
dialog opens.

Click to preview 
worksheet

Click to select /
customize report

Select tabs to 
customize 
report details

Select report
type/s
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5 Select a report type in the Print panel. Multiple reports can be batched 
as part of the same print run. Tick the checkbox next to each. 

6 Select tabs to customize report details as required. Tabs vary with the 
report type.

7 Click OK to close Print Options.
8 If you are using a plotter, click Properties, and set pen colors to 

correspond with the thread colors in the design.

Note: Refer to your plotter manual for information on setting up pen 
colors.

9 Click Preview to inspect the report before sending to print.

10 To print the design, choose an option:
 Print Now: Click to send the design report to your local printer.
 Save as PDF: Click to save the report as a PDF document. You are 

prompted to save to the hard drive or network location.
 Send PDF via Email: Click to send the report – usually an approval 

sheet – as a PDF attachment to your local email client. The PDF is 

Click Close to return to 
design window

Choose a print 
option

Production 
information and 
threadup details

Modify report 
options
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automatically identified by customer name, order number, and 
current date.

Related topics...
 Viewing & managing design information
 Customizing design reports

Report types

In addition to production worksheets, EmbroideryStudio provides a 
number of predefined report types including approval sheets, product 
summaries, color films, and appliqué patterns.

Report types include:

Approval sheet 
attached to email for 
customer review

Report type Function

Approval 
sheet

This is intended for the customer, not production staff. Customers 
can see what they are ordering and approve accordingly. 

Production 
worksheet

This is intended for production staff. All production-related 
information, such as bobbin length, design size, garment fabric, 
etc, is provided.

Production 
summary

This provides two summary tables of the design and associated 
colorways – a Colorway Summary together with a Design 
Summary. 

Select report 
type
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Color films
This report type lets you print color blocks in the design as they appear 
in the Color-Object List. It provides color block information so that 
production staff can see each stitch color in order of stitchout. Separate 
color films are printed for selected colorways on the last page of the 
worksheet.

Related topics...
 Customizing design reports
 Print appliqué patterns

Appliqué 
patterns

This shows appliqué patterns – cutter information – isolated from 
the design. This tells the operator which appliqué pieces are to be 
included.

Report type Function
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Customizing design reports

For each report type you select, tabs allow you to further customize 
report details. Tabs vary with the report type. The Production 
Worksheet actually provides a superset of all available options.

Report tabs

Below is a superset of all tabs available for different report types. The 
Production Worksheet includes all tabs. Other reports contain a 
subset.

General options
Reports generally have the following customizable layout:
 Standard header/footer, incorporating company name/logo, customer 

name, colorway name, user-specified fonts, margin control, etc
 Company name/logo
 Page numbers
 Barcode in header – available for all report types
 Multiple vertical ‘full info’ strips allocated on a single page if zoom 

parameters allow. Alternatively, there is a Start New Page option on 
Info tab to force the layout to start vertical info strips on a separate 
page.

The General tab includes the following layout settings:

Select tab to 
customize report 
details

Select report
type/s

Include order 
information on 
approval sheets

Option Function

Text / heading 
font

Set parameters for all text and headings appearing in the report – 
e.g. Arial for print, Verdana for online reports.
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Terms & conditions
Terms and conditions text is stored in an internal defaults file. The only 
way to update the text and save it for later use it to do the following:
1 Open a new design sheet and digitize a simple object.
2 Open Print Preview and click Options.
3 Select the Approval Sheet report type.
4 Key in your own Terms & Conditions and close print preview.
5 Close the software – don’t save the temporary design.
After restart, each time the approval sheet is used, it contains the 
updated Terms & Conditions.

Barcode options
Some machines read barcodes in order to load designs. Typically, the 
digitizer will send the design to machine memory or database, then print 
out a worksheet. The operator will take the worksheet, scan the barcode, 

Print in 
English

Useful when printing to plotters where the device driver does not 
support the character set you require. Deselecting the checkbox 
prints the report in the language of the operating system. 

Print design 
filename

Include the filename of the current design in the header of the 
product report.

Margins Add a margin between the edge of the page and the content of the 
report. The page size itself is set via the Print dialog.

Company Include your company name on the report. Enter a name and/or 
attach a company logo. If you have already entered one or more 
company names into the system, select from the droplist. 
Optionally, print the logo on the first page only.

Order 
information

Include customer name and order details.

Terms and 
Conditions

Include terms and conditions of use relating to your company 
designs. See below.

Option Function
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and the machine will load the associated file. The Barcode tab allows you 
to specify a standard format based on design name or a custom format.

Many companies are switching to barcode readers on embroidery 
machines to ‘pull’ designs from Windows network locations rather than 
having the computer ‘push’ them to the machine. In addition to design 
name, some machines require the file extension. Amongst the barcode 
options, you can choose to include the current file extension or nominate 
one of your choice – e.g. ‘DST’. 
The ‘custom’ option is provided in case you have other barcode 
requirements – e.g. for pricing purposes.

Colorway options
The Colorways tab allows you to include or exclude selected colorways 
for the current design.

Specify preferred 
barcode format

Select Selected

Hold down <Ctrl>
to select multiple

items

Select colorway 
display for 
printout
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Separate sheets are generated for each selected colorway.

If the Production Summary report type is selected, the Colorway 
Summary table is printed together with the Design Summary table. 
You can also print color blocks in the Colorway Summary table by 
selecting the Show Colors in Summary option in the Stop Sequence 
tab.

Design summary 
table

Colorway summary 
table
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Use the Design tab to include background or product with the colorway.

Tip: Select Crop to Design to crop the empty space around the design.

Zoom options
The Zoom tab lets you set a zoom factor for the design preview and 
physical printout.

Customizable options include:

Related topics...
 Visualize products

Design options

The Design tab allows you to toggle on/off the same options available on 
the View toolbar. Print designs in TrueView™ or stitch only, with needle 

Option Function

Zoom 1.1 Shows design at actual size.

Zoom to fit Scales design to fill available space on the printout.

Zoom to product Scales whole product to fill available space on the printout. 

Custom Sets a specific zoom factor.

Include background 
or product on 
worksheet

Set design zoom 
factor for current 
printout
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points, connectors, etc, or without. Include background fabric or color as 
preferred.

Include the hoop with or without the template. Templates include 
alignment and registration guide markings. These can help production 
staff align the design in the hoop. You can also include the product 
backdrop which can guide staff in correct placement.

Print all types of multi-decoration supported by EmbroideryStudio, either 
separately or in combination. Click the Repeats button to access the 
dialog and set repeating design options. 

Related topics...
 Viewing design components
 Viewing design repeats
 Hoops & templates

Select embroidery
components to

display

Tick to display sequins
(and other machine

functions)

Tick to include bling
components

Click to access 
design repeats
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Embroidery components
To display embroidery components, select from amongst Outlines, 
Stitches, Needle Points, Connectors, TrueView in the Design tab. 
For TrueView to display, you must also have Stitches selected.

Print only
To display print components only, select between Bitmaps and Vectors.
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Sequin components
To display sequin components, select Functions in the Design tab. A 
sequin production summary shows color, size and quantities by sequin 
device as well as a summary on the first page.

Bling components
To display bling components, select Bling in the Design tab. The bling 
production summary shows stone colors, sizes, and quantities as well as 
a summary on the first page. 
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Note: When bling is output as multiple files, each color is separated into 
different templates for flood-filling with selected rhinestones. 

Related topics...
 Output to bling cutter

Design backgrounds
The Design tab also provides options to display design backgrounds – 
e.g. fabric, product, and/or hoop. 

Amongst background options, you can set:

Option Function

Hoop Include the selected hoop, whether or not currently displayed on 
screen.

Hoop template Templates include alignment and registration guide markings. 
These help align the design in the hoop.

Background Include any background currently displayed – color or fabric.

Crop to design Crop any background to the extends of the design, rather than 
the full page.

Product Garment or product backdrop on which to position the design. 
Use it to display location, size and overall appearance for 
visualization or approval purposes. 

Extents box Place an outline around the design to delineate its full extents.
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Related topics...
 Fabric & product backgrounds
 Hoops & templates
 Setting auto start & end

Information options

The Info tab lets you filter information to include on production 
worksheets.

Customizable options include:

Start/end 
crosshair

Print a cross hair across the design indicating design start and 
end points.

Guides When contrasting colors are used in the colorway for guide and 
background colors, guides can be turned off.

Standard Reset printing options to default values.

As Window Set printing options as per current settings in the design window.

Option Function

Option Function

Full Includes all design and production information included in the 
Design Information docker. This information can be further filtered 
via the Blocks tab.

Short Includes only default header and footer information. Usually used 
in conjunction with full size design in order to visualize on garment. 
See also Zoom tab.

Stop 
sequence

Includes only stop sequence information on the worksheet. This 
information can be further filtered via the Stop Sequence tab.

Design name / 
filename only

Includes the design filename as the printout information without 
any other text.

None Eliminates design details altogether and suppresses display of 
default header and footer information – again, can be used in 
conjunction with full size design in order to visualize on garment. 
See also Zoom tab.

Set information to 
include on production 
worksheets



EmbroideryStudio e4 Reference Manual 899

Tip: Worksheets include information entered into the Design 
Information > Summary tab, including comments but excluding 
keywords. See also Viewing & managing design information.

Blocks options

The Blocks tab lets you further filter production information available on 
the Design Information docker for inclusion in the printout.

Select design statistics to include on the worksheet:

Start new 
page

Prints design details on a separate sheet.

Use left side Displays the information column on the left side of the page (rather 
than the default right-hand side).

Option Function

Option Function

Left / right / up 
/ down

Depending on where the design start/end point has been set, 
these figures indicate the distance from that point. 

End X / Y The coordinates of the last stitch. 

Area Total area covered by design – used for estimating hoop sizes, 
fabric requirements, 3D foam, or whether design will fit target 
location.

Max / min 
stitch

The maximum and minimum stitch lengths, and maximum jump 
stitch length in the design.

Thread chart 
type

The name of the thread chart used in the design. All required 
brands for used threads are displayed in a comma-separated list. 

Thread usage Meterage of thread required per color.

Total thread Indicates total meterage of top thread required to stitch out the 
design.

Set detailed 
production information 
for inclusion
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Here is a sample production worksheet with all options selected:

Related topics...
 Viewing & managing design information
 Assign thread colors
 Doing runtime estimates
 Design Hooping
 Setting auto start & end

Total bobbin Total meterage of bottom (bobbin) thread required to stitch out the 
design.

Machine 
runtime

This checkbox is only available if the feature is available in the 
software. If there are no machines set up, checking ’Machine 
runtime’ has no effect as there is nothing to print. 

Option Function

Left / right / up / down

End X / Y

Max / min stitch

Thread chart type

Thread usage

Total bobbin
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Stop sequence options

The Stop Sequence tab lets you further filter production information 
available on the Design Information docker for inclusion in the 
printout.

Select the statistics for each color block:

Here is a sample production worksheet with all options selected:

If the Production Summary report type is selected, the Colorway 
Summary table is printed together with the Design Summary table. 
You can also print color blocks in the Colorway Summary table by 

Option Function

Stitch count Include number of stitches per color.

Needle number Include needle number corresponding to each color change. 
This is only really relevant to needle-addressing machines.

Chart Brand name of thread chart used.

Element name User-defined name to identify each color block. 

Show colors in 
summary

Include color samples in a colorway summary table. 

Choose stop 
sequence information 
for inclusion

Stitch count

Needle number

Chart

Element name
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selecting the Show Colors in Summary option in the Stop Sequence 
tab.

Related topics...
 Viewing & managing design information
 Name design elements
 Colorway options

Colors displayed in 
colorway summary 
table
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Chapter 37

Machine Files

By default EmbroideryStudio saves to its native file format, EMB. This 
format contains all information necessary both for stitching a design and 
for later modification. When opening designs created or saved in other 
formats, EmbroideryStudio converts them internally to EMB format. They 
can then be modified using the full range of EmbroideryStudio features. 
Depending on the file type, you may need to provide additional 
information to assist EmbroideryStudio in the conversion process.

Opening machine files

If you want to scale a design, edit an outline or change a stitch type, then 
the design or selected elements must be first converted into ‘objects’. By 
default, machine files are converted to outlines and objects upon 
opening. Open options should reflect how the design was originally 
digitized, not how you want it now. Experiment with the settings to get 
the best results. 

Tip: To ensure object outlines, stitch types, stitch density and colors are 
correct, it is always a good idea to check and edit designs after 
conversion. To improve the quality of a machine file, it is sometimes 
better to edit stitches before conversion.
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Object recognition

Machine files are generally not suited to modification because stitches are 
not regenerated. However, EmbroideryStudio can interpret object 
outlines, stitch types and spacing from stitch data with some success. In 
this way, you can re-constitute old tape format files and other machine 
file formats for modification in EmbroideryStudio. These ‘recognized’ 
designs can be scaled with stitches recalculated for the new outlines. 
Processing is effective for most machine files but cannot produce the 
same level of quality as original outlines and may not handle some fancy 
stitches.
When you convert a machine file to design file format, EmbroideryStudio 
reads stitch data stitch-by-stitch according to the needle penetration 
points. It recognizes stitch types, spacing and length values, stitch 
effects, and can determine object outlines. Stitch types are assigned as 
Satin, Tatami, or Program Split depending on the pattern of needle 
penetrations.
With Tatami, EmbroideryStudio recognizes stitch spacing and length, and 
applies a random factor. If a design is converted from ESD format, Zigzag 
and Triple Run objects are also recognized. If an object is not recognized, 
it becomes (or remains) a manual object with general and connector 
properties only. As such, it will not scale well.
Recognized object outlines and stitch values are stored as object 
properties in EmbroideryStudio. This means you can scale and transform 
recognized designs in the usual way. You can also change the stitch 
density of the whole or selected parts of a design, and/or of certain stitch 
types.
By default, machine files are converted to outlines and objects upon 
opening but you can also choose to open them without recognition. 
Designs opened in this way can be output for stitching in another format. 
Or you can edit stitches and add new elements. For such purposes, you 
do not need to retrieve information about how the design was created. 
You can scale machine files which have been opened without 
object/outline recognition. However, because the stitch count does not 
change, the density increases or decreases with the design size. Thus you 
should not scale machine files by more than ±10% or some areas may 
be too thickly or too thinly covered.

Original stitch design Scaled stitch design opened 
without object/outline recognition
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Note: With or without object/outline recognition, machine files can be 
saved in EMB format once they are opened in EmbroideryStudio.

Open machine files

When you open machine files with object/outline recognition, you can 
set options to determine how the design will convert. Options vary with 
file type. Alternatively, by opening a machine file without recognition, 
stitch data is preserved. This allows you to perform minor stitch edits and 
scaling operations without compromising the original machine file. 
Alternatively, you can process the whole or selected parts of a design 
after opening and editing.

To open machine files with or without object recognition
1 Open a file from hard disk or read it from embroidery disk.

2 Select a machine file format from the Files of type list and select the 
file to open.

Select format

Click Options

Select file
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3 Click Options. Depending on the file type selected, different options 
are available.

4 Select or deselect the Objects/Outlines checkbox.
Remember, when you open machine files without object/outline 
recognition, ‘manual objects’ are created wherever machine functions 
– e.g. color changes or trims – are detected in the design. They have 
only general and connector properties. 

5 Select a different machine format from the Machine Type list as 
required.
The machine type will default to one suggested by the file format – 
e.g. DST will be interpreted as Tajima. However, you can choose to 
convert the file to a different machine format – e.g. Barudan.

6 Enter the number of jumps to recognize as trims.
When EmbroideryStudio encounters this number of consecutive 
jumps, it will convert them to a Trim function. If this value is different 
from the original design, Trim functions will be not be inserted 
correctly.

7 Use the Stop code as panel to select the output type for stop codes:

Option Function

Color change Stop codes are interpreted as ‘Next Color’ commands. The 
next color is selected from the default color palette.

Stops Stop codes are interpreted as ‘Explicit Stop’ commands. The 
machine stops stitching.

Custom Lets you map thread colors to every stop code in the file. This 
means you can color code machine files which do not contain 
needle addressing information. See Reassigning colors to 
machine files for details.

Choose whether to
recognize objects/outlines

in the design

Select machine
format

Select output type
for stop codes

Enter number 
of jumps as 
trims
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8 Toggle the Automatic Connectors checkbox as required.

9 Check the status of your embroidery machine. Then select the correct 
setting – Speed1 or Speed2 – from the list (if available).
On some Barudan machines there is a speed switch. Depending on its 
position, fast is assigned as either Speed1 or Speed2. For example, 
if you select Speed1, each fast speed function will be translated into 
a Speed1 command.

10 Click Advanced to set advanced recognition options.
11 Click OK and then Open.

If you have ticked the Objects/Outlines checkbox, the design is 
processed and converted to embroidery objects with fill or outline 
stitch properties as well as general and connector properties. If an 
object is not recognized, it becomes a manual object with general and 
connector properties only.

If you have opened without recognition, you can output the design 
without change or perform minor scaling and transforming actions 

Option Function

On Open appropriate designs with automatic connectors without 
having to use object/outline recognition.

Off Open designs with connectors recognized as manual objects. 
This avoids stitch editing problems caused by automatic 
connectors – recommended for open fills.

Select required 
speed

Design opened without 
recognition – manual objects only

Design opened with recognition – mixed 
embroidery and manual objects
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without losing the original stitch information. Alternatively, you can 
process the whole or selected parts of a design after editing.

Related topics...
 Machine Formats
 Recognize object outlines
 Adjusting stitch densities
 Using embroidery disks
 Gunold PCH format
 Wilcom INP format

Advanced recognition settings

You can fine-tune how EmbroideryStudio converts machine files using 
advanced recognition options. By default, EmbroideryStudio converts 
stitches as Tatami, Satin, or Run stitches according to the settings in the 
Recognition - Advanced Options dialog. You can change these values, 
or choose not to convert certain stitch types at all. Generally, the default 
settings provide the best results for the most frequently used fill styles – 
Tatami and Satin – their properties – stitch length and spacing – and edge 
effects, such as stitch shortening. Default settings, however, cannot 
always guarantee the best results as the variety of embroidery designs is 
virtually unlimited.

To adjust advanced recognition settings
1 Access the Open Options dialog and click Advanced.

Original design opened 
without stitch recognition

Opened with stitch
recognition – pattern splits

recognized as Tatami
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The Recognition - Advanced Options dialog opens.

To adjust Tatami recognition settings
 In the Tatami panel, select Recognize tatami in order to process 

tatami fills, and adjust conversion options:

Select to
recognize Tatami

stitches

Select to
recognize Satin

stitches

Select to
recognize Run

stitches

Select to 
recognize Jagged 
Edges

Select to 
recognize Splits

Set space and
stitch length

rounding

Select Segments 
Resolution and 
Merging Factors

Select to recognize
random needle

penetrations

Option Function

Stitch spacing Enter spacing range to recognize. If the row spacing falls 
outside this range it will not be converted to tatami.

Min stitch 
length

Enter minimum stitch length to recognize as tatami.

Random factor Select to allow for random needle penetrations. Tip: Deselect 
the Recognize Splits checkbox to detect Random Factor 
more accurately.

Tatami spacing range 0.4 mm 
to 1.5 mm, Random factor not 
selected

Tatami spacing range
0.4 mm to 1.5 mm,

Random factor selected
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To adjust Satin recognition settings
 In the Satin panel, select Recognize satin in order to process satin 

stitching, and adjust stitch spacings as required. If the row spacing 
falls outside the specified range it will not be converted to satin.

To adjust Run recognition settings
 In the Run panel, select Recognize run in order to process run 

stitching, and adjust conversion options as required:

To adjust Complex Fill recognition settings
 In the Parameter consistency panel, set options for complex fill 

segment recognition:

Option Function

Max stitch length Enter maximum stitch length to recognize.

Length variation Enter percentage by which stitch length can vary in run 
objects.

Option Function

Spacing rounding Enter rounding value for stitch spacings – ‘snaps’ spacing 
values in Tatami and Satin fills to specified increments.

Stitch length 
rounding

Enter rounding value for stitch lengths – ‘snaps’ stitch 
length values in Tatami fills to specified increments.

Spacing range 0.5 mm 
to 5.0 mm

Spacing range 0.1 mm
to 2.0 mm

Max stitch length: 4 mm
Length variation: 10%

Max stitch length: 4 mm
Length variation: 90%
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For example, if the Tatami minimum stitch length is 4 mm, and Stitch 
length rounding is 0.4 mm, stitches from 3.80 to 4.20 mm are 
‘snapped’ to 4.0 mm, and recognized as Tatami.

To adjust stitch effects recognition settings
 In the Effects panel, select Jagged in order to recognize the Jagged 

edge effect. Specify a minimum range in millimeters – anything 
variation greater than this value will be recognized as Jagged edge.

Tatami Spacing range: 0.4 mm to 1.5 mm, 
Spacing rounding: 0.01 mm, 
Stitch length rounding: 0.2 mm

Tatami Spacing range: 0.4 mm to 1.5 mm,
Spacing rounding: 0.05 mm,

Stitch length rounding:0.5 mm

Jagged selected, border object
recognized as jagged edge

Jagged not selected, border 
object recognized as manual
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 In the Splits panel, select Recognize splits to recognize splits in 
tatami fills, and adjust conversion options as required:

Tip: Program splits are reliably recognized when patterns are not 
overlapping. Split patterns can be complex, so the recognition process 
can take up to five times longer with this option.

Option Function

Program splits as 
user defined splits

Recognize split patterns as user-defined splits. Note, 
however, that user-defined splits are scaled when the 
design is scaled. This results in stitch lengths getting longer 
as the design is enlarged, thus limiting scaling. With native 
program splits, on the other hand, patterns – shape, size 
and spacing – remain the same after objects are scaled.

Recognize auto 
splits

Recognize Auto Splits in Satin objects. Otherwise, patterns 
created with Auto Split will be recognized as Tatami.

Recognition level Restrict recognition of Program Splits by increasing 
percentage. Decrease to increase recognition. A low 
percentage number will detect more areas as Satin with 
User Defined Split than Tatami.

User Defined Split

Auto Split
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To adjust segment recognition settings
 In the Segments resolution/merging factors panel, enter values 

to fine-tune the recognition of segments and objects:

Tip: Generally, the lower these values, the larger the number of 
segments/objects likely to be identified. Normally you want to obtain 
design information with a minimum number of identified 
segments/objects. In practice there is always a compromise between 
design recognition quality and the minimum number of correctly 
identified segments/objects.

 Click OK.

Tip: To revert to the original conversion settings, click Reset.

Related topics...
 Open machine files

Option Function

Spacing This value expresses the ratio between stitch spacings in adjacent 
stitch blocks – e.g. adjacent spacings of 0.6 mm and 1.0 mm gives 
a ratio of 1.67. A value of 2.0 in the Spacing field means that these 
stitch blocks will be recognized as one segment or object. A value 
of 1.5 means that they will not. The default value is 3.0. Normal 
Satin and Tatami stitching ranges in spacing from 0.3 to 0.6 mm, 
so most continuous sections of stitching of the same type will not 
be split. To preserve spacing variations for color-blended designs 
and more artistic designs, you may need to reduce the spacing 
factor. In manually punched designs which include stitching with 
irregular spacing, segment breaks can be reduced by increasing 
the factor.

Height This value expresses the ratio between heights of stitch blocks. It 
is important in recognizing Complex Fill shapes, particularly with 
holes.

Recognized objects 
shown in different colors

Spacing: 0.5 mm, 
Height: 2 mm

Spacing: 3 mm,
Height: 4 mm
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Reassigning colors to machine files

When you open a machine file or CND file, a design without color code 
assignment automatically uses the default color palette. You can, 
however, map thread colors to every Color Stop code in the file. This 
means that before opening the file you can color-code designs which do 
not contain needle addressing information.

Note: In order to assign colors correctly, you need to consult a 
production worksheet for the necessary color sequence information.

To reassign colors to a machine file
1 Select File > Open. The Open dialog opens.
2 Select a machine file or CND design and click Options.

If you’ve selected a machine file, the Open Options dialog opens. If 
CND, the Condensed File Input Settings dialog opens. This 
procedure is the same.

3 Select Custom and click Define stop sequence.

Without color code 
assignment

With color code
assignment

Select Define Stop 
Sequence

CND file

Machine file

Select Define Stop 
Sequence
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The Define Stop Sequence dialog opens. Initially the Building stop 
sequence panel is empty.

4 Select a thread chart and first color.

5 Click Assign Color. The color and the description are entered at the 
current Stop in the Building stop sequence grid.

Note: The selection moves to the next color in the thread chart. Two 
consecutive same colors are not allowed and Assign Color is 
disabled.

6 Click Assign Stop to enter an explicit Stop code.
Stop is entered in the Description field.

Select thread
chart

Select color

Click to
assign color

Click to
assign stop
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Note: A Stop Sequence Warning message displays if a redundant 
color function is assigned. Press Delete to delete a selected entry in 
the stop sequence. Click Reset to delete all the entries.

7 Use the Extra Stop codes as panel to select the output type for extra 
stop codes:

8 Repeat the operation as many times as indicated in the production 
worksheet.

9 Click OK. The design will have the desired colors and the correct 
number of Color Changes.

Note: You can convert color changes to an explicit Stop Code. You can 
also remove Color Stops by assigning the same color number to 
consecutive color blocks.

Related topics...
 Read CND files with color-merge TXT file

Reading Melco CND design files

Melco Condensed (CND) is the native file format of Melco embroidery 
digitizing software. CND files store only digitized outlines and stitch 
values. When you open CND designs in EmbroideryStudio, these outlines 
are scaled and stitches recalculated to preserve density. 

Choose how 
extra stops are 
to be interpreted

Option Function

Color changes Extra Stop codes are interpreted as ‘Next Color’ commands. 
The next color is selected from the default color palette.

Stops Extra Stop codes are interpreted as ‘Explicit Stop’ commands. 
The machine stops stitching.

Repeat 
sequence

If you select fewer colors than the design requires, the selected 
colors are repeated. For example, if your design requires four 
colors and you’ve only selected two in the Building Stop 
Sequence list, colors 3 & 4 will be the same as original colors 
1 & 2.
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EmbroideryStudio recognizes all Melco machine functions and stitch 
types, including Partition Lines and Complex Fill, and automatically 
converts them to EMB format. However, CND files do not contain specialty 
features such as Pull Compensation or Auto Spacing, nor do they include 
actual stitches, thread colors, or design icons.

Convert CND files to EMB

There are several versions of CND, all of which can be read by 
EmbroideryStudio. While these designs scale accurately, the number and 
placement of stitches may differ somewhat from the original design. You 
may notice some difference (±10%) in the stitch counts between original 
and converted files. This is because of differences in the software 
methods used to calculate stitches. EmbroideryStudio cannot interpret 
certain specialty features of CND design objects because there is no 
direct equivalent. However, stock designs do not normally use these 
features and will generally convert without problem.
When you open Melco CND files, the Melco stitch types used in the design 
are converted to EmbroideryStudio stitch types – satin, run, tatami, etc. 
You can change conversion settings to adjust spacing, stitch length, 
effects and defaults applied to EmbroideryStudio stitch types. You can 
also set scaling values to open the design at a different size to the 
original.

To convert a CND file to EMB
1 Open the file from your hard disk, or read it from tape or embroidery 

disk.

Select CND
format

Select file
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2 Select the Melco (CND) file to open and click Options. The 
Condensed File Input Settings dialog opens.

3 In the Scale factor panel, enter the scale at which you want to open 
the design.
New dimensions are expressed as a ratio of the original design size. 
For example, to scale to 120% of the original, enter a scale factor of 
1.2 in each field.

4 In the Adjust panel, enter spacing and length values to apply to the 
design as a percentage of original values. You can adjust satin spacing, 
run stitch length as well as tatami spacing and length.

5 In the Auto color merge panel, choose whether you want to read 
thread color information from CND files. This ensures that stitches are 
displayed in the correct colors when converted to EMB. 

6 In the Effects panel, select the effects you want to apply to the 
design. 

Select Auto
Color Merge

option

Enter scale
values

Adjust stitch
values

Select effects 
to apply

Adjust default 
values

Scale factor 
X: 1.00
Y: 1.00

Scale factor 
X: 0.50
Y: 1.00
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For information about these, see the relevant sections of the manual:

7 In the Default values panel, adjust the default values for Satin 
spacing, Stitch length and Maximum stitch length as required.
If the CND design was created with values different to the factory 
settings, you can override them in these fields.
 To save new settings as defaults, click Save.
 To revert to the Melco factory settings, click Reset.

8 Click OK and then Open.
The selected design opens in the design window. You can scale the 
design directly on screen or via the Object Properties docker. You 
can also rotate, mirror and skew the design.

Tip: Before CND designs are stitched out, an EXP format file is 
created. The EXP stores the actual stitches and can be stitched 
directly. This file too can be opened in EmbroideryStudio.

Related topics...
 Save designs in Melco CND format
 Reassigning colors to machine files
 Opening machine files
 Save designs in Melco CND format
 Conversion of Melco CND format to Wilcom EMB

Read CND files with color-merge TXT file

While CND files contain no thread color information themselves, the Auto 
color merge feature can read thread colors for CND files from an 

Option Function

Auto spacing Auto Spacing automatically adjusts stitch spacing wherever a 
column changes width. See Applying satin stitch for details.

Short stitches Standard stitch spacing is calculated at the outside edge of a 
shape. With sharp curves, spacing which provides adequate 
coverage on the outside edge may cause bunching along the 
inside edge. Stitch shortening reduces the length of some 
stitches in sharp turns so that the needle penetrations are 
distributed evenly, creating smoother stitching. See Apply 
stitch shortening for details.

Fractional 
spacing

With Fractional Spacing, EmbroideryStudio calculates spacing 
settings from a specified point called the offset fraction. This 
lies between the outside and inside edges of the shape. You 
can change the offset fraction to adjust stitch spacing at inside 
and outside edges. See Apply fractional spacing for details.
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associated TXT file. Thus stitches are displayed in the correct colors when 
they are converted to EMB. Auto color merge reads and interprets a 
TXT file containing colors from a named thread chart. You must specify 
the thread chart used when the design was originally created in EDS (or 
other design software). 

To read CND files with color-merge TXT file
1 Select File > Open. The Open dialog opens.
2 Select a CND design and click Options. The Condensed File Input 

Settings dialog opens.

3 Select From file in the Auto color merge panel, and select a 
corresponding thread chart from the Auto color merge droplist.
Any thread color named in the text file must correspond to a color in 
the selected thread chart. If not, it will default to black.

4 Click OK. The design opens, the stitches appear in the correct thread 
colors, and the color palette displays the selected thread chart.

Related topics...
 Reassigning colors to machine files
 Create a color-merge TXT file

Select thread
chart

No chart selected – default 
colors assigned

Original colors correctly 
assigned from text file

One color not correctly matched – 
defaults to black
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Create a color-merge TXT file

Auto color merge reads and interprets a TXT file containing colors from 
a named thread chart. You can create this text file manually with a text 
editor such as MS Notepad. The text file must have the same file name 
as the CND file – e.g. Fish.TXT and Fish.CND. Both files must reside in 
the same folder. For the Auto color merge function to work correctly, 
information in the text file must be entered in a certain format. A typical 
text file might look like this:
Fish
Uses curve effects
File: Fish
55.9mmW X 74.5mmH
ST: 6,780
Colors: 8
1. Tropical Sunset
2. Saffron
3. Pale powder Blue
4. Tropical Sunset
5. Pale powder Blue
Curve effect
6. Tropical White
7. Tropical Sunset
8. Pale powder Blue

Text file structure
All text files contain some or all of the following elements.

Txt file item Mandatory Description Example

Design name This is the name of the design as it 
appears in File > Information > Design 
Information > Subject.

Fish

Comments Lines inserted here appear under File > 
Information > Design Information > 
Comments.

Uses curve effects

File name


This is the file name of the CND design 
file. The file extension should not be 
included.

File: Fish

Design size Enter the expected design size for the 
design. The actual design size is 
derived from the software.

55.9mmW X 
74.5mmH

Stitch count Enter the expected stitch count for the 
design. The actual stitch count is 
derived from the software.

ST: 6,780

Number of colors


States the total number of colors in the 
design.

Colors: 8

Thread name 1



Enter the first thread name. The name of 
the thread is searched against the 
Thread Chart. The thread name is 
shown in the File > Design Information > 
Stop Sequence tab.

1. Tropical Sunset
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Thread name 2  Enter the second thread name. 2. Saffron

Thread name 3  Enter the third thread name. 3. Pale Powder Blue

Thread name 4  Enter the fourth thread name. 4. Tropical Sunset

Thread name 5  Add any extra threads to this list. 5. Pale Powder Blue

Thread 
comments

Place comments below the relevant 
thread number.

Curve effect

Thread name 6  6. Tropical White

Thread name 7  7. Tropical Sunset

Thread name 8  8. Pale Powder Blue

Txt file item Mandatory Description Example
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Chapter 38

Embroidery Output

Once an embroidery design is complete, you can output for actual 
stitchout in a variety of ways – sending directly to machine for stitching, 
or saving to specific machine formats and/or to embroidery disk.

Tip: From the same design file, you can also output a production 
worksheet for the embroidery machine operator. See Design Reports for 
details.

Sending designs to machine

EmbroideryStudio provides alternative means for sending designs 
directly to machine. Depending on your software options, you can stitch 
to machine using Stitch Manager, Machine Manager, or Connection 
Manager. Newer machines use USB or Wired-Wireless network 
connections. EmbroideryStudio supports these connections via the 
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Connection Manager. Older-style machines generally use serial port 
connections. EmbroideryStudio supports connection to these machines 
via the Stitch Manager.

Note: Machine Manager and its operations are described in a separate 
supplement. 

Send designs to Connection Manager

Newer machines use USB or Wired-Wireless network connections. They 
can appear as a disk drive or be setup to read designs from a folder on 
the PC. Some machines such as Janome MB-4 and Barudan LEM are 
supplied with propriety connection software. EmbroideryStudio supports 
connection to these machines via Connection Manager. Each machine 
connection:
 Has a unique name and ‘quick-access’ button
 May have a unique folder to which designs can be sent. From here they 

can be accessed from the machine control panel or third-party 
connection software.

To send a design to Connection Manager
 Ensure that the target machine is correctly connected to your PC. See 

your machine documentation for details.
 If a connection already exists, click the quick-access button to send 

the design to a predefined location.

 Alternatively, click the Send to Connection Manager icon. 
 If no connections currently exist, you will be prompted to set one 

up. See Setting up machines for Connection Manager for details.

Use Standard > Send to Connection Manager to connect to supported 
machines via proprietary machine software.

Quick access button
for existing machine

connection
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 If a connection already exists, the dialog opens. 

 Select a connection from the droplist and click Send.
 Using the machine controller or third-party connection software, 

access the design from the network or PC folder.
 Load or send the design and stitch it on the machine.

Related topics...
 Setting up machines for Connection Manager
 Embroidery file formats

Send designs to EmbroideryConnect

Once you have set up one or more EmbroideryConnect devices on your 
network, you have the choice of ‘pushing’ designs or ‘pulling’ them from 
the EmbroideryHub. The Send to EmbroideryConnect button allows 
you to send a design to a named EC device. Alternatively, use the Queue 

Click to set up 
another connection

Select a
connection

Click to send

Use Standard > Send to EmbroideryConnect to send the current design to 
a named EmbroideryConnect device.

Use Standard > Queue Design to send the current design to the 
EmbroideryConnect design queue where they can be ‘pulled’ from the 
machine.
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Design to ‘push’ designs to a queue where they can be ‘pulled’ from the 
machine itself. 

Related topics...
 Sending designs to EmbroideryConnect
 Machine Networking

Send designs to Stitch Manager

Once a design is complete, you can stitch it out to any supported 
embroidery machine without changing design format. If a selected 
machine does not support a particular function included in the design, it 
is simply ignored. When you send several designs in a row, they are 
automatically queued and stitched out one at a time. 

To send a design to Stitch Manager
1 Ensure that the target machine is correctly connected to your PC. See 

your machine documentation for details.

Note: Before you can send designs for stitching, you must also 
configure the machine in EmbroideryStudio.

2 Open a design.

USB-A connection

USB-C
connection

Device state indicator

Power LED and WiFi LED

Use Legacy Features > Send to Stitch Manager to send a design to any 
supported embroidery machine without changing the original design 
format.
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3 Click the Send to Stitch Manager icon. The dialog opens.

4 From the Machine Identification list, select an embroidery machine. 
Click Setup to modify machine settings as required.

5 From the Output as Machine format list, select the correct machine 
format. Click Values to modify the machine format settings as 
required.

Note: This field is automatically updated if the target machine format 
is different to the current format. Select the Prompt Changing 
Machine Format checkbox if you want to be prompted when the 
Output as Machine Format field updates.

6 Click OK to return to the Send to Stitch Manager dialog.
7 Click OK. The Stitch Manager dialog opens listing the files to be 

stitched out.

Tip: To delete a design from the queue, select it and click Cancel.

Related topics...
 Hardware Settings
 Setting up machines for Stitch Manager
 Embroidery machine formats
 Standard machine formats
 Embroidery file formats

Exporting designs for machine

Different embroidery machines understand different languages. Each has 
its own control commands. Before you can stitch out a design, it must be 
in a format which can be interpreted by the machine. Machine or ‘stitch’ 

Select embroidery
machine

Select machine
format
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designs are low-level formats for direct use by embroidery machines. 
They contain only stitch coordinates and machine functions. They are 
generally created on-the-fly when sending designs to machine. Or they 
are converted when saving to disk or memory stick.

Note: The Design Library conversion function allows you to 
batch-convert to and from all EMB and other supported design file types. 
It also batch-converts many machine file formats such as DST, EXP, SEW. 
See also Converting designs.

Export designs to machine file

Converting an open design to machine file format is as simple as choosing 
File > Export Machine File. EmbroideryStudio reads and converts all 
popular formats. Designs originally created in EmbroideryStudio 
generally give the best results. Other file types may not have all the data 
necessary for successful conversion.

For older machines, you can also save designs to proprietary embroidery 
disk. See Using embroidery disks for details.

Caution: If a design feature is not available in the file type you select, it 
will be converted – e.g. Flexi Split stitching may be changed to plain 
Tatami.

Use Standard > Export Machine File to export the current design to a 
machine file for stitching.

Choose a machine 
file format
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Related topics...
 Converting designs
 Send designs to Connection Manager
 Using embroidery disks
 Machine Formats
 Embroidery file formats

Save designs in Melco CND format

You can save files to Melco CND format from EmbroideryStudio. Some 
stitch quality features, stitch types, and decorative fills and effects do not 
convert well. If you intend to save a file in CND format, you should only 
use input methods, stitch types and effects that are compatible with 
Melco EDS-III software.

Trim functions
Superstar-compatible machines do not have trimmers. If you want to 
stitch a design to a machine without trimmers, set machine values to not 
output Trim codes. Then digitize the design for manual trimming. Early 
versions of CND do not support Melco Trim codes. In this case, set the 
machine format values to output Trims as Jumps. 

Turning Tatami fills
When you save to CND format, you need to specify how to convert 
turning tatami stitches. Objects with curving tatami stitches – e.g. 
Column A objects – are not supported by early versions of CND format. 
For Superstar-compatible machines, turning tatami stitches are simply 
converted to Walk stitches, the EDS equivalent of Manual. For earlier 
machines, turning tatami fills need to be converted to normal tatami – 
i.e. with a single stitch angle – then to Normal Fill, the EDS equivalent of 
normal tatami.
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To save designs in Melco CND format
1 Select File > Export Machine File. The Export Design dialog opens.

2 Choose Melco CND from the Files of Type list.
3 In the File name field, enter a name for the design.
4 Click Options. The Save Options dialog opens.

5 Select the required option for converting Turning Tatami fills:

Note: These functions are also available when you send a CND design 
for stitching.

6 Click OK and then Save.

Option Function

Superstar 
Compatible

Converts turning tatami to Walk (EDS equivalent of 
Manual). Complex Fill tatami is output as Normal Fill (EDS 
equivalent of tatami). Superstar-compatible machines do 
not have trimmers. 

Output Tatami as 
Complex Fill

Converts turning tatami fills to normal tatami – i.e. with a 
single stitch angle – then to EDS Normal Fill.

Choose Melco CND 
file format

Select required 
option
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Related topics...
 Standard machine formats
 Melco CND format
 Conversion of Melco CND format to Wilcom EMB.

Save designs in Singer CSD format

The CSD Save Options allows you to select between CSD Type I and 
Type II.

To save designs in Singer CSD format
1 Select File > Export Machine File. The Export Design dialog opens.

2 Select CSD from the Files of Type list.
3 In the File name field, enter a name for the design.
4 Click Options. The Save Options dialog opens.

5 Select the required CSD file type option.
 Type II was introduced in CS 1.2B software for the POEM machine. 
 Type II is also used by the Singer EU software for the POEM 

machine. 
 Type II files also store thread color RGB values and an icon of the 

design.
6 Click OK and then Save.

Choose Singer 
CSD file format

Select CSD file 
type option
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Related topics...
 Opening machine files

Using embroidery disks

Paper tape is the traditional medium for storing designs in stitch data 
format. Embroidery disks, which largely replaced paper tape, are 
specially formatted floppy disks used to transfer designs from computer 
to older embroidery machines. You can format embroidery disks and save 
designs to them from within EmbroideryStudio. The format you use will 
depend on the machine. Designs are generally stored in stitch data 
format, although Melco CND, for example, is a ‘condensed’ file format. 

You can also open designs from embroidery disks of various formats 
directly into EmbroideryStudio. Once read, you can output them without 
change, modify them and output them in the original format, or save 
them as EMB file. You can optionally convert them into objects. After 
conversion, a design can be scaled and changed. See also Opening 
machine files.

Read designs from embroidery disk

You can open designs of other formats from specially formatted 1.44 Mb 
DS/HD (Double-Sided High-Density) embroidery disks.

To read designs from embroidery disk
1 Insert the embroidery disk in your computer’s floppy disk drive.

Use Legacy Features > Embroidery Disk to open designs from or save to 
proprietary embroidery disk formats.
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2 Select Embroidery Disk > Open. 

The Open Embroidery Disk dialog opens.

3 From the Look In list, select the floppy disk drive.
4 Select the disk format. Either:
 Select the format from the Diskette Format list.
 Select the Auto Detect checkbox and let EmbroideryStudio 

automatically determine the format. This generally takes longer.
5 Click OK. The Open From Embroidery Disk dialog opens.

6 From the Designs of Type list, select a design type. Any designs 
saved on disk are listed in the panel. If no designs are listed, make 
sure that the correct drive and disk format are selected.

Note: If the Options button is available, you can set recognition 
options for the design.

7 Click Open.

Select ‘Open’

Select drive

Select format

Select design 
type 
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Related topics...
 Embroidery file formats
 Melco CND format
 Gunold PCH format
 Open machine files

Format embroidery disks

Embroidery disks must be formatted to suit the embroidery machine you 
intend to use or it will not be able to read the design. Older computers 
generally have a High Density 1.44 Mb drive. Most embroidery machines 
use High Density disks so there is usually no problem with transferring 
designs. See your machine manual for details.

To format embroidery disks
1 Insert a 3.5" floppy disk of the correct density in your computer’s 

floppy disk drive. 

Note: Use the disk type required by the embroidery machine, not the 
computer.

2 Select Embroidery Disk > Format. 

The Format Embroidery Disk dialog opens.

3 From the Drive list, select the floppy disk drive. 
4 From the Diskette Format list, select the required disk format.

Use Legacy Features > Embroidery Disk to format proprietary embroidery 
disks.

Select ‘Format’

Select drive

Select format
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5 Click OK to confirm. The Format dialog opens. This is a 
MS Windows® system dialog and may vary with the particular 
operating system you are using.

6 From the Capacity list, select the disk storage capacity.
7 In the Format Options panel, select the ‘full format’ option. Quick 

Format erases all data from the disk but does not reformat it. 
Uncheck the option to reformat a blank disk. See your MS Windows® 
manual for details.

8 Click Start. A progress bar appears. You are prompted when 
formatting is complete.

Note: If you have trouble with formatting a Melco embroidery disk, 
check if your floppy disk drive can read and write single density floppy 
disks.

Write designs to embroidery disk

Save designs to embroidery disk to stitch out on a specific machine. 
When you save to a new format, the design is converted to encode the 
machine functions and commands supported by the particular machine.

To write designs to embroidery disk
1 Insert the embroidery disk in your computer’s floppy disk drive.

Select storage 
capacity

Uncheck quick 
format

Use Legacy Features > Embroidery Disk to open designs from or save to 
proprietary embroidery disk formats.
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2 Select Embroidery Disk > Save As. 

The Save to Embroidery Disk dialog opens.

3 From the Look In list, select the floppy disk drive.
4 Select the disk format. Either:
 Select the format from the Diskette Format list.
 Select the Auto Detect checkbox and let EmbroideryStudio 

automatically determine the format.
Any designs already saved on disk are listed in the panel.

Note: If the disk is not formatted, or its format is not correct, click 
Format. 

5 In the Design Name field, enter a name for the design.
6 In the Filename field, enter a name for the design file.

7 If the Number field is enabled, enter a file number.
Not all machine formats require this information. This option is grayed 
out if the file naming mechanism is not supported by the particular 
embroidery disk type. Tajima uses a free-form file name, so both a 
numbering system and a text file name system are supported, as seen 
in the dialog.

8 From the Machine Format list, select a machine format.
Some machines can read different formats. For example, some Tajima 
machines can read Barudan as well as Tajima. 

Tip: To view or modify machine format settings, click Values. 

Select ‘Save 
As’

Select drive

Select format

Enter file number
if required

Enter design name

Enter file name

Click to view or 
modify settings

Enter machine
format and

design file type
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9 From the Design Type list, select the file type to save to embroidery 
disk. Only one file type is generally available.

10 If available, select the Save Icon checkbox to include a thumbnail 
image of the design with the design file.
This icon appears in the machine control panel during stitch-out.

11 Click Save.

Caution: Wait until the light on the floppy disk drive stops flashing 
before removing the disk.

Related topics...
 Standard machine formats
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Chapter 39

Machine Networking

The EmbroideryConnect capability allows you to wirelessly transfer 
embroidery designs from EmbroideryStudio to USB-enabled embroidery 
machines. Machine files are automatically generated and sent via a 
standard WiFi network to an EmbroideryConnect device plugged into a 
compatible machine. Design transfers are securely encrypted.

Most modern embroidery machines like Tajima, Barudan, Happy, ZSK, 
Ricoma and SWF, can read files from a standard USB memory stick. With 
EmbroideryConnect, there is no need for serial ports, different interface 
methods, or machine cabling.
The EC device is of great potential benefit to commercial embroiderers 
who want to network any brand of commercial or ‘prosumer’ embroidery 
machines and need a choice of ‘push’ or ‘pull’ wireless transfer methods. 
Benefits can also be found for retail kiosk operators.
This section presents an overview of the product concepts, installation, 
configuration, and basic usage for EmbroideryConnect.
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Network overview

In a nutshell, EmbroideryConnect allows users to wirelessly transfer 
embroidery designs from EmbroideryStudio to multiple USB-enabled 
embroidery machines. It is an ideal solution for small to medium size 
embroidery manufacturers. EmbroideryConnect is designed to meet the 
following usage requirements:
 EmbroideryStudio user wants to be able to send a design from PC 

directly to a nominated machine.
 EmbroideryStudio user wants to ‘push’ a design to a queue for eventual 

production.
 Machine operator wants to ‘pull’ a nominated design to embroidery 

machine from the design queue.

Note: The EmbroideryConnect device only supports Windows 10.

What is an EmbroideryConnect network?

The concept behind the EmbroideryConnect network is described by the 
following diagram…

Note: Anyone on the same EmbroideryConnect network who has 
EmbroideryStudio running can send a design to an EC device or design 
queue on an EmbroideryHub. However, there can only be one 
EmbroideryHub running on the same network.

Embroidery machine 1

Embroidery machine 2

Embroidery machine ‘n’

Operator ‘pulls’ 
barcoded design to 
embroidery machine 
from design queue

EmbroideryHub converts 
design to machine file for 

target machine

ES User 1

WiFi Router

Ethernet LAN

ES User ‘n’

Designer sends design to named 
embroidery machine OR to 
EmbroideryHub design queue
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End-user benefits
What are the benefits of the EmbroideryConnect capability?

Usage scenarios

There are two basic ways of setting up an EmbroideryConnect network 
using either a single PC or multiple PCs.

Scenario 1: Single PC
If you are using a single PC to create, edit, and manage your designs as 
well as serve machine files to your embroidery machine/s, you will need 
both EmbroideryStudio and EmbroideryHub running. 

Scenario 2: Multiple PCs
If you are using two or more PCs to create your designs and a dedicated 
PC to serve your machine files, you will need:
 EmbroideryStudio with EmbroideryHub running on PC 1.
 EmbroideryStudio running on PC 2, PC 3, etc.
Design files may be saved anywhere on your network. These are sent to 
the EmbroideryHub where they are converted to machine files and sent 
to the EmbroideryConnect network.

Tip: Visit the Wilcom Support Center at www.wilcom.com.au/support for 
a current list of compatible machines.

Simple and easy to use...
• Easy to install and configure.
• Connect to existing WiFi and eliminate complicated network setup 

and configuration. 
• Plug into any USB-enabled embroidery machine.
• Wireless design transfer – no need for network cables.
• Mix and match different brands of machine on the same network.

The right design, every time...
• Machine file automatically generated on output.
• Convenient operation with the pull method. No risk of selecting 

wrong design for the order.

Safe and secure...
• Correct design loaded to the correct embroidery machine.
• Designs encrypted during transfer and, optionally, removed 

automatically from the design queue. 
• Optionally, designs deleted from the EC device when 

disconnected.

http://www.wilcom.com.au/support
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EmbroideryConnect components

The system employs the following components…

Third-party components

To set up an EmbroideryConnect network, some third-party hardware 
items are also required…

Component Details

EmbroideryConnect 
WiFi device

A Wilcom-supplied WiFi device – one per machine.

EmbroideryHub PC A nominated PC will act as the EmbroideryHub. This PC 
should remain on at all times. All designs are routed through 
it to embroidery machines connected to the 
EmbroideryConnect network.

EmbroideryHub EmbroideryHub software is activated on the dedicated PC…
• Designers can send (push) designs to connected 

machine(s) running the EC device.
• Alternatively, designers can send designs to the 

EmbroideryHub queue.
• Machine operators can request (pull) specific design from 

the queue via barcode reader connected to the EC device.

EmbroideryStudio 
users

Other EmbroideryStudio users can send designs to 
machines via the EmbroideryHub. All EmbroideryConnect 
devices on the network will appear for selection in a 
machine list. There is no need for shared folders, etc.

EmbroideryStudio 
dongle

EmbroideryHub will only run if there’s an EmbroideryStudio 
dongle plugged into the EmbroideryHub PC or there is an 
EmbroideryStudio network dongle on the same network.

Component Details

USB-capable 
embroidery 
machines

• Able to read designs from USB memory stick.
• Preferably with the USB port built into the control panel. 

Add-on USB converters in old machines may not be 
compatible.

Compatible WiFi 
router

See below for details.

Barcode reader Optional.

Windows 
Administrator 
privileges

Access must be configured by a user who has full 
administrator privileges and is part of a Windows 
‘Workgroup’ or ‘Domain’ network.
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WiFi router compatibility requirements
Note the following WiFi router requirements to be compatible with the EC 
device:

EmbroideryConnect device

A separate EmbroideryConnect device is needed for each embroidery 
machine on the network. Designs can be ‘pushed’ to a named device or 
‘pulled’ via barcode reader at each machine.

Device features
Device features are summarized below:

Requirement Details

Standard security 
protocol

The WiFi router must use one of the standard security 
protocols: WEP or WPA/WPA2 Personal. Security type 
‘none’ or ‘unsecured’ is not supported at present. A WiFi 
password is mandatory.

Support for WLAN 
Protocol 802.11 G

The WiFi router needs to support WLAN Protocol 802.11 G 
in the 2.4 Ghz band. The EC device will not connect to a 
WiFi router using the 5 Ghz band. If unsure, consult the 
documentation provided with your router.

WiFi network name You must know the WiFi network name (SSID) and WiFi 
router password (key). We recommend using a SSID 
(network name) that contains only alphanumeric characters 
– letters and numbers.

WiFi coverage WiFi coverage must be sufficient to serve the entire 
production area.

Item Description

EmbroideryConnect 
device

The device itself is small and compact. It can plug directly 
into an embroidery machine USB port or via USB extender 
cable.

USB-C connection USB-C connection at top to connect device to PC or 
embroidery machine.

USB-A connection

USB-C
connection

Device state indicator

Power LED and WiFi LED
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Tip: The EC device comes with 3M mounting strips to attach it to the 
target machine.

EC device states
The EC device indicates various devices states. The following table 
explains the color coding…

EmbroideryConnect setup

Setting up an EmbroideryConnect network is easy…
 A single device is required for each embroidery machine.
 A dedicated network PC acts as the ‘hub’ and runs the EmbroideryHub 

software.
 All devices are configured to the EmbroideryHub PC.
 All secondary PCs access the EmbroideryConnect network via the 

EmbroideryHub.

USB-A connection Separate USB-A input port for USB barcode reader.

Device state indicator The device displays basic status information. See below 
for details.

Power from USB No separate power supply needed – power is drawn from 
USB port.

When… Status light Status

Attaching device to 
machine

Solid green Device is running smoothly so machines 
can access designs.

Scanning barcode Flashing orange Barcode scan failed. Scanned file not 
found in design queue.

Flashing purple Device cannot connect to EmbroideryHub 
for design request.

Sending design to 
device

Flashing yellow Device is unmounted.

Flashing orange Sent file already exists on device.

Flashing red Error occurred.

Item Description

Double-click to start EmbroideryHub.
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To configure an EmbroideryConnect device
1 Ensure the ‘hub’ PC has an active internet connection.
2 Start EmbroideryHub from the program group or desktop. 

When first run, the device list in the EmbroideryHub main window is 
empty.

Open the 
EmbroideryHub

Add a new 
EmbroideryConnect device
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3 Plug the EC device into the computer via the USB-C port located at the 
top. 

4 Ensure all lights are in ‘Setup’ mode. When the power LED is solid 
green and the WiFi LED is flashing blue, the device has finished 
booting. This generally takes about 60 seconds.

5 Click Add New EmbroideryConnect and follow the setup wizard 
prompts.
 If an unconfigured EC device is detected, the process will open the 

wizard directly and take you to the next step.

Power LED solid green and 
WiFi LED flashing blue

Connect
EmbroideryConnect

device to PC

WiFi LED flashing blue 
indicates ‘Setup’ mode



Chapter 39   Machine Networking 946

 If no EC device is detected, the dialog below will appear. Check the 
device is correctly attached and has finished booting. Click Next 
when the button becomes available.

 If more than two unconfigured EC device are connected, the dialog 
below will appear. The code displayed corresponds to the tag 
number on back of the device. Select a device and click Setup.

Select EC 
device
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6 When prompted, select your WiFi network and click Next.

7 Enter the WiFi password and click Next.

8 Identify the EmbroideryConnect device and specify output options.

Select your WiFi 
network

Enter WiFi 
password

Name the 
EmbroideryConnect 
device

Specify the 
EmbroideryConnect 
folder
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Options include:

9 Click Finish. 

10 Wait for the EC device to connect to the network and EmbroideryHub. 
The blue WiFi LED will flash and then turn solid blue when it has 
successfully connected. 

Option Function

EmbroideryConnect 
name 

Give the device a unique name associated with the 
connected machine – e.g. ‘Tajima #2’.

Output file type Specify the machine file type for the selected machine 
– e.g. *.TBF. Design files will be converted on-the-fly to 
this format.

EmbroideryConnect 
folder

Specify the folder on the device if different to the ‘root’ 
folder. Machine requirements are the same as those for 
sending a design via normal USB stick.

Machine brand This field is simply descriptive to help identify the 
machine associated with the EC device.

Number of heads This is a descriptive field.

Machine model This is a descriptive field.

EmbroideryConnect 
device connecting to 
EmbroideryHub

WiFi LED solid blue 
indicates ‘Ready’ 
mode



EmbroideryStudio e4 Reference Manual 949

Connection takes about 60 seconds depending on network traffic.

11 Once configured, remove the EC device from the EmbroideryHub PC 
and connect it to the target machine. 

Tip: The EC device comes with 3M mounting strips to attach it to the 
machine.

12 Again, ensure all lights return to ‘Ready’ mode. You can now send 
designs to this device from EmbroideryStudio.

EmbroideryConnect 
device now connected 
to EmbroideryHub

Connect 
EmbroideryConnect 
device to machine
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13 Configure your other devices in the same way.

Note: The EmbroideryHub needs to remain active at all times in order 
to manage the design flow to all connected EmbroideryConnect 
devices.

Basic device settings

Once your devices are set up and connected to the target machines, you 
can further configure or modify them at any time. There is no need to 
re-attach the EC device to the EmbroideryHub PC. Settings can be 
modified across the network. Double-click the device icon in the main 
window to access settings. 

Add a new 
EmbroideryConnect device

Click to toggle list view
and icon view

Double-click device icon 
to access settings
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Device details
Access the Info tab to modify details provided during the setup 
procedure. Here you can change device name, output file type, and other 
details...

Note: Use ‘Rotate design by 180° on output’ to auto-rotate the design 
by 180° when output to machine file on a connected EC device. If the 
machine is dedicated for cap designs, tick this option.

Design options
Access the Design Options tab to manage design options. All design 
transfers are securely encrypted across the EmbroideryConnect network. 
Various options are available for handling design transfers…

Edit device name, 
output format, and 
other details

Set design 
transfer options

Apply settings to 
all devices
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Design options can be modified as preferred for this EC device…

WiFi settings
The main reason for accessing the WiFi Settings tab is to update the 
network password…

Delete EC device
Access the Delete tab to remove a selected EC device from 
EmbroideryHub.

Option Function

Keep designs when 
powered off

By default, designs stay on the device unless you remove 
them in the Manage Designs window. When unticked, 
designs are cleared from the device so they can’t be 
copied.

Replace designs on 
barcode read request

When ticked, whenever the operator does a barcode scan 
to fetch a design, EmbroideryConnect will delete all 
existing designs on the device before transferring the 
scanned design. Some users only want one design on the 
device at any given time.

Apply to all Click to apply the same settings to all EmbroideryConnect 
devices configured on the EmbroideryHub.

Update password 
as necessary

Delete EC device from 
EmbroideryHub
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Advanced device settings

Access the Advanced Settings tab to update USB memory size settings 
and machine compatibility settings as needed…

Configuring EC device memory size

The default capacity of the EC device is 8MB. Most machines accept this 
size of USB memory stick. Some older machines require smaller sizes 
such as 4MB or Floppy disk size (1.44 Mb). It can take up to 30 seconds 
for changes to be made.

Caution: If you choose floppy memory mode (1.44 Mb), it may not work 
on newer machines.

Update memory 
size settings

Update machine 
compatibility settings

Update memory size 
settings according to 
machine requirements
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You can confirm the change in memory size when the EC device is 
connected to the PC.

Tweaking machine compatibility

A number of machine compatibility options are available under 
Advanced Settings. It may be necessary to enable one or other of these 
to ensure compatibility between your machine controller and the EC 
device. If for any reason you lose WiFi connection to the EC device, the 
only way to reconfigure it is to perform a ‘hard reset’. See If you have 
created a folder structure, double-click the ‘..’ at the top of the list to 
move up a folder level. for details.

Emulating other devices
EmbroideryConnect can emulate other types of device. Some machines 
can only read designs from YE-DATA or Sandisk. For example, Tajima 
TEJT-II-C embroidery machines require these types of device. 
EmbroideryConnect can be set to emulate them.

Disabling serial interface
By default, EmbroideryConnect devices have the USB serial interface 
enabled in order to configure them on EmbroideryHub. It is best to leave 
the setting activated in case you need to reconfigure the device. 
However, if the embroidery machine has a problem with WiFi and serial 

Default RAM 
disk size

Emulate other devices 
according to machine 
compatibility requirements
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interface, you may need to disable it. With the EC device connected, the 
machine may lock up and display an unexpected message. 

Untick the Serial interface function and click OK. You will receive the 
following warning…

Note: If you turn off the serial interface and subsequently lose WiFi 
connection to the EC device, the only way to reconfigure it is to perform 
a ‘hard reset’. See If you have created a folder structure, double-click the 
‘..’ at the top of the list to move up a folder level. for details.

USB drive compatibility mode
There’s an option to run the EC device in ‘USB drive compatibility mode’. 
This may improve machine compatibility in some cases. For instance, if 
you are using Tajima X16 controllers or machines like Janome MB-4 and 
Janome MC12000:
 Tick both ‘USB drive compatibility’ and ‘disable serial interface’. In 

other words, USB drive compatibility should be enabled and serial 
interface disabled. 

 Only do this after the device has been set up and is working.
 If you reset the device for any reason, make sure ‘disable serial 

interface’ is unticked.

Note: The option is grayed out if the device does not have firmware 
version 1.0.1 or greater.

Configuring sub-folders for Barudan machines

Sometimes you may need to specify a folder on the device which is 
different to the ‘root’. Different machines have different requirements. 

Disable serial interface 
if there are problems 
after setup
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For example, ‘MyDesign.fdr/’. These are the same as requirements for 
sending a design via a USB stick. Make sure you include a ‘slash’ (/) at 
the end.

If the EC device will be used with a Barudan machine, a special sub-folder 
must be configured. Barudan machines will not read designs from the 
root folder of any USB stick. You can edit the folder structure on the EC 
device whenever necessary.

Adjusting proxy & network adapter settings

Normally you will not need to touch proxy and network adapter settings. 
However, the Advanced Settings dialog exists to resolve any issues. For 
instance, proxy settings of the EmbroideryHub PC may not match those 
of the local network. Or, if the PC has multiple network adapter 
connections – e.g. both a wired Ethernet connection and a WiFi 
connection – conflicts may arise. To access settings, click the ‘cog’ button 
in the lower right corner of the main screen. 

Specify the EC 
folder on device

Access proxy
server settings
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Proxy settings
Default proxy settings are set in the Windows Internet Options dialog. 
Keep ticked for most situations. If you are using two networks with 
different proxy requirements, this may cause ‘504 errors’ to occur with 
the devices. You will need to untick default settings and use the other 
controls to specify the proxy configuration for your EmbroideryConnect 
network.

Network adapter settings
The network adapter should be left on default most of the time. It’s only 
needed when there are multiple adapters connected to two different 
networks and there are device connectivity issues. If you have two 
adapters and find that the devices consistently switch from ‘Connected’ 
to ‘Disconnected’, select the adapter connected to the 
EmbroideryConnect network. EmbroideryHub should also be restarted.

Sending designs to EmbroideryConnect

Once you have configured one or more devices on your 
EmbroideryConnect network, you have the choice of sending designs to 
a named device or ‘pushing’ them to a queue where they can be ‘pulled’ 
from the machine itself. You can use any PC running EmbroideryStudio 
on your local WiFi network to send designs.
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Send designs to EmbroideryConnect device

Open EmbroideryStudio and load the design or designs you want to send 
to EmbroideryConnect. 

To send a design to an EmbroideryConnect device
 Select a design tab and click the Send to EmbroideryConnect icon. 

The dialog will show a list of named devices connected to the network.

 Choose your preferred device and click OK. The design will be 
automatically converted to the corresponding machine file format and 
sent to the EC device. Here it can be loaded into machine memory for 
stitching.

 Repeat for all designs you want to send to named devices connected 
to the network.

Push designs to EmbroideryConnect design queue

Use Standard > Send to EmbroideryConnect to send the current design to 
a named EmbroideryConnect device.

Choose preferred 
machine / device

Use Standard > Queue Design to send the current design to the 
EmbroideryConnect design queue where they can be ‘pulled’ from the 
machine.
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Open EmbroideryStudio and load the design or designs you want to send 
to EmbroideryHub. When you ‘push’ a design to a queue, you don’t know 
(or care) which machine it gets stitched on. Different production 
environments have different methods. The bigger and busier the 
concern, the more likely you are to use the ‘push’ method.

To push a design to the EmbroideryConnect design queue
 Click a design tab and click the Queue Design icon. A confirmation 

message will appear indicating that the design is in the queue.

 An error check prevents you from sending multiples of the same 
design to the queue.

 Repeat for all designs you want to queue up in preparation for 
production.

 On the machine itself, the operator can ‘pull’ designs to the EC device 
by means of a barcode reader attached to the USB port. Scan the 
barcode printed on the production worksheet. The design will be pulled 

Attach barcode reader 
to EC USB port



Chapter 39   Machine Networking 960

from the queue to the EC device. Here it can be loaded into machine 
memory for production.

View & manage designs on EmbroideryHub

From EmbroideryHub, you can view and manage designs sent both to 
particular machines as well as to the design queue.

To view and manage designs on EmbroideryHub
 Open EmbroideryHub on the EmbroideryHub PC.

Manage designs for the
chosen EC device

Manage designs in the
EmbroideryHub design queue
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 Click the Design Queue tab to view queued designs in 
EmbroideryHub. Here you can delete designs as necessary.

 If you want to view designs sent to the chosen EC device, click the 
Manage Designs button on the device settings dialog.

 A list of designs pending production on the target machine is 
displayed. Here you create new folders, and rename or delete designs 
as preferred.

Tip: If you have created a folder structure, double-click the ‘..’ at the 
top of the list to move up a folder level.

Delete designs from the 
queue as necessary

Manage designs
currently sent to

the device

Manage designs currently 
sent to the device
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Troubleshooting EmbroideryConnect

If experiencing problems using the EmbroideryConnect device, double 
check that it connects to the WiFi and EmbroideryHub correctly.
 The Power and WiFi LEDs on the EC device will be both on and solid if 

connected.
 If they flash briefly and then fade out, the EC device is not connected. 
If a mistake lies in the configuration settings, simply start again and 
double-check the settings.

Reset the device

If you turn off the serial interface and subsequently lose WiFi connection 
to the EC device, the only way to reconfigure it is to perform a ‘hard 
reset’. Power up the device and insert a hairpin into the Reset aperture 
on the side. Hold it for 10 seconds. This restores the device to whatever 
firmware it was initially programmed with. The EC device must then be 
reconfigured using EmbroideryHub.

Tip: If this doesn’t solve the problem, go to the Help & Support site and 
check for updates. 

Update the firmware

The Help & Support site will periodically publish firmware updates for the 
EC device. These may fix known compatibility problems for certain 
machines or support new features and fixes to the device. Any updates 
should not compromise your existing setup.

Reset 
EmbroideryConnect 
device to factory defaults

http://help.wilcom.com
http://help.wilcom.com
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To update the firmware
1 Open EmbroideryHub, access the device settings, and ensure ‘Serial 

interface’ is activated.

2 Download and install the latest version of EmbroideryStudio from the 
Wilcom Help & Support site, if not already installed.

3 Save a copy of the firmware update file to the EmbroideryHub PC. This 
will have been sent to you or downloaded from the Help & Support 
site. Firmware files have a ‘.WIL’ extension which is an encrypted 
format. 

4 Plug the EC device into the computer via the USB-C port located at the 
top. 

Note: Devices configured to ‘1.0.0’ must be re-attached to the 
EmbroideryHub PC for the update to work properly. For all other 
updates, there is no need. Settings can be modified across the 
network.

Ensure serial
interface is

ticked

Power LED solid green and 
WiFi LED flashing blue

Connect
EmbroideryConnect

device to PC

http://help.wilcom.com
http://help.wilcom.com
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5 Double-click the device icon in the EmbroideryHub main window to 
access device settings. 

6 On the Info tab, click the Update button to access the Update 
Firmware dialog.

7 Click the Browse button and locate the firmware update file in the 
save location.

8 Click Update to proceed. A confirmation message warns you that all 
design files will be cleared from the device.

Update the firmware for the 
chosen device

Manage settings for the
chosen EC device
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9 Click Yes to proceed. Progress messages will tell you the current 
status of the firmware update.

10 Once you have confirmation that the EC device is updating, you can 
close the device settings dialog and move to the next device. No need 
to wait until the current one has finished updating. Each device must 
be individually updated.
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PART X
FILE MANAGEMENT

EmbroideryStudio allows you to create files or ‘assets’ of various kinds 
during normal use. The most important of these are your actual 
embroidery designs. But there are other assets you may create, such as 
design templates, custom motifs and borders. These are preserved from 
installation to installation, whether installing a new version of 
EmbroideryStudio or a software update.

Design management
Design Library is a design management tool. Use it to browse design and 
artwork files stored on your local PC or company network. Design Library 
capabilities make it fast and practical for daily commercial use, avoiding 
the need to switch to and from File Explorer. It recognizes all file 
formats used by EmbroideryStudio. It also makes it easy to search, sort 
and browse all embroidery designs on your network. See Design 
Management for details.

Asset management
It’s a good idea to familiarize yourself with the locations and file names 
of your custom assets as a protection in case of computer crash, in order 
to share assets, and in cases where you need to manually copy the 
contents of your asset folders to the new locations. See Asset 
Management for details.

Product templates
EmbroideryStudio allows you to choose a garment or product backdrop 
on which to position decorations. This feature is mainly used to display 
location, size and overall appearance for visualization and customer 
approval purposes. You can add your own single-color and multi-color 
product templates to the software by following the method outlined in 
this section. See Product Visualizer Templates for details.

Standard fonts
The tables in this section display all embroidery fonts that are standard 
with EmbroideryStudio. See Standard Fonts for details.

Custom fonts
EmbroideryStudio provides options for creating custom embroidery 
fonts. You can create entire embroidery fonts from converted TrueType 
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fonts. You can digitize letters from backdrop images, convert vector 
objects, or digitize freehand using any of the input methods. You can use 
artwork from sources such as calligraphy books or TrueType fonts. See 
Custom Fonts for details.

Machine, file & disk types
This section provides details of the file and disk types supported by 
EmbroideryStudio. Details are also provided about the conversion of 
Melco CND, Wilcom INP, and Gunold PCH design formats to and from 
EMB. The section also provides details of vector and bitmap (raster) 
formats. See Machine, File & Disk Types for details.
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Chapter 40

Design Management

Design Library is a design management tool. Use it to browse design 
and artwork files stored on your PC or local network. Design Library 
capabilities make it fast and practical for daily commercial use, avoiding 
the need to switch to and from File Explorer. It recognizes all file 
formats used by EmbroideryStudio. It also makes it easy to search, sort 
and browse all embroidery designs on your network.

If you are already familiar with File Explorer, the interface will be quite 
intuitive to you. But there are some differences. Design Library is a 
‘virtual library’ in that any designs on your system can be located and 
displayed within the navigation pane. Any folder containing embroidery 
designs which resides on your hard disk, external storage device, or local 
network can be included in the navigation pane. In a nutshell, 
Design Library lets you:
 Search for designs – including artwork files – anywhere on your local 

hard drive, network drives, or external devices such as USB or ZIP 
drive.

 Search by various means, including summary information such as 
design title, subject, authors, tags, etc. Order information can also be 
associated with any supported design file.
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 Preview design information in the preview pane or Design 
Information docker.

 Create an organizing structure for easy categorization. Add to or 
remove design folders from your ‘virtual library’.

 Record and manage quotes, orders, and approvals.
 Batch-convert selected design files to all commercial embroidery 

formats such as DST, EXP, SEW, and others.
 Print selected designs or send them for stitchout to embroidery 

machine or to folders which machines can access for stitching.
 Use Design Library to handle quotes, orders, and approvals.

Caution: Included artwork (clipart) and embroidery designs can only be 
used for personal use – i.e. they cannot be commercially sold in any form. 
Changing the medium – i.e. clipart to embroidery or embroidery to clipart 
– does not remove copyright protection.

Note: CorelDRAW® needs to be registered before it can be used by 
EmbroideryStudio. Registration gives you access to the latest 
CorelDRAW® updates. It also provides CorelDRAW® Standard 
Membership which gives you access to content – clipart, fonts, stock 
photos, templates – via Corel CONNECT.

Design library layout

The Design Library is accessed from the Mode toolbar.

Switch between 
Design Library and 
Wilcom Workspace
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The library has five main components – toolbars, navigation pane, design 
display area, details pane, and Design Information docker. The 
appearance will differ somewhat depending on your operating system.

Library components are summarized as follows...

Navigation pane

Design display
area

Details pane

View
(Design Library)

Manage Designs

Component Function

Navigation pane The navigation pane in the Design Library is not an exact 
duplicate of your File Explorer folder structure. It is selective in 
that it only contains folders relevant to embroidery design and 
multi-decoration. Select and add any folder on your PC or 
network to view supported file types.

Design display 
area

The design display area shows any designs in selected folders 
corresponding to the filter selected or search criteria entered in 
the View (Design Library) toolbar. 
• Use the toolbar to filter the design display.
• Right-click selected designs to access a popup menu. Use it 

to cut, copy and delete without leaving the software.
• Use it also to zip designs and folders.

Details pane When a design is selected, summary information is displayed in 
the preview pane.

Design 
Information 
docker

Check design details via this docker. This is always advisable 
prior to design approval or stitchout. Summary and order 
information may be provided by the digitizer or sales team. This 
information can be printed with approval sheets and production 
worksheets.
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Viewing designs in network folders

Navigating to design folders with Design Library is similar to browsing 
with File Explorer. Your access to design folders on your local network 
is only limited by access rights determined by your System Administrator. 
View any supported file type residing in design folders. Designs can be 
searched, sorted, grouped, and browsed by customer or order. Click the 

Toolbars

Mode Switch to Wilcom Workspace to digitize and edit embroidery 
designs.

Manage designs Open selected or recent designs, cut, copy and paste them, 
convert them, print them, or output them to any connected 
embroidery machine or data media.

View 
(Design Library)

Search or sort the entire embroidery library or any chosen 
folders on any criteria selected. Find and manage folders 
containing designs.

Component Function

Click Mode > Design Library to open the Design Library window from which 
to search and catalogue designs as well as quotes, orders, and approvals.

Use View > Layout to toggle navigation pane, details pane, and/or preview 
pane display.
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Design Library icon on the Mode toolbar. Design Library opens in its 
own window.

Design Library is ‘virtual’ in the sense that any designs on your system 
can be located and displayed within the library. This folder acts as a 
container which appears in File Explorer amongst your other Windows 
libraries. 

You can add folders both in File Explorer and in the Design Library 
itself. The initial folder structure is created by your installation. However, 

Toggle panels
on/off

Navigation
pane

Embroidery library
appears amongst
Windows libraries
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any folders on your local network which contain embroidery designs or 
artwork can potentially be included and viewed in Design Library.

Tip: Like File Explorer, the Design Library display can be refreshed 
with a simple F5 keypress.

Change design display

Navigate folder
structure via

navigation tree or
address bar

Use View > Change View to select thumbnails only, thumbnails with 
stitching details, or summary information only.
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Use the Manage Designs toolbar to control display of the navigation 
pane as well as thumbnail appearance. Use the Change View droplist to 
display designs in the preferred format.

Tip: The Design Library display can be refreshed with a simple F5 
keypress, the same as File Explorer.

View design details

Default detail columns vary by file type and are controlled by 
MS Windows®. Design Library, however, provides additional columns 
for data derived from embroidery files. These may include design status, 

Display
designs as

icons or lists

Use View > Reset Detail Columns to reset the columns displayed in details 
view to the default layout.
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customer, order date, etc. Such details are primarily intended for use with 
EMB but can also apply to other embroidery formats.

When viewing design lists in Details view, columns can be arranged in 
any order and with a variety of criteria. Sometimes Windows will reset 
detail columns to Windows defaults, even for EMB files. To return to the 
default layout, simply click the Reset Detail Columns button. 

Group & sort designs

Various mechanisms are available for you to sort and group design 
listings...

Embroidery
data listed
by default

Click
column

headers in

Use droplists and
toggles to sort



Chapter 40   Design Management 976

The Group and Sort by droplists also provide a convenient mechanism 
for managing orders...

View zipped designs

View designs in zipped folders. The limitation is that the contents of 
zipped folders cannot be viewed as thumbnail images.

Related topics...
 Embroidery file formats

Opening designs from Design Library

Embroidery files fall into two broad categories – ‘design files’ and 
‘machine files’. Design files are ones you open and modify in Wilcom 

Group and sort
by same or

mixed criteria

Access zipped
folders
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Workspace. Machine files are generally ones you send to machine for 
production. There is some inter-convertibility between the two formats.

Related topics...
 Filtering designs
 Opening design files
 Opening new files from existing
 Opening machine files

Filtering designs

You can filter your embroidery library between file categories – design 
files, machine files, or all.

The Design Library can filter:
 All Wilcom-supported design files: EMB, ART, JAN
 All machine formats such as DST, EXP, JEF, etc.
 All artwork files read by EmbroideryStudio, both vector and bitmap

Filter designs 
by file type
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Related topics...
 Machine Files
 Embroidery file formats

Opening design files

Design files, also known as ‘all-in-one’ or ‘outline’ files, are high-level 
formats which contain object outlines, object properties and stitch data. 
When you open a design file in the software, corresponding stitch types, 
digitizing methods and effects are applied. Design files can be scaled, 
transformed and reshaped without affecting stitch density or quality. 
After modification, you can save to any supported file format.

Using the Design Library, you have the option of opening one or more 
selected designs in their own design tabs. Simply select a design or 
designs by holding down Ctrl as you click, and then click Open 
Selected.

Use Manage Designs > Open Selected to open design(s) selected in the 
embroidery library.

Select single or
multiple designs

for opening
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Caution: Be careful not to open too many designs simultaneously. 
Potentially you could select all designs in the library and click Open 
Selected. This operation cannot be stopped and may result in the 
computer running out of memory.

Opening machine files

Different embroidery machines speak different languages. Each has its 
own commands for the various machine functions. Machine files, also 
known as ‘stitch files’, are low-level formats for direct use by machines. 
They contain information about the position, length and color of each 
stitch. When they are read into the software, machine files do not contain 
object information such as outlines or stitch types, but present the design 
as blocks of stitches. 

While machine files are generally not suited to modification, the software 
can ‘recognize’ object outlines, stitch types and spacing from stitch data 
with some success. By default, machine files are converted to outlines 
and objects upon opening in the software. These ‘recognized’ designs can 
be scaled with stitches recalculated for the new outlines. Processing is 
effective for most stitch designs but cannot produce the same level of 
quality as original outlines and may not handle some fancy stitches.

Related topics...
 Machine Files

Manual objects with no
outlines and manual

stitches only
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Opening graphic files

Artwork can be opened in EmbroideryStudio in both vector and bitmap 
(raster) formats via Design Library. Samples of both file types are 
installed with EmbroideryStudio in the Pictures library as shown below.

Extended support for CDR files
Design Library provides extended support for Corel CDR files. This 
includes:
 Right-click to access Windows operations – Open, Open With – 

directly into CorelDRAW Graphics. Or double-click to open a selected 
CDR file using the default template.

 Drag-and-drop from File Explorer into CorelDRAW Graphics.
 Drag-and-drop into Wilcom Workspace.
 Drag-and-drop into standalone CorelDRAW® Graphics Suite.

Note: For a full description of image file formats supported by 
CorelDRAW® Graphics Suite, refer to the CorelDRAW® Graphics Suite 
electronic User Guide available via the MS Windows® Start > Programs 
group. Alternatively, use the online help available from the Help menu.

Related topics...
 Digitizing with Bitmaps

Opening new files from existing

Instead of opening the original designs, you can use New from 
Selected. The only difference for practical purposes is that this 
command creates a copy which opens in a new design tab, thus 

Filter by 
graphic file

Use Manage Designs > New from Selected to create new designs based 
on designs selected in Design Library.
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preserving the original design file. Left-clicking uses the default template. 
Right-clicking allows you to select a different template from the dialog. 
Selection is remembered and used the next time the command is 
invoked.

The New from Selected command can also be used to open graphics 
files, including Corel CDR. With CDR, a new file is opened in 
EmbroideryStudio before switching to CorelDRAW Graphics.

Tip: If you want to open one design into another, an Import 
Embroidery function is available in Wilcom Workspace. Combine 
designs or design elements into a single design layout. 

Related topics...
 Combining objects & designs
 Working with templates

Inserting designs with Embroidery Clipart

The Embroidery Clipart feature is a powerful productivity tool which 
allows you to recycle commonly used elements. When you install 

Choose a
template

Activate auto fabrics
and choose a target

Set background 
color and swatch

Choose a target 
machine format

Save as default

Use Docker > Embroidery Clipart to toggle the docker display. Use it to 
record and recover re-usable embroidery elements.
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EmbroideryStudio, the Embroidery Clipart feature is installed with 
Design Library together with a sample clipart library.

Use the Search functionality to filter your list according to name, 
keywords, number of colors, or number of stitches, etc. Once a suitable 
design element is located, simply drag-and-drop it as ‘embroidery clipart’ 
into the current project. Scale to suit the design. Stitch colors are added 
to the Color toolbar.
Use the Browse button to change to any Design Library folder on your 
system. For example, you may want to put together a design such as a 
wreath with components such as ribbons, leaves, fruit and flowers. With 
the clipart library this becomes a simple task.
Use Design Library to manage design elements in your clipart folders. 
Use Design Information to assign names and keywords to each design 
element you save. Keywords play an important part in organizing a 
growing clipart library. Finding a suitable element can take time but 
keywords narrow the selection. Any number of keywords can be assigned 
to the same clipart element. See below.

Related topics...
 Combining objects & designs
 Insert designs
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Viewing & managing design information

Manage and check design details via the Design Information docker. 
This is always advisable when receiving orders or prior to design approval 
or stitchout. Summary and order information may be provided by the 
digitizer or sales team. This information can be printed on approval 
sheets and production worksheets. Choose a file and select Design 
Information via the View toolbar or Design menu.

All designs in Design Library can be tagged for easy search and find. 
Summary information such as design title, subject, authors, tags, is fully 
customizable. Order information can also be associated with any 
supported design file. All additional information is saved with the actual 
design file and can be viewed in any software that can read EMB files. It 
is often desirable to edit design details within the Design Library 
without having to open in the design window. This also enables customer 
service staff to enter/change details without modifying the embroidery 
design itself.

Caution: When updating information in the Design Information 
docker, it may take some time for the index to update before you can 
search on that data.

Use View (Design Library) > Design Information to view and modify design 
details prior to design approval or stitchout.

View file 
information

Add 
descriptive title
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Summary tab

Summary information about a design can be viewed and edited in the 
Summary tab. Generally this information is used to improve 
searchability. Use the information to search and filter designs by author, 
title, or subject. Tags can be added to improve searchability. Information 
can be added in the docker itself or in the Details pane (if activated). 
Click Save to save details with the design file.

Click a field and enter any text which will help you or others identify the 
design at a later date. All information on this tab is also included in the 
production worksheet. Information types include:

Field Description

Title Defaults to filename. Add a more descriptive name for easy 
searching. This name appears on the approval sheet or worksheet.

Subjects This may conform to the primary category by which the design is 
cataloged – e.g. the name of the containing folder.

Authors Name of digitizer and/or designer – appears in production 
worksheet footer.

Tags Keywords for potential Design Library searches.

Edit design summary
information for design

reports
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Related topics...
 Preview design reports

Design tab

Select the Design tab to view design details such as height, width, stitch 
count and colors. The data is extracted from the design file and, apart 
from design title, cannot be modified.

Fields include:

Comments These comments are included in the production worksheet and are 
intended for production staff. They may include instructions for 
machine operators.

Field Description

Field Description

Filename File name of the selected design. This will often be a number or 
alphanumeric format for easy cataloging.

Design information – 
not editable

Provide descriptive 
name as preferred
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Related topics...
 Embroidery machine formats
 Design Hooping
 Using automatic connectors
 Embroidery file formats

Order tab

Order information is saved directly with the design file. This allows 
embroidery orders to be managed via the designs they use without the 

Title Defaults to filename. Add a more descriptive name for easy 
searching. This name appears on the approval sheet or 
worksheet.

Height / width Total height and width of design extents. 

Stitches Total stitch count for design.

Colors Number of thread colors involved in the design.

Stops Normally color changes are associated with Stop functions. 
Depending on machine format, however, the design may include 
an additional last stop to ensure the machine returns to the 
starting needle for the next run.

Colorways Number of colorways in the design.

Trims Number of trims in the design. Generally, you will try to minimize 
the number of trims. 

Color changes Number of color changes required to stitch out design.

Appliqués Number of appliqué objects in the design (if any).

Sequins Number of sequins in the design (if any).

Bling Number of bling objects in the design (if any).

EMB grade While embroidery files are broadly classified as ‘design’ (oultine) 
or ‘machine’ (stitch), the software internally tags each as 
belonging to one of four types – native design (A), imported 
outlines (B), processed stitches (C), or imported stitches (D).

EMB version The version of EmbroideryStudio the file was created in – e.g. 
ES e4.

Machine format The current machine format applying to the file. This generally 
corresponds to the target machine last used to stitch out the 
design.

Objects Indicates total number of objects in the design.

Sequin details Lists any sequins used in the design and their respective 
numbers.

Field Description
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need for a commercial database. The information is included on approval 
sheets.

Tips for use...
 All fields in the Design Information docker can be read and written 

in Design Library.
 Use Save and Reset buttons to ensure that updated fields are saved.
 The Color/Size/Qty table is included in the approval and production 

worksheets. 
 Click buttons to add rows and columns. 
 Double-click to edit labels.

 Numeric displays use locale settings.
 Date fields use locale settings.

Order information 
included on approval 
sheets

Date picker controls use 
regional settings for date 
format

Stores a list of 
customers for use 
between sessions

Add or delete 
sizes

Add or delete 
colors
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Related topics...
 Managing quotes & orders

Thread Colors tab

The Thread Colors tab displays the color sequence and stitch counts for 
each design ‘element’. Elements equate to color changes. The tab also 
provides thread usage estimates which may be used for costings as well 
as production requirements. This information cannot be viewed in 
Design Library. The design first needs to be opened in Wilcom 
Workspace.

Related topics...
 Design thread colors
 Name design elements
 Assign thread colors
 Thread usage estimates
 Modify thread details
 Other general options

Stitching tab

The Stitching tab displays technical stitching details mainly of use to 
machine operators. Information includes such details as target fabric, 
required stabilizers, as well as total thread estimates. These may be used 

Thread color details
not availabe in
Design Library
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for costings as well as production requirements. Bobbin length calculation 
can be further refined if you are planning a large production run. 

Data is extracted from the design file and, apart from title and bobbin 
length calculation, cannot be modified. 

Field Description

Filename File name of the selected design. This will often be a number or 
alphanumeric format for easy cataloging.

Title Defaults to filename. Add a more descriptive name for easy 
searching. This name appears on the approval sheet or 
worksheet.

Auto fabric Predefined fabric settings used in current design. 

Required 
stabilizer

Indicates recommended stabilizer(s) for selected fabric type. 

Design area Total area covered by design – used for estimating hoop sizes, 
fabric requirements, 3D foam, or whether design will fit target 
location.

Total thread Indicates total meterage of top thread required to stitch out the 
design.

Total bobbin Indicates total meterage of bottom (bobbin) thread required to 
stitch out the design. These figures may be required for 
inventory control depending on business practices.

Length 
calculation

Allows you to revise thread usage estimates according to target 
fabric thickness. 

Design information 
– not editable
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Related topics...
 Working with fabrics
 Manage fabrics
 Thread usage estimates
 Design Hooping

Runtime tab

Once your machines have been defined, running times are displayed in 
the Design > Design Information dialog Runtime tab. This tab lists 
available machines together with estimated runtimes based on stitch 
count and machine criteria. Runtime estimate, based on selected 
machine, can also be included in the production worksheet. This 
information cannot be viewed in Design Library. The design first needs 
to be opened in Wilcom Workspace.

Related topics...
 Doing runtime estimates
 Managing quotes & orders

Locating designs in the library

Design Library is a ‘virtual library’ in that any designs on your system 
can be located and displayed within the navigation pane. The 
Design Library doesn’t care where they physically reside on your hard 
disk, local network, or external storage devices. Any folder containing 
embroidery designs can be included in the navigation pane.

Searching the library

Design Library allows for fast searching of designs on shared local 
network drives. This is important for businesses with multiple computers 

Left / right / up / 
down

Depending on where the design start/end point has been set, 
these figures indicate the distance from that point. 

Max/min stitch / 
jump length

The maximum and minimum stitch lengths, and maximum jump 
stitch length in the design.

Field Description

Runtime details not
availabe in

Design Library
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and multiple users creating and accessing EMB, machine files, or graphic 
files. 

Use the View toolbar to search for names or keywords or sort designs by 
name, create date, and other criteria. The Search field is very powerful.

Search criteria
In fact you can search on any criterion displayed on the preview pane. To 
begin with, select a file type to search on, and select criteria from the 
droplists.

Searchable fields include common commercial categories:
 General
 Title

Enter search 
criteria

Select search
criterion

Enter search 
string

Clear search
field

Select file type to
search on
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 File name
 Date modified
 Order #
 Order date
 Order due
 Order notes
 Customer
 Contact
 Reference
 Sales rep
 Design status
Once you have selected a search criteria – e.g. ‘Order due’ – select 
further criteria from the second droplist.

Search strings
Optionally, enter search strings directly into the search field – e.g. 
‘colors<5’ – meaning, ‘fewer than 5 colors’. Search strings default to 
‘CONTAINS’ not ‘EQUALS’ unless you enter a different criteria. 
There is also an ‘All’ criterion which allows you to do perform advanced 
queries using the Windows Search syntax such as:
author:”Wilcom” colors:<5 stitches:<3000
This will narrow the search to only those designs which:
 have been authored by ‘Wilcom’
 have less than 5 colors, and 
 have less than 3000 stitches.
Make sure you use correct syntax. Each field name must include a colon 
(:) after the name. Any names, such as ‘Wilcom’, need to be placed 
between double quotes – “Wilcom”. Use the Clear button to clear the 
Find field before conducting another search.

Select further
search criterion
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Reserved terms
Certain terms are ‘hard-coded’ in the design file. When conducting 
searches in languages other than English, you need to make sure that 
these ‘reserved’ terms are entered in English. Note that the following are 
not natively available in the Operating System and will always appear in 
English:
 Colors
 Height
 Machine
 Objects
 Stitches
 Trims
 Width

Note: Search criteria with two words needs to be entered without spaces 
as shown:

Note: When searching on non-reserved terms, you can search for two 
words separated by spaces and the search will turn up all designs with 
either word. If you want to find designs with both words, add a + 
between them – e.g. koi+fish. If you want an exact match, you need to 
include inverted commas in the search string – e.g “my design”.

Adding folders to the library

Remember that the Design Library is a ‘virtual library’ in Windows. 
When you add or remove folders from the navigation pane, this only 

Search criteria Enter...

Color changes Colorchanges

Design status Designstatus

Order date Orderdate

Order due date Orderduedate

Order notes Ordernotes

Product colors Productcolors

Product type Producttype

Sales rep Salesrep

Use Manage Designs > Manage Embroidery Library Locations to add or 
remove existing folders from the Embroidery Library, enabling fast 
searching and filtering.
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affects the Design Library. It does not affect the folder structure on 
your hard drive or network. To add design folders to your library, use the 
Manage Embroidery Library Locations function to locate folders 
containing designs anywhere on your local network.

Add design folders from 
the local network



EmbroideryStudio e4 Reference Manual 995

Use the Remove button to remove a folder from the Design Library. All 
subordinate folders will disappear from the navigation pane. The same 
functionality is also available via popup menu.

Fast searching on shared network drives

For businesses with multiple computers reading and writing EMB or 
machine format designs, there is usually a need to store designs in 
shared network folders. You may want to set up a company server as a 
central repository for all design files. Connect any folders on the server 
to each client PC via Design Library. Design Library relies on Windows 
indexing to ensure fast searching.

To set up fast searching on shared network drives
 For the Windows file server, make sure you have the Windows Search 

service running. You will need a minimum of Windows Server 2008 on 
the server to enable fast-search indexing. You will also need some 
version of EmbroideryStudio installed.

Remove location 
from the library
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 Add the design folder to be shared with the indexing function. Go to 
Control Panel > Indexing Options > Modify and select the correct 
path.

 Install EmbroideryStudio so that the Shell Extension is registered. This 
allows the server to index additional embroidery file properties.

 Once the server has finished indexing the folder, then, for every PC 
using the file server, add the design folder to Design Library. See 
above.

Note: Fast searching will not work with NAS type devices as they are 
non-windows based operating systems.

Managing quotes & orders

The Design Library provides a practical and simple method of recording 
and managing quotes, orders, and approvals. It is oriented mainly to 
‘Custom Logo’ commercial embroidery, where a design needs to be 
stitched on a specified garment in a defined location. Order information 
is saved directly with the design file. This allows quotes and orders to be 

Select design folder 
to share on the 
network



EmbroideryStudio e4 Reference Manual 997

managed via the designs they use without the complications of a 
separate database.

Order details

Basic order details are stored as EMB file properties. Any alphanumeric 
information can be entered. Fields include:

Enter and edit
order details

Field Details

Filename File name of the selected design. This will often be a number 
or alphanumeric format for easy cataloging.

Title Defaults to filename. Add a more descriptive name for easy 
searching. This name appears on the approval sheet or 
worksheet.

Design status Use ‘design status’ for digitizing and approvals – e.g. ‘Logged’, 
‘Verified’, ‘In Progress’, ‘For Review’, ‘Approved’.

Print approval 
sheet

Takes you to Approval Sheet print preview directly. You have 
the option of sending to a printer, printing a PDF, or sending by 
email.

Order details

Order # Embroidery company’s quote/order number

Order date Date the order was placed

Order due date Date the completed order is due
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Tip: Companies can and should establish guidelines for staff to enter 
consistent information. No checking or enforcement is done by 
EmbroideryStudio.

Related topics...
 Printing design reports

Production jobs

A ‘production job’ in EmbroideryStudio is essentially one design on one 
garment. It is defined as:
 A discrete embroidery design
 To be stitched on a specified product in a specified location
 For a specific order number relating to a specific customer on a specific 

order date
 For a specified order quantity, broken down by color / size / quantity.
A customer order might sometimes require multiple production jobs. If 
so, you use separate EMB files for each job in the order. To see all jobs 
for a specific order, list designs by order # or customer, etc.

Order notes Internal notes for the sales/order staff. They do not appear 
anywhere other than here. The comments in the summary tab 
are included in the production worksheet and are intended for 
production staff.

Customer details

Customer Customer name and/or ID

Contact Customer contact person

Reference Customer reference / PO order or similar

Sales rep Name of salesman dealing with the customer

Product details

Product type Garment or article type – e.g. Polo Shirt

Position Position of design on the product

Quantity Total number of pieces to be stitched with design

Product Brand, style code, product name

Product colors May include product color code or name.

Color / Size / Qty Matrix of product color, size, quantity for the product

Field Details



EmbroideryStudio e4 Reference Manual 999

Multiple production jobs in one order
If a customer order requires multiple production jobs, separate EMB 
design files are created for each one. You can handle this in one of two 
ways. Either define a different internal order number for each job with a 
common stem. For example:

Alternatively, use the same order number and distinguish the job by file 
name. For example:

Design status
Design Status is managed by company staff who change the status 
manually when relevant. Designs can be searched, grouped, and 
managed by status. The droplist contains the following default values:

A staff member sets the status to indicate what he has done, not what is 
to happen next. Other staff monitor status via the Design Library in 
order to know when they are supposed to take subsequent action, and 
update status when they have done so.

Job Order # File Name

1 12345-1 DesignFile

2 12345-2 DesignFile

Job Order # File Name

1 12345 DesignFile-1

2 12345 DesignFile-2

Status Usage

1-Requested Customer Service or Sales requests a new design to be 
digitized.

2-Assigned Digitizing manager assigns to an embroidery digitizer.

3-Digitized Digitizer finishes – design is ready for internal review.

4-Not Ok Digitizing was checked and found faulty – needs to be fixed.

5-Ok Digitizing was checked and found ok – Sales rep to send to 
customer for checking and approval.

6-Sent to 
Customer

Sales rep has sent the design to customer for approval.

7-Approved Sales rep records customer approval.

8-In Production Production manager indicates the job is in production.

9-Job Done Production manager signs off when production job is done.



Chapter 40   Design Management 1000

Grouping & sorting production jobs
Company staff can use Design Library to see all jobs related to one 
order by searching or sorting by order number. You can also:
 Group by: Design Status, Customer, Order, Order Date, Order Due, 

Product Type
 Sort by: Design Status, Customer, Order, Order Date, Order Due, 

Product Type 

Order tracking

Order tracking typically involves some or all of the following steps:
 Staff enter basic order details and status in EmbroideryStudio and 

save as an EMB design file:
 Either a new file which serves as a design request to be digitized, or
 An already digitized EMB design which is to be used for the new 

order.
 Design Library automatically indexes order and design details for 

quick search and find.
 Staff use Design Library to view and manage designs as well as 

quotes, orders, and approvals. Browse, list, or search for designs by:
 Customer
 Order
 Date
 Size
 Design name
 Description, etc

 Order details are printed on approval sheets and emailed for customer 
approval.

 Order details are printed on production worksheets for production 
staff.

 Staff use design status to track and manage order workflow, including 
list of designs:
 To be digitized
 Awaiting customer approval
 Ready for production, etc.

Order tracking by job role

Various job roles within the organization may be involved in preparing 
and managing orders.
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All staff
All staff who have access to Design Library can:
 Easily search and view designs
 Manage and modify design information
 Create design requests
 Create or modify actual designs
 Update design status.

Sales & customer service staff
Embroidery sales and customer service staff will use this kind of 
workflow:
 Create new design requests and enter order details in new or existing 

designs.
 Determine stitch estimates to help determine pricing for quotations.
 Visualize artwork or digitized design on the product to be 

embroidered.
 Estimate design run-time and job-time.
 Email approval sheets to customers for approval.
 Track status of designs and customer approvals.
 Release approved jobs for digitizing and/or production.

Digitizing managers & staff
Digitizing managers and staff will use this kind of workflow to plan and 
manage the design process:
 Review orders by customer, order, or date.
 Use ‘design status’ for digitizing and approvals. Staff update status 

manually as necessary.
 Designs can be searched, grouped, and managed by status.
 Track and manage internal checking status of newly digitized or 

modified designs.
 Track and manage previous and new designs by customer, order, date 

and other job details.

Production managers & staff
Production managers and staff will use this kind of workflow to plan and 
manage production jobs:
 Review orders which have been approved for production.
 Check order details including:
 which designs to use for which order
 how many pieces to embroider on what products and in what 

position
 color/size/quantity details.
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 Estimate design run-time and job-time.
 Help plan production schedules from order-due date, design statistics, 

and job quantities.

Converting designs

By default EmbroideryStudio saves designs to its native EMB format. This 
contains all information necessary both for stitching a design and for later 
modification. The Design Library conversion function allows you to 
batch-convert to and from all EMB and other supported design file types. 
It also batch-converts many machine file formats such as DST, EXP, SEW. 

To convert designs
 Select the file(s) to be converted and click the Convert Selected 

Designs icon. The dialog lists all machine file formats supports by the 
software.

 Select the file types you want to convert to.
 Click Browse to locate a destination folder for the converted designs.
 Click Convert to start the conversion. The converted designs will be 

stored in the nominated folder.

Related topics...
 Send designs to Connection Manager
 Machine Files

Use Manage Designs > Convert Selected Designs to convert the design 
selected in the embroidery library into different machine file types.

Select machine 
file formats to 
convert

Select target 
folder
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 Embroidery file formats

Outputting selected designs

Send designs to machine for stitching via Connection Manager. Create 
hard copy reports of a selected designs using a printer or plotter. Report 
types may include production worksheets, appliqué patterns, color films, 
as well as catalogs and lists of selected designs.

Sending designs to machine

EmbroideryStudio supports various machine models. Some can be 
connected by cable directly to your PC via USB port. Others require files 
to be placed in a specific network location or ‘watching folder’. Older-style 
machines do not support direct connection but they do read ATA PC cards 
and/or USB memory sticks. Connection Manager provides a method of 
connection to machines that appear as removable media or make use of 
third-party connection software. Once set up in EmbroideryStudio, a 
single click is sufficient to send the design to machine.

Note: You can only send one design at a time via Connection Manager.

Related topics...
 Setting up machines for Connection Manager
 Machine Files
 Machine Formats

Print selected designs

You can print worksheets for selected designs, and include thumbnails of 
each in the worksheet. Unlike Print Designs, this option can provide 
design and sewing information.

To print selected designs
 Sort the designs to be printed using Sort.
 Select a design and click the Print Selected icon. The Print Design 

dialog opens.

Use Manage Designs > Send to Connection Manager to stitch out the 
design selected in Embroidery Library.

Use Manage Designs > Print Selected to print designs selected in the 
embroidery library.
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 To customize the printout, click Options.

 Set design report options to include the information you want in the 
format you require.

 The Worksheet type panel provides options for further 
customization. 

 Click OK and ensure correct printer settings in the Windows Print 
Setup dialog. The dialog and the settings available vary from printer 
to printer. See your printer manual for details.

Option Function

Approval sheet This is intended for the customer, not production staff. 
Customers can see what they are ordering and approve 
accordingly. 

Production 
worksheet

This is intended for production staff. All production-related 
information, such as bobbin length, design size, garment 
fabric, etc, is provided.

Production 
summary

This provides two summary tables of the design and 
associated colorways – a Colorway Summary together with a 
Design Summary. 

Appliqué 
patterns

This shows appliqué patterns – cutter information – isolated 
from the design. These can be used as a guide to cutting out 
fabric pieces. They also show which appliqué pieces are to be 
included.

Color film Provides a list of colors in the design, together with color and 
stitch information for each color layer. This helps the machine 
operator to see each stitch color in order of stitchout.
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Related topics...
 Printing design reports
 Customizing design reports

Print design catalogs

Printed catalogs contain thumbnails plus limited text details. You can 
prepare catalogs of your designs to suit your needs.

To print a design catalog
1 Open Design Library and filter designs as desired.

2 Select the designs you want to include in the catalog.
3 Select Manage Designs > Print Selected to Catalog. The Print 

Catalog Options dialog opens.

4 Adjust settings as preferred:
 Change Scale (%) to adjust thumbnail size.
 Select a catalog format – thumbnails with or without design details.
 Choose output target – PDF file or actual printer.

Use Manage Designs > Print Selected to Catalog to print selected designs 
to a catalog.

Choose thumbnails 
with or without design 
details
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5 Click Print. The Print Design dialog opens.

6 Click Preview to view the catalog.

7 To print the design, choose an option:

Option Purpose

Print now Click to send the design report to your local printer.

Save as PDF Click to save the report as a PDF document. You are prompted 
to save to the hard drive or network location.

Send PDF via 
email

Click to send the report – usually an approval sheet – as a PDF 
attachment to your local email client. The PDF is automatically 
identified by customer name, order number, and current date.
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Tip: If the catalog requires more than one page, you can select which 
page to print in the MS Windows® Print Setup dialog.

Related topics...
 Group & sort designs
 Printing design reports

Export design lists

The Export Design List option can be used to print design lists for 
selected folders. This option allows you to create a simple design report 
which can easily be imported into a spreadsheet. You may want to use 
this in order to manage designs by file name.

To export a design list
 Preset the measurement units you want to use – metric or U.S.

 Open the Design Library and select a design folder.
 Sort and filter the designs to export.

 Select all files to include in the export list.

Use Manage Designs > Export Design List to export selected files to Tab 
and CSV (Comma Separated Value) formats suitable for use by most 
spreadsheets.
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 Click the Export Design List icon and choose a location to save the 
list. Choose whether to save as a tab-delimited or comma-separated 
text file.

 Open the text file in a spreadsheet for further sorting and printing.

Tip: Designers frequently want to distribute designs for viewing in real 
colors, in TrueView™ or otherwise, with or without fabric backgrounds. 
Screen images can be captured in PNG format and send as email 
attachments.
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Chapter 41

Asset Management

EmbroideryStudio allows you to create files or ‘assets’ of various kinds 
during normal use. The most important of these are your actual 
embroidery designs. But there are other assets you may create, such as 
design templates, custom motifs and fonts, etc. These are preserved 
from installation to installation, whether installing a new version of 
EmbroideryStudio or a software update. 

It’s a good idea to familiarize yourself with the locations and file names 
of your custom assets for various reasons...
 In the first instance, you should back up your custom assets in case of 

computer crash.
 Also, you may want to share assets with other EmbroideryStudio 

users, or install third-party assets such as custom fonts.
 Finally, if you want to install your software to a new computer, you will 

need to manually copy the contents of your asset folders to the new 
locations.
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Tip: If you are installing your existing setup to a new PC, it’s a good idea 
to create a single ZIP file of all your custom data and pre-install it to the 
new computer before installing EmbroideryStudio.

Custom assets in EmbroideryStudio

The table below summarizes the custom assets you will create and need 
to manage in EmbroideryStudio...

Design files

Design presets

Assets Description

Embroidery 
designs

The built-in Design Library makes it easy to search, sort and 
browse all embroidery designs on your network. Any folder 
containing embroidery designs can be included in the 
navigation tree. See Design Management for details.

Machine files Similarly, the Design Library makes it easy to search, sort and 
browse all machine files on your system. See Design 
Management for details.

Artwork Artwork files may also be managed with the Design Library. 
Sample files are installed by default to the standard Windows 
‘Pictures’ library. See Design Management for details.

Recovery files The Auto Save function creates a temporary file with the 
extension EMA in the RECOVER folder. This is automatically 
restored when EmbroideryStudio is restarted after a computer 
crash. You can access these files manually by browsing to the 
folder and renaming files from EMA to EMB.

Backup files If the Backup Copy option is activated, a backup copy of the 
current design file is automatically created in its previously 
saved form. The backup copy is saved in the BACKUP folder 
with the original file name and native file format.

Assets Description

Design 
templates

Templates are special files used to store fabrics, objects and 
default settings. Use templates when digitizing frequently-used 
design types so that you do not have to adjust current settings 
every time. See Working with templates for details.

Styles A style is a group of property settings stored under a unique 
name. This makes it easy to apply them to selected embroidery 
and lettering objects. Define new styles for a design template, 
either from scratch or based on an existing style or object. See 
Working with styles for details.
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Lettering assets

Stitch presets

Auto fabrics Normally you choose a fabric when you start a design although 
you can change it at any stage. Fabric settings affect all object 
types other than motif fills, appliqué, and run stitches. In addition 
to predefined fabric settings, you can create your own custom 
fabrics to suit particular needs. See Working with fabrics for 
details.

Assets Description

Fonts EmbroideryStudio provides methods for defining custom and 
‘user-refined’ embroidery fonts. You can digitize letters from 
backdrop images, convert vector objects, or digitize freehand 
using any of the input method tools. See Custom Lettering for 
details.

Monogram 
templates

You build monograms using the Monogramming docker. The 
simplest way to get started is to select a monogram template 
from the Designs tab. The Custom folder contains your custom 
templates. See Monogram designs for details.

Teamname 
teams

A teamname design may include names from predefined teams 
which can be used any number of times. You can even combine 
members from different teams. See Managing teams for details.

Teamname 
templates

When creating teamname designs, you can use a preset layout 
or a custom layout based on artwork you may have received. 
Typically, you will receive a brief and possibly artwork from a 
customer. This design can be saved for reuse as a teamname 
template. See Create custom templates for details.

Kiosk templates EmbroideryStudio provides an easy-to-use lettering ‘kiosk’ 
capability for cap and other embroidery. The kiosk is primarily 
intended for retail outlets where fast and simple personalization 
is required. The kiosk provides a set of predefined design 
layouts. You can create your own layouts for use in the kiosk. 
The default banner can also be customized. See Lettering Kiosk 
for details.

Assets Description

Motifs Motif stamps are ready-made design elements, such as hearts, 
leaves or geometric patterns which are contained in libraries or 
‘sets’. You can define your own stamps for individual use or for 
use in motif runs or fills. See Custom motifs for details.

Assets Description
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Other assets

Note: In order to preserve any custom assets, do not uninstall your 
existing version of EmbroideryStudio. Any new updates can be installed 
over top of your existing installation. If you want to move your 
EmbroideryStudio to another PC, you will need to manually transfer any 
custom assets you have created or received from third parties.

Program splits Program Split is a decorative fill stitch where needle 
penetrations form a tiled pattern. Make your own patterns to use 
in Program Split fills. The same patterns can also be used with 
Flexi Split effects. See Creating patterns with custom splits for 
details.

Carving stamps The Carving Stamp feature allows you to select object outlines 
from the design window and apply them directly as stamps or 
save them to a library for future reference. You can use vector 
or embroidery objects as a basis for stamps. See Add stamps to 
a library for details.

Assets Description

Hoops The software allows you to define your own hoops and save for 
later use or associate with a custom machine type. Custom 
hoops are needed because new hoops become available for 
sewing machines more frequently than the software is updated. 
See Creating custom hoops for details.

Machine formats EmbroideryStudio provides standard formats for most 
machines. However, if your machine is different, you may need 
to customize the machine format settings. See Custom machine 
formats for details.

Products EmbroideryStudio lets you choose a garment or product 
backdrop on which to position your decoration. Use it to display 
location, size and overall appearance for visualization and 
approval purposes. It is possible to create custom product 
backdrops for use in your business. See Product Visualizer 
Templates for details.

Thread charts The thread charts contained in the software represent the many 
different brands and colors of thread available. You can modify 
thread charts to reflect the threads you are currently using. You 
can even create your own. See Create & modify thread charts 
for details.

Assets Description
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Custom asset locations

Custom data – including custom fabrics, templates, motifs, borders, and 
fonts – is stored in dedicated folders. In EmbroideryStudio, custom 
locations divide into two broad categories – program data and user data.

Note: Some data folders will only be created when the software is 
opened for the first time after restarting your system.

Program data
Program data is written the Windows ‘ProgramData’ folder whenever you 
modify a standard EmbroideryStudio asset such as auto fabrics. This 
folder is located here: C:\ProgramData\Wilcom\EmbroideryStudio. 
Asset files are then located in the following sub-folders...

Embroidery data
Embroidery data includes any design or machine files. Theoretically, this 
data can be housed anywhere on your network. By default, it is installed 
here: C:\Users\Public\Public Embroidery. Files are then classified 
into the following sub-folders...

Custom asset Location File types

Auto fabrics ..\RES\AutoFabric userdefined.autost

Backup files ..\BACKUP *.EMB

Borders ..\BORDERS *.ESA

Carving stamps ..\STAMPS *.ESA

Fonts ..\Fonts *.ESA

Hoops ..\RES\Hoops USRHOOPS.DSC

Kiosk ..\Kiosk *.EMB, *.PNG

Machine formats ..\RES\Machines UserMachineModels.txt

Motifs ..\MOTIFS *.ESA

Program splits ..\TEMPLATE *.EMT

Recovery files ..\RECOVER *.EMA

Styles ..\TEMPLATE *.EMT

Templates ..\TEMPLATE *.EMT

Thread charts ..\RES\ThreadCharts *.TCH

Custom asset Location File types

Embroidery designs ..\EmbroideryStudio e4 *.EMB, *.ART, 
*.JAN, etc
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Image data
Image data includes any artwork files. Theoretically, this data can be 
housed anywhere on your network. By default, it is installed here: 
C:\Users\Public\Pictures. Files are then classified into the following 
sub-folders...

Product backdrops
EmbroideryStudio allows you to choose a garment or product backdrop 
on which to position decorations. The Product Visualizer feature is used 
to display location, size and overall appearance for visualization and 
customer approval purposes. You can add your own single-color and 
multi-color product templates to the software. See Product Visualizer 
Templates for details.
As assets, product backdrops fall between the stools. They are PNG 
artwork files but they are considered ‘program data’. They have their own 
dedicated location here:
C:\Program Files\Wilcom\EmbroideryStudio\Products

Navigating to assets

Using File Explorer, you can navigate to the precise location of your 
EmbroideryStudio assets with the navigation tree on the left of the 

Machine files ..\Machine Files *.DST, *.U??, 
*.TAP, etc

Monogram templates ..\EmbroideryStudio e4\Monogram 
Template Designs\Custom

*.EMB

Teamname teams ..\EmbroideryStudio e4\Teamname 
Teams

*.TXT

Teamname templates ..\EmbroideryStudio e4\Teamname 
Template Designs\Custom

*.EMB

Custom asset Location File types

Artwork ..\EmbroideryStudio e4 *.JPG, *.BMP, *.PNG, *.CDR, *.AI, 
*.EPS, etc

Fabric patterns ..\Fabrics *.JPG, *.BMP

Custom asset Location File types
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window, or simply by typing or copying the path name into the address 
field and pressing Enter.

Whenever you install updates or upgrades to your existing software, the 
above folder structure, together with any custom assets, will be 
preserved. However, if you install your software to another PC, you will 
need to manually copy the contents of these folders to the new location.

Note: The C:\ProgramData folder may be hidden on some PCs 
depending on the permissions of the user who is logged in. See Showing 
hidden folders for details.

Personal designs & artwork

Amongst your most important assets are of course your embroidery 
designs and any artwork files you may use. These can potentially be 
saved anywhere on your system. By default however...
 Any designs, cutting files, or machine files that you save from 

EmbroideryStudio will be saved by default to the ‘Public Embroidery’ 
folder at this location ... 
C:\Users\<USER>\Public Embroidery\EmbroideryStudio\

 Similarly, any artwork you save from EmbroideryStudio will be saved 
by default to the ‘Pictures’ folder at this location...

Navigate folder
structure via

navigation tree or
address bar
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C:\Users\<USER>\Pictures\EmbroideryStudio\

Whenever you install updates or upgrades to your existing software, the 
folder structure will be preserved. However, if you install your software to 
another PC, you will need to manually copy the contents of the 
‘Embroidery’ and ‘Pictures’ folders to the new location.

Showing hidden folders

If you need to manually copy the contents of your asset folders to a new 
location, you may find that the C:\ProgramData folder is hidden on 
your PC, depending on the permissions of the login you are using. 
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To show hidden folders
 Open the View tab in File Explorer as shown. 

 Tick the Hidden files option. This will reveal the ‘ProgramData’ folder 
and all its contents.

Tick to show 
‘ProgramData’ folder 
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Chapter 42

Product Visualizer Templates

EmbroideryStudio allows you to choose a garment or product backdrop 
on which to position decorations. The Product Visualizer feature is used 
to display location, size and overall appearance for visualization and 
customer approval purposes. Production worksheets provide an option to 
print approval sheets with or without garment backdrops.

Choose colors for each product type. The software provides a library of 
garments of common brands and styles. Most garments use only one 
color but multi-color products with up to three layers are supported. You 
can add your own single-color and multi-color product templates to the 
software by following the method outlined in this section.

Preparing samples

This topic deals with the technique of preparing source images for 
deployment in EmbroideryStudio as product templates for Product 
Visualizer. The most common scenario when creating product templates 
is a single-color product image.

Choose suitable source images

A lot depends on the quality of the source image you choose for use as a 
product backdrop. As a starting point, you need high resolution photos of 
the garment you want to use – e.g. front and back. While images are 
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intended mainly for onscreen viewing, they may also be printed on 
approval sheets.

Size
If you take a small product image and blow it up to actual size, it will not 
gain in quality or resolution. There needs to be enough image data (DPI) 
to display the image satisfactorily at actual size. For optimum quality you 
need an image with:
 Real-world dimensions that represent the garment at actual size – e.g. 

60 cms wide x 90 cms high
 Minimum of 96 DPI, ideally closer to 160 DPI.

Color depth
Make sure you are using an RGB (24 bit color) photo. Commonly used 
formats include RAW, PNG, TIFF or JPG.

Check physical size 
and DPI setting
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Note: As well as reasonably high resolution photos, you need a good 
photo editor. Most screenshots in this document are taken from Corel 
PhotoPaint which is bundled with EmbroideryStudio.

Crop the image

Remove unnecessary border pixels by cropping. This makes it easier to 
set the correct real-world size.

Set image size

Scale the image to real world size using a tool such as the Resample 
dialog below.

Indicative settings:

Scale image to 
real world size

Set DPI to 96 screen 
resolution
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 Untick the ‘Maintain original size’ checkbox.
 Make sure ‘aspect ratio’ is locked.
 Change either width or height to match the physical size of the 

garment or article. For example, height = 50cm. The new size needs 
to be equal to or less than original. If not, the resolution will be too 
low and the image will be pixelated.

 Change the resolution to 96 DPI or higher. Packaged product images 
are set to 96 DPI for standard screen resolution. However, new 
monitors are capable of higher resolutions such as 160 DPI.

 Ideally, the original file size (total number of pixels) should be 
maintained so the image does not lose data (quality).

Note: Simply increasing the DPI to 96 will not add resolution to a low-res 
image. It will only duplicate existing pixels.

Set transparency

Because you want product images to display correctly on any color 
background, you need to make the image background transparent. Make 
sure anti-aliasing is activated. Image edges will appear smoother. The 
transparent background usually appears as a gray checker pattern. If you 
are using Corel PhotoPaint, follow these steps…

To set the transparency
1 Choose Magic Wand Mask.

2 Click the background to select the whole area.
3 If needed, click the + button to add more area until you have selected 

the whole background.

4 Adjust the ‘Tolerance’ setting to limit the range of colors included in 
the transparency. If the background is too similar to the foreground, 
this can become problematic.

Choose Magic 
Wand Mask

Click to add 
more area
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5 Click Invert Mask. The garment alone will be selected.

6 Select Object > Create > Cut Selection.
7 In the Object Manager, select the background and click Delete.

8 The garment will be appear on a gray and white checker pattern. This 
means the background is transparent.

Click to select 
garment alone

Select and 
click Delete

Background is 
transparent
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Converting to grayscale

Product images which are added to the software need to be grayscale, as 
shown below. These are then colored in EmbroideryStudio according to 
user requirements.

Convert to grayscale

Convert the selected image to grayscale making sure that transparency 
is preserved.

Convert to 
grayscale
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Tip: With some photo editors, grayscale images have a limited set of 
tools that make it difficult to perform the subsequent tasks. It is 
preferable to ‘desaturate’ the image. Another advantage of desaturation 
vs grayscale is that you preserve all image data. Hence, you are less 
prone to lose image information like textures, shadows and highlights.

Adjust image brightness and contrast

Generally speaking, the middle gray becomes the selected color and 
lighter and darker grays become shades of that color. For this reason we 
need to ensure that the image is correctly balanced in terms of brightness 
and contrast.

Use a luminance histogram to assess where brightness and contrast lie 
on the graph. You want to have a good spread of dark and light shades 

Balance 
brightness and 
contrast
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of gray, providing good contrast. The histogram curve should be centered 
around the middle.

Save as PNG

Finally, save as PNG format. This format supports transparency. 

Histogram curve 
should be centered 
around the middle

Save as PNG 
format
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Preparing multi-color samples

Most garments use only one color but you will find products with two or 
even three colors. This topic deals with the technique of preparing source 
images for deployment in EmbroideryStudio as multi-color product 
templates for the product visualizer.

You follow exactly the same procedure as for single-color designs, except 
that you need to separate your multi-color image before converting to 
grayscale.

Prepare the layers

In order for EmbroideryStudio to detect the number of colors used in your 
garment, you need to separate the photo into different layers for each. 
The typical photo tool used to separate colors is the masking tool.

Tip: Some graphics packages refer to ‘objects’ rather than ‘layers’.

Use mask tool to 
separate colors
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Resulting layers
For example, let’s say you need to separate a T-shirt which employs two 
colors. The resulting layers (or objects) would look like this:

Make sure the background of each layer is transparent.

Layer rules
The following rules apply to a multi-color shirt. Variations on the same 
approach should be applied to other products such as multi-color caps.
 The body color should always be the layer 1 file.
 Sleeves / collar, if present, should always be the layer 2 file.
 Any other trims and tipping should always be the layer 3 file, unless 

there is no layer 2.
 Each layer must be saved as a separate grayscale PNG file.
 Each PNG file needs to have identical dimensions, DPI, etc.

Tip: it is important to first create the layers / masks, objects, etc, and 
then convert the resulting images to grayscale / desaturated.
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Convert to grayscale

Convert the resulting objects to grayscale making sure that transparency 
is preserved. Remember, you want to have a good spread of dark and 
light shades of gray, providing good contrast.

The layers can then be colored separately in EmbroideryStudio.

Save your layers

Once you have finished separating the photo into different layers, you will 
need to save each as a separate file and copy all resulting files in a 
particular folder.

File format
Each layer must be saved in PNG format. If you have worked your layers 
correctly, each will have a transparent background that usually appears 
as a gray checker pattern.

File naming
Naming conventions:
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 Layer1 file name needs to take the form ‘FileName.png’ – e.g. 
‘Vest.png’.

 Layer2 file name takes the form ‘FileName2.png’ – e.g. ‘Vest2.png’.
 Layer3 file name takes the form ‘FileName3.png’ – e.g. ‘Vest3.png’.

Note: The first name doesn’t need a number and will be name that 
identifies the garment in Product Visualizer.

Deploying product templates

Having created your product images, you are now ready to deploy and 
test them. There’s no need to restart EmbroideryStudio. Open Product 
Visualizer and select your new product in the Products tab.

Copy to folder location

All image files need to be saved in the same location...
 Navigate to the following location:

C:\Program Files\Wilcom\EmbroideryStudio_e4.x\Products
Garments are organized by number of colors and garment type – e.g. 
2 colors, Caps, Kids, etc. 

 Create your own sub-folders as necessary and copy in your prepared 
image files.
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Note: The file name will be the name that identifies the garment in 
Product Visualizer.

Related topics...
 Custom asset locations

Test product templates

While you can create separate templates for different garment sizes, 
EmbroideryStudio assumes a ‘Large’ size garment. This can be further 
scaled within EmbroideryStudio to arrive at an exact size for display 
purposes.

Apply different colors and see how they look on screen. For best results, 
try the first two rows of the color selector. These less saturated colors 

Use Color > Product Visualizer to choose a garment or product backdrop 
on which to position your decoration.

Click View > Show Product to toggle current product display. Right-click for 
Product Visualizer settings.

Use Zoom > Zoom to Product to view the entire product in the design 
window.

Scale image to 
real world size
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usually color well. Highly saturated colors like bright red, cyan, and 
magenta tend to wash out the product image.

Try selecting product colors on-the-fly using the Color Palette flyout:

Related topics...
 Visualize products

Try first two rows 
to start with

Select color 
product backdrops 
on-the-fly
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Chapter 43

Standard Fonts

The tables below display all embroidery fonts that are standard with 
EmbroideryStudio. 

Roman fonts
Roman character fonts include:

3D fonts Created especially for use with foam – commonly used on caps as 
foam is not suitable for washing.

Appliqué fonts Created especially for appliqué, containing all the required outline, 
tack and cover stitches. Great for use on large scale and to reduce 
stitch count.

Bling fonts Created especially for rhinestone and diamantes. They are vector 
format.

Block fonts San-serif typeface style, very common with names and business 
logos. A great style for embroidery as it is clear and easy to read.

Chenille fonts Created especially for chenille embroidery but only suitable if your 
machine supports it. Commonly used for sport and street wear.

Faux chenille 
fonts

It is possible to modify Stipple Stemstitch Fill settings for a denser 
coverage. Combined with a thicker yarn such as Madeira’s 
Burmilana thread, it is possible to achieve a chenille effect. These 
dedicated fonts utilize this proven technique to create ‘faux chenille’ 
lettering.

Fancy fonts Anything that is not ‘blocky’ can be used in a decorative way, 
depending on the style of logo.

Monogram fonts Especially designed for monogramming purposes – commonly 
used for creating initials popular with gifts such as towels and linen. 

Outline fonts Commonly used for sports wear, on back of jackets. Work best at 
larger scale.

Run stitch fonts Commonly used for small lettering, anything under 5mm and where 
satin column are not suitable. 

Script fonts Fluid strokes where characters connect, resembling a hand written 
style.



EmbroideryStudio e4 Reference Manual 1033

Non-Roman fonts
Non-Roman character fonts include:
 Cyrillic fonts
 Hebrew fonts
 Japanese fonts

Minimum & maximum sizes
For best results when stitching, do not exceed the recommended 
maximum or minimum sizes. Note, however, that recommended 
maximum and minimum heights refer to UPPER CASE letters. Most 
embroidery fonts are digitized from an original TrueType Font (TTF), some 
of which have lower-case letters – e.g. ‘a’ and ‘c’ – which are about 70% 
the height of a capital letter. As a result, these letters may be too small 
to embroider neatly. You may need to increase the size of the lower-case 
characters to suit the embroidery.

Special characters
You can create special characters in each font by holding down the Alt 
key on your keyboard and typing 0 (zero), its code, using the numbers 
on the keypad. For example, to type ê with the code 234, type 
Alt+0234. The accented letter will appear when you release the Alt key. 
See also Adding special characters.

Note: Not all characters are available in all fonts.

Serif fonts Older style font which includes an embellishment at the ends of the 
stroke, popular with sportswear.

Small fonts Fonts which are 6mm and below, including satin stitch columns with 
push and pull adjustments.

Special fonts Graphical, multi-colors and fill effects are some of the things that are 
associated with special fonts. Commonly used for decorative 
purposes.

Two-color fonts Each character contains two colors. Commonly used for sports 
wear, on back of jackets. Work best at larger scale.

TrueType Font

Embroidery Letters



Chapter 43   Standard Fonts 1034

Join method
The lettering join method is preset to give the best results for each font. 
Options include:

Roman fonts

Join Purpose

Bottom join BJ Letters are joined along the baseline. Use it when stitching on 
towelling – joins are hidden in the pile.

Closest join CJ Letters are joined at the closest point. Use it to minimize trims.

As digitized AD Letters are joined as they were digitized. Use it with fonts 
combining different fill stitch types or special effects.

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

3D fonts

3D Block2 ^ 0.6 15 1.2 30 AD

3D Brush 
Script ^ 0.8 20 1.6 40 AD

3D Emphatic ^

s

0.8 20 2.4 60 AD

3D Futuro ^ 0.8 20 1.0 25 AD

^ New to ES e4
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3D London ^ 0.8 20 1.2 30 AD

3D 
Monoglyceride ^ 0.8 20 1.2 30 AD

3D 
Sofachrome ^ 0.55 15 0.8 20 AD

Appliqué fonts

College 
Appliqué 1.0 25 3.2 80 AD

Crest Appliqué - - - - AD

Glory Appliqué 1.2 30 4.0 100 AD

Bling fonts

Bling Block - - - - AD

Bling Hollow - - - - AD

Bling Script - - - - AD

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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Block fonts

Advent ^ 0.4 10 2.0 50 CJ

Albert ^ 0.4 10 0.8 20 CJ

Angle Block 0.4 10 4.0 100 CJ

Architect 0.4 10 2.0 50 CJ

Arial Rounded 0.3 7 1.8 45 CJ

Art Block 0.4 10 3.0 75 CJ

Athletica 0.4 10 3.0 75 CJ

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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Avant Garde 0.2 5 2.4 60 CJ

Avatar

o

0.4 10 2.0 50 CJ

Bauhaus 0.4 10 2.0 50 CJ

Block1 0.25 6 1.8 45 CJ

Block2 0.25 6 2.4 60 CJ

Block2-Auto 0.2 5 2.2 55 CJ

Block Caps 0.2 5 2.0 50 CJ

Bounty ^ 0.4 10 1.2 30 CJ

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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Bravo ^ 0.32 8 3.0 75 CJ

Castle 0.25 6 2.0 50 CJ

Folio 
Condensed 0.3 7 2.0 50 CJ

Futura 0.25 6 2.4 60 CJ

Goudy Sans 0.25 6 1.6 40 CJ

Gypsy ^ 0.25 6 1.0 25 CJ

Handel Gothic 0.3 8 2.0 50 CJ

Helvetica 0.25 6 2.4 60 CJ

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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Impress 0.3 7 1.6 40 CJ

Informal 0.25 6 1.2 30 CJ

Jolt 0.4 10 12.0 50 CJ

Kabel 0.25 6 2.4 60 CJ

Lazer 0.25 6 2.0 50 CJ

Legal Block 0.25 6 2.0 50 CJ

Lydian 0.3 7 2.0 50 CJ

Meister Block 0.4 10 2.2 55 CJ

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4



Chapter 43   Standard Fonts 1040

Microgramma 0.25 6 2.4 60 CJ

Microscan 0.3 7 1.6 40 CJ

Monoglyceride ^ 0.4 10 2.4 60 CJ

Monoglyceride 
Bold ^ 0.4 10 2.4 60 CJ

Narrow Block 0.6 15 4.0 100 CJ

Round Block 0.8 20 1.4 35 CJ

Slim Block 0.8 20 8.0 200 CJ

Sofachrome
^

0.4 10 2.0 50 CJ

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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Spatial ^ 0.4 10 0.8 20 CJ

Square Block ^ 0.4 10 2.7 70 CJ

Stencil Block 0.4 10 3.0 75 CJ

Super Block 0.4 10 2.0 50 CJ

Swiss 0.4 10 2.0 50 CJ

Tahoma 0.25 6 1.6 40 CJ

Text Block 0.3 7 1.8 45 CJ

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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Urbane 0.25 6 1.6 40 CJ

Utility Block 0.3 7 4.0 100 CJ

Veranda 0.25 6 2.4 60 CJ

Yama ^ 0.25 6 1.4 35 CJ

Chenille fonts

CH 2Color 
Numbers 2 50 5 125 AD

CH 2inch 
Pennant Script 2 50 2 50 AD

CH 3inch 
Pennant Script 3 75 3 75 AD

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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CH 3.5inch 
Shadow Nos 3.5 87 3.5 87 AD

CH 6inch 
3D-Block 6 150 6 150 AD

CH Chenille 
Block 2 50 6 150 AD

CH Playbill 4 100 6 150 AD

CH Prince 
Athletic 2 50 6 150 AD

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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CH Square 
Block 2 50 6 150 AD

CH Tall 
Pennant Script 3 75 4 100 AD

Faux chenille fonts

Yale 2 50 4 100 AD

Vermicelli 2 50 4 100 AD

Fancy fonts

Agatha 0.4 10 1.6 40 CJ

Anaconda 0.3 8 2.0 50 CJ

Arnold 0.4 10 2.0 50 CJ

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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Blacklight 0.25 6 2.4 60 CJ

Carla 0.4 10 2.0 50 CJ

Charcuterie ^ 0.8 20 2.5 60 CJ

Cheshire 0.4 10 2.0 50 CJ

Columbo 0.3 8 1.2 30 CJ

Comics 0.4 10 2.0 50 CJ

Crayfish ^ 0.4 10 2.0 50 CJ

Crevasse ^ 0.4 10 2.0 50 CJ

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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Croissant 0.25 6 2.0 50 CJ

Curly 0.4 10 2.0 50 CJ

Dotti ^ 0.4 10 2.0 50 CJ

Dr Zeus ^ 0.4 10 2.0 50 CJ

Enchantment 0.4 10 1.6 40 CJ

Energy 0.3 8 2.4 60 CJ

Enviro 0.5 12 3.0 75 CJ

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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Felt Tip 0.4 10 2.0 50 CJ

Flash 0.25 6 2.4 60 CJ

Flourish Light ^ 0.6 15 2.0 50 AD

Free Style 0.4 10 1.6 40 CJ

Gaelic 0.44 11 2.0 50 CJ

Hana 0.5 12 2.0 50 CJ

Handicraft

0

0.3 8 2.5 65 CJ

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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Hobo 0.25 6 1.6 40 CJ

Kids 0.5 12 1.2 30 CJ

Kindergarten 
Block 0.4 10 3.6 90 CJ

Lariat 0.48 12 1.2 30 CJ

Locker ^ 0.6 15 1.6 40 CJ

Lublik 0.4 10 3.0 75 CJ

Mandarin 0.3 8 2.0 50 CJ

Market 0.4 10 1.2 30 CJ

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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Matisse 0.4 10 1.6 40 CJ

Old English 0.4 10 2.0 50 CJ

Olivia 0.3 7 1.6 40 CJ

Orient Express 0.4 10 3.0 75 CJ

Pacific North 
West ^ 0.32 8 2.4 60 CJ

Pastille ^ 0.4 10 0.8 20 CJ

Pixie 0.5 12 1.2 30 CJ

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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Racer 0.3 8 1.4 35 CJ

Speedy 0.3 8 1.2 30 CJ

Sports ^ 0.4 10 2.7 70 CJ

Staccato 0.4 10 0.6 15 CJ

Thriller 0.4 10 2.0 50 CJ

Toddler 0.6 15 2.0 50 CJ

Toon 0.4 10 2.0 50 CJ

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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Victorian 0.3 7 1.0 25 CJ

Viking 0.35 9 2.0 50 CJ

Western 0.4 10 1.4 35 CJ

Western Serif 0.3 7 1.8 45 CJ

Westminster 0.25 6 2.4 60 CJ

Woodstock 0.3 8 2.0 50 CJ

Monogram fonts

Fancy 
Monogram

0

1.0 25 5.0 125 CJ

Octagon 
Monogram 0.7 18 6.0 150 CJ

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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Point 
Monogram 0.7 18 6.0 150 CJ

Seal 
Monogram 0.7 18 6.0 150 CJ

Outline fonts

Detex Normal 0.4 9 2.0 50 CJ

Discoteque 0.4 10 2.0 50 CJ

Futura Outline 0.6 16 2.0 50 CJ

News Outline 1.2 30 3.0 75 CJ

Outline Block 0.75 18 4.0 100 CJ

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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Petrol Shadow 0.8 20 2.0 50 CJ

Swiss Run 
Hollow 0.6 15 4.0 100 AD

Swiss Run 
Satin 1.0 25 3.0 75 AD

Turncoat ^ 0.8 20 3.1 80 BJ

Run stitch fonts

Run Block 0.2 5 0.25 6 AD

Run Cardigan 0.2 5 0.5 12 AD

Run Freehand 0.2 5 0.5 12 AD

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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Run Liberty 0.2 5 0.5 12 AD

Run Murray Hill 0.2 5 0.5 12 AD

Run Script 0.2 5 0.25 6 AD

Script fonts

Ballantines 
Script 0.5 12 2.0 50 CJ

Book Script 1.0 25 2.2 55 CJ

Cayman 0.4 10 2.0 50 CJ

Chancery 0.3 8 2.4 60 CJ

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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City Script 0.3 8 2.4 60 CJ

Crescent Script 0.6 15 1.4 35 CJ

Easy Script 0.3 7 2.4 60 CJ

Edwardian 
Script 0.6 15 3.0 75 CJ

Formal Script 0.3 7 1.4 35 CJ

Handy Script 0.5 12 3.0 75 CJ

Italian Script 0.4 10 4.0 100 CJ

Karin Script 0.5 12 2.0 50 CJ

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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Lila ^ 0.4 10 1.5 35 CJ

Memo Script 0.25 6 1.0 25 CJ

Moly ^ 0.4 10 2.0 50 CJ

Poetic Script 0.6 15 3.1 80 CJ

Pomander ^ 0.35 8 2.4 60 CJ

Python Script ^ 0.4 10 2.0 50 CJ

Royale 0.5 12 2.4 60 CJ

Script1 0.5 12 3.0 75 CJ

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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Script2 0.3 8 2.0 50 CJ

Script3 0.5 12 4.0 100 CJ

Script4

[

0.8 20 3.2 80 CJ

Script5 ^ 0.4 10 2.0 50 CJ

Script6 ^ 0.4 10 2.0 50 CJ

Script7 ^ 0.6 15 2.7 70 CJ

Script8 ^ 0.6 15 2.7 70 CJ

Upright Script 0.5 12 2.0 50 CJ

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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Vivid Script ^ 0.5 12 2.0 50 CJ

Serif fonts

Adelle 0.4 10 2.0 50 CJ

Algerian 0.3 8 1.2 30 CJ

Bodoni 0.3 7 2.0 50 CJ

Casual Serif 0.5 12 2.2 55 CJ

Centurion 0.5 12 2.4 60 CJ

Cheltenham 
Tall 0.3 7 2.0 50 CJ

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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City Medium 0.25 6 3.0 75 CJ

Civic 0.3 8 2.0 50 CJ

College 0.25 6 1.4 35 CJ

Copperplate 0.25 6 1.6 40 CJ

Dauphin 0.3 8 2.4 60 CJ

Flares

o

0.3 7 1.6 40 CJ

Garamond 0.3 7 2.0 50 CJ

Krone 0.3 8 1.6 40 CJ

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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Matrix 0.4 10 1.6 40 CJ

Museo 0.4 10 1.2 30 CJ

Scope ^ 0.4 10 1.6 40 CJ

Schoolbook 0.3 8 2.0 50 CJ

Seagull 0.3 7 1.8 45 CJ

Serif1 0.25 6 1.2 30 CJ

Serif2 0.3 8 1.2 30 CJ

Serif3 0.25 6 2.4 60 CJ

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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Serif4 0.4 10 2.0 50 CJ

Souvenir 0.25 6 1.6 40 CJ

Times Roman 0.25 6 1.6 40 CJ

Typewriter 0.5 12 2.0 50 CJ

Small fonts

Helvetica Small 0.2 5 0.3 7 CJ

Micro Block 0.2 5 0.3 8 CJ

Minature Block 0.2 5 0.25 6 CJ

Sm Cooper 2.4 6 2.0 50 CJ

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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Sm HighTower 0.2 5 0.25 6 CJ

Sm Script 0.2 5 0.25 6 CJ

Small Block1 0.2 5 0.25 6 CJ

Small Block2 0.2 5 0.25 6 CJ

Small Serif 1 0.2 5 0.25 6 CJ

Times Small 0.2 5 0.25 6 CJ

Special fonts

Antique Rose ^ 1.2 30 4.0 100 AD

Crests - - - - AD

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4
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Flair Script 0.75 10 3.2 80 CJ

Tusj

[

0.8 20 4.0 100 AD

Two-color fonts

2 Col Arial 
Shadow 0.6 15 2.0 50 AD

2 Col Plain 
Script 0.5 12 2.0 50 AD

Border Block 2 0.5 12 1.6 40 AD

Dextor 0.5 12 2.0 50 AD

English Village ^ 0.6 15 4.0 100 AD

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4



Chapter 43   Standard Fonts 1064

Non-Roman fonts

Futura 
Border 2 C 0.65 16 2.0 50 AD

Shadow Street ^ 0.6 15 4.0 100 AD

Font Sample
Recommended sizes Join 

methodMin Max

in. mm in. mm

^ New to ES e4

Font Sample
 Recommended sizes Join 

methodMin Max

in. mm in. mm

Cyrillic fonts

Greek 0.3 8 2.0 50 CJ

Greek Script 0.48 12 4.0 100 CJ

Greek 
Spionic 0.4 10 2.4 60 CJ

Jikharev 0.4 10 1.8 45 CJ
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Russian 
Textbook 0.3 8 1.8 45 CJ

Hebrew fonts

Hebrew 
Chaya 0.3 8 1.6 40 CJ

Japanese fonts

Japanese 
Kaisho 0.32 8 2.7 70 CJ

Heisei Gosic

[

0.4 10 2.7 70 CJ

Heisei 
Gyosho 0.32 8 2.7 70 CJ

Heisei 
Kaisho 0.32 8 2.7 70 CJ

Heisei 
Kantei 0.4 10 2.7 70 CJ

Heisei Maru 
Gosic 0.4 10 2.7 70 CJ

Font Sample
 Recommended sizes Join 

methodMin Max

in. mm in. mm
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Note: Japanese fonts (3000 characters each) are available for download 
from www.wilcom.com for customers who wish to use them.

Heisei 
Mincho 0.4 10 2.7 70 CJ

Font Sample
 Recommended sizes Join 

methodMin Max

in. mm in. mm

https://help.wilcom.com/hc/en-us/articles/360000523096-Japanese-Font-Pack
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Chapter 44

Custom Fonts

EmbroideryStudio provides options for creating custom embroidery 
fonts. You can create entire embroidery fonts from converted TrueType 
fonts. You can digitize letters from backdrop images, convert vector 
objects, or digitize freehand using any of the input methods. You can use 
artwork from sources such as calligraphy books or TrueType fonts.

In this section we show how to convert and modify TrueType fonts. We 
digitize embroidery lettering from scratch for inclusion as a custom font. 
We adapt an existing font to a decorative, multicolor font. We also take 
a script font and turn it into a custom embroidery font.
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Tip: Source files and sample custom fonts used in this section are 
included in the Projects > Custom Fonts folder.

Font considerations

You can use artwork to create font letters in the same way as you do 
other objects. Before digitizing, however, establish whether the letter 
shapes are suitable for embroidery, and determine reference height and 
baseline for the font.

Letter shapes
For best results, letter columns should be of similar width, without tight 
curves or sharp corners, or very fine, very wide, or curved serifs.

Corners too sharp

Differences in column
width too great

Serifs too long and fine
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Reference height and baseline
Reference height is the maximum height of capital letters. Although there 
may be subtle differences between upper and lower case letters, it is a 
useful guide for digitizing.

Place letters along a standard baseline to help digitize at a standard 
height. Draw in the baseline if you are digitizing from artwork, or use a 
grid line as your guide. Descenders in letters such as y or g generally fall 
below the baseline.

Tip: Use E or H as reference letters to determine the height and baseline 
for the font. These letters work well because they sit on the baseline and 
do not extend above the standard cap-height.

Letter spacing and width
Letter width varies with letter shape and spacing. When you digitize 
letters, you enter two reference points to mark the width.

Default spacing affects ‘kerning’ or spacing across all letters. This is set 
when packing the font. It is not advisable to add spacing around 
individual letters when digitizing reference points.

Tip: Certain digitizing rules apply when creating script fonts, mainly to 
ensure that the tail of each letter joins seamlessly with the next letter.

Letter sequencing
Letter stitching sequence is based on the join type used when saving the 
font. If you use Closest Join or Bottom Join, EmbroideryStudio applies 
automatic branching. This determines where each stroke starts and ends, 
adding travel runs as necessary. 

Letter height

Baseline

Letter width

Letter width
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However, it is good practice to digitize strokes in the direction they are 
most likely to be stitched in. It is also important to specify the stroke 
order as this is maintained when sequencing is calculated.
If you want to specify the stitching sequence and connectors yourself, 
digitize the letter exactly as you want it stitched. You then need to select 
As Digitized as the font join method.

Converting & editing TrueType fonts

The simplest option for creating custom embroidery fonts is to use the 
built-in Convert TrueType Font feature. This lets you convert any 
TrueType font installed on your system to an embroidery font. 

The process is fully automatic. Lettering shapes are ‘cut’ into Column A 
or Column B embroidery objects. Overlaps and stroke order are detected 
and stitch angles defined. The result is similar to manually digitized fonts 
although the quality may not be quite as good. The quality greatly 
depends on the original shapes, narrower serif type fonts producing 
better results than blocked fonts.

Experiment with conversion settings

The process of converting TrueType fonts to embroidery begins by 
converting individual letters ‘on-the-fly’ and experimenting with 
conversion settings.

Use Toolbox > Lettering to add TrueType lettering directly on-screen. 
Right-click to set the formatting values for new or selected lettering objects.
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To convert TrueType letters on-the-fly
1 Right-click the Lettering icon to access object properties.

2 Select a TrueType font from the droplist.
3 Enter some sample text which mixes capitals and lower-case letters, 

with and without extenders.
4 Click TTF Conversion to access conversion settings.

Select TT font

Set conversion
values

Enter text

Select Complex Fill
for fixed stitch angle

Select Turning
Strokes for turning

stitch angles

Select lettering style
– regular, bold, etc
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5 First of all, select a lettering style, if available, from the Style list – 
e.g. Regular, Bold, Italic. The entire embroidery font will be created in 
the selected style. This option may not be available for all fonts.

6 Specify whether to convert as Turning Strokes or Complex Fill.
This will depend in part on font type – whether serif or non-serif, 
whether script or block. If you want stitching to follow letter contours, 
select Turning Strokes. The Complex Fill option provides a single 
fixed stitch angle.

7 If in doubt, experiment with both settings. Create a sample of each – 
fixed and turning. Because lettering is converted on-the-fly, you can 
select the generated lettering and further adjust settings.

Regular

Bold

Italic

Turning strokes Fixed angle

Adjust Complex Fill
stitch angle for
preferred result
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8 With the Complex Fill option, try adjusting stitch angle and 
regenerating the sample until you find the optimum angle.

9 With the Turning Strokes option, there are many more settings. 
Presets are automatically adjusted according to selected font 
characteristics – e.g. whether serif or sans serif, whether block or 
script. Try the defaults to start with.

10 Zoom in to study the stitching and object formation. Decide which 
style to use – turning or complex fill. If unsatisfied with generated 
Turning Strokes, experiment further with the settings. See below.

Related topics...
 Creating lettering with CorelDRAW Graphics
 Refine turning stroke options

Refine turning stroke options

With Turning Strokes, preset values are automatically adjusted 
according to selected font characteristics – e.g. whether serif or sans 

Return to
suggested values



Chapter 44   Custom Fonts 1074

serif, whether block or script. If unsatisfied with the presets, experiment 
further with the below settings. 

Tip: Click Suggest Values if you need to return to suggested settings at 
any time.

Match ends
Select the Match Ends checkbox to keep stitch angles parallel to the end 
of the stroke. This option will override any corner detection and corner 
fraction where parallel stitching applies.

Stitch angles in strokes should normally be perpendicular to the stroke, 
but the exceptions are letters like K, X, Y with short slanted strokes. In 
these cases it is better to keep the stitch angle parallel to the end of the 
stroke.

Optimize conversion
settings for Turning

Strokes

Return to
suggested values

Match Ends ON – 
stitches parallel to 
baseline

Match Ends OFF 
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Separate serifs
Select the Separate Serifs checkbox if you are converting a serif font.

As the serifs are made into separate strokes, this option is better used 
with larger lettering where serifs are greater than 0.8 mm in breadth.

Break angle
Select the Break Angle checkbox to apply a cap to sharp angles. This 
effect is similar to Smart Corners – if the stroke bends sharply, like the 
letter A or V, it will be split or capped.

Corner detection
Fine-tune processing of corners with these settings:
 Corner Detection Angle specifies the angle which will identify a 

corner in the letter. This is more important for getting well-defined 
small letters. Note, however, that EmbroideryStudio automatically 
inserts stitch angles where needed in order to obtain smooth turning 
stitches. These generally occur at locations where the shape changes 
significantly in direction or width.

Separate 
serifs ON

Separate 
serifs OFF

Break angle 
87º

Break angle OFF – 
no split
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 Corner Fraction specifies fractional spacing at corners. It is used to 
create smooth transitions of stitch angle at corners, shape ends, or 
where a shape changes in width or curvature significantly.

Create overlaps
Select the Create Overlaps checkbox to prevent gaps forming between 
segments. You can fine-tune the overlaps by setting values in the ‘T’ 
junctions and ‘O’ junctions fields.

Convert entire TrueType font

Once you have arrived at conversion settings that suit your chosen 
TrueType font, go ahead and convert the entire font. Custom fonts are 
saved in ESA format to the ‘Fonts’ folder within the Windows 
‘ProgramData’ folder. Conversion happens quickly although Asian fonts 
may take longer. They can be copied and distributed for use by others.

Corner detection angle 150º
Corner fraction 0.6 mm

Corner detection angle 30º
Corner fraction 1.0 mm

Create 
overlaps OFF

Create 
overlaps ON
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To convert a TrueType font
1 Select Setup > Convert TrueType Font. The Convert TrueType 

Font dialog opens.

2 Select the font to be converted together with a font style – e.g. 
Regular, Bold, Italic. The entire embroidery font will be created in the 
selected style.

3 Enter a Font Name if you want to override the default.
4 Choose whether to convert All Characters or Extended ASCII 

character sets. The standard character set contains alphanumeric 
characters only. It excludes punctuation marks and other special 
characters.

Select font
Select font 
style

Set values

Enter font
name

Choose 
character set
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5 Click Conversion Settings. As always, these can be further refined.

6 Adjust settings according to your experiments with on-the-fly font 
conversion.

7 Click OK. A confirmation will appear when the process is complete.

8 To check, right-click the Lettering icon to open the Object 
Properties > Special > Lettering docker. The newly converted font 
will be selected by default and available for use.

Select Complex Fill
for fixed stitch angle

Select Turning
Strokes for turning

stitch angles

Optimize conversion
settings for Turning

Strokes

Test converted
TT font
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Related topics...
 Create lettering with object properties
 Custom asset locations

Edit & repackage generated letters

The process of TrueType font conversion is fully automatic. Lettering 
shapes are ‘cut’ into Column A or Column B objects. Overlaps and stroke 
order are detected and stitch angles defined. If you find that some shapes 
can be improved, you have the option of editing and repackaging 
individually.

To edit & repackage generated letters
1 First set up a grid and save the file for future reference. Whenever you 

need to fix or edit characters, the grid helps with reference.
Set up grid spacing in the Options dialog via Setup > Options > 
Grid & Guides. Turn on Snap to Guides. Set vertical spacing to 
10mm and horizontal spacing to 0.50 mm.

Use Edit > Break Apart to split composite objects – monograms, appliqués, 
lettering, etc – into component objects.

Use Reshape > Reshape Object to reshape selected objects by means of 
control points.

Use Edit > Knife to cut objects along a digitized line, preserving stitch 
settings and colors in resulting objects.

Use Arrange > Apply Closest Join to (re-)apply closest join to objects after 
editing.

Select to
display grid

Select to snap
design points

to grid

Enter grid
spacings
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2 Generate a sample and study the letters. The complete font set 
depends on whether you have chosen to convert All Characters or 
Extended ASCII. The standard character set contains alphanumeric 
characters only.

Tip: You only need to generate those characters that you want to edit 
and repackage. You can do this over time.

3 Note the lettering height. Normally this will default to 10mm but set it 
to whatever height you prefer to work with.

4 Before you start editing, turn off underlay. When you repackage, 
characters should be without underlay.

Sample letters 
to modify

Lettering height

Turn off lettering underlay
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5 Break apart the font, line-by-line and letter-by-letter, until you arrive 
at the component objects.

6 Zoom in to edit letter shapes with the Reshape Object and Knife 
tools.
 Typically you will want to add or remove control points, adjust 

overlaps, and resequence component objects.

Break apart letters into
component objects

Reshape and/or 
resequence as 
needed
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 Optionally, you may use the Knife tool to cut objects into smaller 
overlapping strokes for better stitchability.

7 When you have edited the letter to your satisfaction, select all 
component objects and apply closest join. 

8 Repackage the edited letter to the converted embroidery font. Select 
letter components and save using the Object > Create Letter 
command. 

Cut objects into 
overlapping strokes

Apply closest join to 
component objects

Select font

Enter letter name

Enter reference
height

Latin Wide

L
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9 In the dialog, specify...

10 Click OK. The following warning will appear...

11 Click Yes to proceed and enter a reference line as prompted.

12 Add any other modified letters to your converted TrueType font in the 
same way.

Field Action

Font name Select the converted font from the droplist.

Letter name This should be the actual character – e.g. ‘L’.

Reference height This needs to be the height of the sample letter – e.g. 
10mm.

Click twice to enter 
reference line
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13 Test your updated font via Object Properties > Lettering. Note that 
changes are preserved and underlay automatically added to the 
repackaged characters. Test at different font heights.

Related topics...
 Breaking apart lettering
 Splitting objects
 Reshape letters
 Apply closest join
 Create custom letters
 Save custom letters
 Save custom fonts
 Manage fonts

Digitizing custom fonts

You digitize letters for a custom font just like other embroidery objects. 
Custom letters can be made up of multiple objects, and may be letters, 
numbers, symbols or even pictures. We will be creating a font for a 
nominal height of 20 mm. 

Create text

Choose your
font
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Set fabric, background & machine format

Open EmbroideryStudio from the desktop icon or Windows Start menu. 
From the Home screen, click New from Template. Otherwise, select 
File > New from Template or, holding down the Shift key, click New. 
Since we are stitching out on a polo shirt, choose ‘Pure Cotton’ (the 
default). Select a suitable machine format – e.g. Tajima – and click OK.

Set up grid & guides

First we need to set up a grid to assist when digitizing embroidery letters. 
Guidelines also help when setting reference points. Set up grid spacing 
in the Options dialog via Setup > Options > Grid & Guides. Turn on 
Snap to Guides. Set vertical spacing to 10mm and horizontal spacing to 

Use Standard > New to start a blank design based on the currently selected 
template. Hold down Shift and click to open New from Template dialog.

Click View > Show Product to toggle product image on/off. Right-click to 
open the Product Visualizer docker.

Activate auto fabrics 
and choose a target 
fabric

Choose a target 
machine format
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0.50 mm. The narrow horizontal spacing helps to digitize more accurate 
reference points. 

Tip: If you are planning to do more custom font digitizing, it may be 
worth setting up a template dedicated to the task. 

Related topics...
 Grid display options
 Working with templates

Import & size the backdrop

Click the Import Graphic icon or select File > Import Graphic and 
navigate to Projects > Custom Fonts within the installed 
C:\UsersPublic\Public Embroidery\EmbroideryStudio e4 folder. If 
necessary, select BMP from the Files of Type list. Select ‘Sample 

Click to save 
for current 
template

Select to
display grid

Select to snap
design points

to grid

Enter grid
spacings

Use Standard > Import Graphic to import vector graphic or bitmap image 
into current design
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Font.bmp’ and click Open. Save the design to your local hard drive as an 
EMB file. 

Use the grid to size the backdrop. Remember, we are creating a font for 
a nominal height of 20 mm. Use E as a reference letter to determine the 
height of the font. 

Related topics...
 Insert bitmap images
 Scaling objects

Digitize the letters

Choose sample
font

Use letter E as a 
reference letter 
when scaling

Set ruler zero point 
on baseline

Use Traditional Digitizing > Column A to create columns of varying width 
and stitch angle. Right-click for settings.

Use Fill Stitch Types > Satin to apply satin stitch to new or selected narrow 
columns and shapes. Right-click for settings.
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In this project we are going to create sample letters using uppercase A, 
B, C and lowercase a, b and c. Start digitizing letters using Column A 
with Satin stitch. Make sure you create sufficient underlap to bind letter 
strokes together. No underlay or pull compensation is required. This is 
added when you create actual lettering with the custom font. Make sure 
you strokes are digitized in the sequence they will be stitched out. 
Generally, you don’t need to worry about connections between strokes. 
This is automatically handled when packing the font. 

Tip: Use Vector tools to draw guidelines for more accurate digitizing. 

Related topics...
 Creating custom fonts

Save custom font & letters

When you save a new letter, you need to create a font for it, give it a 
name, specify its height, and indicate whether to preserve any machine 

Use Outline Stitch Types > Satin to create thicker borders or columns of 
even thickness. Right-click for settings.

Underlap 

Stitch first

Draw guides with 
drawing tools
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functions. You also need to set letter width by marking reference points 
on-screen.

Create font
Select a letter and choose Object > Create Letter. Since this is the first 
letter to be saved, create and name a custom font. Click Create in the 
Create Letter dialog to access the Create Font dialog. Enter a font 
name – e.g. ‘My Font’. Set default letter spacing – e.g. 10% – and select 
Closest Join as the default join type. 

Save custom letter
Back in the Create Letter dialog, enter a name for the letter – e.g. ‘A’. 
Set the Reference Height to, say, 20mm. Digitize reference points. 
Imagine there is a box around the letter marking the extents. Reference 
points are where the box and the baseline meet. 

Enter name

Set 10%

Choose 
Closest Join

My Font

10

Closest Join

Click Create

Select font

Enter letter name

Enter reference 
height

Digitize second 
reference point

Baseline

Digitize first
reference point

Letter extents

My Font

A
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Add more letters to your custom font in the same way.

Related topics...
 Create custom letters
 Save custom letters
 Save custom fonts
 Manage fonts

Test the font

Once you have finished packing it, test your custom font by creating 
embroidery lettering via Object Properties > Lettering. Choose your 
custom font from the dropdown menu.

Tip: Compare your design with the sample ‘My Font.EMB’ included in the 
Projects > Custom Fonts folder.

Related topics...
 Create lettering with object properties

Creating multicolor fonts

Lettering objects normally consist of one stitch type and one color only. 
However, the As Digitized join method can be used to create special 
fonts with multiple colors or special effects. We will now use this method 

Use Toolbox > Lettering to add lettering directly on screen.

Create text

My Font

abcABC

Choose your 
font

Lettering
object
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to create a variation of our custom font by adding an embellishment to 
each letter.

Import the embroidery ornament

Import the embroidery ornament using the File > Import Embroidery 
command. Navigate to Projects > Custom Fonts folder. If necessary, 
select EMB from the Files of Type list. Select ‘Leaf.Emb’.

Edit the font

Duplicate the leaf and resize in the Property Bar. Making sure the aspect 
ratio is locked, adjust heights as necessary – in this case, 15mm for 
uppercase ornaments and 10mm for lowercase. Choose the colors you 
want to use for leaf and letters – e.g. moon green and powder blue. Place 

Select 
embroidery 
ornament



Chapter 44   Custom Fonts 1092

the ornament as shown. Duplicate by right-clicking and dragging to the 
next letter. Remove overlaps as required. 

Related topics...
 Reshaping embroidery objects

Save custom font & letters

Select all components of the custom letter and save using the Object > 
Create Letter command. Create a new font for your multicolor custom 
font – e.g. ‘My Special Font’. This time choose As Digitized as the default 
join type. Enter letter name and reference height as before, and untick 

Aspect ratio lockedAdjust height 

Place leaf in 
the middle

Remove overlaps 
as required
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the Remove Functions checkbox. We want to preserve the color 
changes.

Related topics...
 Create custom letters
 Save custom letters
 Save custom fonts
 Manage fonts

Test the font

Again test your custom font via Object Properties > Lettering. Choose 
your custom font from the dropdown menu.

Enter name

Set 10%

Choose ‘As Digitized’

My Special Font

10

As Digitized

Select font

Enter letter name

Enter reference 
height

Untick ‘Remove 
Functions’

My Special Font

Use Toolbox > Lettering to add lettering directly on screen.

Create text

My Special Font

AaBbCc

Choose your
font
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Notice that the lettering object preserves the ‘as digitized’ color changes 
within each letter. Use the Break Apart command to resequence 
like-color objects in the Color-Object List so they stitch out together.

Tip: Compare your design with the sample ‘My Special Font.EMB’ 
included in the Projects > Custom Fonts folder.

Related topics...
 Create lettering with object properties

Digitizing script fonts

Now we are going to make a script font. Certain digitizing rules apply 
when creating script fonts, mainly to ensure that the tail of each letter 
joins seamlessly with the next letter.

Set fabric, background & machine format

Like-color objects 
stitch out together

Use Standard > New to start a blank design based on the currently selected 
template. Hold down Shift and click to open New from Template dialog.

Click View > Show Product to toggle product image on/off. Right-click to 
open the Product Visualizer docker.
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Open EmbroideryStudio from the desktop icon or Windows Start menu. 
From the Home screen, click New from Template. Otherwise, select 
File > New from Template or, holding down the Shift key, click New. 
Since we are stitching out on a polo shirt, choose ‘Pure Cotton’ (the 
default). Select a suitable machine format – e.g. Tajima – and click OK.

Import & size the backdrop

Click the Import Graphic icon or select File > Import Graphic and 
navigate to Projects > Custom Fonts within the installed 
C:\UsersPublic\Public Embroidery\EmbroideryStudio e4 folder. Open the 
‘Sample Script.bmp’ and set up the grid. Check the backdrop height. It 

Activate auto fabrics 
and choose a target 
fabric

Choose a target 
machine format

Use Standard > Import Graphic to import vector graphic or bitmap image 
into current design
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should be 25mm which is the font size we are going to make. Save the 
design as an EMB file.

Digitize the letters

Digitize letters as you did the custom font. For script fonts, the tail of each 
letter has to coincide with the initial stroke of the next in order to create 
a seamless join. Drag a guideline into position to mark the ‘join line’.

Choose
sample font

Use Traditional Digitizing > Column A to create columns of varying width 
and stitch angle. Right-click for settings.

Use Fill Stitch Types > Satin to apply satin stitch to new or selected narrow 
columns and shapes. Right-click for settings.

Use Outline Stitch Types > Satin to create thicker borders or columns of 
even thickness. Right-click for settings.

Join line
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Drag a guideline to intersect the join line on the inside edge of the stroke. 
Turn on ‘Snap to Guides’ in the Options > Grids & Guides tab. Make 
sure reference points of adjacent letters coincide with this point.

The join edge should be approximately perpendicular to the slope. No 
need for overlap on narrow strokes as pull compensation will provide 
sufficient overlap.

Don’t worry about connecting stitches between objects. 
EmbroideryStudio automatically handles this when you save with the 
Closest Join method.

Stroke thickness 
guidelines

Join line

Guideline intersects 
inside edge

Join edge perpendicular 
to slope
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Save custom font & letters

To define reference points for italic fonts, draw a slope angle guideline 
and clone it to mark letter extents as shown. The guideline for the 
reference points always intersects the inside edge of the join as shown.

As before, select a letter and apply the Create Letter command. Create 
and name your script font. Set default spacing to 0% and select Closest 
Join as the default join type. Enter the letter name and set reference 
height to 25 mm. As always, digitize reference points.

Related topics...
 Create custom letters
 Save custom letters
 Save custom fonts
 Manage fonts

Slope angle 
guidelines

Reference points

Digitized reference points coincide 
at intersection of join line and 
inside edge of stroke

Enter name

Set 0%

Choose ‘Closest Join’

My Script Font

0

Closest Join

Select font My Script Font

A

Enter reference
height

Enter letter name
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Test the font

Again, once you have finished packing the letters, test them by creating 
some lettering via Object Properties > Lettering. Choose your script 
font from the dropdown menu. 

Tip: Compare your design with the sample ‘My Script Font.EMB’ included 
in the Projects > Custom Fonts folder.

Related topics...
 Create lettering with object properties

Use Toolbox > Lettering to add lettering directly on screen.

Create text

My Script Font

AaBbCc

Choose your
font
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Chapter 45

Machine, File & Disk Types

This section provides details of the file and disk types supported by 
EmbroideryStudio. Details are also provided about the conversion of 
Melco CND, Wilcom INP, and Gunold PCH design formats to and from 
EMB. The section also provides details of vector and bitmap (raster) 
formats.
In conjunction with CorelDRAW® Graphics Suite, EmbroideryStudio 
reads and writes a wide variety of related and sometimes complementary 
decoration processes or techniques. See also Exporting multiple 
decoration files.

Note: There are many additional Schiffli file formats to suit specific 
Schiffli machines. EmbroideryStudio supports the most important of 
these. See the ES Schiffli User Manual Supplement for details.

Supported machine types

The table shows the machine types supported by EmbroideryStudio. 
Make sure you first check the recommended connection settings for your 
particular machine. If you don’t have a record of the connection settings 
required to set up your embroidery machine, a list can be found at the 
Wilcom Support Center. This provides connection information for all the 
machines listed in this table. See Hardware Settings for details.

Machine format Description Machine files

Tajima

Tajima Use this format for main types of Tajima machines. DST, EMX, T01, TAP

Tajima TBF Use this format for Tajima needle addressing capable 
machines. TBF (Tajima Binary Format) file format is a 
more intelligent machine format which holds needle 
addressing information. The design needs to be 
digitized using this machine format for it to run on 
Tajima machines with a twin-sequin attachment.

TBF

Tajima TMCE-100 Use this format for Chenille-enabled Tajima 
machines.

DST, T01
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Tajima TMCE-600 Use this format for Chenille-enabled Tajima 
machines.

DST, T01

Barudan

Barudan Use this format for many Barudan machines. It 
supports up to 9 needles. The Barudan format is 
suitable for paper tape, FMC disks, and the DSB file 
format.

DSB, T03, TAP, U??, 
XXX

Barudan Chenille Use this format for the older BELM - A3C series of 
Barudan Chenille Machines with 5 Chenille colors. 
Newer models use Barudan FDR-II Chenille 
Combination.

DSB, T03, U??

Barudan Z Series Use this format for Barudan Z series machines with 
10 or more needles.

DSB, T03, U??

Barudan FDR-II 
Lockstitch

Use this format for BED* series lockstitch machines 
and is the standard for all new Barudan lockstitch 
machine models. It supports up to 15 needles and 
optional sequin attachments.

U??

Barudan FDR-II 
Chenille Combination

This format is used for newer models of Barudan 
Chenille machines supporting 6 chenille colors such 
as the BEDYH and BEDSH. Using this format, you 
can digitize pure Chenille or even a combination of 
Chenille and Lockstitch in the one design.

U??

Barudan FDR-II Twin 
Sequin

This is a Barudan twin sequin machine. The design 
needs to be digitized using this machine format for it 
to run on Barudan machine with a twin-sequin 
attachment.

U??

Barudan FDR-II Twin 
Sequin Chenille 
Combination

This is a Barudan twin sequin and Chenille 
combination machine. The design needs to be 
digitized using this machine format for it to run on 
Barudan machine with a twin-sequin and chenille 
attachment.

U??

Barudan FDR-3 The FDR-3 file supports correct color thread display 
in its thumbnail in both Design Library and on the 
Barudan machine to help eliminate costly production 
errors resulting from incorrect colors. Save actual 
thread color info in your machine files and view 
correct color and thread codes (.U03) instead of 
default software colors.

U??

Barudan FDR-3 
Chenille Combination

Use this format for newer models of Barudan Chenille 
machines supporting embroidery on flat items, 
embroidery on thick fabric, loop and chain stitches, 
add-on sequin devices, etc.

U??

Melco

Machine format Description Machine files
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Melco Use this format for main types of Melco machines. ARX, CSD, DSN, DST, 
EMD, STX

Melco Chenille Use this format for Melco-enabled Chenille 
machines.

STX

SWF

SWF Use this format for main types of SWF machines. DST

SWF Twin Sequin DST, EBD

ZSK

ZSK 1 Use this format for ZSK machines that have 7 or 
fewer needles – generally those older than 1991.

DSZ, T05, TAP

ZSK 2 Use this format for ZSK machines that have more 
than 7 needles and those characterized by a 
single-top thread trimmer.

DSZ, T05, TAP

ZSK TC Use this format for ZSK machines that accept 
Transport Code Disks (DOS format disks).

Z??

Other

BERNINA Use this format for all BERNINA machines. CSD, DST, ARX, EMD, 
EXP, GNC, HUS, JEF, 
PCD, PCM, PCQ, 
PCS, PEC, PES, SEW, 
SHV, VIP, VIP3, XXX

Brother / Babylock PEC, PES

Dahao DST, DHA, DHB, DHP, 

Happy TAP

Inbro Use this format for main types of Inbro machines. INB

Janome Use this format for all Janome machines. CSD, DST, EMD, EMX, 
EXP, HUS, JEF, JEF+, 
JXP, PCD, PCM, PCQ, 
PCS, PEC, PES, SEW, 
VIP, VIP3, XXX

Melco Use this format for all Melco machines. ARX, BRO, CND, 
CSD, EMX, EXP, GNC, 
HUS, JEF, PCD, PCM, 
PCQ, PCS, PEC, PES, 
PMU, PUM, SEW, 
STX, VIP, VIP3, XXX

Melco Chenille EXP, STX

Pfaff Use this format for main types of Pfaff machines. KSM, T09

Pocket DPS

Machine format Description Machine files
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Note: If not already a member of the WSC, you will need to register as 
a licensed user of Wilcom software. See www.wilcom.com/support for 
details.

Graphics and multi-decoration file formats

Artwork can be imported into EmbroideryStudio in both vector and 
bitmap (raster) formats. See Digitizing with Bitmaps for details.

Supported vector file formats
EmbroideryStudio supports the following vector graphic formats:

Schiffli Use this format for Schiffli machines. DAT, DHT, ESL, ESS, 
MUD, MST, PAT, SAS, 
T11, T12, T13, T18, 
T20, T22, VDT, VEP

Toyota Use this format for main types of Toyota machines. 10O

Zangs Use this format for Zangs and Marco brand machines 
and pre-1988 ZSK machines without trimmers.

DSZ, T04, TAP

Machine format Description Machine files

Extension Format Read Write

AI Adobe Illustrator  

CDR CorelDRAW  

CDT CorelDRAW Template  

CGM Computer Graphics Metafile  

CLK Corel R.A.V.E.  

CMX Corel Presentation Exchange 5.0  

CSL Corel Symbol Library  

DES Corel Designer  

DWG AutoCAD  

DXF AutoCAD  

EMF Enhanced Metafile  

EPS Encapsulated Postscript  

FMV Frame Vector Metafile  

PLT HPGL Plotter File  

PS Postscript 

SVG Scalable Vector Graphics  

http://www.wilcom.com/support
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Supported bitmap file formats
EmbroideryStudio supports the following bitmap image formats:

Note: For a full description of image file formats supported by 
CorelDRAW® Graphics Suite, refer to the CorelDRAW® Graphics Suite 
electronic User Guide available via the MS Windows® Start > Programs 
group. Alternatively, use the online help available from the Help menu. 
See Digitizing with Bitmaps for details.

Embroidery file formats

There are two types of embroidery file format:

WMF Windows Metafile  

Extension Format Read Write

BMP Windows Bitmap  

GEM GEM file  

JPEG JPEG Group  

JPG JPEG File Interchange  

PAT Pattern File  

PCT Macintosh PICT  

PCX PC Paintbrush  

PNG Portable Network Graphics  

SVGZ Compressed SVG  

TIFF Tagged Image Format  

WMF Windows Metafile  

WPG Corel WordPerfect Graphic  

Extension Format Read Write

File type Description

Design Design files usually contain digitized shapes and lines, selected 
stitch types and stitch values and effects.

Machine Machine files generally contain stitches and machine functions and 
are only suited to specific embroidery machines.
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Wilcom file formats

EmbroideryStudio uses its own native EMB embroidery file format which 
combines the advantages of design files and machine files. Outlines, 
stitches, thread colors, and other data are stored together. Outlines mean 
the file can be scaled and manipulated on an object basis while the stitch 
data preserves manual stitch-by-stitch edits and touchups. Features of 
most third-party formats are supported. Variants and precursors of the 
EMB file format are also shown in the table below.

Tips for use...
 ^ Can only be written by ES Cross Stitch application. 
 † ESD is the native file format of DOS ES, the precursor to the current 

EmbroideryStudio. It is actually a machine file format with stitch 
blocks, stitch types and parameters, and an icon. It has few of the 
advantages of the current EMB file format.

 ‡ Wilcom INP is the native file format of Wilcom Computer Embroidery 
Design software. It is a design file format but it contains no stitch data. 
Wilcom INP designs can be directly converted to EMB files although 
EmbroideryStudio interprets some of the stitch types differently. See 
Wilcom INP format for details.

Extension Format Read Write

EMB EmbroideryStudio design file (up to & including 
ES e4.5)

 

EMC Clipart files  

EMX ^ Wilcom Cross Stitch 

ESD † Wilcom DOS format 

ESL Wilcom ESL  

ESS Wilcom ESS (Schiffli)  

INP ‡ Wilcom condensed format 

Legacy formats *

T01 Tajima (Wilcom DST format)  

T03 Barudan (Wilcom DSB format)  

T04 Zangs  

T05 ZSK (Wilcom DSZ format)  

T09 Pfaff (Wilcom KSM format)  

T10 Wilcom Plauen  

T15 Wilcom Saurer  
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 * T0? formats contain stitch data that can be used to create paper 
tapes. This is the purpose for which they were originally created.

Supported design file formats

EmbroideryStudio supports the following design file (condensed) 
formats:

Note: See below for conversion details when reading these files into EMB 
format or writing to CND format. See Melco CND format and Gunold PCH 
format.

Design template formats
EmbroideryStudio supports the following design template formats:

Supported machine file formats

EmbroideryStudio supports the following machine file (expanded) 
formats:

Extension Format Read Write

ART artista V4.0 design files 

ART42 Explorations project file 

ART?0 BERNINA Embroidery Software file 

CND Melco condensed file  

GNC Great Notions 

JAN Janome Embroidery Software file 

PCH Gunold APS design format 

Extension Format Read Write

EMT Wilcom ES templates  

AMT artista V4.0 template 

AMT42 Explorations template 

JMT Janome Embroidery Software template 

Extension Format Read Write

10O Toyota  

† includes needle addressing data ¥ Two options – ZSK1 and ZSK2 (see note) § TAP and MON 
files are written together – TAP is the machine file, MON the header file.£ Used with Transport Code 
Disks (see note)
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ARX artista (cross stitch) 

BRO Bits & Volts 

CSD Singer / Poem / Huskygram  

DAT Hiraoka DAT  

DSB † Barudan (Tajima machine format)  

DSN Nova 

DST Tajima  

DSZ ¥ ZSK (Tajima machine format)  

EBD SWF  

EMD Elna  

EXP Melco / BERNINA USB Stick  

HUS Husqvarna / Viking / Pfaff  

INB Inbro  

JEF Janome / Elna / Kenmore  

JPX Janome / Elna (cross stitch)  

KSM Pfaff  

MJD Time & Space  

MST Laesser  

PCD Pfaff  

PCM Pfaff  

PCQ Pfaff  

PCS Pfaff  

PEC Brother / Babylock / Deco  

PES Brother / Babylock / Deco  

PMU Proel, ProWin (Proel TSI) 

PUM Proel, ProFlex (Proel TSI) 

SAS Saurer SLC  

SEW Janome / Elna / Kenmore  

SHV Husqvarna / Viking / Pfaff  

STC Gunold APS 

STX Datastitch 

TAP § Happy  

Extension Format Read Write

† includes needle addressing data ¥ Two options – ZSK1 and ZSK2 (see note) § TAP and MON 
files are written together – TAP is the machine file, MON the header file.£ Used with Transport Code 
Disks (see note)
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Supported bling file formats

EmbroideryStudio supports the following rhinestone file formats:

Note: The YNG file format can be read by EmbroideryStudio and sent 
directly to CAMS machine. See Send bling to CAMS machine for details.

Melco CND format

Melco Condensed (CND) is the native file format of the Melco embroidery 
digitizing software. CND files store only digitized outlines and stitch 
values. See also Reading Melco CND design files.

Conversion of Melco CND format to Wilcom EMB

When you open CND designs in EmbroideryStudio, outlines are scaled 
and stitches recalculated to preserve density. EmbroideryStudio 
recognizes all Melco machine functions and stitch types, including 
Partition Lines and Complex Fill, and automatically converts them to EMB 
format. This table details how Melco features are converted.

TBF Tajima  

U?? † Barudan  

VEP Hiraoka 

VP3 Husqvarna / Viking / Pfaff  

XXX † Singer  

Z?? £ ZSK TC  

Extension Format Read Write

† includes needle addressing data ¥ Two options – ZSK1 and ZSK2 (see note) § TAP and MON 
files are written together – TAP is the machine file, MON the header file.£ Used with Transport Code 
Disks (see note)

Extension Format Read Write

YNG Yongnam GemMaster v2.9  

Melco CND EMB Notes

Stitch Types

Column Stitches Column A, Satin 
stitch
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Simple Fill Complex Fill, 
Tatami

The stitch angle is determined by 
the longest stitchline.

Complex Fill Complex Fill Melco EDS Complex Fill are 
recognized and converted to 
EmbroideryStudio Complex Fill.

Column Fill Column A, Tatami 
fill

Walk Run

Bean Stitch Triple Run

Singleline Column Input, 
Centerline

Column C

Singleline Column Input, 
Left Line / Right Line

Column C Side 1 / 
Side 2

Partition Lines Tatami partition 
lines

Underlays

Complex Underlay Tatami underlay in 
Complex Fill object

Edge Walk Edge Run

Column stitches onlyCenter Walk Center Run

Narrow Column Zigzag

Machine functions

Needle Up Jump, Begin Jump

Reset Stitch End Jump

Manual Lock Stitch Added in Tie Off

Automatic Lock Stitch Tie In, Tie Off If Automatic Lock Stitch is set for 
every Color Change, and at the 
start and end of the design, tie off 
and tie in stitches are inserted in 
the EMB design. 

Chain Chain

Moss Moss

Needle Height Needle Height

Slow Slow

Fast Fast

Borer In/Out Borer In/Out

Sequin On/Off Sequin On/Off

Melco CND EMB Notes
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Conversion of Wilcom EMB format to Melco CND

You can save files to Melco CND format from EmbroideryStudio. Designs 
originally created in EmbroideryStudio generally give the best results. 
Other file types may not have all the data necessary for successful 
conversion. This table details how EmbroideryStudio stitch types and 
effects are converted to CND format. 

Tip: When you convert to CND, many EmbroideryStudio effects will be 
lost. If it is important to preserve the effects, save in Melco EXP machine 
format instead. Alternatively, turn off all effects before saving to CND 
format. See also Best EmbroideryStudio input methods for Melco CND 
output.

EMB Melco CND Notes

Stitch types

Manual Walk

Run Walk

Triple Run Bean Stitch Only if the design is an original 
Wilcom EMB design

Triple Run 
(run count > 3)

Bean Stitch Reverts to Triple Run (run count = 3).

Satin stitch Column Fill

Tatami - standard Fill Stitch Use Complex Fill to make sure that 
the stitch lines are parallel.

Tatami - with random 
factor applied

Walk

Tatami - with sharply 
turning stitches 

Walk or Complex 
Fill

Changes to Walk if Superstar 
compatible, otherwise Complex Fill 
with a fixed angle.

Tatami - with slightly 
turning stitches

Fill Stitch, several 
sections

The shape is divided into several 
sections, filled with parallel Fill Stitch. 
There may be small gaps between 
these sections. 

Zigzag Walk Density is not preserved when the 
design is scaled.

E Stitch (Inputs A, B & 
C)

Column Stitches

E Stitch (Complex Fill) Walk

Stitch settings

Run length Set length CND Walk stitch length is the same as 
EMB Run stitch length.
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Tatami length and 
spacing

Fill or Complex 
Fill settings

The length and density of Fill Stitches 
will be the same as EMB Tatami length 
and spacing.

Underlays

Center Run

Walk Uses CND Auto Underlay.
Edge Run

Zigzag

Double Zigzag

Zigzag (for objects with 
Satin cover only)

Narrow Column

Effects

Accordion Spacing Not preserved The effect is lost.

Motif Fill Not preserved The effect is lost.

Contour Stitch Not preserved The effect is lost.

Flexi Split Not preserved The effect is lost.

Auto Split Not preserved The effect is lost.

Jagged Edge Not preserved The effect is lost.

Trapunto style Not preserved The effect is lost.

Program Split Not preserved The effect is lost.

User Defined Split Not preserved The effect is lost.

Photo Flash Walk Density is not preserved when the 
design is scaled.

Quality features

Pull Compensation Not preserved The original shape is preserved. The 
effect is lost.

Fractional Spacing Not preserved In EmbroideryStudio, turn on 
Fractional Spacing and set it to 
0.5mm. Although there is no direct 
equivalent in CND, effectively it uses a 
fixed fractional spacing with a value 
equal to 0.5.

Stitch Shortening Not preserved Outlines are more accurately 
recognized if Stitch Shortening is 
turned off.

Auto Spacing Not preserved Auto Spacing is converted to fixed 
spacing, based on the average space 
value. It is best to turn off Auto 
Spacing when digitizing a design for 
CND. 

EMB Melco CND Notes
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Best EmbroideryStudio input methods for Melco CND output

This table details which input methods give the best results when 
digitizing a design for Melco EDS-III CND output.

Smart Corners Not preserved Avoid digitizing pointed ends.

Machine functions

Color Change / Stop 
functions

Color Change / 
Stop

Functions inserted on stitches inside 
objects are not converted.

Empty Walk Two MK1 points are repeated at the 
current position.

Jump Needle Up

Needle Up Needle Up

Tie In (Lettering) Walk

Tie Off Walk

End Jump Reset Stitch

Begin Jump Needle Up

Needle Height Needle Height

Moss Moss

Chain Chain

Trim Trim The ability to output without Trim 
function does not apply to this version.

EMB Melco CND Notes

Input method Compatibility Notes

Column A, B, C OK Use with Satin only.

Complex Fill OK Only use with Tatami fill. Do not digitize pointed 
ends as they will be ‘squared off’ during 
conversion. Cut off pointed ends with a straight 
line, parallel to the stitch angle, to avoid 
conversion problems.

Complex 
Turning

Not 
recommended

Complex Turning objects are separated into a 
single object per segment. Conversions may 
produce undesired results.

Circle OK

Ring Not 
recommended

The exit point will be on the wrong side of the 
shape.

Star Not 
recommended

The stitches are output as Walk.
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Gunold PCH format

PCH ‘Punch and Stitch’ is the native file format of the Gunold Embroidery 
Design software. Gunold PCH designs can be directly converted to EMB 
files although EmbroideryStudio interprets some of the stitch types 
differently. This table details how Gunold PCH features are converted to 
EMB format.

End - Keep Last 
Stitch

OK The exit point should always be on the opposite 
side to the entry point.

End - Omit Last 
Stitch

Do not use Start digitizing the next shape on the opposite 
side instead.

Input method Compatibility Notes

Gunold PCH EMB

Outline types

Parallel Column A

Serial Column C

Block Outline Complex Fill

Run Run

Incline Run

Manual Manual

Stitch types

Satin Satin

Ceding Tatami

Random Ceding Tatami with random factor applied

Step Tatami

Piping Contour

OBI Tatami

Zigzag Zigzag

Cross not supported

Photo not supported

Satin underlays

none none

Single Center Run

Edge Edge Run

Zigzag Zigzag
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Wilcom INP format

Wilcom INP is the native file format of Wilcom Computer Embroidery 
Design software. Wilcom INP designs can be directly converted to EMB 
files although EmbroideryStudio interprets some of the stitch types 

Cross Zigzag

Edge Zigzag Edge Run + Zigzag

Edge Cross Edge Run + Zigzag

Netting Double Zigzag

Double Zigzag Double Zigzag

Triple Zigzag Double Zigzag

Step / block fill levels

Complex Fill Holes in Complex Fill

Form Fill User Defined Split in Complex Fill

Vector Fill User Defined Split in Complex Fill

Block Fill Program Split in Complex Fill

Miscellaneous

Branches Grouped object (uses lettering 
sequence algorithm)

Random - side 1 / side 2 Jagged Edge effect

Pitch Stitch Spacing

Length Stitch length

Stitch angle Complex Fill stitch angle

U turn Backtrack

Compensation Pull Compensation

Corner mode Smart Corners

Short / Long Stitch Shortening

Square backstitch
Satin
Step

Straight stitch 
Trapunto

Styles Motifs

Patterns none

Gunold PCH EMB
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differently. This table details how Wilcom INP features are converted to 
EMB format.

Wilcom INP EMB Notes

Auto Spacing Auto Spacing Values are different. Can be changed 
before stitching.

Backtrack/Repeat 
section/marked

Separate objects are 
added.

Functions are supported correctly.

Backup Lock Satin tie off

Borderline Tatami Borderline Tatami

Borer In/Out Borer In/Out

CED Block 
lettering

Block2 font Font can be changed after conversion.

CED Block, Jump 
out

Block2 font Manual edits and trimming

Circle Circle

ES Cross Stitch Paths imported as 
Run objects only

Change the stitch type to Motif Run to 
generate cross stitch.

Delete Stitch Manual only, ignored 
for other stitch types

Can be edited

Family of Curves 
Split

Satin, single curve as 
split line 

Noticeably different from Satin. You 
can copy imported curve to get multiple 
curves.
Alternating number is ignored.

Geflecht Standard Tatami Can be edited

Matching Tatami Non-matching 
Tatami 

Complex Fill will have matching 
Tatami.

Motifs Patches Normal objects

Needle In/Out End/Begin Jump

Other Multihead 
Machine 
Functions

Stop (with info label) For example, Insert Appliqué is 
converted to Stop.

Program Stitch Manual stitch

Ring Ring

Scattered Tatami Tatami with random 
factor applied

Will look slightly different

Schiffli Functions Stepp/Blatt only, 
others are ignored

Slow/Fast Slow/Fast

Split Alternate Tatami
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Supported embroidery disk formats

You can write designs to disks which are formatted for a specific 
embroidery machine. The disk can then be read through the machine’s 
Floppy Disk Reader. The following formats are supported:

Split Stitch Standard Tatami Looks different but can be edited

Tajima style Lock Tajima tie off OK most of the time

Tourenblat E Stitch Looks different, so that it is easy to 
locate and edit

Trim/Tie In/Tie Off Connector properties

Turn fill (spacing 
measured along 
shape boundary)

Turning fill (generally 
fewer stitches)

Will look different but can be 
re-digitized in smaller sections

Underlays – slant Zigzag underlay Can be added manually

Underlays, 3 or 4 
layers

Two underlays only Can be edited

Wilcom INP EMB Notes

Format Density Read Write

Barudan 2HD DS/HD  

Barudan S-FMC DS/HD  

DOS DS/HD  

Happy DS/HD  

Tajima DS/HD  

Toyota DS/HD  

ZSK TC DS/HD  
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PART XI
APPLIED DECORATION

EmbroideryStudio provides support for various multi-decoration 
techniques, including print.

Mixed decoration
Virtual embroidery can be printed on garments as is or in combination 
with graphic design or even embroidery. It may have other uses such as 
advertising, posters, murals, billboards, etc. The Cording function allows 
you to designate run stitching which is to form the cording. The Beading 
feature provides support for beading devices. See Mixed Decoration for 
details.

Sequin embroidery
This section describes how to set up sequin palettes for sequin designs 
and how to visualize sequin designs. It explains how to create 
single-sequin as well as multi-sequin runs. It also covers sequin fixings 
as well as reshaping and editing. See Sequin Embroidery for details.

Advanced sequins
This section describes how create sequin fills, both single- and 
multi-sequin, with and without borders. It discusses fancy sequin fills as 
well as flip sequins. It also covers editing sequin fills and converting 
objects to sequins. It deals with single sequin digitizing and custom 
sequins as well as outputting sequin designs. See Advanced Sequins for 
details.

Bling digitizing
This section describes how to digitize with rhinestones. It covers setting 
up bling palettes and describes creating bling runs and fills. It also deals 
with modifying bling objects and bling text. See Bling Digitizing for 
details.

Appliqué embroidery
This section describes different techniques for creating appliqué including 
how to convert vector graphics to appliqué, how to digitize appliqué 
objects from scratch, as well as how to convert Complex Turning objects 
to appliqué. It also covers creating partial cover appliqué for overlapping 
objects as well as how to break up multiple appliqué and recombine 
components for efficient stitchout. See Appliqué Embroidery for details.
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Multi-decoration output
Designs digitized in EmbroideryStudio and CorelDRAW® can be output in 
a variety of ways, both via the Wilcom Workspace and CorelDRAW 
Graphics. This section covers printing designs in CorelDRAW Graphics as 
well as exporting designs as vectors. It also covers the Export 
Multi-Decoration Files capability as well as outputting appliqué and 
bling to machines. See Multi-Decoration Output for details.
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Chapter 46

Mixed Decoration

Once digitized in EmbroideryStudio, you can output designs both as 
actual embroidery and ‘virtual embroidery’. The software provides high 
resolution digital print TrueView for this medium.

Virtual embroidery can be printed on garments as is or in combination 
with graphic design or even embroidery. It may have other uses such as 
advertising, posters, murals, billboards, etc. All types of substrates can 
be used. Production processes include:
 Screen printing
 Dye sublimation
 Direct-to-garment printing (DTG)
 Heat transfer
 Wide format printing
 Vinyl cut (printed)
EmbroideryStudio provides support for many other decoration types. 
Some machines provide devices for cording or beading. The Cording 
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function allows you to designate run stitching which is to form the 
cording. The Borers tool is available to turn needle penetrations into 
boring holes, regardless of selected stitch type. Holes are cut in the 
fabric, producing an effect similar to lace.

Virtual embroidery

EmbroideryStudio provides high resolution TrueView for ‘virtual 
embroidery’. This is a technique that can provide commercial flexibility 
for many different processes.

Image resolution depends on a specified DPI (Dots Per Inch). Maximum 
DPI for printers varies between 600 and 2880 DPI. For garments, good 
results can be obtained within a range of 200 to 400 DPI. Higher 
resolutions are available for printing on paper, photo paper, canvas, 
fabrics, glass, mugs, plaques, wood, metal, etc.
Screen images are typically captured in PNG format because this 
supports transparency. Most DTG printers and other printing techniques 
use RIP (Raster Image Processor) software which can use any raster 
image that supports transparency, including PNG format. Output files can 
be used as is or as input to any graphic or photo editing software.

Output embroidery as virtual decoration

Click View > TrueView to toggle between stitch view and TrueView™. 
Right-click for settings.
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If all you want to do is output the embroidery portion of a design as a 
high resolution virtual decoration, the process is simple.

To output virtual embroidery decoration
 Open your EMB design file.
 Optionally, turn on TrueView™ to visualize the embroidery component. 

The image produced is always in TrueView™ even if the TrueView 
setting is off. The Options > View Design settings will affect the final 
appearance of the virtual embroidery. You may want to adjust these. 

 Optionally, toggle on the product image to visualize the resulting 
virtual decoration on the target garment. Make any size adjustments 
needed.

 Select File > Capture Virtual Decoration Bitmap.

 Select a suitable resolution – e.g. 300 DPI. This setting determines the 
detail at which the TrueView™ image will be rendered. You can 
override presets by keying in a higher resolution as required – e.g. 
1200 DPI. Width and height settings update automatically.

Click View > Show Product to toggle product image on/off. Right-click to 
open the Product Visualizer docker.

Select a suitable
bitmap resolution

Note physical dimensions
of print-ready file



Chapter 46   Mixed Decoration 1122

 Click OK to save a PNG file of the design. Only the embroidery portion 
of the design is output to PNG file. This file can now be printed to 
garment or other media.

Note: For the purposes of virtual decoration, sequins and bling can be 
included in the output.

Related topics...
 Viewing design components
 View options
 Fabric & product backgrounds

Output combined virtual embroidery & print

To produce a combined embroidery decoration plus graphics, use the 
following procedure. Don’t use the Export Multi-Decoration Files 

Click View > TrueView to toggle between stitch view and TrueView™. 
Right-click for settings.

Click View > Show Product to toggle product image on/off. Right-click to 
open the Product Visualizer docker.

Use Mode > CorelDRAW Graphics to import, edit or create vector artwork 
as a backdrop for embroidery digitizing, manual or automatic.

In Graphics mode, click Mode > Show Embroidery to show or hide 
embroidery components.
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command for this scenario as it doesn’t support virtual embroidery as 
print.

To create combined virtual embroidery and print decoration
 Open your EMB design file.
 Optionally, turn on TrueView™ to visualize the embroidery component. 

Use Options > View Design to make any adjustments to TrueView™ 
settings. 

 Toggle on any graphic elements – bitmap or vector.
 Optionally, toggle on the product image to visualize the resulting 

virtual decoration on the target garment. Make any size adjustments 
needed.

To output the virtual decoration
 Switch to CorelDRAW Graphics.
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 In Graphics mode, click Show Embroidery to toggle on the embroidery 
component.

 Select a bitmap resolution – e.g. 300 DPI – from the Mode toolbar. 
You can override presets by keying in a higher resolution as required 
– e.g. 1200 DPI. Width and height settings update automatically.

Tip: This setting determines the detail at which the TrueView™ image 
will be rendered. Maximum DPI for printers can vary between 600 and 
2880 DPI. For general purposes such as printing on T shirts, good 
results can be obtained within a range of 200 to 400 DPI. Higher 
resolutions may be necessary for other substrates or media.

 Select File > Export > PNG to export a high resolution file for 
printing or similar.

Select a suitable 
bitmap resolution

Select PNG 
file format
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 Click Export. The Export to PNG dialog opens.

 Adjust transparency, anti-aliasing, and DPI settings as required. The 
DPI setting in this dialog does not affect the DPI resolution of the 
TrueView™ rendering. It only affects the DPI of the actual output file. 
Normally you would want to set the TrueView™ rendering and output 
resolution to be the same value. You can override presets by keying in 
a higher resolution as required – e.g. 1200 DPI.

 Click OK to export.

Related topics...
 Viewing design components
 View options
 Fabric & product backgrounds

Output combined virtual & actual embroidery

Adjust transparency 
and other settings 
as required

Set output DPI

Click View > TrueView to toggle between stitch view and TrueView™. 
Right-click for settings.

Use Standard > Import Graphic to import artwork into current design as a 
backdrop for manual or automatic digitizing.

Use View > Show Bitmaps to toggle bitmap images on or off. Right-click for 
settings.

Use View > Auto Start & End to toggle the Auto Start & End function on/off 
according to the current settings. Right-click to adjust settings.
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Combining actual and virtual embroidery offers interesting possibilities. 
This technique can be used artistically or to add texture and depth to a 
printed design. It may also be used to lower costs for large production 
runs while maintaining the appearance of actual embroidery.

Typically, you will create a virtual embroidery print of an entire design 
and then overlay real embroidery on some parts of it. Alternatively, you 
may add embroidery elements such as lettering or team names over a 
printed design. It is even possible to embroider the whole design in white 
thread and print virtual embroidery over the top. To produce a design as 
real embroidery plus virtual embroidery, you have two options – via 
Wilcom Workspace or via CorelDRAW Graphics.

To create combined actual embroidery and print decoration
 Create a virtual decoration of your embroidery design. See previous.

Use Mode > CorelDRAW Graphics to import, edit or create vector artwork 
as a backdrop for embroidery digitizing, manual or automatic.
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 Import the PNG file into a new blank design via File > Import 
Graphic. 

 Add the actual embroidery portion of the design. This may be a portion 
of the original design. Or it may be a new component such as lettering 
or even Team Names. 
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 Right-click Auto Start & End.

 Choose Digitize start/end point and click OK. EmbroideryStudio 
prompts you to click a point where you want the design to start and 
end.

 Set a point to which you can easily align the needle. When you stitch 
out the embroidery component, the needle will start and end at this 
point.

Option 1: Export both files together
 Select the File > Export Multi-Decoration Files command.

Set start and 
end point

Select embroidery 
and print file formats 
to export
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 Split out the embroidery production and graphics print files and select 
the formats to export – e.g. DST and PNG.

Note: If you choose PNG, it will default to the CorelDRAW default 
setting of 300 DPI. This can be changed via the CorelDRAW Options 
dialog.

Option 2: Export files separately
 To obtain the embroidery production file, select File > Export 

Machine File from the Wilcom Workspace and choose a suitable 
machine file format – e.g. DST.

 To obtain the graphics production file, switch to CorelDRAW 
Graphics:
 Turn off the embroidery display.
 Select File > Export > PNG to export the print file for graphics 

only.

Related topics...
 Output embroidery as virtual decoration
 Viewing design components
 View options
 Creating simple teamname designs
 Fabric & product backgrounds
 Exporting multiple decoration files

Cording

Cording refers to the technique of fixing a thick cord or yarn onto a fabric, 
usually for decorative purposes. Digitizers frequently want to see the 

Change bitmap file 
export resolution as 
required
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cord line so that while they digitize, they don’t overstitch on sharp turns. 
The Cording function allows you to designate the run stitching which is 
to form the cording. 

Designing for cording

Cording designs are made up of running stitch outlines. Bear in mind:
 Create the design with run stitching to define the cording pattern.
 Run stitching may cross over itself or other objects in a continuous 

fashion. It is best to avoid long runs of overlapping cord.
 However, cording should be, as much as possible, continuous, as the 

cord cannot be trimmed by machine trimmer, only by hand.
 Consequently, any disconnected cording sections must be digitized in 

different colors so the machine will stop to allow for manual trimming.
 It is ok to have sharp corners but avoid extremes.
 It is possible to combine regular embroidery and cording in the same 

design.
 Conversely, it is possible to create cording-only designs with no other 

embroidery stitching.

Producing cording on the machine
To perform cording in combination with embroidery...
 Stitch data from the design file stops the machine as required. On the 

production worksheet, a ‘Stop’ is displayed with an additional color 
swatch indicating ‘CORD’. This prompts the machine operator to switch 
to cording.

 Choose an embroidery thread to stitch the cord to the fabric – either 
a matching color, contrasting color, or see-through thread.

 The machine stitches the design automatically, with the cord being fed 
through the cording device, in shapes defined by the stitch data.
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 At the end of a section of cording, the machine stops so that you can 
trim the cord.

 When Cording is applied, a Cord In/Out function is inserted into the 
stitch sequence. Some machines have a specific cording function 
which is output when saving to machine file – e.g. Barudan FDR-3 file 
format or Schiffli machines that support cording. For machines that 
don’t have an explicit cording function, the software outputs a Stop 
code. 

 During production, the needle penetrates either side of the cord, not 
through the center. As a consequence, the cord is pushed one way or 
the other.

 Relevant production information is also recorded on the design 
worksheet:
 Cord size and color
 Length of cord required
 The stop sequence shows when to start cording, trim cording, and 

end cording.

Create cording designs

To create a cording design in EmbroideryStudio, follow this process:
 Digitize a cording design by digitizing a run with Cording turned on. 

Any suitable input method can be used together with Run stitch.

Use Outline Stitch Types > Run to place a row of single run stitches along 
a digitized line. Right-click for settings.

Use Stitch Effects > Cording to apply the cording effect to new or selected 
objects with run stitching.

Click View > Show Needle Points to show or hide the needle points in 
embroidery stitching.
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 Alternatively, select a run stitch object and apply the Cording effect. 
The cord is displayed as a graphic line. It takes the color of the run 
stitching. This allows designers to check technical correctness and 
better visualize a corded design look.

 Turn on needle points. Adjust display colors as necessary. 

 Avoid or minimize jumps/connectors between different cording objects 
in the design. Don’t use jumps for automatic connectors.

 Avoid or minimize cording crossing over itself.
 It is possible to use some fill stitch methods for cording if you set 

object properties for open density with no underlay. You can then 
break apart the object and apply Run together with Cording.

Idea  Some machines have a specific cording function which is output 
when saving to machine file – e.g. Barudan FDR-3 file format or Schiffli 
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machines that support cording. For machines that don’t have an 
explicit cording function, the software outputs a Stop code. 

Related topics...
 Viewing design components
 Change display colors

Boring

Borer embroidery remains a popular technique for cutting holes in fabric 
to produce an effect similar to lace. If your embroidery machine is 
equipped with a boring knife or needle, the Borers function is available 
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to turn needle penetrations into boring holes, regardless of selected 
stitch type. Holes are cut in the fabric, producing an effect similar to lace.

Prototype boring

Borer digitizing is a difficult skill to master. You will need to experiment 
with your machine and stitch width and spacing settings to achieve 
reliable results. Bear in mind that before putting any boring into 
production, everything needs to be carefully stitch tested, edited, and 
tested again. It all depends on the effect you want to achieve and the 
machine you are using.
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Of critical importance are the following considerations:

Note: This topic provides advice on how to approach boring with 
EmbroideryStudio. Without stitch testing however, we only can provide 
the theory.

Select machine format

Borers are often ‘knife’ attachments which are offset from the main 
needle. Before boring starts, the frame moves so that the borer is in the 
correct position. This movement compensates for the borer offset. 
Check your machine user guide. If it is capable of boring, you may add a 
borer knife or needle and activate the borer function. For older Tajima 
models, there is a ‘Borer’ dip switch in the control panel. For newer 
models, there is a ‘Borer’ function among the machine settings.
Here is a standard Tajima borer set. The borer knife is mounted inside the 
rubber tube, and the borer set is mounted on the needle bar. On the 
machine, there is a hole filled with a small rubber mat to buffer the borer.

Select the format for the target machine you are using. For instance, 
Tajima, Barudan, SWF, Dahao, Happy, ZSK2. The needle position of the 

Fabric type How to achieve the same look with different fabrics? 
Typically, stitches and borer cuts will be slightly 
different.

Hole shape Which cutting technique to use for circle, oval, square, 
etc?

Borer cut How big should the cut be and how many penetrations 
are necessary?

Cover stitch How wide and how dense does the covering need to be?
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borer and its offset value are specified in the Machine Format Settings 
dialog as part of the machine format definition. 

The default setting for Tajima and Dahao formats is for a ‘knife’ 
attachment, where the cutting position is offset ±12 mm from the main 
needle line. This offset is only expressed when you save your design to a 
stitch format like DST. 
If you are using a boring needle instead of a knife, no offset is required. 
Some machines automatically adjust the offset when a Borer In function 
is encountered. These require a value of ‘0’. This too should be part of the 
machine format definition, but you may need to adjust it manually. See 
your machine manual for details.

Note: With Tajima and Barudan machines the Borers function inserts a 
Stop which allows the machine to change to the needle position that uses 
the boring attachment. The machine must be correctly programmed to 
use the correct needle position.

Related topics...
 Machine Formats
 Borer functions
 Custom machine formats

Digitize boring holes

Enter borer offset

Enter needle 
number of borer

Use Function > Penetrations together with Borers to digitize boring holes.

Use Function > Borers to activate the boring function.

Use Traditional Digitizing > Run to digitize an outline around the shape you 
want to bore.

Use Traditional Digitizing > Manual to digitize boring holes.

Use Traditional Digitizing > Column A to digitize border stitching around the 
holes.
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With Borers selected, each needle 
penetration becomes a borer cut, 
regardless of selected stitch type. 
Boring holes are generally stabilized 
with zigzag to prevent fraying and 
movement, and bordered with satin 
stitches.
Whether you are digitizing for borer 
knife or needle, the technique is the 
same.

To digitize the boring hole
1 Ensure Penetrations is on.
2 Open the Stitch List to visualize what is happening at the stitch level.
3 Click the Run icon and digitize a stabilizing run around the borer hole. 

This helps prevent the fabric from tearing.

4 Click the Borers icon. A machine function is inserted to indicate the 
change from stitching to boring. 

5 Using the Run tool, digitize cutting lines. For a round hole, two 
intersecting lines are sufficient. For an oval hole, digitize a single 
cutting line.

Digitize outline 
with Run stitch

Open Stitch List to
study machine

functions
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Diamond shapes represent borer cuts on the fabric. Size indicates 
depth of cut. They do not appear in TrueView™.

Note: Some digitizers prefer to use the Manual tool. Each stitch you 
digitize becomes a boring hole. Bear in mind though that holes 
digitized in this way cannot be scaled.

6 Reduce Run length to 1.0-1.5 mm to place borer penetrations closer 
together. This ensures a clean cut.

7 Because the boring knife does not require tie-in and tie-off stitches, 
deactivate these functions via Object Properties > Connectors.

8 Click Borers again to deselect it. This returns you to normal stitching. 
You now need to stabilize the fabric and create borders by stitching 
around them with zigzag and satin cover stitches.

To stabilize the hole
1 Using Zigzag stitch, digitize around the hole with Column A or, if you 

have it, the Ring tool.

Digitize boring holes 
with Run or Manual 
stitch

Digitize a single
cutting line for an

oval hole

Digitize reinforcement 
with Column A and 
Zigzag
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2 Turn off underlay and adjust stitch length to around 3mm.
3 Place the inside edge close to the hole center so it ‘wraps’ the fabric.
4 In the Stitch List you will see Borer In and Borer Out functions 

whenever the borer knife is engaged. 

To create cover stitching
1 Digitize the cover stitching with Column A and Satin. Or, as a 

shortcut, duplicate the zigzag object and apply satin stitch. 
2 Again, ensure underlay is turned off.

3 Use Align Centers to align all objects.
4 Try experimenting with other styles of cover stitching:
 For a more open style, try Zigzag on its own by decreasing stitch 

spacing to around 1mm.

Digitize cover with 
Column A and Satin

Zigzag cover with 
1mm spacing
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 For a more organic look, try applying Hand Stitch effect to Zigzag 
cover stitching.

 Or for denser cover, try Hand Stitch with Satin cover.

 Pagadhi or String stitch may also provide interesting cover for 
boring holes, both round and square.

 Here we see an experimental square borer hole design. With sharp 
corners, stitching tends to pull fabric inward. We try to compensate 
for this by angling corners outwards.

Zigzag cover with 
Hand Stitch effect

Satin cover with 
Hand Stitch effect

String cover 
stitch

Experimental square 
borer hole with 
angled corners
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Related topics...
 Borer functions
 Filtering stitches & functions
 Digitizing manual stitches
 Digitizing outlines & details
 Automatic tie-in settings
 Automatic tie-off settings
 Stitch length settings
 Digitizing regular columns
 Arranging objects

Combine boring with other techniques

Here are a few tips for combining boring with other embroidery 
techniques...
 Typically you will want to combine boring holes with other stitch types 

and effects such as Stemstitch, Contour, and Motif Run.

Boring combined with 
Stemstitch, Contour, 
and Motif Run
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 String stitch can also be used to good effect with borer designs as 
custom motif runs.

 If your machine supports it, you can combine boring with cording or 
tape embroidery. You may also be able to combine borer holes with 
appliqué objects such as floral motifs.

Related topics...
 Contoured fills
 Decorative outlines
 String stitching
 Cording
 Creating appliqué embroidery

Productivity techniques

Here are a few tips for getting more out of your boring holes...

Boring combined 
with custom String 
stitch motif run

Combine with 
cording and appliqué
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Recycling boring holes
Once you have designed and tested boring holes that work, you can save 
them as custom motifs for re-use. Make sure Remove other functions 
is turned off to preserve cutting lines.

Once you have set up a library of borer holes, these are available for use 
with the Use Motif tool. The advantage of this technique is that boring 
holes can be easily scaled and rotated into position. Check, however, that 
scaling does not affect the ratio of knife cut to zigzag and cover stitching.

Resequencing boring holes for production
When it comes to actual production, borer holes are usually cut in groups 
for faster production. The components need to be sequenced for borer 

Save borer hole as 
custom motif

Reuse borer holes 
from custom motif 
library
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cuts to occur in neat, close groupings. Since individual motifs appear as 
grouped objects, ungroup them and resequence components as needed.

Of course by cutting first and then applying tackdown and cover stitching, 
you risk registration errors. You need to decide between quality vs 
productivity. For large production runs, productivity is a high priority and 
constrained by production cost.

Caution: Depending on production type, you will again need to test the 
design sequence carefully before starting a production run.

Related topics...
 Custom motifs
 Sequencing embroidery objects

Boring output

Export the machine file corresponding to your selected machine format: 
 Tajima - DST
 Barudan - U??
 SWF - EBD
 Dahao - DST
 Happy - TAP
 ZSK2 - Z??

Ungroup and 
resequence borer 
hole components for 
efficient stitchout
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When exporting to Tajima or Barudan machine file, boring functions are 
encoded as color changes. These allow the machine to switch to the 
boring attachment. The machine must be correctly programmed.

In addition to color change codes, the software adds a vertical offset of 
±12mm as Jumps wherever it encounters a ‘Borer In’ or ‘Borer Out’ 
function. These are interpreted on the machine as:
 Borer In: Stop code with -12mm off-set
 Borer Out: Stop code with +12mm offset.

For Tajima DST, the needle bar sequence is set on the control panel by 
the machine operator. If the needle bar sequence is incorrect, the fabric 
is ruined. In the Production Worksheet, needle bars are indicated in 
the color sequence.

Related topics...
 Exporting designs for machine
 Printing design reports

Boring offset 
expressed in 
machine file
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Chapter 47

Sequin Embroidery

Some embroidery machines are equipped with devices that can drop 
sequins onto the garment as it stitches. EmbroideryStudio allows you to 
digitize sequin designs for compatible machines. There is also a dedicated 
tool for automatically converting sequin artwork to sequin runs.

This section describes how to set up sequin palettes and how to visualize 
sequin designs. It explains how to create single-sequin as well as 
multi-sequin runs. It also covers sequin fixings as well as reshaping and 
editing.
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Selecting sequin mode

Before using the Sequin tools, you need a machine format that supports 
sequin output. You can then set up a dedicated sequin palette from a list 
of predefined or custom shapes and sizes. 

Machine capabilities

Machine capabilities vary widely. Some machines only support 
single-sequin devices. These may be mounted on the first or last needle, 
or sometimes both. Some machines support twin-sequin devices. These 
too can be mounted on first and last needles. Newer machines can 
support multi-sequin devices. These may perform consecutive sequin 
feeds – one at a time whilst stitching. Some may allow ‘stack feeding’, 
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where multiple sequins are dropped and secured with a single fixing 
stitch.

In summary, the main sequin device configurations include...
 Machines supporting one sequin per device. These feed only one 

sequin at a time.
 Machines supporting one or two devices per machine head, usually on 

first or last needles.
 Machines supporting twin-sequin devices with no stack feeding – e.g. 

Barudan FDR-II Twin Sequin, Tajima TBF, SWF Twin Sequin.
 Machines supporting twin-sequin devices or even double twin-sequin 

devices with stack feeding – e.g. Dahao.
 Machines supporting multiple sequins per device – four, six, eight, and 

possibly more sequins – with or without stack feeding.

Note: An increasing number of machines support multiple decoration 
types including sequins in combination with chenille, beading, cording, 
and others.

Multi-sequin device 

Double twin-sequin device with 
stack sequin capability
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Single- vs twin-sequins
Single and twin configurations still represent the most common type used 
in sequin production. Even then, different configurations and design 
types are possible:

Note: The kinds of design work you can do with two single-sequin 
devices and a single twin-sequin device are different. The twin 
single-sequin setup will allow you to include runs and fills of either 
sequin, but not both together in the same run or fill.

Sequin machine formats

Before using the Sequin tools, you need to choose a suitable machine 
format. Only some machine formats support beading – e.g. Barudan 
FDR-3, Dahao, Tajima TBF, and SWF Twin Sequin. Refer to your machine 
manual for information about support for this type of decoration.

Note: For machine formats that have no sequin capability, the sequin 
palette will display. However, if you attempt to create a sequin object, 
fixing stitches will be digitized without sequin drops.

Dahao machine format
EmbroideryStudio supports the Dahao machine format which in turn 
supports multi-sequin devices. Up to eight (8) sequins can be defined per 
device. The Dahao controller is used on many Chinese machines. 

Configuration Design type

Single-sequin device 
on one needle

The simplest configuration possible, this allows you to 
produce designs incorporating single-sequin fills, runs, and 
individual sequin drops.

Single-sequin device 
on two needles

Usually mounted on first and last needles, this setup allows 
you to incorporate two types of single-sequin fills, runs, and 
sequin drops.

Twin-sequin device 
on one needle

This configuration allows you to incorporate twin-sequin 
runs and fills. Some configurations (Dahao) also allow twin 
stacking.

Twin-sequin device 
on two needles

This configuration allows you to incorporate two types of 
twin-sequin runs and fills. Again, some may allow twin 
stacking.

Double twin-sequin 
device on one needle

This configuration allows you to incorporate two types of 
twin-sequin or quad-sequin runs and fills, as well as twin or 
quad stacking.
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When you select Dahao as your machine type, Dahao multi-sequin DST 
file format is available on output. The Drop Sequin functions are 
inserted according to Dahao multi-sequin requirements.
The actual Dahao definition for multi-sequin drops is this: one Jump 
signifies drop sequin A, two Jumps on the same spot mean drop sequin 
B, three Jumps signify a sequin C drop, and so on. 
Dahao control panels include a protocol to interpret this encoding. Tajima 
machines, on the other hand, strictly follow the DST file specification. 
Namely, one Jump per sequin drop.

Note: The Dahao controller is configured according to the capabilities of 
the particular sequin device. The digitizer needs to know what the device 
is capable of – e.g. whether capable of sequin stacking, etc.

Select sequin-capable machines

Before you can use the Sequin tools, you need to choose a suitable 
machine format.

To select a sequin-capable machine
1 Select Design > Select Machine Format.

2 From the Available Machine Formats list, select a sequin-capable 
machine format – e.g. Schiffli, Tajima, Barudan, SWF, ZSK, etc.

3 Click OK. Default sequins appear in the sequin palette. It is ready to 
be configured. If you have selected a twin-sequin-capable machine, 
sequins are displayed in pairs.

Select
sequin-capable
machine format

Click to 
adjust format

Twin-sequin palette Single-sequin palette
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Note: Different machines require different presets. Typical modifiable 
values include stitch and jump length, trim functions and color change 
functions. Use the Machine Format Settings dialog to customize 
values if outputting to a specific machine format. 

Related topics...
 Embroidery machine formats
 Exporting designs for machine
 Creating multi-sequin runs

Visualizing sequin designs

Click View > TrueView to toggle between stitch view and TrueView™. 
Right-click for settings.

Use View > Show Stitches to toggle embroidery stitching display. 
Right-click for settings.

Use View > Show Functions to toggle display of machine function symbols. 
Right-click for settings.
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Sequins can be viewed in TrueView or stitch view while Show 
Functions is toggled on.

Both sequins and fixing stitches appear in their selected colors and can 
be turned on or off via Show Functions and Show Stitches toggles.

When traveling through a sequin design, ‘undropped’ sequins appear in 
the ‘unsewn’ color defined in the Background & Display Colors dialog.

Tip: The Show Repeats function displays repeating designs, including 
sequins, in both TrueView and stitch view. You can view a design, even 
while digitizing, with any number of repeats.

Related topics...
 Travel through designs
 Viewing design repeats
 Change display colors

Sequins in 
TrueView

Sequins 
turned off

Sequins when 
traveling

Sequins in 
stitch view
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Setting up sequin palettes

The Sequin Palette Editor lets you prepare a palette of sequins 
according to capabilities of your chosen machine. The palette editor lets 
you define as many devices as your machine supports or you require for 
the design. Choose sequins from a library of predefined shapes or define 
your own. Once set up, the palette is available for use from the Sequin 
toolbar and Object Properties.

To set up a sequin palette
1 Select the machine format that supports the machine you are using or 

the design type you want to create.
2 Click the Sequin Palette Editor icon. Fields are arranged so that 

parameters for each sequin can be viewed at once.

3 Set the number of sequins available per device. Depending on 
machine type, up to eight (8) sequins may be supported. If you have 
chosen a twin-sequin machine, this value is limited to 2.

Use Sequin > Sequin Palette to select from a default or 
user-defined palette of sequin shapes for the current design.

Use Sequin > Sequin Palette Editor to select shapes from a sequin library, 
and define sequin colors and sizes.

Click to add 
more devices

Set number of 
sequins per device



Chapter 47   Sequin Embroidery 1154

4 Use the More button to add devices. Click X in the column header to 
remove.

Typical configurations include:

Note: Typically the machine operator will use Needle 1 to position the 
starting point. Thus single devices are usually mounted on the last 
needle. In terms of software configuration, it makes no difference.

5 Select predefined or custom sequin shapes from the droplist.

Device Configuration

1 x Single sequin A

2 x Single sequin A / A

1 x Twin sequin AB

2 x Twin sequin AB / AB

1 x Double twin (Dahao) ABCD

2 x Double twin (Dahao) ABCD / ABCD

1 x Multi-sequin (6, 8, 12, etc) ABCDEF...

Select sequin 
shape from the 
droplist
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6 Set color and size for each sequin as well as hole size. Colors can be 
defined for front and reverse sides as well as a transparency factor for 
translucent sequins. 

7 If you are using reversible or ‘flip’ sequins, define the reverse color as 
well. Flip sequins are generally used with twin- or multi-sequin 
machines, but may be used on their own.

8 If you are using transparent sequins, define a transparency factor 
from 0 to 90 for each sequin.

Click to
select color

More colors 
available

Define reverse
color for flip

sequins

Transparencies defined 
for better visualization
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 Click OK. Sequins are available for selection.

 Permutations for sequin stacks are automatically calculated and 
displayed in the Manual Sequin droplist and Object Properties.

Tip: The digitizer needs to know the machine capabilities by heart. If 
an unsupported combination is selected – e.g. four sequin stack 
feeding – the drop code is ignored on the machine.

Related topics...
 Select sequin-capable machines
 Creating multi-sequin runs

Digitizing sequin runs

Twin-sequin palette Single-sequin palette

Select sequin or sequin
combination you want

to use

Use Sequin > Sequin Run Auto to create a string of sequins along a 
digitized line according to current settings.

Use Sequin > Sequin Run Manual to manually digitize sequin-drops along 
a digitized line.
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EmbroideryStudio provides tools for creating a string of sequins along a 
digitized line according to preset spacings or as marked by the digitizer. 

Digitize sequin runs as you would motif runs. If you use the manual 
method, you define spacings between sequin-drops with every click you 
make. If you use the automatic method, sequin-drops are calculated 
according to current settings. 

To digitize a sequin run
 Select a sequin-capable machine from the Select Machine Format 

dialog. 
 Define your palette and select a sequin shape from the droplist. For 

simplicity, we show a single-sequin setup.

Use Sequin > Sequin Palette to select from a user-defined palette of 
sequin shapes for the current design.

Select a sequin
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 To digitize a scalable sequin run, use the Sequin Run Auto tool. Enter 
reference points – left-click for corner points, right-click for curve 
points.

 Press Enter to complete. Sequin drops are automatically generated 
along with their fixing stitches. Automatic sequin runs can be scaled.

Tip: You can convert a normal run to sequin run by selecting and 
clicking the Sequin Run Auto tool.

 Alternatively, to control the exact placement of your sequin drops, use 
the Sequin Run Manual tool. Digitize individual sequin drops with left 
and right mouse clicks. 

Digitize outline – left-click
corner points, right-click

curve points

Sequin drops and fixing
stitches generated

automatically

Digitize outline – left-click
corner points, right-click

curve points
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 Press Enter to complete. Sequin drops are generated at each 
reference point. Connecting and fixing stitches are automatically 
generated.

 Double-click to access object properties. Change sequins and adjust 
spacing properties as necessary.

 In the Spacing field, enter a nominal spacing. This is measured from 
the center to center. Minimum spacing is automatically calculated.

 Select a Positioning method from the droplist:

Note: If you change a manual sequin run to exact spacing, all sequin 
drops are recalculated and manual placements lost.

Option Function

Exact Uses nominal spacing. This may result in gap formation at the 
end of the path.

Expand to fit Expands nominal spacing to evenly spread sequin distribution.

Contract to fit Contracts nominal spacing to evenly spread sequin 
distribution, resulting in an extra sequin.

Manual Turns any sequin run into a manual run so that the number of 
sequins won’t change during editing. 

Sequin drops and fixing
stitches automatically

generated

Select positioning 
method

Enter nominal 
spacing

Change fixing 
stitches
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 To change fixing stitches, click the button in the Fixing field. The 
docker expands to show a library of fixing stitch types. See below.

Related topics...
 Select sequin-capable machines
 Creating multi-sequin runs
 Manual sequin digitizing
 Editing sequin runs
 Reinforce outlines
 Adjust entry/exit points

Sequin fixings

EmbroideryStudio provides a library of predefined fixing stitches for use 
with sequin runs or fills. Just as you can digitize sequin drops manually 
or allow the system to calculate them for you, you can manually set fixing 
size or allow the system to determine it according to sequin shape. And 
just as you can define custom sequin shapes, you can also define custom 
fixing stitches to support multi-head sequin devices.

Fixing stitch color
Generally digitizers reserve a single thread color for all sequins, 
regardless of sequin color. Transparent thread is often used on the 
machine in order to avoid differences between thread color and sequin 
color.

Fixing type
The choice of fixing stitch really depends on customer requirements. 
Some may want sequin placements to withstand repeated washing. 
Others may want to save on stitches to reduce production costs. As the 
digitizer, you would typically consider the cost of embroidery production 
against sequin weight in order to find a balance. 

Decorative fixings
Fixing stitches are not generally part of the decoration. They are there 
simply to fix sequins to the fabric. That said, Sequin Run has potential 
as a decorative stitch in its own right. For this purpose you can select 
None in the Sequin Palette. This option is best used with the Sequin 
Drop Direction set to Any.

Apply sequin fixings

Use Sequin > Sequin Palette to select from a user-defined palette 
of sequin shapes for the current design.
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You can select sequins before or after digitizing. Similarly, you can preset 
fixing stitches or change them at any stage.

Tip: Digitizers sometimes want to generate a sequin run and overlay it 
with a plain run so that sequins are more securely fixed. Another reason 
for backtracking is to avoid jump stitches between objects. The 
Backtrack/Repeat tool is enabled for sequin-run objects. When 
applied, EmbroideryStudio generates manual stitches but leaves other 
functions unaffected. See also Controlling stitch direction.

To apply sequin fixing stitches
 To change fixing stitches, double-click to access object properties.

Click to change 
fixing stitch
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 Click the Chooser button in the Fixing field. The docker expands to 
reveal a library of fixing stitch types.

 Select the preferred type.

 To adjust fixing stitch size, select a method:

Method Function

Match sequin Automatically sets a margin around the sequin so that fixing 
stitches don’t punch too close.

Set manually Enables the Size field and lets you set a fixing stitch size 
independent of sequin size.

Choose method for 
setting fixing size

 Fixing stitch
preview

Select fixing
stitch type

Adjust fixing stitch 
size if manual 
option selected
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 If you choose the manual option, specify a value in the Size field. Size 
is measured from the center of the sequin. Enter a value from 2.50mm 
to 30.00mm. 

 If you have chosen automatic matching, specify a margin for the fixing 
stitch in the Margin field. Enter a value from 0.20mm to 2.00mm. This 
ensures that the fixing stitch does not punch too close to the sequin. 

 If you have chosen an eccentric sequin shape such as ‘ellipse’, fixing 
stitches automatically adapt to fit.

 To adjust fixing orientation, choose one of the preset directions – 
left/right, up/down. 

Related topics...
 Create sequin fixings

Choose fixing orientation

Orientation: Left Orientation: 
Right

Orientation: 
Vertical
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Set drop-stitch direction

There is an option to ensure that the initial fixing stitch before the sequin 
drop is placed opposite the feeding direction, as recommended by the 
machine manufacturer. Otherwise, the sequin may be deflected by the 
thread. If the needle then misses the center of the sequin because of 
incorrect placement, the embroidery material, needle or needle plates 
may be damaged. In multihead machines, sequins are fed from the front 
or ‘south’ which means that the initial fixing stitch or ‘drop stitch’ should 
be placed on the ‘north’ side (the default). In Schiffli machines, the 
opposite is the case.

To set the drop-stitch direction
1 Select a sequin-run object and double-click to access object 

properties.

Feeding 
direction

Drop-stitch
direction

Select to prevent 
multiple penetrations

Select drop-stitch 
direction
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2 Select the drop-stitch direction to ensure that the initial fixing stitch is 
opposite the feeding direction:

Caution: With the Any option, direction is not important. This option 
generates the least number of fixing stitches but may not be suitable 
for your sequin device. Check your machine documentation.

3 Enter a Max Angle to specify an angular range within which 
drop-stitch will fall.
You can set the value for either north or south fixing stitches. The 
default is 90° but this can be increased or decreased depending on the 
capabilities of your machine.

4 Select the Prevent multiple penetrations option as required.

Drop-stitch direction Feeding direction

From north Front or ‘south’ – which is the case in multihead 
machines.

From south The top or ‘north’ – which is the case in Schiffli 
machines.

Drop direction ‘From 
South’: initial fixing stitch 
always placed below, and 
sequin fed from ‘north’

Drop direction ‘From
North’: initial fixing stitch

always placed above, and
sequin fed from ‘south’

Set maximum allowable 
angle for placement of 
fixing stitch

Drop stitch direction 
set to North or South
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This option is used to minimize penetrations at the same point, and to 
generate Schiffli-compatible fixing stitching. If you select the Schiffli 
template, the option is ‘on’ by default. When set to ‘off’, some fixing 
stitches will have multiple penetrations at the same point, both at the 
sequin center and outer edge.

5 Select the Closest point join option as required.
By default, this option is off, meaning that the system connects the 
exit leg of the fixing stitch motif, wherever it happens to be, to the 
entry leg of the next fixing stitch motif, again wherever it happens to 
be. That is, unless the connector exceeds the maximum sequin stitch. 
Choose the Closest point join option if you want to always connect 
fixing stitch motifs from the leg closest to the nearest leg of the next 
fixing stitch motif.

Creating multi-sequin runs

EmbroideryStudio enables the creation of multi-sequin designs for 
supported machines. Create and visualize predefined patterns of sequin 
runs. These may comprise multiple sequins of different size, color, and 
shape.

Prevent multiple 
penetrations on

Prevent multiple 
penetrations off
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Tip: Twin-sequin mode also allows you to convert vector artwork to 
twin-sequin outlines. See also Convert sequin artwork.

Stacked sequins

For those machines that support it, EmbroideryStudio allows you to 
define multiple sequin drops on the same needle. 

Use Sequin > Manual Sequin to digitize individual sequins.

Use Sequin > Sequin Run Auto to create a string of sequins along a 
digitized line according to current settings.

Use Sequin > Sequin Run Manual to manually digitize sequin-drops along 
a digitized line.

Use Sequin > Sequin Fill to digitize and fill large, irregular shapes with 
sequins.
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Stacked sequins can be used with Manual Sequin and Sequin Run 
digitizing methods. Permutations are automatically defined according to 
the sequin palette.

For those machines that support it, fixing stitches are only applied after 
all sequins have been dropped. In the case of many twin-sequin 
machines, the first sequin is dropped, fixed in place, and another dropped 
on top and stitched again.

Note: If you choose a stacked sequin configuration that the sequin 
device does not support, the machine will simply ignore that particular 
drop code.

Related topics...
 Setting up sequin palettes
 Digitizing sequin runs
 Digitize sequin drops with fixings

Apply multi-sequin run patterns

Use Sequin > Sequin Run Auto to create a string of sequins along a 
digitized line according to current settings.

Use Sequin > Sequin Palette to select from a user-defined palette 
of sequin shapes for the current design.
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In EmbroideryStudio, you select multi-sequin patterns from a pattern 
library. While patterns can be used with single sequins, they make more 
sense when applied to multi-sequin palettes.

To apply a multi-sequin run pattern
 Optionally, choose an existing sequin run and open Object 

Properties.

 Go to the Outlines > Sequin Run tab and click the Patterns button 
to access the library.

Click to access
pattern library
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 Select a pattern from the menu. A preview is displayed.

 Click Apply Pattern to make the selected pattern current. The 
pattern is immediately applied to any selected sequin-run objects.

 Optionally, select a different sequin combination from the Preview 
Panel droplist and click Apply Sequin.

Click to select
pattern from

droplist

Preview of
selected pattern

Click to apply 
selected 
sequin pair

Select alternative
sequin pair

Make selected 
pattern current

Change
sequin pairs
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 Using the Sequin Run Auto tool, create your runs. The same pattern 
will apply until you change it.

 Optionally, use the Pattern table in the Object Properties docker to 
define your own patterns. See below.

 Optionally, make a selected object’s properties current, including 
multi-sequin patterns, and apply them to existing objects.

Related topics...
 Select sequin-capable machines
 Selecting sequin mode
 Digitizing sequin runs
 Creating multi-sequin runs
 Copy properties

Create multi-sequin run patterns

Copy and paste 
multi-sequin patterns 
from one object to 
another

Use Sequin > Sequin Run Auto to create a string of sequins along a 
digitized line according to current settings.
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With EmbroideryStudio, you can create sequin run patterns and, 
optionally, save them to a pattern library for later use. Depending on 
machine capabilities, patterns may involve twin- or multi-sequin drops, 
with or without sequin stacking. 

Fixing stitches
With sequin patterns, the software actually allows you to apply a different 
fixing type to each sequin. Normally however, you would use the same 
fixing for all sequins in the pattern. Typically you would consider the cost 
of embroidery production against sequin weight in order to find a 
balance. The fewer stitches used, the lower the production cost. At the 
same time, you want sequins to stay in place during use or washing.

Sequin stacks
For stacked sequins, pattern setup depends on machine capabilities. With 
Dahao format, the sequin stack is dropped and secured with a single 
fixing stitch. For non-Dahao machine formats, the first sequin is dropped, 
secured, and another dropped on top and stitched again.

To create a multi-sequin run pattern
 Create a sequin-run object with Sequin Run Auto or select an 

existing object. This allows you to preview your pattern as you go.

 Select the sequin combination you want to use.

Use Docker > Object Properties to toggle the docker on/off. Set properties 
for the current design.

Select sequin 
combination
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 Open Object Properties. The Pattern table displays sequins 
currently in use.

 Add or remove sequins via the + and X buttons in the column header.
 Select a sequin from the droplist. The selected sample updates 

immediately.
 If your machine format supports it – e.g. Tajima TBF, Barudan FDR II 

or 3, SWF Twin Sequin, etc – you can set up stack sequins using the 
Layer field. Specify whether the sequin is to be stacked (‘on top’) or 
to form a new ‘base’.

 With Dahao format, you can choose sequin stacks from the 
combinations in the droplist. In this case, two or even three sequins 
can be dropped simultaneously and locked with a single fixing stitch.

Define parameters
for each sequin in

the pattern

Add sequins to pattern

Click to change 
fixing stitch

Click to change sequin

Set sequin 
placement – ‘base’ 
or ‘on top’

Choose a stack 
sequin combination
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Tip: The digitizer needs to know the machine capabilities by heart. If 
an unsupported combination is selected – e.g. four sequin stack 
feeding – the drop code is ignored on the machine.

 In the Spacing field, enter a nominal spacing for each sequin. Spacing 
is measured from the center of one sequin to the center of the next.

 In the Fixing field, select the type of fixing you want. Generally you’ll 
use the same fixing for all sequins in the pattern.

 When satisfied with the sequin-run pattern, click Save to record the 
pattern for future use.

 Enter a name for the pattern and click OK. It is now available in the 
Sequin Pattern dialog.

Related topics...
 Select sequin-capable machines
 Digitizing sequin runs
 Apply multi-sequin run patterns

Editing sequin runs

Enter nominal spacing

Adjust fixing stitch

Enter pattern
name

Click to save pattern

My Pattern

Use Select > Select Object to resize objects using selection handles.

Use Reshape > Reshape Object to reshape selected sequin-run objects.
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You have complete control over scaling and reshaping sequin-run 
objects. You can also manually fine-tune sequin spacings as well as 
remove or add individual sequins. You can even edit individual fixing 
stitches.

Note: Performing manual edits to sequin-run objects automatically 
deselects all options. If you reset to Exact, Contract to fit, or Expand 
to fit, all manual edits are lost and sequin drops recalculated.

To edit a sequin run
 Scale sequin-run objects by clicking and dragging selection handles, 

or by adjusting general properties. 
 If the object is created with the Sequin Run Auto tool, the sequin 

drops are automatically recalculated.

 If the object is created with the Sequin Run Manual tool, the 
original number of sequin drops is preserved.

Use Sequin > Sequin Edit to fine-tune placement of individual sequins.

Sequin drops regenerated
according to current settings

Original number of
sequin drops preserved
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 Reshape sequin run lines with the Reshape tool. Add reshape nodes 
by left- or right-clicking the outline.

 Fine-tune individual sequin spacings with the Sequin Edit tool – 
click-and-drag a diamond control point. Hold down Shift or Ctrl keys 
to select a range or multiple control points. 

 Delete selected sequins by pressing Delete.

Click-and-drag
spacing handle

Click a diamond control 
point and press Delete
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 Add sequins by holding down the Alt key and clicking the run. If you 
are in multi-sequin mode, select options, including stack sequins, from 
the popup menu.

 To replace a sequin in multi-sequin mode, click a diamond control point 
and select an alternative from the Manual Sequin droplist.

 In multi-sequin mode, right-click a diamond control point while 
modifying a particular sequin. Options include: removing the sequin, 
replacing it, adding another sequin on top or beneath.

Related topics...
 Scaling objects
 Reshaping embroidery objects

Hold down Alt key
and click

Select a sequin 
shape from the 
popup menu

Replace sequin with 
selection from droplist

Replace sequin 
with selection 
from menu
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Chapter 48

Advanced Sequins

Some embroidery machines are equipped with devices that can drop 
sequins onto the garment as it stitches. Machine capabilities vary widely. 
Some machines only support single-sequin devices. Some machines 
support twin-sequin devices. Newer machines can support multi-sequin 
devices. These may perform consecutive sequin feeds – one at a time 
whilst stitching. Some may allow ‘stack feeding’, where multiple sequins 
are dropped and secured with a single fixing stitch.

This section describes how create sequin fills, both single- and 
multi-sequin, with and without borders. It discusses fancy sequin fills as 
well as flip sequins. It also covers editing sequin fills and converting 
objects to sequins. It deals with single sequin digitizing and custom 
sequins as well as outputting sequin designs.

Creating sequin fills

The Sequin Fill feature provides a means of filling complex shapes with 
sequins generally arranged in columns. The fill can also include a border, 
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with or without a margin. This can be made from the same or a different 
sequin and is a property of the object.

Sequin fills are tied together by run stitches and travel runs. Travels are 
placed along the object outline. Sequin centers never fall outside the 
object outline. Sequin fixing stitches, however, can lie outside the outline 
depending on current settings.

Tip: The Show Repeats function displays repeating designs, including 
sequins, in both TrueView and stitch view. You can view a design, even 
while digitizing, with any number of repeats. See also Viewing design 
repeats.

Digitize sequin fills

Before you can use the Sequin tools, you need to choose a suitable 
machine format. Similarly, you need to prepare a palette of sequins 
according to capabilities of your chosen machine. See Selecting sequin 
mode for details.
Once set up, the palette is available for use from the Sequin toolbar and 
Object Properties. Digitizing sequin-fill objects is essentially the same 
as digitizing complex fill objects.

Use Sequin > Sequin Fill to digitize and fill large, irregular shapes with 
sequins.
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Double-clicking the object will invoke Object Properties similar to 
sequin run properties. See Digitizing sequin runs for details.

Controls available on the Fills > Sequin Column Fill tab for patterns 
and fixing stitches are summarized below.

Control Description

Sequin layout 
settings

Use these settings to control the overall layout of the fill grid, 
including angle, sequin spacings, and offsets within the grid. See 
Adjust sequin layouts for details.

Fill margin Include a fill margin or not as required. No sequin will have its 
center placed outside the fill margin. Usually used with a border 
but not necessarily. See Adjust sequin layouts for details.

Add border Sequin fills can include a border, with or without a margin. The 
border is a property of the object. See Fancy sequin fills for details.

Select Determines what patterns are displayed:
• Sequin Fill: displays the fill pattern
• Sequin Run: displays the border pattern.
All other controls work the same as for Sequin Run. 

Sequin layout settings
control overall

appearance of sequin
fills

Control fill margin with
or without border

Add a border as
preferred

Control sequin settings
for both fills and borders

Control fixings for both
fills and borders
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Fixing stitches are selected in the same way as for sequin runs. For 
sequin fills, we recommend the simplest fixing stitch available – C01-1.

Related topics...
 Selecting sequin mode
 Digitizing sequin runs
 Sequin fixings
 Creating free-form shapes

Adjust sequin layouts

Use sequin layout settings to control the overall layout of the fill grid, 
including angle, sequin spacings, and offsets within the grid. 

Use the simplest 
fixing stitch

Use Sequin > Sequin Fill to digitize and fill large, irregular shapes with 
sequins.

Set margin

Adjust sequin
layout

Independent control 
of column and row 
spacings
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Sequin Fill provides independent control of column and row spacings. 
Set the nominal spacing in the Spacing field. You have the option of 
expanding or contracting spacings in rows or columns. Each line is 
adjusted independently. The aim is to make sequins follow to the edge of 
the shape as closely as possible. This is less important if you add a border 
to the fill.

To adjust sequin layouts
 Adjust Angle as shown:

 Adjust Spacing as shown. This setting controls column spacing, not 
row spacing.

Angle: 45° Angle: 90°

Spacing: Default Spacing: 5 mm
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 Use Columns and Rows settings to make sequins fit the grid or 
adjust line-by-line to fit the shape. This is less important if you add a 
border to the fill.

 Adjust Offset as shown. This only works if you have set Rows to 
‘exact’ spacing.

 Adjust Direction as shown. This does not affect sequin layout, but it 
does affect stitching order, whether left-to-right or right-to-left. It may 
affect the appearance of fixing stitches.

Exact columns 
and rows

Adjusted columns 
and rows

Offset: 0 mm Offset: 5 mm

Layout: left-to-right Layout: right-to-left



Chapter 48   Advanced Sequins 1184

 Activate Add Fill Margin and adjust setting as necessary. This is 
generally used in conjunction with the Add border option. See below.

Adding sequin borders

Sequin fills can include a border, with or without a margin. The border is 
a property of the object. If a twin-sequin capable machine is selected, the 
border and fill can differ. They can be comprised of single sequins or 
sequin patterns.

No margin Margin added Margin with border



EmbroideryStudio e4 Reference Manual 1185

To add a sequin border
 Select a sequin-fill object and double-click to access object properties.

 Tick the Add Border checkbox and select Sequin Border from the 
droplist.

 Adjust sequin shape as shown. This can be the same or different to the 
sequin fill if you have a twin-sequin capable machine.

 Adjust the fill margin and border spacing as shown.

Enter nominal
spacing

Click to change
fixing stitch

Adjust fixing stitch
size manually or

automatically

Select Sequin Border

Tick border
option

Adjust fill margin

Sequin fill with 
same type border

Sequin fill with 
different type border
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 Set sequin border fixing stitch direction as shown.

Related topics...
 Digitizing sequin runs
 Sequin fixings

Special sequin fills

EmbroideryStudio provides techniques for creating special sequin fills, 
including reversible or ‘flip’ sequins and scalable sequin stipple fill.

Fancy sequin fills

Fixing stitch direction: 
clockwise

Fixing stitch direction: 
counter clockwise

Adjust fixing 
stitch direction

Use Sequin > Sequin Fill to digitize and fill large, irregular shapes with 
sequins.
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EmbroideryStudio allows you to create fancy sequin fills by a variety of 
methods.

Create variegated stipple fills automatically with single or multi-color 
sequin patterns. These objects are fully scalable and can be reshaped like 
any embroidery object. For stipple fills, sequin borders are activated by 
default.

You can create other fancy sequin fills by the conversion method. This is 
technically a ‘workaround’ since it does not produce a scalable sequin 
object. However, if your design requires it, you can first create the 
desired shape using, for example, Maze or Offset fill. Set spacing 
sufficient to accommodate the sequins you want to use. Then break apart 
and convert the resulting run objects to sequin runs. These can be 

Set loop spacing as 
for embroidered 
stipple fills

Sequin border 
activated by default

Select sequin 
stipple fill type
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grouped. But note what happens when you scale the object – sequins are 
recalculated for each run, but the gap between lines increases.

Related topics...
 Convert objects with Wilcom Workspace
 Break apart composite objects
 Stippling effects
 Maze fills
 Offset fills

Flip sequins

Flip sequins, also known as reversible sequins, create a color-changing 
effect which is very fashionable. Beginning with children’s wear, flip 

Maze fill converted 
to sequin run

Offset fill converted 
to sequin runs

Grouped object 
scaled

Use View > Show Functions to toggle display of machine function symbols. 
Right-click for settings.

Use View > Show Stitches to toggle embroidery stitching display. 
Right-click for settings.

Use Sequin > Sequin Fill to digitize and fill large, irregular shapes with 
sequins.

Use Docker > Carving Stamp to define a pattern of needle penetrations 
using a ‘carving stamp’ as a template.

Use View > Flip Sequins to toggle between front and reverse sides of 
sequin runs and fills in reversible sequin designs. Define colors in the 
Sequin Palette Editor.
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sequins have found a wide variety of applications, from reversible sequin 
shirts, pillow cases, bags, cases, note books, and more. Their use is 
simple – swipe up or down to reveal the reverse side with sometimes 
surprising effects. Flip sequins have also found their way into high 
fashion.

Sequin Fill can be used in combination with Carving Stamp to digitize 
twin-sequin fills with predefined twin sequin assignments. The stamp 
pattern takes the color of the other sequin in the currently selected pair. 
Use the Reshape tool to size, rotate and reshape stamp patterns.

Select sequin 
pair
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If you have defined reversible or ‘flip’ sequins, click the Flip Sequin 
control to view the reverse image as it will appear on stitchout.

Related topics...
 Setting up sequin palettes
 Creating patterns with carving stamps

Creating multi-sequin fills

If you have a twin- or multi-sequin capable machine, you can use the 
Pattern control to create patterned borders and/or fills. Use it also to 
control sequin spacing independently of line spacing. Most controls work 
the same as for Sequin Run. The process is essentially the same as for 
multi-sequin run patterns, except that you can’t save them for later use.

Tip: Twin-sequin mode also allows you to convert vector objects to 
twin-sequin outlines. See also Convert sequin artwork.

Use Docker > Object Properties to toggle the docker on/off. Set properties 
for the current design.
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To create multi-sequin fill patterns
 Open Object Properties and define a fill pattern as you would for a 

sequin run.

 Change sequin combinations as desired.

Define fill 
pattern

Select sequin pair
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 If your machine format allows it, define sequin layers as you would for 
a sequin run, one sequin serving as the ‘base’, and the other dropped 
‘on top’.

 With Dahao format, choose sequin stacks from the combinations in the 
droplist.

Note: If you choose a stacked sequin configuration that the sequin 
device does not support, the machine will simply ignore that particular 
drop code.

Define sequin 
layers

Choose a stack 
sequin combination
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 Optionally, make a selected object’s properties current, including 
multi-sequin patterns, and apply them to existing objects.

Related topics...
 Creating multi-sequin runs
 Sequin fixings

Editing sequin fills

Either by means of object properties or the Reshape Object tool, you 
can control the overall shape of sequin fills as well as their layout. You 
can also set entry and exit points to avoid excessive needle penetrations.

Copy and paste 
multi-sequin patterns 
from one object to 
another

Use Reshape > Reshape Object to reshape selected objects by means of 
control points.

Use Sequin > Sequin Edit to fine-tune placement of individual sequins.
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To reshape and edit a sequin fill
 Select a sequin-fill object and click the Reshape icon.

 Adjust overall shape like any embroidery object.
 Use the three central control points to adjust sequin layout settings 

interactively. These control Direction Angle, Spacing, and Offset 
settings. Pattern spacing is also influenced.

Pattern spacing is also controlled numerically via the Patterns panel.

Use reshape nodes 
to reshape outline

Adjust sequin layout 
settings interactively

Needle 
penetrations

Line spacing: 3mm
Offset: 1mm

Line spacing: 5mm
Offset: 4mm

Line angle: 125°
Pattern spacing: 8mm
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 Adjustments can cause needle penetrations to occur within sequins. 
Affected sequins are highlighted in pink. Adjust layout and/or 
entry/exit points to minimize unwanted needle penetrations.

 Fine-tune individual sequin spacings with the Sequin Edit tool – 
click-and-drag a diamond control point.

 Holes can be digitized in sequin-fill objects in the same way as any free 
shape.

Related topics...
 Reshaping embroidery objects
 Editing sequin runs
 Creating free-form shapes

Converting objects to sequins

Most objects in EmbroideryStudio are inter-convertible. Open and closed 
sequin objects are no exception. Any open object – Run, Stemstitch, 
Motif Run, Freehand, Column C, Vector – can be quickly converted to 
sequin run. Similarly, any closed object – Column A/B, Complex Turning, 
or Complex – can be converted to sequin fill. EmbroideryStudio also 

Set entry and exit points to 
minimize excessive 
needle penetrations

Sequin fills can 
contain holes
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provides a dedicated tool for automatically converting sequin artwork in 
the form of a vector file to sequin runs. 

Convert embroidery objects to sequins

Convert any open object – Run, Stemstitch, Motif Run, Freehand, 
Column C, Vector – to sequin run.

Right-click and select Convert > Convert to Sequin Run. Alternatively, 
simply click the Sequin Run Auto icon.

Use Sequin > Sequin Run Auto to create a string of sequins along a 
digitized line according to current settings.

Use Sequin > Sequin Fill to digitize and fill large, irregular shapes with 
sequins.
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Similarly, convert any closed object – Column A/B, Complex Turning, or 
Complex – to sequin fill.

Right-click and select Convert > Convert to Sequin Fill. Or click the 
Sequin Fill icon.

Convert sequin artwork

Frequently, artwork for sequin designs is independently created by a 
specialist designer and supplied to the embroidery digitizer as a vector 
file. The Vectors to Sequins tool is available for just this purpose. A 
sequin run is automatically created from a set of vector objects 
representing sequins. Fixing stitches are generated automatically 
according to current settings. If you are digitizing twin-sequin runs, 

Use Sequin > Vectors to Sequins to create a sequin run from a set of sequin 
vector objects selected by intersecting line.
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EmbroideryStudio will generate sequin drops according to the currently 
selected sequin run pattern.

To convert sequin artwork
1 Select a machine format that supports sequin mode via the Select 

Machine Format dialog. 
2 Insert the sequin artwork into the design.

Properly designed artwork will contain vector objects centered on the 
exact locations required for sequins in the design.

3 Select the sequin shape you want to use from the droplist in the 
Sequin Palette.

4 Select the Vectors to Sequins icon.
5 Click the sequin graphic which will start the sequin run.

6 Digitize a line connecting all sequins to be included in the sequin run.
The line only needs to touch the sequin object somewhere within its 
boundary. Left-click for corner points, right-click for curve points.

Select single sequin

Digitize
connecting line

passing through
all sequin graphics
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7 Press Enter.
A sequin run is generated along a curve that passes through the center 
of each sequin graphic with sequin objects positioned at these centers. 
Current properties are applied and the object is set to ‘manual’ by 
default. The generated curve contains a reshape node at each sequin 
position.

Tip: If you are running twin-sequin mode and preset a sequin pattern 
in Object Properties, this pattern is applied to the converted sequin 
objects while sequin spacing is preserved as per the artwork.

Related topics...
 Select sequin-capable machines
 Creating multi-sequin runs

Manual sequin digitizing

If you require precise control over the positioning and encoding of your 
sequin drops, EmbroideryStudio provides manual techniques for this 

Sequin Run
automatically generated

Reshape nodes generated
at each sequin drop

Pattern applied
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purpose. Digitize your own sequin drops with fixings. Or even insert 
individual sequin-drop functions while traveling through the design.

Digitize sequin drops with fixings

The Manual Sequin input method allows you 
individual control over sequin placement and 
fixing stitches. Create decorative outlines and 
patterns manually using sequins from the 
selection list. To add a sequin to the stitching 
sequence, simply drop it onto the design and 
secure it with manual stitches. Manual sequin 
stitching is a difficult digitizing skill to master and 
you need to plan the stitching sequence carefully 
in order to minimize unnecessary stitches. 
Experiment with your machine and stitch length 
and spacing settings to achieve the desired result.

Note: Sequin mode is supported in Schiffli, 
Tajima, Barudan and ZSK embroidery machine 
formats. Before you can use Sequin mode, you 

Use Sequin > Manual Sequin to digitize individual sequins.
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must select a machine format that supports it. Similarly, before you can 
use Twin-Sequin mode, you must select a suitable machine format. 

To digitize sequin drops with fixing stitches
 Select a machine format that supports sequin mode via the Select 

Machine Format dialog.
 Set up your palette in the Sequin Palette Editor according to the 

machine type – single, twin, multi-sequin – that you have selected.

 Select a color for the fixing stitching from the Color toolbar.
 Click the Manual Sequin icon. If your machine format supports it, 

stack sequin permutations are displayed in the droplist.

 Select the sequin or combination you want to use.
 Left-click to begin your manual sequin placement. It must start with 

at least one stitch.

Tip: Zoom in for more accurate digitizing.

Click to add 
more devices

Set number of 
sequins per 
device

Define reverse 
colors and 
transparencies

Select sequin or sequin
combination you want

to use
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 Right-click to drop a sequin. A sequin outline appears.

 Left-click to digitize fixing stitches around the sequin to secure it.
Three stitches in the shape of a ‘Y’ are generally used. The needle 
points of each stitch must be placed precisely to ensure that sequins 
are not pierced by the needle when stitching.

Tip: If you make a mistake while digitizing, press Backspace to 
retrace your steps.

 If you have activated twin- or multi-sequin mode, press the Tab key 
to switch between available sequin shapes while digitizing.

Left-click to digitize 
fixing stitches

Right-click to 
‘drop’ sequin

Continue digitizing – 
right-click for sequin 
drops, left-click for 
fixing stitches

Press Tab to 
change sequins



EmbroideryStudio e4 Reference Manual 1203

 If you have set up a palette for a machine with two single-sequin 
devices, you need to press Enter before changing sequins in the 
palette droplist.

 Continue digitizing manually in the same way – right-click to add a 
sequin, left-click to digitize fixing stitches. Press Enter to finish.

Related topics...
 Select sequin-capable machines
 Setting up sequin palettes
 Creating multi-sequin runs

Insert sequin drops

Press Enter before 
selecting second sequin

Use Outline > Digitize Run to place a row of single or triple run stitches 
along a digitized line.

Use Outline Stitch Types > Motif Run to create a string of motifs along a 
digitized line.

Use Docker > Stitch List to toggle Stitch List display on and off. Use it to 
select individual stitches.

Use Travel > Travel 1 Stitch to move stitch cursor forwards/backwards 1 
stitch at a time. Left/right click.

Use Sequin > Drop Sequin to drop a sequin at the current needle position. 
For twin-sequin machines, left-click to drop a left-sequin, right-click to drop 
a right-sequin.

Click Function > Insert Function to insert machine function at current stitch 
cursor position. 

Use Sequin > Clear Function to remove any sequin functions from the 
current needle position.
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In preference to the Manual Sequin tool, some digitizers flesh out 
designs using Run or Triple Run or even Motif Run and then travel 
through it, dropping sequins manually as and where required. The 
running stitch itself works as fixing stitch. It can be reinforced with 
Backtrack. This technique can be used with single or multi-sequins.

To insert sequin drops
1 Select a machine format that supports sequin mode via the Select 

Machine Format dialog.
2 Set up your sequin palette – single, twin, quad, etc – according to 

machine capabilities.
3 Set a fixed run length to suit the sequin type/s you are using.

Use Traditional Digitizing > Backtrack to reinforce an outline, stitching it in 
the reverse direction to the original.

Set run 
length to suit 
sequins
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4 Choose a digitizing method to create the design or pattern you want.

5 Optionally, open the Stitch List.
6 Press the Home button and travel through the design using arrow 

keys or Travel tools.
7 Travel to the insertion point and press the ‘hotkey’ 5. Alternatively, 

click the Drop Sequin button.

Quad palette
available

Sequin 
dropped

Drop Sequin
function inserted
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8 If you are using a twin-sequin palette, press the hotkey 6 to drop the 
other sequin. Alternatively, right-click the Drop Sequin button.

9 If you are using a multi-sequin palette, select Insert Function from 
the toolbar or the Stitch List popup menu.

10 From the Functions list, select Drop Sequin. Depending on machine 
requirements, you will either add the function to the current stitch, or 

Second sequin 
dropped

Travel to
drop point

Select Insert
Function
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insert it on an empty stitch or empty jump. See your machine manual 
for details.

11 When the Drop Sequin function is correctly defined, click OK. The 
Select Sequin dialog opens showing available sequins.

12 Choose a preferred sequin. The Drop Sequin function, together with 
any additional empty stitches or jumps, is added at the current needle 
position.

13 Continue traveling and inserting sequins by the same methods.

14 To delete a sequin drop, travel to the location and press 4. 
Alternatively, click the Clear Sequin button.

Select Drop
Sequin function

Insert additional 
empties as 
necessary

Choose preferred 
sequin or 
combination

Travel and insert
additional sequin drops
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Tip: If you are using Triple Run, the repeat stitch will tack down your 
sequin drop. If you are using Single Run, you can use the Backtrack 
tool to tack down the sequin drops.

Related topics...
 Select sequin-capable machines
 Travel through designs
 Insert machine functions manually

Custom sequins

EmbroideryStudio supports custom sequin shapes with offset holes. Such 
sequin shapes can be utilized for flipping sequins on the fabric to form 
two different sequin fill patterns. Alternatively, you may be working with 
sequins which don’t appear in the standard sequin library. Define your 
own sequins using circle, oval, rectangle, or other shapes.

Create sequin shapes

Use Graphics Digitizing > Ellipse to digitize ellipse or circle vector outlines.

Use Graphics Digitizing > Basic Shapes to digitize basic shapes. Press 
<Ctrl> to maintain aspect ratio. Press <Shift> to center at the first point.

Use Outline Stitch Types > Vector Outline to create vector outlines with no 
stitch properties applying.
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The software allows you to define your own sequin shapes with their own 
hole position. 

To create a custom sequin
1 Create a sequin shape using vectors only. The Ellipse or even Basic 

Shapes tools can be useful. Outline and hole must be digitized as 
separate objects. 

2 Position the hole. 
3 Size the sequin shape to a nominal size – e.g. 1.5mm.
4 Select both objects and choose Object > Create Sequin Shape.

5 Give your sequin a name and click OK to save. The custom shape is 
available from the sequin droplist for use in sequin palettes. Use it in 
sequin runs or fills.

Position hole as 
required

Enter a sequin
name

My Sequin
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Tip: Use the Setup > Manage Sequin Shape command to rename 
or delete custom sequin shapes from the library.

Related topics...
 Create vectors
 Digitize stars & rings
 Digitize basic shapes
 Manage custom motifs

Create sequin fixings

Just as you can define custom sequin shapes, you can define custom 
fixing stitches to support multi-head sequin devices. Some limitations 
might exist for older more complicated sequin devices. Access the dialog 
via the Object > Create Sequin Fixing command.

Rename or delete 
custom sequin 
shapes

My Sequin

Follow
instructions

Name your
fixing stitch

Set angle to define
snap lines

Custom fixing stitch
added to library
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Custom sequin fixings mean you can:
 Create multiple layers of stitching for decorative effects, sometimes in 

different thread colors (Barudan).
 Reduce stitch counts in large sequin designs.
 Accommodate specific fixing requirements.
 Accommodate new capabilities – e.g. offset holes.

Tip: If you have chosen an eccentric sequin shape such as an ‘ellipse’, 
fixing stitches automatically adapt to fit.

Tip: Use the Setup > Manage Sequin Fixing command to rename or 
delete custom sequin fixings from the library.

Outputting sequin designs

Use Docker > Design Information to view and modify design details prior to 
design approval or stitchout.

Click Standard > Print Preview to preview the production worksheet on 
screen.

Use Standard > Export Machine File to export the current design to a 
machine file for stitching.
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Once your sequin design is ready for production, check all design details 
via the Design Information docker. The Design tab provides a 
summary of all sequins used in the design creation.

When you come to output your design to machine file, make sure you are 
using the correct file format. EmbroideryStudio currently supports the 
following...

Machine format File format

Barudan FDR-3 U??

Barudan FDR-3 Chenille Combination U??

Barudan FDR-II Twin Sequin U??

Barudan FDR-II Twin Sequin Chenille Combination U??

Dahao DST (Dahao)

Schiffli ESS

SWF DST

Sequin details
listed on Design tab
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When you select Dahao multi-sequin DST as you output file format, the 
Drop Sequin functions are inserted according to Dahao multi-sequin 
requirements. Dahao control panels include a protocol to interpret this 
encoding. Tajima machines, on the other hand, strictly follow the DST file 
specification.

Note: For machine formats that have no sequin capability, the sequin 
palette will display. However, if you attempt to create a sequin object, 
fixing stitches will be digitized without sequin drops. No sequins appear.
Create a hard copy of your production worksheet to provide thread and 
sequin information for the machine operator. 

Related topics...
 Printing design reports
 Exporting designs for machine

SWF Twin Sequin EBD

Tajima DST

Tajima TBF TBF

ZSK ZSK

Machine format File format
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Chapter 49

Bead Embroidery

Bead embroidery is a type of applied decoration where beads, like 
sequins, are stitched rather than glued to fabric, suede, or leather. Unlike 
woven, knitted, and crocheted beading, embroidered beading does not 
form part of the fabric structure. Traditionally, it has been used on 
garments and decorative textiles. Accessories such as handbags or belt 
buckles may also be embellished with bead embroidery. As may 
household items such as pillowcases or cushions.

Embroidery machines can be equipped with a device that drops beads 
onto fabric as it stitches, similar in principle to sequin embroidery. 
EmbroideryStudio includes a Beading capability which supports beading 
devices. A library of beads of different size, shape and color, is available, 
together with fixing stitches supporting classic upright, flat and sideways 
beading.
This section describes how to set up bead palettes and how to visualize 
bead designs. It explains how to create single-bead as well as multi-bead 
runs. It also covers bead fixings as well as reshaping and editing. It also 
deals with individual bead drops.

Beading mode

Before using the Bead tools, you must select a machine format that 
supports bead output. You can then set up a dedicated palette for your 
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design from a list of shapes. Each can be adjusted in size, height and 
color.

Machine beading

Capabilities vary but bead devices are not as varied as sequin devices. 
There are two categories: bead tape and loose beads. For both types of 
setup, twin-bead configurations are currently the most popular.

Twin-bead tape device Twin-beading loose
bead device
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Bead tapes, like sequin reels, provide controlled placement of beads on 
fabric. With loose beads, containers hold them on top of the dispenser. 
This method is not quite as reliable as beads on tape. 

Various layout methods are available on the machine. EmbroideryStudio 
supports the classic fixing stitch types – ‘upright’, ‘flat’, and ‘sideways’ – 
as well as decorative variants.

Related topics...
 Embroidery machine formats

Select bead-capable machines

Before using the Bead tools, you need to choose a suitable machine 
format. Only some machine formats support beading – e.g. Tajima TBF, 
Dahao and SWF Twin Sequin. Refer to your machine manual for 
information about support for this type of decoration.

Note: For machine formats that have no bead capability, the bead palette 
will display. However, if you attempt to create a bead object, fixing 
stitches will be digitized without bead drops.
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To select a bead-capable machine
1 Select Design > Select Machine Format.

2 From the Available Machine Formats list, select a bead-capable 
machine format – e.g. Tajima TBF, Dahao.

3 Click OK. Default bead shapes are now available for selection from the 
Bead Palette. If you have selected a twin-bead-capable machine, 
bead shapes and sizes are displayed in pairs. Up to eight (8) beads can 
be supported when the Dahao machine format is selected.

Note: Different machines require different presets. Typical modifiable 
values include stitch and jump length, trim functions and color change 
functions. Use the Machine Format Settings dialog to customize 
values if outputting to a specific machine format. 

Select
bead-capable

machine format
Modify format 
as necessary

Twin-bead palette Single-bead palette
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Related topics...
 Embroidery machine formats
 Exporting designs for machine

Visualize bead designs

Beading can be viewed in TrueView or stitch view while Show 
Functions is toggled on.

Both beads and fixing stitches appear in their selected colors and can be 
turned on or off via Show Functions and Show Stitches toggles.

When traveling through a beading design, ‘undropped’ beads appear in 
the ‘unsewn’ color defined in the Background & Display Colors dialog.

Click View > TrueView to toggle between stitch view and TrueView™. 
Right-click for settings.

Use View > Show Stitches to toggle embroidery stitching display. 
Right-click for settings.

Use View > Show Functions to toggle display of machine function symbols. 
Right-click for settings.

Beading in 
TrueView

Beading 
turned off

Beading in 
stitch view

‘Undropped’ beads 
when traveling
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Related topics...
 Travel through designs
 Viewing design repeats
 Change display colors

Creating bead runs

EmbroideryStudio provides tools for creating a string of beads along a 
digitized line according to preset spacings or as marked by the digitizer. 

Digitize bead runs as you would do sequin runs. If you use the manual 
method, you define spacings between bead-drops with every click you 
make. If you use the automatic method, bead-drops are calculated 
according to current Bead Run object properties.

Set up bead palette

Use the Bead Palette Editor to prepare a palette of beads for use 
according to your machine capabilities. Bead devices are normally 
attached to the first or last needle of the machine head.

To set up a bead palette
1 Select the machine format that supports the machine you are using.

Use Bead > Bead Palette Editor to select shapes from a bead library, and 
define bead colors and sizes.
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2 Click the Bead Palette Editor icon. Fields for each bead are arranged 
in tabular form.

3 Set the number of beads available per device. Depending on machine 
type, up to eight (8) beads may be supported. If you have chosen a 
twin-bead machine, this value is limited to 2.

4 Use the More button to add devices. Click X in the column header to 
remove.

5 Select a bead from the droplist.
6 Set color, bead and hole size, as well as height.

Click to add 
more devices

Set number of 
beads per device

Select bead 
shape from the 
droplist

Click to
select color

More colors 
available
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7 Set up other beads in the same way, and click OK. Beads are available 
for selection.

Related topics...
 Select bead-capable machines

Digitize bead runs

Normally beads are stitched last, after motifs and other embroidery are 
complete. With the Bead Run tools you have the option of digitizing 
individual bead drops or letting the system generate them for you. 
Automatic bead runs can be scaled.

To digitize a bead run
1 Select a bead-capable machine from the Select Machine Format 

dialog. 
2 Define your palette and select bead shapes you want to use from the 

droplist, in this case a twin-bead setup.

Beads available 
per device

Use Bead > Bead Run Auto to create a string of beads along a digitized 
line according to current settings.

Use Bead > Bead Run Manual to manually digitize bead-drops along a 
digitized line.

Use Bead > Bead Palette to select from a user-defined palette of 
bead shapes for the current design.

Beads available 
per device
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To digitize automatic bead placements
 To digitize a scalable bead run, use the Bead Run Auto tool. Enter 

reference points – left-click for corner points, right-click for curve 
points.

 Press Enter to complete. Bead drops are automatically generated 
along with fixing stitches according to current Bead Run object 
properties.

Tip: You can convert a normal run to bead run by selecting and 
clicking the Bead Run Auto tool.

 Double-click the object to access properties and swap beads as 
preferred.

Digitize outline – left-click
corner points, right-click

curve points

Bead drops and fixing
stitches generated

automatically

Swap beads
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 In the Spacing field, enter a nominal spacing. By default, this is 
measured ‘along baseline’, from one bead drop to the next. Minimum 
spacing is automatically calculated.

 Adjust Positioning method as preferred:

 Exact: Uses nominal spacing. This may result in gap formation at 
the end of the path.

 Expand to fit: Expands spacing to evenly spread bead distribution.

Enter nominal 
spacing

Adjust positioning 
method

Exact

Expand to fit
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 Contract to fit: Contracts spacing to evenly spread bead 
distribution, sometimes resulting in an extra bead.

 Manual: Turns bead run to ‘manual’ so that the number of beads 
won’t change when scaling.

 Change the Spacing measure as necessary in order to prevent bead 
bunching.

 Use Angle to orientate beads in relation to the run line. Fixing stitches 
are adjusted accordingly.

Contract to fit

Along baseline

Between shapes

Choose spacing 
method

Enter bead 
angle
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 Set Angle to -90° to flip bead orientation.

 To change fixing stitches, click the ‘...’ button in the Fixing field. The 
docker expands to display a library of fixing stitch types. See below.

To digitize manual bead placements
 Alternatively, to control the exact placement of your bead drops, use 

the Bead Run Manual tool. Digitize individual bead drops with left 
and right mouse-clicks. 

 Press Enter to complete. Bead drops are generated at each reference 
point. Connecting and fixing stitches are automatically generated.

Note: Manual placements can be reset by choosing a different 
Positioning method. If you change to exact spacing, all drops are 
recalculated and manual placements lost.

Set bead angle to 
-90° to flip orientation

Digitize outline – left-click
corner points, right-click

curve points

Bead drops and fixing
stitches automatically

generated
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Create patterned bead runs

With EmbroideryStudio, you can create bead run patterns for immediate 
use. Patterns generally involve multi-bead drops.

To create a patterned bead run
 Create a bead-run object with Bead Run Auto or select an existing 

object. This allows you to preview your pattern as you go.

 Select the bead combination you want to use.

 Open Object Properties. The Pattern table displays beads currently 
available.

 Add or remove beads via the + and X buttons in the column header.

Use Bead > Bead Run Auto to create a string of beads along a digitized line 
according to current settings.

Use Docker > Object Properties to toggle the docker on/off. Set properties 
for the current design.

Select bead 
combination

Define parameters
for each bead in

the pattern

Add beads to pattern

Click to change 
fixing stitch

Click to change bead
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 Select a bead from the droplist. The selected sample updates 
immediately.

 In the Spacing field, enter a nominal spacing for each bead. By 
default, spacing is measured along the digitized line.

 In the Fixing field, select the type of fixing you want. Generally you’ll 
use the same fixing for all beads in the pattern.

Related topics...
 Select bead-capable machines
 Digitize bead runs

Bead fixings

EmbroideryStudio provides a library of predefined fixing stitches for use 
with bead runs. Generally digitizers reserve a single thread color for all 
beads, regardless of bead color. Transparent thread is often used in order 
to avoid differences between thread color and bead color. Various layout 
methods are available. EmbroideryStudio supports the classic types – 
‘upright’, ‘flat’, and ‘sideways’ – as well as variants. Fixing stitches are 
generally not part of the decoration.

Upright

Flat

Sideways



Chapter 49   Bead Embroidery 1228

Bead fixing considerations

Fixing type is independent of device type. The bead is always dropped in 
the same way. Fixing stitches control bead orientation. However, different 
machines and dispensers have their own production requirements and 
idiosyncrasies.

Bead production vs sequin production
Bead production is more exacting than sequin production. While sequin 
devices used to have similar issues, they have matured to the point 
where they can manage all kinds of fixing types at high speed. Moreover, 
sequin materials are more forgiving. Needle penetrations do not 
generally cause serious problems. The minimum commercial operating 
speed for bead production is 800 rpm or higher. Typical problems which 
can occur at high speed:
 Beads are missed
 Beads are smashed
 Needles are broken.

Testing for high speed production
You may need to modify or ‘tweak’ predefined fixing types provided by 
the software in order to run reliably at high speed. This will involve 
testing on the machine. While fixing stitches in EmbroideryStudio 
automatically adapt to bead size, each bead type will need to be tested 
separately. Generally speaking, bead production can be stabilized when 
running machines at low speed, say, 600 rpm. This is suitable for testing.
A typical scenario might be:
 Develop a bead embroidery design.
 Carry out a sampling test at low speed.
 Test at production speed in order to calculate costs. 
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 Assess whether bead fixing meets high speed requirements – e.g. 
beads are missed or smashed.

 Adjust bead fixings and test again.

Options for editing bead fixings
Options available in EmbroideryStudio for bead designers are:
 Modify or ‘tweak’ fixing stitches by means of object properties. This 

may involve:
 Trying out different fixing stitch types
 Testing automatic as well as fixed spacings
 Modifying margin settings.

 Edit bead fixings with the Bead Edit tool.
 Digitize bead drops with the Manual Bead tool.
 Insert bead drops with the Insert Function capability.
 Create your own bead fixings and save them as custom motifs.

Apply bead fixings

You can select beads before or after digitizing. Similarly, you can preset 
fixing stitches or change them at any stage.

Use Bead > Bead Palette to select from a user-defined palette of 
bead shapes for the current design.



Chapter 49   Bead Embroidery 1230

To apply bead fixing stitches
 To change fixing stitches, double-click to access object properties.

 Click the ‘...’ button in the Fixing field. The docker expands to display 
a library of fixing stitch types.

Click to change 
fixing stitch

 Fixing stitch
preview

Select fixing
stitch type

Choose fixing 
size method

Adjust fixing stitch 
size if manual 
option selected
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 Select the preferred style – ‘upright’, ‘flat’, ‘sideways’.

 To adjust fixing stitch size, select a method:

 If you choose ‘set manually’, specify a value in the Size field. Size 
is measured from the center of the bead. Enter a value from 
2.50mm to 30.00mm. 

 If you choose automatic matching, specify a margin for the fixing 
stitch in the Margin field. Enter a value from 0.20mm to 2.00mm. 
This ensures that the fixing stitch does not punch too close to the 
bead. 

Method Function

Match bead Automatically sets a margin around the bead so that fixing 
stitches don’t punch too close.

Set manually Activates the Size field and lets you set a fixing stitch size 
independent of bead size.

Set fixed 
fixing size
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 To adjust fixing orientation, choose one of the preset directions – 
left/right, up/down. 

Related topics...
 Create sequin fixings

Editing bead runs

Bead-run objects can be edited like any other embroidery object. 
Parameters can be adjusted via object properties, or bead runs reshaped 
and edited, right down to individual bead orientations and fixings.

Convert objects to bead runs

Most objects in EmbroideryStudio are inter-convertible. Bead runs are no 
exception. Any outline object – Run, Stemstitch, Motif Run, Freehand, 
Column C, Vector – can be quickly converted to bead run.

Orientation: Left

Orientation: Right

Orientation: Vertical

Choose fixing 
orientation

Use Bead > Bead Run Auto to create a string of beads along a digitized line 
according to current settings.
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To convert an object to a bead run
 Select the object – Run, Stemstitch, Motif Run, Freehand, Column C, 

or Vector.
 Right-click and select Convert > Convert to Bead Run.

 Alternatively, click the Bead Run Auto icon.

 Double-click to access object properties.

Edit bead runs

You have complete control over editing bead-run objects, from scaling to 
adding or removing individual beads. You can also manually fine-tune 
bead spacing and orienation. You can even edit individual fixing stitches.

Use Select > Select Object to resize objects using selection handles.

Use Reshape > Reshape Object to reshape selected bead-run objects.

Use Bead > Bead Edit to fine-tune placement of individual beads.
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Tip: Performing manual edits automatically sets bead positioning to 
Manual. If you reset to Exact, Contract to fit, or Expand to fit, all 
manual edits are lost.

To edit a bead run
 Scale bead-run objects by clicking and dragging selection handles, or 

by adjusting general properties. 
 With Bead Run Auto objects, bead drops are automatically 

recalculated.

 With Bead Run Manual objects, the original number of bead drops 
is preserved while spacing is increased.

 Edit bead runs with Reshape:
 Add nodes by left- or right-clicking the outline.
 To remove a node, select and press Delete.

Bead drops regenerated
according to current settings

Original number of
bead drops preserved
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 Click-and-drag to move the start point. To reverse stitch direction, 
apply Edit > Reverse > Reverse Curves.

 Fine-tune individual bead spacings with the Bead Edit tool. 
Click-and-drag a diamond control point. Hold down Shift or Ctrl keys 
to select a range or multiple control points.

 Remove selected beads by pressing Delete or via the popup menu. 
Use the same menu to replace individual beads from the current 
palette.

Add or delete
nodes

Click-and-drag to 
move start point

Click-and-drag 
spacing handle

Right-click to access
popup menu
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 Add beads from the popup menu by holding down the Alt key and 
clicking the bead run.

 To rotate an individual bead, click the diamond control point. Use the 
rotation handle to orient the bead as necessary.

 Click the bead to activate fixing stitches. Use the handles to fine-tune 
as necessary.

Related topics...
 Scaling objects
 Reshaping embroidery objects

Hold <Alt> and click
to add beads

Click-and-drag
rotation handle

Click-and-drag
to reposition

fixing stitches
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Manual bead digitizing

If you require precise control over the positioning and encoding of your 
bead drops, EmbroideryStudio provides manual techniques for this 
purpose. Digitize your own bead drops with fixings. Even insert individual 
bead-drop functions while traveling through the design. Or create your 
own bead fixings for use as custom motifs.

Digitize manual bead drops

The Manual Bead input method 
allows you individual control over 
bead placement and fixing stitches. 
Create decorative bead placements 
or ‘clusters’ using beads from the 
palette. To add a bead to the 
stitching sequence, simply drop it 
onto the design and secure it with 
manual stitches.

Note: Manual bead stitching is a difficult digitizing skill to master and you 
need to plan the stitching sequence carefully in order to minimize 
unnecessary stitches. Experiment with your machine and stitch length 
and spacing settings to achieve the desired result.

Use Bead > Manual Bead to digitize individual beads.
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To digitize manual bead drops
1 Select a machine format that supports bead mode via the Select 

Machine Format dialog. See Select bead-capable machines for 
details.

2 Set up your palette in the Bead Palette Editor according to the 
machine type – single, twin, multi-bead – that you have selected.

3 Select a color for the fixing stitch from the Color toolbar.
4 Click the Manual Bead icon. If you have activated twin-bead mode, 

bead options are displayed in the droplist.

Tip: Zoom in for more accurate digitizing. Hold down Ctrl+Shift to 
constrain the cursor to horizontal and vertical directions, or 15° 
increments.

5 Select a bead and left-click to begin your manual bead placement. It 
must start with at least one stitch. How you proceed depends on the 
layout style you are aiming for. The most common is ‘flat’:

6 One technique for creating a ‘flat’ fixing stitch is as follows:
 Click-stitch forward as manual run stitching.
 Move forward one bead length and right-click to drop a bead. An 

outline appears.
 Click-stitch backwards. This stitch is going through the hole and will 

pull the bead back and down.
 Click-stitch forward across the bead to the drop point.

 Click-stitch forward as manual run stitching until you reach the next 
drop point.

Beads available 
per device

Flat

Click-stitch backwards
and then forwards

Right-click to
drop bead

Click-stitch forward
as manual run
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Tip: If you make a mistake while digitizing, press Backspace to 
retrace your steps.

7 Continue digitizing manually in the same way – right-click to drop a 
bead, left-click to digitize fixing stitches. Press Enter to finish.

Tip: Remember to test your beading drops on the machine at normal 
speed (low-to-medium) and then at high speed. Differences will show 
up at high speed.

8 If you have activated multi-bead mode, press the Tab key to switch 
between available bead shapes while digitizing.

9 Press Enter to finish.

Tip: Typically, you combine manual bead drops with Run stitch. Use 
Run to ‘map out’ the design and use Manual Bead to digitize 
individual bead drops or ‘bead clusters’.

To digitize sideways fixing stitches
The recommended technique for creating a ‘sideways’ layout is similar in 
principle to ‘flat’.

1 Click-stitch forward as manual run stitching.

Continue digitizing –
right-click for bead drops,
left-click for fixing stitches

Press <Tab> to
switch beads

Sideways
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2 Turn sideways at the point you want to drop the bead.
3 Move forward one bead length and right-click to drop the bead. A bead 

outline appears.
4 Click-stitch backwards. This stitch is going through the hole and will 

pull the bead back and down.

5 Click-stitch forward as manual run stitching until you reach the point 
of the next bead drop.

6 Press Enter to finish.

To digitize upright fixing stitches
Below is the ‘classic’ upright layout. In this procedure we add some stitch 
reinforcement to help position the bead.

1 Click-stitch forward as manual run stitching.
2 Optionally, click-stitch a bead surround in manual run stitching. This 

will help ‘seat’ the upright bead.
3 Right-click in the center of the surround to drop the bead. A bead 

outline appears.

Click-stitch one 
stitch back to 
secure

Right-click to 
drop bead

Press <Enter> 
to finish

Upright
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4 Click-stitch forwards to the edge of the bead surround. This stitch is 
going through the hole and will secure the bead in the upright position.

5 Click-stitch forward as manual run stitching until you reach the point 
of the next bead surround.

6 Press Enter to finish.

Related topics...
 Select bead-capable machines
 Beading mode

Insert bead drops

In preference to the Manual Bead tool, some digitizers flesh out designs 
using Run or Motif Run and then travel through it, dropping beads 

Click-stitch to secure the
upright bead

Right-click to
drop bead

Click-stitch a bead surround
to ‘seat’ the bead drop

Press <Enter> 
to finish

Use Outline > Digitize Run to place a row of single or triple run stitches 
along a digitized line.

Use Outline Stitch Types > Motif Run to create a string of motifs along a 
digitized line.

Use Docker > Stitch List to toggle Stitch List display on and off. Use it to 
select individual stitches.

Use Travel > Travel 1 Stitch to move stitch cursor forwards/backwards 1 
stitch at a time. Left/right click.

Click Function > Insert Function to insert machine function at current stitch 
cursor position. 

Use Bead > Clear Function to remove any bead functions from the current 
needle position.
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manually as and where required. This technique can be used with single 
or multi-beads.

To insert bead drops
1 Select a machine format that supports bead mode via the Select 

Machine Format dialog.
2 Set up your bead palette – single or more – according to machine 

capabilities.
3 Set a fixed run length to suit the bead type/s you are using.

Set run length to 
suit beads
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4 Create the design or pattern you want and choose the bead or beads 
to use.

5 Optionally, open the Stitch List.
6 Press the Home button and travel through the design using arrow 

keys or Travel tools.
7 Travel to the insertion point and select Insert Function from the 

toolbar or Stitch List popup menu.

8 From the Functions list, select Drop Bead. Depending on machine 
requirements, you will either add the function to the current stitch, or 

Twin-bead 
palette available

Travel to 
insertion point
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insert it on an empty stitch or empty jump. See your machine manual 
for details.

9 When the Drop Bead function is correctly defined, click OK. The 
Select Bead dialog opens showing available beads.

10 Choose a preferred bead. The Drop Bead function, together with any 
additional empty stitches or jumps, is added at the current needle 
position.

Select Drop
Bead function

Insert additional 
empties as 
necessary

Choose preferred 
bead

Bead dropped at 
insertion point
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11 Continue traveling and inserting beads by the same method.

12 To delete a bead drop, travel to the location and click the Clear Bead 
icon.

Related topics...
 Digitizing outlines & details
 Motif runs
 Select bead-capable machines
 Travel through designs
 Insert machine functions manually

Custom bead motifs

Another technique for deploying custom bead fixings is to save them as 
motifs and use them singly or in motif runs. The Create Motif function 

Bead dropped at 
insertion point

Use Traditional Digitizing > Use Motif to add motifs to design one-by-one. 
Rotate, scale, or mirror as you add.

Use Outline Stitch Types > Motif Run to create a string of motifs along a 
digitized line.
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lets you save your own motifs for future use. Custom motifs are saved in 
custom ‘motif sets’. 

To create and save a motif
1 Create your custom bead and fixing stitch or edit an existing one.

2 Duplicate and align the motif as you want it to appear in a motif run. 
Use Alignment tools for precise arrangement.

3 Once you have determined the layout, select objects and apply 
Closest Join. Use the middle motif to determine reference points.

4 Select the motif and choose Object > Create Motif.

5 Select a custom motif set from the droplist and enter a name in the 
Motif Name field.

6 Deselect the Remove other functions option. This ensures that 
beads are preserved.

7 Click OK.

Determine 
nominal layout

Select motif set

Enter motif name

Deselect ‘Remove
other functions’

Bead 1
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8 Click two reference points for the bead motif. These should coincide 
with entry and exit points.

9 Use you custom bead and fixing in bead runs or individual placements.

Related topics...
 Custom motifs
 Selecting & placing motifs
 Motif runs

Bead encoding & decoding

In EmbroideryStudio, dedicated ‘Bead’ functions are used for bead 
designs. Analogous functions exist for sequins.

When exporting to Tajima DST file format, both ‘Drop Bead’ and ‘Drop 
Sequin’ functions are replaced by Jump codes. When exporting to DST 
format with Dahao as your selected machine format, the machine file 

Mark reference 
points

Create individual 
bead placements as 
preferred

Dedicated sequin and
bead functions in

EmbroideryStudio
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employs a modified protocol for non-standard use of Jump codes. This is 
a modified Dahao-specific DST format.

Encode beads as sequins
You do not need to be concerned with machine file encoding unless your 
design contains both sequins and beads. Since both object types are 
encoded the same way in the machine file, you need to explicitly map 
beads and sequins to respective ‘slots’ on the machine. You do this on 
output via the Save Options dialog. Droplists on the Save Options > 
Beading tab are available whenever you export as Tajima DST with 
Dahao as your current machine format.

Let’s say your design contains two (2) sequins and two (2) beads. And 
let’s say your machine is configured with sequins in Slots A and B, and 
beads in Slots C and D. On the Beading tab, Bead A must map to Sequin 
C and Bead B to Sequin D. Then the Dahao controller will be able to 
correctly distinguish sequins from beads on stitchout.
Note that this mapping is not indicated on the production worksheet since 
it only affects the machine file, not the source design file. This means the 
designer must communicate the correct mapping to the machine 

Dahao machine 
controller

Encode beads as
sequin functions
on the machine
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operator (or vice versa) according to how sequins and beads are 
configured. It is important to make sure that mappings do not intersect. 
For instance, you do not want both Bead A and Sequin A to be allocated 
to Slot A.

Note: DST files can only encode up to four (4) sequins and/or beads. This 
means that if you have, say, 3 sequins and 5 beads in the same design, 
mapping will not work. You will run out of slots.

Compensate for bead-switch delay
Some machine configurations have a specific deficiency when it comes to 
beading. Namely, they are one step late when switching beads. When 
controllers encounter a command to drop Bead X, the machine will drop 
whatever bead is in the picker and only then make the switch.
To correct the error, you must compensate by employing a ‘preemptive 
bead swap’. This will shift bead changes by one step. By ticking 
Compensate for bead swap delay, the first line becomes re-encoded 
as shown...

Note: Installation engineers will be able to advise if it is necessary to 
compensate for ‘bead shift’.

Decode sequins as beads
The Open Options dialog provides an inverse set of controls to decode 
machine files which have been encoded by means of the Save Options 
> Beading mechanism. The Open Options > Conversion Details tab 
allows you to decode sequin functions as beading when opening these 
formats using Dahao target machine.

Decode sequins
as bead functions

in the software

Restore sequence 
from bead swap 
where necessary
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Note: When you open a Tajima DST file, the software only shows the 
Standard tab. When you choose ‘Dahao’ from the machine type droplist, 
the Conversion Details tab becomes available.

Related topics...
 Select bead-capable machines
 Opening machine files
 Exporting designs for machine



EmbroideryStudio e4 Reference Manual 1251

Chapter 50

Bling Digitizing

Bling refers to decorative objects placed on garments or templates, either 
on their own or in combination with other design elements. Bling is 
supplied in varying sizes, shapes, colors and materials. It goes under 
names such as diamante, rhinestones, eyelets, ribbons, charms, crystals, 
glitz, nailheads, studs, etc. EmbroideryStudio lets you add bling to 
multi-decoration designs with the Bling toolset. This allows you to create 
and visualize bling embellishments in combination with other decorative 
elements.

Bling production processes

The Bling feature allows digitizers to create patterns of bling runs or fills 
with editing capabilities similar to those of the Sequin toolset. The single 
biggest difference between Sequin and Bling is that individual 
rhinestones are not allowed to overlap or be too close together. Another 
difference is that there is no stitching associated with bling. 
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Bling, rhinestones, crystals, and glitz are interchangeable terms referring 
to decorative objects placed on garments or templates. They are supplied 
in various sizes, shapes, colors and materials. 

There are two basic processes for creating bling designs:
 Hot-fix template production
 Direct-to-garment production

Hot-fix template production
Hot-fix templates can be produced in two ways:
 Bling template: This is the design layout on which rhinestones are 

initially placed prior to transfer. The template is created by cutters or 
engravers. Rhinestones are placed onto the template by a manual 
flood-fill process and then manually transferred to transfer tape.

 Bling transfer: In a semi-automatic process, bling is placed directly 
onto transfer tape (or sheet) by machine. Examples are IOline 
CrystalPress and CAMS machines. The bling design is ready for heat 
transfer to the final product – e.g. a T-shirt.

Direct-to-garment bling production
Direct-to-garment bling production is supported by many machines. 
Automatic rhinestone transfer machines are designed for high speed, 
high volume production. They enable users to fix any type of rhinestones, 
studs, and so forth directly to any type of fabric.

Tip: If you have neither CAMS automatic rhinestone placement machine 
nor a direct-connect cutting machine, you can use the Convert Bling for 
Production command to convert bling objects to vector shapes. These 
can be then output to vector file for use by third-party applications. See 
Outputting bling for details.

Cutting data
Cutting data sent to machine consists solely of vectors which describe the 
location, size, and shape of the bling in the template. There are no 
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connecting lines or data that do not relate directly to the placement of 
the bling. For example:

Bling templates
Bling templates must have holes cut to suit the bling size to be used. 
Below is a table of stone size to hole size. ‘SS’ stands for ‘Stone Size’. 

Stone size Hole size (mm)

SS04 1.7

SS05 1.9

SS06 2

SS07 2.3

SS08 2.5

SS09 2.7

SS10 2.9

SS12 3.2

SS16 4

SS20 5

SS30 6.5

SS34 7.3

SS40 8.7

SS48 11.4

SS60 14.3

Original 
Bling Fill

Result in CorelDRAW 
Graphics after 
conversion
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Bling toolset
The Bling toolbar contains the following tools:

Bling objects have properties like normal embroidery objects. The 
Object Properties docker contains two tabs called Bling Fill and Bling 
Run to handle these properties. Editable properties include bling type – 
size, shape color, facets – patterns, fill density, angle and layout. Bling 
features include:
 Similar functionality to the Sequin tool.
 predefined library of rhinestone shapes.
 Tools to create outline and fill patterns.
 Controls to adjust placement of stones to avoid overlaps.
 Tools to convert vector outlines to bling patterns.
 Commands to create cut files to send to cutting machine – similar to 

appliqué.
 Inclusion of bling count by size and color on production worksheet.

Setting up bling palettes

The Bling Palette Editor lets you prepare a palette of rhinestones for 
use in the current design. Once set up, the palette is available for use in 
Object Properties or from the Bling toolbar.

To define a bling palette
 Click the Bling Palette Editor icon.

Use Bling > Bling Palette Editor to select and configure rhinestone shapes 
from a pattern library.
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Fields are arranged in tabular form so that parameters for each 
rhinestone type can be viewed at once.

Note: The controls available in the Bling Palette Editor are similar 
to those available in the Sequin Palette Editor.

 Click the More button to add new entries as required.
 Use the Bling droplist to select rhinestone type and size – e.g. ‘Round 

ss12’.
The droplist displays rhinestones available for use in both runs and 
fills. The code specifies a size range displayed at the bottom of the 
popup – e.g. ‘ss12’ falls within a size range of 3.00-3.20 mm.

Click to add 
rhinestone types

Adjust bling 
dimensions

Select 
rhinestone 
shape and size

Indicates size 
range for 
selected bling
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 Edit bling colors and sizes as required. The controls are summarized 
below.

 Define a Production Type for the bling palette:
 Placement: If you have an automatic or semi-automatic machine, 

choose this option.
 Cutting: If you have a cutting machine, you will need to cut holes 

in the template material a little bigger than the rhinestone size you 
intend to use. You can set an Allowance value, say 0.04mm, for 
rhinestones to easily fit within the cut holes of the stencil.

 Set an Overcut allowance (as a percentage) as necessary. This 
determines extra distance the knife needs to travel to ensure a 

Control Function

Color Change colors by clicking the drop-arrow and accessing the 
color selection palette. Choose from a range of both standard 
and non-standard colors, or mix your own.

Size1/Size2 These are editable fields which control bling dimensions. 
Circles, squares, stars, flowers and triangles (equilateral) have 
editable width. All other shapes have both editable width and 
height. The units of measurement are determined by the user. 
See also Set measurement units.

Comment Comment is a free text field limited to a maximum of 128 
characters.

Production 
type

If you are using a cutting machine, you can adjust the ‘cutting 
allowance’ for rhinestones to easily fit the cut holes in the 
stencil. See below.

Overlap 
tolerance

Set the minimum allowable distance between stones. Once 
set, the software controls placement so that no stones are 
placed closer than this value. See also Edit bling-fill objects.

Save Save the palette to the file system for use in another session.

Adjust cutting 
allowance – e.g. 
0.04mm
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clean cut. You may need to experiment with this setting depending 
on the cutting machine you are using.

Note: Bling objects exported to a cutter retain color information, and 
cutting outlines have hairline width.

 Click OK to confirm. Rhinestone shapes are now available for use in 
Object Properties or from the Bling Manual palette.

Tip: Click Save to save bling palette to the current template. You 
might consider setting up a dedicated bling template. 

Set overcut
percentage

Overcut 
allowance

Rhinestone shapes 
available for Bling 
Manual
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Related topics...
 Setting up sequin palettes
 Bling production processes
 Create bling fills
 Working with templates

Creating bling runs & fills

The Bling feature provides tools for creating bling runs as well as fills. 
The fill can include a border, with or without a margin. You have the 
option of digitizing individual rhinestone ‘drops’ with the manual method.

Digitize bling runs

Use the Bling Run Auto method to create a string of rhinestones along 
a digitized line. There are two available types – Simple Run (same size 

Use Bling > Bling Run Auto to create a string of rhinestones along a 
digitized line according to current settings.

Use View > Show Bling to toggle bling display on/off.

Use Bling > Show Bling Work Area to visualize the design within the work 
area of the selected machine model.



EmbroideryStudio e4 Reference Manual 1259

stones) and Pattern Run (different sizes following a regular pattern). 
The system automatically generates drops according to current settings.

To digitize a bling run
1 Set up the bling palette if you haven’t already done so. 
2 Optionally, toggle on Show Bling Work Area to visualize the design 

within the work area of the selected machine model. 
3 Click the Bling Run Auto icon.
4 Digitize the line as you would for a normal run object – left-click for 

corner points, right-click for curve points. 

5 Press Enter to finish. Rhinestones are automatically generated. 
Spacings can be individually adjusted.

Bling outline

Simple bling run

Bling pattern run

Press Enter

Digitize outline – left-click corner 
points, right-click curve points
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6 Double-click the object to view properties. The Object Properties 
docker opens at the Bling Run tab.

Available controls are summarized below.

Control Function

Pattern 
Editor

Use to create bling run patterns. Click ‘+’ in the pattern editor and 
select the desired rhinestone shape from the droplist.

Positioning Place rhinestones along the curve and adjust placement to meet 
selected criteria:

Exact: places bling along curve according to specified spacing.

Expand to fit: places as many bling as possible along each curve 
segment where spacing is never less than specified. With this 
option, there are always rhinestones at each cusp point.

Compact: non-circular rhinestones are placed such that minimal 
distance between is equal to specified spacing.

Manual: allows manual distribution of rhinestones along curve.

Orientation Place rhinestones either relative to object baseline or absolute 
(fixed ‘north’) orientation.

Statistics Summary information: type, SS (stone size), color, shape, count 
(for the selected object). If multiple objects are selected, bling 
information for all selected objects is displayed.

Select run type

Hover over bling row to 
display summary 
information – type, SS 
(stone size) or actual size, 
color name, shape and 
facet

Position bling along
curve according to

selected option Orientate bling to 
object outline

Summary of bling
used in selected

object
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7 Use pattern settings as for sequin runs to create simple or variegated 
bling runs.

8 Set bling orientation to baseline or fixed angle.

Tip: The Backtrack/Repeat tool is enabled for bling-run objects.

Related topics...
 Setting up bling palettes
 Send bling to CAMS machine
 Digitizing sequin runs
 Digitizing outlines & details
 Reinforce outlines

Place rhinestones manually

You have the option of digitizing individual rhinestone ‘drops’ with the 
manual method.

Angle to baseline Angle to 
horizontal line

Use Bling > Bling Manual to digitize individual bling drops. Select from a 
user-defined palette of rhinestone shapes.
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To place rhinestones manually
 Click Bling Manual and select the bling type you want from the 

droplist. 

 Digitize individual rhinestones by left-clicking. If you make a mistake, 
press Backspace.

 Holding down the Shift key, use the handle to adjust rhinestone 
orientation as you digitize.

 Press Enter to finish.

Create bling fills

Select rhinestone

Click Bling
Manual

Use handle to 
adjust angle Press Enter

Use Bling > Bling Fill to digitize complex shapes (with or without holes) filled 
with bling.

Activate Bling > Automatic Overlap Removal if you want to automatically 
remove unwanted overlapping bling items from a bling object.

Activate Bling > No Automatic Overlap Removal if you don’t want to 
automatically remove overlapping bling items from a bling object.

Activate Bling > Highlight Bling Overlaps if you want to highlight 
overlapping bling items in a bling object – i.e. if you want to edit manually.

Use View > Show Bling to toggle bling display on/off.

Use Bling > Show Bling Work Area to visualize the design within the work 
area of the selected machine model.
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The Bling Fill feature provides a means of filling complex shapes with 
bling arranged in columns. Bling fill types include Column Fill (straight 
grid, angled grid) and Contour Fill.

Tip: You can create offset objects from bling-fill objects. All the same 
options are available as are available for embroidery objects, plus the 
ability to create bling fills and runs.

To create a bling fill
1 Optionally, toggle on Show Bling Work Area to visualize the design 

within the work area of the selected machine model.
2 Click the Bling Fill button.
3 Digitize control points for a closed object in the same way as Complex 

Fill.

4 Press Enter to close the shape. You are prompted to create another 
boundary.

5 Press Enter twice to finish the object.

Bling-fill object with 
Column Fill type 
and Follow Outlines 
enabled
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6 Double-click the object to view properties. The Object Properties 
docker opens at the Bling Fills tab.

7 Select a fill type – Column Fill or Contour Fill.

Select fill type

Adjust fill angle
Shift fill in relation to

object outline Force fill to follow 
object outlines

Select fill pattern type

Bling fill editor: Hover over 
bling row to display summary 
information – type, SS (stone 
size) or actual size, color 
name, shape and facet

Add border to
selected bling-fill

object

Set margin between bling 
border and fill

Border pattern editor: Hover 
over bling row to display 
summary information – type, SS 
(stone size) or actual size, color 
name, shape and facetOrientate bling to

object outline

Summary of bling
used in selected

object

Column Fill type Contour Fill type
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8 Adjust angles and shift as required – these settings are only available 
with Column Fill.

9 Use pattern settings as for sequin fills to create simple or multiline 
bling fills:
 For a simple fill, set the fill type to Simple and adjust pattern as 

desired.

 For a more complex, variegated fill, set the fill type to Multiline 
and adjust pattern for each line as desired.

Angle: 0°, Shift: 0.00 Angle: 45°, Shift: 0.00

Simple fill – 1 shape Simple fill – 2 shapes Simple fill – 3 shapes

Set required number 
of pattern lines

Edit line pattern as 
desired

Scroll between lines
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10 Adjust line spacing settings as required.

11 Add borders as required. See below

Tip: By default, Automatic Overlap Removal is selected in order to 
automatically remove unwanted items from overlapping bling objects. 
Choose another option if you want to manually edit rhinestone 
overlaps.

Note: Bling overlaps are determined by the Overlap Tolerance 
setting. This defines the minimum allowable distance between stones. 

Bling fill summary
Controls available on the Bling Fill tab are summarized below.

Contour fill
Line spacing: 1mm

Contour fill
Line spacing: 3mm

Contour fill
Line spacing: 5mm

No automatic overlap removal Automatic overlap removalHighlight bling overlaps

Control Description

Fill type Available fill types include: Column Fill, Contour Fill. Respectively, 
these fill a shape with columns along which patterns are repeated, or 
contours where patterns are repeated along a contoured path.
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Related topics...
 Send bling to CAMS machine
 Setting up bling palettes
 Creating sequin fills
 Creating multi-sequin fills

Layout Bling-fill objects exist in one of two ‘layout’ states: Auto and Manual. 
In the Auto state, bling fills are automatically re-generated whenever 
an object is scaled or reshaped. In the Manual state, the bling count 
does not change during transformations. See also Modifying bling 
objects.

Angle Changes the angle of the column fill. This is only applicable to 
Column Fill.

Shift Moves the entire fill pattern in relation to the object outline. This can 
be used to achieve a more even fill placement. Acceptable values are 
between ±0.5.

Follow 
outlines

Expands the space between bling in each line of fill in order to follow 
the object outline. This results in a stronger outline demarcation. It is 
only applicable to Column Fill and works in conjunction with borders. 
See Add bling borders for details.

Pattern 
editor

Use to create bling patterns as either single-line or multi-line 
patterns. Create patterns by clicking ‘+’ in the pattern editor and 
selecting bling from the palette. Multi-line patterns are created 
similarly, but each time the number of lines increases, a new tab is 
added to the pattern editor. This allows a new pattern to be added. 
See also Creating sequin fills.

Line 
spacing

Set the distance between the currently active line tab and the next 
line in the pattern. This can be the same or different for each and 
every line. By default, this value is the same for each.

Border When checked, this adds a border to any selected bling-fill object. 
You can also create a pattern for the border similarly to single-line 
patterns for bling fills.

Margin Add a margin to rhinestones forming the border. Smaller border 
margins result in a larger number of rhinestones in the fill.

Orientation Place bling in the border either relative to the object baseline or at an 
absolute (fixed ‘north’) orientation.

Statistics View the following information: type, SS (stone size), color, shape, 
count (for the selected object). If multiple objects are selected, then 
bling information will be displayed for all selected objects. You can 
re-order the columns as needed.

Control Description
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Add bling borders

Like sequin fills, bling fills can also include a border, with or without a 
margin. The border can be made from different or same rhinestones and 
is a property of the bling-fill object.

To add a border or changing border properties
1 Select the bling-fill object and tick the Border checkbox.

2 Use pattern settings to create simple or variegated bling borders.
3 Select the bling margin as required.

Add border to
selected bling-fill

object

Edit border
pattern as desired
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A border margin is created by adding an ‘offset’ to each individual 
bling item in the border. Smaller border margins result in a larger 
number of rhinestones in the fill as shown.

Related topics...
 Adding sequin borders

Modifying bling objects

Bling-fill objects can be scaled and reshaped like any embroidery object. 
When reshaping, resizing or editing an object/design, the software 
automatically recalculates the number of stones but does not resize 
them. The Bling toolset also provides tools for editing rhinestones 
individually.

Tip: Object properties for bling-run and bling-fill objects can be copied 
and applied to other objects. This is done via the Make Properties 
Current and Apply Current Properties commands.

Transform bling-fill objects

Use Select > Select Object to resize objects using selection handles.
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Bling-fill objects can be scaled and transformed like any embroidery 
object with one difference. Bling-fill objects exist in one of two ‘layout’ 
states: Auto and Manual. In the Auto state, bling fills are automatically 
re-generated whenever an object is scaled or reshaped. In the Manual 
state, the bling count does not change during transformations.

To transform a bling-fill object
 Select the bling-fill object and check the Layout setting.

 Scale as desired.

 Similarly, skew as desired.

Related topics...
 Transforming Objects

Check layout 
state

Layout: Manual
Bling count unchanged

Layout: Auto
Bling fill regenerated

Layout: Manual
Bling count unchanged

Layout: Auto
Bling fill regenerated
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Reshape bling-fill objects

When reshaping a bling-fill object you can reshape object outlines in the 
normal way. When Column Fill is applied, you can graphically change 
the fill angle and curve line as well.

To reshape a bling-fill object
 Select the bling-fill object.

 Click the Reshape icon or press the H key.
Control points appear around the object outline. If column fill is 
selected, two other control bars appear – one (orange handles) to 
control fill angle, and the other (yellow handles) to control curve lines.

 Reshape the outline in the normal way.
In this case, we adjust the outline only slightly to improve the bling fill 
coverage.

Use Select > Select Object to resize objects using selection handles.

Use Reshape > Reshape Object to reshape selected bling run objects.

Curve line 
control bar

Fill angle 
control bar

Reshape 
control points

Adjust outline to 
improve fill coverage
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 Adjust fill angle control as desired.

 Adjust curve line control as desired.
Right or left-click anywhere along the line to add curve or angle points. 
Curve line adjustments have no effect on object properties.

Edit bling-fill objects

The Bling toolset provides tools for editing rhinestones individually. The 
following operations are applicable to bling run, bling fill, and bling 
manual objects.

Drag orange bar to 
adjust fill angle

Click to create curve or 
angle point

Use Bling > Bling Edit to edit bling items individually.

Activate Bling > Automatic Overlap Removal if you want to automatically 
remove unwanted overlapping bling items from a bling object.

Activate Bling > No Automatic Overlap Removal if you don’t want to 
automatically remove overlapping bling items from a bling object.

Activate Bling > Highlight Bling Overlaps if you want to highlight 
overlapping bling items in a bling object – i.e. if you want to edit manually.
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To edit a bling-fill object
 Select the bling-fill object and click the Bling Edit icon. Selection 

handles change.

 Select rhinestones individually within the object.
Use the Ctrl key to select multiples.

 Delete or reposition selected rhinestones as desired.
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 Select rhinestones and right-click to replace by means of the popup 
menu.

 Use the same popup menu to delete or add rhinestones.
These operations are treated as manual edits. The object’s layout 
status is automatically changed to Manual. This means that bling 
count does not change during object transformations.

Tip: By default, Automatic Overlap Removal is selected in order to 
automatically remove unwanted items from overlapping bling objects. 
Choose another option if you want to manually edit rhinestone 
overlaps.

Note: Bling overlaps are determined by the Overlap Tolerance 
setting. This defines the minimum allowable distance between stones.

Convert objects to bling

Any closed object can be converted to a bling-fill object. Similarly, any 
outline object – closed or open – can be converted to bling-run.

No Automatic Overlap Removal Automatic Overlap RemovalHighlight Bling Overlaps
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To convert an object to bling
 Right-click a fill object and select Convert > Convert to Bling Fill.

 Alternatively, click the Bling Fill button on the Bling toolbar.
 Similarly right-click a run object and select Convert > Convert to 

Bling Run.

Tip: You can also create objects with the Freehand Embroidery tools 
which can be converted to bling-fill objects. 
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Creating bling lettering

Use the dedicated Bling Lettering tool to create lettering in the same 
way as embroidery lettering. Use the same properties as embroidery 
lettering. Depending on the font, you also have access to Bling Run or 
Bling Fill properties. Alternatively, various techniques exist to create 
bling text without lettering properties.

To create bling lettering
 Select the Bling Lettering tool and select a font from the Special > 

Lettering tab. For best results, use native bling fonts.

 Digitize bling lettering as you would embroidery lettering.

 Adjust properties as for embroidery lettering including size, slant, etc.
 Change font type. Use embroidery fonts or TrueType fonts with bling 

as desired. 

Use Bling > Bling Lettering to create bling lettering onscreen using native 
bling fonts, embroidery fonts, or TrueType fonts. Right-click for settings.

Bling-specific 
fonts
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 Alternatively, select an existing embroidery lettering object and 
convert to Bling Run or Bling Fill.

 Create a TrueType object and convert to Bling Run or Bling Fill.

 Create a lettering object in CorelDRAW Graphics, change to Wilcom 
Workspace, use Centerline Run Object to trace the letters, and 
convert to Bling Run.

 Depending on the font type you are using, adjust bling automatic fills 
or outlines for Bling Fill or Bling Run.

Related topics...
 Creating embroidery lettering
 Editing text
 Creating bling runs & fills

Select all objects and apply 
Centerline Run Object
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Outputting bling

EmbroideryStudio supports a number of methods for exporting bling for 
production. Options include:

The Export Multi-Decoration Files capability allows you to output files 
for multi-decoration designs. The system recognizes whether a 
component is embroidery, graphic, appliqué, or bling. 

Related topics...
 Outputting bling for production
 Exporting multiple decoration files

Output method Details

CAMS machine If you have a CAMS automatic rhinestone placement 
machine, use the dedicated CAMS connection.

Placement file Alternatively, export your bling design to YNG format to be 
read by your placement machine.

Bling cutter Send bling shapes direct to any supported cutting machine.

Vector file Convert bling shapes to vectors in order to cut bling templates.
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Chapter 51

Appliqué Embroidery

Automatically create all the stitching you need for appliqué using the 
Appliqué tools. Up to four layers of stitching – guide runs, cutting lines, 
tack stitches and cover stitches – can be generated for any appliqué 
object.

Print a copy of appliqué patterns to use in cutting out fabric pieces. Each 
piece is numbered according to the stitching sequence. You can also 
output appliqué shapes to cutter or separate file.

Creating appliqué embroidery

Use the Appliqué tools to generate all the stitching you require for 
appliqué objects. 

Tip: If you want to pre-set appliqué settings, right-click the Appliqué 
icon with no objects selected. When property values are changed, 
settings will apply to all newly created appliqué objects in the current 
session. See Working with object properties for details.

Convert vector graphics to appliqué

Use Mode > Tag as Appliqué to tag a vector object for conversion to 
appliqué.
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In CorelDRAW Graphics, the Tag as Appliqué button allows you to tag 
selected vector objects for conversion to appliqué. 

To convert a vector graphic to an appliqué object...
1 Create or open a vector graphic in CorelDRAW Graphics and select 

it.
2 Click Tag As Appliqué. The object is tagged for conversion with a thick 

dotted outline. The CorelDRAW® Object Manager also indicates which 
objects have been tagged as appliqué.

3 Click Convert Graphics to Embroidery. EmbroideryStudio 
automatically converts the vector object to appliqué and switches to 
Wilcom Workspace. 

Use Mode > Convert Graphics to Embroidery to convert selected graphics 
to embroidery and switch to Wilcom Workspace.

Object appears 
with thick dotted 
outline

Red appliqué cover 
stitch generated

Fill color remains the 
same
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Note: When present, vector fill properties are maintained in Wilcom 
Workspace to give the appearance of a fabric patch. Otherwise, fills 
are rendered in gray.

Note: The success of the conversion can be affected by font size as a 
proportion of cover stitch width. Where the cover stitch is too thick for 
the resulting object, it may be ignored.

Related topics...
 Adjusting appliqué settings
 Cut appliqué shapes

Digitize appliqué objects

Pattern fill Texture fillGrey fill

Use Appliqué > Appliqué to digitize appliqué objects with up to four layers 
of stitching – guide runs, cutting lines, tack stitches, and cover stitches.

Use Appliqué > Appliqué without Holes to digitize single-boundary appliqué 
objects with up to four layers of stitching – guide runs, cutting lines, tack 
stitches, and cover stitches. 
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Use Appliqué to produce the stitching you 
require for appliqué objects. Up to four 
layers of stitching – guide runs, cutting 
lines, tack stitches and cover stitches – can 
be generated. When you stitch out an 
appliqué object, the machine stops 
between layers. Appliqué also allows you 
to set a frame-out position which shifts the 
hoop from under the needle, making it 
easier to place and trim appliqué patches.

To digitize appliqué objects
1 Click the Appliqué icon and digitize the boundary of the shape. Follow 

the prompts. If you make a mistake, press Backspace to delete the 
last reference point.

Tip: If you only need to create a single-boundary appliqué object, you 
may prefer to use the Appliqué without Holes tool.

2 Press Enter to close the shape. You can create another appliqué object 
at this stage.

3 Press Enter again.
4 Click the outline to set entry and exit points or press Enter to accept 

defaults.
5 If prompted to do so, mark the frame-out position or press Enter to 

accept the default.
Frame-out commands are specified as a Stop function or Color 
Change respectively. They can be set after guide run and/or tack 
stitch.

Mark frame-out 
position
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6 Press Enter. Up to four layers of stitching – guide run, cutting line, 
tack and cover – are generated, depending on current settings.

7 Double-click the appliqué object to check the settings.

8 Adjust settings as required:

Satin cover stitch

Zigzag tack stitch

Guide run and cutting line

Adjust fabric 
swatch settings

Adjust tack stitch 
settings

Adjust cover stitch 
settings

Adjust guide run 
settings
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 Fabric swatch: See Add fabric swatches to appliqué for details.
 Guide run: See Adjust guide run settings for details.
 Tack stitch: See Adjust tack stitch settings for details.
 Cover stitch: See Adjust cover stitch settings for details.

9 Optionally, apply Smart Corners to appliqué objects.
10 Optionally, run Stitch Player or use the travel tools to check the 

appliqué stitching sequence.

Related topics...
 Embroidery digitizing
 Adjust frame-out positions
 Controlling corner stitching
 Viewing stitching sequence
 Cut appliqué shapes

Convert embroidery objects to appliqué

You can convert complex fill and other objects to appliqué by adding 
entry, exit points and frame-out position. 

To convert embroidery objects to appliqué
1 Right-click an object and select Convert and the icon from the popup 

menu.

Select to convert 
to appliqué 
object
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2 Click the outline to set the stitch entry and exit points or press Enter 
to accept the defaults. 

3 Mark a frame out position or press Enter to accept the default.
The object is converted and stitches regenerated.

Related topics...
 Cut appliqué shapes

Adjusting appliqué settings

Whether you create appliqué from scratch using the Appliqué tool, or 
convert existing vector graphics or Complex Turning objects, 
EmbroideryStudio produces all the stitching you need. Up to four layers 
– guide runs, cutting lines, tack stitches and cover stitches – can be 
generated. Each of these layers can be adjusted via Object Properties. 

When you stitch out an appliqué object, the machine stops between 
layers. EmbroideryStudio also allows you to pre-set a frame-out 
movement which shifts the hoop from under the needle, making it easier 
to place and trim appliqué shapes.

Tip: If you want to pre-set appliqué settings, right-click the Appliqué 
icon with no objects selected. When property values are changed, 
settings will apply to all newly created appliqué objects in the current 
session. See Working with object properties for details.

Frame-out 
position

Entry and exit 
points

Complex 
Turning object

Satin cover stitch

Zigzag tack stitch

Guide run and cutting line



Chapter 51   Appliqué Embroidery 1286

Add fabric swatches to appliqué

EmbroideryStudio lets you select a fabric swatch for appliqué objects. 
The swatch becomes a property of the object. Choose from amongst the 
included ‘factory’ swatches or choose a scanned sample of the fabric you 
want to use. Use the Show Appliqué Fabric toggle to turn it on or off.

Adjust guide run settings

The guide run is the first layer to be stitched and is used to position 
appliqué fabric on the background material. An extra cutting line can be 
added if the fabric is to be trimmed in position. You can also specify a 
frame-out movement in order to place the appliqué patch.

Right-click Appliqué > Appliqué to choose fabric swatch for selected 
appliqué objects.

Use View > Show Appliqué Fabric to toggle the appliqué fabric display 
on/off.

Click to choose 
fabric swatch for 
selected objects

Right-click Appliqué > Appliqué to adjust guide run settings.

Right-click Appliqué > Appliqué without Holes to adjust guide run settings.
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To adjust guide run settings
 Double-click the appliqué object to access object properties.

 Select a cutting method:

Option Function

Pre-cut No cutting line is generated. This assumes you have a pre-cut 
appliqué patch ready to be placed in position.

Trim-in-place An additional cutting line is generated.

Select cutting 
method
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A cutting line allows trim the fabric after the cutting line has been 
stitched.

 Optionally, adjust Stitch length and Offset values in the Guide Run 
panel. A negative offset moves the guide run within the outline, a 
positive value moves it outside.

 Optionally, set a Frame Out after the guide run in order to place the 
appliqué patch. Depending on the machine you are working with – 
multi-head or single-head – the frame-out command must be 
specified as a Stop function or Color Change respectively.

Related topics...
 Adjust frame-out positions
 Digitize appliqué objects

Guide run 

Cutting line

Tack stitches

Cover stitches

Offset: 1 mm Offset: -1 mm Offset: 0 mm
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Adjust tack stitch settings

Tacking is used to fix appliqué shapes to a background fabric before cover 
stitching is applied. You can adjust settings or omit this layer altogether. 
You can also specify a frame-out movement in order to trim the appliqué 
patch.

To adjust tack stitch settings
 Double-click an appliqué object to access object properties.

 In the Tack panel, select a tack stitch type from the droplist. 
Alternatively, select None.

Right-click Appliqué > Appliqué to adjust tack stitch settings.

Right-click Appliqué > Appliqué without Holes to adjust tack stitch settings.

Select tack stitch type

Adjust tack stitch 
spacing

Run tacking Zigzag tackingE Stitch tacking
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 Adjust tack stitch settings according to selected stitch type:

 Optionally, adjust Offset values. A negative offset moves the tack 
stitch inwards relative to the guide run. A positive value moves it 
outwards.

 Optionally, set a Frame Out after the tack stitching in order to trim 
the appliqué patch. Depending on the machine you are working with 
– multi-head or single-head – the frame-out command must be 
specified as a Stop function or Color Change respectively.

Adjust cover stitch settings

Option Function

Length Stitch length value for Run stitch.

Runs E Stitch only. Number of runs between stitches.

Spacing Stitch spacing value for E Stitch and Zigzag.

Count Number of stitch repetitions for Zigzag only.

Width Column width value for Zigzag and E Stitch.

Offset Run stitch only. Negative offset value moves the tack stitching 
within the outline, a positive value moves it outside.

Zigzag spacing: 
3mm

Zigzag spacing: 
1.5mm

Negative offset Positive offsetNo offset

Right-click Appliqué > Appliqué to adjust cover stitch settings.

Right-click Appliqué > Appliqué without Holes to adjust cover stitch 
settings.
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The cover stitch is generally the satin border around the appliqué shape. 
However, you don’t have to include it. Optionally, you can change the 
cover stitch type to zigzag, E stitch or raised satin. You can also adjust 
width and offset relative to other appliqué components.

To adjust cover stitch settings
 Double-click an appliqué object to access object properties.
 Optionally, turn off cover stitching via the checkbox.

 Adjust cover stitch Width as preferred.

 Optionally, adjust Offset values. A negative offset moves the border 
inwards relative to the tack stitch. A positive value moves it outwards.

Adjust cover stitch 
settings

Cover stitch width:
1.5mm

Cover stitch width: 
3.0mm

Positive offset

Negative offset
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 For more or less dense cover stitching, change stitch types via the 
Object Properties > Fill tab. Adjust Spacing values accordingly.

Adjust frame-out positions

When stitching out appliqué objects, you can set a frame-out position 
after the guide run and/or tack stitch. This shifts the hoop out from under 
the needle, making it easier to place and trim the appliqué. Depending 
on the machine you are working with – multi-head or single-head – the 
frame-out command must be specified as a Stop function or Color 
Change respectively. 

To adjust the frame-out position
 Select the object and click the Reshape Object icon.

Change cover 
stitch type

Right-click Appliqué > Appliqué to adjust frame-out settings.

Right-click Appliqué > Appliqué without Holes to adjust frame-out settings.

Use Reshape > Reshape Object to reposition frame-out marker.
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Control points appear along with the Reshape Views toolbar. 
Appliqué objects include a frame-out position marker. Show 
Entry/Exit Points must be activated to view it.

 Click and drag the frame-out marker to the required position.

 If you are using Object Properties, the Frame Out panel lets you 
specify frame-out coordinates in relation to the top center of the 
design, which is the zero point.

Related topics...
 Reshaping embroidery objects

Frame-out 
zero point

Frame-out 
position marker

Click and drag 
frame-out position 
marker
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Combining appliqué

When you come to combine more than one appliqué object in the one 
design, you will encounter issues to do with overlapping objects and 
appliqué sequencing. EmbroideryStudio provides tools to help.

Create partial cover appliqué

You can create appliqué objects with partial cover stitching without 
doubling-up borders with Partial Appliqué. In combination with the 
Remove Overlaps tool, you can remove all underlying stitching.

Use Appliqué > Appliqué to digitize partial cover appliqué objects.

Right-click Appliqué > Appliqué without Holes to digitize partial cover 
appliqué objects.

Use Appliqué > Partial Appliqué to create partial cover stitching for 
overlapping appliqué objects.

Use Appliqué > Remove Overlaps to remove underlying layer of stitching 
in overlapping objects using the selected object as a ‘cutter’. Right-click for 
settings.
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To create partial cover appliqué
 Digitize appliqué shapes with Appliqué.

 If you only want to remove underlying cover stitching, select both 
objects and click Partial Appliqué. Cover stitches are generated in a 
clockwise direction between start and end points, leaving the rest of 
the boundary unstitched.

Appliqué objects 
overlap

Underlaying 
cover stitching 
removed
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 If you want to remove all underlying stitching, first select the ‘cutter’ 
object and select Arrange > Remove Overlaps or right-click the 
tool.

 Set the cutting overlap to half the width of the cover stitching – e.g. 
2mm – and click OK.

 Select all objects and click Partial Appliqué to remove underlapping 
cover stitching.

Set the overlap to 
half the width of the 
cover stitching

Underlying 
stitching 
removed

Unwanted cover 
stitching 
removed
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 Remove any unwanted fragments and zoom in to check the overlaps.

Related topics...
 Digitize appliqué objects
 Removing underlying stitching

Resequence appliqué components

The Combine Appliqué Components tool breaks multiple appliqué 
objects into their components – guide runs, cutting lines, tack stitches 
and cover stitches – and combines and resequences them for efficient 
stitchout. The end result is that the guide run of all appliqué objects is 
stitched in one pass, followed by the tack stitch and then cover stitch. A 
single frame-out movement occurs after guide run and tack stitch 
components.

Cover stitching 
removed at 
overlaps

Use Appliqué > Combine Appliqué Components to break apart multiple 
appliqué objects into component objects and combine and resequence 
them for efficient stitchout.
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To resequence appliqué components
1 Select a group of appliqué objects. The Combine Appliqué 

Components tool is activated.

2 Click Combine Appliqué Components. A message box warns that 
the appliqué objects will be broken apart and recommends that you 
save the design before proceeding.

3 Click OK to confirm. The selected appliqué objects are broken apart 
and same components – guide runs, cutting lines, tack stitches and 
cover stitches – combined and resequenced.

Outputting appliqué

Print a copy of appliqué patterns to use in cutting out fabric pieces. 
Alternatively, use Send to Appliqué Cutter to send appliqué shapes 
from a design file to a laser cutter. 

Each appliqué 
object digitized and 
stitched out in its 
entirety

Thread colors of each 
appliqué object recombined 
and resequenced for 
efficient stitchout
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Tip: CorelDRAW Graphics also lets you output objects as a vector file. 
This can then be downloaded to a laser cutter using CorelDRAW® 
Graphics Suite. For a full description of the CorelDRAW® Graphics Suite 
tools, refer to the electronic User Guide available via the MS Windows® 
Start > Programs group. Alternatively, use the onscreen help available 
from the Help menu.

Related topics...
 Print appliqué patterns
 Cut appliqué shapes
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Chapter 52

Multi-Decoration Output

Designs digitized in EmbroideryStudio and CorelDRAW® can be output in 
a variety of ways, both via the Wilcom Workspace and CorelDRAW 
Graphics. 

Firstly, EmbroideryStudio provides a ‘one-stop-shop’ for the output of 
mixed decoration. The Export Multi-Decoration Files capability allows 
you to output multi-decoration components for various processes. It can 
provide:
 Direct input to required machines – the most efficient method – or
 A file format which can be used by the machine’s supporting software.
This feature is accessed via a menu command in both Wilcom 
Workspace and CorelDRAW Graphics – File > Export 
Multi-Decoration Files.
For machines that support direct connection, there are two commands:
 File > Send to Appliqué Cutter
 File > Send to Bling Cutter
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In order to output all multi-decoration components, it may be necessary 
to use more than one of these commands. 


Multi-decoration types

In addition to normal embroidery (including sequins), the mixed 
decoration export capability supports all the following types of media, 
both singly and in combination.

Print designs

In the context of multi-decoration design, a portion may need to be 
output to a printing process for inclusion on the article. This component 
may be referred to as ‘print’ or ‘graphics’. The most commonly used 
commercial printing processes are:
 Screen printing
 Sublimation
 Direct-to-garment (DTG)
 Heat-transfer printing

Direct-to-garment
Direct-to-garment printing is handled like most other printing from a PC: 
The print image is sent to the DTG printer through the MS Windows® 
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print manager via a print driver. The image generally has a transparent 
background for DTG printing. DTG printing requires heat fixing to make 
the garment washable.

Sublimation
Sublimation printing is similar to DTG printing but the process uses solid 
inks which give a more even gradation of color compared to the liquid 
inks used in DTG printing. With sublimation printing, inks are printed onto 
a release paper and then transferred to fabric or other surface.
Sublimation means a change from a solid to gaseous state and back to a 
solid without becoming liquid. Thus dye particles migrate from the paper 
as a gas, to bond with a polymer – fabric or other material – and become 
solid again. The transfer is effected using high heat (205°C) and 
pressure, thus guaranteeing that the image penetrates and becomes an 
integral part of the substrate.

Screen printing
Screen printing is a more complex process than DTG, requiring the 
creation of a screen for each ‘spot color’ making up the design. Spot or 
‘direct’ colors can be identified as a special ink or Pantone or other. There 
may be multiple screens for each one, depending on how the design is 
layered.

Heat-transfer printing
A fourth process, which is less likely to be used in the garment industry, 
employs heat transfer paper. Graphics are printed and then heat-fixed to 
a substrate using an iron or heat-press. Printers that support heat 
transfer media generally provide an automatic mirror function as the 
image must be mirrored in order to be heat-transferred to the substrate. 
Heat-transfer is the preferred process for point-of-merchandising 
substrates or media such as mugs, pens, etc. 

Related topics...
 Outputting designs as images
 Virtual embroidery

Appliqué designs

Appliqué is a decoration or ornament made from cut pieces of one 
material applied to the surface of another. Pieces may be fixed to one 
another using an embroidered border of satin, raised satin, or none. 
Appliqué cutting is supported in EmbroideryStudio by outputting vectors 
that describe the appliqué material. The information can be sent directly 
to a supported MS Windows® cutter or output to printed templates for 
manual cutting of appliqué shapes.
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Related topics...
 Appliqué Embroidery

Bling designs

Bling, rhinestones, crystals, and glitz are interchangeable terms referring 
to decorative objects placed on garments or templates. They are supplied 
in various sizes, shapes, colors and materials. There are two basic 
processes for creating bling designs:
 Hot-fix template production
 Direct-to-garment production

Hot-fix template production
Hot-fix templates can be produced in two ways:
 Bling template: This is the design layout on which rhinestones are 

initially placed prior to transfer. The template is created by cutters or 
engravers. Rhinestones are placed onto the template by a manual 
flood-fill process and then manually transferred to transfer tape.

 Bling transfer: In a semi-automatic process, bling is placed directly 
onto transfer tape (or sheet) by machine. Examples are IOline 
CrystalPress and CAMS machines. The bling design is ready for heat 
transfer to the final product – e.g. a T-shirt.

Direct-to-garment bling production
Direct-to-garment bling production is supported by many machines. 
Automatic rhinestone transfer machines are designed for high speed, 
high volume production. They enable users to fix any type of rhinestones, 
studs, and so forth directly to any type of fabric.

Tip: If you have neither CAMS automatic rhinestone placement machine 
nor a direct-connect cutting machine, you can use the Convert Bling for 
Production command to convert bling objects to vector shapes. These 
can be then output to vector file for use by third-party applications. See 
Outputting bling for details.

Related topics...
 Bling Digitizing
 Send bling to CAMS machine

Printing designs in CorelDRAW Graphics

To send a multi-decoration design to production, you generally print the 
digital art design before stitching the embroidery. To do this, you first 
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need to hide the embroidery because you don’t want it printing on the 
digital art printer.

Note: EmbroideryStudio includes as standard the entire suite of 
CorelDRAW® Graphics Suite drawing tools which offer many techniques 
for drafting outlines and shapes on screen. Refer to the electronic User 
Guide available via the MS Windows® Start > Programs group. 
Alternatively, use online help available from the Help menu.

To print a design in CorelDRAW Graphics
1 Switch to CorelDRAW Graphics. 
2 Toggle off Show Embroidery to hide any embroidery objects. 
3 Click the Print icon on the Standard toolbar. The Print dialog opens.
4 Adjust print settings as required and click Print Preview button to 

preview. Otherwise click Print button to print.
The design is printed with or without embroidery objects showing 
depending on whether the Show Embroidery button is toggled on or 
off.

5 To sew embroidery over top of the printed design, switch to Wilcom 
Workspace and toggle off Show Graphics. 

Tip: Make sure you align the needle with a manually digitized start and 
end point to ensure that stitching aligns with the digitally printed part 
of the design. 

Related topics...
 Operating modes

Stitching should align 
on garment with 
digitally printed part 
of design
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 Viewing design components
 Send designs to Stitch Manager
 Setting auto start & end

Exporting embroidery as vectors

Once digitized in EmbroideryStudio, embroidery designs can be output as 
vectors. These can be opened in CorelDRAW Graphics. This can serve 
various purposes such as appliqué cutting, multimedia, screen printing, 
and so on. The Export Design as Vector command exports whole 
designs or selected objects only. Included bitmaps will remain as bitmaps 
in the resultant file.

To export embroidery as vectors
1 Open the embroidery design for export.
2 Optionally, select particular objects for export.
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3 Choose File > Export Design as Vector.

4 Choose a file format – EPS or EMF – and export location.
5 Once saved, open in CorelDRAW Graphics or third-party application 

for further processing.

Related topics...
 Creating vector shapes in EmbroideryStudio
 Loading vector artwork

Choose file format
and export

location
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 Visualizing vector graphics

Exporting multiple decoration files

EmbroideryStudio allows all multi-decoration components to be exported 
as file formats suitable for the particular process or machine. Apart from 
embroidery, EmbroideryStudio supports design output for a number of 
related and sometimes complementary decoration processes. Namely, 
bling (rhinestone) designs, printed designs, as well as appliqué designs.

Export design components

The Export Multi-Decoration Files capability allows you to output files 
for multi-decoration designs. The system recognizes whether a 
component is embroidery, graphic, appliqué, or bling. This, in turn, helps 
to increase the profitability of ‘quantity 1’ articles. It can provide:
 Direct input to supported machines, as this is the most efficient 

method, or
 A file format which can be used directly by the machine’s supporting 

software.

Note: If the printer, appliqué, or bling machine is directly supported, this 
procedure is not required. For example, cutting appliqués or outputting 
bling templates have their own procedures.

To export design components
1 Open the multi-decoration design you want to output.

Use Standard > Export Multi-Decoration Files to export all design 
components requiring different production processes.
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2 Click the Export Multi-Decoration Files icon.

3 Select Export Current Design if you want to output all design 
objects.
This is the default option and, unless you have pre-selected certain 
objects for inclusion, the only option.

4 Optionally, select the multi-decoration components you want to export 
by ticking the relevant checkbox in the Elements pane.

5 If you have selected Bling as one of your export components, 
optionally select Multiple Files or Single File.
When Multiple Files is selected, different bling types – i.e. by size, 
color, and/or shape – will be output to separate files. Multiple file 

Output all available
design objects

Optionally, select
specific design

components

Adjust export location
as necessary

Name export files if
different to design file

name
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output is important for the manual flood-fill method of creating 
rhinestone templates.

Tip: Depending on your cutting machine, you may choose to export 
cutting outlines only. Preset in the Bling Palette Editor. Bling objects 
exported this way retain color information, and cutting outlines have 
hairline width.

6 For each component, select required file types from the droplist. 
If you select an embroidery format, an associated Options button 
may be enabled. For bling, you can choose AI format for 
semi-automatic machines. For any other cutting machines, you can 
save directly to CDR format.

7 Optionally, click the Options button if available.
If no options are set, the system uses default options for each file 
format. If a selected file type is PNG, design components are exported 
with transparency on. Defaults are as follows:
 Color mode: RGB color (24Bit)
 Transparency: On

1

2

3



Chapter 52   Mult i-Decoration Output 1310

 Anti-alias: On
 Maintain aspect ratio: On
 Resolution: 300 DPI
The default DPI setting can be changed via the CorelDRAW Options 
dialog.

8 Select an export location:
 Export to set locations (the default): preset locations for 

different files. In some production environments, each file is placed 
in a network location where it can be used by the operator of that 
process.

 Export to: specify a location for all files – e.g. external USB stick. 
Folders are rarely changed once established, but occasionally they 
may need to be adjusted or temporarily overridden. 

9 Optionally, enter a filename to be used by all selected multi-decoration 
components. If no filename is entered, the system will use the design 
filename by default.

10 Click Export. The system writes all selected components to their 
specified location/s.
 If no file types have been selected, the Locations dialog will 

display. You can set default file types at this stage or cancel out.
 If files have the same file extension and location, filenames will be 

created with a component suffix.

Change bitmap file 
export resolution as 
required
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 If a file/s already exists in target folder/s, the system will give you 
the option to overwrite, skip, or cancel the process.

 If the embroidery file output contains team names, the system will 
display the team names Output Option dialog.

Related topics...
 Exporting multiple decoration files
 Set export locations
 File naming conventions
 Embroidery file formats
 Supported machine types
 Output to bling cutter
 Cut appliqué shapes
 Setting up bling palettes
 Outputting teamname designs

Set export locations

In some production environments, each file is placed in a specific location 
where it can be used by the operator of that process. For example, the 
Tajima Machine Network requires all files to be placed in a specific folder 
so they can be seen directly by the machine. Similarly, file formats used 
in any given process do not change unless the process changes – for 
example, if a machine is replaced. Use the following procedure when you 
want to set export defaults for the Export Multi-Decoration Files 
process.

Use Standard > Export Multi-Decoration Files to export all design 
components requiring different production processes.



Chapter 52   Mult i-Decoration Output 1312

To set export locations
1 Run the Export Multi-Decoration Files procedure.

2 To set or change the default multi-decoration file export settings, click 
the Locations button.

3 Select file locations via the browse (...) button for each design 
component.

4 Click OK to finish.
Once set, your settings are remembered for each successive session. 

Tip: Preset locations can be overridden for one-off exports – e.g. to 
USB stick – by means of the Export to option.

Related topics...
 Export design components

Set default file 
export locations

Default file 
export locations

Override preset 
locations
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Export selected objects

On occasion, you may want to export only selected objects from your 
multi-decoration design. The Export Multi-Decoration Files capability 
allows you to pre-select objects in the design window.

To export selected objects
1 Open or create a multi-decoration design.
2 Select the individual objects you want to export. In the example 

below, we will export the word ‘Cheerleading’ only.

3 Click the Export Multi-Decoration Files icon.

4 Select the Export Selected Objects Only option. This checkbox will 
appear only if you have selected objects in the design window.

Use Standard > Export Multi-Decoration Files to export all design 
components requiring different production processes.

Select ‘Export
Selected Objects

Only’
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5 Make location adjustments as necessary and click Export. Only 
selected objects are exported to file.

Related topics...
 Export design components

File naming conventions

By default, the Design name field will take the current design name – 
e.g. ‘Design1’. You can change it if you wish. This name is applied to all 
files exported with the Export Multi-Decoration Files dialog.

If exported files for any components have the same selected file 
extension and location, the file name will be automatically suffixed as 
follows:

Example
The single multi-decoration file – ‘Design1.EMB’ – contains embroidery, 
graphic, appliqué, and bling components. Depending on chosen file 
types, you will see file names of the following kind:

Design Element Suffix

Embroidery _EMB

Graphics _GFX

Appliqué _APQ

Bling _BLG (for a single file)

Design Element File Type File Name

Embroidery Wilcom EMB Design1_EMB.EMB

Graphic CorelDRAW Design1_GFX.CDR

Appliqué AutoCAD Design1_APQ.DXF

Default file name
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Bling multi-file output
When bling objects in a design contain rhinestones of different size, 
shape, and/or color, and the Multiple Files output option is selected in 
the Settings dialog, files will take a suffix of the following form:
 <filename>_SSx_<color>
 <filename>_SSx_<color>_<shape_name>
 <filename>_<color>_<shape_name>_<XxY>
For example, consider a design with the following bling types:

Tip: The print preview shows which rhinestones are in which file.

Related topics...
 Embroidery file formats
 Output to bling cutter

Outputting appliqué for production

Print a copy of appliqué patterns to use in cutting out fabric pieces. 
Alternatively, use Send to Appliqué Cutter to send appliqué shapes 
from a design file to a laser cutter. 

Tip: CorelDRAW Graphics also lets you output objects as a vector file. 
This can then be downloaded to a laser cutter using CorelDRAW® 
Graphics Suite. For a full description of the CorelDRAW® Graphics Suite 
tools, refer to the electronic User Guide available via the MS Windows® 
Start > Programs group. Alternatively, use the onscreen help available 
from the Help menu.

Print appliqué patterns

Print appliqué patterns for use in cutting out fabric pieces. Each piece is 
numbered according to stitching sequence. One copy of placement 

Bling Adobe Illustrator Design1_BLG.AI

Bling type Output filename

Navette 8 x 4mm with color Emerald Design1_Emerald_Navette_8x4.PLT

Flower SS16 with color Crystal Design1_SS16_Crystal_Flower.PLT

SS04 with color Aquamarine Design1_SS04_Aquamarine.PLT

Design Element File Type File Name
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outlines is printed at 100% scaling, with each outline separated for use 
in cutting the fabric.

To print an appliqué pattern
1 Create or open an appliqué design.

2 Select File > Print Preview and click the Options icon.

3 Select Appliqué Patterns report type.

Select
appliqué

patterns report
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4 Set General options and click OK. Each appliqué pattern is numbered 
according to the stitching sequence. Stitch count and colors are 
displayed.

5 Click Print Now to output appliqué shapes to printer.

Related topics...
 Customizing design reports

Cut appliqué shapes

EmbroideryStudio can extract outlines from a design and send them to a 
laser cutter. This procedure is employed when the cutter is supported 
directly by a MS Windows® driver. Only shapes defining the actual 
appliqué fabric are sent. 

Note: Before you send appliqué shapes to a cutter, make sure it is set up 
on your system with the correct MS Windows® (printer) driver. Some 
cutters – e.g. Ioline – use a standard driver for HP-7475 plotters. Once 
the driver is installed in MS Windows®, there is no need for a separate 
hardware setup in EmbroideryStudio.

Use Standard > Send to Appliqué Cutter to send appliqué shapes from 
design file to laser cutter.
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To output appliqué shapes
1 Create or open an appliqué design.

2 Click Send to Appliqué Cutter or select File > Send to Appliqué 
Cutter.

3 From the Name list, select the appliqué cutter. For more information, 
refer to the User Manual of the particular cutter you are using.

Click to preview
worksheet
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4 Click Preview to preview the pattern. The Print Preview dialog 
opens showing every appliqué shape in the order of the stitching 
sequence.

5 Click Print Now to output appliqué shapes to cutter.

Outputting bling for production

EmbroideryStudio supports a number of methods for exporting bling for 
production. Options include:

Note: The Export Multi-Decoration Files capability allows you to 
output files for multi-decoration designs. The system recognizes whether 
a component is embroidery, graphic, appliqué, or bling. See also 
Exporting multiple decoration files.

Caution: Bling designs can be saved to earlier versions of EMB. However, 
bling objects will convert to vector objects.

Output method Details

CAMS machine If you have a CAMS automatic rhinestone placement 
machine, use the dedicated CAMS connection.

Placement file Alternatively, export your bling design to YNG format to be 
read by your placement machine.

Bling cutter Send bling shapes direct to any supported cutting machine.

Vector file Convert bling shapes to vectors in order to cut bling templates.
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Send bling to CAMS machine

EmbroideryStudio supports direct connection to CAMS automatic 
rhinestone placement machines. A general procedure is outlined below.

Note: Before executing the procedure, it is important that the machine 
drivers for your CAMS machine be properly installed. They need to be 
installed and the machine connected before setting up the COM port. 
Refer to your machine documentation.

To select bling machine
1 Select the machine you want to connect to via the Setup > Bling 

Machine Setup command.

2 In the Model panel, select the machine model you are using.
3 Activate the Bling Work Area to visualize the design within the work 

area of the selected machine model.

Use Bling > Show Bling Work Area to visualize the design within the work 
area of the selected machine model.

Use Standard > Send to Connection Manager to connect to supported 
machines via proprietary machine software.

Select your 
machine model
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4 Set the color of the work area as desired.

To send to Connection Manager
1 From the Standard toolbar, click the Send to Connection Manager 

button.

2 From the Connection Manager droplist, select ‘CAMS’.
3 Click the Setup button. The CAMS Setup dialog opens.

Select ‘CAMS’

Check communications 
port and baud rate 
settings
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4 Check the communications port and baud rate settings. 
If you are using an ‘old school’ serial connection, the COM port in the 
software should match the port to which the cable is connected. If you 
are using a USB connection, the COM port in EmbroideryStudio must 
match the ‘virtual’ COM port assigned to it. You can find this in 
Windows Control Panel > Device Manager.

If you are using a USB connection and the COM port is not available 
for selection in EmbroideryStudio, you need to verify that your 
hardware drivers have been correctly installed and are up-to-date. 
Check your machine documentation for details.
The baud rate in EmbroideryStudio must match the baud rate at which 
the machine was configured to read the data. This is normally 57600 
(the system default). However, you can confirm the value when you 
prepare the machine to receive data. The baud rate will be displayed 
on the machine console.
The model will default to the machine selected via the Setup > Bling 
Machine Setup function. You can change it here if required.

If using a USB connection, 
COM port setting must 
match ‘virtual’ COM port 
assigned to it
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5 Click OK. The Send to CAMS Machine dialog opens.

6 Use this dialog to assign bling in the design to the available feeders on 
the CAMS machine.

7 Prepare the machine to receive data and click the Send button.

Caution: If you try to send something before the machine is ‘Ready’, 
it may fail to read the next design.

To export to bling placement file
 If your placement machine is not directly connected to the PC, use the 

Export Machine File option to output to Yongnam YNG format. This 
can loaded onto the machine via memory stick.

Assign bling to 
available feeders on 
CAMS machine

Select YNG format
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Suggested workflow
The precise workflow you follow will depend on the number of feeders 
available on the selected machine. For example, if you have a machine 
with two feeders which is currently set up to feed SS6 on Feeder #1 and 
SS10 on Feeder #2, and wish to output a design which contains SS6, 
SS8, SS10, you may do so like this:
 Drag SS6 to Feeder #1.
 Drag SS10 to Feeder #2.
 Prepare the machine for download.
 When the machine is ‘Ready’ for download, click Send.
 When the machine has finished receiving the file, run the machine to 

place all the SS6 and SS10 stones.
 Once the run is completed on the machine, replace the SS6 feeder on 

the machine with the SS8 feeder.
 In the software, drag SS8 to Feeder #1 (where you had previously 

dragged the SS6).
 Prepare the machine for download again.
 When the machine is again ‘Ready’, click Send.
 When the machine has finished receiving the file, run it in order to add 

the SS8 stones to the design already containing the stones from the 
previous run.

Depending on the number of bling types used in the design and number 
of available feeders, you may need to send bling more than once. You will 
be prompted if you exit before all bling has been sent to machine.

Related topics...
 Send designs to Connection Manager

Output to bling cutter

Use Standard > Send to Bling Cutter to send vectors for any bling in a 
multi-decoration design to a supported cutting machine.
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The Send to Bling Cutter function sends vectors for any bling in a 
multi-decoration design directly to a cutting machine. Use it with any 
bling template cutter supported by MS Windows®.

To output to a bling cutter
1 Open or create a multi-decoration design. A cutting or engraving 

machine must be connected to the PC and configured to receive data.
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2 Click the Send to Bling Cutter icon or select File > Send to Bling 
Cutter. The Send to Bling Cutter dialog opens.

3 Select your bling cutter from the droplist or select a suitable printer.
4 Select the Print to file option if you want to print the design to file.
5 Click Properties and check your output settings.
6 For a realistic view click the Preview button.

Select bling
cutter or suitable

printer

Click to preview
printable parts of

design

Select if you 
want to print 
to file
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Note: In multi-bling designs, each color is separated into different 
templates for flood-filling.

7 Click OK to send the bling templates to bling cutter or to file.
The bling cutting/engraving information is sent to machine in the 
required format. The machine cuts the desired template/s. The cutting 
data consists solely of vectors which describe the location, size, and 
shape of the bling in the template. There are no connecting lines or 
data that do not relate directly to bling placement.

Tip: A bling production summary shows stone colors, sizes, and 
quantities as well as a summary on the first page.

Related topics...
 Set up machines
 Print reports
 Customizing design reports

Convert bling for production

If you have neither CAMS automatic rhinestone placement machine nor 
a direct-connect cutting machine, you can use the Convert Bling for 
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Production command to convert bling objects to vector shapes. These 
can be then output to vector file for use by third-party applications.

Once converted, individual bling shapes can be exported as a printable 
file – for example, EMF or EPS – via the File > Export Design as Vector 
command. This in turn can be imported into cutting software as a bling 
template.

If your software level supports CorelDRAW Graphics, you can export the 
vector shapes to other formats, including SVG, FCM, DXF, and many 

Convert bling for
production

Single bling 
object

Export converted
bling shapes as

vectors

Converted bling
shapes
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others. These too can be used to cut a template sheet for bling design. 
Switch to CorelDRAW Graphics and use the File > Export command.

Note: The Export Multi-Decoration Files capability allows you to 
output files for multi-decoration designs. The system recognizes whether 
a component is embroidery, graphic, appliqué, or bling. See also 
Exporting multiple decoration files.

Converted 
bling shapes

Export converted 
bling shapes as 
vectors
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PART XII
PRODUCT DIFFERENTIATION TABLE
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Product differentiation table
The Product Differentiation Table below itemizes features which are relevant to each product model. The 
EmbroideryStudio e4 product suite consists of these product models:

While every effort has been made to maintain the Product Differentiation Table up to the current release, late 
changes may not be precisely reflected. For purchasing advice, please visit the website or talk to a Wilcom 
representative.

Product models Capabilities Applications

1 ES Designing ^ Professional digitizing and graphic design, lettering, and editing. It 
supports the full range of optional ES Elements. Some are 
included as standard.

Larger logo embroidery businesses with 
digitizing

2 ES Digitizing * Professional embroidery digitizing. Fashion and textile production digitizing

3 ES Decorating ^ Professional lettering, customization and editing. Auto-digitizing 
and simple manual digitizing. Includes some ES Elements.

Small embroidery shops – replaces 
DecoStudio

4 ES Editing Full lettering, customization, editing, with machine connections. Logos, retail shops, production shops

5 ES Lettering Full lettering, customization, with machine connections. Logos, retail shops

^ Includes CorelDRAW® Graphics Suite as standard. * Only available in certain countries.

● Included as standard  ○ Modular ‘Element’  L Limited functionality ^ New to ES e4 * Improved in ES e4

Capability Feature Product models Reference

1 2 3 4 5

Basics Basic Procedures

Switch design modes CorelDRAW 
Graphics * ● ● Operating modes

Access Design Library Design Library ^ ● ● ● ● ● Design library
View object properties Object Properties ● ● ● ● L Access object properties
Select machine format * ● ● ● ● ● Embroidery machine formats
Open embroidery design file * ● ● ● ● ● Open designs

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering
● Included as standard  ○ Modular ‘Element’  L Limited functionality ^ New to ES e4 * Improved in ES e4

https://www.wilcom.com/Products.aspx
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Create design based on template New from Template ● ● ● ● ● Create designs from templates
Save embroidery design file Save Design * ● ● ● ● ● Save & close designs
Send design as email attachment ● ● ● ● ● Send designs as email attachments
Select design objects * ● ● ● ● L Selecting objects
Display grids, rulers and guides Show Rulers & 

Guides * ● ● ● ● ● Display grids, rulers & guides

Set measurement units ● ● ● ● ● Set measurement units
Measure distances on screen ● ● ● ● ● Measure distances on screen

View designs Viewing Designs

View embroidery components ● ● ● ● ● View embroidery components
View graphical components * ● ● ● ● ● View graphical components
Zoom and pan across designs Zoom * ● ● ● ● ● Zoom & pan designs
View multiple designs * ● ● ● ● ● Set up multiple views
Show design in Overview window Overview Window ● ● ● ● ● Work with the Overview Window
Simulate design stitchouts Stitch Player * ● ● ● ● ● Simulate design stitchouts
Travel through designs Travel Tools ● ● ● ● ● Travel through designs
Show multiple colorways Current Colorway ● ● ● ● ● Switch colorways
Change backgrounds and display 
colors

Background & 
Display Colors * ● ● ● ● ● Change backgrounds

View color blocks and design objects Color-Object List ● ● ● ● View selected color blocks
View design repeats Show Repeats ● ● ● ● ● Viewing design repeats
View design details Design Information * ● ● ● ● ● Viewing design information
View design report Print Preview * ● ● ● ● ● Preview design reports

Manage threads Threads & Charts

Select thread colors Color palette * ● ● ● ● ● Select thread colors
Assign thread colors * ● ● ● ● ● Assign thread colors
Edit thread colors ● ● ● ● ● Edit thread colors
Create & modify thread charts ● ● ● ● ● Managing thread charts

Capability Feature Product models Reference

1 2 3 4 5

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering
● Included as standard  ○ Modular ‘Element’  L Limited functionality ^ New to ES e4 * Improved in ES e4



P
ro

d
u

c
t d

iffe
re

n
tia

tio
n

 ta
b

le
1333

System settings System Settings

Set view options ● ● ● ● ● View options
Set grid options ● ● ● ● ● Grid display options
Mouse scroll/zoom control ● ● ● ● ● Scroll options
Set reshape options ● ● ● ● ● Reshape options
Set automatic save and backup 
options

● ● ● ● ● Automatic save & backup options

Set pointer position display ● ● ● ● ● Pointer position display
Set inserted embroidery file options ● ● ● ● ● Thread color handling for inserted 

files
Set paste & duplicate options * ● ● ● ● ● Paste & duplicate options
Set digitizing tool options * ● ● ● ● ● Digitizing presets
Set toolbar display options ^ ● ● ● ● ● Toolbar display options
Set Object Property ‘apply’ options ● ● ● ● ● Object property apply options
Set other general options ● ● ● ● ● Other general options
Set warning options ● ● ● ● ● Warning options

Hardware Hardware Settings

Connect to machine via Connection 
Manager

Connection 
Manager

● ● ● ● ● Setting up machines for Connection 
Manager

Connect to machine via Stitch 
Manager

Stitch Manager ● ● ● ● ● Setting up machines for Stitch 
Manager

Perform runtime estimates Runtime Analyst ● ● ● ● ● Doing runtime estimates
Connect to scanner ● ● ● Setting up scanners
Connect to digitizing tablet ● ● Connecting digitizing tablets

Machine formats Machine Formats

Modify standard machine formats ● ● ● ● ● Standard machine formats
Adjust advanced machine format 
settings (color change sequence, 
start/end design, speed)

● ● ● ● ● Advanced machine formats

Capability Feature Product models Reference

1 2 3 4 5

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering
● Included as standard  ○ Modular ‘Element’  L Limited functionality ^ New to ES e4 * Improved in ES e4
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Create custom machine formats ● ● ● ● ● Custom machine formats

Stitch types Stitch Types

Create simple outline stitching Run, etc * ● ● ● ● L Simple outlines
Create ‘sculpture’ runs (bead 
stitching)

Sculpture Run * ● ● Sculpture run settings

Create decorative outlines Backstitch, 
Stemstitch * ● ● Decorative outlines

Create satin borders and fills Satin, Raised Satin * ● ● L L L Satin stitching
Create tatami borders and fills Tatami * ● ● ● L L Tatami stitching

Digitize shapes Digitizing Shapes

Digitize with graphical tools Graphics Digitizing * ● ● ● Digitizing with graphical tools
Digitize outlines and details Digitize Run, etc * ● ● ● ● ● Digitizing outlines & details
Digitize regular columns Column C * ● ● Digitizing regular columns
Digitize irregular columns Column A/B * ● ● Digitizing irregular columns
Create free-form shapes Complex Turning / 

Complex Fill * ● ● Creating free-form shapes

Object properties Object Properties

Modify current property settings ● ● ● ● ● Change current settings
Change object properties ● ● ● ● ● Change object properties
Make selected object properties 
current

Make Properties 
Current 

● ● ● Copy properties

Change & manage fabrics Auto Fabric ● ● ● ● ● Working with fabrics
Define & apply styles Styles ● ● Working with styles
Create design templates Save as Template * ● ● ● ● ● Create design templates

Colorways Colorways

Add colorways Colorway Editor * ● ● ● ● ● Add colorways
Change color schemes Color Wheel ^ ● ● Change color schemes
Name design elements ● ● ● ● ● Name design elements
Split color blocks Split Palette Color ● ● ● ● ● Split color blocks

Capability Feature Product models Reference

1 2 3 4 5

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering
● Included as standard  ○ Modular ‘Element’  L Limited functionality ^ New to ES e4 * Improved in ES e4



P
ro

d
u

c
t d

iffe
re

n
tia

tio
n

 ta
b

le
1335

Set backgrounds Background & 
Display Colors * ● ● ● ● ● Set fabric backgrounds

Visualize products Product Visualizer * ● ● ● ● ● Visualize products

Productivity tools Productivity Techniques

Add decorative borders to designs Add Borders * ● ● ● ● ● Add design borders
Create embroidered stars & rings Star/Ring ● ● Digitize stars & rings
Digitize basic shapes Basic Shapes ^ ● ● Digitize basic shapes
Add or remove holes in objects Add Holes ^ ● ● ● Add & remove holes
Fill holes in objects Fill Holes ● ● ● Fill holes
Create simple offsets Simple Offsets ● ● ● Simple offsets
Create multiple offset outlines & 
offsets

Outlines & Offsets * ○ ○ ○ Create outlines & offsets

Create offsets with open objects Open Offsets ^ ○ ○ Create offsets with open objects
Create automatic wreaths Mirror-Merge * ○ ○ Mirroring & reflecting selections
Create design arrays Mirror-Merge Array * ○ ○ Creating design arrays

Combine & sequence objects Combining Objects

Combine objects and designs – copy, 
paste, clone, etc * ● ● ● ● ● Combining objects & designs

Group & lock objects Group/Lock ● ● ● ● Grouping & locking objects
Select objects by color or stitch type * ● ● ● ● Selecting objects by color or stitch 

type
Resequence embroidery objects ● ● ● ● Sequencing embroidery objects
Auto-sequence entire design Optimize Color 

Changes ^ ● ● ● ● Auto-sequence entire designs

Transform objects Transforming Objects

Position, align & distribute objects ● ● ● ● ● Arranging objects
Scale objects ● ● ● ● ● Scaling objects
Rotate objects Rotate ● ● ● ● ● Rotating objects
Skew objects Skew ● ● ● ● ● Skewing objects

Capability Feature Product models Reference

1 2 3 4 5

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering
● Included as standard  ○ Modular ‘Element’  L Limited functionality ^ New to ES e4 * Improved in ES e4
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Mirror objects Mirror ● ● ● ● ● Mirroring objects

Reshape objects Reshaping Objects

Reshape embroidery objects Reshape Object ● ● ● ● L Reshaping embroidery objects
Reshape star & ring objects Reshape Object ● ● ● ● Reshaping stars & rings
Apply envelopes to embroidery 
objects

Envelopes * ● ● ● ● ● Applying envelopes

Break apart branched objects Break Apart ● ● ● ● Break apart composite objects
Cut shapes manually Knife ● ● ● Cut shapes manually
Cut shapes automatically Automatic Knife ● ● ● Cut shapes automatically
Shape vector / embroidery objects – 
merging, splitting, trimming, etc

Shaping Tools ○ ○ Shaping objects

Stitches & machine functions Stitches & Machine Functions

Insert, move or delete individual 
stitches

Stitch Edit ● ● ● ● ● Selecting & editing stitches

Split embroidery objects Split Object ● ● ● ● Splitting objects
Insert/edit/clear machine functions Insert Function ● ● ● ● ● Editing machine functions
Edit stitches and functions with Stitch 
List

Stitch List ● ● ● ● Edit machine functions manually

Digitize individual stitches Manual ● ● Digitizing manual stitches
Convert selected stitches to objects Process Stitches ● ● Converting stitches to objects

Underlays & pull compensation Underlay & Pull Compensation

Apply automatic underlay Auto Underlay * ● ● ● ● ● Stabilizing with automatic underlay
Apply underlay by shape Auto Underlay ● ● ● ● ● Underlay by segment or by shape
Create slanted zigzag & double 
zigzag underlay

● ● ● ● ● Zigzag underlay settings

Apply pull compensation Pull Compensation ● ● ● ● ● Compensating for fabric stretch

Stitch quality Optimizing Stitch Quality

Reverse stitch direction Reverse Curves ● ● Reverse stitch direction
Reinforce outlines Backtrack / Repeat * ● ● Reinforce outlines

Capability Feature Product models Reference

1 2 3 4 5

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering
● Included as standard  ○ Modular ‘Element’  L Limited functionality ^ New to ES e4 * Improved in ES e4
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Remove underlying stitching Remove Overlaps * ● ● ● Removing underlying stitching
Adjust stitch angles Stitch Angles * ● ● ● Adjusting stitch angles
Adjust stitch density Process Stitches ● ● Adjusting stitch densities
Remove small stitches automatically Small Stitches ● ● ● ● ● Eliminating small stitches
Control corner stitching Smart Corners * ● ● L L L Controlling corner stitching
Reduce stitch bunching Shortening ● ● ● ● ● Reducing stitch bunching
Split long stitches Auto Split ● ● ● ● ● Split satin stitches
Preserve long stitches Auto Jump ● ● ● ● ● Preserve long stitches

Embroidery connectors Embroidery Connectors

Apply automatic connectors Connectors ● ● ● ● ● Using automatic connectors
Add tie-offs & trims manually Tie Off * ● ● ● ● ● Adding connectors manually
Keep/omit last stitches Keep/Omit Last 

Stitch
● ● Keeping or omitting last stitches

Adjust entry/exit points Show Entry/Exit ● ● ● ● L Adjust entry/exit points
Apply closest join Closest Join ● ● ● ● L Apply closest join
Automatic object sequencing Branching ● ● Automatic branching

Patterned stitching Patterned Stitching

Create textures with Tatami offsets Tatami Offset ● ● ● ● L Creating textures with tatami offsets
Create textures with program splits Program Split ● ● Creating textures with program splits
Create custom splits User-Defined Split ○ ○ User-defined splits
Create custom stitch patterns Carving Stamp ○ ○ Creating patterns with carving 

stamps

Curved stitching Curved Stitching

Create contoured stitching Contour * ○ ○ Contoured fills
Create offset fills Offset Fill ^ ○ ○ Offset fills
Create spiral fills Spiral Fill ^ ○ ○ Spiral fills
Create radial fills Radial Fill ^ ● ● Radial fills
Create textures with flexi-splits Flexi Split ○ ○ Flexi-splits

Capability Feature Product models Reference

1 2 3 4 5

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering
● Included as standard  ○ Modular ‘Element’  L Limited functionality ^ New to ES e4 * Improved in ES e4
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Create curved fills Florentine Effect / 
Liquid Effect ○ ○ Curved fills

Motif stitching Motif Stitching

Place single motifs Use Motif ○ ○ Selecting & placing motifs
Create motif runs Motif Run ○ ○ Motif runs
Create graded motif runs Motif Run ^ ○ ○ Create graded motif runs
Create motif fills Motif Fill L L L Motif fills
Create 3D effects with motif fills 3D Warp ○ ○ Enveloped motif fills
Create graded motif columns Motif Column ^ ○ ○ Create graded motif columns
Create motifs & motif sets ○ ○ Custom motifs

Specialty stitching Specialty Stitching

Create freehand embroidery Freehand 
Embroidery * ● ○ Freehand embroidery

Create jagged edges Jagged Edge ● ● Jagged edges
Create zigzag and E-stitch borders 
and fills

Zigzag, E Stitch * ● ● ● Decorative borders

Create textures with stippling Stipple ○ ○ Stippling effects
Create open stitching with trapunto Trapunto ● ● ● Trapunto open stitching
Create accordion spacing effects Accordion Spacing ○ ○ Accordion spacing
Create color blending effects Color Blending ○ ○ Color blends
Create string stitching String ^ ○ ○ String stitching
Create chenille-type patterns Square, Coil * ● ● Chenille patterns
Create cross stitch fills Cross Stitch ○ ○ Cross stitch fills

Embroidery lettering Embroidery Lettering

Create lettering in CorelDRAW 
Graphics

CorelDRAW 
Graphics ● ● Creating lettering with CorelDRAW 

Graphics
Create lettering in Wilcom WorkspaceLettering * ● ● ● ● ● Creating embroidery lettering
Format lettering – italic, bold, justified, 
etc ● ● ● ● ● Adjusting lettering properties

Capability Feature Product models Reference

1 2 3 4 5

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering
● Included as standard  ○ Modular ‘Element’  L Limited functionality ^ New to ES e4 * Improved in ES e4
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Add baselines – horizontal, vertical, 
arc, circle, custom ● ● ● ● ● Working with baselines

Edit lettering text Lettering ● ● ● ● ● Editing text
Scale and transform lettering objects ● ● ● ● ● Modifying lettering
Adjust individual letters – reposition, 
transform, reshape, recolor ● ● ● ● ● Adjusting individual letters

Adjust and reshape baselines ● ● ● ● ● Adjusting baselines
Break apart lettering Break Apart ● ● ● ● Breaking apart lettering
Add special characters Insert Symbol ● ● ● ● ● Adding special characters
Set lettering stitch types – Satin, 
Tatami, etc

Stitch Types ● ● ● ● ● Applying stitch types & effects to 
lettering

Create special effects with lettering 
art

Lettering Art ^ ● ● ● ● ● Creating special effects with lettering 
art

Adjust lettering stitching sequence Letter Sequence ● ● ● ● ● Adjust letter sequencing
Change lettering join method Letter Sequence ● ● ● ● ● Change lettering join method
Automatic letter kerning Auto Kerning ● ● ● ● ● Setting automatic letter kerning
Apply automatic letter spacing Auto Letter Spacing ● ● ● ● ● Setting automatic letter spacing
Apply lettering underlay Auto Underlay ● ● ● ● ● Setting lettering underlay

Team names & monograms Team Names & Monogramming

Add multiple names to designs Team Names * ● ● ● ● ● Creating simple teamname designs
Create teamname templates Team Names * ○ ○ ○ Teamname templates
Output team-name designs Team Names ● ● ● ● ● Outputting teamname designs
Create monogram designs Monogramming * ● ● ● ● ● Monogramming

Custom lettering Custom Lettering

Convert TrueType fonts to embroidery 
fonts

Convert TTF * ○ ○ Converting TrueType fonts to 
embroidery

User-refined letters ● ● ● ● ● Creating user-refined letters
Create custom fonts ○ ○ Creating custom fonts
Merge fonts ● ● ● ● ● Merging fonts

Capability Feature Product models Reference

1 2 3 4 5

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering
● Included as standard  ○ Modular ‘Element’  L Limited functionality ^ New to ES e4 * Improved in ES e4
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Lettering kiosk Lettering Kiosk

Configuration options for supervisors ● ● ● ○ ○ Configuration options for supervisors
Create custom design layouts ● ● ● ○ ○ Creating custom design layouts

Digitize with bitmaps Digitizing with Bitmaps

Insert / paste bitmap images Import Graphic ● ● ● ● ● Insert bitmap images
Crop bitmap images Crop Bitmap * ● ● ● Crop bitmap images
Edit bitmap images in third-party 
applications ● ● ● Touch up bitmaps

Smooth bitmap images ● ● ● ● ● Smooth bitmap images
Save artwork CorelDRAW 

Graphics ● ● Save artwork

Prepare artwork for auto-digitizing Prepare Bitmap 
Colors * ● ● ● Preparing images for auto-digitizing

Add and match image colors Add Bitmap Colors ● ● ● ● ● Add & match image colors

Digitize with vectors Digitizing with Vectors

Create vector outlines and fills Drawing Tools * ● ● ● Creating vector shapes in 
EmbroideryStudio

Color vector objects ● ● ● Color vectors
Insert / paste vector graphics Import Graphic ● ● ● L L Loading vector artwork
Convert artwork to vector graphic Auto Trace To 

Vectors ● ● ● Auto-tracing bitmap artwork

Smooth curves Smooth Curves ● ● Smoothing curves
Show/hide vector graphics ● ● ● ● ● Visualizing vector graphics

Automatic digitizing Automatic Digitizing

Inter-convert graphics and 
embroidery objects

CorelDRAW 
Graphics ● ● Convert objects with CorelDRAW 

Graphics
Convert between embroidery objects 
– Run, Column C, etc.

Convert ● ● ● Converting designs with CorelDRAW 
Graphics

Digitize shapes with Auto-Digitizing Auto-Digitizing ● ● ● Auto-digitize individual shapes

Capability Feature Product models Reference

1 2 3 4 5

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering
● Included as standard  ○ Modular ‘Element’  L Limited functionality ^ New to ES e4 * Improved in ES e4
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Match palette colors to an image Color Matching 
Method * ● ● ● Auto-digitize individual shapes

Convert bitmaps with Smart Design Smart Design * ● ● ● Auto-digitize entire designs
Auto-digitizing bitmap and vector 
shapes

Auto-Digitizing ● ● ● Auto-digitize individual shapes

Convert photos to line embroidery Photo Flash ○ ○ ○ Auto-digitize with Photo Flash
Convert photos to ‘coral’ embroidery Reef PhotoStitch ^ ○ ○ ○ Auto-digitize with Reef PhotoStitch
Convert photos to color embroidery Color PhotoStitch ^ ○ ○ ○ Auto-digitize with Color PhotoStitch

Design management Design Management

View designs in network folders ^ ● ● ● ● ● Viewing designs in network folders

Open designs from Design Library Design Library ^ ● ● ● ● ● Opening designs from 
Design Library

Insert designs with Embroidery 
Clipart Embroidery Clipart ^ ● ● Inserting designs with 

Embroidery Clipart
Search for designs ^ ● ● ● ● ● Searching the library
Manage folders ^ ● ● ● ● ● Adding folders to the library

Manage design information ^ ● ● ● ● ● Viewing & managing design 
information

Manage job orders ^ ● ● ● ● ● Managing quotes & orders
Convert designs ^ ● ● ● ● ● Converting designs
Output selected designs ^ ● ● ● ● ● Outputting selected designs

Design hooping Design Hooping

Set up custom hoop lists ● ● ● ● ● Setting up hoop lists
Set auto start & end ● ● ● ● ● Setting auto start & end
Select hoops automatically Auto Hoop ● ● ● ● ● Selecting hoops automatically
Select hoops manually Show Hoop * ● ● ● ● ● Selecting hoops manually
Create custom hoops ● ● ● ● ● Creating custom hoops

Capability Feature Product models Reference

1 2 3 4 5

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering
● Included as standard  ○ Modular ‘Element’  L Limited functionality ^ New to ES e4 * Improved in ES e4
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Embroidery output Embroidery Output

Send designs to Connection ManagerConnection 
Manager ● ● ● ● ● Send designs to Connection 

Manager
WiFi USB machine networking EmbroideryConnect ^ ● ● ● ● ● Send designs to EmbroideryConnect
Send designs to Stitch Manager Stitch Manager ● ● ● ● ● Send designs to Stitch Manager
Export designs for machine * ● ● ● ● ● Exporting designs for machine
Read/write embroidery disk ● ● ● ● ● Using embroidery disks
Send designs to Machine Manager ● ● ● ● ● Machine Manager Supplement

Design reports Design Reports

Output designs as images ● ● ● ● ● Outputting designs as images
Print/plot design reports * ● ● ● ● ● Printing design reports
Save or send design as PDF ^ ● ● ● ● ● Printing design reports
Customize report information * ● ● ● ● ● Customizing design reports
Print multiple colorways ● ● ● ● ● Customizing design reports
Print color blocks ● ● ● ● ● Customizing design reports

Machine files Machine Files

Convert machine files to EMB format ● ● ● ● ● Opening machine files
Open/save designs in Melco CND 
format ● ● ● ● ● Reading Melco CND design files

Color merge Melco CND files ● ● ● ● ● Create a color-merge TXT file
Reassign colors to stitch / CND files ● ● ● ● ● Reassigning colors to machine files

Machine networking EmbroideryConnect Machine Networking

EmbroideryConnect setup ● ● ● ● ● EmbroideryConnect setup
Basic device settings ● ● ● ● ● Basic device settings
Advanced device settings ● ● ● ● ● Advanced device settings

Send designs to EmbroideryConnect ● ● ● ● ● Sending designs to 
EmbroideryConnect

Capability Feature Product models Reference

1 2 3 4 5

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering
● Included as standard  ○ Modular ‘Element’  L Limited functionality ^ New to ES e4 * Improved in ES e4
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Chenille embroidery Chenille Chenille Embroidery

Digitize for chenille ○ ○ Digitizing for chenille
Visualize chenille stitching ○ ○ Visualizing chenille stitching
Open & save chenille designs ○ ○ Open & save chenille designs
Create compound chenille ○ ○ Creating compound chenille
Create chain-stitch fills ○ ○ Creating chain-stitch fills
Create narrow chenille shapes ○ ○ Creating narrow chenille shapes
Create chenille borders ○ ○ Creating chenille borders
Control needle heights ○ ○ Controlling needle heights
Add lettering to chenille designs ○ ○ Adding lettering to chenille designs
Chenille machine formats ○ ○ Chenille machine formats
Output chenille designs ○ ○ Outputting chenille designs

Mixed decoration Mixed Decoration

Save designs as ‘virtual decoration’ Virtual embroidery ● ○ ● Virtual embroidery
Add cording Cording ^ ● ● Cording
Boring Manual ● ● Boring

Sequins Sequin Embroidery

Select sequin mode ○ ○ Selecting sequin mode
Visualize sequin designs ○ ○ Visualizing sequin designs
Set up custom sequin palette ○ ○ Setting up sequin palettes
Create sequin runs Sequin Run ○ ○ Digitizing sequin runs
Change sequin fixings ○ ○ Sequin fixings
Create multi-sequin runs Sequin Run ○ ○ Creating multi-sequin runs
Create sequin fills Sequin Fill * ○ ○ Creating sequin fills
Create multi-sequin fills Sequin Fill * ○ ○ Creating multi-sequin fills
Scale & reshape sequin fills ○ ○ Editing sequin fills
Pattern stamp re-coloring of 
twin-sequin fills ^ ○ ○ Flip sequins

Convert objects to sequins ○ ○ Converting objects to sequins

Capability Feature Product models Reference

1 2 3 4 5

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering
● Included as standard  ○ Modular ‘Element’  L Limited functionality ^ New to ES e4 * Improved in ES e4
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Digitize individual sequins Sequin Manual ○ ○ Manual sequin digitizing
Create custom sequins ^ ○ ○ Custom sequins

Beading Bead Embroidery

Set up beading mode ^ ○ ○ Beading mode
Create bead runs Bead Run ^ ○ ○ Creating bead runs
Change bead fixings ^ ○ ○ Bead fixings
Edit bead runs ^ ○ ○ Editing bead runs
Digitize individual beads Manual Bead ^ ○ ○ Manual bead digitizing

Bling Bling Digitizing

Set up bling palettes Bling ● ○ ● Setting up bling palettes
Create bling runs and fills Bling ● ○ ● Creating bling runs & fills
Add bling borders Bling ● ○ ● Add bling borders
Place rhinestones manually Bling ● ○ ● Place rhinestones manually
Modify bling objects Bling ● ○ ● Modifying bling objects
Create bling lettering Bling ● ○ ● Creating bling lettering

Appliqué Appliqué Embroidery

Convert vector graphics to appliqué Convert Graphics to 
Embroidery ● ● Convert vector graphics to appliqué

Create appliqué designs Appliqué * ● ● ● Creating appliqué embroidery
Add fabric swatches to appliqué 
objects Appliqué ● ● ● Add fabric swatches to appliqué

Create partial appliqué shapes Partial Appliqué ● ● Create partial cover appliqué
Recombine and resequence multiple 
appliqué for efficient stitchout

Combine Appliqué 
Components ● ● ● Combining appliqué

Multi-decoration output Multi-Decoration Output

Print designs in CorelDRAW GraphicsCorelDRAW 
Graphics ● ○ ● Printing designs in CorelDRAW 

Graphics
Export embroidery as vectors ● ● ● Exporting embroidery as vectors
Export multi-decoration files ● Exporting multiple decoration files

Capability Feature Product models Reference

1 2 3 4 5

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering
● Included as standard  ○ Modular ‘Element’  L Limited functionality ^ New to ES e4 * Improved in ES e4
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5

Print / cut appliqué patterns Appliqué ● ● ● Outputting appliqué for production
Output bling for production Bling ● ○ ● Outputting bling for production

Capability Feature Product models Reference

1 2 3 4 5

1 ES Designing 2 ES Digitizing 3 ES Decorating 4 ES Editing 5 ES Lettering
● Included as standard  ○ Modular ‘Element’  L Limited functionality ^ New to ES e4 * Improved in ES e4
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Quick reference

There are two fundamental design modes in 
EmbroideryStudio:

Wilcom Workspace
This mode allows you to create and edit 
embroidery objects using the embroidery 
digitizing toolset.

CorelDRAW Graphics
This mode allows you to create and edit 
vector objects using the CorelDRAW® 
Graphics Suite toolset. For a detailed 
description of the CorelDRAW Graphics 
interface, refer to the electronic User Guide 
available via the MS Windows® Start > 
Programs group. Alternatively, use the 
online help available from the Help menu.

EmbroideryStudio menus

The EmbroideryStudio design window menu 
bar contains the pulldown menus described 

below. Some commands are also available 
as toolbar buttons.

Tip: Standard MS Windows® Alt key 
shortcuts apply. Use the Alt key with the 
letter underlined in the menu. To cancel an 
operation, press Esc twice.

File menu

Menu bar

Status / Prompt bars

Mode tools

Standard tools

Object properties
docker

Color tools

Docker tabs

Design window

View tools

Toolbox

‘Floating’ toolbar

Stitch Effects tools

Stitch Types tools

Graphic style and
traditional input

methods

Design tabs

New design Create new blank design based on 
a fabric or template.

New from 
template

Create new design from a 
template. 

Open design Open existing design. 
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Edit menu

Open recent Most recently used files listed – 
select to open file.

Open backup 
design

Opens directly onto the backup 
folder for quick access to backup 
files in case of software failure.

Close Close current design window.

Close all Close all open design windows.

Save Save current design.

Save as Save current design with a 
different name, location or design 
file format.

Save as 
template

Save current design as a design 
template for future use.

Save as 
monogram 
template

Save current design as a 
monogram template for future use 
with the Monogramming tool.

Save as 
teamname 
template

Save current design as a 
teamname template for future use 
with the Team Names tool.

Export 
machine file

Convert current design to a 
machine format other than your 
selected machine.

Print Print the current design.

Print preview Display design 
worksheet/approval sheet – print 
from preview window.

Import 
embroidery

Insert one design into another to 
create combined design. Color 
palettes are also combined. 
Colors with same RGB values are 
automatically identified as having 
the same thread color.

Import graphic Import artwork into current design 
as a backdrop for manual or 
automatic digitizing.

Scan graphic Scan images directly into 
EmbroideryStudio.

Export design 
as vector

Save design as vectors in EMF or 
WMF format.

Export 
multi-decoratio
n files

Export mixed decoration design 
components as file formats for use 
by control software or machine.

Record in 
database

If you have DesignWorkflow 
installed, record an open design to 
the database.

Capture 
design bitmap

Save design image as bitmap 
exactly as it appears on screen.

Capture virtual 
decoration 
bitmap

Output high resolution digital print 
TrueView for ‘virtual embroidery’.

Send via email Send design as email attachment.

Export design 
properties

Output current design information 
and machine runtime settings to 
CSV file.

Send to 
Connection 
Manager

Connect to supported machines 
via proprietary machine software.

Send to 
Embroidery 
Connect

Send current design to named 
EmbroideryConnect device.

Queue design Send current design to 
EmbroideryConnect design queue 
to be ‘pulled’ from machine.

Send to 
appliqué cutter

Send appliqué shapes from 
design file to laser cutter.

Send to bling 
cutter

Send vectors for any bling in any 
multi-decoration design to a 
supported cutting machine. 
Configure the machine via Setup.

Cross stitch Access Cross Stitch application.

Exit Close all open designs and exit 
program.

Undo Undo previous action.

Redo Redo previously undone action.

Cut Cut selection and place on 
Clipboard.

Copy Copy selection and place on 
Clipboard.

Paste Paste contents of Clipboard. 
Options available in Options > Edit 
tab.

Paste after 
selected

Override current defaults and 
paste directly after selected object 
in the stitching sequence.

Paste special 
>

Override current Paste setting and 
select from paste options available 
in Options > Edit tab.

Duplicate Duplicate selected objects within 
the design (rather than copy to 
clipboard).
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View menu

Design menu

Duplicate with 
offset

Duplicate an object with an offset. 
Adjust settings via the Options > 
Edit dialog. 

Delete Delete selected objects.

Select / 
deselect all

Select or deselect all objects in a 
design.

Select by 
color / stitch 
type

Select all objects of the same color 
or same stitch type.

Close curve 
with straight 
line / curve 
line

Close an open outline with a 
straight or a curved line.

Reverse > Control push-pull effect by 
reversing stitch direction – affects 
stitching direction of Jagged Edge, 
Contour Stitch and E Stitch objects. 
Can also affect Tatami offsets, as 
well as Flexi Split and Motif Run 
orientation.

Smooth 
curves

Apply curve ‘smoothing’ to both 
embroidery and vector objects.

Transform > Transform selected objects using 
combination of reference points 
and numeric values. Rotate 
selected objects with aid of 
reference points alone.

Envelope > Apply Bridge, Pennant, 
Perspective, and Diamond effects 
to lettering objects.

TrueView Toggle between normal (stitch) 
view and TrueView™.

Show >
Access same design viewing 
commands as available on View 
toolbar.

Hoop Show / hide hoop display.  

Hoop 
template

Show hoop template as an 
alternative to grid lines, in order to 
align design at correct location and 
orientation.

Show grid Toggle on/off grid display.

Show rulers & 
guides Toggle on/off rulers and guides. 

Zoom > Zoom in to selected area of the 
design.

Zoom 1:1 Display design at actual size.

Zoom factor Set precise viewing scale.

Zoom in / out 
1.25x

Zoom in and out in smaller 
increments to ‘slow down’ 
mouse-wheel scrolling.

Zoom in / out 
2x

Display design at twice/half current 
size.

Zoom to fit
Display whole design or only 
selected embroidery objects in 
design window.

Zoom to 
selected

View selected objects in the design 
window.

Zoom to 
product

View entire product in the design 
window.

Zoom to hoop View entire hoop in the design 
window. 

Pan Pan across the current design.

Previous view Return to previous view.

Center 
current stitch

Center the design window at the 
current stitch cursor position.

Measure Measure distance between two 
points on screen.

Stitch player Simulate embroidery design 
stitchout on screen.

View by color View embroidery objects by color – 
e.g. when resequencing objects.

View all 
colors

Show all colors after activating 
View by Color.

View by 
machine 
function >

View machine Chenille and Schiffli 
functions – Chain/Moss, 
Stepp/Blatt, etc.

Refresh 
screen Refresh screen display.

Design 
properties

Display design information such as 
size and number of stitches, and 
add comments to print to 
worksheet.

Select 
machine 
format

Select machine format 
corresponding to embroidery 
machine you intend to use.

Machine 
format 
settings

Define values to encode when 
outputting to a specific machine 
format.
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Object menu

Arrange menu

Function menu

Auto fabric Change current fabric type and 
associated settings.

Auto hoop Prompt system to select a suitable 
hoop from My Hoops list.

Background 
& display 
colors

Access Background & Display 
Colors dialog for background 
colors, swatches, and product 
templates.

Auto start & 
end

Access automatic design start/end 
settings.

Remove 
small stitches

Automatically remove unwanted 
small stitches.

Repeats

Use in combination with the Show 
Repeats tool to access settings for 
use with continuous and 
overlapping designs.

Design 
repeat

Same as Repeats command but 
only works for Schiffli machines.

Make 
properties 
current

Make properties of a selected 
object current for the design.

Apply current 
properties

Apply current settings to selected 
objects.

Apply favorite 
style

Assign up to 10 favorite styles via 
Manage Styles. Select object and 
click button to apply.

Apply style Apply predefined style to selected 
objects.

Use for 
Florentine / 
Liquid effect

Make guidelines for Florentine or 
Liquid effects.

Create motif Add individual motifs to a design. 
Save own motifs for future use.

Create 
program split

Turn embroidery or drawing objects 
into patterns for use in Program 
Split fills.

Create letter Access command used in custom 
fonts. See Custom Lettering for 
details.

Create 
user-refined 
letter

Save a reshaped letter as a 
‘user-refined letter’. Only available 
when selected in Reshape mode.

Update 
kerning 
settings

Update kerning settings for 
contiguous pairs of selected letters 
of the same font. Only available 
when Automatic Kerning is in use. 

Create 
sequin shape

Define your own sequin shapes 
with their own hole position and 
size. Save to a custom sequin 
library.

Create 
sequin fixing

Define custom fixing stitches to 
support multi-head sequin devices.

Set color Change color of consecutive 
objects of same color.

Group / 
Ungroup Group or ungroup selected objects.

Lock / Unlock 
all

Lock selected objects or unlock all 
objects in a design.

Branching Automatically sequence and group 
like embroidery objects. 

Apply closest 
join

Join selected objects at the closest 
point. Re-apply closest join after 
editing.

Break apart

Split branched objects – 
monograms, appliqués, lettering, 
etc – into components. Allows each 
to be edited individually.

Sequence > Resequence selected objects in 
order selected, or resequence 
objects by color to reduce color 
changes.

Align >

Same functions as the Arrange 
toolbar. See Arrange tools for 
details.

Space 
evenly >

Make same 
size >

Shaping > Same functions as the Shaping 
toolbar.

Remove 
overlaps

Remove the underlying layer of 
stitching in overlapping objects. 

Penetrations Toggle Penetrations function on/off. 
Engage needles or borers, or 
disengage to create jumps.

Borers Toggle Borers function on/off.
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Stitch menu

Graphics menu

Setup menu

Insert Stop Insert Stop function at current stitch 
cursor position.

Insert Tie-off Insert a tie-off.

Insert Trim Insert a trim.

Insert Empty 
stitch Insert an empty stitch.

Insert Empty 
jump Insert an empty jump.

Insert 
function

Insert machine function at current 
stitch cursor position.

Clear 
function

Remove machine functions from 
the current stitch cursor position.

Edit function Edit machine function at current 
stitch cursor position.

Generate 
stitches

Generate stitches for selected 
objects.

Stitch edit 
selection

Select a range of objects as you 
travel through the design.

Process 
stitches

Adjust stitch density of and/or scale 
whole or selected parts.

Recognize 
objects / 
outlines

Recognize new or revised object 
outlines after stitch editing – use 
with machine files opened without 
object/outline recognition. 

Split object Split object in two at current needle 
position. Use with Travel by Stitch 
functions.

Import 
graphic

Import artwork into current design 
as a backdrop for manual or 
automatic digitizing.

Instant smart 
design

Automatically create embroidery 
from imported artwork instantly.

Smart design Create whole embroidery designs 
directly from imported artwork.

Keep graphic 
objects

Retain original artwork during 
conversion.

Color 
matching 
method

Match colors from inserted bitmap 
or vector graphic to thread colors in 
selected chart/s

Crop bitmap Crop bitmap images to remove 
unnecessary detail and save 
processing time.

Remove crop Remove crop. 

Finalize crop Turns a ‘virtual crop’ into a ‘hard 
crop’ by reducing an image to its 
new visible extents.

Prepare 
bitmap colors

Prepare bitmap images for 
automatic digitizing.

Edit using > Edit bitmaps using Paint, Corel 
PHOTO-PAINT, or Paint Shop Pro.

Turning satin 
object

Fill narrow column shapes with 
turning stitching.

Tatami fill 
object with 
holes

Fill large shapes with tatami 
stitching, preserving any holes

Tatami fill 
object

Fill large shapes with tatami 
stitching, ignoring any holes.

Centerline 
run object

Create centerlines in narrow 
shapes with Run stitching.

Outline run 
object

Create outlines around shapes with 
Run stitching.

Auto trace to 
vectors

Convert artwork to vector objects. 
These can be converted to 
embroidery objects.

Adjust bitmap Adjust image lightness and 
contrast.

Photo Flash Create whole embroidery designs 
directly from photographs.

Color 
PhotoStitch

Automatically turn photographs and 
other bitmap artwork into 
multi-colored embroidery.

Reef 
PhotoStitch

Automatically turn photographs into 
reef-like embroidery.

Add bitmap 
colors

Assign matching thread colors from 
selected chart/s to the current 
colorway.

Options Access current settings for design 
window object display.

Manage 
thread charts

Define your own thread charts. 
When you create a thread chart, 
you are creating a store of colors for 
future use.

Manage auto 
fabrics

Modify existing fabric definitions 
and create new ones. 
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Window menu

Help menu
EmbroideryStudio provides various ways to 
access information about the software and 
how to use it via the Help menu. See 
Resources & support for details.

EmbroideryStudio toolbars

The Wilcom Workspace contains the 
toolbars described below. Some tools are 
shortcuts to pulldown menu commands. 
Details of optional toolbars are provided in 
the onscreen documentation.

Note: Only the most commonly used 
toolbars are on by default.

Standard tools
The Standard toolbar contains commonly 
used tools and commands, specific to and 
only visible in Wilcom Workspace.

Manage 
styles

Define new styles for a template, 
either from scratch or based on an 
existing style or object.

My hoops Configure My Hoop list to include 
only hoops available for use.

Manage 
motifs

Manage your custom motif sets.

Manage 
user-refined 
letters

Adjust height range and other 
settings for custom ‘user-refined’ 
letters.

Manage 
sequin fixing

Rename or delete custom sequin 
fixings from the library. See also 
Object > Create Sequin Fixing.

Manage 
sequin shape

Rename or delete custom sequin 
shapes from the library. See also 
Object > Create Sequin Shape.

Manage 
alphabets

Modify custom alphabets by 
changing names, default letter 
spacings and join types.

Convert 
TrueType 
font

Convert a TrueType font to an 
embroidery font.

Calibrate 
screen

Set up your monitor. 

Connection 
Manager 
setup

Connect to machines that appear 
as removable media or make use of 
third-party connection software.

Tablet setup Set up digitizing tablet.

Scanner 
setup Set up Scanner.

Bling 
machine 
setup

Set up direct connection to CAMS 
automatic rhinestone placement 
machine.

Machine 
runtime setup

Set up multiple named machines for 
the purposes of runtime analysis.

Security 
device setup

Show/set security device.

New tab 
group...

Split the design window into a 
second tab group, either vertical or 
horizontal. Each tab group can 
contain multiple designs.

Move to tab 
group...

Move a current design to the other 
design tab. Can also be dragged to 
the other design group.

Remove tiling Remove tab groups and split 
windows and return to a single 
design window.

Split window Split design tab into multiple views 
of the same design.

Dockers > Show/hide dockers to optimize 
working area.

Toolbars > Show/hide toolbars to optimize 
working area.

Kiosk Lettering kiosk capability for cap 
and other embroidery for use at 
retail outlets where simple 
personalization of standard design 
layouts is required.

More 
windows

View more open windows.

New design Create a new design file.

Open 
design

Open an existing embroidery 
design.

Open recent 
designs

Open a design from a list of 
recently opened designs.
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Property bar
Adjust general object properties – width, 
height, position – by means of the Property 
Bar. Changes to the values are applied by 
pressing Enter on the keyboard. They are 
discarded when you press Esc or click 
anywhere outside the fields. See Access 
object properties for details.

Status & Prompt bars
The Status and Prompt bars provide 
continuous display of current cursor position 
status as well as instructions for use of 
selected tools. See Operating modes for 
details.

View tools
Use the View tools to visualize your designs 
– e.g. as design outlines, by stitches, by 
machine functions, as they will stitch out on 
the fabric. Right-click to access settings. 
See also Viewing Designs.

Save design Save the current design file.

Export 
machine file

Export the current design to a 
machine file for stitching.

Print Print the current design file.

Print 
preview

Preview design 
worksheet/approval sheet. Print 
from preview window.

Cut Cut selection and place on 
Clipboard.

Copy Copy selection and place on 
Clipboard.

Paste
Paste contents of Clipboard. 
Options available in Options > 
Edit tab.

Undo Undo previous action.

Redo Redo previously undone action.

Import 
embroidery

Import embroidery design file 
into current design. 

Import 
graphic

Import artwork into current 
design as a backdrop for 
manual or automatic digitizing.

Export multi- 
decoration 
files

Export mixed decoration design 
components as file formats for 
use by control software or 
machine. 

Send to 
Connection 
Manager

Send current design to machine 
via proprietary machine 
software.

Send to 
Embroidery
Connect

Send the current design to a 
named EmbroideryConnect 
device.

Queue 
Design

Send the current design to the 
EmbroideryConnect design 
queue.

Send to 
appliqué 
cutter

Send appliqué shapes from 
design file to laser cutter. 

Send to 
bling cutter

Send vectors for any bling in a 
multi-decoration design to a 
supported cutting machine. 
Configure the machine via 
Setup. 

Zoom Scale: Select zoom scale 
from droplist

Options
Access application options for 
design view, grid & guides, and 
other settings.

TrueView Toggle between stitch view and 
TrueView™.

Show 
stitches

Toggle embroidery stitching 
display.

Show 
outlines Toggle object outlines display.

Show 
needle 
points

Toggle needle point display.

Show 
connectors

Toggle connecting stitch 
display.

Show 
functions

Toggle display of machine 
function symbols.



Quick reference 1354

Zoom tools
Use the Zoom tools to magnify the design 
view by zooming in on individual stitches or 
details. See Zoom & pan designs for details.

Mode tools
The Mode tools control interactions 
between Wilcom Workspace and 
CorelDRAW Graphics.

Show 
repeats Toggle design repeats display.

Show 
bitmaps Toggle bitmap images on or off.

Show 
vectors Toggle vector graphic display.

Dim artwork
Dim graphic backdrops to show 
stitches more clearly for 
digitizing.

Show 
appliqué 
fabric

Toggle appliqué fabric display.

Show 
product

Toggle current product display. 
Right-click for Product 
Visualizer settings.

Show bling Toggle rhinestone (bling) 
display.

Flip 
Sequins

Toggle between front and 
reverse sides of sequin runs 
and fills in reversible sequin 
designs.

Show hoop Toggle hoop display.

Show grid Toggle grid display.

Show rulers 
& guides Toggle rulers & guides display.

Measurement units: Change 
measurement units within 
software without changing 
system settings. 

Auto hoop
Prompt system to select a hoop 
from My Hoops list. Right-click 
Show Hoops for settings.

Auto start & 
end

Set auto start and end points for 
entire design.

Stitch player Simulate embroidery design 
stitchout on screen.

Zoom
Zoom in or out via left and right 
mouse clicks, or drag a selection 
marquee to view design detail.

Zoom 
1:1 Display design at actual size.

Zoom factor: Select zoom scale 
from the droplist or key in a zoom 
factor and press Enter.

Zoom to 
fit 

Display whole design in design 
window.

Zoom to 
selected Magnify only selected objects.

Zoom to 
product

View entire product in the design 
window.

Zoom to 
hoop

Display entire hoop in the design 
window. 

Home

Revisit the Home screen to get 
started with a new design, or 
access tutorials and other 
product information.

Wilcom 
Workspace

Access full embroidery 
creation and editing toolset.

CorelDRAW 
Graphics

Access full graphic creation 
and editing toolset.

Design 
Library

Open the Design Library 
window from which to search 
and catalogue designs as well 
as quotes, orders, and 
approvals.

Convert 
embroidery 
to graphics

Convert selected embroidery 
to vector graphics and switch 
to CorelDRAW Graphics.

Convert 
graphics to 
embroidery

Convert selected graphics to 
embroidery and switch to 
Wilcom Workspace.
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Docker tools
Use the Docker tools to toggle modeless 
dialogs (dockers) on or off. See also Work 
with dockers.

Color tools
The Color toolbar contains a palette specific 
to and only visible in Wilcom Workspace. 
See Choosing threads for details.

Tag as 
appliqué

Tag vector lettering for 
conversion to appliqué 
embroidery lettering with 
turning stitching.

Tag fill as 
turning satin

Use this tag only for narrow 
vector objects, such as 
lettering-like vectors.

Tag as Photo 
Flash

Convert photos to Photo Flash 
embroidery. 

Keep graphic 
objects

Keep original objects after 
conversion.

Match to 
embroidery 
palette

Toggle thread-color matching 
for converted vector objects. 

Show 
embroidery

Toggle embroidery object 
display.

Virtual Decoration Quality: set 
the rendering quality of 
embroidery TrueView for a 
virtual decoration.

Design 
information

Access design details 
including job order details.

Overview 
window

Toggle Overview Window 
display. View and pan 
thumbnail of current design. 

Object 
properties

Toggle Object Properties 
display. Use it to preset 
properties or adjust for 
selected objects.

Color-object 
list

Toggle Color-Object List 
display. View and sequence 
design objects.

Colorway 
editor

Toggle Colorway Editor 
display. Assign thread colors 
to color palette and define 
colorways.

Threads

Show or hide the Threads 
docker to find threads from 
different charts and change 
design colors.

Stitch list
Toggle Stitch List display. Use 
it to view, filter and select 
stitches.

Team names
Toggle Teamname List display. 
Use it to view and edit 
individual team names. 

Carving 
stamp

Toggle Carving Stamp display. 
Create needle penetrations 
using a ‘carving stamp’ as 
template.

Embroidery 
clipart

Toggle the docker display. Use 
it to record and recover 
re-usable embroidery 
elements.

Current Colorway: switch 
between predefined colorways. 
Define via Colorway Editor.

Colorway 
editor

Toggle Colorway Editor display. 
Use it to assign thread colors to 
color palette and define 
colorways.

Background 
& display 
colors

Change design background 
and display color presets for 
the current colorway. 

Product 
visualizer

Toggle Product Visualizer 
docker display. Use it to edit the 
current product in the design 
window.

Current 
color Shows the current color.

Pick color Pick up a color from the design 
window and make it current.

Apply 
current color

Apply the current color to 
embroidery objects. 

Add color Add color slot to palette. Edit 
via the Colorway Editor.

Remove 
color 

Remove unused last color slot 
from color palette.

Hide unused 
colors

Show or hide all unused colors 
in the color palette.
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Colorway Editor
The Colorway Editor contains tools for 
editing colorways.

Toolbox tools
The Toolbox contains embroidery 
digitizing/editing tools specific to and visible 
only in Wilcom Workspace. By default, the 

Toolbox docks vertically to the left of 
screen but can be floated, re-configured, 
and docked like any other toolbar.

Remove 
unused 
colors

Remove unused colors from 
the palette.

Split palette 
color

Split selected color into two 
color slots. Normally used with 
multiple colorways.

Cycle used 
colors

Cycle through combinations of 
used colors. Left- or right-click. 

Color wheel Access Color Wheel to test 
combinations of related colors. 

Threads

Show or hide the Threads 
docker to find threads from 
different charts and change 
design colors. 

Create 
colorway

Add a new colorway to the 
design. 

Rename 
colorway Rename selected colorway. 

Delete 
colorway Delete selected colorway. 

Move 
colorway 
left Move selected colorway in 

Colorway Editor to right or left.Move 
colorway 
right

Background 
& display 
colors

Change design background 
and display color presets for the 
current colorway. 

Edit color Edit specification and color of 
the selected color slot.

Show 
colorway 
details

Toggle display between current 
colorway and all colorways.

Hide 
unused 
colors

Show or hide all unused colors 
in the color palette.

Select See Selection tools for details.

Reshape See Reshape tools for details.

Edit See Edit tools for details.

Lettering

Create embroidery lettering 
onscreen using native 
embroidery fonts or TrueType 
fonts. Right-click for settings.

Team 
names

Toggle Teamname List display. 
Use it to view and edit individual 
team names. 

Monogram- 
ming

Create monograms using a 
selection of predefined 
monogramming styles, border 
shapes and ornaments.

Simple 
offsets

Create simple outlines for any 
filled embroidery or closed 
vector object.

Outlines & 
offsets

Create outlines and offsets of 
any type for any filled 
embroidery or closed vector 
object.

Open 
offsets

Create precise offsets for any 
open embroidery or vector 
object.

Add border
Add borders to designs (or 
selected objects) from a border 
library.

Color 
blending

Generate color blends, 
perspective effects and shading 
in selected objects.

Auto-
digitizing See Property bar for details.

Envelope See Envelope tools for details.

Arrange See Arrange tools for details.

Shaping See Shaping tools for details.
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Selection tools
Use the Select tools to select embroidery 
objects in a variety of ways. See Selecting 
objects for details.

Reshape tools
Use the Reshape tools to reshape objects 
with control points as well as edit individual 
stitches. See Reshaping embroidery objects 
for details. See also Stitches & Machine 
Functions.

Edit tools
Use the Edit tools for object editing 
operations. See Reshaping Objects for 
details.

Envelope tools
Envelopes are typically applied to lettering 
objects, but they can also be applied to 
other types of embroidery object. See 
Applying envelopes for details.

Arrange tools
Use the Arrange tools for moving, aligning 
and distributing objects, as well as grouping 
and locking operations. See Transforming 
Objects for details.

Select 
object

Click to select individual objects. 
Use with Ctrl or Shift keys to 
select groups or ranges of 
objects. Drag a selection 
marquee to select multiple 
objects. 

Freehand 
select

Select object by drawing a 
freehand line around it.

Select 
current

Select object at current cursor 
position.

Polygon 
select

Select objects by digitizing a 
selection marquee around them.

Polyline 
select

Select objects by digitizing a line 
through them.

Reshape 
object

Reshape selected objects, edit 
stitch angles, and adjust 
entry/exit points. 

Show 
reshape 
nodes

Toggle reshape nodes for 
selected objects.

Show 
bézier 
handles

Toggle Bézier handles for 
selected objects. (Only available 
when the Bézier reshape option 
is selected in the Options > 
Reshape tab.)

Show 
stitch 
angles

Toggle stitch angles for selected 
objects.

Show 
entry/exit

Toggle entry (green diamond) 
and exit (red cross) points for 
selected objects.

Stitch edit Select individual stitches for 
editing.

Keep last 
stitch Keep last stitch in a column. 

Omit last 
stitch Omit last stitch in a column. 

Break 
apart

Split branched objects – 
monograms, appliqués, lettering, 
etc – into components. Allows 
each to be edited individually.

Knife
Cut objects along a digitized line, 
preserving stitch settings and 
colors.

Automatic 
knife

Slice large objects into smaller 
ones with automatic overlaps.

Bridge 
envelope

Make lettering object to make 
it bulge or arch.

Pennant 
envelope Make objects compress.

Perspective 
envelope Make objects bulge or stretch.

Diamond 
envelope

Make objects bulge or 
compress.

Delete 
envelope

Delete envelopes from 
selected objects.

Group Group selected objects.

Ungroup Ungroup selected grouped 
objects.
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Traditional digitizing tools
The Traditional Digitizing toolset 
provides all the input methods embroidery 

digitizers are familiar with. Traditional 
digitizing methods divide into three main 
categories – ‘free shapes’, ‘column shapes’, 
and ‘outlines’. See also Embroidery 
digitizing.

Outline tools
Use the Outline tools for digitizing 
embroidery outlines. See Digitizing outlines 
& details for details.

Lock Lock selected objects.

Unlock all Unlock all locked objects in 
design.

Branching Automatically sequence and 
group like embroidery objects. 

Apply 
closest join

Join selected objects at the 
closest point. Re-apply closest 
join after editing. 

Break apart

Split branched objects – 
monograms, appliqués, 
lettering, etc – into 
components. Allows each to be 
edited individually.

Align left Left-align selected objects.

Align centers 
vertically

Align centers of selected 
objects vertically.

Align right Right-align selected objects.

Align top Align tops of selected objects.

Align centers 
horizontally

Align centers of selected 
objects horizontally.

Align bottom Align bottoms of selected 
objects.

Align centers Align selected objects through 
their centers. 

Space 
evenly 
across

Distribute selected objects 
evenly across design window.

Space 
evenly down

Distribute selected objects 
evenly down design window.

Make same 
width

Scale selected object/s to 
same width as last-selected 
reference object.

Make same 
height

Scale selected object/s to 
same height as last-selected 
reference object.

Make same 
width & 
height

Scale selected object/s to 
same size as last-selected 
reference object.

Outlines See Outline tools for details.

Backtrack
Reinforce an outline, stitching it 
in the reverse direction to the 
original.

Repeat
Duplicate an outline in the same 
direction – typically used with 
closed shapes.

Column A Digitize column of turning 
stitches of varying width.

Column B
Digitize column of turning 
stitches, where opposite sides 
are different.

Column C Digitize column or border of fixed 
width.

Complex 
fill

Digitize filled shape with a single 
stitch angle in the current stitch 
type – outline only.

Complex 
turning

Digitize filled shape with turning 
stitches in the current stitch type 
– outline only.

Star Digitize star shape filled with 
zigzag stitching.

Ring Digitize circle and oval-shaped 
ring.

Manual See Manual stitch tools for 
details.

Use motif
Add motifs to design one-by-one. 
Rotate, scale, or mirror as you 
add. 

Branching Automatically sequence and 
group like embroidery objects. 

Digitize 
run Place a row of single or triple run 

stitches along a digitized line.
Triple run
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Manual stitch tools
The Manual tools are used for digitizing 
individual stitches. Enter single stitches or 
three stitch layers at a time. See Digitizing 
manual stitches for details.

Graphics digitizing tools
Graphics Digitizing tools operate in a 
similar way to CorelDRAW® 
Graphics Suite or other graphics 
applications. Assign a stitch type to a 
digitized shape from Outline Stitch or Fill 
Stitch toolbars. See also Digitizing with 
graphical tools. See also Appliqué 
Embroidery.

Stitch angle tools
Add or remove stitch angles with the Stitch 
Angle tools. See Adjusting stitch angles for 
details.

Hole tools
Hole tools are used to cut as well as fill 
holes in embroidery objects. See Adding & 
filling holes for details.

Appliqué tools
Appliqué tools are specialized for appliqué 
work. Use them to create appliqué objects, 
resequence objects for efficient stitchout, as 
well as generate partial cover stitching for 

Motif Run Place a row of motifs along a 
digitized line. 

Backstitch Place a row of backstitches 
along a digitized line. 

Stemstitch Place a row of stemstitches 
along a digitized line. 

Manual

Digitize individual ‘manual’ 
stitches. Manual objects have no 
outlines, only stitches. Stitch 
density does not change. 

Triple 
manual

Digitize triple ‘manual’ stitches. 
Manual objects have no outlines, 
only stitches. Stitch density does 
not change. 

Digitize 
open 
shape

Digitize open object in the 
current stitch type – outline only.

Digitize 
closed 
shape

Digitize closed object in the 
current stitch type – outline or fill.

Digitize 
column

Digitize column of varying width 
in the current stitch type – outline 
or fill.

Rectangle
Digitize rectangle or square in 
the current stitch type – outline or 
fill. Press <Ctrl> to constrain.

Ellipse Digitize ellipse or circle in the 
current stitch type – outline or fill.

Basic 
shapes

Digitize basic shapes. Press 
<Ctrl> to keep the proportion of 
the shape. Press <Shift> to 
center at the first point entered.

Freehand 
open 
shape

Draw open freehand object in the 
current stitch type – outline only.

Freehand 
closed 
shape

Draw closed freehand object in 
the current stitch type – outline or 
fill.

Stitch 
angles See Stitch angle tools for details.

Holes See Hole tools for details.

Appliqué See Appliqué tools for details.

Stitch 
angles

Add stitch angles to selected 
objects. 

Remove 
stitch 
angles

Remove stitch angles from 
closed objects with turning 
stitches.

Add holes Add hole/s to selected filled 
object.

Remove 
holes

Remove hole/s from selected 
object.

Fill holes
Fill hole/s in selected object. 
Choose an exact fit or offset the 
edges.
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overlapping appliqué. See Appliqué 
Embroidery for details.

Auto-digitizing tools
Auto-Digitizing tools provide everything 
necessary to automatically digitize shapes in 
electronic artwork, both bitmap and vector, 
without using manual input methods. See 
Auto-digitize individual shapes for details.

Stitch type tools
The Stitch Type toolbars provide a range of 
basic outline and fill stitch types as well as 
those of a more artistic or decorative 
nature. Outlines stitches can generally be 
applied to open or closed shapes. Right-click 
to access stitch settings. See also Stitch 
Types.

Appliqué

Digitize appliqué object with up 
to four layers of stitching – guide 
runs, cutting lines, tack stitches, 
and cover stitches. 

Appliqué 
without 
holes

Digitize single-boundary 
appliqué object with up to four 
layers of stitching – guide runs, 
cutting lines, tack stitches, and 
cover stitches. 

Combine 
appliqué

Combine and sequence 
components of selected appliqué 
objects for efficient stitchout.

Partial 
appliqué

Create partial cover stitching for 
overlapping appliqué objects.

Remove 
overlaps

Remove underlying layer of 
stitching in overlapping objects 
using the selected object as a 
‘cutter’. 

Instant 
smart 
design

Automatically create 
embroidery from imported 
artwork instantly.

Smart 
design

Create whole embroidery 
designs directly from imported 
artwork.

Keep 
graphic 
objects

Retain the original artwork 
during conversion.

Color 
matching 
method

Toggle thread color matching for 
auto digitizing.

Crop 
bitmap

Crop bitmap artwork for use with 
auto-digitizing tools.

Remove 
crop Click to remove cropping area.

Finalize 
crop

Make cropping permanent. 
Once finalized, cropping cannot 
be removed.

Prepare 
bitmap 
colors

Prepare bitmap images for 
automatic digitizing.

Turning 
satin object

Fill narrow column shapes with 
turning stitching.

Tatami fill 
object with 
holes

Fill large areas with tatami 
stitching, preserving any holes.

Tatami fill 
object

Fill large areas with tatami 
stitching, ignoring any holes.

Centerline 
run object

Create centerlines in narrow 
shapes with Run stitching.

Outline run 
object

Create outlines around shapes 
with Run stitching.

Auto trace 
to vectors

Convert artwork to vector 
objects. These can be 
converted to embroidery 
objects.

Adjust 
bitmap

Adjust image lightness and 
contrast in preparation for 
auto-digitizing.

Photo Flash
Create whole embroidery 
designs directly from 
photographs.

Color 
PhotoStitch

Automatically turn grayscale or 
color photograph into 
embroidery. 

Reef 
PhotoStitch

Automatically turn photographs 
into reef-like embroidery.

Outline stitches

Run Create single stitch run outlines 
and details.

Sculpture 
run

Create alternating triple-single 
stitch run for a hand-stitched 
look.

Triple run Create heavier triple stitch 
outlines and details.
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Backstitch Create traditional backstitch 
outlines for delicate borders.

Stemstitch
Create traditional stemstitch 
outlines for decorative details 
such as stems and vines.

Motif run
Create ornamental craftstitch 
outlines. Choose from a motif 
library.

String Create string craftstitch outlines 
for delicate borders.

Satin Create glossy satin borders or 
columns of even width.

Satin raised
Create layered satin borders or 
columns of even width for a 
raised surface.

Zigzag
Create borders or columns of 
even width for an open 
'sawtooth' effect.

E stitch
Create borders or columns of 
even width for an open 'comb' 
effect.

Tatami
Create borders or columns of 
even width for different needle 
penetration patterns.

Program 
split

Create borders or columns of 
even width for decorative 
needle penetration patterns.

Square
Create borders or columns of 
even width for an open 'toothed' 
effect.

Coil
Create borders or columns of 
even width for an open ‘coil’ 
effect. 

Contour
Use for contoured stitching 
following borders or columns of 
even width. 

Vector 
outline

Create vector outlines without 
stitch properties.

Fill stitches

Satin Create glossy satin fills for 
narrow shapes.

Satin raised Create layered satin fills for a 
raised surface.

Zigzag Create zigzag fills for an open 
'sawtooth' effect.

E stitch Create E stitches for an open 
'comb' effect.

Tatami
Create solid stitching for large 
shapes with different needle 
penetration patterns.

Coil Create open coil fills.

Square Create open straight parallel 
fills.

Double 
square Create grid fills.

Island coil Create concentric rows of coil 
fills. 

String Create string craftstitch fills.

Program 
split

Create solid decorative fills 
using needle penetrations to 
form tiled patterns.

Motif

Create decorative fills using 
embroidery motifs to form 
repeating patterns. Choose 
from a motif library.

Motif column

Place motifs along the center 
line of a column shape and 
resize to fit. Right-clicking for 
settings.

Cross stitch

Fill large areas with cross 
stitching on an invisible grid 
that applies to all design 
objects.

Contour
Create curved fills where 
stitches follow contours of a 
shape.

Spiral Create spiral stitching radiating 
from the center of the object.

Maze Fill
Create maze-like stitching 
which follows object contours 
for open fills.

Offset Create offset fill stitching in any 
closed shape.

Stipple
Create a stipple fill which 
meanders randomly within a 
shape.

Stipple 
backstitch

Create a stipple backstitch fill 
which meanders randomly 
within a shape.
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Stitch effect tools
Use the Stitch Effects tools for modifying 
or improving stitch quality, including 
applying automatic underlay to selected 
objects. Right-click for settings.

Mirror-merge tools
Mirror Merge tools allow you to duplicate 
and transform selected embroidery objects, 
as well as merge them into a single object. 
See Mirroring objects for details.

Stipple 
stemstitch

Create a stipple stemstitch fill 
which meanders randomly 
within a shape.

Vector fill Create vector fills without stitch 
properties.

Auto underlay Generate automatic underlay 
for selected objects.

Pull 
compensation

Apply to selected objects to 
compensate for fabric 
stretch. 

Auto jump Preserve long stitches in new 
and selected objects. 

Shortening
Reduce stitch bunching in 
tight curves by shortening 
stitches along inside edge. 

Fractional 
spacing 

Even out stitch density along 
inside and outside edges. 

Mitre corners Create sharp mitre corners at 
intersections. 

Cap corners Create capped corners for 
fewer stitches. 

Lap corners Create ‘Tidori’ style corner 
stitching. 

Jagged edge

Create rough edges, shading 
effects, or imitate fur and 
other fluffy textures in 
selected objects. 

Trapunto

Force underlying travel runs 
to the edges of selected 
objects. Use with open 
stitching. 

User-defined 
split

Create custom split-line 
effects. 

Accordion 
spacing

Create perspective and 
shading effects with stitch 
spacing varying between 
dense and open fill. 

Flexi split

Create decorative split 
patterns following stitch 
angles and scaled according 
to object width. 

Radial fill

Create radial turning 
stitching with various stitch 
types including satin, tatami 
and program splits. Can be 
applied to ring shapes. 

Florentine 
effect

Create custom curve-line 
stitching with a single 
guideline. 

Liquid effect Create custom curve-line 
stitching with twin guidelines. 

3D Warp Create 3D effects in selected 
motif fills. 

Hand Stitch 
Effect

Create hand-stitch effects 
which combine randomized 
stitch length, angle and 
count.

Cording
Apply cording effect to new 
or selected objects with run 
stitching.

Mirror copy 
horizontal

Duplicate and mirror 
horizontally and merge 
overlapping objects (optional). 

Mirror copy 
vertical

Duplicate and mirror vertically 
and merge overlapping 
objects (optional). 

Mirror copy 
horizontal & 
vertical

Duplicate and mirror selected 
objects around a center point.

Array

Duplicate designs, such as 
badges, automatically 
re-sequencing color blocks for 
efficient multiple design 
stitchouts.

Reflect
Duplicate and mirror objects 
or designs. Create decorative 
borders.
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Shaping tools
When working with overlapping vector or 
embroidery objects, you can merge, trim or 
split them with the Shaping tools. See 
Shaping objects for details.

Sequence tools
Sequence tools are used to resequence 
selected objects. Use them in conjunction 
with the Color-Object List. See 
Sequencing embroidery objects for details.

Wreath
Duplicate objects around a 
center point. Create wreath 
designs.

Kaleidoscope Mirror paired objects in a 
wreath.

Mirror merge settings

Rows: Set number of rows in 
the array.

Row spacing: Set spacing 
between rows in the array.

Columns: Set number of 
columns in the array.

Column spacing: Set spacing 
between column in the array.

Wreath points: Set number of 
duplicates (including source). 
Kaleidoscope works best with 
an even number.

Set precise distance and 
angle – measured from center 
of source object to center of 
wreath or kaleidoscope.

Weld
Merge selected overlapping 
objects into a single ‘flattened’ 
object.

Intersect
Trim selected overlapping 
objects so that only intersected 
areas remain.

Exclude
Trim selected overlapping 
objects and preserve individual 
properties.

Front-back

Trim selected overlapping 
objects so that only 
non-overlapping areas of the 
topmost object remain.

Back-front

Trim selected overlapping 
objects so that only 
non-overlapping areas of the 
bottommost object remain.

Flatten Trim all overlaps in selected 
overlapping objects.

Divide
Split selected objects into 
separate adjoining objects 
wherever they intersect.

Combine
Merge properties of selected 
overlapping objects and trim 
overlapping areas.

Keep 
original 
objects

Keep original objects after 
shaping operations.

Overlap: Adjust object overlaps 
resulting from Flatten or Divide 
shaping operations.

Back 1 
object

Move a selection back one object 
in the stitching sequence. 

Forward 1 
object

Move a selection forward one 
object in the stitching sequence. 

Back 1 
color

Move a selection back one color 
in the stitching sequence. 

Forward 1 
color

Move a selection forward one 
color in the stitching sequence. 

Move to 
start

Move a selection to start of 
stitching sequence. 

Move to 
end

Move a selection to end of 
stitching sequence. 

Sequence 
by selects

Resequence objects in the order 
selected.

Sequence 
by color

Resequence all blocks of like 
color. (To maintain separate color 
blocks, use the Color-Object 
List.)
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Transform tools
Use the Transform tools to mirror, rotate 
and skew objects. See Transforming Objects 
for details.

Styles tools
Use the Styles toolbar to apply predefined 
styles to a design. The tools let you:
 Apply current settings to selected objects
 Change current settings, and
 Apply styles to selected objects.
The styles you select as ‘favorites’ are each 
assigned a tool icon on the toolbar. See 
Working with styles for details.

Stitch editing tools
Use the Stitch tools for stitch editing and 
processing operations. See also Stitches & 
Machine Functions.

Function tools
Use the Function tools to insert machine 
functions manually. See Stitches & Machine 
Functions for details.

Mirror 
horizontal

Flip selected objects 
horizontally.

Mirror 
vertical Flip selected objects vertically.

Mirror by 
reference 
line

Mirror objects around a 
defined axis using a reference 
line.

Rotate left 
15°

Rotate selected objects by 15° 
in counter-clockwise direction.

Rotate right 
15°

Rotate selected objects by 15° 
in clockwise direction.

Rotate: Rotate selected 
objects by specified amount – 
positive or negative – in 
degrees.

Skew: Skew selected objects 
by specified amount – positive 
or negative – in degrees.

Transform by 
reference 
line 
numerically

Transform selected objects 
using a combination of 
reference points and numeric 
values.

Transform by 
reference 
line freely

Rotate selected objects with 
the aid of reference points 
alone.

Make 
properties 
current

Make properties of a selected 
object current for the design.

Apply 
current 
properties

Apply current settings to selected 
objects.

Favorite 
style

Assign up to 10 favorite styles via 
Manage Styles. Select object 
and click button to apply.

Apply style Apply predefined style to 
selected objects.

Generate 
stitches

Generate stitches for selected 
objects.

Stitch edit Select individual stitches for 
editing.

Selects on 
/ off

Select a range of objects as you 
travel through the design.

Process 
stitches

Adjust stitch density of and/or 
scale whole or selected parts.

Split object
Split object in two at current 
needle position. Use with Travel 
by Stitch functions.

Penetrations
Toggle Penetrations function. 
Engage needles or borers, or 
disengage to create jumps. 

Borers Toggle Borers function. Use for 
cutting holes in fabric.

Insert Stop Insert Stop function at current 
stitch cursor position. 

Insert Tie-off Insert Tie-off function at current 
stitch cursor position. 

Insert Trim Insert Trim function at current 
stitch cursor position.

Insert Empty 
stitch 

Insert Empty stitch function at 
current stitch cursor position.

Insert Empty 
jump

Insert Empty jump function at 
current stitch cursor position.

Insert 
function

Insert machine function at 
current stitch cursor position.
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Warning: When you insert stitches or 
machine functions manually, you must 
maintain them manually. If an object’s 
stitches are regenerated for any reason, all 
stitch editing and machine functions are 
lost.

Legacy feature tools
Newer machines use USB and wired or 
wireless network connections. Older 
machines use serial ports or even 
proprietary embroidery disks. Use the 
Legacy Features for connecting to older 
style machines. See Embroidery Output for 
details.

Travel tools
Use the Travel tools to view the stitching 
sequence of a design color-by-color, 
object-by-object, or stitch-by-stitch. 
Traveling can be initiated from any stitch in 

a design. See Viewing stitching sequence for 
details.

Sequin tools
Use the Sequin tools to digitize sequined 
designs for compatible machines. There are 
also tools for creating boring holes. See 
Sequin Embroidery for details. 

Clear 
function

Remove machine functions 
from current stitch cursor 
position. 

Edit function Edit machine function at 
current stitch cursor position.

Slow Insert Slow function to 
decrease machine speed.

Fast Insert Fast function to increase 
machine speed.

Send to 
Machine 
Manager

Send multiple designs to 
machine from 
EmbroideryStudio or 
DesignWorkflow and view or 
manage job queues. 

Send to 
Stitch 
Manager

Send current design direct to 
embroidery machine for 
production.

Embroidery 
disk

Open designs from or save to 
proprietary embroidery disk 
formats.

Hardware 
setup

Set up a machine connection 
with name, port, and protocol.

Start / end 
design

Move stitch cursor to the 
start/end of design. 
Left/right-click.

Travel by 
object

Move stitch cursor to the 
next/previous object. 
Left/right-click.

Travel by 
segment

Move stitch cursor to the 
next/previous segment. Left/right 
click.

Travel by 
color

Move stitch cursor to the 
next/previous color change. 
Left/right click.

Travel by 
function

Move stitch cursor to the 
next/previous machine function. 
Left/right click.

Travel by 
trim

Move stitch cursor to the 
next/previous Trim function. 
Left/right click.

Travel 
1000 
stitches

Move stitch cursor 
forwards/backwards 1000 
stitches at a time. Left/right click.

Travel 100 
stitches

Move stitch cursor 
forwards/backwards 100 stitches 
at a time. Left/right click.

Travel 10 
stitches

Move stitch cursor 
forwards/backwards 10 stitches 
at a time. Left/right click.

Travel 1 
stitch

Move stitch cursor 
forwards/backwards 1 stitch at a 
time. Left/right click.

Sequin 
palette 
editor

Select sequins for the design 
from a sequin library.

Sequin Palette: Select sequin 
shapes for the current design.

Manual 
sequin

Digitize individual sequin drops. 
Right-click for settings.



Quick reference 1366

Bead tools
Use the Bead tools to create bead runs as 
well as fills for compatible machines. See 
Bead Embroidery for details.

Bling tools
Use the Bling tools to create bling runs as 
well as fills for compatible machines. See 
Bling Digitizing for details.

Chenille tools
If you have the Chenille option installed, 
the Wilcom Workspace will include a 
Chenille toolbar containing specific Chenille 
stitch types and machine functions. See 

Left sequin Switch to left sequin when 
digitizing twin-sequin designs.

Right 
sequin

Switch to right sequin when 
digitizing twin-sequin designs.

Sequin run 
auto

Create a string of sequins along 
a digitized line. Right-click for 
settings.

Sequin run 
manual

Digitize sequin-drops along a 
digitized line. Right-click for 
settings.

Sequin fill
Digitize and fill larger shapes 
with sequins. Right-click for 
settings.

Sequin 
edit

Fine-tune placement of individual 
sequins within selected sequin 
objects. 

Vectors to 
sequins

Create sequin runs from sequin 
artwork. Digitize a guideline 
connecting the sequins to 
include within a run.

Drop 
sequin

Drop a sequin at the current 
needle position. For twin-sequin 
machines, left-click to drop a 
left-sequin, right-click to drop a 
right-sequin.

Clear 
function

Remove any sequin functions 
from the current needle position.

Bead 
palette 
editor

Select shapes from a bead 
library, and define bead colors 
and sizes.

Manual 
bead Digitize individual beads.

Bead run 
auto

Create a string of beads along a 
digitized line according to current 
settings.

Bead run 
manual

Manually digitize bead-drops 
along a digitized line.

Bead edit Fine-tune placement of individual 
beads.

Clear 
function

Remove any bead functions from 
the current needle position.

Bling 
palette 
editor

Select rhinestones for the design 
from a bling library.

Bling 
manual Digitize individual bling drops.

Bling run 
auto

Create a string of rhinestones 
along a digitized line. Right-click 
for settings.

Bling fill
Digitize and fill larger shapes 
with rhinestones. Right-click for 
settings. 

Bling 
lettering

Create bling lettering onscreen 
using native embroidery fonts or 
TrueType fonts. Right-click for 
settings.

Automatic 
overlap 
removal

Toggle on to remove excess 
rhinestones in overlapping Bling 
objects.

No 
automatic 
overlap 
removal

Toggle on to preserve 
rhinestones in overlapping Bling 
objects.

Highlight 
bling 
overlaps

Toggle on to highlight 
overlapping rhinestones. Use 
with manual edits.

Bling edit
Fine-tune placement of individual 
rhinestones within selected Bling 
objects.

Show bling 
work area

Visualize design within the work 
area of the selected machine 
model. Right-click for settings.
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Chenille User Manual Supplement for 
details.

Schiffli tools
If you have the Schiffli option installed, the 
Wilcom Workspace will include a Schiffli 
toolbar containing specific Schiffli stitch 
types and machine functions. See Schiffli 
User Manual Supplement for details.

Manage design tools
Use the Manage Designs tools for fast 
searching of designs on shared network 
drives. This is important for businesses with 
multiple computers and multiple users 
creating and accessing EMB or machine 
format designs. See Design Management for 
details.

Chain

Create decorative stitching 
resembling links of a chain – 
used for outlines and borders 
as well as monograms. 

Moss

Create dense cover using 
looped stitch typical of Chenille 
raised stitching – best with 
simple shapes.

Needle 
height

Control height of loop formed 
when sewing Moss stitch as 
well as width of Chain stitch.

Compound 
chenille

Use with Complex Fill to 
automatically generate Moss or 
Chain stitch run-arounds for 
complex shapes. Right-click to 
adjust offsets.

View by 
Chain / 
Moss

View Chenille objects to allow 
easy identification of Chain and 
Moss elements – lockstitch in 
green, Chain in blue, Moss in 
red.

Blatt Reduce thread tension.

Stepp Increase thread tension.

End jump Engage needles or borers.

Begin jump Disengage needles or borers.

Slow Decrease machine speed.

Fast Increase machine speed.

Borer in Engage borer.

Borer out Disengage borer.

Borer depth: Determine borer 
hole size – valid depths are 
1-13 for Plauen and 0-12 for 
Saurer.

RPM- Decrease turning speed of 
machine.

RPM+ Increase turning speed of 
machine.

Fadenleiter- Decrease Fadenleiter stroke 
by one increment.

Fadenleiter+ Increase Fadenleiter stroke by 
one increment.

Thread 
brake-

Decrease thread brake 
pressure.

Thread 
brake+

Increase thread brake 
pressure.

Drop sequin Trigger a sequin drop.

Schiffli 
arrangement

Split designs into color blocks 
arranged into logical parts.

New from 
selected

Create new designs from a 
chosen template based on 
selected designs and/or 
bitmaps.

Open 
selected

Open all designs currently 
selected in the Design Library. 

Open 
recent 
designs

Open a design from a list of 
recently opened designs.

Cut Cut selection and place it on the 
clipboard. 

Copy Copy selection and place it on 
the clipboard. 

Paste Paste contents of the clipboard.
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View (Design Library) tools
Design Library allows for fast searching of 
designs on shared network drives. The 
View (Design Library) toolbar contains 
functions for quick search, sort, and location 

of designs on your company network. See 
Design Management for details.

Convert 
selected 
designs

Convert all designs currently 
selected in the Design Library to 
different file formats. 

Send to 
Connection 
Manager

Send a selected design to a 
connected and configured 
embroidery machine via 
proprietary machine software.

Print 
selected

Print all designs currently 
selected in the Design Library to 
a connected and configured 
printer.

Print 
selected to 
catalog

Print all designs currently 
selected in the Design Library to 
an HTML catalog.

Export 
design list

Export a list of all design files 
visible in the Embroidery Library, 
together with associated design 
information, to CSV or TXT file.

Manage 
embroidery 
library 
locations

Add or remove existing folders 
from the Embroidery Library, to 
enable fast searching and 
filtering.

Layout
Toggle the navigation pane, 
details pane, and/or preview 
pane display.

Design 
information

Toggle the Design information 
docker display. Use it to view or 
change design details, 
including order information.

Change 
view

Change current view of design 
lists.

Reset detail 
columns

Reset columns displayed in 
details view to the default 
layout. 

Group by: Group the current list 
of designs by selected property 
and sort order.

Ascending 
order Sort designs in ascending or 

descending order. Descending 
order

Sort by: Sort the current list of 
designs by selected property 
and sort order.

Showing: Filter the current list 
of designs by file type. 

Search: Filter designs based 
on specified search criteria – 
e.g. stitch range.
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Keyboard shortcuts

In addition to shortcut keys, standard 
MS Windows® Alt key shortcuts apply in 
some cases. Use the Alt key with the letter 
underlined in the menu. To cancel an 
operation, press Esc twice.

General functions

To... Press

open design C+O or 
A+F+O

close design A+F+C

export machine file V+E

open Lettering dialog A

open online help 1

print design C+P or 
A+f+p

save design C+S

save as A+f+A

send design to EmbroideryConnect V+A+S

send design to EC Queue V+A+Q

start new design C+N 
toggle Color-Object List V+L

toggle Design Information docker A+p

toggle Grid V+G

toggle Overview window V+V

toggle Stitch List V+J

toggle measure tooltip C+i

measure distance on-screen M

cancel command E 
redo command C+Y 
undo command C+Z

exit application A+4 

Digitizing functions 

To... Press or

activate Auto Trace To Vectors 
for selected artwork

C+M

activate Branching I

activate Complex Turning 2

activate Complex Fill 3

activate Column A 4 V+A

activate Column B 5

activate Column C 6

activate Backtrack V+X

activate Appliqué 7

activate Single Run 8 V+N

activate Triple Run 9

activate Motif Run 0

activate Backstitch !

activate Stemstitch @

apply Satin stitch V+I

apply Tatami stitch V+M

delete last input point B

finish digitizing object (keep last 
stitch)

R

finish digitizing object (omit last 
stitch)

s

finish digitizing free shape 
boundary

R

generate stitches G

make combined vector object V+H 
switch between fill and run 
stitch

s

switch between fill and manual 
stitch

R

Selecting objects

To... Press

activate Select Object tool o 
deactivate Select Object tool E

select all objects C+A 
deselect all objects E or X 
activate Polygon Select tool C+L 
select by color C+A+a

select object at current needle 
position

V+O 

select multiple objects C+[

select range of objects V+[

select next object T 
select previous object V+T 
select object beneath 2+[ 
add next object to selection C+T 
add previous object to selection C+V+

T 
group selected objects C+G 
ungroup selected objects C+U 

* Stitch Edit tool selected

Digitizing functions  (cont)

To... Press or
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lock selected object K 
unlock all locked objects V+K 

Viewing designs

To... Press

toggle TrueView™ on/off T 
toggle stitches S

toggle outlines L

toggle needle points † .

toggle connectors V+C

toggle function symbols V+F

view by color A+c

hide others V+s

toggle bitmaps D

toggle vectors V+D

zoom (marquee) B 
zoom to 1:1 scale (100%) 1 
specify zoom factor F 
zoom in 2X Z 
zoom out 2X V+Z 
zoom to all design * 0

zoom to selected objects * V+0

zoom to product * C+0

zoom to hoop * A+0

zoom box in Overview window V+B

activate panning P 
deactivate (temporarily) Auto 
Scroll

^ V

toggle Auto Scroll on/off C+V+A

center current stitch in Design 
Window

C 

return to previous view V 
redraw (refresh) screen r

† Period * Zero ^ Hold down

Viewing stitching sequence

To travel... Press

activate Stitch Player V+R

to start of design h

to end of design e

^ No object selected † Numeric keypad only, no object 
selected

Selecting objects (cont)

To... Press

* Stitch Edit tool selected

to next color x

to previous color z

to next object C+T

to previous object V+T

to next segment ^ C+r

to previous segment ^ C+l

to next function ^ C+x

to previous function ^ C+z

to next trim ^ A+r

to previous trim ^ A+l

1 stitch forward ^ r

1 stitch backward ^ l

10 stitches forward ^ b

10 stitches backward ^ t

100 stitches forward † +

100 stitches backward † -

1000 stitches forward † V++

1000 stitches backward † V+-

Cutting & pasting objects

To... Press or

cut object C+X V+D

copy object C+C C+Z

paste object C+V V+Z

duplicate object C+D 
duplicate with offset C+V+D

paste special > object 
property position

V+Z

paste special > shift pasted 
objects

C+V+V

paste special > center at 
current stitch

C+A+V

paste special > start at 
current stitch

V+A+V

delete selected objects or last 
object

D

Viewing stitching sequence

To travel... Press

^ No object selected † Numeric keypad only, no object 
selected
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Modifying objects

To... Press or click

activate Reshape Object tool H 
activate Show Stitch Angles tool A+a

activate Show Reshape Nodes 
tool

A+N

activate Stitch Angles tool C+H

add outlines and/or offsets C+V+O

add stitch angles (Complex 
Turning) 

C+H

change reshape node type ^ [+M

check design integrity !

maintain proportions while 
resizing

† V+:

mirror horizontally C+1

mirror vertically A+1

move selected object 
horizontally or vertically

* C+:

nudge selected object [+t b l r 
remove overlaps C+V+E

toggle Auto Underlay on/off u

* Drag object † Drag handle ^ Select control point

Schiffli functions

To... Press

insert Blatt/Stepp function [ ]

insert Fadenleiter Plus/Minus < >

insert Boring Tension Start/End / \

insert RPM Plus/Minus : "

change Schiffli borer depth ;

show Schiffli repeats W

Editing stitches (Stitch Edit mode)

To... Press or click

activate Stitch Edit tool E 
toggle stitch selection Q 
toggle stitch selection while 
traveling by stitches

T 
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Glossary

10O:  Machine file format 
native to Toyota machines.
3D Warp:  3D Warp is used 
with Motif Fill to create three 
dimensional effects. You can 
make shapes appear concave or 
convex using Globe In or Globe 
Out. You can also create 
distance effects using 
Perspective.
ABC Pattern 
Arrangements:  See Pattern 
Arrangements (ABC).
Accordion spacing:  Artistic 
stitch effect that gradually 
varies stitch spacing between 
dense and open fill along an 
embroidery object, producing 
shading and color effects which 
are difficult to achieve 
manually.
Acetate:  A salt or ester of 
acetic acid of cellulose made 
into a synthetic filament, yarn, 
or fabric.
Active window:  The active 
window is one to which the next 
command or action will apply. If 
a window is ‘active’, its title bar 
changes color to differentiate it 
visually from other open 
windows.
Aetze:  The breaking down or 
dissolving of a base fabric on 
which a lace pattern has been 
stitched, leaving only the 
stitched threads. Or lace 
processing – ‘wet aetze’ 
involving a caustic soda bath or 
‘dry aetze’ involving heat.
Aetzing:  The process of 
eliminating the base fabric to 
make Schiffli laces, leaving only 
the threads remaining.
Allover:  Continuous 
embroidery which covers all of 
the goods from selvage to 
selvage.

Anchor point:  A fixed point 
used when rotating, scaling, 
skewing or mirroring a design.
Anti-aliasing:  A software 
technique similar to dithering 
which is used to soften hard 
outlines where color blocks 
intersect. It produces smoother 
outlines by ‘blurring’ the pixels 
where colors join.
Appliqué:  Decoration or 
trimming cut from one piece of 
fabric and stitched to another to 
add dimension and texture. 
Designs with appliqué can be 
more economical than 
embroidery alone, if appliqué 
occupies a significant amount of 
the design, thereby lowering 
stitch count. In Schiffli 
embroidery, appliqué refers to 
an embroidered motif, hand-cut 
or aetzed away from base 
fabric.
Appliqué cutter:  A device 
that can cut fabric along a line, 
somewhat like old pen plotters. 
It requires a vector file as input. 
In MS Windows® they can be 
set up as a type of printer 
device.
ARQ:  BERNINA Quilter format.
ART:  BERNINA format.
Artwork:  Bitmap image or 
vector graphic used as a 
digitizing template. See also 
Bitmap image and Vector 
graphic.
Artwork preparation:  See 
Image preparation.
Aufsatz:  The last stitch of a 
design before it repeats itself.
ARX:  ES Cross Stitch format.
Auto appliqué:  Auto 
Appliqué is an embroidery 
object associated with an 
appliqué which provides 
automatic stitching to place it, 

tack it down, and cover its 
edges.
Auto center:  Auto Center 
automatically centers the start 
and end points of a design.
Auto-digitizing:  Toolset 
used to create embroidery 
designs by automatically 
digitizing blocks of color in 
electronic images, or converting 
vector outlines directly to 
embroidery objects. See also 
Smart Design.
Auto kerning:  For lettering 
objects, auto-kerning involves 
looking up in a ‘kerning table’. 
This specifies the spacing 
adjustments for each pairwise 
combination of letters so that 
whenever a predefined pair 
occurs, the letter spacing is 
automatically adjusted.
Auto scroll:  The Auto Scroll 
feature automatically scrolls the 
screen while you are digitizing.
Auto spacing:  Auto Spacing 
only affects Satin stitch. It 
adjusts stitch spacing according 
to column width.
Auto split:  Auto Split only 
affects Satin stitch. When 
applied, it breaks any long Satin 
stitches into shorter ones. It 
also distributes needle 
penetrations in a random 
pattern so that they do not form 
a line in the middle of the 
shape. Used primarily to 
prevent long stitches in wide 
columns, it can also be used as 
an alternative to Tatami fill. 
Auto Split looks more Satin-like 
and works well with turning 
stitches, creating soft lines and 
a little more depth.
Auto start and end:  Before 
stitching, some embroidery 
machines require you to 
position the starting needle 
exactly above the first needle 



EmbroideryStudio e4 Reference Manual 1373

penetration point. Use Auto 
Start and End to connect the 
first and last stitches in the 
design. This makes it easy to 
position the needle before 
stitching, and reduces the 
chance of the needle hitting the 
side of the frame.
Automatic color change:  
Ability of multi-needle 
embroidery machine to follow a 
command to change to a 
specified needle with a different 
thread color.
Automatic pull 
compensation:  Embroidery 
stitches pull the fabric inwards 
where the needle penetrates. 
This can cause the fabric to 
pucker, and gaps to appear in 
the embroidery. Automatic pull 
compensation counters this 
effect by ‘overstitching’ outlines 
of filled shapes on the sides 
where the needle penetrates. 
This means the design can be 
optimized for different fabrics. 
See also Pull compensation.
Automatic stitch 
shortening:  Reduces stitch 
bunching at sharp corners. See 
also Stitch shortening.
Auto Trace:  Auto Trace is 
used to convert bitmap images 
to vector drawings.
Back appliqué:  A fabric piece 
used behind a design where the 
front fabric will be cut away to 
reveal the fabric beneath it.
Backdrop:  An electronic 
image used as a guide for 
digitizing designs on screen. 
Two types are used – vector or 
bitmap. Insert them from 
various file sources, or copy and 
paste them via the 
MS Windows® clipboard.
Background:  
EmbroideryStudio lets you 
change the background color of 
the design workspace to match 
the color of your fabric. Or you 
can select a background fabric 
for more realistic previews and 
presentations. The background 
is saved with the colorway.
Backing:  Also known as 
‘stabilizers’, backings are woven 

or non-woven materials placed 
beneath the item or fabric being 
embroidered for stability and 
support. A backing can be 
hooped with the item or placed 
between the machine throat 
plate and hooped garment. The 
more stitches a design has, the 
heavier the backing required. 
Backings are available in 
various weights and types such 
as cut-away, tear-away and 
wash-away (soluble). 
Professional embroiderers use 
tear-away stabilizers for woven 
fabrics and cut-away stabilizers 
for knits. See also Topping.
Backstitch:  Backstitch is an 
input method which can be used 
for delicate outlines. This stitch 
follows intricate curves well. It 
is also is the term used for 
every second row of stitches in 
a Tatami fill. See also Standard 
backstitch, Borderline 
backstitch, and Diagonal 
backstitch.
Backtrack:  Use Backtrack 
and Repeat to reinforce outlines 
while specifying the direction of 
the stitching. Backtrack stitches 
in reverse direction to the 
original. It is typically used to 
make run stitch outlines thicker 
without creating unwanted 
connecting stitches. Repeat 
duplicates the original stitch 
direction and is typically used 
with closed shapes.
Backup:  The copying of files 
onto floppy disk or other 
storage media in order to 
duplicate and secure data. 
Usually two copies are made 
and kept separately.
Batting:  A layer of padded 
material between the front and 
back fabric to add thickness and 
substance.
Begin jump function:  Begin 
Jump functions instruct the 
machine not to use needle 
penetrations. When encoded in 
an output file, it normally 
converts to a Needle In 
function. See also End Jump 
function.
Bézier curve:  Vector shape 
produced according to 
principles invented by French 

engineer, Pierre Bézier. A Bézier 
curve consists of a series of 
segments with shapes 
generated by cubic functions. 
Each segment is bounded by 
nodes, and its curvature is 
affected by a control point 
associated with the node at 
each end. The displacement and 
direction of the control point 
from the node are parameters 
from which the cubic curve 
shape is derived.
Bitmap:  Also known as raster 
images, bitmaps are electronic 
images made up of dots or 
‘pixels’, in contrast to vector 
‘outlines’. Each pixel is mapped 
to a location in an image and 
has numerical color values. 
Typically created in paint 
programs, bitmaps have file 
extensions such as BMP, JPG, 
GIF, TIF and PCX. When 
enlarged or scaled down, vector 
drawings preserve image 
quality while bitmap images 
generally cause problems of 
pixelation and image 
degradation. See also Pixels.
Blackwork:  Blackwork gets 
its name from the black silk 
thread traditionally used in this 
form of embroidery. It can be 
used to decorate articles such 
as hankies, table napkins, table 
clothes, and doilies.
Blatt stitch:  Schiffli term 
meaning ‘to feed the yarn’, 
thereby producing a long zigzag 
stitch with threads lying close 
together. Adapted for Multihead 
use. See also Satin stitch.
Blending:  See Color 
Blending.
Bling:  Refers to decorative 
objects placed on a garment or 
template. They are supplied in 
various sizes, shapes, colors 
and materials. Often referred to 
as rhinestones.
Block:  The basic unit of a quilt 
top.
BMP:  MS Windows® bitmap 
image format. See also Bitmap.
Bobbin:  Spool or reel that 
holds the bobbin thread, which 
helps form stitches on the 
underside of the fabric.
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Bobbin thread length:  This 
factor provides a simple 
mechanism for a more accurate 
bobbin thread length estimate. 
The default value (100%) is 
suitable for a design with a 
mixture of stitch types. If the 
design is all run stitches or all 
tatami, more bobbin thread will 
be used and the factor can be 
increased say to 125%. If the 
design is all satin stitch, the 
factor can be reduced to say 
65%.
Bonding:  Permanently joining 
two fabrics together with a 
bonding agent. Heat sealing.
Border:  Single closed-curve 
object which can be optionally 
added to a monogram. Also, a 
strip of fabric that is joined to an 
inner quilt to enhance it.
Borderline backstitch:  The 
rows are approximately parallel. 
With lower density fills, 
borderline backstitch creates a 
smooth, well-defined edge. 
Borderline backstitch is also 
called Trapunto style. See also 
Backstitch.
Borer:  Borer is a sharp 
instrument attached to 
embroidery machines to 
puncture fabrics. Schiffli 
machines have built-in borer 
knives under the needle line 
which can cut different sized 
holes in fabric.
Borer depth:  You can choose 
the numbering system for 
specifying Borer depth – Plauen 
where one is the base and 
seven (7) the normal middle 
position and Saurer where the 
base is zero and the normal 
middle position is six (6).
Borer depth function:  The 
Borer Depth function controls 
the size of the boring hole. The 
deeper the borer cuts, the 
larger the hole. The borer depth 
on Schiffli machines is changed 
one value at a time. Thus a 
change in depth of three (3) 
units will be automatically 
distributed by Schiffli to three 
(3) stitches.
Borer functions:  Borer 
In/Out functions are available 
for embroidery machines 

equipped with a borer. They 
instruct the machine when to 
use the boring knife or tool 
instead of a needle.
Boring:  ‘Open-work’ 
incorporated into embroidered 
designs. A sharp-pointed 
instrument punctures, or bores, 
the fabric, and stitches are 
made around the opening to 
enclose the raw edges.
Boring tension functions:  
Start/End Boring Tension 
functions instruct servo thread 
machines to feed less thread for 
stitching in boring holes. For 
Hiraoka TNS Ein, it 
overrides/restores Stepp/Blatt 
tension.
Bounding box:  The dotted 
rectangle that appears when 
you select a range of items.
Branching:  The Branching 
feature lets you digitize like 
objects – e.g. the fingers of a 
hand – without having to think 
about the most efficient 
stitching sequence and joins.
BRO:  Bits & Volts file format.
Candlewicking:  A traditional 
white-on-white embroidery 
technique, usually done on 
white linen or cotton fabric with 
heavy cotton threads.
Card:  A paper tape to control 
the frame. Various sizes for 
Schiffli machines, 7 channel for 
multihead. See also Jacquard 
card.
Cap Corner:  A type of Smart 
Corner. Cap corners are used for 
very sharp corners as they 
produce fewer stitches.
Cascade:  A way of arranging 
open windows on the desktop 
so that they overlap each other, 
with the title bar of each window 
remaining visible.
CED:  A data condensed file 
format. 
Center at current stitch:  
The object will be placed with its 
center at the needle position 
marker.

Center run underlay:  
Center Run underlay places a 
row of stitches along the center 
of a column. It is used to 
stabilize narrow columns (e.g. 
2-3 mm wide).
Chain stitch:  Stitch that 
resembles a chain link, formed 
with one thread fed from the 
bottom side of the fabric. Done 
on a manual or computerized 
machine with a hook that 
functions like a needle.
Checkbox:  A small square 
box that appears in a dialog box 
and that can be selected or 
cleared. When selected, a tick 
or a cross appears. A checkbox 
represents an option that you 
can set.
Chenille:  Form of embroidery 
in which a loop (moss) stitch is 
formed on the top side of the 
fabric. Uses heavy yarns of 
wool, cotton or acrylic. Created 
by a chain stitch machine that 
has been adjusted to form this 
stitch type. Also known as ‘loop 
piling’.
Click:  Press and release the 
left mouse button. See also 
Right-click.
Click-and-drag:  Click to 
select, hold down the left mouse 
button, move the cursor and 
release.
Clipboard:  A temporary 
storage area in PC memory for 
what was last cut or copied. 
Images on the clipboard can be 
pasted into designs any number 
of times.
Close button:  Used to close a 
window or an application. In 
MS Windows®, it appears as a 
small box with an ‘X’ in it at the 
top-right of the title bar.
CND:  Melco Condensed (CND) 
is the native file format of the 
Melco embroidery digitizing 
software. CND files store only 
digitized outlines and stitch 
values.
Color blending:  Digitizing 
technique which creates 
interesting perspective, shading 
and color effects by blending 
colored layers. Two colors are 
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merged smoothly from one to 
another using a mixture of 
dense and open fill.
Color block:  A color block or 
‘element’ corresponds to a color 
change in the design. It may be 
comprised of one or more 
same-color objects. These may 
form a single group – e.g. 
‘ropes’ – or more – e.g. ‘ropes 
and birds’. Each color block, or 
element, can be given a 
descriptive name for easy 
identification. These then 
appear on the production 
worksheet. The operator 
generally uses them to ensure 
correct colors are used during 
production. The Color-Object 
List provides a sequential list of 
objects as digitized, grouped by 
‘color block’. This list shows a 
separate icon for all color blocks 
and objects used in the design. 
The Color Palette Editor also 
shows a list of color blocks. 
Color-change function:  
Color-change functions tell the 
Schiffli machine to change 
thread color. In RCC/INC 
machines, the command also 
moves the frame under the next 
selected needle. They are 
automatically inserted when 
you select a new color from the 
color palette.
Color depth:  Color depth, 
also called ‘pixel depth’, refers 
to the amount of color 
information available to each 
pixel in an image. An image with 
a color depth of 1-bit can 
display only two colors. As the 
color depth increases, more 
colors are available – 16 Colors 
(4 bit), 256 Colors (8 bit), High 
Color (16 bit), True Color (24 
bit).
Color palette:  The color 
palette contains a selection of 
thread colors tailored for each 
design. This color scheme, or 
‘colorway’, represents the 
actual thread colors in which a 
design will be stitched. See also 
Thread chart.
Color Reduction:  See Image 
Preparation.
Colorways:  Colorways are 
multiple color schemes for the 

same design. They are made up 
of colors defined in ‘color blocks’ 
which may be created in 
EmbroideryStudio or similar 
design program, or may be 
selected from a patent color 
system such as Chromatone or 
Pantone.
Column:  Narrow, long, 
curving shape.
Column A:  An input method 
used to digitize columns of 
varying width and stitch angle. 
Digitized pairs of reference 
points define the outline, while 
lines connecting the pairs define 
the stitch angles.
Column B:  An input method 
used to digitize shapes where 
one side is different to the other, 
especially where one side 
requires more reference points 
than the other. Stitches turn 
evenly throughout the entire 
shape. You can use any fill stitch 
type except Motif Fill.
Column C:  An input method 
used to digitize columns of fixed 
width. It is typically used for 
digitizing borders and outlines 
of larger shapes. You can 
digitize columns to create thick 
lines or borders. Column C is 
typically used with Satin stitch.
COM port:  A standard serial 
port used as a connection point 
for peripherals. Other ports may 
be present if the appropriate 
internal option cards have been 
installed. The computer must be 
informed which port is being 
used by which peripheral – e.g. 
COM1, COM2, etc.
Combination Split:  Use of 
different combinations of Satin 
and Tatami stitches in Program 
Split to create various effects 
with the same pattern. There 
are three Combination Split 
options – Satin in Satin, Satin in 
Tatami and Tatami in Tatami.
Command:  An instruction 
issued to the software in order 
to carry out an action. It may be 
as simple as ‘paste an object’ or 
as complex as ‘regenerate 
stitches’. It is usually activated 
via a menu item, toolbar icon, 
or command button in a dialog.

Command button:  A button 
in a dialog which executes or 
cancels the selected action. Two 
common command buttons are 
Cancel and OK.
Complex Fill:  Input method, 
used to digitize large and 
complex shapes. Allows holes to 
be designated at the same time 
the object outline is digitized. 
The object is thus digitized as 
one fill area, instead of being 
broken down into multiple 
sections. Objects so created are 
known as Complex Fill objects.
Complex Turning:  This is an 
input method used to digitize 
complex shapes with turning 
stitches. Many shapes can be 
digitized with this tool. Create 
objects using left and right 
clicks to mark reference points 
to form the boundary outlines. 
By digitizing boundaries within 
shapes, you can create filled 
objects with holes.
Condensed file:  See Design 
file.
Configuration:  The size and 
type of computer hardware. 
Can also be used to mean the 
options provided with your 
software.
Confirmation message:  A 
message displayed by the 
software asking you if you are 
sure you want to proceed – e.g. 
when you want to delete a 
design.
Connection Manager:  A 
software feature to allow the 
sending of files to shared 
folders.
Connector stitches:  
Connector stitches link objects 
in a design. They can be run 
stitches or jumps. You can use 
automatic settings to generate 
connectors, trims and tie-offs, 
or add them manually. However, 
automatic connectors are not 
recommended for Schiffli 
designs because machine 
functions cannot be placed on 
connector stitches (stitches in 
the Needle Out position).
Connectors:  Hardware 
devices to connect cables to 
ports. If the connection is male, 
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the port is female, and vice 
versa. The wiring configuration 
of each device is determined by 
its function.
Copy:  To place a copy of a 
selection onto the clipboard. 
See also Duplicate.
Control panel:  The panel on 
an embroidery machine by 
which the operator sets up the 
machine for embroidery 
production.
Control points:  Control 
points are used to modify object 
shapes, stitch angles and entry 
and exit points. You can change 
the shape of an object by 
moving, adding or deleting 
control points on the outline. 
For most objects, you can also 
change control points from 
corner points to curves.
Contour stitch:  Contour is a 
curved fill stitch type – stitches 
follow the contours of a shape, 
creating a curved, light and 
shade effect. It only works on 
columnar shapes. There are two 
types – Standard and Spiral – 
both of which can be applied to 
Column A, Column B, Column C 
or Ring objects. Standard 
Contour can also be applied to 
Circle objects.
Copyright:  A right granted by 
the government or by 
international agreement giving 
the owner the exclusive 
privilege to publish and sell 
artistic work during the life of 
the creator plus 50 years.
Cord functions:  Cord In/Out 
functions tell the machine to 
engage or disengage the cord 
device.
Cording:  Cording is a 
technique which employs a 
single decorative cord laid on 
fabric and attached with 
transparent zigzag stitches. It 
forms relatively simple, 
low-stitch-count designs 
featuring lots of swirls and 
curves. Raised cording is 
achieved by sewing the 
garment around the cord from 
the wrong side. The result is a 
self-fabric raised effect. 
Different widths of cording are 
available to provide a wide 

range of looks. A special 
attachment is required for the 
embroidery machine.
Cord-in-lay:  A special 
apparatus to automatically lay 
on cord or ribbons on a Schiffli 
machine.
Cover stitch:  Cover stitch is 
the border around an appliqué 
shape. You can control various 
settings including cover stitch 
type – Satin or E Stitch – width, 
stitch spacing, as well as the 
offset.
Conversion software:  
Programs that read information, 
other than from a card, and 
translate it from one sewing 
machine format to another. 
Converter box:  A converter 
box acts like a translator from 
one memory card format to 
another, via computer. Various 
companies offer this technology 
under names like the Magic 
Box™ from Oklahoma 
Embroidery. They translate 
designs from memory cards in 
other formats or from a hard 
drive, disk, or CD and write the 
design to a blank card. 
Crest:  An embroidered motif 
like an emblem, an insignia or a 
Coat of Arms.
Crystals:  See Bling.
CPU:  Central Processing Unit.
CSD:  
POEM/Singer/Huskygram file 
format
Current settings:  Current 
property settings override the 
template defaults. Unless you 
deliberately change them, these 
take the default values. You 
generally change them to save 
time when digitizing. For 
example, you may preset 
Tatami stitch spacing to use a 
specific density for all new 
Tatami objects you create. See 
also Object properties.
Custom:  Lets you map thread 
colors to every stop code in the 
file. This means you can 
color-code machine file designs 
which do not contain needle 
addressing information, before 
opening the file.

Custom fonts:  Custom fonts 
are made up of letters, numbers 
or symbols you digitize.
Custom designs:  Designs 
created by digitizing artwork or 
manipulating existing patterns.
Cut:  An editing function. To 
remove a selection from a 
design. The cut selection is 
stored in memory (on the 
‘clipboard’) and can be pasted 
into the same or different 
design.
Cut appliqué:  See Back 
appliqué.
Cutter:  See Appliqué cutter.
Cutting lines:  A second line 
of run stitches that forms a 
guide when trimming the fabric 
of an appliqué patch.
DAT:  DAT is the machine file 
extension used with Hiraoka, 
Laesser, and Wilcom SPES 
formats.
Default object properties:  
See Default values.
Default values:  predefined 
settings which determine object 
properties such as stitch 
spacing, as well as certain 
system settings. These are 
stored in the design template. 
They are automatically applied 
to any newly created objects. 
They remain ‘current’ unless 
you override them with new 
settings. See also Current 
property settings.
Defects:  See Stitching 
defects.
Density:  See Stitch density 
or Thread density.
Design:  A ‘design’ is a file in 
the native embroidery format – 
e.g. EMB, JAN, ART – of 
embroidery digitizing software. 
The design source may be a 
stitch format design. The design 
contains stitching information 
such as fabric type in addition to 
stitched shapes.
Design card:  Disk containing 
computerized embroidery 
designs read by the embroidery 
machine’s computer.



EmbroideryStudio e4 Reference Manual 1377

Design elements:  The 
decorative design components 
that make up a monogram 
(including ornaments and 
borders).
Design file:  Design files, also 
known as ‘all-in-one’ or ‘outline’ 
files, are high-level formats 
which contain object outlines, 
object properties and stitch 
data. Examples include CND, 
GNC, INP and PCH. When you 
open a design file in 
EmbroideryStudio, 
corresponding stitch types, 
input methods and effects are 
applied. Design files can be 
scaled, transformed and 
reshaped without affecting 
stitch density or quality. See 
also Machine file.
Design object:  See Objects.
Design information:  
Designs themselves have 
properties, some of which can 
be modified, others not. The 
most important design property 
is its source – Native Design, 
Imported Outlines, Processed 
Stitches, or Imported Stitches. 
Other properties include the 
software version number, stitch 
count, and so on. Colorways too 
are properties of the whole 
design.
Design repeat:  A Schiffli 
design is repeated horizontally 
as many times as it fits across 
the frame. Repeat values 
increment in multiples of 4 to a 
maximum of 96. For example, 
the design can be stitched by 
every needle (Repeat=4/4), 
every second needle 
(Repeat=8/4), or every third 
needle (Repeat=12/4), and so 
on.
Design source:  While 
embroidery files are broadly 
classified as ‘design’ (outline) or 
‘machine’ (stitch), 
EmbroideryStudio internally 
tags files as belonging to one of 
four types–Native Design, 
Imported Outlines, Processed 
Stitches, or Imported Stitches. 
See also Design information.
Design template:  See 
Template.

Design Workspace:  The 
design workspace is where 
designs are displayed for 
viewing and modification.
DW Administrator:  It is the 
DW Administrator who is 
generally responsible for the 
high-level setup of 
DesignWorkflow databases. The 
DW Administrator determines 
who gets access to databases, 
what users can see and do, and 
who defines the categories 
under which information will be 
stored. The DW Administrator is 
generally the manager of the 
company’s design section. This 
person has the necessary 
background knowledge and 
authority to control what goes 
into databases and how the 
information is to be used.
Desktop:  MS Windows® 
terminology for the screen 
background on which program 
icons are displayed.
Destination folder:  The 
folder (directory) where you 
intend to copy or move one or 
more files.
Detail:  An outline, a border, a 
pickout run, or a small area of 
the design you want to be 
stitched out last when using 
Smart Design.
Diagonal backstitch:  The 
backward rows are diagonal, 
directly connecting the forward 
rows. Diagonal backstitch is 
suitable for turning shapes, and 
gives good results with Jagged 
Edge. See also Backstitch.
Dialog:  An onscreen box that 
either requests or provides 
information. Many dialogs 
present options to choose 
among before a command is 
carried out. Some dialogs 
present warnings or explain 
why a command cannot be 
completed.
Digitizer:  Usually refers to 
the person punching or 
digitizing the design. Digitizer 
can also refer to the digitizing 
tablet used by the digitizer. See 
also Digitizing tablet.
Digitizing:  Process of 
encoding a design. Artwork is 

converted into a series of 
‘embroidery objects’ to be read 
and manipulated by a specialist 
CAD/CAM application. Before 
outputting to embroidery 
machine, it is converted into 
‘stitch data’. See also 
Punching.
Digitizing puck:  With a 
digitizing tablet, you generally 
use a puck instead of a mouse 
to mark reference points and 
select commands from the 
menu chart.
Digitizing tablet:  Design 
device used by digitizers to plot 
needle penetrations for 
embroidery designs. 
Sometimes used as an 
alternative to digitizing directly 
on-screen. Typically, a pencil 
drawing of the design is 
enlarged and then taped to this 
tablet. The digitizer then uses a 
device known as a puck to 
indicate stitch types, shapes, 
underlay and actual needle 
penetrations.
Digitizing tool:  Digitizing 
tools, sometimes referred to as 
‘input methods’, are similar to 
drawing tools except that the 
end result is an embroidery 
object rather than a vector 
object. Different digitizing tools 
are suited to creating different 
shapes or design elements.
Direct-to-garment 
printing:  DTG is performed 
like most other printing from a 
PC. The print image is sent to 
the DTG printer through the 
MS Windows® print manager 
using a print driver. The image 
must have a transparent 
background for DTG printing. 
DTG printing requires heat 
fixing to make the images 
washable.
Disk:  See Floppy disk.
Disk drive:  Computers 
usually have three types of disk 
drive: a hard disk (or fixed disk) 
which usually supports the 
mass storage of information 
and applications, a floppy disk 
drive, and a CD ROM drive.
Display:  A screen used to 
display the output of a 
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computer. Also known as the 
monitor.
Dithering:  A software 
technique which combines 
existing colors in a 
checkerboard arrangement of 
pixels. It is typically used to 
simulate colors that are missing 
from an image palette. A type of 
optical illusion created by 
placing two pixels of different 
color next to each other. The 
human eye automatically 
resolves the two colors into a 
third color.
Docker:  A dialog which, while 
open, allows the user to select 
objects freely. Controls in the 
dialog change to conform to the 
values of selected objects, or 
show relevant system 
information when no object is 
selected. Changes made to 
settings in the dialog may be 
applied while it remains open. 
Other dialogs and commands 
may be opened and used while 
the modeless dialog remains 
open.
Dongle:  A security hardware 
device required to run protected 
software. Some are attached to 
a parallel port, others to a USB 
port.
Dots per inch (DPI):  A 
measurement of screen or 
printer resolution – the number 
of dots in a line of 1".
Double split alternate:  A 
variant of Tatami split. See User 
Defined Split.
Double-click:  Click the left 
mouse button twice without 
moving the mouse. 
Double-clicking carries out 
actions such as opening a 
program from an icon.
Download:  The process of 
transferring a copy of a file from 
a remote computer or the 
internet to a computer or other 
device such as an embroidery 
machine.
Drag:  An operation of the 
mouse. Holding the (left) 
mouse button while moving the 
mouse. Typically used for 
moving something on the 
screen.

Drawing object:  See Vector 
object.
Drawing package:  Software 
application that creates or 
allows you to edit vector 
graphics made up of separate 
individual vector objects. Vector 
graphics can be scaled with no 
loss of sharpness. Examples of 
vector editing programs are 
Adobe Illustrator, MacroMedia 
Freehand and Corel Draw. See 
also Graphics application.
Droplist :  A single-line dialog 
box control that opens to 
display a list of choices.
Drop sequin function:  The 
Drop Sequin function is 
available for embroidery 
machines equipped with a 
sequin dispenser. It instructs 
the machine when to drop a 
sequin on the fabric for 
stitching.
DSB:  Barudan file format. 
Basically the same as the T03 
tape file but wit a ‘header’ in 
front so that it can be written to 
floppy disk – i.e. it is the floppy 
disk version of the T03 file.
DST:  Machine file format 
native to Tajima machines.
DSZ:  ZSK stitch or ‘expanded’ 
file format.
Duplicate:  When an object is 
duplicated, it is not copied to 
the clipboard. This leaves the 
clipboard free for you to cut or 
copy other objects.
DXF:  AutoCAD vector graphic 
format.
E Stitch:  Widely used for 
tacking down appliqués as a 
decorative border. The stitches 
form a comb pattern.
Editing:  Changing aspects of 
a design via a computerized 
editing program. Most programs 
allow you to scale designs up or 
down, edit stitch-by-stitch or 
block-by-block, merge lettering 
with the design, move aspects 
of the design around, combine 
designs and insert or edit 
machine commands.
Elastic lettering:  Special 
effects applied to lettering 

objects to make them bulge, 
stretch or compress. 
Electronic artwork:  There 
are two broad categories of 
artwork file, both of which can 
be imported into 
EmbroideryStudio for use as 
digitizing backdrops – vector 
and bitmap. To create good 
quality embroidery, you need to 
choose or create suitable 
artwork of either format.
Element:  An element, in 
software terms, is a color block 
consisting of sequential, 
same-color objects. You can 
assign names to elements 
which then appear on the 
production worksheet. The 
operator generally uses these to 
make sure colors are correct 
during production. See also 
Production worksheet.
EMB:  Design file format native 
to Wilcom ES. EMB designs 
contain a complete set of design 
information in a single 
‘all-in-one’ file – object outlines 
and properties, actual stitches 
and machine functions, thread 
colors, a picture icon, summary 
information, and more. Even 
the original design bitmap 
image can be included in EMB 
format. Only native EMB files 
provide 100% perfect scaling 
and transformation.
Emblem:  Embroidered design 
with a finished edge, applied to 
a garment after stitching, 
commonly an insignia of 
identification. Also known as a 
‘crest’ or ‘patch’.
Emblem work:  Many Schiffli 
machines are used for creating 
emblems or logos. This work, 
however, uses only a small 
subset of the available functions 
of the Schiffli machine. 
Typically, for example, emblem 
work does not contain the bored 
holes or long Satin stitches 
which occur in lace designs. 
Emblem work is also stitched on 
Multihead machines.
Embroidery:  Decorative 
stitching on fabric. Generally 
involves non-lettering designs, 
but can also include lettering 
and/or monograms. Evidence of 
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embroidery exists during the 
reign on Egyptian pharaohs, in 
the writings of Homer and from 
the Crusaders of the 12th 
century. Has evolved from 
hand-work to manual sewing 
machines and from hand-looms 
and Schiffli machines with 
hundreds of needles to 
high-speed, computerized 
multihead machines.
EmbroideryConnect 
device:  Wilcom-supplied 
device to enable connection of 
USB-enabled embroidery 
machines to an 
EmbroideryConnect machine 
network via a WiFi router.
Embroidery disk:  
Embroidery disks are specially 
formatted floppy disks used to 
transfer designs from computer 
to embroidery machine. You can 
format embroidery disks and 
save designs to them from 
within EmbroideryStudio. The 
format you use will depend on 
the selected embroidery 
machine. You can also open 
designs from embroidery disk 
directly into EmbroideryStudio. 
Embroidery objects:  In 
embroidery design, you build 
designs from basic shapes or 
‘embroidery objects’. They are 
called ‘objects’ because they 
are discrete entities which can 
be selected and manipulated 
independently of each other. 
They are like ordinary vector 
objects in that they have certain 
characteristics or ‘properties’ 
such as color, size, position, and 
so on. They also have properties 
unique to embroidery such as 
stitch type and density. See also 
Vector objects.
Embroidery thread:  See 
Thread.
Emery roller:  The Schiffli 
roller on which threads are 
twisted and tensioned.
Empty function:  An ‘empty 
stitch’, or non-data stitch, is an 
industry term for any stitch with 
a zero movement (0, 0). 
However, EmbroideryStudio 
distinguishes between 
intentional empty stitches 
related to the machine 

functioning, and unintentional 
empty stitches, which can occur 
in small or pointed parts of 
shapes. An empty function is an 
empty stitch that the system 
processes as a machine 
function. It is not removed by 
the small stitch filter and is 
preserved when stitches are 
regenerated or the design is 
resized. See also Empty stitch.
Empty jump:  You create 
empty jumps (0,0) manually in 
EmbroideryStudio by digitizing 
with Penetrations Out. This 
prevents the needle from 
penetrating the fabric, forcing 
the machine to move across the 
design in a series of jumps. 
Also, use empty stitches or 
empty jumps when required by 
the selected machine format. 
See also Empty stitch.
End Jump function:  End 
Jump functions instruct the 
machine to use needle 
penetrations. When encoded in 
an output file, it normally 
converts to a Needle In 
function. See also Begin Jump 
function.
Empty stitch:  Empty stitch is 
a tight (zero length) lockstitch, 
used together with, or as an 
alternative to, tie-in and tie-off 
stitches, particularly in objects 
filled with light density stitching 
where standard tie-ins and 
tie-offs may be visible. Also, use 
empty stitches or empty jumps 
when required by the selected 
machine format. See also 
Empty jump and Empty 
function.
EMX:  Wilcom cross stitch file 
format.
End X/Y:  The coordinates of 
the last stitch.
Enlargement drawing:  The 
technical drawing, usually six 
times larger than the original 
design, indicating the stitches 
to be digitized. When you 
digitize with a tablet, you use an 
enlargement drawing to trace 
the shapes and outlines of the 
design in the same way you use 
backdrops on-screen. Before 
you start, you need to prepare 

the enlargement drawing. See 
also Digitizing tablet.
Enlarger:  The draftsman or 
designer who draws the 
technical drawing for the 
puncher to follow.
Entry point:  The entry point 
is the point where the thread 
enters the embroidery object. 
This should coincide with the 
exit point of the preceding 
object.
Envelope:  Special effect 
which makes objects bulge or 
arch, stretch or compress. 
Envelope is typically applied to 
lettering objects, but can also 
be applied to other types of 
embroidery object.
EPS (Encapsulated 
PostScript):  A standard file 
format for importing and 
exporting PostScript language 
files among applications in a 
variety of environments. An ESP 
file is a PostScript file which 
describes a single page, usually 
an illustration. In general, the 
purpose of the EPS file is to be 
included (encapsulated) in 
another PostScript file and can 
contain any combination of text, 
graphics and images. EPS files 
normally include a small, 
low-resolution TIFF, or 
vector-based MS Windows® 
metafile image preview, as it 
will appear on a printed page.
ESD:  Native DOS format of 
Wilcom DOS ES – contains 
stitch data, like stitch types and 
densities, which permits better 
processing. ESD in later 
versions contains lettering 
objects with outlines.
ESL:  ESL is a file used to 
produce any Wilcom Schiffli Tnn 
file from EmbroideryStudio. It is 
read but not written by the 
Schiffli Converter to produce 
RCC Tnn files.
ESS:  ESS is the primary 
machine file format for 
Wilcom-developed Schiffli servo 
control systems. When the ESS 
file is read directly by a Wilcom 
Electronic Servo System 
(WESS), high data resolution 
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and stitch accuracy are 
possible.
Exit:  To leave a current 
window or application.
Exit point:  The exit point is 
the point where thread leaves 
the embroidery object. This 
should coincide with the entry 
point of the next object.
EXP:  Stitch or ‘expanded’ file 
format native to Melco 
machines.
Expanded file format:  See 
Machine file.
Expanded tape:  An 
expanded tape which has every 
stitch of the design punched.
Extension:  See File 
extension.
Fabrics:  Fabrics have many 
properties, the main one being 
elasticity or ‘fabric stretch’. 
Surface texture, if present, is 
another property that requires 
different underlay types. When 
you choose a fabric for use with 
a particular design, the system 
pre-loads settings optimized for 
that fabric. These can be 
overridden on an 
object-by-object basis. See also 
Fabric settings.
Fabric settings:  predefined 
fabric settings include settings 
for all full-coverage stitch types. 
For each stitch type, spacing is 
preset. Additionally, the quality 
effects of pull compensation and 
underlay are also preset for 
each stitch type. Push, warping, 
and shearing are reduced by 
suitable underlay for the stitch 
type and fabric. Decorative 
effects such as Motif Fill are not 
affected when fabric settings 
are changed.
Fabric stretch:  Embroidery 
stitches pull the fabric inwards 
where the needle penetrates. 
This can cause the fabric to 
pucker, and gaps to appear in 
the embroidery. Use automatic 
pull compensation to counter 
this effect by ‘overstitching’ 
outlines of filled shapes.
Facing:  See Topping.

Factory settings:  These are 
the initial system settings as 
installed. They are a standard 
known setting that you can 
return to. Some customers 
want to create custom settings 
tailored to the exact fabric they 
are using most frequently. The 
‘My Fabric’ settings are those 
retained in the design and can 
be saved to the template file.
Fadenleiter:  Fadenleiter is a 
mechanism on some Schiffli 
machines for controlling the 
feed and tension of yarns.
Fadenleiter functions:  
Fadenleiter +/- functions 
instruct the machine to increase 
or decrease Fadenleiter stroke 
one increment. This means 
increasing or decreasing thread 
feed because the section is 
getting wider/narrower.
FDR:  An embroidery disk 
format native to Barudan 
machines.
Festoon:  Festoon is a 
mechanism on some Schiffli 
machines for reinforcing edges 
on scallops, etc, for a strong 
cutting edge. It is also the name 
of a stitch type.
Festoon functions:  Festoon 
In/Out functions instruct the 
machine to engage or 
disengage the festoon device.
File:  A named collection of 
specifically related information 
stored on a disk. Designs that 
have been saved are stored as 
files.
File extension:  The dot and 
three letters at the end of a 
filename such as ‘.BMP’. The 
extension identifies the file as a 
certain type, readable by 
certain applications.
Filename:  The name of a file, 
including the extension, e.g. 
Cat.BMP.
Fill stitch:  Series of running 
stitches commonly used to 
cover large areas. Different fill 
patterns can be created by 
altering the angle, length and 
repeat sequence of the stitches. 
Also known as Geflect stitch.

Finishing:  Processes done 
after embroidery is completed. 
Includes trimming loose 
threads, cutting or tearing away 
excess backing, removing 
facing or topping, cleaning any 
stains, pressing or steaming to 
remove wrinkles or hoop marks 
and packaging for sale or 
shipment.
FIXPAT:  The FIXPAT (Fix 
Pattern) utility is a conventional 
Schiffli visual-editing program 
which displays the tape file in 
the Jacquard card format with 
holes. The program is good for 
safety-checking designs and 
can be useful as a fast editor for 
known problem patterns as well 
as direct function editing.
Flagging:  Up and down 
motion of fabric under action of 
the needle, so named because 
of its resemblance to a waving 
flag. Often caused by improper 
framing of goods. Flagging may 
result in poor registration, 
unsatisfactory stitch formation 
and birdnesting.
Float:  Longer-than-normal 
Satin stitches that lay on top of 
a design, or the stitches made 
when the needle is 
disconnecting from the design, 
later removed.
Floppy disk:  A flexible disk 
permanently sealed in a square 
plastic jacket – e.g. HD/DD 3.5" 
floppy disk. Used for 
information storage ‘off-line’ for 
security and/or infrequently 
used data. Also used for 
transferring punched 
embroidery design (machine 
file) data from computer to 
embroidery machine.
Florentine effect:  With 
Florentine Effect you can curve 
Complex Fill along a digitized 
line to create flowing stitch 
effects. The stitches follow the 
digitized line but maintain 
uniform density and needle 
penetration patterns.
FMC:  An embroidery disk 
format native to Barudan 
machines.
Folder:  A collection of files 
and subfolders that are stored 
together on a disk. Part of 
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structure for organizing files on 
a disk.
Font:  A set of characters, 
including letters, numbers and 
other typographic symbols, of 
the same design and style. 
Sometimes called ‘alphabet’, 
even if it includes non-letter 
characters. See also Lettering.
Following:  The directions 
drawn on the enlargement by 
the designer as a guide for the 
puncher's advancement and 
sequence in punching.
Fox test:  Method of testing 
thread tension and soundness 
of timing. Sew the word FOX in 
one-inch Satin stitch block 
letters with each needle bar, 
then examine the reverse side 
for skipped stitches and 
correctly balanced ratio of top 
thread to bobbin thread. The 
correct balance is generally 
considered to be a one-third 
ratio of bobbin thread to 
two-thirds top thread. These 
letters are used because they 
require the movement of the 
pantograph in all directions, 
increasing the likelihood that 
the beginnings of timing 
irregularities will be discovered.
Fractional spacing:  
Fractional spacing is used to 
place stitches more evenly in 
curved shapes, producing 
better quality embroidery with 
fewer stitches. Fractional 
spacing is particularly useful for 
columns of Satin stitches with 
sharp turns.
Frame:  Holding device to 
secure fabric under an 
embroidery head for stitching. 
May employ a number of means 
to maintain stability during the 
embroidery process, including 
clamps, vacuum devices, 
magnets, or springs. See also 
Hoop.
Frame-out position:  When 
you stitch out appliqué objects, 
you can set a frame-out 
position. This shifts the hoop 
out from under the needle, 
making it easier to place and 
trim the appliqué shapes. The 
frame out settings determine 

the distance and direction of the 
hoop movement.
Free Line baseline:  Free 
Line is the only type of baseline 
which does not have a fixed or 
pre-determined length. When 
you choose Free Line, the 
baseline will extend as long as 
you keep adding letters. You 
only need to mark its start 
point. See also Baseline.
French inch:  The French inch 
is a measurement used for 
spacing needles on the Schiffli 
machines (c. 27mm). See also 
Needle spacing.
Fringe:  Threads that are cut 
and hang loosely from the edge 
of a design.
Function:  See Machine 
Function.
Geflect stitch:  Geflect refers 
to light or heavy stitching used 
to fill in an area of a design with 
run stitches. It is also known as 
Ceeding or Tatami. See also Fill 
stitch.
Generic Shiffli machine 
format:  Because there are 
many types of Schiffli machine, 
individual settings can be quite 
different even though the 
capabilities are the same. To 
deal with this, Schiffli uses the 
concept of the ‘Generic Schiffli 
Machine’. The Schiffli generic 
machine format supports 
functions required for a wide 
range of machine types.
Glitz:  See Bling.
Graphics application:  
Software application that 
creates or allows you to edit 
bitmap images and/or vector 
graphics. See also Paint 
package and Drawing 
package.
CorelDRAW Graphics:  An 
operating mode in which the 
CorelDRAW® Graphics Suite 
application is active.
Gradient Fill:  An artistic 
stitch effect that gradually 
varies stitch spacing between 
dense and open fill along an 
embroidery object, producing 
shading and color effects which 

are difficult to achieve 
manually.
Grayscale:  A grayscale 
picture is made up of 254 
different shades of gray, plus 
solid black and solid white for a 
total of 256 different tones. 
Black and white photographs 
are grayscale.
Grid:  Grid lines provide visual 
cues to help you accurately 
place a design. When you start 
the software for the first time, 
grid lines appear by default.
Guide runs:  Series of stitches 
used to align embroideries in 
multi-hooping situations or to 
assist in fabric placement for 
appliqué. It is the first appliqué 
layer stitched and is used to 
position the pre-cut appliqué 
patches on the background 
material. See also Appliqué.
Hard disk:  A device for mass 
information storage. Usually the 
disk is fixed inside the system 
unit, and a second hard disk can 
be added. When you store 
information on the hard disk it 
will remain there until you 
delete it. As it has a finite 
capacity, file management is 
required.
Hardware:  Computer 
componentry, including 
monitor, keyboard, digitizing 
tablet, printer, scanner, sewing 
machine, etc.
Heat transfer printing:  A 
process which is sometimes 
used in the production of a 
printed design for commercial 
use employs heat transfer 
paper to which graphics are 
printed. This is then heat-fixed 
to a garment using an iron or 
heat-press. The process falls 
into the same category as 
printing. Printers that support 
heat transfer media in most 
cases provide an automatic 
mirror function in the printer 
driver as the image must be 
printed in reverse in order to be 
heat-transferred to a garment. 
See also Direct-to-garment 
printing.
Heinzle:  Heinzle is a Schiffli 
disk format.
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Heirloom embroidery:  
Embroidered goods designed to 
be passed down from 
generation to generation.
Hiraoka DAT:  Hiraoka DAT is 
a Schiffli disk version of the 
Plauen card format for Hiraoka 
machine.
Hoop:  Device made from 
wood, plastic or steel used to 
tightly grip fabric and stabilizer 
between an inner and outer 
ring. Designed to hold fabric 
taut against the machine bed 
for embroidering, it attaches to 
machine’s frame.
Hooping:  The process of 
placing the fabric and/or 
stabilizer into the embroidery 
hoop. One of the most common 
reasons for a poorly stitched 
design is improper hooping. 
I-beam:  One shape taken by 
the PC pointer, it indicates that 
text can be input at the point 
selected. The shape is like the 
capital letter ‘I’.
Icon:  Miniature picture used in 
the screen display instead of, or 
as well as, text. The file list can 
be displayed as icons with the 
filenames beneath. The 
toolboxes which appear in the 
left of the screen are composed 
of icons.
Image editing program:  
See Graphics application.
Image preparation:  
Cleaning up scanned images as 
input to embroidery digitizing. 
This may involve any one or a 
combination of the following 
techniques: reducing the 
number of colors, adding or 
emphasizing outlines, removing 
noise, dithering or anti-aliasing, 
eliminating unnecessary detail, 
cropping sections or eliminating 
backgrounds.
Imported outlines:  Designs 
read from non-EMB outline – 
CND or PCH – where stitches 
have been generated in 
EmbroideryStudio (or 
equivalent) from original 
outlines and stitching data.
Imported stitches:  Designs 
read from stitch or ‘expanded’ 

files, with or without outline 
recognition, but stitches have 
not been regenerated through 
stitch processing. Note that if 
you change a stitch design – 
e.g. add a lettering object – the 
status changes to ‘Processed 
Stitches’ even though the 
imported stitches may not have 
been regenerated.
INC:  Individual Needle Control 
(INC) was a mechanism 
originally developed for Saurer 
Pentamat machines whereby 
each needle/borer position 
across the whole machine could 
be activated or de-activated 
individually, either under 
program or manual control. 
INP:  Wilcom condensed file 
format.
Input method:  See 
Digitizing tool.
Jacquard card:  Historically 
Schiffli designs were stored on 
Jacquard cards of which there 
are two types – Plauen and 
Saurer. Named after Joseph M 
Jacquard, inventor of the 
Jacquard loom, Jacquard cards 
contain a stitch-by-stitch 
interpretation of the design 
together with machine 
functions, exactly as the 
embroidery machine will read it, 
encoded as a series of holes. 
Later applied to 68 mm tape 
used to program automated 
embroidery machines. See also 
Tape code.
Jagged edge:  Technique for 
creating rough edges, to create 
shading effects, or to imitate fur 
or other fluffy textures in your 
design.
JPG:  JPEG file interchange 
bitmap image format.
Jump:  A frame or hoop 
movement without a needle 
penetration, commonly used to 
get from one point in a design to 
another. In Schiffli terms a 
Jump stitch means a frame 
movement in Needle Out mode.
Jump function:  Jump(M) 
functions cause frame 
movements without needle 
penetrations and are used to 

move smoothly from one part of 
a design to another.
Justification:  The position of 
lettering on the embroidery 
baseline.
Lacework:  Lacework involves 
the use of threads to produce 
overall embroidery of full-length 
fabrics. Most often used to 
embellish women's apparel and 
home fashions. Such work 
typically uses boring. It is the 
most widely used application for 
Schiffli machines.
LAN:  Local Area Network – a 
wired network of 
interconnected PCs and other 
network enabled devices such 
as printers.
Letter spacing:  The space 
between adjacent letters.
Letters:  Initials or name 
making up a monogram. Letters 
of a font.
Lettering:  Embroidery using 
letters or words. Lettering 
commonly called ‘keyboard 
lettering’ may be created from 
predefined font styles or fonts, 
allowing variance of size, 
height, spacing, density and 
other characteristics.
Line art:  A drawing with only 
two colors – usually black and 
white.
List box:  A single-line dialog 
that opens to display a list of 
choices.
Lockstitch:  Commonly 
referred to as a lock-down or 
tack-down stitch, a lockstitch is 
formed by three or four 
consecutive stitches of at least a 
10-point movement. It should 
be used at the end of all 
columns, fills and at the end of 
any element in your design 
where jump stitches will follow, 
such as color changes or the 
end of a design. May be stitched 
in a triangle, star or in a straight 
line. Lock stitch is also the name 
of the type of stitch formed by 
the hook and needle of home 
sewing machines, as well as 
computerized embroidery 
machines.
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Lockstitch machines:  Both 
Schiffli and Multihead machines 
are lockstitch machines, 
forming stitches in the same 
way as a home sewing machine. 
Lockstitch operations involve 
two threads – top and bottom. 
The top thread is driven by a 
needle, the bottom by a shuttle. 
The bottom thread ‘locks’ the 
top thread in place, hence the 
name ‘lockstitch’. See also 
Multihead lockstitch 
machine.
Logical machine 
functions:  Schiffli makes a 
distinction between ‘logical’ and 
‘physical’ machine functions. 
The logical machine function is 
what you, the digitizer, want to 
perform – for example, start or 
stop boring. Logical functions 
are saved as ‘object properties’ 
in the native Wilcom EMB design 
file.
Logo:  Name, symbol or 
trademark of a company or 
organization. Short for 
logotype.
Looms:  See Schiffli.
Loom run:  The stitching of 
one complete pattern in one 
row on a Schiffli machine.
Looping:  Loops on the surface 
of embroidery generally caused 
by poor top tension or tension 
problems. Typically occurs when 
polyester top thread has been 
improperly tensioned.
Machine file:  Machine or 
‘stitch’ files are low-level 
formats for direct use by 
embroidery machines. They 
contain only stitch coordinates 
and machine functions. Machine 
files are generally not suited to 
scaling because stitches are not 
regenerated during rescaling. 
See also Design file.
Machine format:  Different 
embroidery machines 
understand different languages. 
They have their own control 
commands for the various 
machine functions. Before you 
can stitch a design, it must be in 
a format which can be 
understood by the target 
machine. Common formats 

include Barudan, Brother, 
Fortran, Happy, Marco, 
Meistergram, Melco, Pfaff, 
Stellar, Tajima, Toyota, 
Ultramatic and ZSK.
Machine function:  Machine 
functions are commands for a 
specific embroidery machine. 
These include color changes, 
thread trims, jumps, machine 
stops, needles in/out, and 
boring begin/end. Schiffli 
makes a distinction between 
‘logical’ and ‘physical’ machine 
functions. See also Logical 
machine functions and 
Physical machine functions.
Machine unit:  The ‘machine 
unit’ is the smallest frame 
movement which the 
embroidery machine can 
perform. In Schiffli machines 
there are three types – Plauen 
(1/6 mm or 0.1667mm), Saurer 
(0.1mm), and hi-resolution 
WESS.
Machine setup:  Before you 
can send designs for stitching, 
you must configure the machine 
in EmbroideryStudio. You can 
add machines, change settings 
for machines already set up, or 
delete machines that are no 
longer required.
Magic wand:  Technique for 
creating embroidery designs by 
automatically digitizing color 
blocks in electronic images.
Manual object:  When you 
open a stitch format file without 
outline recognition, it becomes 
a single ‘manual’ object. This 
object consists of individual 
needle penetration points and 
has only general and connector 
properties. When you transform 
(scale, rotate, mirror) a manual 
object, the original stitch 
density does not change.
Max/Min stitch length:  The 
minimum and maximum stitch 
lengths allowable in a design 
determine the outside limits as 
measured between needle 
penetration points. They are 
governed by the minimum and 
maximum frame movements 
that the machine can make.
Maximize button:  For 
windows, the small box in the 

center of the group of three at 
the right of the title bar. Click 
the Maximize button to enlarge 
a window to its maximum size.
Memory:  The place in the 
computer’s system unit that 
stores information while you are 
working with it. If you exit 
without saving information in 
memory, it will be lost.
Menu bar:  The menu bar 
contains dropdown menus of 
commands. Some of the same 
commands are available on the 
toolbar.
Menu chart:  The menu chart 
provided with the software lets 
you select commands directly 
from the digitizing tablet using 
the puck. You need to ‘register’ 
it before use.
Minimize button:  For 
windows, the small box to the 
left of the group of three at the 
right of the title bar. Click the 
Minimize button to reduce a 
window to its minimum size.
Minimum stitch length:  
The minimum movement of the 
hoop. It is measured between 
needle penetration points. See 
also Max/Min stitch.
Mirror:  Duplication of an 
object in the Y and/or X axis. 
The location and orientation of 
the mirrored stitches are 
determined by location and 
angle of the axis of reflection 
relative to the position of the 
original stitches.
Mirror-merge:  Mirror-Merge 
Array can create multiple copies 
of designs, such as badges, 
spaced in rows and columns for 
faster stitchouts. Mirror-Merge 
Reflect can duplicate and mirror 
designs simultaneously. You can 
use it to quickly create borders 
or merge duplicates into a 
symmetrical object such as a 
heart. Mirror-Merge Wreath can 
duplicate objects around a 
center point. The Kaleidoscope 
tool works like Wreath but 
mirrors objects as well.
Mitre corner:  A type of 
Smart Corner. Mitre Corners 
create a sharp line at the 
intersection of the two columns. 
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They are designed primarily for 
corners between 75° and 90°. 
See also Smart Corners.
Modal dialog:  A dialog which, 
while open, prevents the user 
from selecting any control or 
object outside it. Changes made 
to settings inside the dialog are 
not effective until it is closed.
Modem:  Unit to 
telegraphically send computer 
information from one computer 
to another.
Monitor:  In computer terms, 
a device that accepts video 
signals from a computer and 
displays information. Monitors 
generally employ cathode-ray 
tubes or flat-panel displays to 
project images. In practice, the 
terms monitor and display are 
used interchangably. In 
digitizing terms, the monitor is 
where digitizing or stitching 
progress can be followed, 
stitch-by-stitch.
Monogram:  Embroidered 
design composed of one or 
more letters, usually the initials 
of a name. Can also consist of 
borders or designs to mark 
ownership of items such as 
clothing, caps, handkerchiefs, 
etc.
Moss stitch:  Chenille-type 
stitch. See Chenille.
Motif:  predefined design 
elements, such as hearts, 
leaves or border patterns, that 
can be quickly inserted into a 
design. Motifs generally consist 
of one or more simple objects, 
and are stored in a special motif 
set.
Motif Fill:  Motif Fill is a 
decorative fill stitch with which 
you can fill larger shapes. 
Depending on your software’s 
capabilities, you can also create 
special or three dimensional 
effects.
Motif run:  Motifs which are 
linked together along a digitized 
line. You can create decorative 
outlines using any motif from 
the list. 
Motif set:  Motifs are stored in 
‘motif sets’ similar to fonts. 
There are two predefined motif 

sets. One contains single motifs 
for fills which use the same 
pattern in both forward and 
backward rows. The other set is 
intended for use with two-part 
motifs which use 
complementary patterns for 
forward and backward rows. 
You can also define your own 
‘motif sets’ to organize and 
classify motifs of your own 
creation.
Mouse:  A device, equipped 
with control buttons and 
designed to roll about on the 
table next to the keyboard. As 
the mouse moves, its circuits 
relay signals that move a 
pointer on the screen.
MST:  MST is a Laesser file 
type. It includes same stitch 
data as Laesser DAT. (Not 
supported in Schiffli ES e4.)
Multicolored designs:  
Multicolored designs contain 
more than one color. Most 
Schiffli machines do not support 
automatic color change. That is, 
there is no mechanism to 
activate individual or groups of 
needles. Thus multicolored 
designs are expensive to 
produce because operators 
need to manually trim the 
threads and re-thread the 
needles.
Multihead lockstitch 
machine:  Multihead lockstitch 
machines have a horizontal 
frame. The needles are vertical, 
and are grouped in heads. They 
are mainly used for stitching 
individual items – e.g. badges, 
garments, which are stretched 
in separate hoops attached to 
the frame under each head. A 
multihead machine can have up 
to 24 heads, and each head can 
have up to 20 or more needles. 
Thread change and trims can be 
done automatically. See also 
Lockstitch machine.
Multi-appliqué:  A type of 
appliqué object composed of 
more than one piece of fabric 
and bordered by various types 
of embroidery objects.
Native designs:  Native 
designs refer to designs created 

in EmbroideryStudio software 
(or equivalent).
Native file format:  A design 
saved in the original format of 
the application you are working 
with is said to be the ‘native’ file 
format. It can also refer to the 
machine file format required by 
a specific embroidery machine. 
When saved to another format, 
it is known as a non-native 
format.
Needle:  Small, slender piece 
of steel with a hole for thread 
and a point for piercing fabric. A 
machine needle differs from a 
handwork needle – the machine 
needle’s eye is found at its 
pointed end. Machine 
embroidery needles may come 
with a) sharp points for piercing 
heavy, tightly woven fabric, b) 
ball points which glide between 
fibers of knit, or c) a variety of 
specialty points, such as wedge 
points, which are used for 
leather.
Needle addressing:  Some 
machines support ‘needle 
addressing’. Needle numbers 
correspond to slots in the color 
palette. Each color in the design 
corresponds to a needle 
number. Older multi-needle 
machines simply move to the 
next needle whenever a 
color-change function is 
encountered. In either case, the 
machine must have the correct 
thread colors loaded for each 
needle to stitch out correctly.
Needle in/needle out 
functions:  The Needle In and 
Needle Out functions instruct 
the machine whether or not to 
use needle penetrations. You 
can enter these functions 
automatically using the 
Penetrations tool.
Needle points:  You can view 
needle points in a design to 
check density or, for instance, to 
select stitches for editing.
Needle spacing:  Needle 
spacing is the distance between 
adjacent needles of a Schiffli 
embroidery machine. Typical 
values are 27.07 mm and 
27.04mm. The software lets 
you set up and adjust this value 
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to suit the type of machine 
which will stitch the design.
Nesting:  Nesting lets you 
create or insert an object at an 
exact point of the stitching 
sequence. You can ‘nest’ an 
object in the middle of another 
object’s stitching sequence to 
prevent long connectors being 
generated.
Network:  To link embroidery 
machines via a central 
computer and disk-drive 
system, usually via a modem or 
network card. A group of 
machines linked via a central 
computer.
Network folder location:  
The logical location of a folder 
on a network. Contains the PC 
name together with the folder 
name – e.g. \\My 
PC\EmbroideryMachine1.
Noise filtering:  Noise 
filtering means restoring the 
solid color blocks of original 
artwork in scanned images. This 
is achieved by merging different 
shades into one solid color. 
Noise filtering is important for 
automatic digitizing because it 
makes it easier for the software 
to identify solid color blocks 
which become embroidery 
objects in the resulting design. 
It also cleans up blurred or 
mottled areas of color.
NORMAL template:  The 
NORMAL template is the default 
template supplied with the 
software. It contains current 
property settings as well as a 
selection of preset styles. These 
styles include variations on the 
current property settings. For 
example, <PRESET_SATIN_1> 
and <PRESET_SATIN_2> 
contains different stitch spacing 
settings for Satin stitches. You 
can view and modify the 
settings for these styles at any 
time. See also Templates.
Objects:  In computer science, 
‘objects’ are regarded as any 
discrete item that can be 
selected and manipulated, such 
as an onscreen graphic. In 
object-oriented programming, 
objects include data and the 
procedures necessary to 

operate on that data. See also 
Embroidery objects.
Object outline:  See Design 
file.
Object properties:  All 
embroidery objects in 
EmbroideryStudio contain 
defining settings or ‘values’. The 
values stored with an object 
become its ‘properties’. All 
objects have certain properties 
in common such as size and 
position. There are other, more 
specific properties of objects 
which depend on the object 
type. The most important 
property of all embroidery 
objects is stitch type.
Object recognition:  See 
Outline recognition.
Object type:  An object has a 
type, shape, thread type and 
color, stitching settings and a 
position in the stitching order. 
The object type may or may not 
determine the intended final 
appearance of the stitching.
Offset Object:  Software 
function used to create new 
outlines from the outlines of 
selected objects.
Ornament:  A grouped 
embroidery design which may 
consist of one or more objects 
of any type and one or more 
colors. Ornaments may be 
placed in up to eight positions 
around letters, or centered 
behind letters.
Options:  Options provide 
software with extra functionality 
that can be purchased by 
registered owners of the 
product.
Outline file:  See Design file.
Outline recognition:  When 
you convert a machine file to 
outline format, 
EmbroideryStudio reads the 
data stitch-by-stitch according 
to the needle penetration 
points. The software then 
‘recognizes’ stitch types, 
spacing and length values, 
stitch effects, and can 
determine object outlines.

Outline stitch:  Stitch such as 
Run or Satin used to outline an 
embroidery object.
Overall embroidery:  Overall 
embroidery is embroidery which 
covers the entire fabric. This 
includes lacework where the 
backing fabric is actually 
removed after manufacture. 
Overall embroidery is typical of 
Schiffli manufacture, less 
common with Multihead.
Overshoot:  Overshooting is a 
technique used by Schiffli 
punchers to reduce distortion of 
fabric by pulling more thread 
from the cone and reducing the 
pulling force of the thread.
Overview window:  Use the 
Overview window to view a 
thumbnail of the design. The 
window is updated whenever 
you make a change, and can be 
used to zoom in or pan across 
the design workspace. 
Paint package:  Software 
application that creates or 
allows you to edit image files. 
You can create lines and filled 
areas as well as edit the image 
pixel-by-pixel using 
paintbrushes, erasers and 
spraypaint tools. Examples of 
image editing programs are 
Adobe Photoshop, Jasc 
PaintShop Pro and Corel 
PHOTO-PAINT®. See also 
Graphics application.
Pan:  Use Pan to view parts of 
a design which are not currently 
visible in the design workspace. 
Paper tape:  Traditional 
recording media used in the 
embroidery industry is the 
paper tape. The tape coding 
process produces the final 
design in stitch format – a 
stitch-by-stitch interpretation of 
the design – exactly as the 
embroidery machine will read it. 
Now largely replaced by floppy 
disk, tapes are still used by 
older machines. More 
specifically, stitch data paper 
tapes are eight-channel paper 
tapes which, in effect, are hard 
copies of 8 bit binary code.
Parallel port:  A connection 
on a computer, usually LPT1, 
where you plug in the cable for 
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a parallel printer and/or a 
dongle. Parallel ports are used 
to connect some embroidery 
machines. They are named 
LPT1, LPT2, etc. When you set 
up a parallel machine 
connection, select the parallel 
port and the required protocol, 
and complete the machine 
setup procedure.
Partial appliqué:  Technique 
to create appliqué objects with 
partial cover stitching to create 
an overlapping effect without 
doubling-up borders.
Partition lines:  Partition 
Lines is a method for offsetting 
needle penetrations in Tatami 
fills, used, like Tatami Offset 
Fractions, to create needle 
penetration patterns or textures 
in stitched embroidery.
Paste:  To insert an object, 
which has previously been 
placed on the clipboard by 
cutting or copying selected 
objects, into a design. You can 
paste from the clipboard as 
many times as you like.
PAT:  PAT is a Saurer SHC file 
type.
Patch:  The fabric piece use in 
appliqué.
Pattern:  The design, card, 
punching, tape, disc, or 
enlargement.
PCH:  Gunold design or 
‘outline’ file format.
PCX:  PC Paintbrush bitmap 
image format.
PDF:  Portable Document 
Format. Used to view the Online 
Manual in Acrobat Reader.
Patchwork:  The composite of 
pieces sewn together to form a 
large piece, such as a quilt.
Patchwork block:  A 
collection of patches sewn 
together, usually forming a 
regular shape such as a 
rectangle. These are then sewn 
together to make a quilt.
Pattern Arrangement 
(ABC):  Some Schiffli 
embroidery machines can read 
designs in which repeated parts 
are stored only once in the 

design file and only the repeat 
instructions are given to the 
machine. EmbroideryStudio 
provides tools to define pattern 
arrangements and output to 
specific formats which support 
the feature.
Pattern outline:  See Motif 
Run.
Pause function:  The Pause 
function is a conditional Stop, 
always on an empty stitch. It is 
interpreted by the machine 
according to the machine 
operator preferences.
PEN:  PEN is a Saurer 
Pentamat Station file type. (Not 
supported in Schiffli e3.0.)
Pencil rub:  Low-cost way of 
producing an embroidery design 
sample. Consists literally of a 
piece of tracing paper placed 
over a stitchout and rubbed 
lightly with a pencil to produce 
an impression of the 
embroidery.
Penetrations:  The Needle In 
and Needle Out functions 
instruct the machine whether or 
not to use needle penetrations. 
You can enter these functions 
automatically using the 
Penetrations tool.
Pentamat:  An advanced 
Schiffli individual needle and 
borer switching system 
available on Saurer and Laesser 
Machines.
Peripheral:  Any device 
connected to a computer which 
is to some degree controlled by 
the computer – e.g. an 
embroidery machine or printer.
Physical machine 
functions:  When outputting 
designs, Schiffli translates 
design data into stitches and 
machine functions that the 
target machine will understand. 
The functions that the machine 
understands are called 
‘physical’ machine functions.
Piecing:  The business of 
sewing patches together into 
patchwork blocks.
Pixel:  A dot. For example, 
dots of light that make up the 
image on a computer screen. 

The more pixels in a given area 
– that is, the smaller and closer 
together they are – the higher 
the resolution.
Pixelation:  An effect which 
occurs when a bitmap image is 
enlarged so that the individual 
pixels are obvious to the eye.
Placement lines:  See Guide 
runs.
Plauen:  Plauen is the area in 
Germany where Schiffli 
machines originated. It now 
identifies a type of Schiffli 
machine and Jacquard punched 
card encoding. It is also known 
by the names of other 
manufacturers such as Hiraoka, 
Comerio, Zangs, etc, who 
copied and modified the original 
design. The Plauen machine 
requires the hook to be held in 
the right hand for threading.
PLS:  PLS is a Saurer SLC file 
type.
PMU:  PMU is a Proel stitch or 
‘expanded’ file format.
PNG:  Portable Network 
Graphics vector graphic format.
PNN:  PNN is a Plot file used in 
SPES. (Not supported in Schiffli 
e3.0.)
Pointer:  A part of the screen 
display, the pointer can take 
various shapes. It is moved by 
moving the mouse and can be 
used to point to anything on the 
screen to make selections and 
indicate points for input. It also 
indicates when the computer is 
working and no input is 
possible.
Point:  Unit of measurement, 
with 10 points equal to 1 mm.
Port:  A connection on a 
computer where you plug in the 
cable that carries data to 
another device. Ports which are 
used to attach peripherals have 
names like COM1 or LPT1 so 
that you can specify where the 
peripherals are attached.
Position:  The Position 
indicator shows position of the 
design (X, Y) in the design 
workspace.
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Print preview:  Use to 
preview design and design 
information before printing a 
Production Worksheet. The 
design is displayed as it will be 
printed.
Process:  The Process feature 
lets you adjust the density of 
one or more stitch types across 
the whole or selected parts of a 
design. Change stitch density in 
order to stitch on a different 
fabric or with a different thread. 
Alternatively, you may want to 
make production cheaper by 
reducing the overall stitch 
count. Processing a machine file 
is similar to converting it to a 
design file when opening except 
that you can process only 
selected objects or stitches. 
Processed stitches:  Designs 
read from stitch or ‘expanded’ 
files where stitches have been 
regenerated by processing.
Production worksheet:  The 
production worksheet is the link 
between the designer and the 
embroidery machine operator. 
It contains a design preview as 
well as essential production 
information, including the 
design size, the color sequence 
and any special instructions.
Program:  A computer 
program or ‘application’ is 
generally used for a particular 
kind of work, such as word 
processing or database 
management.
Program split:  A decorative 
fill stitch which can be applied to 
various object types where 
needle penetrations form a tiled 
pattern. Different preset 
patterns are available for use.
Properties:  See Object 
properties.
Protocol:  The 
communications protocol 
depends on the connection type 
between the computer and the 
embroidery machine. This will 
be one of: standard serial, 
parallel, serial to parallel 
converted (DCi), or interface 
card.
PS:  Postscript vector format.
Puck:  See Digitizing puck.

Puckering:  Result of the 
fabric being gathered by the 
stitches. Many possible causes 
include incorrect density, loose 
hooping, lack of backing, 
incorrect tension or dull needle.
Pull compensation:  
Digitizing technique that takes 
into account the distortion of a 
design that will occur because 
of the interaction of thread with 
fabric. ‘Push and pull’ will cause 
a circle digitized perfectly round 
to sew with the sides pushed 
out, resulting in an egg shape. 
Generally, it is necessary to 
extend horizontal elements and 
reduce vertical elements. See 
also Automatic pull 
compensation.
Punching:  Conversion of 
artwork into a series of 
commands to be read by an 
embroidery machine’s 
computer or controller. The 
term refers to an earlier method 
of machine embroidery 
whereby designs are ‘punched’ 
to paper tape. A part of the 
machine, called an automat, 
reads the paper tape or 
Jacquards punched with holes 
representing stitches, 
pantograph movements and 
other commands. While still 
capable of producing paper 
tape, many digitizing systems 
now store this information on 
disk formats. See also 
Digitizing.
Push-pull:  When any stitch is 
sewn into fabric, the tension in 
the thread between needle 
penetrations can build up and 
result in a ‘push-pull’ effect. 
This can cause distortions in 
your sewn designs, poor stitch 
registration and even the 
bunching of the fabric. The 
degree of distortion can be 
affected by the following 
factors: stitch density, fabric 
type, underlay, backing type, 
thread type and garment 
orientation. See also 
Stitch-Pull.
Quilting:  In general, the 
process of making a quilt. 
Specifically, the stitching of 
patterns into the quilt layers to 
add strength and decoration to 

a quilt. Stitching includes top, 
batting, and backing, to form 
decorative patterns on the quilt 
surface and hold the layers 
together. 
RAM:  Random Access 
Memory, computer chip 
maintaining memory.
Random factor:  You can 
eliminate unwanted patterns 
and distribute stitches evenly 
within a shape using a random 
factor. Apply random factors to 
Tatami Partition lines or 
Program Splits. You can use this 
effect to imitate different 
textures such as fur, grass, 
leaves, etc.
Raster image:  See Bitmap 
image.
Read:  To open a design which 
has been written on a design 
card or to an embroidery 
machine.
Reader/writer:  A device that 
allows you to download/upload 
designs to and from a design 
card. Cards can be purchased 
from your dealer or from 
designers on the net. Cards can 
have designs on them or are 
blank for you to read/write 
from/to. The cards are inserted 
into the embroidery module 
attached to a sewing machine. 
The R/W will allow you to have 
the PC and sewing machine 
quite separate from one 
another.
Recognition:  See Outline 
recognition.
Redraw:  The screen display is 
refreshed. This is useful when 
parts of the display have 
become obscured in the course 
of editing. See also Slow 
Redraw.
Reduce colors:  See Image 
preparation.
Reference point:  A point 
that can be aligned with the 
grid. For example, you can set 
the grid reference point to the 
design center. This is easier and 
faster than moving the whole 
design. 
Refresh:  See Redraw.
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Registration:  Correct 
registration is achieved when all 
stitches and design elements 
line up correctly.
Relative Pointer Setting:  
This setting shows the pointer 
position as an absolute value 
from the first needle point of the 
design. Useful for checking that 
the design fits a given area.
Relative:  The distance the 
pointer is from a previously 
marked point, or from the 
previous stitch point.
Repeat:  Layout used for 
making emblems or designs on 
a fabric span that are repeated 
at regular intervals. The design 
repeat is defined by the 
distance between needles – the 
point at which the design 
repeats itself.
Repeat color change 
(RCC):  A Repeat Color Change 
(RCC) is a mechanism on some 
Schiffli machines to change the 
pattern of active needles in 
order to modify the repeat 
pattern and/or thread color.
Repeat sequence:  If you 
select fewer colors than the 
design requires, the selected 
colors are repeated. For 
example, if your design requires 
four colors and you’ve only 
selected two in the Building 
Stop Sequence list, colors 3 and 
4 will be the same as original 
colors 1 and 2.
Resequence:  You can change 
the position of a selected object 
by cutting it, then pasting it 
somewhere else in the stitching 
sequence, or by using the 
Resequence command. You can 
also resequence objects by 
color or using the Color-Object 
List. 
Resizing:  See Scaling.
Resolution:  Resolution 
determines the number of dots 
per inch (dpi) used to create an 
image. The higher the value, 
the clearer the image, but the 
more storage space required. A 
resolution of 75 dpi generally 
produces good results.

RGB:  RGB stands for red, 
green, and blue. It is the 
system used by computer 
monitors to create color.
Rhinestones:  See Bling.
Rhinestone template:  This 
is the design layout on which 
rhinestones are initially placed 
for creation of a ‘rhinestone 
transfer’. This is what is created 
from the cutters or engravers.
Rhinestone transfer:  This is 
the rhinestone design ready for 
heat transfer to the final 
product – e.g. a T-shirt.
RPM functions:  RPM +/- 
functions instruct the machine 
to increase or decrease machine 
speed in increments from 
current or normal.
Right-click:  To press and 
release the right mouse button. 
See also Click.
Rollover:  The point at which 
the fabric is shifted – loosened 
and reset – vertically to 
continue stitching. Common on 
long fabric Schiffli machines.
Rotation handles:  When you 
select an object, selection 
handles display at its 
extremities. If you click the 
object again, rotation and skew 
handles appear around the 
object. Rotation handles appear 
at the corners of the object and 
an anchor point displays at the 
object’s center. Skew handles 
are diamond-shaped and 
appear at the center-top and 
bottom of the object. See also 
Selection handles.
Run stitch:  Run stitch, also 
known as ‘Walk stitch’, places a 
single row of stitches along a 
digitized line. The needle 
penetrations are placed in 
consecutive order. Run is 
generally used for stitching 
outlines and connector stitches. 
Run stitch length can be set to 
automatically vary in order to 
follow tight curves.
SAS:  SAS is a Saurer SLC, 
Saurer SLC RCC, Saurer SLC 
Standard or Saurer Pentamat 
file format.

Sash:  A fabric strip that 
separates blocks in a setting, 
framing them and making the 
quilt larger.
Satin stitch:  Type of fill 
stitch. Formed by closely 
arranged zigzag stitches, it can 
be stitched at any angle and 
with varying lengths. The 
thread is laid across a shape 
with a zigzag sewing action 
where two stitches form a 
column. Hence it is only suitable 
for small or narrow shapes. As 
the stitches are almost parallel, 
Satin provides good coverage. 
It is often used for lettering, 
outlining, and details. Because 
there are generally no needle 
penetrations breaking up the 
fill, Satin stitch creates a glossy 
effect.
Saurer:  Saurer is a Schiffli 
machine brand and type as well 
as a Jacquard card encoding 
format. The format has three 
variants with support added for 
more modern RCC and 
Pentamat machines. 
Sometimes it is referred to as 
the ‘left hand machine’ because 
the threading requires the hook 
to be held in the left hand.
Saurer SHC:  SHC is a high 
level code format which is 
designed to be machine 
independent in order to control 
both Saurer and Plauen type 
mechanisms. The format 
supports thread trimming.
Saurer SLC:  SLC is a Saurer 
low level code format for Schiffli 
designs.
Save:  To store (design) 
information in a file. Each time 
you save a design, you replace 
the previous version using the 
filename. You should save your 
design frequently.
Scalability:  Ability to enlarge 
or reduce a design. In expanded 
format, most scaling is limited 
to 10 to 20%, because the 
stitch count remains constant 
despite final design size. In 
condensed formats, on the 
other hand, scale changes may 
be more dramatic, because 
stitch count and density may be 
varied.
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Scale factor:  This option 
allows you to automatically 
scale CND designs as you load 
them. For example, to scale the 
imported design to 120% of the 
original, you would enter a scale 
factor of 1.2.
Scaling:  Ability to enlarge or 
reduce a design in size. In stitch 
or ‘expanded’ format, most 
scaling is limited to ±5% 
because the stitch count 
remains constant despite final 
design size. In design or 
‘outline’ formats, scale changes 
may be more dramatic because 
stitch count and density are 
recalculated.
Scanner:  A device that 
converts physical images into 
digital form so that they can be 
stored and manipulated by 
computer. Scanning allows you 
to take scanned images as a 
basis for embroidery design.
Scanning resolution:  Most 
scanners require you to enter 
scanning resolution 
information. Resolution 
determines the number of dots 
per inch (dpi) used to create a 
drawing. The higher the value, 
the clearer the image but larger 
the file. For digitizing purposes, 
use a maximum resolution of 
300 dpi (dots per inch). A 
resolution of 72 dpi (screen 
resolution) will usually be 
sufficient. Generally speaking, 
the smaller the source image 
and/or more detail it contains, 
the higher the resolution needs 
to be.
Schiffli card:  Plauen or 
Saurer type Jacquard card.
Schiffli card image:  
Jacquard card electronic 
encoding produces a ‘tape file’ 
which is essentially an 
electronic ‘image’ of the card. 
Schiffli outputs two tape file 
formats – T10 (for Plauen) and 
T15 (for Saurer). See also Tape 
code.
Schiffli disk:  Schiffli disks 
include Saurer SLC/SHC, 
Heinzle, Hiraoka, and Laesser.

Schiffli machine:  
Commercial embroidery 
machine that utilizes the 
combination of needle and 
shuttle to form a stitch. Massive 
in size. Some schiffli machines – 
also known as looms – weigh 10 
tons and have up to 1024 
needles. Most Schiffli machines 
do not have automatic thread 
trim or automatic color change. 
Excellent for emblem 
production, the creation of lace, 
embroidery production on 
oversized items and production 
orders of very large quantities.
Screen calibration:  You 
need to calibrate your monitor 
so that designs at 1:1 scale 
appear at real size. Do this 
when you first install 
EmbroideryStudio, whenever 
you change your monitor, or 
adjust your monitor’s horizontal 
or vertical controls.
Screen printing:  Screen 
printing is a more complex 
process than direct-to-garment, 
requiring the creation of a 
screen for each of the spot 
colors (Pantone) that make up 
the design. There may be 
multiple screens for each spot 
color, depending on how the 
design is layered. See also 
Direct-to-garment printing.
Screen resolution:  See 
Pixels.
Scroll bar:  The bar at the 
bottom and right edge of a 
window whose contents are not 
entirely visible. Each scroll bar 
contains a small box, called a 
scroll box, and two scroll arrows 
to allow different types of 
scrolling.
Security code:  Options in 
EmbroideryStudio are 
controlled by a security device 
installed on the computer. 
Security access codes entered 
into the software are sent to 
this security device. Each 
security device has a unique 
serial number and identity code.
Security device:  See 
Dongle.
Segments:  Filled embroidery 
objects are generally built as 

several discrete ‘segments’. 
Travel runs are typically used to 
connect them. All segments, 
however, form part of the same 
object. Where they meet, the 
push-pull effect on the fabric 
during stitchout may cause 
gaps to appear.
Select:  To highlight an object 
or group of objects for the 
purpose of editing. Only 
selected items can be edited.
Selection handles:  Eight 
small squares that appear 
symmetrically at the corners 
and edges of a selected object. 
Use them to position and resize 
objects. See also Rotation 
handles.
Selection marquee:  The 
dotted rectangle that appears 
when you select a range of 
items. See also Bounding box.
Sequence:  See Stitching 
Sequence.
Sequins:  Sequins are small 
plastic disks with a hole usually 
in the center. They are stored on 
reels joined one-to-another by a 
weak link. They are stitched 
onto fabric by mechanical 
placement in the path of the 
sewing needle.
Sequin attachment:  Sequin 
attachments are computerized 
or manual machine devices 
which apply sequins by 
stitching, glue or heat.
Sequin mode:  Sequin mode 
enables quick digitizing of Drop 
Sequin functions. See also Drop 
Sequin functions.
Serial port:  A connection 
point on a computer where you 
plug a serial communications 
device such as a modem. PC 
serial COM ports are male 
connectors, and can be either 
9-pin or 25-pin. They are 
named COM1, COM2, COM3, 
etc. The number of available 
ports limits the number of 
devices you can connect. If 
additional ports are required, 
you can add them. Multi-port 
serial cards can also be used.
Serial port setup:  Here you 
can adjust Baud, Data Bits, 
Stop Bits, Parity values. These 
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settings must be identical to 
those of the embroidery 
machine. The type of 
handshaking must match the 
type of cable you are using.
Serif:  In typography, serifs 
are semi-structural elements on 
the ends of strokes that make 
up letters and symbols. A 
typeface that has serifs is called 
a serif typeface. A typeface 
without serifs is called 
sans-serif.
Sharpen edges:  Tool used to 
prepare outlined images for 
automatic digitizing. Sharpen 
Edges automatically sharpens 
outlines and reduces noise. 
Areas enclosed by a black 
outline are reduced to a single 
color. Outline sharpening makes 
it easier for the software to 
recognize distinct areas in the 
artwork. These areas then 
become the embroidery objects 
of the finished design. Use it 
particularly if the outlines are 
blurry, fuzzy or indistinct.
Short stitch:  Digitizing 
technique that places shorter 
stitches in curves and corners to 
avoid an unnecessarily bulky 
build-up of stitches.
Shortcut key:  A key stroke or 
a series of keystrokes you can 
use to perform a task instead of 
using the mouse. For example, 
Ctrl+C actions the Copy 
command.
Side movement:  The 
distance the frame can move 
horizontally on a Schiffli 
machine, measured in quarters.
Side stick:  Adjustable bars 
with pins on each end of the 
Schiffli frame to hang or pin the 
ends of the goods being 
spanned.
Sizing handles:  See 
Selection handles.
Skew handles:  See Rotation 
handles.
Slow Redraw:  Use to redraw 
your design slowly. Slow 
Redraw lets you view the 
stitching and color sequence of 
a design in slow motion.

Small stitches:  Use the 
Small Stitch Filter to remove 
unwanted small stitches from a 
design automatically.
Smart corners:  Sharp points 
in a shape may cause a 
bunching of stitches and needle 
penetrations which can create a 
hard spot in the embroidery and 
may damage the fabric or 
needle. Smart Corners helps 
you control sharp corners in 
Column A and Column C 
objects. See also Mitre Corner 
and Cap Corner.
Smart design:  Toolset used 
to create embroidery designs by 
automatically digitizing 
electronic images. Smart 
Design automatically converts 
bitmap images to fully digitized 
embroidery with little or no 
intervention. See also 
Auto-Digitizing.
Software:  Programs, such as 
MS Windows® and 
EmbroideryStudio, which run 
your computer.
Span:  The prepared goods 
ready to load the Schiffli 
machine. It may contain many 
yards of goods.
Span cloth:  Fabric attached 
permanently to the roller of the 
Schiffli machine with pins onto 
which the fabrics are attached.
Spangles:  See Sequins.
Spanning:  The loading of the 
goods on the frame, placing it 
under tension preparatory for 
embroidery.
Specialty fill:  A fill stitch 
capability that produces a fill 
with a ‘relief’ or motif design 
within the fill-stitch area, e.g. 
Pattern Fill.
Specialty threads:  Threads 
designed for effects such as 
shine, glitter, iridescence or 
thickness. The threads often are 
made from synthetic materials 
including rayon, mercerized 
cotton, metallics and textured 
nylon.
Spiral contour:  Spiral 
Contour creates a single, 
continuous line of stitching that 
spirals around to fill the shape. 

Typically, it is used for rings and 
borders, but it is also suitable 
for other closed shapes. See 
also Contour stitch.
Split alternate:  Split 
Alternate is a variation of Tatami 
split. See also User Defined 
Split.
Split object:  You can split 
embroidery objects that were 
created with the Column A, 
Column B, and Column C tools, 
if Satin or Tatami, or Program 
Split is the selected stitch type.
SPI:  Stitches per inch – 
system for measuring density or 
the number of Satin stitches in 
an inch of embroidery.
SPM:  Stitches per minute – 
system for measuring the 
running speed of an embroidery 
machine.
SR/SD:  Melco Star format. 
‘Star’ and ‘Superstar’ are types 
of Melco machine (quite old 
now).
Stabilizer:  See Backing.
Standard backstitch:  The 
rows are approximately parallel, 
with every backstitch row 
slightly shorter than the forward 
row. Because the rows are 
different lengths, there are 
fewer small stitches at the edge 
of the shape, reducing possible 
damage to the fabric. Standard 
backstitch is suitable for high 
density fills. See also 
Backstitch.
Standard Contour:  
Standard Contour creates rows 
of stitches across the shape, 
perpendicular to the digitized 
stitch angle. The number of 
stitch lines is constant, so the 
stitching is denser where the 
shape is narrower, and more 
open where the shape is wider. 
See also Contour stitch.
Start/End Boring Tension 
functions:  See Boring Tension 
functions.
Station:  See Repeat Color 
Change (RCC).
Status bar:  Provides 
information about the whole 
design: number of stitches, 
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position of the design (X, Y), 
number of colors (C), number of 
stops (S), etc.
STC:  Gunold stitch or 
‘expanded’ file format.
Stemstitch:  A detail stitch 
that can be used to outline 
items or fill in areas. It is used 
for stems and vines with other 
decorative stitches, or as an 
outline for Satin or Motif fills.
Step stitch:  Series of parallel 
stitches commonly used to 
cover large areas. Different step 
patterns can be created by 
altering the angle, the length 
and repeat sequence of the 
stitches.
Stippling:  A method of 
creating a fill made of run 
stitches which meander around 
within a border. Often used in 
quilting.
Stitch:  A stitch is one needle 
penetration. May also refer to 
the thread spanning one needle 
penetration and the next.
Stitch angle:  The stitch angle 
is the angle the overall stitching 
follows within a shape. The 
shape may have a fixed stitch 
angle – e.g. 45° to the 
horizontal – or multiple stitch 
angles.
Stitch bunching:  Standard 
stitch spacing is calculated at 
the outside edge of a shape. 
With sharp curves, spacing 
which provides adequate 
coverage on the outside edge 
may cause bunching along the 
inside edge. This may cause 
thread breakage when stitching 
out.
Stitch count:  Stitch count 
refers to the number of stitches 
in a design. In 
EmbroideryStudio one stitch is 
considered one machine 
revolution. See also Design 
information.
Stitch density:  The number 
of stitches per given area (or 
stitch lines per distance in a fill).
Stitch editing:  Digitizing 
feature that allows one or more 
stitches in a pattern to be 
deleted or altered.

Stitch file:  See Machine file.
Stitch length:  The distance 
between two needle penetration 
points. For maximum stitch 
length, the length is measured 
according to the X and Y 
co-ordinates, whichever is 
greater. Run stitch length can 
be set to automatically vary in 
order to follow tight curves. See 
also Max/Min stitch length.
Stitch List:  The Stitch List 
displays stitch number, stitch 
coordinates, stitch length, stitch 
function, stitch color. When you 
select a stitch in the list, it is 
simultaneously selected in your 
design. 
Stitch processing:  The 
calculation of stitch information 
by means of specialized 
software, allowing scaling of 
expanded format designs with 
density compensation.
Stitch processor:  A 
patented software feature 
developed by Wilcom 
International P/L. Stitch 
Processor is a function of the 
software which interprets ‘raw’ 
stitch data and converts it into 
objects that the software can 
recognize.
Stitch-pull:  See Push-Pull.
Stitch type:  Three basic 
stitch types are available with 
lockstitch machines – Run, 
Satin and Tatami (Weave). 
EmbroideryStudio provides 
many variants of these.
Stitch shortening:  When a 
shape takes a sharp turn, the 
spacing of stitches on the inside 
of the shape decreases rapidly. 
This results in bunching on the 
inside and gaps on the outside 
of the shape. The longer the 
stitch, the worse the problem. 
Automatic Stitch Shortening 
solves this problem by 
eliminating thread bunching. 
The embroidery has smooth, 
even stitch spacing throughout. 
It also reduces thread 
breakages during production.
Stitch spacing:  Spacing 
between two consecutive 
needle penetrations on the 
same side of a column. The 

smaller the value, the greater 
the stitch density. For more 
open stitching, use larger 
values.
Stitching defects:  Stitching 
defects may appear in the form 
of gaps between filled areas, 
fabric show-through and thread 
breaks. These are often caused 
by incorrect stitching settings – 
e.g. setting pull compensation 
too small for the fabric 
stretchiness.
Stitch-to-machine:  The 
software lets you send a design 
directly to the embroidery 
machine for stitching if it is 
connected to your computer.
Stitching direction:  
Stitching direction can affect 
embroidery quality because of 
the Push-Pull effect. Only closed 
embroidery objects can be 
reversed.
Stitching sequence:  The 
embroidery objects in a design 
form a stitching sequence. 
Initially, objects are stitched in 
the order in which they were 
created or the design 
assembled. You can change the 
position of a selected object by 
cutting it, then pasting it 
somewhere else in the 
sequence, or by using the 
Resequence command. You can 
also resequence objects by 
color or with the Color-Object 
List.
Stock designs:  Embroidery 
designs readily available on disk 
or proprietary embroidery card. 
Digitized embroidery designs 
that are commercially available 
for general use by 
embroiderers.
Stop code:  Stop codes are 
interpreted as ‘explicit stops’. 
The machine stops stitching.
Stop function:  If you want 
the embroidery machine to stop 
for any special reason while 
stitching a design, you need to 
insert a Stop function in the 
stitching sequence. If there are 
Stops in a design, these can be 
read into EmbroideryStudio as 
either a Color-change function 
or a Stop function.
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Straight stitch machine:  
Machine, which features 
needles that move up and down 
in one spot. The pantograph 
pushes the design along. The 
majority of commercial 
embroidery machines use this 
type of needle movement.
STX:  Datastitch stitch or 
‘expanded’ file format.
Stuepfel:  Stuepfel is a Schiffli 
machine attachment for 
cleaning out holes after boring.
Stuepfel functions:  Stuepfel 
In/Out functions instruct the 
machine when to switch to the 
Stuepfel device from the borer. 
Borer In engages both the borer 
and the Stuepfel.
Styles:  A style is a group of 
property settings stored under a 
unique name. You can save any 
combination of settings to a 
style. This makes it easy to 
apply these settings to selected 
embroidery and lettering 
objects. When you apply a style 
to an object, the style settings 
replace its current properties. 
Any properties not specified in 
the style, retain their current 
settings.
Sublimation:  Sublimation 
means a change from a solid to 
gaseous state and back to a 
solid without becoming liquid. 
Thus dye particles migrate from 
the paper as a gas, to bond with 
a polymer – fabric or other 
material – and become solid 
again. The transfer is effected 
using high heat (205°C) and 
pressure, thus guaranteeing 
that the image penetrates and 
becomes an integral part of the 
substrate.
Sublimation printing:  
Sublimation is similar to DTG 
printing but the process uses 
solid inks which give a more 
even gradation of color rather 
than the liquid inks in DTG 
printing. With sublimation 
printing, inks are printed onto a 
release paper and then 
transferred onto a fabric or 
other surface.

Supported machine type:  
A machine is ‘supported’ by the 
software either via a direct 
implementation in the software 
for a specific machine or via the 
MS Windows® operating 
system – e.g. a MS Windows® 
supported printer or 
MS Windows® supported 
cutter.
Swiss embroidery:  Satin 
stitch embroidery. Also recalls 
the origins of automated 
embroidery in Switzerland, 
where the Schiffli embroidery 
machine was developed in the 
1800s by Isaak Groebli. 
Embroidery remains a 
government-supported industry 
in Switzerland today.
System administrator:  The 
System Administrator is 
responsible for the entire 
Enterprise Network and 
security. In smaller enterprises, 
the System Administrator is 
also usually responsible for 
database administrations.
System requirements:  
What your computer’s hardware 
and software, operating 
together, can support. System 
requirements are printed on 
software packages, design disk 
cards and packs, CDs and other 
computer accessories. You need 
to know what your system can 
and cannot support, as 
sometimes a system is not 
capable of handling new 
software without adding 
memory or disk space. 
T03:  T03 is an old paper tape 
version of Barudan file.
T10:  T10 is a Wilcom Plauen 
Schiffli format used to punch 
cards or as input to Electrocard 
or converted to floppy disk 
formats. 
T11:  T11 is a Wilcom Plauen 
RCC Zangs Schiffli format.
T12:  T12 is a Wilcom Plauen - 
RCC Hiraoka Schiffli format.
T13:  T13 is a Wilcom Plauen - 
RCC Comerio Schiffli format.
T15:  T15 is a Wilcom Saurer 
Schiffli format used to punch 
cards or as input to Electrocard 

or converted to floppy disk 
formats. 
T16:  T16 is a Saurer B Schiffli 
format.
T18:  T18 is a Wilcom Saurer 
RCC Schiffli format.
T19:  T19 is a Wilcom Saurer B 
- RCC Schiffli format.
T20:  T20 is a Wilcom Saurer 
Pentamat Schiffli format.
T21:  T21 is a Wilcom Saurer B 
Pentamat Schiffli format.
T22:  T22 is a Wilcom Plauen 
Pentamat Schiffli format.
Tablet:  See Digitizing tablet.
Tackdown:  Zigzag stitch, 
placed after placement and 
cutting lines, and used to fix 
appliqué patches to the 
background fabric before cover 
stitching is applied.
Tape:  See Paper tape.
Tape code:  More recently, the 
recording media used in the 
embroidery industry has been 
the paper tape. Jacquard card 
electronic encoding produces a 
‘tape file’ which is essentially an 
electronic ‘image’ of the card. 
Schiffli outputs two tape file 
formats – T10 (for Plauen) and 
T15 (for Saurer). As the newer 
Schiffli machines can read 
floppy disks, there are various 
Schiffli machine floppy disk 
formats. You therefore need to 
convert the basic tape file to the 
required disk format.
Tatami stitch:  Series of run 
stitches, commonly used to 
cover large, irregular shapes. 
Stitches are laid in rows 
traversing back and forth across 
the shape. These can be parallel 
or slightly turning. Different fill 
patterns can be created by 
varying the stitch length, angle 
or sequence. Also known as 
Weave stitch.
Tatami offset fractions:  
With Tatami fills you can specify 
how each row is offset in order 
to create patterns formed by 
needle penetrations. You do this 
by adjusting either offset 
fractions or partition lines. By 
adjusting offset fractions, you 
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can create textured fills where 
the stitch penetrations are more 
clearly visible. 
Tatami partition lines:  With 
Tatami fills you can specify how 
each row is offset in order to 
create patterns formed by 
needle penetrations. Partition 
lines, with up to eight offsets, 
can create more patterns. 
Tatami underlay:  Tatami 
underlay is used to stabilize 
large, filled shapes. It 
resembles an extremely open 
Tatami fill stitch, where rows of 
stitches are placed across the 
object to create the underlay.
Team Names:  The Team 
Names feature lets you create 
designs with multiple names. 
For example, you can use the 
same logo with different names 
for sports teams or corporate 
uniforms without having to 
create multiple copies of the 
same design. 
Templates:  Templates are 
special files used for storing 
styles and default property 
settings. The NORMAL template 
packaged with the software 
provides a selection of preset 
styles. You can modify these as 
required and save them back to 
the NORMAL template or to your 
own custom templates. Use 
these when digitizing 
frequently-used design types to 
save time re-adjusting the 
current property settings. For 
example, a custom template 
may include standard objects 
and sample lettering. It may 
simply have preferred stitch 
settings, lettering font and size, 
and colors set as current 
settings. Or it may have special 
density, pull compensation or 
underlay settings to suit 
different fabrics.
Tension:  Tautness of thread 
when forming stitches. Top 
thread tension, as well as 
bobbin thread tension, need to 
be correctly set. Proper thread 
tension is achieved when about 
one third of the thread showing 
on the underside of the fabric on 
a column stitch is bobbin 
thread.

Textured edge:  Use 
Textured Edge to create rough 
edges, to create shading 
effects, or to imitate fur or other 
fluffy textures in your design.
Thread:  Fine cord or natural 
or synthetic material made from 
two or more filaments twisted 
together and used for stitching. 
Machine embroidery threads 
come in rayon (high sheen), 
cotton (duller finish), polyester 
(strong and colorfast), metallics 
(synthetic core wrapped with 
metal foil or thin slivers of metal 
foil) and acrylic (sheen similar 
to rayon).
Thread Brake functions:  
Thread Brake +/- functions 
instruct the machine when to 
increase or decrease tension 
one increment by Thread Brake.
Thread chart:  Thread charts 
are lists of predefined thread 
colors. They may be based on 
commercially available thread 
charts, or charts you define 
yourself. You can copy colors 
between different thread charts 
to create your own charts from 
existing colors. See also Color 
palette.
Thread code:  Code is the 
identification number of a 
thread color in a brand.
Thread roller functions:  
Thread Roller +/- functions 
instruct the machine when to 
increase or decrease tension 
one increment by Thread Roller 
Feed (2S-55 RCC).
Thread cutting:  The removal 
of ‘floats’, by hand or by 
machine.
Thread density:  Different 
thread density systems are 
used by different thread 
manufacturers. Density A is 
normal embroidery thread 
(density 120/2, or 40). Density 
B is thicker, Density C is finer, 
and Density D is very fine.
Thread thickness:  See 
Thread density.
Thread type:  Embroidery 
thread varies in thickness. 
Types are A, B, C and D. Stitch 
density should be set according 

to the thread type. See also 
Thread thickness.
Tie-ins:  Tie-in stitches are 
inserted at the start of objects 
to prevent stitches from 
unraveling. They are inserted 
inside the shape on the second 
stitch. You generally use them 
when the previous connector is 
trimmed.
Tie-offs:  Tie-offs are 
generally placed before trims to 
prevent stitches from 
unraveling. You can adjust 
connector settings to 
automatically add tie-offs under 
certain conditions, or add them 
manually. You can also include 
trim functions so machines with 
trimmers cut the thread 
automatically.
Title bar:  The horizontal bar 
located at the top of a window 
and containing the title of the 
window. On many windows, the 
title bar also contains the 
Control menu box and Maximize 
and Minimize buttons.
Toolbar:  Toolbars provide 
quick and easy access to 
EmbroideryStudio commands. 
Click a toolbar button to 
activate a command or, where 
applicable, right-click to view 
and adjust its settings.
Topping:  Material hooped or 
placed on top of fabrics that 
have definable nap or surface 
texture, such as corduroy and 
terry cloth, prior to embroidery. 
The topping compacts the wale 
or nap and holds the stitches 
above it. It includes a variety of 
substances, such as plastic 
wrap, water-soluble plastic ‘foil’ 
and open-weave fabric that has 
been chemically treated to 
disintegrate with the application 
of heat. Also known as ‘facing’. 
See also Stabilizer.
Trapunto:  Trapunto is a 
general term for open fill 
stitching, often used as a 
background or for filling large 
shapes. In EmbroideryStudio, 
Trapunto effect forces travel 
runs to the edges of objects so 
they do not show through open 
or loose stitching.
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Travel runs:  Travel runs are 
typically used to connect 
segments of complex shapes. 
They can also connect adjacent 
objects. Because runs are not 
trimmed, they may be visible in 
the final embroidery. For this 
reason, they are less commonly 
used as connectors between 
objects than jumps. If objects 
are adjacent and connectors will 
be hidden, they can be used.
Traveling:  You generally 
check a design’s stitching 
sequence by ‘traveling’ through 
it by stitches, segments, 
functions or objects.
Trim function:  If you are 
using a machine with an 
automatic trimmer, the trim 
code causes the thread to be cut 
after a tie-off. In the software, 
trims are represented by a 
triangle with a small circle at the 
point where stitching starts 
again. The trimmed connector 
appears as a dotted line. You 
can adjust connector settings to 
automatically add trims, or add 
them yourself.
Trimmers:  Devices built into 
an embroidery machine to 
automatically trim or cut 
remaining thread when the 
design jumps from one area to 
another or performs a color 
change.
Trimming:  Action of cutting 
loose thread, removing backing, 
etc, from the final embroidered 
product.
Triple Run stitch:  Triple Run 
repeats each Run stitch three 
(or more) times for a thick line. 
Typically used to add borders 
and pickout runs to designs.
Triple Satin:  Triple Satin is 
often used for folk designs to 
mimic handmade embroidery 
that uses thicker thread. If you 
require thicker stitches, set the 
Satin stitch to repeat itself 
multiple times. 
TrueType font:  Digital font 
technology designed by Apple 
Computer and now used by 
both Apple and Microsoft in 
their operating systems.

TrueView™:  TrueView™ 
provides you with a preview of 
how your embroidery will look 
when stitched out. It gives the 
screen image a three 
dimensional look.
Turning stitches:  
Embroidery objects can be filled 
with parallel or turning 
stitching. Turning stitches are 
columns of stitches which turn 
to follow the path defined by the 
object outline. By contrast, 
parallel stitching traverses the 
shape in one direction only – 
e.g. at 90° to the horizontal, 
45°, or whatever is set. Objects 
can be created with turning 
stitching already applying, or 
multiple stitch angles can be 
added later. Turning stitches are 
best used with designs 
containing complicated, turning 
shapes such as trees, animals, 
or large filled areas. Turns 
generally occur at points where 
a shape changes significantly in 
direction or width.
TWAIN:  Industry standard 
which allows devices (such as 
scanners) to communicate 
directly with design and layout 
programs. Both device and 
program must be 
TWAIN-compliant. This lets you 
use any TWAIN-compliant 
scanner with your software.
U??  Machine file format native 
to Barudan machines.
UDL file:  DesignWorkflow 
uses the Microsoft Data Link 
(UDL) format to link to its 
databases. UDL files are similar 
to MS Windows® shortcuts, but 
they contain more information 
about where the actual 
database and all of its attendant 
files are located. Copies of UDL 
files can be shared, renamed 
and relocated so that many 
people can use the information. 
In effect, every user with 
DesignWorkflow can have their 
own UDL link to the same 
database.
Underlay:  Stitches sewn 
before other design elements to 
help stabilize fabrics. The 
stitching action that will attach 
the backing to the fabric being 
embroidered. It also supports 

the top embroidery for a more 
lofty, dimensional look. 
Underlay stitches are made up 
of a series of single run stitches, 
usually with a very short stitch 
length, and are digitized 
manually or placed 
automatically under the column 
(satin) or fill stitch areas of your 
embroidery design.
Underlay margin:  The 
distance between an object 
outline and the edge of the 
underlay. Increase this margin 
to prevent underlay stitches 
from extending outside the 
cover stitches.
USB-capable embroidery 
machine:  An embroidery 
machine which has a standard 
USB port built into the machine 
or machine control panel.
USB converter:  A device 
which converts a standard serial 
connection port to a USB type A 
connection.
USB memory stick:  
Standard USB memory stick or 
simply ‘USB stick’ used for 
storing and transporting files.
USB port:  Universal Serial 
Bus Connector – a connection 
on a computer where you plug 
in the dongle. 
User-defined split:  
User-defined splits add details 
to filled objects via digitized 
lines of needle penetrations 
called ‘split lines’. Split lines are 
stored as object properties. 
They are preserved when 
stitches are regenerated even if 
you apply a different stitch 
type.
Values:  The actual settings – 
letters and numbers – that you 
enter into dialogs. See also 
Object Properties.
Variable sizing:  Ability to 
scale a design to different sizes.
Variable stitch length:  The 
software can automatically 
calculate the best length for 
each stitch with the Variable 
Run Length option. A chord gap 
value controls how closely the 
stitches follow the digitized 
lines.
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VDT:  VDT is a Hiraoka Schiffli 
format.
Vector graphic:  Unlike raster 
images, vector graphics contain 
vector data. This is a collection 
of geometric shapes and lines 
that combine to make an image. 
Rather than pixels, such data is 
recorded as a set of 
mathematical formulas defining 
shapes such as rectangles, 
ellipses, curves, polygon stars, 
etc. These are created using 
vector graphics programs such 
as CorelDRAW® 
Graphics Suite. Vector graphics 
are scalable without distortion, 
and are usually much smaller 
than bitmap images. See also 
Bitmap image.
Vector object:  Vector objects 
are derived from vector 
graphics and can be created in 
EmbroideryStudio or imported. 
In EmbroideryStudio they can 
be converted to and from 
embroidery objects. You can set 
general properties such as size 
and position, and arrange and 
transform them in the same 
way as other objects. See also 
Vector graphics.
Vector text:  A text object 
created using the CorelDRAW® 
Graphics Suite Text tool.
VEP:  Hiraoka VEP file format is 
used extensively for Pattern 
Arrangements (ABC) on 
existing machines. VEP uses a 
small arrangement file which 
splits the different design parts 
– A is one file, B is a second file, 
C is a third file.
Watcher:  The operator of the 
Schiffli machine who sets the 
pattern, twists the yarns, 
maintains the shuttles, loads 
and unloads the machines, 
performs the rollovers and 
watches for thread and needle 
breakage. The machine 
operator.
Wave Effect:  With Wave 
Effect you can curve Closed Fill 
stitches along a digitized line to 
create flowing stitch effects. 
The stitches follow the digitized 
line but maintain uniform 
density and needle penetration 
patterns.

Weave stitch:  See Tatami 
stitch.
WECS:  WECS (Wilcom 
ElectroCard System) eliminates 
the need for Jacquard cards. 
WECS reads Wilcom machine 
files T10 and T15 and runs the 
Schiffli Automat directly. You 
therefore only need to save the 
design as a machine file to 
floppy disk.
Weight:  When referring to 
T-shirts, the three standard 
weight divisions are 
mid-weight/value, 
heavyweight/premium, and 
super heavyweight.
WESS:  WESS (Wilcom 
Electronic Servo System) 
replaces the Schiffli Automat 
and controls the frame 
movements directly by servo 
motors. It requires Wilcom ESS, 
Hiraoka DAT, Saurer SAS, T10 
or T15 files on floppy disk as 
input and its method of 
operation is similar to WECS.
WIA:  Windows Image 
Acquisition (WIA) is the still 
image acquisition platform in 
the Windows family of operating 
systems starting with Windows 
Millennium Edition (Windows 
Me) and Windows XP.
WiFi device:  Device capable 
of connecting to a WiFi Router 
or wireless access point.
WiFi network name 
(SSID):  Service Set Identifier 
(SSID) – the unique identifier 
attached to the information 
which is sent over a wireless 
local area network.
WiFi password (key):  
Password, passphrase or key 
(depending on the WiFi security 
type) that allows connection to 
the WiFi router or access point.
WiFi router:  Device that 
provides basic network 
infrastructure for a home or 
small office network. Provides a 
wireless access point for many 
wireless devices to connect to 
each other for access to the 
Internet as well as for file 
sharing and printing. 
Sometimes referred to simply 
as a Wireless Router.

WiFi USB machine 
network:  A network of 
wirelessly connected, USB 
enabled embroidery machines 
and PCs.
Windows domain:  a 
network of Windows PCs, also 
known as ‘network domain’, in 
which computers rely on a 
centralized authentication 
database. Users log into the 
domain and the access 
privileges are served from the 
central database which is 
controlled by a network 
administrator.
Windows workgroup:  
‘Workgroup’ is Microsoft’s term 
for a peer-to-peer local area 
network. Computers running 
Microsoft operating systems in 
the same workgroup may share 
files, printers, or Internet 
connection.
Wireless Access Point 
(WAP):  A wireless access 
point or ‘WAP’ is a hardware 
device on a local area network 
(LAN) that allows wireless 
capable devices and wired 
networks to connect.
WLAN:  Wireless Local Area 
Network or WiFi network.
WMF:  MS Windows® Metafile 
vector format.
Write:  To send design 
information to an embroidery 
disk, design card or embroidery 
machine for immediate 
stitchout or storage.
X/Y coordinates:  The 
horizontal (X) and vertical (Y) 
distances on a graph or 
computer screen. Use X values 
to measure width, and Y values 
to measure height.
XXX:  Compucon stitch or 
‘expanded’ file format in the 
professional market.
Zigzag stitch:  Zigzag stitch 
is similar to Satin but is 
generally used where fewer 
stitches are required. The 
needle penetrates each side of 
the column, laying the thread 
across in an open zigzag 
pattern. The density is 
determined by the stitch 
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spacing setting. The settings for 
Zigzag fill stitches are stored 
separately from Zigzag and 
Double Zigzag underlay 
settings.
Zigzag underlay:  Zigzag and 
Double Zigzag underlay 
stitching is used to support wide 
columns.
Zoom factor:  The scale at 
which the design is currently 
displayed.
ZSK:  ZSK1 format is for older 
ZSK machines, generally those 
older than 1991. ZSK2 is for 
newer ZSK machines, those 
characterized by a single top 
thread trimmer. The trim is the 
most significant differentiating 
factor between the two types.
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Index

Numerics
3D Warp tool 564–566

A
Accordion Spacing

tool 598
overview 598

Add
Bitmap Colors dialog 795
Border dialog 346
Color tool 122, 125
Holes tool 349
Team dialog 703
Thread dialog 135
to Favorites dialog 275

add to palette, inserted files 142
adding

colorways 281
Empty Stitch/Empty Jump 470
stitch angles to complex fills 436
tie-offs 469
trims 469

Adjust Bitmap
dialog 808, 856
tool 808, 856

adjusting
column width 241
Motif fill width and height 223
Satin stitch spacing with 

auto-spacing 204
Satin stitch spacing with fixed 

spacing 208
stitch angles 437
Tatami stitch length 211
Tatami stitch spacing 211

Align
Bottom tool 331
Centers Horizontally tool 331
Centers tool 331
Centers Vertically tool 330
Left tool 330
Right tool 330
Top tool 331

all-in-one files 65
alphabets

converting TrueType 732, 1076
converting TrueType fonts 729, 

1070
converting TrueType to 

embroidery fonts 729, 1070
creating new 745
digitizing from artwork 738, 1068
merging files 749

modifying 748
preparing drawings 741
user-refined 735
See also lettering

anchor points, rotation 337
angles

rotating by exact angle 338
rounding sharp corners, 

Input C 448
skewing by exact angle 340
See also stitch angle

anti-aliasing 781
appliqué

adjusting settings 1285
converting Complex Turning 

objects 1284
converting vector graphics 1279
cover stitch values 1290
cutting shapes 1317
digitizing 1281
guide run values 1286
outputting 1315
partial cover 1294, 1295
printing patterns 1315
splitting 381
tacking values 1289
view fabrics 87

Appliqué Fabric dialog 1286
Appliqué tools

Appliqué 1281–1294
Appliqué without Holes 1281–

1294
Combine Appliqué 

Components 1297
Partial Appliqué 1294

Apply
Closest Join tool 476, 1079
Current Color tool 122
Current Properties tool 264

apply object properties 145
Apply Style

dialog 272
tool 272

Arrange toolbar
Align Bottom 331
Align Centers 331
Align Centers Horizontally 331
Align Centers Vertically 330
Align Left 330
Align Right 330
Align Top 331
Apply Closest Join 476, 1079
Branching 481
Group 312
Lock 314

Make Same Height 335
Make Same Width 335
Make Same Width and 

Height 336
Space Evenly Across 331
Space Evenly Down 332
Ungroup 313
Unlock All 314

arranging objects
grouping 312
locking 312

arrays
Array tool 366
creating 366

artwork
anti-aliased images 781
Auto-digitize 837
choosing 779
converting to vector 

drawings 825
dithered images 781
enlargement drawings 181
loading 823
scanned images 781
sequins 1197
vector drawings 815

Assign Thread tool 125
Auto Fabric dialog 68, 266, 841, 

844, 845, 846
Auto Fabric Settings dialog

Lettering 271
Narrow Satin 270
Stabilizer 271
Tatami/Program Split Fill 269
Wide Satin 270

Auto Hoop tool 868
Auto Jump

tool 456
overview 456

auto scroll 154
Auto Spacing

setting values 204
Settings dialog 206
spacing offset 205
stitch length 205
stitch spacing 205

Auto Split 454
Auto Start & End

dialog 775, 867
tool 771, 866, 1125

auto start/end method, team 
names 710

Auto Trace To Vectors tool 825
Auto Underlay

dialog 421–426
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tool 420–426, 484, 684
Auto-Digitizing Tools

Adjust Bitmap 808, 856
Auto Trace To Vectors 825
Centerline Run Object 844
Color Matching Method 831, 837, 

843
Color PhotoStitch 856
Crop Bitmap 856
Instant Smart Design 837
Keep Graphic Objects 837, 840
Outline Run Object 844
Photo Flash 847
Prepare Bitmap Colors 804, 808
Smart Design 840
Tatami Fill Object 844
Tatami Fill Object with Holes 843
Turning Satin Object 843

Auto-Digitizing tools
Crop Bitmap 798, 808, 831, 848, 

852
Finalize Crop 799
Remove Crop 798

automatic
Automatic Knife tool 385
Automatic Resize dialog 808
backup 140
borders 345
branching 479
centering 866
connectors, see connectors
jumps, see Auto Jump
letter kerning 678
pull compensation 428
save 140
sequencing 323
spacing, see Auto Spacing
split, see Auto Split
trims 467
underlay 419
borders, see also lettering

automatic digitizing 830
Auto Trace To Vectors 830
converting grayscale 

images 847, 852
creating embroidery designs 840
cropping images 798
Photo Flash 830
Smart Design 830

B
Back 1

Color tool 322
Object tool 322

backdrops 18
dimming 148
inserting bitmap images 823
loading 823
scanning 791
smoothing bitmap images 802
smoothing vector drawings 827
using bitmap images 792

Back-Front tool 390

background
change fabrics 109
image, toggle on/off 298
images, changing 294
images, scanning 791
transparent 798

Background & Display Colors
dialog 295–299, 775
tool 109, 111, 283, 295

backstitch
Backstitch tool 216
borderline 215
diagonal 215
selecting for Tatami 214
standard 215
types 214

Backtrack tool 432, 1204
backtracking objects 432
Barcode 890
Barudan twin-sequin-capable 

machine 1150
baselines

adjusting 648
Baseline Settings dialog 653
changing 630
reshaping 649

Basic Shapes tool 348, 816, 1208
basic shapes, digitizing 348
bead fixings

apply 1229
editing options 1229

bead palettes
Bead Palette Editor dialog 1219
Bead Palette Editor tool 1219
setting up 1219

bead runs
automatic 1219, 1221
Bead Run Auto tool 1221, 1226, 

1232
Bead Run Manual tool 1221
create 1219, 1221
create palette 1219
edit 1232, 1233
manual 1219, 1221

Bead toolbar
Bead Edit 1233
Bead Palette Editor 1219
Bead Run Auto 1221, 1226, 1232
Bead Run Manual 1221
Manual Bead 1237

beading
bead drops, digitize 

manually 1237
Bead Edit tool 1233
bead mode 1214
bead production 1228
bead-capable machines 1216
custom 1245
digitize individual 1237
encoding & decoding 1247
insert bead drops 1241
insert functions 1241
machines 1215
manual digitizing 1237
visualize 1218

bitmap images
anti-aliasing 781
dimming 148
dithered 781
file types 823
inserting 823
scanned 781
scanning 791
smoothing 802
using as backdrops 792
view 87

Blackwork runs, splitting 381
bling

Automatic Overlap Removal 
tool 1262, 1272

Bling Edit tool 1272
Bling Fill tool 1262
Bling Lettering tool 1276
Bling Machine Setup dialog 1320
Bling Manual tool 1261
Bling Palette Editor

dialog 1254
tool 1254

Highlight Bling Overlaps 
tool 1262, 1272

No Automatic Overlap Removal 
tool 1262, 1272

set up palette 1254
view 87

bling fills
Bling Column Fill 1263–1270
Bling Contour Fill 1263–1270

bling runs
automatic 1258
Bling Run Auto tool 1258
manual 1258

Bling toolbar
Automatic Overlap 

Removal 1262, 1272
Bling Edit 1272
Bling Fill 1262
Bling Lettering 1276
Bling Manual 1261
Bling Palette Editor 1254
Bling Run Auto 1258
Highlight Bling Overlaps 1262, 

1272
No Automatic Overlap 

Removal 1262, 1272
Show Bling Work Area 1258, 

1262, 1320
block digitizing 248

with Block Digitizing tool 248
with multiple angles 248

Borderline backstitch 215
borders

Add Borders tool 345
digitizing with Column C 240, 

245
offset objects 353
sequin fills 1184
setting width 241

borer functions, set 192
boring

Borers tool 1136
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change borer display color 111
digitizing boring holes 1136
oval holes 1137, 1138
round holes 1137, 1138

boundaries, digitizing for 
appliqué 1279

branching 479
Branching tool 481
using auto underlay 484
using Color-Object List 482

brands, thread 135
Break Apart tool 381, 659, 741, 

1079
bunching, reducing with stitch 

shortening 449

C
Calibrate Screen dialog 160
CAMS machine, direct output 1320
CAMS Setup dialog 1321, 1323
Cap Corners tool 443–444
Capture Design Bitmap dialog 73, 

882
Capture Virtual Decoration Bitmap 

dialog 1121
Carving Stamp docker

Digitize 511
Use Object 509, 513
Use Pattern 507

carving stamps
adding to library 513
Carving Stamp tool 507–515
changing appearance 515
creating stitch patterns 506
digitizing 510
pre-defined 507
reshaping 516
using objects 508

CDR files, extended support 980
Center Out, letter sequencing 675
centering object, with crosshair 

cursor 330
Centerline Run Object

digitizing artwork 843
tool 844

Change View tool 973
Changed Stitches dialog 156
Character Map dialog 668
charts

manage threads 130
see thread charts

check for updates 147
Chenille fill stitch 605
circle objects

moving 376
reshaping 376

Clear Function tool 1203, 1241
clipart, embroidery 981
cloning objects 310
Close Curve with Curve Line 

command 237
Close Curve with Straight Line 

command 237
closest join 146

CND
compatible input methods 1112
conversion tables 1108
saving as 929
saving to 1110

codes, thread 135
Coil

Coil tool 603
Color Blending

dialog 601
tool 600

color blocks, split 292
Color Matching Method dialog 856
color matching, automatic 794
Color PhotoStitch

dialog 856
tool 856

color reduction 783
Color toolbar

Add Color 122, 125
Apply Current Color 122
Background & Display 

Colors 109, 111, 295
Color Wheel 284
Colorway Editor 99, 108, 125, 

281–292
Current Color 122
Current Colorway 108
Cycle Used Colors 284
Hide Unused Colors 123
Pick Color 122
Product Visualizer 109, 298, 774, 

1030
Remove Color 122
Remove Unused Colors 123
Split Palette Color 292
Threads 125

Color Wheel
dialog 284
tool 284

Color-change functions 190
color-change functions, set 189
Color-Object List

tool 60, 77, 321, 327, 482
docker 78, 99, 123, 292, 321, 828
resequencing objects 321–327
resequencing objects by 

number 327
select objects 77

colors
borer display 111
change backgrounds 109
change display 111
change thread colors 122
changing 284
changing thread colors 281
consecutive objects 129
copy across thread charts 133
create thread charts 131
edit thread colors 130
grid display 111
matching images to threads 794
modify thread details 134
object outlines 111
resequencing by 325

selecting objects by color 317
stitch display 111
thread colors 198, 280
travel by 105

Colorway Editor
tool 61, 125, 281–292
docker 99, 108, 130, 282–292
Edit Color 130

Colorway Editor tools
Background & Display Colors 283
Create Colorway 281
Delete Colorway 283
Rename Colorway 283

colorways 281
change display 107
display colors 111
view 108

Column A
tool 245–246, 520, 1087–1096, 

1136
creating borders 353
digitizing columns 245
offset objects 353

Column B
tool 248
creating borders 353
offset objects 353

Column C
tool 240–244, 448
corner fractions 243
creating offset objects 353
digitizing columns and 

borders 240
reversing stitch direction 432
round sharp corners 448

columns
digitizing with Column A 245
digitizing with Column C 240, 

245
setting width 241
turning stitching 248
width, adjusting 429
width, Pull Compensation 

tool 429
combination splits

Satin in Satin 495
Satin in Tatami 495
selecting 494
Tatami in Tatami 495
types 494

combining objects
and designs 306
Combine Appliqué Components 

tool 1297
Combine tool 388
nesting 311

commands
Close Curve with Curve Line 237
Close Curve with Straight 

Line 237
Manage Sequin Fixing 1210
Reverse Curves 549
Save as Monogram 

Template 277, 714
Save as Teamname 
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Template 277, 690
Update Kerning Settings 679, 

681
Use for Florentine Effect 543
Use for Liquid Effect 543

compensating for stretch, see pull 
compensation

Complex Fill
tool 250–256, 503, 536–538, 555, 

585
adding stitch angles 436
creating borders 353
digitizing objects 254
digitizing the stitch angle 250
filling holes 433
offset objects 353
open stitching 596
stitch angle 255
Trapunto 596

complex shapes
adding holes 254
digitizing 249

Complex Turning
tool 250–257
adding stitch angles 436
converting to appliqué 1284
nominal stitch angle 255
offset objects 353

composite objects, splitting 381
condensed files

Condensed File Input Settings 
dialog 914–920

Confirm File Replace dialog 1307
Connection Manager Setup 

dialog 162, 760
connection settings

Connection Manager 924
peripheral devices 160
serial ports 161, 168
USB ports 160

Connection Settings dialog 162, 
760

connectors
add Empty Stitch/Empty 

Jump 470
adding tie-offs and trims 468
after object 462
automatic 461
digitizing with Needles Out 471
inside objects 463
jumps 460
jumps (automatic) 461
Runs 460
runs (automatic) 463
setting automatic tie-in 

values 464
setting automatic tie-off 

values 465
setting automatic trim 

values 467
tie-ins 460, 465
tie-offs 460, 466
travel runs 472
Trim after 468
trims 460

types 459
consecutive objects, recolor 129
continuous input 144
Contour

tool 520, 520–523
Contour stitch overview 520
offset fraction 523
setting stitch values 523
Spiral 521
Standard 521

control points 230
reshape objects 369
viewing 370

conversion tables
digitizing for CND format 1112
opening CND files 1108
opening Gunold PCH files 1113
saving to CND format 1110
supported machine file 

formats 1104
convert

Convert Designs dialog 1002
Convert Embroidery to Graphics 

tool 833
Convert Selected Designs 

tool 1002
Convert TrueType Font

dialog 733, 1077
vector to embroidery 833, 835

Convert Graphics to Embroidery 
tool 614, 833, 1280

converting
Conversion Settings dialog 731–

1071
objects 833
photos to designs 847, 852
sequin artwork 1197
See also conversion tables

converting outline designs
CND conversion tables 1108
EMB conversion limitations 929
EMB to CND 929
EMB to CSD 931
PCH conversion table 1113

converting stitch designs
recognize Jumps as Trim 906
recognize Objects/Outlines 905

coordinates
length 84
setting for objects 330

copying
cloning objects 310
Copy Thread Chart dialog 134
Copy tool 309
duplicating objects 310
object properties 264
objects 309

cording 1129
Cording tool 1131
CorelDRAW Graphics

creating lettering 614
design window 57, 808, 1122, 

1126
Options dialog 1128, 1307

corners

cap 441
corner fraction value 243
corner fractions, Column C 243
fraction value 243
mitre 441
rounding, Column C 448
smart corners 441

cover stitches
digitizing appliqué 1281
setting values 1290

craft stitches, ripple fills 527
Create

Colorway tool 281
Alphabet dialog 745
Auto Fabric dialog 268
Colorway dialog 282
Hoop dialog 875–879
Program Split dialog 501–502
Split Pattern dialog 513
Style dialog 273
Thread Chart dialog 132
User-Refined Letter dialog 735

Create Letter
dialog 743–745

create lettering
letter height 739, 1069
letter shapes 739, 1068
letter width 740, 1069
monograms 665

Create Motif
dialog 568, 1246

Create Motif Set dialog 568, 1246
Create Sequin Fixing dialog 1210
Create Sequin Shape dialog 1209
Crop Bitmap tool 798, 808, 831, 

848, 852, 856
Cross Stitch tool 609
crosshair cursor 146, 330
CSD format, saving as 931
CSV output file 174
cumulative stitch count 146
current

Current Color tool 122
needle position marker 105
object properties, changing 261
object properties, make 

current 264
curved fills

adjusting settings 540
applying to existing objects 541
applying to multiple objects 542
Contour 520
creating 536
creating fills with two curves 538
creating new objects 536
Curve tab 541

curved lines, making 230
custom alphabets

saving 745
selecting 747

custom hoops 875
custom letters, saving 743
custom sequins 1208
cut and paste

objects 309
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resequencing 319
cut holes in objects 349
Cut tool 309, 319
cutting

cutting lines, digitizing 
appliqué 1281

threads 469
Cycle Used Colors tool 284

D
decode bead output 1247
default thread charts, save to 

template 137
Define Stop Sequence dialog 914
Delete Colorway tool 283
density, applying fractional 

spacing 450
deselect objects 75
design catalogs, print 1005
design colors, changing 284
design components

view 85
view embroidery 85
view graphics 87

design files
convert 1002
filter 977
locate 990
new from existing 980
open 978
overview 65
print 1003
search in library 990
send to machine 1003

design formats
Gunold PCH 65
old format ESD 65
Wilcom INP 65

design information
tool 172, 288, 884, 983
manage 983
tool 290
view 974

Design Information docker 116, 
1211
Design 985
Order 986
Runtime 172, 990
Stitching 128, 173, 988
Summary 984
Thread Colors 291, 988

Design Integrity Alert dialog 156
Design Library

add folders 993
layout 969
window 971

designs
Auto Start and End 866
combining 306
components, exporting 1311, 

1312, 1314, 1315
converting formats 45
export lists 1007

export machine files 928
multiple views 92
naming elements 290
open 68
opening stitch designs 905
outputting 923
preview reports 118
redraw slowly 103
resequencing 319
save 71
view repeats 113
templates, see templates

device reset 962
devices

beading 1215
single / twin 1149

Diagonal backstitch 215
Dialogs

Color Matching Method 831, 838
dialogs

Add Bitmap Colors 795
Add Border 346
Add Thread 135
Add to Favorites 275
Adjust Bitmap 808, 856
Appliqué Fabric 1286
Apply Style 272
Auto Fabric 68, 266, 841, 844, 

845, 846
Auto Fabric Settings > 

Lettering 271
Auto Fabric Settings > Narrow 

Satin 270
Auto Fabric Settings > 

Stabilizer 271
Auto Fabric Settings > 

Tatami/Program Split Fill 269
Auto Fabric Settings > Wide 

Satin 270
Auto Spacing Settings 206
Auto Start & End 775
Auto Start and End 867
Automatic Resize 808
Background & Display 

Colors 295–299, 775
Baseline Settings 653
Bead Palette Editor 1219
Bling Machine Setup 1320
Bling Palette Editor 1254
Calibrate Screen 160
CAMS Setup 1321, 1323
Capture Design Bitmap 73, 882
Capture Virtual Decoration 

Bitmap 1121
Changed Stitches 156
Character Map 668
Color Blending 601
Color Matching Method 856
Color PhotoStitch 856
Color Wheel 284
Condensed File Input 

Settings 914–920
Confirm File Replace 1307
Connection Manager Setup 162, 

760

Connection Settings 162, 760
Conversion Settings 731, 1071
Convert Designs 1002
Convert TrueType Font 733, 1077
Copy Thread Chart 134
CorelDRAW Options 1128, 1307
Create Alphabet 745
Create Auto Fabric 268
Create Colorway 282
Create Hoop 875–879
Create Layout Set 696
Create Letter 743–745
Create Motif 568, 1246
Create Motif Set 568, 1246
Create Program Split 501–502
Create Sequin Fixing 1210
Create Sequin Shape 1209
Create Split Pattern 513
Create Style 273
Create Teamname Layout 696
Create Thread Chart 132
Create User-Refined Letter 735
Define Stop Sequence 914
Design Integrity Alert 156
Digitizer Setup 180
DXF File Options 821
Edit Color 130
Edit Function 408
Effects > Curve 531
Embroidery Machine 

Connection 166
Export 803, 1123, 1126
Export Design 930–931
Export Multi-Decoration 

Files 1128, 1307–1314
Export to PNG 1123, 1126
Fabric Settings Unchanged 156
File Locations 1312
Fill Holes 351
Format Embroidery Disk 934
Format Floppy Disk Drive 934
Hardware Setup 166, 168–178
Hoop Not Found 869
Import 824
Import Embroidery 306
Import EPS 824
Import Graphic 792, 821
Info 869
Insert Function 405
Insert Symbol 662–665
Kerning Table 680
Kiosk 759
Length Calculation 128
Letter Sequence 675–677
Letter Spacing Table 682
Machine Format Settings 1150, 

1217
Machine Format Settings > 

Advanced 194–196
Machine Format Settings > 

Standard 188–193, 197
Machine Runtime Settings 170
Machine Runtime Setup 170
Manage Alphabets 748
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Manage Auto Fabrics 268
Manage Favorites 275
Manage Motifs 571
Manage Sequin Shape 1209
Manage Styles 273–275
Manage Teams 703
Manage Thread Charts 132–135
Manage User-Refined 

Lettering 737
Move Stitch 400
My Hoops 865
Name Order 688
New from Template 70, 771
New Pattern Set 513
Non-Native Design 156
Open 905, 917
Open Custom Kiosk Banner 767
Open Design 68, 73, 769
Open Embroidery Disk 932
Open From Embroidery Disk 932
Open Options 905–914
Optimize Color Changes 324
Options > Edit 310
Options > Export 174
Options > General 139, 145, 247
Options > Grid & Guides 79, 151, 

872
Options > Hoop 865, 872–879
Options > Kiosk 759, 765–767
Options > Reshape 155, 383
Options > Scroll 154
Options > View Design 147
Options > View Design tab 97
Options > View Graphics 149
Options > Warnings 156
Outlines & Offsets 353
Prepare Bitmap Colors 808
Print 885
Print Catalog Options 1005
Print Design 1003, 1005
Print Options 885, 1003, 1316
Print Options > Barcode 890
Print Options > Blocks 176, 899
Print Options > Colorways 891
Print Options > Design 893
Print Options > General 889
Print Options > Info 898
Print Options > Stop 

Sequence 901
Print Options > Zoom 893
Process Stitches 415, 439
Properties (Windows 

Explorer) 117
Pull Comp 430
Recognition - Advanced 

Options 908–913
Reef PhotoStitch 853
Remove Overlaps 434
Remove Small Stitches 440
Rename Alphabet 748
Rename Letter 748
Rename Split Pattern 507, 513
Rename Thread Chart 132
Repeats 114, 893

Resequence By Number 327
Revert to Factory Settings 279
Save As 277
Save As Template 137
Save Hoop As 875
Save Options 930–931
Save Pattern 1172, 1179
Save to Embroidery Disk 935
Select By Color 317
Select By Stitch Type 318
Select Fabric Pattern 295
Select Machine Format 64, 196, 

1150, 1217
Select Source 176
Select Thread Charts 126, 132
Send to Appliqué Cutter 1318
Send to Bling Cutter 1325
Send to CAMS Machine 1321, 

1323
Send to Connection 

Manager 924, 1321, 1323
Send to Stitch Manager 926
Sequence By Color 325
Sequin Palette Editor 1153, 1201
Sequin Pattern 1169, 1197, 1198
Serial Port Setup 168
Set Color 129
Show Functions 410
Show Stitches 411
Simple Offsets 352
Smart Design 841
Smooth Curves 827
Some Bling Remaining 1324
Special 448, 675, 702
Stitch Manager 926
Stitch Player 103
Stitch Shortening Settings 451
Tablet Setup 183–184
Team Names 688
Team Names Matrix 709
Teamname Layouts 693
Teamname List 693, 699–708
Transform by Reference 

Line 335, 340
TrueView Options 147
Turning Auto Fabric Off 266
Turning Auto Fabric On 266
View by Color 99
Warning 476

Digitize Closed Shape tool 235, 
536, 538, 549, 816

Digitize Column tool 245
Digitize Open Shape tool 235, 549, 

816
Digitize Run tool 237, 542, 585, 

1203, 1241
Digitizer Setup dialog 180
digitizer tablets

change drawing scale 184
Digitizer Setup dialog 180
point mode 179
puck actions 185
register enlargement 

drawings 181

stream mode 179
digitizing

appliqué objects 1281
boring holes 1136
closed shapes using Digitize 

Closed Shape tool 235
columns 248
columns and borders 240, 245
columns with Column A 245
complex shapes 249
individual stitches 412
input methods 225
lines with Open Shape 235
methods, Open Shape tool 235
new motifs 568
shapes with Auto Trace To 

Vectors 825
split lines 503
turning stitches 536
with Needles Out 471

digitizing artwork
Centerline Run Object 843
Outline Run Object 843
Tatami Fill 843
Tatami Fill without Holes 843
Turning Satin 843

digitizing methods
Column C 240, 245
selecting 225

digitizing tool options 144
Dim Artwork tool 148
dim graphics 149
dimming backdrops 148
direct-to-garment production 1251
display options 96

change colors 111
font list display 145
grid 79
pointer position 140
settings 107
toolbar display 144

distances, measure on-screen 84
dithering 781
Docker toolbar

Carving Stamp 507–515
Color-Object List 60, 77, 96, 99, 

321, 327, 482
Colorway Editor 61
Design Information 116, 172, 

288, 290, 884
Embroidery Clipart 981
Object Properties 60–62, 261–

276, 461–472, 680, 818
Overview Window 94
Stitch List 397–411, 1203, 1241

dockers
Carving Stamp 1188
Carving Stamp > Digitize 511
Carving Stamp > Use 

Object 509, 513
Carving Stamp > Use 

Pattern 507
Color-Object List 78, 99, 123, 

292, 321, 828
Colorway Editor 99, 108, 130, 
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282–292
Design Information 1211
Design Information > 

Design 985
Design Information > Order 986
Design Information > 

Runtime 172, 990
Design Information > 

Stitching 128, 173, 988
Design Information > 

Summary 984
Design Information > Thread 

Colors 291, 988
Monogramming > Borders 725
Monogramming > Designs 714
Monogramming > Letters 717
Monogramming > 

Ornaments 719
Object Properties 1172, 1190, 

1226
Object Properties > 

Accordion 598–601
Object Properties > Auto 

Jump 457
Object Properties > Bling 

Fills 1263–1270
Object Properties > Bling 

Run 1259
Object Properties > 

Connectors 462–468
Object Properties > Curves 565–

567
Object Properties > Decorative > 

Jagged edge 583
Object Properties > Decorative > 

Trapunto 596
Object Properties > Fill Stitch > 

Stipple Fill 590, 593
Object Properties > Fills 261–

263, 276
Object Properties > Fills > Cross 

Stitch 609
Object Properties > Fills > E 

Stitch 587
Object Properties > Fills > Motif 

Fill 546, 556–560
Object Properties > Fills > Photo 

Satin 848
Object Properties > Fills > Raised 

Satin 210
Object Properties > Fills > 

Ripple 528
Object Properties > Fills > 

Satin 204–210, 455
Object Properties > Fills > Sequin 

Column Fill 1179, 1185, 1190, 
1194

Object Properties > Fills > Sequin 
Stipple Fill 1186

Object Properties > Fills > 
Tatami 212–214, 487–491, 596

Object Properties > Hand 
Stitch 579

Object Properties > Outlines > 
Backstitch 217

Object Properties > Outlines > 
Bead Run 1226–1230

Object Properties > Outlines > 
Motif Run 546–549

Object Properties > Outlines > 
Run 201, 1204, 1242

Object Properties > Outlines > 
Sequin Run 1161–1164, 1169–
1172

Object Properties > Outlines > 
Square 587

Object Properties > Outlines > 
Stemstitch 217

Object Properties > Outlines > 
Triple Run 202

Object Properties > Program 
Split 493–502

Object Properties > Pull 
Comp 428–430, 625

Object Properties > 
Shortening 451

Object Properties > Smart 
Corners 444, 450

Object Properties > Special > 
Appliqué 261, 1292

Object Properties > Special > 
Bitmap 802

Object Properties > Special > 
Column C 242–244

Object Properties > Special > 
Complex Fill 255–257

Object Properties > Special > 
Complex Turning 255–258

Object Properties > Special > 
Lettering 637–658, 662–665, 
672–682, 731–747, 1071

Object Properties > Special > 
Photo Flash 848

Object Properties > Special > 
Vector 818

Object Properties > 
Underlay 421–426, 484

Object Properties >Special > 
Lettering 622–627, 634

Object Properties >Special > 
Travel Run 472

Product Visualizer 299
Stitch List 397–411, 471
Threads 126, 132

DOS disks, opening designs 932
drawing objects

coloring 818
coloring fills 818
coloring outlines 818
create enlargement drawing 181
creating complex shapes 386
drawings creating 816
enlargement drawings 181
See vector objects 816
smoothing vectors 827

drawing scale 182
change 184

Drop Bead
functions, insert 1241

Drop Sequin
functions, inserting 1203
tool 1203

drop-stitch direction, sequin 

runs 1164
duplicate options

object property position 142
shift duplicated objects 142

duplicating
cloning objects 310
objects 310

DXF File Options dialog 821

E
E Stitch tool 218, 587
EC device

configuring memory size 953
reset 962
troubleshooting 961

Edit Color
dialog 130
tool 130

Edit Function dialog 408
Edit menu

Reverse Curves 432
Edit tools

Automatic Knife 385
Break Apart 381, 659, 741, 1079
Knife 383, 1079

editing objects 369
editing stitches 400

inserting stitches 399
machine functions 402
moving stitches 400
removing small stitches 440
using Stitch List 409

EDS-III
conversion table 1108
digitizing for 1112
saving to CND format 1110

effects
3D warp 565–567
Accordion 598–601
Accordion Spacing 598
Auto Jump 456
Auto Underlay 419
Color Blending 600
Curve 531, 541
Jagged Edge 582
pull compensation 428
Shortening 451
smart corners 441
stitch shortening 449
Trapunto 596

Effects toolbar
Cording 1131

elements, naming 116, 290
Ellipse tool 234, 816, 1208
email attachments 73
embroidery clipart 981
Embroidery Clipart docker 981
embroidery components, view 85
Embroidery Disk tool 932–935
embroidery disks

formats 934
formatting 934
opening designs 932
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Embroidery Machine Connection 
dialog 166

embroidery machines
connections 161

embroidery objects
convert to sequins 1196
convert to vector 833, 835
creating complex shapes 386
inter-converting 833

EmbroideryStudio, starting 51
EMF format 1305
EMT files 277
encode bead output 1247
end-of-design functions, set 192
enlargement drawings

change scale 184
creating 181
prepare 181
register 182
shift 184

entry/exit points
adjusting 474
changing 827

Envelope effect
Bridge Envelope 379
Diamond Envelop 379
Penant Envelope 379
Perspective Envelope 379

Envelope Tools
Bridge Envelope 379
Diamond Envelope 379
Penant Envelope 379
Perspective Envelope 379

envelopes
distorting lettering objects 379
types 379

EPS format 1305
estimates

runtime 169
thread usage 128

Exclude tool 390
Export Design

dialog 930–931
Information 174
List tool 1007

Export Design as Vectors 
command 1305

export designs 928
Export dialog 803, 1123, 1126
Export Machine File tool 928, 1211
Export Multi-Decoration Files

dialog 1128, 1307–1314
tool 1307–1313

Export to PNG dialog 1123, 1126

F
Fabric Settings Unchanged 

dialog 156
fabrics

change colors 109
fabric stretch, see pull 

compensation
managing 268
select 70

fancy fill stitches, Program 
Split 492

favorites, assigning favorite 
styles 274

file formats
sequins 1149, 1211

File Locations dialog 1312
file sources, A, B, C, D 66
file types

design files 65
EMT 277
machine files 1104

Fill Holes
dialog 351
tool 351

Fill Stitch Types
String 585

Fill Stitch Types toolbar
Coil 603
Contour 520–523
Cross Stitch 609
Double Square 608
Island Coil 605
Motif Fill 223, 545, 555, 557, 559, 

563
Offset Fill 526
Program Split 219, 492–498, 671
Satin 204–209, 454, 669, 1087–

1096
Satin Raised 204–209, 669
Spiral Fill 527
Square 607
Stipple Backstitch 589
Stipple Fill 589
Stipple Stemstitch 589
Tatami 212, 487, 491, 670
Vector Fill 816
Zigzag 670

Fills
Contour 520–523, 524
Cross Stitch 609
Double Square 608
E Stitch 587
Motif Fill 223, 545, 555, 557, 559, 

563
Motif Fills 556–557
Offset Fill 526
Photo Satin 848
Program Split 219, 493–498, 671
Raised Satin 210
Satin 204–209, 261–263, 455, 

669
Satin Raised 204–209, 669
Spiral Fill 527
Square 607
Stipple Backstitch 589
Stipple Fill 589, 590, 593
Stipple Stemstitch 589
Tatami 212, 212–214, 487–491, 

596, 670
Vector Fill 816
Zigzag 587, 670

fills
adjusting curved fill settings 540
applying curved fills 541–542

block digitizing 248
creating curved fills 536
creating fills with two curves 538
cross stitch 609
fill stitching 605
ripple 527
Sequin Column Fill 1179–1194
Sequin Stipple Fill 1186
switching between fill and 

outline 230
Tatami 211
with sequins 1178

filtering stitches
by function 410
by stitch length 411

Finalize Crop command 798
Finalize Crop tool 799
find threads 130
fixing stitches 1160

beads 1227
color 1160
types 1160

flat bead fixing 1227
Flexi Split tool 533
flip sequins 1188
Florentine Effect tool 536–540
folders, view designs 971
font list display 145
fonts, letter kerning 678
Format

Embroidery Disk dialog 934
Floppy Disk Drive dialog 934

formats
EPS, EMF 1305
machine types 1100

Forward
1 Color tool 322
1 Object tool 322

Fractional Spacing tool 450
frame movement, Auto Jump 456
Freehand

Select tool 75
Closed Shape tool 574–576
creating lines 575
Open Shape tool 573–576
smoothing lines 576

Freehand Embroidery Smoothing 
toolbar
Guide Inner Circle Radius 577
Number of Guide Circles 577
Show Guide 577

Front-Back tool 390
Function toolbar

Borers 1136
Insert Empty Jump 470
Insert Empty Stitch 470
Insert Function 405, 1203, 1241
Insert Tie Off 469
Insert Trim 469
Penetrations 471, 1136

functions
Drop Bead 1241
Drop Sequin 1203
end-of-design 192
Stop 192
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G
gaps, offsetting filled holes 433
general options

digitizing tools 144
General Properties

dimensions 334
positioning using 

coordinates 330
Generate Stitches tool 232
grade A, B, C, D 66
graded motif columns 563
graded motif runs 552
graphical components, view 87
graphics

converting to appliqué 1279
EMF, EPS 1305
grayscale images, 

converting 847, 852
open files 980
packages, linking 800

Graphics Digitizing toolbar
Basic Shapes 348, 816, 1208
Digitize Closed Shape 235, 536, 

538, 549, 816
Digitize Column 245
Digitize Open Shape 235, 549, 

816
Ellipse 234, 816, 1208
Fill Holes 351
Freehand Closed Shape 574–576
Freehand Open Shape 573–576
Rectangle 234, 816
Remove Stitch Angles 436
Stitch Angles 436

grid
display 79
display color 111
snap to 152
spacing 151

Group tool 312
grouped objects 312

selecting components 315
Guide Inner Circle Radius tool 577
guide patterns

Motif Fill 559
Program Split 498

Guide Position dialog 79
guide runs

digitizing appliqué 1281
offsetting 1286
setting values 1286

Gunold, opening PCH files 1113

H
Hand Stitch tool 579
handles, see selection handles
hardware

monitor setup 160
peripheral device settings 160
setting up scanner 176

Hardware Setup
dialog 166–168, 178
tool 166, 168, 178

height, make objects same 
size 335

hidden objects, display 77
Hide Unused Colors tool 123
Hole Tools

Add Holes 349
Fill Holes 351
Remove Holes 349

holes
add holes 349
adding to complex shapes 254
digitizing boring holes 1136
filling holes 433

Hoop Not Found dialog 869
hoops

custom lists 865
frame out (Auto Appliqué) 1292
selecting 871

hot-fix template production 1251

I
images

bitmaps 792
changing backgrounds 294
cleaning up 783
color reduction 783
cropping 798
dimming bitmaps 148
editing 800–801
image preparation 782
inserting bitmaps 823
loading 823
matching thread colors 794
noise filtering 785
outline sharpening 784
outlined vs non-outlined 782
preparation 782
scanning bitmaps 791
sharpening 788
smoothing bitmaps 802

Import Embroidery
dialog 306
tool 306, 773

Import EPS dialog 824
Import Graphic

dialog 792, 821, 824
tool 792, 823, 856, 1125

Import Team Members tool 690
Info dialog 869
input methods

Column A 245
digitizing 225
Motif Run 549
selecting 225

insert designs, clipart 981
Insert Empty

Jump tool 470
Stitch tool 470

Insert Function
dialog 405
tool 405, 1203, 1241

Insert Symbol dialog 662–665
Insert Tie-Off tool 469

Insert Trim tool 469
inserting

bitmap images 823
one design into another 306
one object inside another 311
stitches 399

Instant embroidery
auto-digitize 837

inter-converting objects 833
Intersect tool 390
Island Coil

fill stitch 605
tool 605

italics, lettering 624

J
Jagged Edge tool 579, 582, 671
joining

creating smooth joins 246
objects, see connectors

jumps
adding 471
adding Empty Jumps Empty 

Stitches 470
Auto Jump 456
automatic connectors 461
digitizing with Needles Out 471
overview 460
using 403

justification, lettering 624

K
kaleidoscope

Kaleidoscope tool 364
using with wreath 364

Keep
Graphic Objects tool 833
Original Objects tool 394

keep/omit last stitch
Column A 246
Column B 248
Keep Last Stitch tool 473
Omit Last Stitch tool 473

Kerning Table dialog 680
Kiosk

dialog 759
Choose Design Panel 755
customization panel 755, 757
Monograms 758

Knife tool 383, 1079

L
Lap Corners tool 443–444
last stitch, keep or omit 246–248
layers, removing excess 

stitching 433
layout

Design Library 969
Layout tool 971
Motif Fills 559
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Program Split patterns 498
sequin fills 1181

Legacy Features toolbar
Embroidery Disk 932–935
Hardware Setup 166, 168, 178
Send to Stitch Manager 926

length
automatic split 454
Contour stitch 523
Length Calculation dialog 128
nominal 540
preserving long stitches 456
travel runs 472

Letter Sequence dialog 675–677
letter spacing

adjusting 627
automatic 682
changing 626

lettering
Lettering tool 620–630, 636–638, 

648–655, 662–663, 672–679, 
699, 730–747, 771, 773, 1070–
1099

2-color alphabets 677
Lettering tool 675–677
adding to designs 38
adjusting individual letters 643
adjusting Satin stitch 

settings 669
applying lettering art 379
art, applying 379
As Digitized join method 678, 

1034
automatic borders 345
Bottom Join method 678, 1034
Closest Join method 678, 1034
coloring 648
coloring on-screen 648
converting TrueType letters 730
creating embroidery fonts from 

TrueType 729, 1070
creating in CorelDRAW 

Graphics 614
creating in design window 616
creating monograms 665
editing 636
formatting 624
generating stitches 232
I-beam 648
join methods 677
keeping original stitch 

values 677
kerning 678
letter spacing 626
Letter Spacing Table dialog 682
line spacing 626
names, see names
reshaping baseline 649
reshaping curved baselines 649
reshaping on screen 645
selecting symbols 662
special characters and 

symbols 661, 662
splitting 381
stitching sequence 675

transforming with Reshape 
Object tool 644

word spacing 626
See also alphabets
See also baselines

lines
digitizing with Open Object 235
split lines 503

Liquid Effect tool 538–542
Lock tool 314
locking objects 312
lockstitches, see Empty Stitch

M
machine connections

bead-capable 1216
Machine Format Settings > 

Advanced 194–196
Machine Format Settings > 

Standard 188–193, 197
Machine Manager 923
sequin-capable 1150
supported formats 1100

machine files
conversion options 905
open 979
opening 905
overview 66
processing into objects 905
reassigning colors 914
stitch recognition 905
supported formats 1104

Machine Format Settings 
dialog 1150
Advanced 1217
Standard 1217

machine formats
advanced 193
changing 923
color-change sequence 194
create custom 197
Dahao 1149
select 64, 70
sequins 1149, 1211
start/end of design 194

machine functions
borers in/out 402
boring 404
color change 402, 403
inserting manually 405
jumps 402–403
sequins on/off 402
speed 195
Stops 403
thread trim 403
trims 402
types 403
using 405

Machine Runtime
configure 170
Settings dialog 170
Setup dialog 170

machines
connection setup 161

view functions 87
Make Properties Current tool 264
Make Same

Height tool 335
Width and Height tool 336
Width tool 335

Manage
Alphabets dialog 748
Auto Fabrics dialog 268
Embroidery Library Locations 

tool 993
Favorites dialog 275
Motifs dialog 571
Sequin Shape dialog 1209
Styles dialog 273–275
Teams dialog 703
Teams tool 691
Thread Charts dialog 132–135
User-Refined Lettering 

dialog 737
Manage Designs toolbar

Convert Selected Designs 1002
Export Design List 1007
Manage Embroidery Library 

Locations 993
New From Selected 793, 980
Open Selected 978
Print Selected 1003
Print Selected to Catalog 1005
Send to Connection 

Manager 1003
manual

Manual Bead tool 1237
Manual Sequin tool 1167, 1200
Manual tool 412, 1136
digitize beads 1237
manual objects splitting 401
objects 66
right-clicking 413

Manual tools
Manual 412
Triple Manual 413

Match All tool 125
Match to Embroidery Palette 

tool 833
match to palette, inserted files 142
Matching Method dialog 844, 845, 

846
matrix of team names 708
maximum stitch length 540
Maze Fill tool 592
measurements

distances on screen 84
setting units 81

Melco
CND conversion tables 1108
CND format, saving as 929
digitizing for CND (tables) 1112

memory size, configuring EC 
device 953

minimum stitch, Tatami 211, 212
Mirror

by Reference Line tool 342
Horizontal tool 342
Vertical tool 342
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Mirror Copy
Horizontal & Vertical tool 361
Horizontal tool 361
Vertical tool 361

Mirror Merge Settings toolbar 363–
366

Mirror Merge tools
Array 366
Kaleidoscope 364
Mirror Copy Horizontal 361
Mirror Copy Horizontal & 

Vertical 361
Mirror Copy Vertical 361
Reflect 362
Wreath 364

mirroring objects
around a specified axis 342
around X or Y axis 342
creating wreaths 364
horizontally 342
vertically 342
with kaleidoscope 364

mitre corners 441
Mitre Corners tool 443–444

Mode toolbar
Convert Embroidery to 

Graphics 833
Convert Graphics to 

Embroidery 614, 833, 1280
CorelDRAW Graphics 57, 808
Design Library 11, 59, 793, 971
Home 52
Keep Graphic Objects 833
Match to Embroidery Palette 833
Show Embroidery 57, 1122
Switch to CorelDRAW 

Graphics 823, 1122, 1126
Tag as Appliqué 1279
Tag as Photo Flash 833, 848
Tag Fill as Turning Satin 614, 833
Wilcom Workspace 53

modify designs 32
Color-Object List 77
moving objects 329

modifying objects
aligning 330
changing entry point 827
changing exit point 827
changing radius of Circle 376
changing size of Ring 377
grouping 312
locking 312
mirroring 341
moving Ring object 

boundary 377
resequencing objects by 

number 327
resequencing with Color-Object 

List 327
reshaping Circle objects 376
reshaping Ring objects 377
reshaping Star objects 376
rotating 337
scaling 332
skewing

spacing evenly 331
using envelopes 379

monitor, setup 160
Monogramming docker

Borders 725
Designs 714
Letters 717
Ornaments 719

Monogramming tool 714–724
monograms

creating 665
splitting 381

motif fill
Motif Fill tool 223, 545, 555, 557, 

559, 563
applying 223, 555
filling shapes with 223, 555
layout 560
layout motifs 559
modifying layouts on-screen 559
motif size 559
offsets 557
rotating 559
spacing 557
Two-part motifs 556
values 557

motif run
Motif Run tool 223, 545–549, 

1203, 1241–1245
creating offset objects 353
graded 552
Motif Run tool 549
overview 549
reshaping 553

motifs
adjusting offsetting 

on-screen 562
adjusting spacing on-screen 561
creating new 568
custom beads 1245
graded columns 563
laying out on-screen (Motif 

Fill) 559
motif sets 571
overview 545
reference points 568
remove functions 568
rotating patterns on-screen 561
saving 568
scaling (Motif Fill) 559
scaling patterns on-screen 561
skewing patterns on-screen 561
See also Motif Fill
See also Motif Run

mouse wheel, preset behavior 153
move pointer after scroll 154
Move Stitch dialog 400
Move to

End tool 322
Start tool 322

moving objects
moving circles 376
nudging 330
positioning with X:Y 

coordinates 330

with click-and-drag 330
multi-bead run patterns, 

create 1226
multi-colorways 281
multiple

stitch angles 248
views 92

multi-sequins
create fills 1190
create run patterns 1171
setting up patterns 1168

My Hoops dialog 865

N
names, outputting designs 707
native file formats 66
needle penetrations

applying partition lines 489
decorative (Program Split) 492
digitizing split lines 503
digitizing with Needles Out 472
offsetting (Tatami) 487
offsetting for Contour 523
random factor 491

needle position marker 105
needle-number functions 190
network folders, view designs 971
new

New Design tool 70
New Pattern Set dialog 513
New tool 1085, 1094

New from
Selected tool 793, 980
Template dialog 70, 771

noise filtering, images 785
nominal stitch length 540
Non-Native Design dialog 156
NORMAL template

overview 276
reverting 279
use 70

nudging objects into position 330
Number of Guide Circles tool 577

O
Object menu

Create Motif command 568, 1246
object outlines, display color 111
object properties

Object Properties tool 60–62, 
261–262, 276, 461–467, 472, 
680, 818, 1172, 1190, 1226

access 62
applying/managing 271
changing 262
connectors 459
current 260
default 260
lettering 621
make current 264
presetting 261
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saving current 261
saving to a template 276
styles 271
templates 275

Object Properties docker 63
Accordion 598–601
Auto Jump 457
Auto Underlay 484
Bling Fills 1263–1270
Bling Run 1259
Connectors 462–468
Curves 541, 565–567
Decorative > Jagged edge 583
Fills 261–263, 276
Fills > Appliqué 1292
Fills > Cross Stitch 609
Fills > Decorative > 

Trapunto 596
Fills > E Stitch 587
Fills > Motif Fill 546, 556–560
Fills > Photo Satin 848
Fills > Program Split 493–502
Fills > Raised Satin 210
Fills > Ripple 528
Fills > Satin 204–210, 455
Fills > Sequin Column Fill 1179–

1194
Fills > Sequin Stipple Fill 1186
Fills > Stipple Fill 590, 593
Fills > Tatami 212–214, 487–491, 

596
Hand Stitch 579
Outlines > Backstitch 217
Outlines > Bead Run 1226–1230
Outlines > Motif Run 546–549
Outlines > Run 201, 1204, 1242
Outlines > Sequin Run 1161–

1164, 1169–1172
Outlines > Square 587
Outlines > Stemstitch 217
Outlines > Triple Run 202
Pull Comp 428–430, 625
Shortening 451
Smart Corners 444
Smart Corners > Fractional 

spacing 450
Special 472, 675, 702–1295
Special > Appliqué 261, 1282–

1292
Special > Bitmap 802
Special > Column C 242–244, 

448
Special > Complex Fill 255–257
Special > Complex Turning 255–

258
Special > Lettering 622–627, 

634, 637–658, 662–665, 672–
682, 731–747, 1071

Special > Photo Flash 848
Special > Vector 818
Underlay 421–426, 684

objects
applying underlay 420
backtracking 432

circles 346
cloning 310
connecting 459
convert to sequins 1195
converting 833
copying and pasting 309
creating duplicates 432
deselect 75
duplicating 310
editing 369
French dots 346
locking and unlocking 314
manual 66
mirror-merging 341
moving 329
nesting 311
ovals 348
positioning 329
reflecting 362
repeating 432
resequencing 318
reshaping 369
rings 346
rotating 337
select colors 122
selecting 26
shaping 386
skewing 340
splitting 381, 401
vector 816
See also modifying objects

Offset Fill tool 526
offsetting

Auto Spacing (Satin) 205
Contour needle points 523
creating offset objects 353
filled holes (Complex Fill) 433
Motif Fill patterns 557
objects 353
offset fractions (Tatami) 487
Program Split patterns 

on-screen 500
random factor (Tatami) 491
using partition lines 489

omit/keep last stitch
Column A 246
Column B 248

open
Open Design tool 68, 73
Open Recent tool 68
Open tool 762, 768
Open Custom Kiosk Banner 

dialog 767
Open Design dialog 68, 73
Open dialog 905, 917
Open Embroidery Disk 

dialog 932
Open From Embroidery Disk 

dialog 932
Open Options dialog 905, 914
Open Selected tool 978
stitching, see also color blending

Open Offsets tool 359
open stitching, Trapunto 596
open-ended shapes, digitizing 235

opening designs
converting stitch designs 905
from DOS disk 932
other formats 932
scaling 903

OpenType fonts, converting to 
embroidery 618

Optimize Color Changes dialog 324
options

check for updates 147
closest join 146
crosshair cursor 146
cumulative stitch count 146
digitizing tools 144
general 146
move pointer after scroll 154
play button sounds 146
pointer position 140
response time 154
show Home screen on 

startup 146
show measure tooltip 146
View Design tab 97
view settings 147

Options dialog
Edit 310
Export 174
General 139, 145, 247
Grid & Guides 79, 151–152, 872
Hoop 865, 872–879
Kiosk 759, 765–767
Reshape 155, 383
Scroll 154
View Design 147
Warnings 156

Options tool 147–156, 247, 759–
767, 1120–1125

outlines
Outline Run Object tool 844

Outline Stitch Types toolbar
Backstitch 216
Contour 520–523
E Stitch 218, 587
Motif Run 223, 545–549, 1203, 

1241–1245
Program Split 219, 492–498
Run 200, 201, 1131
Satin 204–209, 1088–1096
Satin Raised 204–210
Sculpture Run 200, 203
Square 218, 587, 606
Stemstitch 216
Tatami 212
Triple Run 200, 202
Vector Outline 816, 1208
Zigzag 218, 587

Outline tools
Motif Run 549

Outline Tools toolbar
Digitize Run 237, 542, 1203, 

1241
outlines

Backstitch 216
Bead Run 1226–1230
change display color 111
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Contour 520–523
control points 230
creating borders around 

objects 353
digitizing artwork 843
E Stitch 218, 587
Motif Run 223, 545–549, 1203, 

1241–1245
Program Split 219, 492–498
Run 200, 201, 1131, 1204, 1242
Satin 204–209, 1088–1096
Satin Raised 204–210
Sculpture Run 200, 203
Sequin Run 1161–1172
Square 218, 587, 606
Stemstitch 216, 217
stitches, Motif Run 549
switching between fill and 

outline 230
Tatami 212
Triple Run 200, 202
Vector Outline 816, 1208
Zigzag 218, 587

Outlines & Offsets 353
outlines, simple 199
outputting designs

to different formats 923
ovals

boring oval holes 1137, 1138
reshaping circles to ovals 376

overlapping
color blending 600
stabilizing segments 256

overlaps
removing stitching 433
tolerance between 

rhinestones 1254
overstitching, pull 

compensation 428
Overview Window tool 94

P
Partial Appliqué tool 1294
partition lines 489
paste options

center at current stitch 142
object property position 142
shift pasted objects 142
start at current stitch 142

Paste tool 309, 319
patterns

creating patterns 501
editing 502
laying out on-screen (Motif 

Fill) 559
laying out on-screen (Program 

Split) 498
multi-bead runs 1226
multi-sequin fills 1190
multi-sequin runs 1171
pre-defined 507
Program Split 492
scaling for Motif Fill 559

setting up twin-sequins 1168
using objects 508

Penetrations tool 471, 1136
peripheral devices, connection 

settings 160
Photo Flash tool 847
photos, converting to 

embroidery 847, 852
Pick Color tool 122
planning

design shapes 24
stitching sequence 24

play button sounds 146
PNG format 1311, 1312, 1314, 

1315
point mode, digitizer tablets 179
pointer position, display 140
Polygon Select tool 75
Polyline Select tool 75
ports

serial 161, 168
USB 160

position coordinates 84
Prepare Bitmap Colors

dialog 808
tool 804, 808

preserving long stitches 456
preset styles, NORMAL 

template 276
Print Catalog Options dialog 1005
print design

save as PDF 119, 886
Send design as PDF 

attachment 119, 886
send to printer 119, 886

Print Design dialog 1003, 1005
Print now command 119, 886
Print Options dialog 885, 1003

Barcode 890
Blocks 176, 899
Colorway 891
Design 893
General 889
Info 898
Stop Sequence 901
Zoom 893

Print Preview tool 1211
Print Selected to Catalog tool 1005
Print Selected tool 1003
printing

Print dialog 885
Print Options dialog 1316
Print Preview tool 118
Print tool 884

Process Stitches
dialog 415, 439
tool 415, 438

product backdrops, view 87
Product Visualizer

docker 299
tool 109, 298, 774, 1030

production worksheet
preview 118
print 884, 1303
printing 884

sequins 1211
products

change backgrounds 109
templates, selecting 298

Program Split
Program Split tool 671
adjusting spacing on-screen 500
applying 492
combination splits 494
creating patterns 501
editing patterns 502
filling shapes with 493
layout patterns 498
modifying layouts on-screen 498
offsetting patterns 

on-screen 500
Program Split tool 219, 492–498
rotating patterns on-screen 499
scaling patterns on-screen 499
skewing patterns on-screen 500

properties
lettering 621
Properties dialog, Windows 

Explorer 117
vector objects 818

Property bar 63
accurate positioning 330
scaling objects 334

puck, digitizing 185
pull compensation

Pull Compensation tool 428–429
applying 428
overview 428
reversing stitch direction 432

push-pull effect, compensating 
for 256

Q
Queue Design tool 925, 958

R
Radial Fill tool 530
Raised Satin tool 204
reassigning colors, to machine 

files 914
recognition

Advanced Options dialog 908–
913

Recognize Object/Outline 
command 415

Rectangle tool 234, 816
rectangular hoops, creating 875
redraw designs slowly 103
Reef PhotoStitch dialog 853
reference lines

mirroring objects 342
rotating by specified angle 339
rotating relative to 339

reference points 230
motifs 568
origin 181
rotating using 339
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rotating using (exact angle) 339
rotation point 181
scaling objects with 335
See also control points

Reflect tool 362
reflecting objects, using 

Mirror-Merge 362
register enlargement drawings 182
Remove

Crop tool 798
Overlaps dialog 434
Overlaps tool 433, 1294
Small Stitches dialog 440
Unused Colors tool 123

Remove Holes tool 349
Rename

Colorway tool 283
Alphabet dialog 748
Letter dialog 748
Split Pattern dialog 507, 513
Thread Chart dialog 132

Repeat tool 432
repeating

motifs (Motif Run) 562
objects 432

Repeats dialog 114, 893
repeats, view design 113
resequencing

by color 325
by selection 325
objects 318
objects by Color-Object List 327
objects by number 327
Resequence By Number 

dialog 327
using cut and paste 319
using the Color-Object List 321

Reset Detail Columns tool 974
reset device 962
Reshape Object tool 370–377, 437, 

474, 503–516, 530, 536, 538, 542, 
553, 565–566, 627, 640–649, 672, 
681, 735, 741, 827, 1174–1193, 
1233, 1271, 1292

reshape objects, options 155
reshape sequin fills 1193
Reshape Tools

Keep Last Stitch 473
Reshape Object 370–377, 437, 

474, 503–516, 530, 536, 538, 
542, 553, 565–566, 627, 640–
649, 672, 681, 735, 741, 827, 
1271, 1292

Reshape tools
Reshape Object 155

Reshape Views toolbar
Show Bézier Handles 370, 374
Show Entry/Exit Points 370, 474
Show Reshape Nodes 370–374, 

516
Show Stitch Angles 370, 437

reshaping objects 369
bézier control handles 374
circles 376
lettering 649

Motif Run 553
reshape nodes 372
Ring 377
sequin runs 1174
Star 376

response time 154
Reverse Curves command 432, 549
reverse stitching

Backtrack and Repeat 432
direction 432

Revert
Revert to Factory Settings 

dialog 279
Revert to NORMAL template 279

rhinestones
digitizing 1251
placement machines 1320
production type 1254

Ring objects
changing size 377
moving boundary 377
reshaping objects 377

Ring tool 346, 585
Rotate

tool 338
Left 15° tool 338
Right 15° tool 338

rotating objects 337
by an exact amount 338
by click-and-drag 337
motifs in Motif Fills 559
on screen 337
patterns on-screen 561
Program Split patterns 

on-screen 499
using a reference line 339
using a reference line and 

angle 339
rounding corners, Column C 448
runs

Run tool 200, 201, 1131, 1136
run patterns

multi-beads 1226
multi-sequins 1171

runs
automatic connectors 463
Backtrack and Repeat 432
beads 1219, 1221
convert to bead runs 1232
creating offset objects 353
overview 460
sequins 1156
stitching 200
travel runs 472

runtime analysis
configure 170

runtime estimates 169
print 176

S
same size, objects 335
sample

motifs, Motif Fill 559

patterns, Program Split 498
satin

Satin tool 204–209, 454, 669, 
1087–1096

appliqué cover stitch 1290
applying Auto Split 454
automatic spacing 204
Satin Raised tool 669
setting stitch count 209
splitting long stitches 454

Save
Design tool 71, 762, 768
Hoop As dialog 875
Options dialog 930–931

Save As
dialog 277
Monogram Template 

command 277, 714
PDF command 119, 886
Teamname Template 

command 277, 690
Template dialog 137

Save Pattern dialog 1172
Save to Embroidery Disk 

dialog 935
saving

CSD format 931
designs 71
Melco CND format 929
object properties to a 

template 276
scale factor 812
scaling objects

by click-and-drag 333
make same size 335
on screen 333
to an exact size 334
using Object Properties 

panel 334
using reference points 335

scanning
artwork 791
color mode 787
resolution 787
setting up scanners 176
sharpening 788
tips 788

scrolling, automatic 153
Sculpture Run tool 200, 203
search criteria 991

reserved terms 993
search strings 992
segments

adjusting overlap 256
Complex Fill objects 254

Select
Select Object tool 310, 315, 

1174, 1233, 1269, 1271
Select By Color dialog 317
Select By Stitch Type dialog 318
Select Fabric Pattern dialog 295
Select Machine Format dialog 64, 

196, 1150, 1217
Select Object tool 641

select objects
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by color 317
by stitch type 318
Color-Object List 77
current object 106
grouping 312
resequencing by selection 325
while traveling 106
with Polygon Select 75
within groups 315

Select Source dialog 176
Select Thread Charts

dialog 126, 132
tool 125

Select tools
Freehand Select 75
Polygon Select 75
Polyline Select 75
Select Current 107
Select Object 75, 96, 106, 310, 

315, 641, 1269–1271
selecting stitches 395

by needle point 395
several stitches 395
single stitch 395
while traveling through a 

design 398
with the Stitch List 397

selection handles, scaling 330
Selects On/Off tool 398
Send PDF via Email command 119, 

886
Send to

CAMS Machine dialog 1321, 1323
Connection Manager 

dialog 1321, 1323
Stitch Manager tool 926

Send to Appliqué Cutter
dialog 1318
tool 1317

Send to Bling Cutter
dialog 1325
tool 1324

Send to Connection Manager
dialog 924, 1321, 1323
tool 1003, 1320

Send to Connection Manager 
tool 161

Send to EmbroideryConnect 
tool 925, 958

Sequence
automatic 323
by Color command 325
By Color dialog 325
by Number command 327
by Selects tool 325
check stitching 103
resequencing 319

Sequence toolbar
Back 1 Color 322
Back 1 Object 322
Forward 1 Color 322
Foward 1 Object 322
Move to End 322
Move to Start 322
Sequence by Selects 325

sequin designs
output 1211
visualizing 1151

sequin fills
adjust layouts 1181
angles 1182
borders 1184
convert to sequin fill 1195
creating 1178
digitizing 1179
flip sequins 1188
margins 1182
maze fills 1186
multi-sequins 1190
offset fill 1186
reshaping 1193
sequin offsets 1182
spacing 1182
special 1186
stipple 1186

Sequin Palette Editor dialog 1201
sequin palettes

Sequin Palette Editor dialog 1153
Sequin Palette tool 1153–1160
setting up 1153

Sequin Pattern dialog 1169, 1197
sequin runs

automatic 1156
creating 1156
drop-stitch direction 1164
manual 1156
scale/reshape 1174
Sequin Run Auto tool 1156, 

1168, 1171, 1196
Sequin Run Manual tool 1156
twin-sequins 1166

sequin shapes, create 1208
Sequin toolbar

Clear Function 1203, 1241
Drop Sequin 1203
Manual Sequin 1167, 1200
Sequin Edit 1175–1193
Sequin Fill 1179–1196
Sequin Palette 1153–1160
Sequin Palette Editor 1153
Sequin Run Auto 1156, 1168, 

1171, 1196
Sequin Run Manual 1156
Vectors to Sequins 1197

sequins
converting artwork 1197
create sequin shapes 1208
Design Information docker 1211
insert drops while traveling 1203
insert functions 1203
machine capabilities 1147
sequin drops, digitize 

manually 1200
Sequin Edit tool 1175–1193
Sequin Fill tool 1179–1196
sequin mode 1147
Sequin Pattern dialog 1198
sequin-capable machine, 

selecting 1150

single vs twin 1149
stacked 1167

serial devices
recommended settings 161, 168

Serial Port Setup dialog 168
Set Color dialog 129
set reference point 152
sets, modify motifs 571
settings

display 107
pointer position display 140

shapes
baselines, reshaping 649
block digitizing 248
digitizing 235
digitizing using block 

digitizing 248
Shaping Tools

Back-Front 390
Combine 388
Exclude 390
Front-Back 390
Intersect 390
Keep Original Objects 394
Weld 388

shortcut keys, view components 86
shortening

Shortening tool 451
See also stitch shortening

Show
Appliqué Fabric tool 1286
Background Image toggle 298
Bézier Handles tool 370, 374
Bitmaps tool 148, 792, 856, 1125
Drawing tool 386
Embroidery tool 1122
Entry/Exit Points tool 370, 474
Functions dialog 410
Grid tool 79, 150
Guide tool 577
Needle Points tool 396
Product tool 109, 298, 775, 1030, 

1085, 1094, 1121, 1122
Repeats tool 113, 828
Reshape Nodes tool 370–374, 

516
Rulers and Guides tool 79, 150, 

152
Stitch Angles tool 370, 437
Vectors tool 148

Show Bling
tool 1258, 1262
Work Area tool 1258, 1262, 1320

Show Embroidery tool 57
Show Functions tool 1151, 1188, 

1218
Show Home screen on startup 146
Show Hoop tool 865, 871–879
show measure tooltip 146
Show Needle Points tool 1131
Show Stitches

dialog 411
tool 1151, 1218
toolbar 1188

Show Vectors tool 821, 823, 828
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show wireframe 149
sideways bead fixing 1227
Simple Offsets

dialog 352
tool 352

simple offsets 352
single sequins 1149
skewing objects

by click-and-drag 341
by exact angle 340
patterns on-screen 561
Program Split patterns 

on-screen 500
Skew tool 340
with rotation handles 341

smart corners
cap corners 444
Cap Corners tool 443–444
Lap corners 446
Lap Corners tool 443–444
mitre corners 445
Mitre Corners tool 443–444
round corners, Column C 448
setting values 444

Smart Design
Smart Design tool 840
Instant Smart Design tool 837
Keep Graphic Objects tool 837, 

840
Smart Design dialog 841

smooth
Smooth Curves command 827
Smooth Curves dialog 827
joins, creating 246
smoothing freehand lines 576

snap to grid 152
Some Bling Remaining dialog 1324
spacing

Accordion Spacing 598
objects evenly 331
offset, Auto Spacing 205
open spacing (color 

blending) 600
open spacing (Trapunto) 596
Space Evenly Across tool 331
Space Evenly Down tool 332
using Auto Spacing 204

Special
Appliqué 1282–1292
Bitmap 802
Column C 242–244, 448
Complex Fill 255–257
Complex Turning 255–258
Lettering 622–627, 634, 637–

658, 662–665, 675–682, 702, 
731–747, 1071

Photo Flash 848
Travel Run 472
Vector 818

Spiral Contour 521
Spiral Fill tool 527
Split

Object command 402
Object tool 401
Palette Color tool 292

split windows 92
splitting

combination splits 494
lines 503
objects 401
using Auto Split 454
using split lines 503

Square tool 218, 587, 606
stabilizing, with auto underlay 419
stacked sequins 1167
Standard

Export Machine File 928
Standard contour 521
Standard security protocol 942
Standard toolbar

Copy 309
Cut 309, 319
Export Machine File 1211
Export Multi-Decoration 

Files 1307–1313
Import 823
Import Embroidery 306, 773
Import Graphic 792, 821, 856, 

1125
New 1085, 1094
New Design 70
Open 762, 768
Open Design 68, 73
Open Recent 68
Options 147–156, 247, 759–767, 

1120–1125
Paste 309, 319
Print 884
Print Preview 118, 1211
Queue Design 925, 958
Save Design 71, 762, 768
Send to Appliqué Cutter 1317
Send to Bling Cutter 1324
Send to Connection 

Manager 161, 924, 1320
Send to EmbroideryConnect 925, 

958
Show Drawing 386

Star
reshape objects 376
tool 346

Status Line, measurements 84
stemstitch

Stemstitch tool 216
settings 217

stipple
Stipple Backstitch tool 589
Stipple Fill tool 589
Stipple Stemstitch tool 589
creating textures 589

stitch angles
Remove Stitch Angles tool 436
Stitch Angles tool 436
adding 437
adding to complex fills 436
adjusting 437
Complex Fill/Complex 

Turning 255
defining for Complex Fill 250
turning stitches, Column A 245

Stitch Edit tool 395–414
Stitch Effects toolbar

3D Warp 564–566
Accordion Spacing 598
Auto Jump 456
Auto Underlay 420–426, 484, 

684
Cap Corners 443–444
Flexi Split 533
Florentine Effect 536–540
Fractional Spacing 450
Hand Stitch 579
Jagged Edge 579, 582, 671
Lap Corners 443–444
Liquid Effect 538–542
Mitre Corners 443–444
Pull Compensation 428–429
Radial Fill 530
Shortening 451
Trapunto 596
User Defined Split 503

stitch length 201
Stitch List

Stitch List tool 397–411, 1203–
1241

filtering by function 410
Stitch List docker 397–411, 471
using 409

Stitch Manager
Stitch Manage dialog 926
Send to Stitch Manager tool 926

stitch patterns, with carving 
stamps 506

Stitch Player
tool 103

stitch recognition 905
advanced options 908

stitch shortening
applying 451
overview 449

Stitch Shortening Settings 
dialog 451

Stitch toolbar
Generate Stitches 232
Process Stitches 415, 438
Selects On/Off 398
Split Object 401
Stitch Edit 395–414

stitch types
Backstitch 216
Contour 520, 520–523
Cross Stitch 609
E Stitch 218, 587
E stitch 587
Island Coil Fill 605
Maze Fill 592
Motif Fill 555, 557, 559, 563
Motif Run 223, 545–549, 1203, 

1241–1245
Offset Fill 526
outlines 199
Program Split 219, 492, 492–498, 

671
Run 200, 201, 1131
run stitching 200
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Satin 203, 204–209, 454, 669, 
1087–1096

Satin Raised 203–209
Sculpture Run 200, 203
Spiral Fill 527
Square 218, 587, 606
Stemstitch 216
Stipple 589
Stipple Backstitch 589
Stipple Stemstitch 589
Tatami 211, 212
Triple Run 200, 202
Triple Satin 209
Zigzag 218, 587

stitch values
Auto Spacing (Satin) 204
backstitch 214
guide runs (appliqué) 1286
length (Tatami) 211, 212
setting Tatami offsets 486
setting Tatami values 211
tacking (appliqué) 1289

stitches
appliqué cover 1290
appliqué tacking 1289
change display color 111
Contour stitch values 523
digitizing run stitches 235
editing 400
generating 232
keep/omit last stitch 246–248
Manual 412
multiple run counts (Triple 

Run) 202
preserving with Auto Jump 456
removing layers 433
reversing direction 432
reversing stitch direction 432
selecting 395
shortening 449
travel by 105
travel runs 472
See also editing stitches
See also selecting stitches

stitching designs
check sequence 103
Send to Connection Manager 

tool 924, 1320
Send to Stitch Manager 

dialog 926
Send to Stitch Manager tool 926
sequence, see also sequence
using Connection Manager 924
using Stitch Manager 926
See also Stitch Manager

Stop functions 190
stream mode, digitizer tablets 179
strengthening auto underlays 419
String stitch 585
styles

applying 272
applying favorites 272
assigning favorites 274
creating new style 273
make object properties 

current 264
modifying 274
overview 271

Styles toolbar
Apply Current Properties 264
Apply Style 272
favorite styles 272
Make Properties Current 264

Switch to CorelDRAW Graphics 
tool 823, 1122, 1126

switching, between fill and 
outline 230

system settings 139
automatic backup 140

T
tab groups 92
Tablet Setup dialog 183–184
tacking

digitizing appliqué 1281
setting values 1289

Tag
Tag as Appliqué tool 1279
Tag as Photo Flash tool 833, 848
Tag Fill as Turning Satin tool 614, 

833
Tajima twin-sequin-capable 

machine 1150
tatami

Tatami Fill Object tool 844
Tatami Fill Object with Holes 

tool 843
Tatami stitch type 491
Tatami tool 212, 487, 491, 670
backstitch 214
Borderline backstitch 215
density 212
diagonal backstitch 215
offset fractions 487
offsets 486
partition lines 489
random factor 491
random patterns 491
stitch length 211
stitch spacing, length and 

minimum length 211
values 211

Team Names
dialog 688
Import Team Members 690
Manage Teams 691
Matrix 708
tool 693–699, 703–708

team names 687
Create Layout Set dialog 696
Create Teamname Layout 

dialog 696
creating 687
creating separate designs 708
designs, saving 710
Name Order dialog 688
outputting designs 707
See also names

Teamname Layouts dialog 693
Teamname List dialog 708

Team Names docker
Teamname Matrix 708

Teamname List
dialog 699–708
docker 693

Teamname List tool
Apply To All 702
Create Designs 702
Object Properties 702
Remove 689, 702
Select All 689, 702
Sort Ascending 689, 702
Sort Descending 689, 702
Teamname Matrix 702

Teamname Matrix
dialog 709
tool 708

templates
creating 277
deleting 278
modifying 278
NORMAL 276
NORMAL template 70
reverting to original 279
saving object properties 276
selecting products 298

tension control for boring 196
text, editing lettering 636
textured fills

creating 533
stippling 589

third-party applications 800
thread charts

copy colors 133
create 131
manage 130
modify threads 130, 134

thread colors 198, 280
assign 125
choose 122
inserted files 142
matching 794
matching to image 794

thread usage, estimate 128
Threads

docker 126, 132
tool 125

threads
brands 135
code 135
color matching 794
density 135
thickness 205
type 135
types 205

Threads toolbar
Assign Thread 125
Match All 125
Select Thread Charts 125

tie-ins
overview 460
setting automatic tie-ins 

values 464
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tie-offs
adding 468
methods 465
overview 460
setting automatic tie-off 

values 465
setting automatic trim 

values 467
Tie Off tool 469

toolbars
Toolbars menu 60
display 60
display options 144

Toolbox
Add Borders 345
Color Blending 600
Lettering 620–630, 636, 648–

655, 662, 663, 672–679, 699, 
730–747, 771, 773, 1070–1099

Monogramming 714–724
Open Offsets tool 359
Outlines & Offsets 353
Simple Offsets 352
Team Names 703

Traditional Digitizing
Backtrack 1204
Column A 520
Column B 520
Complex Fill 536–538
Complex Turning 250–257

Traditional Digitizing toolbar
Backtrack 432
Column A 245–246, 1087–1096, 

1136
Column B 248
Column C 240–244, 448
Complex Fill 250–256, 503, 555, 

585
Complex Turning 250–257
Digitize Run 585
Manual 412, 1136
Repeat 432
Ring 346, 585
Run 1136
Star 346
Triple Manual 413
Use Motif 223, 545, 1245

Transform by Reference Line
dialog 335, 340
Freely tool 339
Numerically tool 335, 339

Transform toolbar
Mirror by Reference Line 342
Mirror Horizontal 342
Mirror Vertical 342
Rotate 338
Rotate Left 15° 338
Rotate Right 15° 338
Skew 340
Transform by Reference Line 

Freely 339
Transform by Reference Line 

Numerically 335, 339
transforming objects

letters on screen 644

mirroring (reference line) 342
rotating (reference line and 

angle) 339
scaling (reference points) 335

transparent backgrounds, 
images 798

Trapunto
tool 596
overview 596

Travel
1 Stitch tool 401
by Object tool 107
by Segment tool 401

travel runs 472
Travel toolbar

Travel 1 Stitch 401, 1203, 1241
Travel by Object 107
Travel by Segment 401

traveling
select objects 106
selecting stitches 398
with bead drops 1241
with sequin drops 1203

trim functions, set 188
trims

adding 468
overview 460
Trim tool 469

Triple Manual tool 413
Triple Run

tool 200
creating offset objects 353
tool 202

Triple Satin 209
troubleshooting 961
TrueType fonts 729, 1070

converting complete 
alphabets 732, 1076

converting to embroidery 
fonts 729, 1070

TrueType fonts, converting to 
embroidery 618

TrueType tool 1151, 1218
TrueView Options dialog 147
Turning Auto Fabric

Off dialog 266
On dialog 266

Turning Satin Object tool 843
turning stitches

applying fractional spacing 450
applying stitch shortening 451
Column C 243
Contour 520
corner fractions 243
digitizing with Column A 245

turning-off
automatic tie-ins 464
automatic tie-offs 465
automatic trims 467
fractional spacing 450
pull compensation 428

twin-sequins 1149
creating runs 1166
setting up patterns 1168

two-color alphabets 677

U
underlay

Underlay dialog 684
See also Auto Underlay

ungroup objects, Ungroup tool 313
Unlock All tool 314
unlocking objects 314
Update Kerning Settings 

command 679, 681
upright bead fixing 1227
usage, threads 128
USB stick, troubleshoot 961
Use for Florentine Effect 

command 543
Use for Liquid Effect command 543
Use Motif tool 223, 545, 1245
User Defined Split tool 503
user-define sequins 1208
user-refined alphabets 735

V
values

automatic connectors 461
travel runs 472

Vector Fill tool 816
vector graphics

automatic digitizing 815
converting artwork 825
converting to appliqué 1279
importing & exporting 821
loading 823
reshaping 827
smoothing 827
view 87

vector objects
coloring 818
convert to embroidery 833, 835
creating 816

Vector Outline tool 816, 1208
vectors

Export Design as Vectors 
command 1305

Vectors to Sequins tool 1197
View (Manage Designs) toolbar

Design Information 983
View by Color dialog 99
View Design, Options dialog 147
view designs 85

colorways 108
control points 370
display hidden objects 77
display options 96

View Graphics, Options dialog 149
View toolbar

Auto Hoop 868
Auto Start and End 771, 866, 

1125
Change View 973
Dim Artwork 148
Layout 971
Reset Detail Columns 974
Show Appliqué Fabric 1286
Show Bitmaps 148, 792, 856, 
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1125
Show Bling 1258, 1262
Show Functions 1151, 1188, 

1218
Show Grid 79, 150
Show Hoop 865, 871–879
Show Needle Points 396, 1131
Show Product 109, 298, 775, 
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